Интеграция 1С и SharePoint

Публикация № 1020078 22.03.19

Интеграция и обмен данными - WEB-интеграция

SharePoint интеграция post-запрос сериализация бухгалтерия предприятия

Заказчики поставили задачу автоматизации согласования заявок на оплату в программе 1С:Бухгалтерия предприятия 3.0. Согласно ТЗ, данные должны подтягиваться из действующей электронной системы документаоборота на MS SharePoint (в дальнейшем СЭД MS SP).

Интеграция 1С и SharePoint.

Заказчики  поставили задачу автоматизации согласования заявок на оплату в программе 1С:Бухгалтерия предприятия 3.0. Согласно ТЗ, данные должны подтягиваться из действующей электронной системы документооборота на MS SharePoint (в дальнейшем СЭД MS SP).

В результате длительных поисков информации, как это можно реализовать, оказалось, что данная связка очень скудно описана, как в мануалах 1С, так и SharePoint. Найденные же статьи по данной тематике на специализированных форумах по 1С и SharePoint – не совсем понятны для обычных программистов 1С, которые до этого никогда не сталкивались с SharePoint.

Чтобы решить поставленную задачу, потребовалась два специалиста: программист 1С и специалист по SharePoint.  И только благодаря коллективной совместной работе получилось быстро подружить двух монстров 1С и SharePoint.

В данной статье попробую описать некоторые тонкости, которые помогут связать 1С и SharePoint.

Для начала, потребуется:

  1.  Бесплатная программа Fiddler (http://www.telerik.com/fiddler)
  2.  Имя хоста, где расположен СЭД, например docflow.Host.ru
  3.  Имя и логин Basic-пользователя SharePoint- это закодированная строка состоящая из имени и логина в виде последовательности символов, которую может предоставить специалист SharePoint, он же и настраивает права на объекты, которые сможет видеть этот пользователь, например это выглядит так: ZW9zXzFjX3JlYWQ6WDlub3dndUU=
  4.  Из SharePoint нужны два параметра списка listName и viewName, которые представляют из себя набор групп символов в фигурных скобках, например listName {4026E083-7E99-4ECE-8E55-69A781DA9B3B}  и viewName {F7D3173B-E36B-4E5C-B00E-32905DDABDEB} – данный список предоставляет и настраивает его состав специалист по SharePoint
  5.  Далее при помощи программы Fiddler составляются запросы к SharePoint и переносятся в код 1С
  6.  Например на форме в 1С пользователь  вбивает регистрационный номер договора и по этому номеру он должен получить данные из СЭД SP, передаем в процедуру ПолучитьСписокДокументов(РегНомер= "/17", СписокКлючей, СтруктураСоответствий)  регистрационный номер:
&НаКлиенте
Процедура ПолучитьСписокДокументов(РегНомер = "/17",СписокКлючей,СтруктураСоответствий) Экспорт
	
	ТекстЗапроса	= ТекстЗапросаДокументов(РегНомер);
	ОТВЕТ = ПолучитьОтвет(ТекстЗапроса);
	Попытка
		Десериализовать(ОТВЕТ,СписокКлючей,СтруктураСоответствий);
	Исключение
	КонецПопытки;
	
КонецПроцедуры

Собираем запрос, заранее протестированный в Fiddler, при этом желательно не использовать переносы строк, используемые в стандартных запросах 1С в функции ТекстЗапросаДокументов(РегНомер, Папка="ВР05.06. Акты сдачи-приемки", listName="{4026E083-7E99-4ECE-8E55-69A781DA9B3B}", viewName="{F7D3173B-E36B-4E5C-B00E-32905DDABDEB}"):

&НаКлиенте
// По умолчанию listName и viewName для Актов, Договоров, Отчетов
Функция ТекстЗапросаДокументов(РегНомер,Папка="ВР05.06. Акты сдачи-приемки",listName="{4026E083-7E99-4ECE-8E55-69A781DA9B3B}",viewName="{F7D3173B-E36B-4E5C-B00E-32905DDABDEB}") Экспорт

	ТекстЗапроса = 
	"<?xml version='1.0' encoding='utf-8'?>" +
	"<soap:Envelope xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xmlns:xsd='http://www.w3.org/2001/XMLSchema' xmlns:soap='http://schemas.xmlsoap.org/soap/envelope/'>" +
		"<soap:Body>" +
			"<GetListItems xmlns='http://schemas.microsoft.com/sharepoint/soap/'>" +
			"<listName>" + listName + "</listName>" +
			"<viewName>" + viewName + "</viewName>" +
				"<query>" +
					"<Query>" +
						"<Where>" +
							"<And>" +
								"<Contains>" +
									"<FieldRef Name='RegNumber' />" +
									"<Value Type='Text'>" + РегНомер + "</Value>" +
								"</Contains>" +
								"<Eq>" +
									"<FieldRef Name='DocGroupLink' />" +
									"<Value Type='Text'>" + Папка + "</Value>" +
								"</Eq>" +
							"</And>" +
						"</Where>" +
					"</Query>" +
				"</query>" +
				"<ViewFields>" +
					"<FieldRef Name='DocCategoryId' /> " +
				"</ViewFields>" +
			"<rowLimit>50</rowLimit>" +
			"</GetListItems>" +
		"</soap:Body>" +
	"</soap:Envelope>";
	Возврат ТекстЗапроса;
	
КонецФункции

и далее обращаемся непосредственно с пост-запросом к серверу и получаем ответ:

&НаКлиенте
Функция ПолучитьОтвет(ТекстЗапроса) Экспорт
	
	ОТВЕТ 		= "";
	
	Сервер		= "https://docflow.host.ru";
	Директория	= "/Docs/Contract/_vti_bin/";
	ВебСервис	= "Lists.asmx";
	Метод		= "GetListItems";
	ЛогинПароль	= "ZW9zXzFjX3JlYWQ6WDlub3dndUU="; // ЗакодированнныеПароль&ЛогинBasicПользователя
	
	XMLHTTP	= Новый COMОбъект("Msxml2.XMLHTTP");
	XMLHTTP.Open("POST",Сервер + Директория + ВебСервис,0);
	XMLHTTP.SetRequestHeader("Host", СтрЗаменить(СтрЗаменить(Сервер,"https://",""),"http://",""));
	XMLHTTP.SetRequestHeader("Content-Type", "text/xml; charset=utf-8");
	XMLHTTP.setRequestHeader("Content-Length", СтрДлина(ТекстЗапроса));
	XMLHTTP.SetRequestHeader("SOAPAction", "http://schemas.microsoft.com/sharepoint/soap/" + Метод);
	XMLHTTP.SetRequestHeader("Authorization", "Basic " + ЛогинПароль);
	Попытка
		XMLHTTP.Send(ТекстЗапроса);
		ОТВЕТ = XMLHTTP.responseText;
	Исключение
	КонецПопытки;
	
	Возврат	ОТВЕТ;
	
КонецФункции

Ответ приходит в формате xml и требует десериализации

&НаКлиенте
Процедура Десериализовать(XMLСтруктураСериализованногоОбъекта,СписокКлючей,СтруктураСоответствий) 
	
	ЧтениеXML	= Новый ЧтениеXML;
	ЧтениеXML.УстановитьСтроку(XMLСтруктураСериализованногоОбъекта);
	ЧтениеXML.ПерейтиКСодержимому();
	
	ТипXML = ФабрикаXDTO.Тип("nsv_СЭД", "row");
	Попытка
		ОбъектXML = ФабрикаXDTO.ПрочитатьXML(ЧтениеXML, ТипXML);
		Если ОбъектXML.Body.GetListItemsResponse.GetListItemsResult.listitems.data.ItemCount = "0" Тогда
		ИначеЕсли ОбъектXML.Body.GetListItemsResponse.GetListItemsResult.listitems.data.ItemCount = "1" Тогда
			
			Стр = ОбъектXML.Body.GetListItemsResponse.GetListItemsResult.listitems.data.row;
			
			Ключ = СокрЛП(Стр.ows_ID);
			
			Реквизиты = Новый Структура;
			
			ЗаполнитьРеквизитыТекст(Стр,Реквизиты,"ows_RegNumber");
			ЗаполнитьРеквизитыТекст(Стр,Реквизиты,"ows_Title");
			
			ЗаполнитьРеквизитыЧисло(Стр,Реквизиты,"ows_Sum");
			ЗаполнитьРеквизитыЧисло(Стр,Реквизиты,"ows_NDS");
			
			ЗаполнитьРеквизитыДата(Стр,Реквизиты,"ows_RegDate");
			
			СписокКлючей.Добавить(Ключ);
			СтруктураСоответствий.Вставить(Ключ,Реквизиты);
			
		ИначеЕсли ОбъектXML.Body.GetListItemsResponse.GetListItemsResult.listitems.data.ItemCount <> "0" Тогда
			
			Для Каждого Стр Из ОбъектXML.Body.GetListItemsResponse.GetListItemsResult.listitems.data.row Цикл
				
				Ключ = СокрЛП(Стр.ows_ID);
				
				Реквизиты = Новый Структура;
				
				ЗаполнитьРеквизитыТекст(Стр,Реквизиты,"ows_RegNumber");
				ЗаполнитьРеквизитыТекст(Стр,Реквизиты,"ows_Title");
				
				ЗаполнитьРеквизитыЧисло(Стр,Реквизиты,"ows_Sum");
				ЗаполнитьРеквизитыЧисло(Стр,Реквизиты,"ows_NDS");
				
				ЗаполнитьРеквизитыДата(Стр,Реквизиты,"ows_RegDate");
				
				СписокКлючей.Добавить(Ключ);
				СтруктураСоответствий.Вставить(Ключ,Реквизиты);
				
			КонецЦикла;
			
		КонецЕсли;
	Исключение
	КонецПопытки;
	
	ЧтениеXML.Закрыть(); 
	
КонецПроцедуры

и немного поработать с реквизитами:

&НаКлиенте
Процедура ЗаполнитьРеквизитыЧисло(Стр,Реквизиты,Свойство)
	
	Если Стр.Свойства().Получить(Свойство) = Неопределено Тогда 
		Реквизиты.Вставить(Свойство,0);
	Иначе 
		Реквизиты.Вставить(Свойство,Число(СокрЛП(СтрЗаменить(Стр[Свойство]," ",""))));
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура ЗаполнитьРеквизитыТекст(Стр,Реквизиты,Свойство)
	
	Если Стр.Свойства().Получить(Свойство) = Неопределено Тогда 
		Реквизиты.Вставить(Свойство,"");
	Иначе
		Значение = Формат(Стр[Свойство],"ЧГ=0");
		Реквизиты.Вставить(Свойство,ВРег(СокрЛП(СтрЗаменить(СтрЗаменить(СтрЗаменить(Значение,"»",""),"«",""),"  "," "))));
	КонецЕсли;
	
КонецПроцедуры

&НаКлиенте
Процедура ЗаполнитьРеквизитыДата(Стр,Реквизиты,Свойство)
	
	Если Стр.Свойства().Получить(Свойство) = Неопределено Тогда 
		Реквизиты.Вставить(Свойство,Дата(1,1,1));
	Иначе 
		Реквизиты.Вставить(Свойство,Дата(СтрЗаменить(СтрЗаменить(СтрЗаменить(Стр[Свойство],"-",""),":","")," ","")));
	КонецЕсли;
	
КонецПроцедуры

Далее полученные и разложенные по полочкам данные возвращаются через переменные СписокКлючей и СтруктураСоответствий в удобном для обработки виде.

Скачать файлы

Наименование Файл Версия Размер
Интеграция 1С и SharePoint:

.docx 236,35Kb
5
.docx 236,35Kb 5 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. VasilVtoroy 23.03.19 00:29 Сейчас в теме
Ужас какой. Зачем Msxml2.XMLHTTP -то, когда есть встроенное HTTPСоединение?
user665687_korostelevin; HystriX; +2 Ответить
4. -I- 25.03.19 20:21 Сейчас в теме
(1) у вас есть шанс написать свою статья через HTTPСоединение
2. A_Max 19 25.03.19 12:10 Сейчас в теме
ТекстЗапросаДокументов - Зачем эта куча плюсов?!?!?! Или в ресурс вынести, или одной многострочной "строкой" и затем стрШаблон (стрЗаменить для стареньких версий). А ещё лучше сделать универсальную функцию построения запроса.

Если ОбъектXML.Body.GetListItemsResponse.GetListItemsResult.listitems.data.ItemCount = "0" Тогда
ИначеЕсли ОбъектXML.Body.GetListItemsResponse.GetListItemsResult.listitems.data.ItemCount = "1" Тогда
/*/*/*/*/
ИначеЕсли ОбъектXML.Body.GetListItemsResponse.GetListItemsResult.listitems.data.ItemCount <> "0" Тогда
/*/*/*/*/
КонецЕсли

Зачем последнее условие?

Значение = Формат(Стр[Свойство],"ЧГ=0");

Формат для строки не работает.

Ну и в итоге я бы всё это реализовал на XSLT преобразовании в уже готовые структуры 1С.
3. -I- 25.03.19 20:18 Сейчас в теме
(2) Сделайте, кто вам мешает
5. olo_lo4 18.02.21 17:03 Сейчас в теме
подскажите а какой метод нужен для загрузки файла в директорию, где это можно найти и посмотреть ?

XMLHTTP.SetRequestHeader("SOAPAction", "http://schemas.microsoft.com/sharepoint/soap/" + Метод);
bluntschi; +1 Ответить
Оставьте свое сообщение

См. также

Передача больших пакетов через веб-сервисы Промо

WEB-интеграция Платформа 1С v8.3 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

06.12.2015    73443    Infostart    19    

Интеграция (Ich will version)

Идеи и тренды в разработке WEB-интеграция Платформа 1С v8.3 Абонемент ($m)

Поговорим про интеграцию с точки зрения архитектора.

1 стартмани

16.09.2022    3035    botokash    66    

Модуль переводов и платежей QIWI

Розничная торговля WEB-интеграция Платформа 1С v8.3 1С:Управление торговлей 11 Россия Абонемент ($m)

Инструкция по установке и работе "Модуля переводов и платежей QIWI" для УТ11.4. Публикация создана с целью размещения актуальной онлайн инструкции по работе пользователей с функционалом оформления платежей или переводов КИВИ через РМК в УТ11.4, а также для описания установки модуля в УТ 11.4 и размещения необходимых библиотек dll.

03.06.2022    521    Rastopchinss    5    

Тестирование API 1C Postman

WEB-интеграция Платформа 1С v8.3 Абонемент ($m)

Тестирование вашего API, который вы сделали на 1С.

1 стартмани

18.08.2021    6062    kolya_tlt    7    

Демо связи веб сервисов 1С и php Промо

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Демонстрация обращения к веб сервису 1С из php. Пример простейший, уровня hello world. Дана одна страница и информационная база 1С с одним справочником и одним веб сервисом. Веб сервис выдаёт содержимое справочника по запросу странички.

1 стартмани

19.07.2013    33247    Трактор    20    

Создаем интернет-магазин на бесплатной CMS PrestaShop с открытым кодом за 60 минут

Розничная торговля WEB-интеграция Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Управленческий учет Абонемент ($m)

Описано пошаговое создание полноценного действующего интернет-магазина. Бесплатно. Без программирования. Без навыков администрирования. Для "чайников".

1 стартмани

31.05.2021    2505    andryandry    0    

Перенос всех логов в Elasticsearch

WEB-интеграция Платформа 1С v8.3 Абонемент ($m)

В качестве стандартного места хранения логов в "1С:Предприятие" используется Журнал регистрации. Также часто для хранения служебных событий создают специальные Регистры сведений. Но у этих решений есть свои недостатки. В статье описан подход для хранения любых логов в самой популярной свободной поисковой системе Elasticsearch.

1 стартмани

15.07.2020    6631    kuleshov.x    5    

1С+Firebase. Оперативное отображение информации

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Появилась задача по отображению информации из базы в "режиме реального времени" с возможностью масштабирования количества подключенных клиентов (неплохо бы уметь подключаться с мобильных устройств), плавающей нагрузкой и минимальными затратами на разработку без изобретения сложных велосипедов. В уме довольно быстро всплыло "Firebase". Далее небольшой опыт реализации взаимодействия с Firestore для раскрашивания объектов карты.

1 стартмани

06.04.2020    4088    oyti    2    

Примеры пользования web сервисов 1С из браузера Промо

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Даны примеры реализации доступа к web сервисам 1С из браузера. Примеры web сервисов, а также javascript'ы для доступа к этим сервисам. AJAX доступ к 1С.

1 стартмани

29.06.2008    159120    Трактор    233    

Синтез речи из текста с помощью Яндекс SpeechKit

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В статье описан процесс подключения Яндекс SpeechKit API и программная реализация синтеза речи из текста с помощью этого API. Тестировалось на релизе платформы 8.3.16.1224. Может использоваться в любой конфигурации. Синтез речи может использоваться для самых разных целей, в моём случае потребовалось перевести лекции из текстовых файлов в звук

1 стартмани

05.04.2020    13643    m0zg153    2    

На хайпе: интегрируем 1С с сервисом видеоконференций Zoom

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

По причине коронавируса всем резко понадобились видеоконференции, а Зум (zoom.us) - одна из самых популярных платформ для этого. Когда пользователей и трансляций в зуме много, возникает необходимость в автоматизации. Рассматривается интеграция 1С с Zoom через API - от регистрации в сервисе до создания конференции из 1С.

1 стартмани

04.04.2020    18297    muzipov    5    

Вариант реализации REST API для 1С-Битрикс Управление сайтом

WEB-интеграция Платформа 1С v8.3 Россия Абонемент ($m)

В статье опишу вариант обмена 1С УТ 11.4 и 1С-Битрикс управление сайтом с иcпользованием компонентов Symfony, в качестве примера обмен данными по товарам.

1 стартмани

28.01.2020    12226    malikov_pro    3    

Разбираемся с web-kit в 1С, на примере интеграции TinyMCE в управляемую форму в УТ 11.4. Допиливаем обмен с сайтом в УТ 11.4

WEB-интеграция Платформа 1С v8.3 Управляемые формы 1С:Управление торговлей 11 Абонемент ($m)

Многие уже знают, что в релизе платформы 8.3.14.1565, браузер Internet Explorer был заменен на Web-Kit, это на самом деле большой шаг вперед, но я уверен, многим, как и мне, пока не совсем понятно, что к чему. Возник опыт использования web-kit в 1С, вызова JS из 1С и вызова 1С из JS. Давайте вместе попробуем понять, чем одно отличается от другого, и заодно сделаем, что-нибудь полезное. Да и наверняка многим придется переписывать свои подобные поделки после обновления на новую платформу, так что надеюсь мой опыт окажется полезным.

2 стартмани

08.12.2019    10735    Бэнни    25    

"Живые" картинки со Snap.SVG

WEB-интеграция Работа с интерфейсом Платформа 1С v8.3 Абонемент ($m)

В статье рассмотрен пример использования http-сервисов для визуализации данных

1 стартмани

24.10.2019    16159    blackhole321    7    

Интеграция 1С с сайтом (магазином) WordPress (WooCommerce) с помощью Rest API сайта. Часть 1. Авторизация

WEB-интеграция Платформа 1С v8.3 Абонемент ($m)

Интеграция 1С с сайтом (магазином) WordPress (WooCommerce) с помощью функционала Rest API предоставляемого платформой (CMS) WordPress (WooCommerce). Без дополнительных приложений на PHP/вставьте сюда любой другой язык программирования/.

1 стартмани

12.10.2019    55606    osivv    39    

АИТП. Автоматизируем управление ресурсами на примере Яндекс.Почта для домена

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В статье демонстрируется использование программного пакета АИТП для автоматизации предоставления ИТ-ресурсов сотрудникам на примере управления почтовыми ящиками Яндекс.Почта для домена.

1 стартмани

26.08.2019    7002    blackhole321    4    

Использование HTTP-сервиса для создания "фронтенда" HTML/CSS/jQuery с кэшированием

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В статье описан способ создания "фронтенда" на HTML/CSS/jQuery и скрипт кеширования AJAX запросов на PHP.

1 стартмани

06.08.2019    16256    Sedaiko    28    

Обмен с интернет-магазином на платформе DOCPART

WEB-интеграция Оптовая торговля Розничная торговля Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В настоящее время существует множество платформ для создания интернет-магазинов. Удобные и не очень, платные или бесплатные. У каждого решения найдутся свои сторонники, но наличие оперативного обмена с учётной системой важно для любой платформы. В этой публикации мы рассмотрим одну из популярных платформ для создания интернет-магазина по продаже автозапчастей Docpart и организацию обмена данными с ней.

10 стартмани

04.07.2019    7359    Johny_v    25    

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере"

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    27193    dmitry1975    37    

Подключение к REST API через OAuth протокол из 1С

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В статье описаны варианты подключения И решение граблей по подключению к REST API через протокол OAuth 2.0 из 1С. При разработке такого подключения для получения данных и загрузки в базу 1С я столкнулся с некоторыми проблемами, решил их и хочу поделиться этими наработками.

1 стартмани

06.09.2018    20723    chemezov    14    

HTTP Сервисы: Путь к своему сервису. Часть 1

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    175228    dsdred    45    

А чё это вы здесь делаете, а?

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Разработчикам тиражных обработок близка и понятна проблема обратной связи с пользователем. Много важного и полезного можно почерпнуть, зная, что делает бухгалтер, который запустил обработку. В большом мире вэба сбор статистики на сайте дело привычное и даже обязательное. Эта статья покажет практику применения инструментов сбора статистики из мира веба для обработок на платформе 1С:Предприятие.

1 стартмани

21.01.2018    25667    infosoft-v    42    

Пример заполнения/создания файла XML из XSD схемы, используя XDTO

WEB-интеграция Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Добрый день, коллеги! Наконец-то дошли руки написать сию статью. Хочу поделиться своим опытом по разбору xsd схемы используя Фабрику XDTO, а также связанным с этим XML файлом. Думаю, наверняка кому-то понадобится.

1 стартмани

21.12.2017    66229    sandybaev    28    

Простой бесплатный DashBoard с помощью http сервиса

WEB-интеграция Платформа 1С v8.3 Абонемент ($m)

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    59555    dewersia    32    

Получение данных из Wialon Hosting через HTTP запросы (Remote API)

WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Автомобили, автосервисы Россия Абонемент ($m)

Статья будет полезна для быстрого старта работы с Wialon Hosting. Здесь я опишу основные принципы работы с системой Wialon через Remote API.

1 стартмани

12.09.2017    32255    maxopik2    28    

Google OAuth и мобильное приложение

Мобильная разработка Внешние источники данных WEB-интеграция Платформа 1С v8.3 Мобильная платформа Конфигурации 1cv8 Абонемент ($m)

Об аутентификации для работы с сервисами google из мобильного или настольного приложения

1 стартмани

29.08.2017    12341    stveans@gmail.com    3    

Заполнение ОГРН с использованием Инструментов разработчика

Обработка справочников WEB-интеграция Платформа 1С v8.3 Россия Абонемент ($m)

Вот и до нашей организации добралось требование указывать в отчетности для ГлавКонтроля ОГРН контрагента. Как всегда, задача возникла внезапно, и решить ее нужно было "вчера".

1 стартмани

14.04.2017    6938    vsuh    0    

Передача большого количества объектов через Web-сервисы

WEB-интеграция Платформа 1С v8.3 1С:Управление торговлей 11 Абонемент ($m)

Один из вариантов передачи большого количества объектов при использовании Web-сервисов.

1 стартмани

31.01.2017    16929    SinglCOOLer    14    

Использование SoapUi для работы с веб-сервисами. Часть1

WEB-интеграция Платформа 1С v8.3 Абонемент ($m)

Как работать с SoapUi для тестирования веб-сервисов .

1 стартмани

30.09.2016    143797    kiv1c    32