Сохранение запроса со всеми параметрами и временными таблицами

Публикация № 1054984

Разработка - Универсальные функции

Запрос сохранение параметры временные таблицы консоль запросов

Функция сохранения запроса со всеми параметрами и временными таблицами в формате *.q1c для открытия в консоли запросов с диска ИТС.

Предисловие

Наверное у каждого программиста 1С есть консоль запросов для управляемого приложения с диска ИТС. Она позволяет сохранять и открывать файлы в формате *.q1c, который представляет собой обычный xml. Я написал функцию, которая позволяет во время отладки сохранить запрос со всеми параметрами в формате *.q1c, чтобы можно было затем открыть его в режиме Предприятие с уже установленными параметрами и временными таблицами. 

Код основной функции и вспомогательных функций и процедур

Функция СохранитьЗапрос(Запрос, ИмяКаталогаИлиПолноеИмяФайла) Экспорт
	
	Попытка
		ИмяКаталогаСоСлэшем = ИмяКаталогаИлиПолноеИмяФайла + ?(Прав(ИмяКаталогаИлиПолноеИмяФайла,1)="\", "", "\");
		ИмяЗапроса = "Запрос_"+Формат(ТекущаяДата(), "ДФ=гггг-ММ-дд_ЧЧ-мм-сс");
		ПолноеИмяФайла  = ИмяКаталогаСоСлэшем + ИмяЗапроса + ".q1c";

		МассивСоздаваемыхВТекстеЗапросаВТ = МассивСоздаваемыхВременныхТаблицЗапроса(Запрос.Текст);
		
		//Добавим в начало текста запроса выборку во временные таблицы
		ТекстВыборкиВоВременныеТаблицы = "";
		МассивДанныхПоВременнымТаблицам = Новый Массив;
		Если Запрос.МенеджерВременныхТаблиц <> Неопределено Тогда
			Для Каждого ВременнаяТаблица Из Запрос.МенеджерВременныхТаблиц.Таблицы Цикл
				//Исключим временные таблицы, которые создаются в тексте этого запроса
				Если МассивСоздаваемыхВТекстеЗапросаВТ.Найти(ВременнаяТаблица.ПолноеИмя) <> Неопределено Тогда
					Продолжить;
				КонецЕсли;
				
				ТекРезультатЗапроса = ВременнаяТаблица.ПолучитьДанные();
				ТаблицаПустая = ТекРезультатЗапроса.Пустой();
				//Если временная таблица пустая, то в текст выборки добавим создание этой таблицы, но в МассивРезультатовВТ записывать не будем
				ТекстВыборкиВоВременныеТаблицы = ТекстВыборкиВоВременныеТаблицы + ПолучитьТекстВыборкиКолонокТаблицыЗначенийВЗапросе(ВременнаяТаблица.ПолноеИмя, ТекРезультатЗапроса.Колонки, ТаблицаПустая);
				Если НЕ ТаблицаПустая Тогда
					МассивДанныхПоВременнымТаблицам.Добавить(Новый Структура("ИмяВременнойТаблица,РезультатЗапроса", ВременнаяТаблица.ПолноеИмя, ТекРезультатЗапроса));
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
		
		ЗаписьXML = Новый ЗаписьXML;
		ЗаписьXML.ОткрытьФайл(ПолноеИмяФайла, "utf-8");
		ЗаписьXML.ЗаписатьОбъявлениеXML();

		ЗаписьXML.ЗаписатьНачалоЭлемента("querylist");

			ЗаписьXML.ЗаписатьНачалоЭлемента("query");
			ЗаписьXML.ЗаписатьАтрибут("name", ИмяЗапроса);

				ЗаписьXML.ЗаписатьНачалоЭлемента("text");
				ЗаписьXML.ЗаписатьТекст(ТекстВыборкиВоВременныеТаблицы + Запрос.Текст);
				ЗаписьXML.ЗаписатьКонецЭлемента(); //text

				ЗаписьXML.ЗаписатьНачалоЭлемента("parameters");

					Для Каждого КЗ Из Запрос.Параметры Цикл
						ЗаписьXML.ЗаписатьНачалоЭлемента("parameter");
						ЗаписьXML.ЗаписатьАтрибут("name", КЗ.Ключ);

						ЗначениеПараметра = КЗ.Значение;
						ТипЗнчПараметра = ТипЗнч(ЗначениеПараметра);

						Если ТипЗнчПараметра  = Тип("Граница") Тогда
							ЗаписьXML.ЗаписатьАтрибут("type", "Граница");
							ЗаписьXML.ЗаписатьНачалоЭлемента("divide");
								ЗаписьXML.ЗаписатьАтрибут("type", "Дата");
								ЗаписьXML.ЗаписатьАтрибут("valueDiv", Строка(ЗначениеПараметра.ВидГраницы));
								ЗаписьXML.ЗаписатьАтрибут("value", XMLСтрока(ЗначениеПараметра.Значение));
							ЗаписьXML.ЗаписатьКонецЭлемента(); //divide

						ИначеЕсли ТипЗнчПараметра = Тип("МоментВремени") Тогда
							ЗаписьXML.ЗаписатьАтрибут("type", "МоментВремени");
							ЗаписьXML.ЗаписатьНачалоЭлемента("item");
								ЗаписьXML.ЗаписатьАтрибут("type", XMLТипЗнч(ЗначениеПараметра.Ссылка).ИмяТипа);
								ЗаписьXML.ЗаписатьАтрибут("valueRef", XMLСтрока(ЗначениеПараметра.Ссылка));
								ЗаписьXML.ЗаписатьАтрибут("valueDate", XMLСтрока(ЗначениеПараметра.Дата));
							ЗаписьXML.ЗаписатьКонецЭлемента(); //item

						ИначеЕсли ТипЗнчПараметра = Тип("СписокЗначений") Тогда
							ЗаписьXML.ЗаписатьАтрибут("type", "СписокЗначений");
							ЗаписатьЗначенияМассиваДляЭлементаПараметр(ЗаписьXML, ЗначениеПараметра.ВыгрузитьЗначения());
							
						ИначеЕсли ТипЗнчПараметра = Тип("Массив") Тогда
							ЗаписьXML.ЗаписатьАтрибут("type", "СписокЗначений");
							ЗаписатьЗначенияМассиваДляЭлементаПараметр(ЗаписьXML, ЗначениеПараметра);

						ИначеЕсли ТипЗнчПараметра = Тип("ТаблицаЗначений") Тогда
							ЗаписьXML.ЗаписатьАтрибут("type", "ТаблицаЗначений");
							ЗаписатьТаблицуЗначенийВПараметрЗапроса(ЗаписьXML, ЗначениеПараметра, Ложь);

						Иначе
							ЗаписьXML.ЗаписатьАтрибут("type", ПолучитьИмяТипаЗначенияXML(ЗначениеПараметра));
							ЗаписьXML.ЗаписатьАтрибут("value", XMLСтрока(ЗначениеПараметра));

						КонецЕсли;

						ЗаписьXML.ЗаписатьКонецЭлемента(); //parameter
					КонецЦикла;

					//Все не пустые временные таблицы, создание которых мы добавили ранее к тексту запроса, запишем в параметры запроса как таблицы значений
					Если Запрос.МенеджерВременныхТаблиц <> Неопределено Тогда
						Для Каждого ТекСтрока Из МассивДанныхПоВременнымТаблицам Цикл
							тзВременнаяТаблица = ТекСтрока.РезультатЗапроса.Выгрузить();
							ЗаписатьТаблицуЗначенийВПараметрЗапроса(ЗаписьXML, тзВременнаяТаблица, Истина, ТекСтрока.ИмяВременнойТаблица);
						КонецЦикла;
					КонецЕсли;					
						
				ЗаписьXML.ЗаписатьКонецЭлемента(); //parameters

			ЗаписьXML.ЗаписатьКонецЭлемента(); //query
		
		ЗаписьXML.ЗаписатьКонецЭлемента(); //querylist
		
		ЗаписьXML.Закрыть();
		
		Возврат "Запрос с параметрами успешно сохранен в файл " + ПолноеИмяФайла;
		
	Исключение
		Возврат "Не удалось записать запрос с параметрами в файл по причине: " + ОписаниеОшибки();
		
	КонецПопытки;

КонецФункции

Функция ПолучитьИмяТипаЗначенияXML(ЗначениеПараметра)
	
	ТипЗнчПараметра = ТипЗнч(ЗначениеПараметра);
	
	Если ТипЗнчПараметра = Тип("Строка") ИЛИ ТипЗнчПараметра = Тип("Неопределено") Тогда
		Возврат "Строка";
	
	ИначеЕсли ТипЗнчПараметра = Тип("Число") Тогда
		Возврат "Число";
	
	ИначеЕсли ТипЗнчПараметра = Тип("Дата") Тогда
		Возврат "Дата";
	
	ИначеЕсли ТипЗнчПараметра = Тип("Булево") Тогда
		Возврат "Булево";
	
	Иначе
		Возврат XMLТипЗнч(ЗначениеПараметра).ИмяТипа;
	
	КонецЕсли;

КонецФункции

Процедура ЗаписатьЗначенияМассиваДляЭлементаПараметр(ЗаписьXML, Массив)

	Для Каждого ТекущееЗначение Из Массив Цикл
		ЗаписьXML.ЗаписатьНачалоЭлемента("item");

			ЗаписьXML.ЗаписатьАтрибут("type", ПолучитьИмяТипаЗначенияXML(ТекущееЗначение));
			ЗаписьXML.ЗаписатьАтрибут("value", XMLСтрока(ТекущееЗначение));

		ЗаписьXML.ЗаписатьКонецЭлемента(); //item
	КонецЦикла;

КонецПроцедуры

Процедура ЗаписатьТаблицуЗначенийВПараметрЗапроса(ЗаписьXML, Таблица, ПараметрЦеликом, ИмяПараметра="")

	Если ПараметрЦеликом Тогда
		ЗаписьXML.ЗаписатьНачалоЭлемента("parameter");
		ЗаписьXML.ЗаписатьАтрибут("name", ИмяПараметра);
		ЗаписьXML.ЗаписатьАтрибут("type", "ТаблицаЗначений");
	КонецЕсли;
	
	ЗаписьXML.ЗаписатьАтрибут("colcount", Формат(Таблица.Колонки.Количество(), "ЧН=0; ЧГ=0"));
	ЗаписьXML.ЗаписатьАтрибут("rowcount", Формат(Таблица.Количество(), "ЧН=0; ЧГ=0"));
	
	ТекИндексСтроки = 0;
	Для Каждого ТекСтрокаТЗ Из Таблица Цикл
		ТекИндексКолонки = 0;
		Для Каждого ТекКолонкаТЗ Из Таблица.Колонки Цикл
			ЗаписьXML.ЗаписатьНачалоЭлемента("item");
			
			ТекущееЗначение = ТекСтрокаТЗ[ТекКолонкаТЗ.Имя];
			
			ЗаписьXML.ЗаписатьАтрибут("nameCol", ТекКолонкаТЗ.Имя);
			ЗаписьXML.ЗаписатьАтрибут("row", Формат(ТекИндексСтроки, "ЧН=0; ЧГ=0"));
			ЗаписьXML.ЗаписатьАтрибут("col", Формат(ТекИндексКолонки, "ЧН=0; ЧГ=0"));
			ЗаписьXML.ЗаписатьАтрибут("type", ПолучитьИмяТипаЗначенияXML(ТекущееЗначение));
			ЗаписьXML.ЗаписатьАтрибут("length", "0");
			ЗаписьXML.ЗаписатьАтрибут("value", XMLСтрока(ТекущееЗначение));
			
			ЗаписьXML.ЗаписатьКонецЭлемента(); //item
			
			ТекИндексКолонки = ТекИндексКолонки + 1;
		КонецЦикла;

		ТекИндексСтроки = ТекИндексСтроки + 1;
	КонецЦикла;
	
	Если ПараметрЦеликом Тогда
		ЗаписьXML.ЗаписатьКонецЭлемента(); //parameter
	КонецЕсли;
КонецПроцедуры

Функция МассивСоздаваемыхВременныхТаблицЗапроса(ТекстЗапроса)

	Перем МассивВТ;
	
	МассивВТ = Новый Массив;
	
	//Запрос может не открываться объектом СхемаЗапроса, но при этом выполняться,
	//в этой ситуации лучше вернуть пустой массив, чем завершить работу с ошибкой
	Попытка
		СхемаЗапроса = Новый СхемаЗапроса();
		СхемаЗапроса.УстановитьТекстЗапроса(ТекстЗапроса);
		Для Каждого Пакет Из СхемаЗапроса.ПакетЗапросов Цикл
			Если ТипЗнч(Пакет) = Тип("ЗапросВыбораСхемыЗапроса") Тогда
				Если ЗначениеЗаполнено(Пакет.ТаблицаДляПомещения) Тогда
					МассивВТ.Добавить(Пакет.ТаблицаДляПомещения);
				КонецЕсли;
			КонецЕсли;
		КонецЦикла;
	Исключение
	КонецПопытки;
	
	Возврат МассивВТ;

КонецФункции

Функция ПолучитьТекстВыборкиКолонокТаблицыЗначенийВЗапросе(ИмяПараметра, Колонки, ПустаяТаблица)

	Перем Текст;
	
	ПоляТаблицы = "";
	Для Каждого ТекКолонка Из Колонки Цикл
		Если ПоляТаблицы <> "" Тогда
			ПоляТаблицы = ПоляТаблицы + "
			|	";
		Иначе
			ПоляТаблицы = ПоляТаблицы + "	";
		КонецЕсли;
		
		СтруктураТипа = СтруктураТипаКолонкиДляЗапроса(ТекКолонка.ТипЗначения.Типы());
		
		Если ПустаяТаблица Тогда
			ПоляТаблицы = ПоляТаблицы + СтруктураТипа.ЗначениеПоУмолчанию + " КАК "+ТекКолонка.Имя + ",";
			
		Иначе
			Если СтруктураТипа.ИмяДляПриведенияТипов <> "" Тогда
				ПоляТаблицы = ПоляТаблицы + "ВЫРАЗИТЬ(Т."+ТекКолонка.Имя + " КАК "+СтруктураТипа.ИмяДляПриведенияТипов+") КАК "+ТекКолонка.Имя + ",";
			Иначе
				ПоляТаблицы = ПоляТаблицы + "Т."+ТекКолонка.Имя + " КАК "+ТекКолонка.Имя + ",";
			КонецЕсли;
			
		КонецЕсли;
	КонецЦикла;
	//Уберем последнюю запятую
	ПоляТаблицы = Лев(ПоляТаблицы, СтрДлина(ПоляТаблицы)-1);
	
	Текст = 
	"ВЫБРАТЬ
	|"+ПоляТаблицы+"
	|ПОМЕСТИТЬ "+ИмяПараметра;
	
	Если НЕ ПустаяТаблица Тогда
		Текст = Текст + "
		|ИЗ
		|	&"+ИмяПараметра+" КАК Т"
		;
	КонецЕсли;
	
	Текст = Текст + "
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|";
	
	Возврат Текст;

КонецФункции

Функция СтруктураТипаКолонкиДляЗапроса(МассивТиповКолонки)
	
	Перем Результат;
	
	Результат = Новый Структура;
	Результат.Вставить("ЗначениеПоУмолчанию", "НЕОПРЕДЕЛЕНО");
	Результат.Вставить("ИмяДляПриведенияТипов", "");
	
	//Если колонка имеет единственный тип, либо 2 типа, один из которых Null, то в запросе выборки во временную таблицу будем приводить к этому типу, 
	//чтобы избежать ошибок открытия конструктора запросов, если дальше где-то идет выбор "через точку"
	ЕдинственныйТип = Неопределено;
	Если МассивТиповКолонки.Количество() = 1 Тогда
		ЕдинственныйТип = МассивТиповКолонки[0];
	
	ИначеЕсли МассивТиповКолонки.Количество() = 2 Тогда
		Если МассивТиповКолонки[0] = Тип("Null") Тогда
			ЕдинственныйТип = МассивТиповКолонки[1];
		
		ИначеЕсли МассивТиповКолонки[1] = Тип("Null") Тогда
			ЕдинственныйТип = МассивТиповКолонки[0];
		
		КонецЕсли;
	КонецЕсли;
	
	Если ЕдинственныйТип <> Неопределено Тогда
		
		Если ЕдинственныйТип = Тип("Число") Тогда
			Результат.ЗначениеПоУмолчанию = "0";
			
		ИначеЕсли ЕдинственныйТип = Тип("Строка") Тогда
			Результат.ЗначениеПоУмолчанию = """""";
			
		ИначеЕсли ЕдинственныйТип = Тип("Дата") Тогда
			Результат.ЗначениеПоУмолчанию = "ДАТАВРЕМЯ(1,1,1)";
			
		ИначеЕсли ЕдинственныйТип = Тип("Булево") Тогда
			Результат.ЗначениеПоУмолчанию = "ЛОЖЬ";
			
		ИначеЕсли ЕдинственныйТип = Тип("ВидДвиженияНакопления") Тогда
			Результат.ЗначениеПоУмолчанию = "ЗНАЧЕНИЕ(ВидДвиженияНакопления.Приход)";
			
		Иначе
			ИмяТипаXML = XMLТип(ЕдинственныйТип);
			Если СтрНайти(ИмяТипаXML, "Ref.") > 0 Тогда
				ПустаяСсылка = Новый(ЕдинственныйТип);
				ПолноеИмяМетаданного = ПустаяСсылка.Метаданные().ПолноеИмя();
				Если ЗначениеЗаполнено(ПолноеИмяМетаданного) Тогда
					Результат.ЗначениеПоУмолчанию = "ЗНАЧЕНИЕ("+ПолноеИмяМетаданного+".ПустаяСсылка)";
					Результат.ИмяДляПриведенияТипов = ПолноеИмяМетаданного;
				КонецЕсли;
			КонецЕсли;
		
		КонецЕсли;
	КонецЕсли;
	
	Возврат Результат;
	
КонецФункции

Как это использовать?

Просто скопируйте эти функции и процедуры в общий модуль с флажком "Серверный" (или в общий модуль расширения, если основная конфигурация на полной поддержке). Пусть общий модуль называется, например "Отладка". Затем запускаем отладку интересующего запроса, останавливаем отладку на строке с Запрос.Выполнить(), нажимаем Shift+F9 и печатаем Отладка.СохранитьЗапрос(Запрос, "\\Host\Share"). Здесь Отладка - это имя общего модуля, Запрос - имя переменной типа "Запрос", \\Host\Share - имя сетевого каталога, куда будет сохранен запрос (этот каталог должен быть доступен для записи пользователем, под которым запущен сервер 1С Предприятие).

Запрос со всеми параметрами будет сохранен в файл \\Host\Share\Запрос_{ТекущаяДатаИВремя}.q1c. При открытии файла *.q1c в консоли запросов запрос и все параметры будут восстановлены. 

Временные таблицы

Если у менеджера временных таблиц запроса есть временные таблицы, они будут сохранены как параметры типа ТаблицаЗначений с именем временной таблицы. Также к началу текста запроса при сохранении будет добавлен текст для создания временных таблиц из параметров типа ТаблицаЗначений. Таким образом открыв сохраненный запрос мы можем сразу выполнить его, он уже будет настроен таким же образом, каким он был настроен в момент выполнения отладки.

Тестовое окружение

Функции проверялись на платформе 8.3.10.2667.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Evg-Lylyk 3070 13.05.19 12:59 Сейчас в теме
2. Serge R 137 13.05.19 15:50 Сейчас в теме
Я знаю о существовании этой и подобных ей консолей запросов. Моя статья о том, как можно улучшить удобство использования ИТС-ной консоли запросов.
Созинов; +1 Ответить
3. yk1979 21.05.19 13:44 Сейчас в теме
Работает, автору спасибо!
4. Xershi 1020 21.05.19 14:03 Сейчас в теме
А в тонком клиенте это будет работать?
5. Serge R 137 21.05.19 19:28 Сейчас в теме
(4) Да, в тонком клиенте работает
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76278    Serginio    108    

Печать в word, pdf через html

Печать Практика программирования Универсальные функции v8 Россия Бесплатно (free)

При работе с клиентами возникла задача: использовать форматированный документ. Итак, существует справочник, в нем табличная часть. Для каждой строки требуется ввести описание, причем описание имеет тип форматированный документ. Потребовалось организовать печать табличной части справочника с описанием для каждой строки. Тип данных "Форматированный документ" не может выводится в табличный документ, поэтому пришлось организовывать печать через Microsoft Word.

11.09.2020    597    arr    4    

Самый простой парсинг и обработка веб-страниц в 1С

WEB Универсальные функции v8 1cv8.cf Бесплатно (free)

Рассмотрим самый простой парсинг веб-страниц средствами платформы 1С и еще некоторые полезные приемы работы с веб-страницами.

07.08.2020    4236    YPermitin    18    

Выполнение внешней обработки по расписанию для управляемого и обычного приложения

БСП (Библиотека стандартных подсистем) Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Использование БСП для выполнения внешних обработок в управляемом и обычном приложении

06.08.2020    960    RPGrigorev    0    

Универсальные функции с примерами использования Промо

Универсальные функции v8 Бесплатно (free)

14 универсальных функций, с примерами использования - для обычного и управляемого интерфейса

26.02.2016    41143    unichkin    46    

Пользовательское поле СКД одной процедурой

Практика программирования Универсальные функции v8 Бесплатно (free)

Быстрое создание пользовательского поля "выражение" одной процедурой

05.08.2020    1503    Yashazz    0    

Полезные встроенные функции для работы с печатными формами и не только на УТ 11.4 и БП 3.0 (сравнение)

Универсальные функции v8 БП3.0 УТ11 Россия Бесплатно (free)

В данном обзоре приведу примеры встроенных используемых функций для работы с печатными формами на примерах конфигураций Управление торговлей 11.4 и Бухгалтерия 3.0.

10.07.2020    2698    quazare    5    

Вывод дерева в табличный документ СКД

Практика программирования Универсальные функции v8 v8::СКД Бесплатно (free)

Вывод содержимого элемента формы "ДанныеФормыДерево" в табличный документ средствами СКД.

09.07.2020    2484    Yashazz    4    

Минимализмы 3 Промо

Практика программирования Универсальные функции v8 Бесплатно (free)

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    46424    ildarovich    45    

Команда "Вывести список" для динамического списка. Программное выполнение (вариант)

Универсальные функции v8::УФ 1cv8.cf Бесплатно (free)

Делаем свою кнопку вместо "Вывести список" из пункта "ещё" динамического списка.

11.06.2020    2980    DanDy    58    

Ещё немного функционального стиля в 1С или Как нам отфильтровать таблицу значений

Универсальные функции v8 Россия Бесплатно (free)

Потребовалось накладывать хитрые отборы на таблицу значений в сотни строк и десятки колонок, однако Скопировать со структурой отбора мне не подошло. Пришлось немного покреативить, подсмотрев, как это делается в других языках - возможно, получилось несколько топорно, но тем не менее - работает.

16.05.2020    2748    GlebHappy    34    

Сходство Джаро - Винклера. Нечеткое сравнение строк

Универсальные функции v8 Россия Бесплатно (free)

В области информатики и статистики сходство Джаро - Винклера представляет собой меру схожести строк для измерения расстояния между двумя последовательностями символов. В публикации рассмотрены некоторые особенности алгоритма, и представлен вариант его реализации на языке 1С.

25.12.2019    6971    brooho    17    

Универсальная функция для программного выполнения СКД Промо

Инструментарий разработчика Универсальные функции v8::СКД 1cv8.cf Бесплатно (free)

Часто встречаются вопросы на форумах о программном формировании СКД. Вроде и информации много по этому поводу, но... Все как всегда :) Собственно, в описании без лишних слов выложен текст общей функции, в которую, для выполнения отчета, нужно передать (минимум 2 параметра): СКД и ТабличныйДокумент.

20.05.2015    30522    dj_serega    18    

Функция - Формат государственного номера автомобиля

Универсальные функции v8 Автомобили, автосервисы Россия Бесплатно (free)

Возникла необходимость в приведении к единому формату хранящихся, и вводимых вновь, автомобильных Регистрационных знаков - Гос.номер.

23.12.2019    3541    brooho    4    

Полезности | Дерево значений | Обычные формы |

Практика программирования Универсальные функции v8 Бесплатно (free)

Полезные функции при работе с деревом значений.

04.12.2019    5471    Mellow    7    

Обработка расширением на клиенте

Расширения Универсальные функции v8::УФ 1cv8.cf Бесплатно (free)

Описываю нетривиальный прием работы с расширением, который позволит относительно быстро реализовывать некоторые обработки данных. Суть: обработка данных на клиенте с использованием методов, которые реализованы разработчиком конфигурации на форме объекта. Если эти методы есть вне модуля формы объекта (общий модуль, модуль менеджера, модуль объекта)- лучше сделать обработку более простым способом.

31.10.2019    7067    EvgenURNN    9    

Выполнение произвольного кода в фоновых заданиях Промо

Универсальные функции v8 Бесплатно (free)

Если надо быстро провести 100`000 документов...

13.01.2016    24603    unichkin    13    

Использование XML-схемы из макета внешней обработки

Обмен через XML Универсальные функции v8 1cv8.cf Бесплатно (free)

Простой способ использования XML-схем из макета внешней обработки.

28.10.2019    10795    Olesia_Matusevich    10    

Быстрое создание наполненных коллекций

Практика программирования Универсальные функции v8 1cv8.cf Бесплатно (free)

Разберем самые частые способы создания коллекции, значения которой известны заранее. И сравним скорость их выполнения.

28.10.2019    7133    SeiOkami    66    

Преобразование XML в таблицу значений или иной объект 1С методом XSL преобразования

Универсальные функции Обмен через XML v8 1cv8.cf Бесплатно (free)

Сразу открою интригу, напрямую прочитать XML, не содержащий объект 1С, не удастся. Статья раскрывает способы привести XML к формату, который возможно прочитать средствами платформы.

24.10.2019    11122    kraspila    29    

Распределение оплаты по товарам Промо

Практика программирования Универсальные функции v8 1cv8.cf Бесплатно (free)

Учебная задача. Оплата приходит по заказу. Требуется запросом распределить её по товарам. Практическая задача была сложнее. Упростил специально для иллюстрации. Сначала собираем в одну таблицу заказы и товары. Затем ОБЪЕДИНТЬ ВСЕ с оплатами. Потом намазываем оплату на товар.

04.08.2014    19148    Трактор    5    

Обертка функций Excel на русском. Ускорение процесса разработки.

Загрузка и выгрузка в Excel Универсальные функции v8 Бесплатно (free)

Устали переключаться с русского на английский и обратно при работе с таблицами Excel из 1С? Сборка наиболее необходимых функций и методов работы с Excel, обернутых в функции 1С на русском языке.

24.10.2019    7215    DmitryKotov    6    

Функция СтрШаблон с именованными маркерами

Универсальные функции v8 1cv8.cf Бесплатно (free)

Функция позволяет задавать именованные маркеры формата [Имя], в отличии от типовых нумерованных формата %n

1 стартмани

21.10.2019    4335    kirinalex    27    

Полезняшки по СКД и построителям. Просто код

Практика программирования Универсальные функции v8 v8::СКД Бесплатно (free)

Полезные процедуры и функции для работы с построителями и СКД. Просто исходник.

10.10.2019    9925    Yashazz    45    

Сканируем без сканера или MXL to JPG Промо

Внешние источники данных Универсальные функции Печатные формы документов v8 1cv8.cf Бесплатно (free)

Хотите конвертировать документы в формат изображения менее чем за минуту, не имея сканера? Тогда эта статья для вас.

24.05.2012    34086    shakmaev    47    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    31262    ids79    16    

Добавление возможности подключения внешних отчетов и обработок к объектам конфигурации при помощи расширения

Универсальные функции v8::УФ ERP2 Бесплатно (free)

Часто приходится сталкиваться с тем, что необходимо внести изменения в типовую конфигурацию, но очень не хочется снимать её с поддержки. Для этого в 1С существует ряд инструментов. Эта короткая статья посвящена тому, как подучить возможность подключения внешних отчетов к объекту конфигурации при помощи расширения на примере 1С:ERP Управление предприятием 2 (проверено на 1С:ERP Управление предприятием 2 (2.4.6.230)).

15.04.2019    4539    user995537    0    

Иерархия справочника Сверху Вниз. Получаем произвольное количество родителей "верхнего" уровня

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Иерархия справочника Сверху Вниз. Функция для получения произвольного количества родителей "верхнего" уровня. На примере справочника "Номенклатура".

28.03.2019    6137    obsfromekb    11    

Доработка проведения типовых документов в УТ 11.4, КА 2.4, ЕРП 2.4

Практика программирования Универсальные функции Разработка v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Бесплатно (free)

Различные варианты корректировки типовых механизмов проведения документов, без корректировки основной конфигурации. Использование расширений, подписок на событие и механизма локализации типовых документов.

22.03.2019    17730    ids79    16    

Добавление отчетов в типовые конфигурации 1С

Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем) v8::УФ v8::СКД 1cv8.cf Бесплатно (free)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    53540    ids79    46    

Расширение конструктора мобильного рабочего места для варианта "клиент 1С+RDP" (для любых wi-fi терминалов). Экосистема решений Simple WMS

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Универсальные функции Мобильная разработка Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8::УФ УУ Бесплатно (free)

Развитие проекта «Конструктор мобильного клиента на Android» https://infostart.ru/public/976636/ для устройств не на Андроиде (работающих в режиме RDP). В отличие от варианта Android работа на терминалах происходит в режиме 1С:Предприятие через RDP а конфигурации мобильных клиентов полностью совместимы для обоих версий. Т.е. конфигурация единая, создается один раз и ее может читать как Android -устройство, так и 1С-клиент на RDP без необходимости какой либо переделки.

05.02.2019    12967    informa1555    10    

Работа со строками: от простого к сложному

Практика программирования Универсальные функции v8 Бесплатно (free)

Простые примеры работы со строками, в конце более читаемый разбор сложных текстов.

14.01.2019    28816    Evg-Lylyk    17    

Нумерация колонок субконто при выгрузке набора записей регистра бухгалтерии в таблицу значений

Универсальные функции v8 Бесплатно (free)

Решение проблемы несовпадения номеров колонок с номерами субконто на счете при выгрузке в таблицу значений.

14.01.2019    5618    The Ded    5    

Многопоточное восстановление последовательностей

Производительность и оптимизация (HighLoad) Практика программирования Математика и алгоритмы Универсальные функции v8 Бесплатно (free)

Универсальный алгоритм многопоточного фонового восстановления любой последовательности.

05.12.2018    13192    _ASZ_    33    

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке

Универсальные функции Зарплата Управление персоналом (HRM) Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Бесплатно (free)

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    86597    GeterX    114    

Кадровые данные сотрудников в ЗУП 3.1 в отчетах

Универсальные функции Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия Бесплатно (free)

Параметры используемые для получения данных сотрудников в ЗУП 3.1. Пригодится для разработки отчетов как напоминалка.

07.11.2018    32802    fromlion    22    

Добавление расшифровки в стандартные и добавленные внешние отчеты со стандартной формой отчета на СКД

Универсальные функции v8::УФ v8::СКД ERP2 УТ11 Россия Бесплатно (free)

Описан способ добавления расшифровки отчета на СКД как встроенного в систему, так и добавленного внешнего отчета.

27.09.2018    10776    bmk74    8    

Функция НайтиФайлы() в каталоге netshare на Linux - обход ошибки работы

Практика программирования Универсальные функции v8 Бесплатно (free)

Решение проблемы применения функции НайтиФайлы() в каталоге с netshare на Linux-сервере - не работает поиск файлов по указанной маске (шаблону)

19.09.2018    6296    drmaxart    3    

Простой способ программно открыть заполненную форму нового (незаписанного) документа в тонком клиенте

Универсальные функции v8 Бесплатно (free)

В этой публикации я поделюсь своим способом открывать программно новый незаписанный документ в тонком клиенте. Для использования этого способа потребуется немного модифицировать конфигурацию. Добавив универсальные процедуру и функцию, можно будет использовать их для любых документов/справочников.

09.06.2018    11328    Serge R    12    

Генерация временного ряда запросом

Универсальные функции v8 v8::Запросы 1cv8.cf Бесплатно (free)

Способ генерации последовательности дат средствами языка запроса 1С.

07.05.2018    8730    dim_zal    6    

Таблица значений в Таблицу HTML - функция с возможностью настройки цвета шапки, заголовков, выравнивания и размера колонок

Практика программирования Универсальные функции v8 1cv8.cf Бесплатно (free)

Если вам нужно быстро получить таблицу значений в виде строкового типа 1С в формате HTML, вам поможет эта функция, включена возможность автоматического вывода столбца пункт по порядку.

22.12.2017    25261    rpgshnik    22    

Пример преобразования двоичных данных в строку

Универсальные функции v8 Бесплатно (free)

Доброго всем времени суток. Хочу поделиться маленьким решением маленькой проблемы. Думаю, будет интересно новичкам. Я не раз встречал на форумах вопрос: как преобразовать двоичные данные в строку? В частности, к примеру, частенько нужно получить хэш файла MD5 в текстовом виде, но как мы знаем 1С возвращает его в виде двоичных данных.

08.12.2017    18892    frkbvfnjh    21