Вставляем картинку из буфера обмена (платформа 1С 8.3.24)

29.03.24

Разработка - Универсальные функции

Задача: вставить картинку из буфера обмена на форму средствами платформы 1С.

Скачать исходный код

Наименование Файл Версия Размер
Вставить картинку из буфера обмена (платформа 1С 8.3.24):
.epf 19,94Kb
3
.epf 1.0.1 19,94Kb 3 Скачать

Для демонстрации механизма создал обработку. На форму добавил кнопку и событие "ПриВставкеИзБуфераОбмена"

 

 

 

При нажатии на кнопку выполняется асинхронная процедура "КартинкаИзБуфера", в которой с помощью свойства глобального контекста "СредстваБуфераОбмена" получим картинку, содержащуюся в буфере.

 

 

&НаКлиенте
Асинх Процедура КартинкаИзБуфера(Команда)    
	
	Картинка = Ждать ПриВставкеИзБуфераОбменаКартинки(); 
	ВставитьКартинкуИзБуфера(Картинка);  
	
КонецПроцедуры

&НаКлиенте
Асинх Функция ПриВставкеИзБуфераОбменаКартинки()
	
    Если СредстваБуфераОбмена.ИспользованиеДоступно() Тогда
        ФорматДанных = СтандартныйФорматДанныхБуфераОбмена.Картинка;
        Если Ждать СредстваБуфераОбмена.ПоддерживаетсяФорматДанных(ФорматДанных) Тогда
			Возврат Ждать СредстваБуфераОбмена.ПолучитьДанныеАсинх(ФорматДанных);
        КонецЕсли;
    КонецЕсли;
	
    Возврат Неопределено;
		
КонецФункции

&НаКлиенте
Процедура ВставитьКартинкуИзБуфера(Картинка)
	
	Если ТипЗнч(Картинка) = Тип("Картинка") Тогда
		ПутьККартинке = КаталогВременныхФайлов()+"screen.jpg";
		Картинка.Записать(ПутьККартинке); 
		
		ДвоичныеДанные = Новый ДвоичныеДанные(ПутьККартинке);    	
		Скриншот = ПоместитьВоВременноеХранилище(ДвоичныеДанные, УникальныйИдентификатор); 
	КонецЕсли;	
	
КонецПроцедуры

 

Обрабатываю событие ctrl + v

 

 

&НаКлиенте
Процедура ПриВставкеИзБуфераОбмена(Значение, СтандартнаяОбработка) 
	
	ВставитьКартинкуИзБуфера(Значение);   
	
КонецПроцедуры

&НаКлиенте
Процедура ВставитьКартинкуИзБуфера(Картинка)
	
	Если ТипЗнч(Картинка) = Тип("Картинка") Тогда
		ПутьККартинке = КаталогВременныхФайлов()+"screen.jpg";
		Картинка.Записать(ПутьККартинке); 
		
		ДвоичныеДанные = Новый ДвоичныеДанные(ПутьККартинке);    	
		Скриншот = ПоместитьВоВременноеХранилище(ДвоичныеДанные, УникальныйИдентификатор); 
	КонецЕсли;	
	
КонецПроцедуры

 

Тестировал: 

  • Платформа 1С:Предприятие 8.3 (8.3.24.1342)

См. также

Загрузка табличного документа в таблицу значений. Пять строк кода, которые изменили мир

Универсальные функции Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Благодаря этим пяти строчкам можно больше не заморачиваться с загрузкой из внешних файлов. Пользуюсь везде, всегда и постоянно.

21.05.2024    7934    dimanich70    77    

105

GUID в 1С 8.3 - как с ними быть

Универсальные функции Программист Стажер Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Пришлось помучиться с GUID-ами немного, решил поделиться опытом, мало ли кому пригодится.

12.02.2024    6345    atdonya    22    

53

Переоткрытие внешних обработок

Универсальные функции Программист Платформа 1С v8.3 Бесплатно (free)

На заключительных этапах, когда идет отладка или доработка интерфейса, необходимо много раз переоткрыть внешний объект. Вот один из способов автоматизации этого.

30.11.2023    4465    ke.92@mail.ru    16    

64

Валидация JSON через XDTO (включая массивы)

WEB-интеграция Универсальные функции Механизмы платформы 1С Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

При работе с интеграциями рано или поздно придется столкнуться с получением JSON файлов. И, конечно же, жизнь заставит проверять файлы перед тем, как записывать данные в БД.

28.08.2023    10352    YA_418728146    7    

148

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2525    35    progmaster    8    

4

Расширение: Быстрые отборы через буфер [Alt+C] Копировать список, [Alt+V] Вставить список, [Ctrl+C] Копировать из файлов

Инструментарий разработчика Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Копирует в буфер значения из списков, из ячеек отчетов, таблиц, настроек списков, других отборов и вставляет в выбранную настройку отбора. Работает с Объект не найден. Работает как в одной так и между разными базами 1С. Использует комбинации [Alt+C] Копировать список, [Alt+V] Вставить список. Также для копирования данных используется стандартная [Ctrl+C] (например из открытого xls, mxl, doc и т.п. файла скопировать список наименований)

1 стартмани

13.10.2022    16758    148    sapervodichka    112    

132

Система контроля ведения учета [БСП]

Универсальные функции Механизмы типовых конфигураций БСП (Библиотека стандартных подсистем) Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данном материале рассмотрим типовой алгоритм подсистемы контроля учета БСП в конфигурациях на примерах.

18.07.2022    7565    quazare    8    

110
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. cheshirshik 64 19.03.24 07:16 Сейчас в теме
У 1с есть форматированный документ, который позволяет вставлять картинку из буфера обмена вообще без кода. Но за статью спасибо. Добавлю в закладки. Может пригодится.
2. baracuda 2 19.03.24 10:05 Сейчас в теме
(1) ну так статья не про форматированный документ, а про поле формы.
adhocprog; +1 Ответить
7. Mopo3 332 26.03.24 15:23 Сейчас в теме
(1) не совсем так. Есть особенности. Например, если из WA скопировать картинку в буфер и попробовать штатно вставить её в ФД через Ctrl+V - то ничего не сработает. Кроме как через использование события ПриВставкеИзБуфераОбмена() этот сценарий не отработать.
8. cheshirshik 64 26.03.24 16:35 Сейчас в теме
(7)

У меня все работает в форматированном документе и через Контрол+В и через Шифт+Инсерт без всяких подписок на событие. И в тонком клиенте и в толстом клиенте и в веб клиенте.
Прикрепленные файлы:
4. Поручик 4678 21.03.24 18:12 Сейчас в теме
То, что я и другие разработчики делали лет 10 назад с использованием компоненты.
5. kamisov 154 24.03.24 09:57 Сейчас в теме
Картинку через новую функцию прогнали, но ДД все еще через файлы гоняем?
6. John_d 5457 25.03.24 12:16 Сейчас в теме
(5)
&НаКлиенте
Асинх Процедура ПриВставкеИзБуфераОбмена(Значение, СтандартнаяОбработка)
    ДанныеФайлов = Новый Соответствие;
    Если ТипЗнч(Значение) = Тип("Массив") Тогда
        Для каждого ЭлементБуфера Из Значение Цикл
            Если ТипЗнч(ЭлементБуфера) = Тип("СсылкаНаФайл") И НРег(ЭлементБуфера.Расширение) = ".docx" Тогда
                ДанныеФайла = Ждать ЭлементБуфера.ПолучитьКакДвоичныеДанныеАсинх();
                ДанныеФайлов.Вставить(ЭлементБуфера.Файл.Имя, ДанныеФайла);
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
    Если ДанныеФайлов.Количество() <> 0 Тогда
        ПриВставкеИзБуфераОбменаНаСервере(ДанныеФайлов);
    КонецЕсли;
КонецПроцедуры
Показать
9. user1378392 3 10.04.24 22:40 Сейчас в теме
Здравствуйте, подскажите, на УНФ 3.0 подойдет?
10. AneJIbcuH 37 16.04.24 20:21 Сейчас в теме
(9) Дело не в конфигурации, только в платформе (от 8.3.24)
11. user1378392 3 16.04.24 23:03 Сейчас в теме
(10) А 8.3.21 может не подойти?
Оставьте свое сообщение