Отправка уведомлений с помощью командной строки, Оповещения с сервера на клиент с помощью командной строки

Публикация № 1206374 05.03.20

Разработка - Механизмы платформы 1С

Оповестить пользователей из серверного модуля или регламентного задания сервер клиент уф

Отправка уведомлений с помощью команды командной строки msg. Оповестить пользователей из серверного модуля или регламентного задания, с помощью командной строки msg.

Часто возникает необходимость оповестить клиента о какой нибудь информации (Например о новом сформированном документе) с сервера. На данный момент, в типовых методах 1С нет возможности оповестить клиента с сервера, в основном существующие методы оповещения построены на принципе периодического "опроса" клиента на сервер. Проще говоря "обработчики ожидания". Многие разработчики используют обработчики ожидания, либо разрабатывают\используют внешние компоненты для реализации подобной задачи. Типовые механизмы: напоминания, уведомления, задачи ... так же используют периодический зарос сервера на появление новых данных.

Далее будет показан пример, как отправить уведомление с сервера на клиент используя команду (командной строки Windows ) - MSG

"Команда MSG существовала еще в Windows 2000/XP и предназначалась для обмена сообщениями между пользователями вошедшими в систему локально и пользователями терминальных сессий ( подключившихся к удаленному рабочему столу ) . В Windows Vista и более поздних операционных системах семейства Windows команда MSG стала основным стандартным средством обмена сообщениями, поскольку команда net send в данных ОС больше не поддерживается."

Для примера возьмем небольшой код использования данного механизма:

///Модуль Web-Сервиса Пример1
                                                                                                   
Процедура СоданияДокумента(Параметры) 
                                                                                                        
    Чтение = Новый ЧтениеXML;
    Чтение.УстановитьСтроку(Текст);
    
    //прочитаем начало xml файла
    Чтение.ПерейтиКСодержимому();
    
    //прочитаем начало корневого элемента
    Чтение.Прочитать();
    
    //читаем содержимое пока текущим не станет конец корневого элемента, т.к. мы писали туда только целые элементы справочника,
    //а сериализатор читает каждый из их полностью, то мы упремся именно в конец корневого
    Пока Чтение.ТипУзла<>ТипУзлаXML.КонецЭлемента Цикл
                                                                                                             
        НовыйДокумент = Документы.АвансовыйОтчет.СоздатьДокумент();

        //читаем очередной элемент справочника
        Объект = СериализаторXDTO.ПрочитатьXML(Чтение);

        ЗаполнитьЗначенияСвойств(НовыйДокумент,Объект );
                                                                                         
        Попытка
            НовыйДокумент.Записать(РежимЗаписиДокумента.Проведение); 
            ///Записываем документ и отправляем уведомление о новом документе                                          
            ОповеститьПользователяОНовомДокументе(НовыйДокумент.Ссылка)
        Исключение
            ТекстОшибки = ОписаниеОшибки();
        КонецПопытки;
                                                                                 
    КонецЦикла;
    
    Чтение.Закрыть();                                                                                                      
                                                                                                                                                                                                                                               
КонецПроцедуры
                                                                                                     
Процедура ОповеститьПользователяОНовомДокументе(Ссылка)
    ///Пример отправки уведомления 
    ///Получим список активных пользователей Информационной базы
    ///Делаем отбор по "Бухгалтеру" и отправляем                                                                                           
    Попытка
        массивСоединений = ПолучитьСоединенияИнформационнойБазы(); ///Получаем список активных пользователей
    	Для каждого масс из массивСоединений цикл

	    	Если масс.ИмяПриложения	= "1CV8C" тогда ///1С Предприятие
		    	Если масс.ИмяПользователя = "Бухгалтер" Тогда  ///Отправляем уведомление Бухгалтеру
			        ИмяКомпьютера = масс.ИмяКомпьютера;
                    СтрокаМСГ = "MSG /time:1000 /server:"+ СокрЛП(ИмяКомпьютера)+" * " + "Сформирован новый документ: " + строка(Ссылка);;
    		        ЗапуститьПриложение(СтрокаМСГ);
                КонецЕсли;
		    КонецЕсли;
	    КонецЦикла;
    Исключение
        ТекстОшибки = ОписаниеОшибки();                                                    
    КонецПопытки;


    ///Либо сразу пропишем ИмяКомпьютера "Бухгалтера" 
    ///В случае если Бухгалтер не работает в программе 1С на данный момент.
    //Попытка 

    //    ИмяКомпьютера = "buhgalter-1";
    //    СтрокаМСГ = "MSG /time:1000 /server:"+ СокрЛП(ИмяКомпьютера)+" * " + "Сформирован новый документ: " + строка(Ссылка);;
    //	ЗапуститьПриложение(СтрокаМСГ);
        
    //Исключение
    //    ТекстОшибки = ОписаниеОшибки();                                                    
    //КонецПопытки;
                                                                                                   
КонецПроцедуры

В примере рассматривается отправка уведомления Бухгалтеру.

 

 

 

 

 

 

 

 

 

 

Данную команду так же можно использовать для отправки уведомления пользователям локальной сети, как выборочно так и всем сразу. 

Пример реализации:

///Получаем имена компьютеров локальной сети
///Заносим имена в табличную часть "Компьютеры" 

&НаСервере
Процедура ПолучитьВсеКомпьютерыЛокальнойСети()
                                                                                       
	Компьютеры.Очистить();
    
    ///Для получения Списка локальных и терминальных пользователей используем команду
    /// cmd -  "Net View" 
    ///Команда net view выводит список доменов, компьютеров или общих ресурсов на данном компьютере. 
    ///Вызванная без параметров, команда net view выводит список компьютеров в текущем домене. 
                                                                                         
	objShell = Новый COMОбъект("WScript.Shell") ;
    objScriptExec = objShell.Exec("Net View") ;
    strPingResults = НРег(objScriptExec.StdOut.ReadAll());
                                                                                            
	Для Индекс = 1 По СтрЧислоСтрок(strPingResults) Цикл
        ПолучитьКомп(СтрПолучитьСтроку(strPingResults, Индекс));
    КонецЦикла;
                                                                                          
КонецПроцедуры

Процедура ПолучитьКомп(ММ)  ///Форматируем имя компьютера (Удаляем лишние символы)

    ///Имя компьютера в локальной сети будет иметь вид: "\\Admin"      
	НачСлова = СтрНайти(ММ,"\\");

	Если НачСлова = 0 тогда
		возврат;
	КонецЕсли;

	КонСлова = СтрНайти(ММ," ",,НачСлова);

	Комп = СокрЛП(Сред(ММ,НачСлова+2,КонСлова - НачСлова));	

	Компьютеры.Добавить().ИмяКомпьютера = Комп;
КонецПроцедуры

///В итоге получаем Таблицу с именами компьютеров в локальной сети
///Далее, выбираем нужных пользователей и отправляем уведомление             

&НаСервере
Процедура ОтправитьУведомленияНаСервере()
                                                                                            
	Для каждого стр из Компьютеры цикл   ///Пометка - вторая колонка Табличной части, для ручного выбора пользователей
		Если стр.Пометка тогда    
			СтрокаМСГ = "MSG /time:1000 /server:"+ СокрЛП(стр.ИмяКомпьютера)+" * " + Сообщение;
    		ЗапуститьПриложение(СтрокаМСГ);
		КонецЕсли;
	КонецЦикла;
                                                                                              
КонецПроцедуры

&НаКлиенте
Процедура ОтправитьУведомления(Команда)
                                                                                              
	Если ПустаяСтрока(Сообщение) тогда
		ПоказатьОповещениеПользователя("Отсутсвует сообщение!");
		возврат;
	КонецЕсли;
                                                                                               
	ОтправитьУведомленияНаСервере();
                                                                                             
КонецПроцедуры

 

 

 

Параметры MSG и Возможные ошибки:

Нынешняя реализация msg.exe прекрасно подходит для обмена сообщениями между сеансами локальных и терминальных пользователей в пределах одной системы, однако, в случаях обмена между разными компьютерами локальной сети, потребуется изменить некоторые настройки безопасности, принятые по умолчанию в операционных системах Windows Vista, 7 и более поздних.

При стандартных настройках, отправка сообщения пользователям удаленных компьютеров не выполняется и сопровождается сообщением:

Ошибка 1722 при получении имен сеанса

Это означает, что на компьютере, где должно приниматься посылаемое сообщение, невозможно получить информацию о вошедших в систему пользователях. Причиной может быть то, что брандмауэр блокирует входящие соединения, недостаточны права пользователя по отношению к удаленной системе, запрет удаленного вызова процедур в параметрах службы сервера терминалов. Как минимум, для обмена сообщениями с использованием команды msg между компьютерами, необходимо иметь учетную запись пользователя, действительную по отношению к удаленной системе и выполнить следующие настройки:

на каждом компьютере, которому будут отправляться сообщения, добавить в раздел реестра HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server параметр AllowRemoteRPC типа REG_DWORD и равный 1 Для изменения настроек можно использовать .reg-файл следующего содержания:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server]
"AllowRemoteRPC"=dword:00000001


В ОС Windows Vista, Windows 7, 8, 10 ключ реестра AllowRemoteRPC существует, но имеет значение равное 0 , что необходимо исправить. Для применения изменений требуется перезагрузка.

поскольку для обмена сообщениями утилита msg.exe использует протокол SMB (Server Message Block ), на каждом компьютере, которому будут отправляться сообщения, должен быть открыт TCP порт 445


Примеры использования MSG:

msg * /server:Server "Тестовое сообщение " - отправить тестовое сообщение всем пользователям компьютера Server

msg * /server:192.168.0.1 "Тестовое сообщение " - отправить тестовое сообщение всем пользователям компьютера с IP-адресом 192.168.0.1

msg RDP-Tcp#0 /server:TSServer "Тестовое сообщение" - отправить тестовое сообщение пользователю терминальной сессии с именем RDP-Tcp#0 на компьютере TSServer

msg console /server:Windows7 "Тестовое сообщение" - отправить тестовое сообщение текущему локальному пользователю компьютера Windows7

msg console "Тестовое сообщение" - отправка тестового сообщения от пользователя сеанса RDP локальному пользователю. Если эта команда выполняется не пользователем терминальной сессии, то сообщение будет отправлено локальным пользователем самому себе.

Для выполнения команды msg от имени другого пользователя можно воспользоваться утилитой PSExec из пакета PSTools или штатным средством runas.exe

psexec -u otheruser -p otherpass msg * /server:win10 TEST message

runas /user:otheruser "msg * /server:win10 Test message"

Сообщения, отправляемые командой msg локальному пользователю компьютера с операционной системой Windows XP, который отсутствует ( еще не вошел в Windows ) отображаются в окне с приглашением к регистрации в системе и могут быть доступны посторонним.

Источник MSG.

К данной статье прикреплена обработка для отправки уведомления. Обработка тестировалась на конфигурации ЗУП (3.1.9.108).

Универсальная, подходит конфигурациям на управляемых формах.

Скачать файлы

Наименование Файл Версия Размер
Оповещения с сервера на клиент MSG

.epf 7,67Kb
15
.epf 1.2 7,67Kb 15 Скачать

Специальные предложения

Автор запретил комментарии

См. также

Сколько стоит слово Знач в клиент-серверных вызовах?

Механизмы платформы 1С HighLoad оптимизация Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Небольшое исследование влияния ключевого слова Знач в параметрах функций на производительность клиент-серверных вызовов.

1 стартмани

18.12.2022    1627    user1373370    2    

16

Гонка конфигураторов с помощью экзекутора

Инструментарий разработчика DevOps и автоматизация разработки Механизмы платформы 1С Платформа 1С v8.3 Абонемент ($m)

Выгружать конфигурацию в файлы в последнее время стало супер модно. Контроль версий, Git, CI/CD и вот это вот все. Исходники как тексты сегодня нужны всем. Но возникают вопросы: а каким методом лучше и быстрее выгружать конфигурацию в файлы, а какая версия платформы справляется с этой задачей оперативнее? Моя статья постарается ответить на эти вопросы. Как говорится, заставим попотеть ваши конфигураторы. С помощью 1С Исполнителя 2.0 мы выгрузим конфигурацию ЗУП, используя платформу пяти версий, от 8.3.18 до 8.3.22.

1 стартмани

16.11.2022    3506    infosoft-v    40    

44

Как передать Таблицу Значений в Динамический Список?

Механизмы платформы 1С Универсальные функции Платформа 1С v8.3 Абонемент ($m)

До версии 8.3.9 ответ однозначен - никак. Потом были добавлены временные таблицы для динамических списков, но официальный ответ остался неизменным - никак. Ну а если очень надо?

1 стартмани

17.10.2022    4437    Dementor    9    

23

Перечень множественных значений в ячейке динамического списка. Как стало и как было

Механизмы платформы 1С Платформа 1С v8.3 План видов характеристик Абонемент ($m)

В платформе версии 8.3.21 наконец-то появилась возможность указать, что характеристика может содержать более одного значения, и правильно отобразить этот перечень в динамическом списке. Настройка нового механизма, а также альтернативы, используемые ранее, описаны в статье.

1 стартмани

20.09.2022    3251    Alxby    9    

47

Что не так с таблицами формы?

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Почему при редактирования строки таблицы нельзя отказаться от изменений? Почему на верхнем уровне дерева можно ввести только один узел? Ответ на эти и другие вопросы один - потому что 1С :) Однако не все так плохо! Возможностей кастомизации в платформе 1С вполне достаточно, чтобы улучшить работу с этим элементом и снять некоторые ограничения.

1 стартмани

19.09.2022    1807    kalyaka    3    

22

Программная работа с типовыми формами истории данных

Механизмы платформы 1С Платформа 1С v8.3 Абонемент ($m)

Попалась по работе интересная задачка - включить для регистра сведений историю изменений и сделать собственные кнопки открытия стандартных форм истории. Информации на эту тему особо не нашлось, поэтому решил зафиксировать этот кусочек в виде небольшой статьи.

1 стартмани

07.07.2022    1428    zeltyr    5    

19

Точка останова с условием. Приемы и хитрости использования

Механизмы платформы 1С Платформа 1С v8.3 Абонемент ($m)

“Точка останова с условием“ - применима в самых разнообразных ситуациях, и грамотное её применение экономит много времени разработчика 1С.

1 стартмани

10.06.2022    5139    Onwardv    8    

58

Использование HTML Редактора whizzywig в 1С 8.2 и 1С 8.3 платформах

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1C v8.2 Конфигурации 1cv8 Россия Абонемент ($m)

В статье будут разобраны способы использования визуального HTML Редактора whizzywig в 1С 8.2 и 1С 8.3, который существенно меньше по размерам, чем TinyMCE, но при этом обладает большими возможностями. Показано достоинство этого редактора. Приведены обработки, которые работают как на компьютерной платформе, так и пример реализации обработки, которая предназначена для мобильной платформы. Решение испытывалось на платформах 1С 8.2.12 и 8.3.20, и мобильном клиенте 8.3.19.59.

2 стартмани

12.04.2022    1035    user1206119    2    

3

Использование HTML Редактора NicEdit в 1С 8.2 и 1С 8.3 платформах

Механизмы платформы 1С Платформа 1С v8.3 Мобильная платформа Платформа 1C v8.2 Абонемент ($m)

В статье будут разобраны способы использования визуального HTML Редактора NicEdit в 1С 8.2 и 1С 8.3, который существенно меньше по размерам, чем TinyMCE. Показано достоинство этого редактора. Приведены обработки, которые работают как на компьютерной платформе, так и пример реализации обработки, которая предназначена для мобильной платформы. Решение испытывалось на платформах 1С 8.2.12 и 8.3.20, и мобильном клиенте 8.3.19.59.

2 стартмани

11.04.2022    1562    user1206119    7    

5

Семеро одного не ждут? Асинхронное исследование асинхронности

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Все уже, наверное, знают о появлении в новых версиях платформы асинхронных функций и конструкций Асинх/Ждать. Многие, возможно, уже их используют. Но что будет, если создать свои асинхронные функции, запустить и не дожидаться окончания их выполнения? Неужели можно запустить несколько процессов параллельно?

1 стартмани

08.06.2021    9912    Alxby    55    

59

Загрузка, скачивание, удаление файлов с помощью НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера()

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В платформе 8.3.15 появились новые методы НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера(). В данной статье рассмотрено готовое решение проверенное и прекрасно работающее на тонком и веб-клиенте.

1 стартмани

25.07.2020    26168    Flashill    18    

55

Удаление записи из табличной части в режиме без использования модальности

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Всем привет! Появилась необходимость в написании кода удаления записи из табличной части с обратной связью в режиме без использования модальности. Но как правильно сделать нигде не нашел. Предлагаю свой вариант на растерзание.

1 стартмани

01.03.2020    3453    vaganovsergey    2    

0

Пауза на платформе 1С, очень нативная и очень бережная к ресурсам

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Иногда необходимо установить паузу при выполнении программных алгоритмов. К сожалению, платформа 1С не имеет решения на уровне глобального контекста, поэтому приходится разработчику придумывать "костыли и велосипеды". Решения, которые "общеприняты": либо используют внешние библиотеки (VBS, WS, ping и пр.), либо нещадно используют ресурсы (бесконечный цикл и т.п.). Хочу предложить еще одно решение, основанное на механизме управляемых блокировок платформы 1С. Итак, приступим:

1 стартмани

25.11.2019    7359    Sibars    65    

11

Описание формата внутреннего представления данных 1С в контексте обмена данными

Механизмы платформы 1С Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    25803    Dementor    32    

221

"Убер на складе": динамический расчет маршрутов с учетом реальных расстояний

Учет ТМЦ Механизмы платформы 1С Платформа 1С v8.3 Управленческий учет Абонемент ($m)

Представляю методику и инструмент для динамического расчета маршрутов отбора на высоконагруженных складах для максимального повышения эффективности склада, ускорения проходимости и, как следствие, экономии денег. Это методика и обработка для интеграции в WMS решения. Тестировалось на 1С 8.3.14.1565.

3 стартмани

24.06.2019    24840    informa1555    25    

76

Безопасная работа с транзакциями во встроенном языке

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    61503    tormozit    67    

283

Асинхронная работа с текстовыми файлами в 1С 8.3

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В этой статье я рассмотрю основные моменты работы с текстовым файлом в 1С 8.3. (загрузка - выгрузка) в режиме отключенной модальности (асинхронно).

1 стартмани

28.02.2019    13687    signum2009    7    

12

Баг или фича? Неожиданное поведение платформы

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Рассмотрим несколько случаев неожиданного поведения платформы 1С, а также что с этим можно cделать.

18.02.2019    27182    Infostart    90    

185

Динамическое изменение формы: кнопочная форма выбора справочника

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Динамическое изменение формы на примере кнопочного выбора из справочника.

1 стартмани

18.10.2018    10315    RocKeR_13    14    

38

Жизненный цикл управляемой формы. Шпаргалка разработчика

Механизмы платформы 1С Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Прочитав когда-то давно книжку "Разработка управляемых форм", составил для себя такую схемку-напоминалку для обращения в процессе разработки. С тех пор не раз выручала и избавляла от необходимости лезть в гуглы.

1 стартмани

29.06.2018    49406    stas_ganiev    26    

325

Асинхронная запись и чтение файла без использования модальных методов и временных файлов

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В статье рассмотрено решение задачи формирования и записи файла на основе данных информационной базы. Формирование происходит на стороне сервера с помощью механизма потоков. Используются асинхронные методы передачи файлов между клиентом и сервером. Также рассмотрено решение обратной задачи - чтение файла и запись его данных в информационную базу. Статья ориентирована прежде всего на новичков, также приведенный код может использоваться в качестве шаблона.

1 стартмани

10.04.2018    38042    Alxby    23    

153

Обманчивая ошибка "Данные были изменены или удалены другим пользователем"

Механизмы платформы 1С Платформа 1С v8.3 Абонемент ($m)

В данной статье описывается такая причина возникновения сообщения об ошибке «Данные были изменены или удалены другим пользователем», расследование которой может завести в тупик.

1 стартмани

25.03.2018    41872    rinat_alp2    7    

8

Отборы (поиск) в табличной части либо таблице значений (управляемые формы)

Механизмы платформы 1С Платформа 1С v8.3 Управляемые формы Абонемент ($m)

В управляемых формах для нас доступен мощный ресурс работы с динамическими списками посредством СКД - отборы, сортировки и далее. Но вот табличная часть (таблица значений) на управляемой форме не позволяет работать так гибко. Мы можем научить пользователей пользоваться комбинацией клавиш "Ctrl+F", но давайте немного упростим жизнь и позволим нашим пользователям настраивать отборы (осуществлять поиск) по табличной части прямо в нашем окне.

1 стартмани

22.03.2018    101516    Kim1C    26    

61

Динамические колонки в таблице значений из разного числа строк (как в отчёте)

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Как всегда, статья больше адресована себе, чтобы в нужный момент быстро найти. Предыстория... Как-то передо мной была поставлена задача сделать обработку, в которой по пользователям нужно было вывести загрузку по их активным проектам в настоящий момент. Она требовалась для руководителя, который для менее загруженного пользователя назначал бы новые проекты. По одному и тому же проекту чаще всего были задействованы разные пользователи, число и названия проектов также различались.

1 стартмани

16.02.2018    16672    perepetulichka    5    

15

План видов характеристик (ПВХ) - с чем его едят

Механизмы платформы 1С Платформа 1С v8.3 План видов характеристик Абонемент ($m)

План видов характеристик - эта фишка нужна Аналитикам. В данной статье мы рассмотрим пример создания сложного ПВХ по учебнику Хрусталевой/Радченко. А также создадим свой собственный механизм ПВХ с двумя видами отчетов-СКД на выходе.

1 стартмани

14.02.2018    82464    jan-pechka    17    

105

Проверка таблицы на дублирование строк (ТаблицаЗначений, ТабличнаяЧасть) и получение массива таких строк

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Функция для проверки дублирования строк в ТаблицеЗначений или ТабличнойЧасти. Также, если необходимо, возвращает массив задублированных строк (можно обработать).

1 стартмани

05.02.2018    14038    uri1978    27    

12

Программное создание динамического списка на управляемой форме. (Динамическое создание динамического списка). Готовая процедура + обработка - демонстрационный пример

Механизмы платформы 1С Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Если у вас возникает необходимость на форму влиять динамически и создавать элементы управляемой формы программно, а особенно хотите вывести программно (динамически) динамический список, вам будет интересна эта процедура. Процедура включает также возможность формирования своей командной панели (а-ля снятие галочки "Автозаполнение" у стандартной командной панели списка).

1 стартмани

19.01.2018    87216    rpgshnik    38    

381

Система взаимодействия. Быстрый старт

Механизмы платформы 1С Платформа 1С v8.3 Россия Абонемент ($m)

В статье описано принципиальное взаимодействие клиентского сеанса с сервером взаимодействия.

1 стартмани

28.11.2017    52767    Goleff74    27    

96

Асинхронность в управляемом интерфейсе 1С

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

В статье доступно объясняется про новое модное явление асинхронности, добавленное в платформу 1С. Также приложен пример асинхронной обработки по поиску файлов.

1 стартмани

15.01.2017    28785    fixin    30    

38

Отличия в управляемом приложении при создании нового документа без сохранения объекта

Механизмы платформы 1С Платформа 1С v8.3 1С:Бухгалтерия 2.0 Абонемент ($m)

В обычном приложении «1С:Предприятие 8», если необходимо создать новый документ и без сохранения открыть его форму, мы просто создавали объект, наполняли его данными и открывали форму объекта. В управляемом приложении «1С:Предприятие 8» есть существенные отличия, которые я попытаюсь описать.

1 стартмани

05.05.2016    13927    sss123    4    

8

Трюки 1С 8 – Передача формы документа в форму выбора

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

В данной серии статей будут показаны несколько трюков, которые компенсируют отдельные слабости платформы 1С 8, в частности, в области разработки обычных форм.

1 стартмани

30.08.2013    14968    mbm    14    

25

Сравнение скорости получения имени класса через Метаданные.*.Содержит и через Метаданные().ПолноеИмя()

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Сравнение скорости двух методов определения класса объекта через его метаданные. Когда есть Объект, но неизвестно заранее, какой у него тип (например получен из реквизита типа ЛюбаяСсылка)

1 стартмани

08.08.2013    10026    taiba    9    

12

Методика оперативного проведения и управляемые блокировки

Механизмы платформы 1С Платформа 1С v8.3 Абонемент ($m)

Несмотря на то, что у меня уже есть статья посвященная механизму оперативного проведения, очень часто, нет не так, очень-очень-очень часто спрашивают, что это такое. Я подумал и решил написать ну очень-очень-очень подробную статью про методику оперативного проведения и управляемые блокировки. А без управляемых блокировок, собственно, методику использовать бессмысленно.

1 стартмани

25.07.2013    85979    GROOVY    176    

335

ТипЗнч vs Метаданные()

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Сравнение скорости определения типа объекта через ТипЗнч и через Метаданные

1 стартмани

15.06.2013    25879    taiba    25    

20

Как узнать, является значение ссылочного типа «битой ссылкой» или нет?

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv7 Россия Абонемент ($m)

Для платформ 1С-7.7 и 1С-8.x описаны простые способы выяснения того, является ли ссылочное значение ссылкой на несуществующий объект. Для обеих платформ выложены примеры реализации функции IsEmpty(), возвращающей признак пустого значения и флаг «битой ссылки».

1 стартмани

28.02.2013    33447    yuraos    25    

18

XDTO - часть 3

Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Мы продолжаем цикл статей по изучению подсистемы XDTO в 1С:Предприятие. Это третья часть, в которой мы будем работать непосредственно с подсистемой, рассмотрим главные строительные блоки подсистемы и рассмотрим небольшой пример кода.

3 стартмани

28.01.2013    223304    Evil Beaver    181    

480

Некоторая работа с данными через COM

Механизмы платформы 1С Платформа 1С v8.3 Абонемент ($m)

В статье приведены примеры работы с Платформой 8.X через COM (точнее, через объект COMConnector). Примеры кода были использованы при реализации прикладных задач в процессе трудовой деятельности.

2 стартмани

05.12.2012    63281    wowik    32    

179

74 полезности из комплексного курса по конфигурированию 1С 8.2

Механизмы платформы 1С Платформа 1С v8.3 Россия Абонемент ($m)

Курс прошел в октябре 2011 года. До этого уже была определенная подготовка (прочитал несколько книг, прошел несколько интернет-курсов и подготовился по вопросам к экзамену 1С: Профессионал по платформе 8.2). На этом курсе прошел обучение по 4 темам: основные объекты, оперативный учет, периодические расчеты и бухгалтерский учет. Хочу рассказать вам о том, что было не очевидно для меня. Надеюсь и вам пригодится.

1 стартмани

02.03.2012    13836    Flashill    65    

220