Диадок, модуль 1С - заполнение полей с дополнительной информацией

21.05.21

Интеграция - ЭДО и ОФД

Некоторые контрагенты для настройки электронного обмена документами требуют заполнения специальных полей  ИнфПолФХЖ1 и ИнфПолФХЖ2 дополнительной информацией.

Например:
https://kazan.megastroy.com/edo

- В дополнительном текстовом поле документа ЭДО (XML) должен быть указан GLN магазина «Мегастрой» согласно нижеприведенному примеру:


<ИнфПолФХЖ1>
  <ТекстИнф Идентиф="грузополучатель" Значен="4604985999975" />
  </ИнфПолФХЖ1>
</СвСчФакт>


- В дополнительном текстовом поле табличной части документа ЭДО (XML) должны быть указаны международные штрих-кода номенклатуры EAN-13 или EAN-8 формата согласно нижеприведенном примере:
 

<ТаблСчФакт>
     <СведТов НалСт="X" НомСтр="1" X" ОКЕИ_Тов="X" КолТов="X" ЦенаТов="X" СтТовБезНДС="X" СтТовУчНал="X">
     <Акциз>
        <БезАкциз>X</БезАкциз>
    </Акциз>
    <СумНал>
        <СумНДС>X</СумНДС>
    </СумНал>
    <ИнфПолФХЖ2 Значен="4610001691112" Идентиф="штрихкод"/>
</СведТов>  


Быстро разобраться мне помогла статья - //infostart.ru/1c/articles/1247892/, за что автору этой статьи благодарность. А ниже привожу пример рабочей процедуры в подключаемом модуле:

 

Процедура _ОбработатьДляАгавы(СсылкаНаДокумент, Протоконтент)
      

//в моем случае GLN хранится в доп свойстве документа сч.фактура выданный  - "GLN"    
    _СвойствоGLN = УправлениеСвойствами.НаборСвойствПоИмени("GLN");
    GLN = УправлениеСвойствами.ЗначениеСвойства(СсылкаНаДокумент,_СвойствоGLN);
    //Сообщить(""+СсылкаНаДокумент+" GLN:"+GLN);
     

ДополнитьМассивKeyValue(Протоконтент.AdditionalInfoId.StructedAdditionalInfos, "грузополучатель", Строка(GLN));

    КоллекцияСтрок = Протоконтент.Table.Items;
    
    Для Каждого Элемент Из КоллекцияСтрок Цикл
          
        Номенклатура     = Справочники.Номенклатура.НайтиПоКоду(Элемент.ItemVendorCode);
        
        ШХ = _ПолучитьШтрихКод(Номенклатура);
        Если НЕ ЗначениеЗаполнено(ШХ) Тогда
            Сообщить("("+Номенклатура.Код+") " + Номенклатура.Наименование + " - не указан ШХ!", СтатусСообщения.Важное);
        КонецЕсли;
        
        ДополнитьМассивKeyValue(Элемент.StructedAdditionalInfos
            , "штрихкод"
            , ШХ);
            
        //Сообщить(ШХ); 


    КонецЦикла;
КонецПроцедуры

 

Тестировалось на:

1С:Предприятие 8.3 (8.3.18.1289)

Бухгалтерия предприятия, редакция 3.0 (3.0.89.34) 

Диадок подключаемый модуль ИнфПолФХЖ1 и ИнфПолФХЖ2

См. также.

SALE! 25%

Кассовые операции Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Программист Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Россия Бухгалтерский учет Налоговый учет Управленческий учет Платные (руб)

В публикации размещены специализированные обработки для загрузки кассовых чеков в базах 1С (для локальных баз): '1С:Бухгалтерия предприятия, ред. 3.0', '1С:Управление нашей фирмой 8, ред. 3.0', '1С:Комплексная автоматизация, ред. 2.5', ‘1С:ERP Управление предприятием, ред. 2’ и ‘1С:Управление торговлей, ред. 11.5’. Вы просто сканируете QR коды с бумажных и электронных чеков c помощью мобильного приложения ФНС и чеки автоматически (без ручного ввода) загружаются в документы 'Авансовый отчет', 'Расходы предпринимателя', 'Путевой лист', 'Приходная накладная', 'Поступление (акты, накладные, УПД)', 'Приобретение товаров и услуг', 'Отчет о розничных продажах' и 'Поступление денежных документов'.

12960 9720 руб.

19.08.2020    66318    312    73    

213

Документооборот и делопроизводство (СЭД) ЭДО и ОФД Учет документов Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Мощный, единый инструмент для решения всех проблем, связанных с переходом на ЭДО. Экономит бумагу и время - организует архив оригиналов первичных документов прямо в базе 1С, в прикрепленных файлах к соответствующим документам. С помощью комплексного отчета по ошибкам в ЭДО позволяет выявить и исправить все возможные ошибки - ошибочно сопоставленные документы, не подписанные документы, подписанные, но не загруженные в 1С документы. Автоматически сопоставляет не сопоставленные между собой документы. Может работать по расписанию и присылать отчет о состоянии архива/по ошибкам на почту. Взаимодействует напрямую с сервисами Диадок/СБИС, имеет интуитивно понятный интерфейс и учитывает 3-х летний опыт 40+ клиентов.

14880 руб.

17.12.2018    44844    62    51    

75

Кассовые операции ЭДО и ОФД Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Согласно 54-ФЗ по правилам ведения кассовых операций необходимо оформлять приходные кассовые ордера (ПКО) и расходные кассовые ордера (РКО) на основании чеков ККМ. Все данные о чеках, можно взять на сайте оператора фискальных данных (ОФД). Обработка загрузки данных из ОФД в 1С сделает за вас в 1С - ПКО и РКО, Операции по платежным картам или Отчет о розничных продажах (может создать номенклатуру в 1С, указать налоги и др. реквизиты в документах в зависимости от налогообложения ККМ в торговой точке). Проверено на: OFD.RU / Первый ОФД / Такском / Платформа ОФД / Ярус / ОФД Яндекс / ОФД Астрал /ОФД СБИС / Гарант ОФД / КОРУС ОФД / КОНТУР ОФД / ОФД АО Тандер / ИнитПро / Группа Элемент/

3600 руб.

09.08.2017    149109    876    372    

532

Оптовая торговля Производство готовой продукции (работ, услуг) Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Бухгалтер Платформа 1С v8.3 Бухгалтерский учет Управляемые формы 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Выгрузка УПД, товарной накладной ТОРГ-12, акта, счета-фактуры по реализации (в БП сч-ф на аванс) в xml-файл в формате ФНС приказ 820 от 19.12.2018. Выгрузка УКД и корректировочного счета-фактуры в xml-файл в формате ФНС приказ 736 от 12.10.2020. Выгрузка товарной накладной в xml-файл ФНС приказ 551 от 13.11.2015, редакция 08.04.2019. Выгрузка акта приемки-сдачи работ (услуг) в xml-файл ФНС приказ 552 от 13.11.2015, редакция 08.04.2019. Добавлена выгрузка счетов на оплату по документам ЗаказПокупателя (в УНФ), ЗаказКлинета (в УТ / КА / ERP), СчетНаОплатуПокупателю (в БП). Добавлена обработка Выгрузка УПД c документов реализации 1С в Контур.Диадок по API.

15600 руб.

13.04.2018    83064    394    9    

429

Регламентированный учет и отчетность Обмен с ГосИС ЭДО и ОФД Бухгалтер Пользователь Платформа 1С v8.3 1С:Управление торговлей 11 Оптовая торговля, дистрибуция, логистика Россия Управленческий учет Платные (руб)

Работаете по контрактной схеме, сталкивались с проблемой, что в контракте жестко указаны наименование, цена, единица измерения товара. И не все готовы создавать новую номенклатуру под каждый контракт или менять наименование и единицу измерения для уже имеющейся. Тем более, бывает так, что контракт - это формальность. Контракт не описывает жесткие условия поставки, нужно соблюсти правильность в предоставлении документов. Данное решение позволит вам оперировать своей номенклатурой при оформлении реализаций по государственному контракту в УТ 11.5 и КА 2.5.11, в то же время выводить на печать документы, соответствующие данным контракта. Реализована выгрузка для сайта госзакупок (ЕИС) по 44-ФЗ.

40800 руб.

19.12.2022    10710    20    19    

17

ЭДО и ОФД Файловый обмен (TXT, XML, DBF), FTP Обмен с ГосИС Бухгалтер Пользователь Платформа 1С v8.3 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Россия Бухгалтерский учет Платные (руб)

Групповая выгрузка файлов из 1С в формате XML для ЭДО в каталог по приказу №820 ФНС для Контур.Диадок, СБИС и других провайдеров ЭДО. Поддержка УНФ 1.6, УНФ 3.0 Поддержка УТ 10.3, УПП 1.3 Поддержка Розница 2.3 Добавлена выгрузка непосредственно из документа

18000 руб.

15.12.2022    6981    108    26    

18

ЭДО и ОФД Загрузка и выгрузка в Excel Бухгалтер Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Кто получает документы через Контур.ДиаДок (XML файл формат 820) и набивает их вручную в 1С, тот наверняка хотел бы автоматизировать этот процесс. Поддержка конфигураций: Бухгалтерии 3, УПП 1.3, 1С:КА 2.4 и 1С:КА 2.5, УТ10, УТ11.4 и УТ11.5. Выгрузка XML в формате 820 для диадок из БУХ3

3600 руб.

11.02.2020    89823    286    156    

209
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. charushkin 107 26.05.21 08:16 Сейчас в теме
Привет!

Ссылка на номенклатуру можно получить так:

СлужебнаяИнформация = Элемент.СлужебнаяИнформация; // структура с полями "Номенклатура", "Характеристика" и "Упаковка"
Номенклатура = СлужебнаяИнформация.Номенклатура;
2. _Vovik 97 26.05.21 22:38 Сейчас в теме
Привет!
Спасибо за замечание. Надо будет посмотреть.
3. serge_msk 181 21.06.21 10:07 Сейчас в теме
Спасибо за полезную статью!
сделал модуль для Азбуки Вкуса
4. _Vovik 97 21.06.21 13:12 Сейчас в теме
5. MrWashington 09.07.21 18:35 Сейчас в теме
(4) Добрый день ! Помогите разобраться как всё таки заполнить эти поля ИнфПолФХЖ1 и ИнфПолФХЖ2 , из описания разработчика не понятно где это заполняется. В вашем примере тоже не понимаю, мне нужно в УПД заполнить данные поля, помогите примером или твкныте пальцем где это заполняется . Можно за денежку
гыук320; CharoChes1; COMPER; +3 Ответить
6. _Vovik 97 09.07.21 20:28 Сейчас в теме
Качаете модуль 1с
Настраиваете обработку "подключаемый модуль" как в этой статье:
https://infostart.ru/1c/articles/1247892/
В подключаемом модуле так же как в этой статье:
Процедура ОбработатьСобытиеПослеЗаполненияКонтента(Параметры)
	
	ТипыКонтента = ТипыКонтента();
	
	СсылкаНаДокумент			 = Параметры.ДокументСсылка;
	Протоконтент				 = Параметры.Content;
	ТипКонтента					 = Параметры.ТипКонтента;
	ПараметрыФормированияФайла	 = Параметры.ПараметрыФормированияФайла;
	
	Если ТипКонтента = ТипыКонтента.Utd820SellerContent Тогда
		
		//ПримерОбработкиУПД820(СсылкаНаДокумент, Протоконтент);
		//-->
		_ОбработатьДляАгавы(СсылкаНаДокумент, Протоконтент);
		//--<
...
Показать
7. _Vovik 97 09.07.21 20:29 Сейчас в теме
ДополнитьМассивKeyValue(Протоконтент.AdditionalInfoId.StructedAdditionalInfos, "грузополучатель", Строка(GLN));
ДополнитьМассивKeyValue(Элемент.StructedAdditionalInfos
, "штрихкод"
, ШХ);

эти строки и есть заполнение этих полей.
MrWashington; +1 Ответить
8. MrWashington 10.07.21 01:29 Сейчас в теме
(7)Спасибо огромное , всё получилось , только добавляю строки в функции ПодготовитьЭлектронныйДокумент . Вроде как тут рекомендуют заполнять из описания разработчика к модулю.
9. _Vovik 97 10.07.21 10:19 Сейчас в теме
(8) Пожалуйста. Может быть, мне не попадалось описание разработчика.
10. lavkz 16.03.22 20:09 Сейчас в теме
добрый день. подскажите пожалуйста. требуется заполнение 2х дополнительных полей.
<ИнфПолФХЖ1>
<ТекстИнф Значен="0207,,Идентиф="номер_тк"/>
<ТекстИнф Значен="S,,Идентиф="код_получателя"/>
<ИнфПолФХЖ1>
Как мне это сделать?
Прикрепленные файлы:
11. wildsery 06.04.22 17:14 Сейчас в теме
(10) Нет никакой разницы, сколько дополнительных полей в разделе.
Там всё равно массив, если бы вы посмотрели в отладчике.

ДополнитьМассивKeyValue(Протоконтент.AdditionalInfoId.StructedAdditionalInfos, "номер_тк", "0207");
ДополнитьМассивKeyValue(Протоконтент.AdditionalInfoId.StructedAdditionalInfos, "код_получателя", "S");
12. SelivanovV 27.07.22 13:22 Сейчас в теме
Здравствуйте, как объект XDTO перевести в структуру
13. MrWashington 27.07.22 17:02 Сейчас в теме
(12)В БСП есть ОбщийМодуль.ОбменДаннымиXDTOСервер , там функция ОбъектXDTOВСтруктуру(ОбъектXDTO, КомпонентыОбмена) Экспорт , который выполняет преобразование объекта XDTO в структуру с данными.
14. _Vovik 97 12.08.22 23:08 Сейчас в теме
Модуль Диадока обновился. Новый рабочий код подключаемого модуля (целиком):


Перем ОсновнойМодуль Экспорт;

Процедура УПД_ДобавитьИнфПолФХЖ1(Content, Key, Value)
	
	Если НЕ ЗначениеЗаполнено(Value) Тогда
		Возврат;
	КонецЕсли;
	
	AdditionalInfoId = Content.AdditionalInfoId;
	
	ОсновнойМодуль.ДобавитьИнформационноеПоле(AdditionalInfoId, Key, Value);

КонецПроцедуры

//-->20210516 
Функция _ПолучитьШтрихКод(_номенклатура)
	Если НЕ ЗначениеЗаполнено(_номенклатура) Тогда
		Возврат Неопределено;
	КонецЕсли;
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
					|	ШтрихкодыНоменклатуры.Штрихкод КАК Штрихкод
					|ИЗ
					|	РегистрСведений.ШтрихкодыНоменклатуры КАК ШтрихкодыНоменклатуры
					|ГДЕ
					|	ШтрихкодыНоменклатуры.Номенклатура = &Номенклатура";
	Запрос.УстановитьПараметр("Номенклатура",_номенклатура);
	Рез = Запрос.Выполнить().Выгрузить();
	Если Рез.Количество()=0 Тогда
		Сообщить("Не указан ШК: ("+_номенклатура.Код+") "+_номенклатура.Наименование,СтатусСообщения.Важное);
	Иначе
		Возврат СокрЛП(Рез[0].Штрихкод);
	КонецЕсли;

	
КонецФункции

// Обработка заполнения контента в формате приказа ММВ-7-15/820@.
//
// Параметры:
//  СсылкаНаДокумент - ЛюбаяСсылка	 - ссылка на документ информационной базы;
//  Протоконтент	 - Структура	 - http://1c-pro-docs.diadoc.ru/ru/latest/objects/Utd820SellerContent.html
//
Процедура _ОбработатьДляАгавы(СсылкаНаДокумент, Протоконтент)
			
	_СвойствоGLN = УправлениеСвойствами.НаборСвойствПоИмени("GLN");
	GLN = УправлениеСвойствами.ЗначениеСвойства(СсылкаНаДокумент,_СвойствоGLN);
	Сообщить(""+СсылкаНаДокумент+" GLN:"+GLN);
	
	УПД_ДобавитьИнфПолФХЖ1(Протоконтент, "грузополучатель", Строка(GLN));	
			
	КоллекцияСтрок = Протоконтент.Table.Items;
		
	Для Каждого Элемент Из КоллекцияСтрок Цикл
		
		Номенклатура	 = Справочники.Номенклатура.НайтиПоКоду(Элемент.ItemVendorCode);
		
		ШХ = _ПолучитьШтрихКод(Номенклатура);
		Если НЕ ЗначениеЗаполнено(ШХ) Тогда
			Сообщить("("+Номенклатура.Код+") " + Номенклатура.Наименование + " - не указан ШХ!", СтатусСообщения.Важное);
		КонецЕсли;
		
		Если ЗначениеЗаполнено(ШХ) Тогда
			ОсновнойМодуль.ДобавитьИнформационноеПоле(Элемент, "штрихкод", ШХ);  
		КонецЕсли;		
		
	КонецЦикла;

КонецПроцедуры
//--<

Функция ОбработатьСобытие(ИмяСобытия, Параметры) Экспорт

	Если ИмяСобытия = "ПодготовитьЭлектронныйДокумент" Тогда
		Возврат ПодготовитьЭлектронныйДокумент(Параметры);
	КонецЕсли;
	
КонецФункции


// Обработчики событий подключаемого модуля

Функция ПодготовитьЭлектронныйДокумент(Параметры)

	// Имя шаблона: Произвольное изменение контента УПД
	Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда
				
		Content		= Параметры.Результат.Content;
		Документ1С 	= Параметры.Результат.Документ1С;

		ВидДокументаРазвернутый = Параметры.ВидДокументаРазвернутый;
		
		ТипКонтента_XDTO = ВидДокументаРазвернутый.ТипКонтента;
		
		Если ВРЕГ(ТипКонтента_XDTO) = ВРЕГ("Utd820SellerContent") Тогда
			
			_ОбработатьДляАгавы(Документ1С, Content);

		КонецЕсли;

		//Возврат Истина;

	КонецЕсли;

КонецФункции

  
// Общие функции для использования в обработчиках событий



// Методы работы с XDTO



// общие функции подключаемого модуля (БСП и взаимодействие с основным модулем)

Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = Новый Структура;
	ПараметрыРегистрации.Вставить("Вид",			 	"ДополнительнаяОбработка");
	ПараметрыРегистрации.Вставить("Наименование", 		"Диадок (СКБ Контур): Подключаемый модуль");
	ПараметрыРегистрации.Вставить("БезопасныйРежим", 	Ложь);
	ПараметрыРегистрации.Вставить("Версия", 			ЭДО_ВерсияAPIПодключаемогоМодуля());
	ПараметрыРегистрации.Вставить("Информация", 		"Модуль работы с электронными первичными документами через Диадок (подключаемая часть)");
	
	ТаблицаКоманд = ПолучитьТаблицуКоманд();
	
	ДобавитьКоманду(ТаблицаКоманд, "Выполнение регламентных операций подключаемого модуля Диадок", "ВыполнитьРегламентныеДействияПМ", "ВызовСерверногоМетода");
	
	ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
	
	Возврат ПараметрыРегистрации;
	
КонецФункции

Функция ПолучитьТаблицуКоманд()
	
	Команды = Новый ТаблицаЗначений;
	
	Команды.Колонки.Добавить("Представление", 			Новый ОписаниеТипов("Строка")); 
	Команды.Колонки.Добавить("Идентификатор", 			Новый ОписаниеТипов("Строка"));
	Команды.Колонки.Добавить("Использование", 			Новый ОписаниеТипов("Строка"));
	Команды.Колонки.Добавить("ПоказыватьОповещение", 	Новый ОписаниеТипов("Булево"));
	Команды.Колонки.Добавить("Модификатор", 			Новый ОписаниеТипов("Строка"));
	
	Возврат Команды;
	
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
	
	НоваяКоманда						= ТаблицаКоманд.Добавить();
	НоваяКоманда.Представление			= Представление;
	НоваяКоманда.Идентификатор			= Идентификатор;
	НоваяКоманда.Использование			= Использование;
	НоваяКоманда.ПоказыватьОповещение	= ПоказыватьОповещение;
	НоваяКоманда.Модификатор			= Модификатор;
	
КонецПроцедуры

Процедура ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыВыполненияКоманды = Неопределено) Экспорт
	
	Если ИдентификаторКоманды = "ВыполнитьРегламентныеДействияПМ" Тогда
		ВыполнитьРегламентныеДействияПМ(ПараметрыВыполненияКоманды);
	КонецЕсли;
	
КонецПроцедуры

Процедура ВыполнитьРегламентныеДействияПМ(Параметры)
	// Регламентные действия, НЕ требующие инициализации основного модуля
КонецПроцедуры

Функция ЭДО_ВерсияAPIПодключаемогоМодуля() Экспорт
	
	Возврат 4;
	
КонецФункции

Процедура ЭДО_СлужебнаяИнформацияГенератораШаблона()

	// Данный метод не выполняет кода и содержит только настройки построителя ПМ в момент генерации кода.
	// Предназначен для облегчения анализа изменений реального кода относительно шаблона.
	
	// ВерсияПостроителя: 0.5.6
	//{ Сценарии
	// Произвольное изменение контента УПД
	//} Сценарии

КонецПроцедуры
Показать
bugtester; +1 Ответить
18. swi76 23.09.22 08:44 Сейчас в теме
(14)Почему то упорно игнорирует УКД


// Имя шаблона: Изменение таблицы товаров УКД (УТ 10), основные поля
Если ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда

Content = Параметры.Результат.Content;
Документ1С = Параметры.Результат.Документ1С;

ВидДокументаРазвернутый = Параметры.ВидДокументаРазвернутый;

ТипКонтента_XDTO = ВидДокументаРазвернутый.ТипКонтента;

Если ВРЕГ(ТипКонтента_XDTO) = ВРЕГ("UcdSellerContent") тогда


УКД_ИзменитьДанныеТоваров(Content, Документ1С);


КонецЕсли;

Возврат Истина;

КонецЕсли;


параметры находит они читаются а вот Параметры.Свойство неопределено , УПД проходит ,
УКД не проходит условие Если "ТипЗнч(Параметры) = Тип("Структура") И Параметры.Свойство("Результат_ИМ") Тогда"

убираем Параметры.Свойство("Результат_ИМ") тогда нет данных по контрагенту
15. swi76 19.09.22 10:03 Сейчас в теме
А чтобы в УКД выводилось поле ИнфПолФХЖ2 выводилось , что нужно писать
16. _Vovik 97 19.09.22 13:41 Сейчас в теме
(15) ОсновнойМодуль.ДобавитьИнформационноеПоле(Элемент, "штрихкод", ШХ);
17. swi76 21.09.22 03:03 Сейчас в теме
УПД это ВРЕГ("Utd820SellerContent")

А УКД Что тогда
19. user787726 24.10.22 14:05 Сейчас в теме
Подскажите, как на текущей версии подключаемого модуля добавить доп реквизит ИнфПолФХЖ2 ?
20. MrWashington 24.10.22 17:18 Сейчас в теме
(19) Согласно документации в подключаемом модуле в модуле менеджера ПодготовитьЭлектронныйДокумент(Параметры)
21. user787726 25.10.22 12:27 Сейчас в теме
(20) У нас обычные формы.
Получилось так:
Подключаемый модуль, модуль объекта:

Процедура Заполнить_Item(Контент, СтрокаТЧ, ФункцияДокумента, Услуга, Документ1С)

Если НЕ Услуга Тогда
Если ЗначениеЗаполнено(СтрокаТЧ.СерияНоменклатуры) и ЗначениеЗаполнено(СтрокаТЧ.СерияНоменклатуры.НомерГТД) и ЗначениеЗаполнено(СтрокаТЧ.СерияНоменклатуры.СтранаПроисхождения) Тогда
НовЭлемент = НовыйЭлементСпискаXDTO(Контент.CustomDeclarations);
Заполнить_CustomDeclaration(НовЭлемент, СтрокаТЧ.СерияНоменклатуры.СтранаПроисхождения.Код, СтрокаТЧ.СерияНоменклатуры.НомерГТД.Код);
КонецЕсли;

Если ЗначениеЗаполнено(СтрокаТЧ.Номенклатура.ДатаНачалаМаркировки) и Документ1С.Дата > СтрокаТЧ.Номенклатура.ДатаНачалаМаркировки ТОгда
ШКДляОСУ = ПолучитьКодМаркировки(СтрокаТЧ.Номенклатура,СтрокаТЧ.СерияНоменклатуры, СтрокаТЧ.ЕдиницаИзмерения);
Если ЗначениеЗаполнено(ШКДляОСУ) Тогда
НовЭлемент = НовыйЭлементСпискаXDTO(Контент.ItemIdentificationNumbers);
Заполнить_ItemIdentificationNumber(НовЭлемент, "020"+ШКДляОСУ+"37"+ СтрЗаменить(Строка(Контент.Quantity),Символы.НПП,""));
КонецЕсли;
КонецЕсли;

//Ольга 24.10.22
Если Документ1С.Контрагент.ИНН = "100*******" Тогда
ШК = ПолучитьКодМаркировки(СтрокаТЧ.Номенклатура,СтрокаТЧ.СерияНоменклатуры, СтрокаТЧ.ЕдиницаИзмерения);
Если ЗначениеЗаполнено(ШК) Тогда
НовЭлемент = НовыйЭлементСпискаXDTO(Контент.StructedAdditionalInfos);
Заполнить_StructedAdditionalInfos (НовЭлемент,"штрихкод", ШК);
КонецЕсли;
КонецЕсли;
//Ольга 24.10.22

КонецЕсли;


В итоге в теге ИнфПолФХЖ2 добавляется Значение равное штрихкоду и идентификатор = "штрихкод".
22. babys 90 16.11.22 10:23 Сейчас в теме
Кто подскажет как правильно переопределить КПП в отправляемой счёт-фактуре?
23. babys 90 16.11.22 18:18 Сейчас в теме
(22) Контент.Sellers[0].Kpp = Параметры.Результат.Документ1С.ДокументОснование.Грузоотправитель.КПП
24. user672223_econ 14.06.23 03:33 Сейчас в теме
(14) Огромное спасибо. Очень-очень помогло.
25. McMurphyTV 17.10.23 13:42 Сейчас в теме
Добрый день! А как добавить ИДФайлИнфПол перед ТекстИнф?
26. Denosik 21.03.24 16:41 Сейчас в теме
Можете помочь? Как заполнять поле "Иные сведения" в УКД, не могу разобраться...
27. MrWashington 21.03.24 16:44 Сейчас в теме
28. Denosik 26.03.24 11:28 Сейчас в теме
(27)Да вот уже начитался на разных форумах. Генератор подключаемого модуля тут не помогает
29. MrWashington 26.03.24 11:33 Сейчас в теме
(28) Ну так "Генератор" как пример и статья доходчиво объясняет как вносить изменения в модуль не трогая сам модуль. Всё просто и понятно
30. Denosik 26.03.24 11:40 Сейчас в теме
(29) Верно, но как вносить изменения я уже понял. Но это касаются только инфополей, что до этого заполнялись и они записаны в XML в Content. Иные данные не заполнялись изначально, поэтому возможно в XML даже тега на это поле нет
31. MrWashington 26.03.24 11:44 Сейчас в теме
32. MrWashington 26.03.24 11:59 Сейчас в теме
(30)Дам тебе подсказку, поле "ИнфПолФХЖ3" это будет Коллекция AdditionalInfoItem , с индентификатором "СтПерИнф" то что тебе нужно ) так что там всё есть
Оставьте свое сообщение