Вертикальная автофиксация для СКД

28.08.10

Разработка - Работа с интерфейсом

В СКД очень не хватает возможности автофиксации строк. Обусловлено это невозможностью однозначно определить их количество в общем случае. Однако в большинстве случаев это можно сделать

Обращаю ваше внимание, что приведенная процедура работает не всегда корректно. Но в большинстве случаев она сделает свое дело.

// Выводит результат СКД с установкой вертикальной автофиксации.
// Параметры:
// Таб - ТабличныеДокумент, ПолеТабличногоДокумента - куда выводим отчет;
// ПроцессорКомпоновкиДанных - ПроцессорКомпоновкиДанных;
// ЭлементыРасшировки - ЭлементыРасшифровкиКомпоновкиДанных;
// МассивИгнорируемыхПолей - Массив, *Неопределено - массив имен игнорируемых полей;
// РазрешитьПрерывание - Булево, *Истина.
//
Процедура ЛксВывестиРезультатКомпоновкиСАвтофиксациейСтрок(Таб, ПроцессорКомпоновкиДанных, ЭлементыРасшировки,
 Знач МассивИгнорируемыхПолей = Неопределено, РазрешитьПрерывание = Истина) Экспорт 
 
 ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
 ПроцессорВывода.УстановитьДокумент(Таб);
 ПроцессорВывода.НачатьВывод();
 ФиксацияВыполнена = Ложь;
 Если МассивИгнорируемыхПолей = Неопределено Тогда
  МассивИгнорируемыхПолей = Новый Массив;
 КонецЕсли; 
 Пока Истина Цикл
  ЭлементРезультатаКомпоновкиДанных = ПроцессорКомпоновкиДанных.Следующий();
  Если ЭлементРезультатаКомпоновкиДанных = Неопределено Тогда
  Прервать;
  КонецЕсли;
  
  // Автофиксация
  Если Не ФиксацияВыполнена Тогда
  Для Каждого ЗначениеПараметра Из ЭлементРезультатаКомпоновкиДанных.ЗначенияПараметров Цикл
  Если ТипЗнч(ЗначениеПараметра.Значение) = Тип("ИдентификаторРасшифровкиКомпоновкиДанных") Тогда
  ЗначенияПолейРасшифровки = ЭлементыРасшировки[ЗначениеПараметра.Значение].ПолучитьПоля();
  Для Каждого ЗначениеПоляРасшифровки Из ЗначенияПолейРасшифровки Цикл
  Если МассивИгнорируемыхПолей.Найти(ЗначениеПоляРасшифровки.Поле) = Неопределено Тогда
  Таб.ФиксацияСверху = Таб.ВысотаТаблицы;
  ФиксацияВыполнена = Истина;
  Прервать;
  КонецЕсли;
  КонецЦикла;
  Если ФиксацияВыполнена Тогда
  Прервать;
  КонецЕсли;
  КонецЕсли;
  КонецЦикла;
  КонецЕсли;
  
  ПроцессорВывода.ВывестиЭлемент(ЭлементРезультатаКомпоновкиДанных);
  Если РазрешитьПрерывание Тогда
  ОбработкаПрерыванияПользователя();
  КонецЕсли; 
 КонецЦикла;
 ПроцессорВывода.ЗакончитьВывод();
 
КонецПроцедуры // ЛксВывестиРезультатКомпоновкиСАвтофиксациейСтрок

См. также

Богатый редактор картинок, хранимых в базе, с возможностью РИСОВАНИЯ. Редактор внешних файлов картинок. Объект, расширяющий возможности работы с картинками из встроенного языка (Три в одном) + Обработка «Стандартизация картинок»

Работа с интерфейсом Рабочее место Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Платные (руб)

Обработка предназначена для редактирования картинок в режиме «Предприятие», с возможностью РИСОВАТЬ на них. Поддерживается работа как в обычных формах (толстый клиент) так и на управляемых формах (тонкий клиент). Обработка позволяет редактировать как картинки, хранимые в базе, так и графические файлы с диска на файловой системе. Помимо базовых функций (изменение размеров, преобразование формата, обрезание картинки, повороты и т.п.) – редактор имеет богатый набор инструментов для рисования. Доступна функция вставки изображения из буфера обмена. Также обработка может быть использована из встроенного языка как объект для редактирования картинок. Объект может быть использован: на стороне клиента, на стороне сервера, из внешнего соединения. Данная обработка будет особенно полезна тем, кто вносит картинки в базу (изображения номенклатуры, фотографии физических лиц и т.п.). Функционал реализуется с использованием JavaScript и бесплатного ПО ImageMagick (без использования внешних компонент).

6000 руб.

16.01.2015    62012    43    59    

81

[Расширения] Динамическое управление видимостью и доступностью элементов форм (УФ) (8.3.6+)

Работа с интерфейсом Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Платные (руб)

Механизм «Динамическое управление доступом к элементам форм объектов 1С8» предназначен для обеспечения возможности оперативного управления видимостью и доступностью элементов форм документов и справочников продуктов фирмы «1С» «1С:Предприятие 8». Решение универсальное, встраивается в любую конфигурацию с минимальными доработками, что позволяет без проблем обновлять типовые решения.

5000 руб.

14.01.2016    54638    16    21    

42

Управление дашбордами

Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Обработка предназначена для создания и управления дашбордами.

2400 руб.

29.06.2020    16865    21    4    

35

Новогоднее оформление для 1С

Работа с интерфейсом Платформа 1С v8.3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Зарплата и Управление Персоналом 3.x 1С:Управление нашей фирмой 3.0 Бесплатно (free)

Добавьте новогоднего настроения! Расширение создает декорацию в виде гирлянды на некоторых формах объектов.

27.12.2023    11092    759    elcoan    45    

106

Конструктор HTML, CSS и javascript

Инструментарий разработчика Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Подходит для создания web-страниц для замены управляемых форм 1С, красивых отчетов, интерфейса мобильного приложения на платформе 1С и для простых страниц веб-сайтов.

2 стартмани

10.04.2023    9849    153    acces969    31    

119

Модель состояния для MVC

Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

"MVC плохо применима в 1С" - познакомьтесь с моделью состояния и, возможно, ваше мнение поменяется! Представленное решение является эволюционным развитием идеи реализации MVC для 1С. В новой версии добавлены DSL для описания модели состояния, а также параметризация свойств параметров и элементов формы.

1 стартмани

05.07.2022    3899    kalyaka    4    

29

Табло очереди заказов на экран телевизора

WEB-интеграция Работа с интерфейсом Платформа 1С v8.3 1С:Розница 2 Платные (руб)

Связка из веб-приложения и расширения для 1С: Розница 2.3.

3600 руб.

29.04.2022    12253    1    5    

10

Условное оформление элементов форм в пользовательском режиме 1С (управление видимостью и доступностью элементов форм)

Работа с интерфейсом Платформа 1С v8.3 Платные (руб)

Подсистема условного оформления элементов форм (далее подсистема) предназначена для настройки оформления элементов форм (видимость, доступность, цвет фона, цвет текста и прочее) в пользовательском режиме 1С. Также подсистему возможно использовать для ограничения доступа к реквизитам формы для определенных пользователей (или групп пользователей).

6000 руб.

18.01.2022    8916    1    2    

6
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. пользователь 20.12.08 14:14
Сообщение было скрыто модератором.
...
2. tormozit 7143 25.12.08 22:22 Сейчас в теме
Вот параметры вывода, которые влияют на корректность работы:
Выводить заголовок
Выводить параметры данных
Выводить отбор

Для каждого надо делать "смещение". Попробую решить эту проблему
3. tormozit 7143 25.12.08 22:49 Сейчас в теме
Сделал намного более интеллектуальный анализ. Теперь (2) не влияет на корректность определения.
12. Fargoth 03.09.09 20:13 Сейчас в теме
(3) А как бы листинг намного более интеллектуального анализа получить?
13. tormozit 7143 04.09.09 09:47 Сейчас в теме
(12) Он здесь (синим цветом).
14. Fargoth 04.09.09 16:53 Сейчас в теме
(13) А чего то оно мне при использовании вывода параметров не корректно высоту шапки определяет...
4. alexeys81@ukr.net 65 15.01.09 17:34 Сейчас в теме
Я чо-то туплю. А как получить ПроцессорКомпоновкиДанных, чтобы передать его в процелуру ЛксВывестиРезультатКомпоновкиСАвтофиксациейСтрок()?
5. alexeys81@ukr.net 65 15.01.09 18:18 Сейчас в теме
Сорри, уже вдуплил. Отлично всё работает!
6. alexeys81@ukr.net 65 16.01.09 10:52 Сейчас в теме
Ещё вопросик. Отчёт выводится, строки фиксируются, но пропала расшифровка. Когда кликаю по какой-либо ячейке, чтобы расшифровать, никакое меню не выпадает. Выскакивает окно с кодом элемента. Что делаю не так? Вызываю указанную процедуру из отчёта след образом:

Перем ДанныеРасшифровки;
ЭлементыФормы.Результат.Очистить();
КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновкиДанных = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.Настройки, ДанныеРасшифровки);
ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновкиДанных,, ДанныеРасшифровки);
ЛксВывестиРезультатКомпоновкиСАвтофиксациейСтрок(ЭлементыФормы.Результат, ПроцессорКомпоновкиДанных, ДанныеРасшифровки.Элементы);
7. therva 55 31.05.09 21:37 Сейчас в теме
(6) Переменную "ДанныеРасшифровки" нужно создавать конструктором:

Процедура ДействияФормыДействиеСформировать(Кнопка)
// Вставить содержимое обработчика.

ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;

КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;

ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;


ЭлементыФормы.Результат.Очистить();


МакетКомпоновкиДанных = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, КомпоновщикНастроек.Настройки, ДанныеРасшифровки);

ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновкиДанных,,ДанныеРасшифровки);

ВывестиРезультатКомпоновкиСАвтофиксациейСтрок(ЭлементыФормы.Результат, ПроцессорКомпоновкиДанных, ДанныеРасшифровки.Элементы);

КонецПроцедуры
8. anig99 2843 03.06.09 09:39 Сейчас в теме
Ещё бы сделать автофиксацию первой колонки
9. Defor 107 08.08.09 16:10 Сейчас в теме
Предлагаю фиксацию устанавливать при анализе ячеек результата:

// Автофиксация таблицы
//
// Параметры
// Результат - <Тип.ТабличныйДокумент> - Табличный документ формы
Процедура Автофиксация(Результат)

Для индСтр=1 По Результат.ВысотаТаблицы Цикл
Для индКол=1 По Результат.ШиринаТаблицы Цикл
Ячейка = Результат.Область("R"+индСтр+"C"+индКол);
Если не Ячейка.Расшифровка = Неопределено Тогда
Результат.ФиксацияСверху = индСтр - 1;
возврат;
КонецЕсли;
КонецЦикла;
КонецЦикла;

КонецПроцедуры
10. tormozit 7143 11.08.09 12:48 Сейчас в теме
(9) Можно, но зачем 2 раза вместо одного обходить возможно огромный табличный документ?
11. Defor 107 17.08.09 12:25 Сейчас в теме
Обход происходит только до первой ячейки, в которой имеется расшифровка.

В принципе можно оставить перебор только строк.

До конца цикла выполнение произойдет только в том случае когда отчет пустой.
15. mevgenym 87 14.09.09 10:38 Сейчас в теме
вариант из типовых

Если Не ТаблицаЗафиксирована
И ЭлементРезультата.ЗначенияПараметров.Количество() > 0
И ТипЗнч(КомпоновщикНастроек.Настройки.Структура[0]) <> Тип("ДиаграммаКомпоновкиДанных") Тогда

ТаблицаЗафиксирована = Истина;

ДокументРезультат.ФиксацияСверху = ДокументРезультат.ВысотаТаблицы;

КонецЕсли;
16. 1СПрограммер 17.09.09 10:33 Сейчас в теме
у меня постоянно пишет, что не может найти макет ;(((

{Отчет.БДДС.Форма.ФормаОтчета(301)}: Ошибка при вызове метода контекста (Вывести): Ошибка вывода результата
ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);
по причине:
Ошибка вывода результата
по причине:
Макет не найден "Макет1"
17. tormozit 7143 17.09.09 11:01 Сейчас в теме
Теперь будем вообще все ошибки по СКД писать сюда?) Лучше их писать в форуме.
18. n949eo 09.11.11 12:07 Сейчас в теме
Оставьте свое сообщение