Новогоднее оформление для 1С

27.12.23

Разработка - Работа с интерфейсом

Добавьте новогоднего настроения! Расширение создает декорацию в виде гирлянды на некоторых формах объектов.

Скачать исходный код

Наименование Файл Версия Размер
Новогоднее оформление для 1С
.cfe 25,97Kb
759
.cfe 25,97Kb 759 Скачать бесплатно

Создал простое расширение, которое добавляет на формы новогоднюю гирлянду. Выглядит очень необычно и радует окружающих)

 

 

 

 

Проверено на конфигурациях:

1. Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.144.49) 
2. Управление торговлей, редакция 11 (11.5.15.57)
3. Зарплата и управление персоналом КОРП, редакция 3.1 (3.1.28.60) 
4. Управление нашей фирмой, редакция 3.0 (3.0.6.126) 

Установка: добавить расширение, снять флажок "Безопасный режим".

Хорошего дня!

Проверено на следующих конфигурациях и релизах:

  • Бухгалтерия предприятия, редакция 3.0, релизы 3.1.22.86
  • Управление торговлей, редакция 11, релизы 11.5.15.57
  • Зарплата и управление персоналом, редакция 3.1, релизы 3.1.28.60
  • Управление нашей фирмой, редакция 3.0, релизы 3.0.6.126

новый год новогоднее оформление мандарины шампанское

См. также

Богатый редактор картинок, хранимых в базе, с возможностью РИСОВАНИЯ. Редактор внешних файлов картинок. Объект, расширяющий возможности работы с картинками из встроенного языка (Три в одном) + Обработка «Стандартизация картинок»

Работа с интерфейсом Рабочее место Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Платные (руб)

Обработка предназначена для редактирования картинок в режиме «Предприятие», с возможностью РИСОВАТЬ на них. Поддерживается работа как в обычных формах (толстый клиент) так и на управляемых формах (тонкий клиент). Обработка позволяет редактировать как картинки, хранимые в базе, так и графические файлы с диска на файловой системе. Помимо базовых функций (изменение размеров, преобразование формата, обрезание картинки, повороты и т.п.) – редактор имеет богатый набор инструментов для рисования. Доступна функция вставки изображения из буфера обмена. Также обработка может быть использована из встроенного языка как объект для редактирования картинок. Объект может быть использован: на стороне клиента, на стороне сервера, из внешнего соединения. Данная обработка будет особенно полезна тем, кто вносит картинки в базу (изображения номенклатуры, фотографии физических лиц и т.п.). Функционал реализуется с использованием JavaScript и бесплатного ПО ImageMagick (без использования внешних компонент).

6000 руб.

16.01.2015    62021    43    59    

81

[Расширения] Динамическое управление видимостью и доступностью элементов форм (УФ) (8.3.6+)

Работа с интерфейсом Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Платные (руб)

Механизм «Динамическое управление доступом к элементам форм объектов 1С8» предназначен для обеспечения возможности оперативного управления видимостью и доступностью элементов форм документов и справочников продуктов фирмы «1С» «1С:Предприятие 8». Решение универсальное, встраивается в любую конфигурацию с минимальными доработками, что позволяет без проблем обновлять типовые решения.

5000 руб.

14.01.2016    54647    16    21    

42

Управление дашбордами

Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Обработка предназначена для создания и управления дашбордами.

2400 руб.

29.06.2020    16874    21    4    

35

Конструктор HTML, CSS и javascript

Инструментарий разработчика Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Подходит для создания web-страниц для замены управляемых форм 1С, красивых отчетов, интерфейса мобильного приложения на платформе 1С и для простых страниц веб-сайтов.

2 стартмани

10.04.2023    9855    153    acces969    31    

119

Модель состояния для MVC

Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

"MVC плохо применима в 1С" - познакомьтесь с моделью состояния и, возможно, ваше мнение поменяется! Представленное решение является эволюционным развитием идеи реализации MVC для 1С. В новой версии добавлены DSL для описания модели состояния, а также параметризация свойств параметров и элементов формы.

1 стартмани

05.07.2022    3904    kalyaka    4    

29

Табло очереди заказов на экран телевизора

WEB-интеграция Работа с интерфейсом Платформа 1С v8.3 1С:Розница 2 Платные (руб)

Связка из веб-приложения и расширения для 1С: Розница 2.3.

3600 руб.

29.04.2022    12263    1    5    

10

Условное оформление элементов форм в пользовательском режиме 1С (управление видимостью и доступностью элементов форм)

Работа с интерфейсом Платформа 1С v8.3 Платные (руб)

Подсистема условного оформления элементов форм (далее подсистема) предназначена для настройки оформления элементов форм (видимость, доступность, цвет фона, цвет текста и прочее) в пользовательском режиме 1С. Также подсистему возможно использовать для ограничения доступа к реквизитам формы для определенных пользователей (или групп пользователей).

6000 руб.

18.01.2022    8926    1    2    

6

Программный интерфейс для доработки форм

Работа с интерфейсом Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Реализовал простой способ программного создания новых элементов, команд и реквизитов на форме.

25.11.2021    9612    AtamanovYS    19    

139
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Sofia9876 27.12.23 13:56 Сейчас в теме
Огонь! Супер! Спасибо! С наступающим!)
osipovnv; elcoan; +2 Ответить
2. AllShallFall 27.12.23 14:08 Сейчас в теме
УНФ 1.6.27.295 - не выводилось на формах списков.
решилось удалением "знач" в расширенном модуле ПодключаемыеКоманды процедуры нг_ПриСозданииНаСервере.

за расширение - спасибо) !
osipovnv; Lemmonbri; elcoan; +3 Ответить
3. Lemmonbri 120 27.12.23 14:17 Сейчас в теме
На отраслевых или более старых версиях тоже запуститься с минимальными доработками - на версии 8.3.17 УТиВСК запустилось с минимальными правками.
В отчетах без форм не работает (обычно самописные или отраслевые). В самописных формах так же может не запуститься, но все решается быстро добавлением декорации вручную)
osipovnv; elcoan; +2 Ответить
4. Aleksey79 27.12.23 15:18 Сейчас в теме
Спасибо! С наступающим!
osipovnv; elcoan; +2 Ответить
5. SerVer1C 756 27.12.23 16:06 Сейчас в теме
На Инфостарте такая же гирлянда. Совпадение?
osipovnv; Serg O.; elcoan; +3 Ответить
6. elcoan 1003 27.12.23 16:26 Сейчас в теме
(5) Вдохновлялся именно ею)
osipovnv; Aleksey79; +2 Ответить
10. SerVer1C 756 27.12.23 17:26 Сейчас в теме
(6) Друзья, для бОльшего эффекта праздника держите "живую" гирлянду.
mangust4; dbachinsky; MrBukas; Aleksey79; shunk; elcoan; +6 Ответить
7. gtrr34 6 27.12.23 16:37 Сейчас в теме
Спасибо большое! Вот чего не хватало для настроения!!!

В мелком масштабе правильное отображение появилось после внесения правок в модуль "нг_ОбщегоНазначения"

// Было
	//НовыйЭлемент.Масштабировать = Истина;
	//НовыйЭлемент.Масштаб = 50;
	//НовыйЭлемент.Высота  = 1;

	// Стало
	Если ВариантМасштабаФормКлиентскогоПриложения = 
		ВариантМасштабаФормКлиентскогоПриложения.Обычный Тогда
		НовыйЭлемент.Масштабировать = Истина;
		НовыйЭлемент.Масштаб = 50;
		НовыйЭлемент.Высота  = 1;
	ИначеЕсли ВариантМасштабаФормКлиентскогоПриложения = 
		ВариантМасштабаФормКлиентскогоПриложения.Компактный Тогда
		НовыйЭлемент.Высота  = 2;
	КонецЕсли;
Показать


Так же из-за внесения расширения методом объединить/сравнить возник конфликт имени роли "Расш1_ОсновнаяРоль"
Что натолкнуло меня на мысль: "В расширении всегда меняй префикс имен, подставляемый по умолчанию!"

P.S. Жаль нельзя через внешнюю обработку, а то порадовал бы бухгалтеров на базовых БП :)
MaxTolya; Serg O.; it_depDi; Serious; Teplotrassamen; elcoan; +6 Ответить
21. polos75 28.12.23 11:33 Сейчас в теме
(7)

ВариантМасштабаФормКлиентскогоПриложения.Компактный Тогда


Что-то не так. Может, в платформе дело, но у меня в режиме совместимости с 8.3.16 такой глобальной переменной как ВариантМасштабаФормКлиентскогоПриложения нет.
Вопрос появился, так как некоторые коллеги ещё и отключают интерфейс Такси.
Сделал так:

	НовыйЭлемент.Подсказка = "С Новым Годом!!!    Мототехника - ВПЕРЁД!!!";
	нп=Новый НастройкиКлиентскогоПриложения;
	Если ТекущийВариантИнтерфейсаКлиентскогоПриложения() = ВариантИнтерфейсаКлиентскогоПриложения.Такси
		и не нп.ВариантМасштабаФормКлиентскогоПриложения = ВариантМасштабаФормКлиентскогоПриложения.Компактный Тогда
			НовыйЭлемент.Масштабировать 		  = Истина;
			НовыйЭлемент.Масштаб = 50;
			НовыйЭлемент.Высота  = 1;
	Иначе
		НовыйЭлемент.Высота = 2;
	КонецЕсли;
Показать
8. Teplotrassamen 27.12.23 16:42 Сейчас в теме
Спасибо, жаль только после нового года мои бухгалтера и кадровики увидят это. Но думаю в январе повисит пару недель точно.
Ingraf; Serg O.; elcoan; +3 Ответить
9. v8_088 27.12.23 16:50 Сейчас в теме
Красиво, спасибо. С Новым Годом.
11. maksa2005 534 27.12.23 19:53 Сейчас в теме
12. degtyarev85 28.12.23 06:48 Сейчас в теме
Спасибо!
Закину свои 5 копеек. Чтобы в общих журналах тоже выходила гирлянда добавляем в расширение модуль "ОбщегоНазначенияБКВызовСервера" и подменяем функцию "УстановитьОтборПоОсновнойОрганизации".
Проверено на конфигурации Бухгалтерия для Казахстана, для России возможно придется использовать другой модуль
предположу что "ОбщегоНазначенияБПВызовСервера".
&Вместо("УстановитьОтборПоОсновнойОрганизации")
Функция нг_УстановитьОтборПоОсновнойОрганизации(Форма, ИмяСписка, ИмяРеквизита, ЗначениеОтбора)
	
	нг_ОбщегоНазначения.ПриСозданииНаСервере(Форма);
	
	ПродолжитьВызов(Форма, ИмяСписка, ИмяРеквизита, ЗначениеОтбора);
	
КонецФункции
Показать
Teplotrassamen; elcoan; +2 Ответить
13. dj_tol 103 28.12.23 07:03 Сейчас в теме
ERP 2.5.14 полет нормальный.
14. insurgut 207 28.12.23 08:04 Сейчас в теме
Чтобы вручную не контролировать, в процедуру ПриСозданииНаСервере добавил...

	ДедМорозПришел = Ложь;
	Если Месяц(ТекущаяДата()) = 12
		И День(ТекущаяДата()) >= 25 Тогда
		ДедМорозПришел = Истина;
	КонецЕсли;
	
	Если Месяц(ТекущаяДата()) = 1
		И День(ТекущаяДата()) <= 14 Тогда
		ДедМорозПришел = Истина;
	КонецЕсли;
	
	Если Не ДедМорозПришел Тогда
		Возврат;
	КонецЕсли;
Показать
IntellXeon; mangust4; elcoan; +3 Ответить
16. user991808 28.12.23 09:38 Сейчас в теме
(14) Можно еще проще :)

ТекМесяц 	   = Месяц(ТекущаяДатаСеанса()); 
ТекЧисло 	   = День(ТекущаяДатаСеанса());	
ДедМорозПришел = ТекМесяц = 12 И ТекЧисло > 24 ИЛИ ТекМесяц = 1 И ТекЧисло < 20;
    
Если ДедМорозПришел = Ложь Тогда
   Возврат;
КонецЕсли;
mangust4; 1v7; elcoan; +3 Ответить
24. insurgut 207 28.12.23 13:09 Сейчас в теме
(16) от перестановки мест слагаемых, как говорится, суть не меняется. Цели максимально кратко записать код тут не стоит. :)
15. Serg O. 260 28.12.23 09:22 Сейчас в теме
можно и GIF-гирлянды вставлять ...
в Общие картинки - нг_Оформление можно загрузить из файла ...
вот несколько "бегущих огней"
Прикрепленные файлы:
zaic; dbachinsky; Teplotrassamen; Aleksey79; elcoan; +5 Ответить
22. SerVer1C 756 28.12.23 11:38 Сейчас в теме
(15) мои мысли читаете (из 10-го коммента)
Eugene_Elhaz; +1 Ответить
17. _burb_on_ 10 28.12.23 09:46 Сейчас в теме
Товарищи, я в этом нуб... Но может кто-то соберет все предложения в одну обработку?
И автодату, и общие журналы и анимацию? :)
19. user991808 28.12.23 10:30 Сейчас в теме
(17)
кто-то соберет все предложения в одну обработку?
И автодату, и общие журналы и анимацию? :)

Держи :)
Порадуй коллег:)
Прикрепленные файлы:
PUBID_2008158-НовогоднееОформление.cfe
user1628996; VAAngelov; akR00b; oveksKnaaz; OlegAr; Teplotrassamen; user1559729; anuar_medeup; Serg O.; Matveev_VS; _burb_on_; Nordvip; LavinVladik; elcoan; +14 Ответить
20. LavinVladik 214 28.12.23 11:01 Сейчас в теме
От
(19)
Про гинератор хитро
23. user991808 28.12.23 12:17 Сейчас в теме
(20) Мы выживали как могли)
18. KirillHome 4 28.12.23 10:21 Сейчас в теме
(16) Я добавил ещё такое...

ЭлементНовогодняяИллюминация = Форма.Элементы.Найти("нг_Оформление");
Если ЭлементНовогодняяИллюминация <> Неопределено Тогда
	Если НЕ ДедМорозПришел  тогда
		Форма.Элементы.Удалить(ЭлементНовогодняяИллюминация);
	КонецЕсли;
	Возврат;
КонецЕсли;

//А уже потом...
Если ДедМорозПришел = Ложь Тогда
	Возврат;
КонецЕсли;
Показать
insurgut; elcoan; +2 Ответить
25. insurgut 207 28.12.23 13:11 Сейчас в теме
(18) по логике Дед мороз там уходит ещё до создания элемента формы, поэтому удалять и нечего :)
26. user1632114 28.12.23 14:26 Сейчас в теме
ERP 2.5.12.121 с небольшими исправлениями взлетело
27. orlin553 28.12.23 14:44 Сейчас в теме
жаль на 8.3.18 не работает)
28. user1632114 28.12.23 14:54 Сейчас в теме
(27)
жаль на 8.3.18 не работает)

Почему не работает?
31. orlin553 28.12.23 14:57 Сейчас в теме
30. LavinVladik 214 28.12.23 14:56 Сейчас в теме
(27) подправить надо маленько и все заработает
29. triviumfan 93 28.12.23 14:54 Сейчас в теме
Прикольно. Оригинально. Спасибо.
32. ByBedareva 2 28.12.23 15:06 Сейчас в теме
С исправлениями, но запустила на Документообороте 2.1. Спасибо большое за новогоднее настроение
33. Matveev_VS 160 28.12.23 16:36 Сейчас в теме
34. PerlAmutor 129 29.12.23 06:24 Сейчас в теме
Для ERP 2.5.8 на платформе 8.3.20 (Такси + В закладках)
Для ЗУП КОРП 3.1.27 на платформе 8.3.23
Прикрепленные файлы:
НовогоднееОформление_ERP258_8320.cfe
НовогоднееОформление_ЗУП3127_8323.cfe
Teplotrassamen; akR00b; elcoan; +3 Ответить
36. akR00b 22 29.12.23 10:23 Сейчас в теме
35. zakharov_yuri 33 29.12.23 07:25 Сейчас в теме
Спасибо. Поставил. Жаль, поздновато, но хо-ро-шо.
37. alexey_kurdyukov 157 29.12.23 11:37 Сейчас в теме
Лучшая разработка за год!
38. aleksey2 86 29.12.23 12:36 Сейчас в теме
Ошибка применения модуля "НовогоднееОформление ОбщийМодуль.ПодключаемыеКоманды.Модуль". Список параметров метода "нг_ПриСозданииНаСервере" не соответствует методу "ПриСозданииНаСервере".
39. elcoan 1003 29.12.23 12:37 Сейчас в теме
(38) Нужно убрать "Знач" у второго параметра в "нг_ПриСозданииНаСервере"
40. ejique 29.12.23 16:58 Сейчас в теме
Спасибо, хорошая идея!
41. Danilov 04.01.24 10:48 Сейчас в теме
Спасибо! Запустил.
42. user2035252 09.01.24 14:43 Сейчас в теме
Добрый день!

Подскажите пожалуйста алгоритм как эту гирлянду отключить?
43. elcoan 1003 10.01.24 23:02 Сейчас в теме
(42) Добрый день! Отключить активность у расширения или удалить его из базы.
44. IntellXeon 05.02.24 18:21 Сейчас в теме
Спасибо! а что если намутить для каждого времени года?
45. LamerSoft 1181 26.02.24 18:24 Сейчас в теме
Снимаю шляпу, лихо и забавно )
Оставьте свое сообщение