Формирование документа MS Word с использованием БСП и программное добавление закладок

15.08.23

Разработка - Инструментарий разработчика

Пример формирования документа MS Word с использованием библиотеки стандартных подсистем и добавление закладок в сформированный документ путем редактирования XML кода файла MS Word. (Тестирование проводилось на платформе 8.3.18.1959 с использованием библиотеки стандартных подсистем версии 3.1.7.294)

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Формирование документа MS Word с использованием БСП и программное добавление закладок
.epf 26,83Kb
10
10
1 SM
Скачать Купить за 1 850 руб.

Появилась необходимость в формировании документа MS Word из макета, однако попытка использования COM-объекта на сервере не увенчалась успехом. Решено было обратиться к БСП.

Основная идея данной статьи - показать способ подстановки закладок в документ MS Word, но так как была использована и библиотека стандартных подсистем, решил сформировать документ ".docx" с её помощью и заодно составить шпаргалку для подобных задач.

Статья получилась достаточно громоздкая, поэтому cпрятал формирование документа с помощью БСП под спойлер.

Для нуждающихся приложена обработка, которую можно самостоятельно поковырять и разобрать, а я же, в свою очередь, поковыряю и разберу её в этой статье.

 
 Формирование документа MS Word с помощью БСП

 

Для формирования закладок исходил из того, что файл, формируемый MS Word с расширением .docx, по сути, является архивом, содержащим xml файлы с данными и настройками основного файла. Если разархивировать его как обычный архив, он будет выглядеть следующим образом:

 

 

Сами же данные (в т.ч. и закладки) находятся в xml файле "document.xml", который, в свою очередь, находится в папке "word".

Таким образом, ныряем в код:

&НаСервере
Процедура СформироватьИПрисоединитьФайлыMSWord(ИмяМакета, КаталогСохранения, КаталогВременныхФайлов)
	
	ПутиДляРаботыСФайлами = СформироватьПутиДляРаботыСФайлами(ИмяМакета, КаталогСохранения, КаталогВременныхФайлов);
	
	//	Формирование документа MS Word с использованием процедур БСП
	СформироватьШаблонВMSWord(ПутиДляРаботыСФайлами.ПутьКФайлуШаблон, ИмяМакета);
	
	//	Заполнение закладок в созданном документе
	ЗаполнитьЗакладкиКакZIP(ИмяМакета,
							ПутиДляРаботыСФайлами.ПутьКФайлуШаблон,
							ПутиДляРаботыСФайлами.ПутьКВыгрузкеДляАрхива,
							ПутиДляРаботыСФайлами.ПутьКРедактируемомуФайлу,
							ПутиДляРаботыСФайлами.ПутьКФайлуСЗакладками);
	
	УдалитьФайлы(КаталогВременныхФайлов);
	
КонецПроцедуры

Первые две строчки процедуры были разобраны под спойлером, там же можно увидеть и изюминку формирования путей, для работы с xml файлами, а сейчас разберем процедуру "ЗаполнитьЗакладкиКакZIP".

Первым делом необходимо разархивировать полученный документ с расширением ".docx":

&НаСервере
Процедура ЗаполнитьЗакладкиКакZIP(ИмяМакета, ПутьКФайлуШаблон, ПутьКВыгрузкеДляАрхива, ПутьКРедактируемомуФайлу, ПутьКФайлуСЗакладками)
	
	АрхивZip = Новый ЧтениеZipФайла(ПутьКФайлуШаблон);
	
	АрхивZip.ИзвлечьВсе(ПутьКВыгрузкеДляАрхива, РежимВосстановленияПутейФайловZIP.Восстанавливать);
	
	АрхивZip.Закрыть();
	
	ОтредактироватьФайлTXT(ИмяМакета, ПутьКРедактируемомуФайлу);
	
	НовыйАрхивZip = Новый ЗаписьZipФайла(ПутьКФайлуСЗакладками,,,МетодСжатияZIP.Копирование,УровеньСжатияZIP.Оптимальный,МетодШифрованияZIP.Zip20);
	НовыйАрхивZip.Добавить(ПутьКВыгрузкеДляАрхива + "_rels\",РежимСохраненияПутейZIP.СохранятьОтносительныеПути,РежимОбработкиПодкаталоговZIP.ОбрабатыватьРекурсивно);
	НовыйАрхивZip.Добавить(ПутьКВыгрузкеДляАрхива + "customXml\",РежимСохраненияПутейZIP.СохранятьОтносительныеПути,РежимОбработкиПодкаталоговZIP.ОбрабатыватьРекурсивно);
	НовыйАрхивZip.Добавить(ПутьКВыгрузкеДляАрхива + "docProps\",РежимСохраненияПутейZIP.СохранятьОтносительныеПути,РежимОбработкиПодкаталоговZIP.ОбрабатыватьРекурсивно);
	НовыйАрхивZip.Добавить(ПутьКВыгрузкеДляАрхива + "word\",РежимСохраненияПутейZIP.СохранятьОтносительныеПути,РежимОбработкиПодкаталоговZIP.ОбрабатыватьРекурсивно);
	НовыйАрхивZip.Добавить(ПутьКВыгрузкеДляАрхива + "*.xml",РежимСохраненияПутейZIP.НеСохранятьПути,РежимОбработкиПодкаталоговZIP.НеОбрабатывать);
	
	НовыйАрхивZip.Записать();
		
КонецПроцедуры

В теле данной процедуры мы сначала разархивируем файл, затем вызываем процедуру, редактирующую файл "document.xml", и, после, собираем его обратно в файл с расширением ".docx". 

Переходим к процедурам, добавляющим закладки:

&НаСервере
Процедура ОтредактироватьФайлTXT(ИмяМакета, ПутьКРедактируемомуФайлу)
	
	Текст = Новый ТекстовыйДокумент;
	Текст.Прочитать(ПутьКРедактируемомуФайлу);
	
	СтрокаXML = Текст.ПолучитьТекст();
	
	//**********************************************************************************
	
	//	Вторым параметром передаем строку поиска, от которой будем отталкиваться
	//	w:name="ИмяЗакладки"
	//	для каждой последующей закладки увеличиваем id на 1
	
	ВставитьЗакладку(СтрокаXML, "ДАТАРЕГ", "<w:bookmarkStart w:id=""1"" w:name=""ДатаРегистрации""/>", "<w:bookmarkEnd w:id=""1""/>");
	ВставитьЗакладку(СтрокаXML, "РЕГНОМЕР", "<w:bookmarkStart w:id=""2"" w:name=""РегистрационныйНомер""/>", "<w:bookmarkEnd w:id=""2""/>");
	
	//**********************************************************************************
		
	Текст.УстановитьТекст(СтрокаXML);
	Текст.Записать(ПутьКРедактируемомуФайлу);
	
КонецПроцедуры

&НаСервере
Процедура ВставитьЗакладку(СтрокаXML, СтрокаПоиска, ЗакладкаНачало, ЗакладкаКонец)
	
	//**********************************************************************************
	
	//	Открытие закладки
	
	ПозицияНайденнойСтроки = СтрНайти(СтрокаXML, СтрокаПоиска);
	
	ПозицияВставкиНачалаЗакладки = СтрНайти(СтрокаXML, "<w:r", НаправлениеПоиска.СКонца, ПозицияНайденнойСтроки) - 1;
	
	ЧислоСимволовСлева = ПозицияВставкиНачалаЗакладки;
	ДлинаСтроки = СтрДлина(СтрокаXML);
	ЧислоСимволовСправа = ДлинаСтроки - ПозицияВставкиНачалаЗакладки;
	
	ТекстСлева = Лев(СтрокаXML, ЧислоСимволовСлева);
	ТекстСправа = Прав(СтрокаXML, ЧислоСимволовСправа);
	ТекстВставки = ЗакладкаНачало;
		
	СтрокаXML = ТекстСлева + ТекстВставки + ТекстСправа;
	
	//**********************************************************************************
	
	// Закрытие закладки
	
	ПозицияНайденнойСтроки = СтрНайти(СтрокаXML, СтрокаПоиска);
	
	ПозицияВставкиКонцаЗакладки = СтрНайти(СтрокаXML, "</w:r>", НаправлениеПоиска.СНачала, ПозицияНайденнойСтроки) + СтрДлина("</w:r>") - 1;
	
	ЧислоСимволовСлева = ПозицияВставкиКонцаЗакладки;
	ДлинаСтроки = СтрДлина(СтрокаXML);
	ЧислоСимволовСправа = ДлинаСтроки - ПозицияВставкиКонцаЗакладки;
	
	ТекстСлева = Лев(СтрокаXML, ЧислоСимволовСлева);
	ТекстСправа = Прав(СтрокаXML, ЧислоСимволовСправа);
	ТекстВставки = ЗакладкаКонец;
		
	СтрокаXML = ТекстСлева + ТекстВставки + ТекстСправа;
	
	//**********************************************************************************
	
КонецПроцедуры

По-хорошему, стоит работать с xml файлами как, собственно, с xml файлами, открывая один на чтение, другой на запись, но до меня, к сожалению, не дошло как это можно сделать, поэтому решил работать с xml как с текстовой строкой.

В общем случае, сначала в строке ищем точку вхождения текста, куда нужно вставить закладку. В нашем случае это "ДАТАРЕГ" и "РЕГНОМЕР". Их мы передаем вторым параметром в процедуру "ВставитьЗакладку". Третий и четвертый параметры - это, соответственно, конструкции, которыми Word обозначает закладки, которые, мы, собственно, и вставляем в нужные места. В этих же конструкциях мы задаем id закладки (важно увеличивать для каждой последующей закладки id на 1) и имя закладки (ДатаРегистрации и РегистрационныйНомер в нашем случае).

В процедуре "ВставитьЗакладку" после того, как была найдена строка вхождения, в нужные места по тегам вставляются переданные конструкции открытия и закрытия закладки. Такие дела.

ХОЧУ ОБРАТИТЬ ВНИМАНИЕ, что не стоит называть текст вхождения по типу "&!ВхождениеТекста123!&". Дело в том, что Word по-своему записывает некоторые слова. Таким образом, множество знаков (&#$!,. и прч.) он, вероятно, сохранит в виде кодировки символа, а не непосредственно сам символ. Также длинные слова он может разделить на несколько. Визуально, в документе, это будет единое слово, но в xml файле оно будет разделено на несколько, что не позволит отыскать его. Так что для подобных изощрений имеет смысл поэкспериментировать и найти короткое слово.

 
 Пример ошибки

Так это выглядит в MS Word:
Так это выглядит в xml: <w:t xml:space="preserve">РЕГНОМЕР</w:t>

Так это выглядит в MS Word:
Так это выглядит в xml: <w:t xml:space="preserve">егистрацонныйНомер</w:t>

Как можно видеть, знак амперсанда и букву "Р" Word где-то съел, закодировав по-своему.

 

На этом у меня всё, спасибо за внимание!

обработка закладки word БСП

См. также

Инструментарий разработчика Роли и права Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    140727    772    391    

803

Пакетная печать Печатные формы Инструментарий разработчика Программист Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    11566    31    6    

61

Инструментарий разработчика Программист Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Инструмент для написания и отладки кода в режиме «1С:Предприятие». Представляет собой консоль кода с возможностью пошаговой отладки, просмотра значений переменных любых типов, использования процедур и функций, просмотра стека вызовов, вычисления произвольных выражений на встроенном языке в контексте точки останова, синтаксического контроля и остановки по ошибке. В консоли используется удобный редактор кода с подсветкой, контекстной подсказкой, возможностью вызова конструкторов запроса и форматной строки.

5400 руб.

17.05.2024    13890    33    27    

75

Инструменты администратора БД Инструментарий разработчика Роли и права Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Расширение позволяет без изменения кода конфигурации выполнять проверки при вводе данных, скрывать от пользователя недоступные ему данные, выполнять код в обработчиках. Не изменяет данные конфигурации, легко устанавливается практически на любую конфигурацию на управляемых формах.

10000 руб.

10.11.2023    7292    27    4    

51

SALE! %

Инструментарий разработчика Инструменты администратора БД Системный администратор Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Универсальный инструмент программиста для администрирования конфигураций. Сборник наиболее часто используемых обработок под единым интерфейсом.

3600 2880 руб.

14.01.2013    181897    1104    0    

876

Инструментарий разработчика Программист 8.3.14 1С:Конвертация данных Россия Платные (руб)

Расширение для конфигурации “Конвертация данных 3”. Добавляет подсветку синтаксиса, детальную контекстную подсказку, глобальный поиск по коду.

15000 руб.

07.10.2021    15991    3    12    

39

Инструментарий разработчика Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Восстановление партий или взаиморасчетов, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

5000 руб.

07.02.2018    101134    242    97    

303

Инструментарий разработчика Перенос данных 1C Программист Платформа 1С v8.3 Платные (руб)

В процессе работы в 1С часто возникает потребность получить данные из другой базы. Обычно это делается через COM-соединение, и время выполнения запроса при этом оставляет желать лучшего. В данной публикации представлено универсальное решение для 1С, позволяющее практически моментально выполнить произвольный код или запрос с параметрами в другой информационной базе через Web-сервис.

2400 руб.

24.09.2019    24506    17    15    

34
Оставьте свое сообщение