Работа с внешними обработками на управляемых формах

14.05.24

Разработка - Инструментарий разработчика

Пошагово описывается процесс от создания обработки до реализации механизма сохранения, восстановления и передачи данных с формы обработки, в модуль обработки с помощью справочника Дополнительные отчеты и обработки в конфигурациях на базе БСП. Рассматриваются имена типов команд и описывается, для какой цели они служат.

Скачать исходный код

Наименование Файл Версия Размер
Методичка по работе с внешними обработками на УФ:
.epf 7,48Kb
69
.epf 7,48Kb 69 Скачать бесплатно

Методичка по работе с внешними обработками на УФ

(Заранее приношу свои извинения за размытые картинки, пытался побороть их, пока не получилось! на всякий случай всё продублирую текстом.)

В первую очередь ставится демо база на БСП.Открываем базу в пользовательском режиме,идем в  справочник Дополнительные отчеты и обработки находим знак ? как на картинке ниже,открываем справку, в самом низу справки полностью копируем Функцию СведенияОВнешнейОбработке()

 

 

1. Создаем внешнюю обработку, добавляем в модуль объекта Функцию СведенияОВнешнейОбработке()

На всякий случай код прилагаю

Функция СведенияОВнешнейОбработке() Экспорт

ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.1");

ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработки<...>();

ПараметрыРегистрации.Версия = "...";

///

Команда = ПараметрыРегистрации.Команды.Добавить();

Команда.Представление = НСтр("ru = '<Представление команды>'");

Команда.Идентификатор = "<Имя команды>";

Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКоманды<...>();

Команда.ПоказыватьОповещение = <Истина/Ложь>;

Возврат ПараметрыРегистрации;

КонецФункции

Зде сь в функции сведения о внешней обработке уже определены ПараметрыРегистрации и  Команды

И их нужно всего лишь заполнить в самой обработке

 

 

Кстати, таблица команд это по сути кнопки, которые будут располагаться на форме самой обработки

 

 

Вернемся во внешнюю обработку.

Заполним команды.

Команда.Представление = Команда представления это то, как будет видеть представление команды пользователь

Команда.Идентификатор = Это то, как будет видеть идентификатор программа.

Команда.ПоказыватьОповещение = Истина или Ложь будет показывать что команда в данный момент выполняется.

Перейдем к Команда.Использование В общем модуле ДополнительныеОтчетыИОбработкиКлиентСервер располагаются функции с Именами типов команд,рассмотрим эти команды подробнее

 

 

Тип команды «Вызов Серверного метода», конечно же, предполагает то, что команда будет вызвана на сервере. Чаще всего такие команды нужны для выполнения регламентных обработчиков, которые будут выполниться и запускаться по расписанию.
Тип команды «Вызов клиентского метода» предполагает, что что-то должно произойти на клиенте, но не открытие формы самой обработки. Здесь на клиенте можно поработать, например с клиентскими методами Word например.

А вот тип команды «Открытие формы» позволяет открывать форму, которую мы определим в самой обработке, либо какую ни будь произвольную форму.

Тип команды «Загрузка данных из файла» доступен только в глобальных обработках (вид = «Дополнительная обработка») при наличии в конфигурации подсистемы «Загрузка данных из файла»

Теперь, когда определили ТипКоманды как на скриншоте выше, нам нужно определить обработчик этой команды

Для этого там же в модуле объекта добавляем экспортную процедуру

Процедура ВыполнитьКоманду(ИдентификаторКоманды,ПараметрыВыполненияКоманды) Экспорт

//// ИдентификаторКоманды у нас прописан в процедуре СведенияОВнешнейОбработке

Если ИдентификаторКоманды = "ФормированиеЛога" Тогда 

  ////можно передовать разные идентификаторы команды и в соотв.с этим
  ///строить логику выполнения 

КонецЕсли;

Если ИдентификаторКоманды = "Другой" Тогда 

////можно передавать разные идентификаторы команды

КонецЕсли;

КонецПроцедуры

Кстати, если в функцию СведенияОВнешнейОбработке()  добавить второй блок команд

 

 

То вторую команду мы увидим уже в пользовательском режиме в справочнике Внешние обработки и отчеты

 

 

Так как тип команды   у нас серверный, в пользовательском режиме у нас появились часы, которые позволят нам настраивать в дальнейшем расписание.

 

Открытие формы обработки и передача данных с формы на сервер(в модуль обработки)

Иногда возникает необходимость программно открыть форму обработки, заполнить какие нибудь данные  и далее передать эти данные  для обработки в модуль самой обработки.

Для этого нам нужно  в модуле обработки СведенияОВнешнейОбработке()
в Команда.Использование определить ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы()

Функция СведенияОВнешнейОбработке() Экспорт  

     ////здесь определяются команды и.т.д.

    Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();

  КонецФункции

Для того, чтобы форма обработки открывалась, нужно создать форму и для примера добавить строковый  реквизит, но ничего вам не мешает создать здесь таблицуЗначений или ссылку на справочник и т.д.

 

 

Продолжаем работать с возможностями обработки и сделаем 2 в 1, механизм сохранения и восстановления настроек и  механизм передачи данных с формы обработки в модуль обработки.

Сперва посмотрим на справочник ДополнительныеОтчетыИОбработки, это справочник имеет реквизит Хранилище обработки,  и ХранилищеНастроек.

Реквизит Хранилище обработки позволяет хранить саму внешнюю обработку, отчет, которая загружается в справочник.

Реквизит Хранилище настроек это те настройки, которые мы хотим передать при открытии этой самой обработки.

И то и другое имеет тип данных ХранилищеЗначений (не путать с временным хранилищем).

 

 

Тип ХранилищеЗначения доступен только на стороне сервера, туда можно записать всё, что сериализуется.

Вернемся в форму обработки, на закладке Параметры обработки добавим ДополнительнаяОбработкаСсылка с типом данных СправочникСсылка.ДополнительныеОтчетыИОбработки

 

 

Общая схема того, что мы собираемся реализовывать

 

 

В форме обработки реализуем механизм сохранения и восстановления настроек 

&НаСервере
///---Здесь мы при открытии обработки по факту считываем данные из ХранилищеНастроек Справочника  ДополнительныеОтчетыИОбработки
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
         Если ЗначениеЗаполнено(Параметры.ДополнительнаяОбработкаСсылка) Тогда
ХранилищеНастроек = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Параметры.ДополнительнаяОбработкаСсылка,"ХранилищеНастроек");    
НастройкиСтруктура = ХранилищеНастроек.Получить();
                  Если  ТипЗнч(НастройкиСтруктура) = Тип("Структура") Тогда
                          Объект.Реквизит1 =  НастройкиСтруктура.Реквизит1; 
                          РеквизитФормы1   =  НастройкиСтруктура.РеквизитФормы1;
                  КонецЕсли;
         КонецЕсли; 
КонецПроцедуры

 

прокоментируем процедуру ПриСозданииНаСервере()

Если мы в пользовательском режиме запустим обработку, то в модуле формы самой обработки автоматически будет заполнен Параметр  Параметры.ДополнительнаяОбработкаСсылка,  а заполнятся Параметры  ссылкой на элемент справочника ДополнительныеОтчетыИОбработки, то есть на ссылку вашей обработки.

Ссылку мы получили, теперь нам нужно  посмотреть, что хранится в реквизите ХранилищеНастроек

 ХранилищеНастроек = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Параметры.ДополнительнаяОбработкаСсылка,"ХранилищеНастроек");

При первом открытии, конечно же, в Справочнике.ДополнительныеОтчетыИОбработки никаких данных не будет.

И чтобы не возникало ошибки, поставим проверку



              НастройкиСтруктура = ХранилищеНастроек.Получить();
               Если  ТипЗнч(НастройкиСтруктура) = Тип("Структура") Тогда
                       Объект.Реквизит1 =  НастройкиСтруктура.Реквизит1; 
                       РеквизитФормы1   =  НастройкиСтруктура.РеквизитФормы1;
               КонецЕсли;

Произвольно заполним в пользовательском режиме на форме Реквизит1 и РеквизитФормы1

 


Теперь нам нужно где-то сохранить настройки формы, чтобы в следующий раз их открыть и заодно передать данные в модуль объекта


&НаСервере
Процедура ПриЗакрытииНаСервере()
         ///Получаем объект своей обработки из спр. ДополнительныеОтчетыИОбработки
       ДополнительнаяОбработкаОбъект =     Параметры.ДополнительнаяОбработкаСсылка.ПолучитьОбъект();
         ////--подготовим структуру с нашими реквизитами и данными
                   НастройкиСтруктура = Новый Структура;
         НастройкиСтруктура.Вставить("Реквизит1",Объект.Реквизит1);
         НастройкиСтруктура.Вставить("РеквизитФормы1",РеквизитФормы1);
      /////И записываем в  реквизит  ХранилищеНастроек  Объект.Реквизит1 и РеквизитФормы1
         ДополнительнаяОбработкаОбъект.ХранилищеНастроек = Новый ХранилищеЗначения(НастройкиСтруктура);
         ДополнительнаяОбработкаОбъект.Записать();
КонецПроцедуры

Данные переданные с формы обработки теперь хранятся в справочнике  ДополнительныеОтчетыИОбработки в реквизите ХранилищеНастроек, принадлежащем нашей обработке.

После того как форма была закрыта, в модуле обработки автоматически запускается Процедура ВыполнитьКоманду()


Процедура ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыВыполненияКоманды) Экспорт
         ССылкаНаОбработку =  ПараметрыВыполненияКоманды.ДополнительнаяОбработкаСсылка; 
         Если ЗначениеЗаполнено(ССылкаНаОбработку) Тогда
                 ХранилищеНастроек = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ССылкаНаОбработку,"ХранилищеНастроек");
                 НастройкиСтруктура = ХранилищеНастроек.Получить();
                 Если  ТипЗнч(НастройкиСтруктура) = Тип("Структура") Тогда
                          Реквизит1        =  НастройкиСтруктура.Реквизит1; 
                          РеквизитФормы1   =  НастройкиСтруктура.РеквизитФормы1;
                Если ИдентификаторКоманды = "ФормированиеЛога" Тогда 
                    ЗаписьЖурналаРегистрации(Реквизит1);
                          ИначеЕсли   ИдентификаторКоманды = "ФормированиеЛога2" Тогда
                                   ЗаписьЖурналаРегистрации(РеквизитФормы1);
                          КонецЕсли;
                 КонецЕсли;
         КонецЕсли; 
КонецПроцедуры

Прокомментируем процедуру ВыполнитьКоманду(ИдентификаторКоманды, ПараметрыВыполненияКоманды)

Здесь мы уже  через  ПараметрыВыполненияКоманды  обращаемся к  ДополнительнаяОбработкаСсылка, что прилетела к нам с формы обработки, проверяем, что она заполнена и с помощью метода БСП получаем ХранилищеНастроек

ХранилищеНастроек = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ССылкаНаОбработку,"ХранилищеНастроек");

НастройкиСтруктура = ХранилищеНастроек.Получить();

Получив структуру НастройкиСтруктура = ХранилищеНастроек.Получить();  обрабатываем её так как нужно.

Реквизит1        =  НастройкиСтруктура.Реквизит1;  
РеквизитФормы1   =  НастройкиСтруктура.РеквизитФормы1;

Кстати, параметр процедуры Идентификатор Команды передается из Функции СведенияОВнешнейОбработке()

 

 

Далее при выполнении команды делаем с данными, что нам заблагорассудится.

Файл обработки прилагаю. Тестировал на конфигурации "Библиотека стандартных подсистем", редакция 3.1 (3.1.9.179).

ТипКомандыВызовСерверногоМетода() ТипКомандыВызовКлиентскогоМетода() ТипКомандыОткрытиеФормы() ТипКомандыЗаполнениеФормы() Методичка Внешние обработки передача данных с формы обработки.

См. также

Infostart Toolkit: Инструменты разработчика 1С 8.3 на управляемых формах

Инструментарий разработчика Роли и права Запросы СКД Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    129745    700    390    

752

Infostart PrintWizard - создание и редактирование печатных форм в 1С 8.3

Пакетная печать Печатные формы Инструментарий разработчика Платформа 1С v8.3 Запросы 1С:Зарплата и кадры бюджетного учреждения 1С:Конвертация данных 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Платные (руб)

Инструмент, позволяющий абсолютно по-новому взглянуть на процесс разработки печатных форм. Благодаря конструктору можно значительно снизить затраты времени на разработку печатных форм, повысить качество и "прозрачность" разработки, а также навести порядок в многообразии корпоративных печатных форм.

18000 руб.

06.10.2023    9083    25    6    

49

Infostart УДиФ: Управление данными и формами 1С

Инструменты администратора БД Инструментарий разработчика Роли и права Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Расширение позволяет без изменения кода конфигурации выполнять проверки при вводе данных, скрывать от пользователя недоступные ему данные, выполнять код в обработчиках. Не изменяет данные конфигурации, легко устанавливается практически на любую конфигурацию на управляемых формах.

10000 руб.

10.11.2023    5239    14    2    

39

SALE! %

PowerTools

Инструментарий разработчика Инструменты администратора БД Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Универсальный инструмент программиста для администрирования конфигураций. Сборник наиболее часто используемых обработок под единым интерфейсом.

3600 2880 руб.

14.01.2013    179641    1091    0    

868

OneDebugger - инструмент для отладки кода без использования режима конфигуратора

Инструментарий разработчика Платформа 1С v8.3 Платные (руб)

Инструмент для написания и отладки кода в режиме «1С:Предприятие». Представляет собой консоль кода с возможностью пошаговой отладки, просмотра значений переменных любых типов, использования процедур и функций, просмотра стека вызовов, вычисления произвольных выражений на встроенном языке в контексте точки останова, синтаксического контроля и остановки по ошибке. В консоли используется удобный редактор кода с подсветкой, контекстной подсказкой, возможностью вызова конструкторов запроса и форматной строки.

5400 руб.

17.05.2024    4520    3    12    

33

Бустер Конвертации данных 3 (Infostart Toolkit)

Инструментарий разработчика 8.3.14 1С:Конвертация данных Россия Платные (руб)

Расширение для конфигурации “Конвертация данных 3”. Добавляет подсветку синтаксиса, детальную контекстную подсказку, глобальный поиск по коду.

15000 руб.

07.10.2021    15348    3    12    

38

Многопоточность. Универсальный «Менеджер потоков» 2.1

Инструментарий разработчика Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Восстановление партий или взаиморасчетов, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

5000 руб.

07.02.2018    100265    240    97    

299

1С HTML Шаблоны / HTML Templates

Инструментарий разработчика Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Быстрая и удобная обработка для работы с шаблонами HTML. Позволяет легко и быстро формировать код HTML.

2040 руб.

27.12.2017    28659    4    10    

17
Оставьте свое сообщение