"Локализация" значений констант для пользователей в 1С:7.7

12.12.09

Задачи пользователя - Адаптация типовых решений

Для каждого пользователя - свои значения констант. :)

Пришла в голову оригинальная мысль, проверил - работает.

 // глобальный модуль, блок объявления переменных
Перем Константа;                       
Перем ТЗКонстанта Экспорт;  // (12.12.09) для локальных модулей                     

// глобальный модуль, блок операторов
Пер = СоздатьОбъект("Периодический"); 
ДопПериод = 0;

Константа = СоздатьОбъект("ТаблицаЗначений");
Константа.НоваяСтрока(); 

Для М1 = 1 По Метаданные.Константа() Цикл                 
  ИдКонстанты = Метаданные.Константа(М1).Идентификатор;
  Константа.НоваяКолонка(ИдКонстанты); 
Если Метаданные.Константа(М1).Периодический = 1 Тогда
// подключим эмуляцию методов периодических констант Получить() Установить()
// через СписокЗначений
СЗ = СоздатьОбъект("СписокЗначений");
Пер.ИспользоватьОбъект(ИДКонстанты);
Пер.ОбратныйПорядок(0);
Если Пер.ВыбратьЗначения() > 0 Тогда
Пер.ПолучитьЗначение();
                  ДатаНач = Пер.ДатаЗнач;
                  Пер.ОбратныйПорядок(1);
Пер.ВыбратьЗначения();
Пер.ПолучитьЗначение();
                  ДатаКон = Пер.ДатаЗнач + ДопПериод;
                  Для М2 = ДатаНач По ДатаКон Цикл
СЗ.Установить(М2,Пер.ЗначениеНаДату(М2));
КонецЦикла;
            КонецЕсли;
Константа.УстановитьЗначение(1,М1,СЗ);
Иначе 
Константа.УстановитьЗначение(1,М1,Const.ПолучитьАтрибут(ИдКонстанты));
КонецЕсли;
КонецЦикла
// локализуем значения для пользователя ;)
 Константа.ДатаЗапретаРедактирования = "Это дата запрета редактирования, однако.";
 ТЗКонстанта = Константа; // (12.12.09) для локальных модулей

Естественно,  после такого "надругательства" методы константы ПолучитьАтрибут() и УстановитьАтрибут() будут работать только в англоязычной версии.

 

Примечание (12.12.09). Эта подмена встроенного агрегатного типа на объявленную переменную может работать с обращением к ней только из текущего модуля, т.е.   локальном модуле ее потребуется заново переопределить

Перем Константа;        


Константа = ТЗКонстанта;              

См. также

Улучшенная обработка "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7

Печатные формы Адаптация типовых решений Программист Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Приятное улучшение обработки "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7 для более комфортной работы с "любимой семерочкой".

1 стартмани

04.02.2022    3236    1    igor7777    0    

3

Расчет страховых взносов в 1С 7.7 "Учет и отчетность предпринимателя, ред. 1.2" с апреля 2020

Адаптация типовых решений Программист Платформа 1С v7.7 Конфигурации 1cv7 Россия Бухгалтерский учет ФОМС, ЕФС Бесплатно (free)

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

09.04.2020    20028    Юджин58    39    

5

Дистрибьюция 7.7. Часть 1. Жизненный цикл заявки покупателя. Одна заявка покупателя, много адресов доставки.

Адаптация типовых решений Программист Платформа 1С v7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Управленческий учет Бесплатно (free)

Описан способ работы с учетом расписания с приоритетными покупателями - торговыми сетями (основными покупателями) в торговой или комплексной учетной системе на 1С 7.7. Множественная заявка покупателя на несколько торговых точек.

14.10.2019    6097    ksnik    14    

3

Как в торговле 7.7 печатать код ТНВЭД в счет-фактуре

Операции по ВЭД Адаптация типовых решений Программист Оперативный учет 7.7 1С:Торговля и склад 7.7 Россия Бухгалтерский учет НДС Бесплатно (free)

В данной статье хотел поделиться опытом, как в Торговле 7.7 ( релиз 994) сделать возможность выводить код ТНВЭД в печатную форму счета-фактуры. Сразу скажу, что нужно это только тем, кто осуществляет экспорт в страны таможенного союза. Остальные могут не волноваться.

15.11.2017    11873    AndKovalchuk    0    

1

Предельные базы взносов в ПФР, ФСС, ФФОМС 2015 в 1С: Бухгалтерия 7.7

Зарплата Адаптация типовых решений Программист Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Реализация Постановления Правительства РФ 1316 от 04.12.14 для типовой конфигурации "Бухгалтерский учет 7.7" рел. 7.70.590

1 стартмани

31.12.2014    23976    9    Sergey1CSpb    2    

0
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Jers 09.09.09 18:15 Сейчас в теме
Действительно надругательство :)
2. salexdv 2341 09.09.09 23:08 Сейчас в теме
3. Shaman100M 1151 10.09.09 11:05 Сейчас в теме
скорее, муляж :)

Из всех глобальных атрибутов, похоже, "Константа" лучше всего эмулируется, однако, увлекаться этим не стоит. ))
4. artbear 1551 10.09.09 18:03 Сейчас в теме
C помощью 1С++ и спец.класса можно заставить работать и все методы встроенного объекта :)
5. artbear 1551 10.09.09 18:07 Сейчас в теме
Что-то подобное я получал при работе над 1С++, но автору все равно заслуженный плюс.
Оставьте свое сообщение