Перенос физического лица из ЗУП в БП

27.11.14

Интеграция - Перенос данных 1C

Когда регламентированная зарплата переносится из ЗУП в БП без разреза по сотрудникам, то в БП приходится вручную повторять ввод физического лица, ранее уже введенного в ЗУПе. Я немного дописал ЗУП и нужных людей (подотчётники, водители и проч.) можно переносить из ЗУПа в БП. Названия переменных и функций объясняются тем, что в организации, для которой это написано, бухгалтерский учет ведется в отраслевой конфигурации Подрядчик строительства на базе БП.

 1. Добавляем константу ПоПуть, тип строка.

2. Создаем общую форму ПоПуть, для ввода значения константы ПоПуть.

3. У справочника ФизическиеЛица, копированеим формы ФормаСписка, создаем форму ФормаСписка1, делаем ее основной формой списка.

    Создание новой формы обусловлено желанием не усложнять обновление релизов ЗУПа. 

4. В ФормаСписка1:

       - объявляем две пересенные: Перем Подрядчик, Подразделение;

       - добавляем две кнопки с процедурами:

Процедура УстановитьПоПуть(Кнопка)
 ОткрытьФорму("ОбщаяФорма.ПоПуть");
КонецПроцедуры

     и

Процедура ПодСинхронизация(Кнопка)
 
 Попытка V82 = Новый COMОбъект("V82.ComConnector");
 Исключение Предупреждение("Нет V8"); Возврат;
 КонецПопытки;
 
 СтрокаПодключения = "file='"+Константы.ПоПуть.Получить()+
 "'; usr='Обменник'; pwd='19096019';";
 Подрядчик = V82.Connect(СтрокаПодключения);
 
 Фли = ЭтаФорма.ТекущийЭлемент.ТекущаяСтрока;
 Если Фли.ЭтоГруппа Тогда Возврат; КонецЕсли;
 
 Запрос = Подрядчик.NewObject("Запрос"); 
 Запрос.Текст = 
 "ВЫБРАТЬ
 | ФизическиеЛица.ИНН
 |ИЗ
 | Справочник.ФизическиеЛица КАК ФизическиеЛица
 |ГДЕ
 | ФизическиеЛица.Наименование = &Наименование
 | И ФизическиеЛица.ИНН = &ИНН";
 Запрос.УстановитьПараметр("Наименование", Фли.Наименование);
 Запрос.УстановитьПараметр("ИНН", Фли.ИНН);
 Таб = Запрос.Выполнить().Выгрузить();
 Если Таб.Количество() > 0 Тогда
  Предупреждение("Физлицо: "+Фли.Наименование+", ИНН: "+Фли.ИНН+" уже существует в Подрядчике");
  Возврат;
 КонецЕсли; 
 ЗаполнитьПодразд(Фли);
 
 Фпо = Подрядчик.Справочники.ФизическиеЛица.СоздатьЭлемент(); 
 Фпо.Наименование  = Фли.Наименование;
 Фпо.ДатаРождения  = Фли.ДатаРождения;
 Фпо.ИНН     = Фли.ИНН;
 Фпо.КодИМНС    = Фли.КодИМНС;
 Фпо.Комментарий   = Фли.Комментарий;
 Фпо.СтраховойНомерПФР = Фли.СтраховойНомерПФР;
 Если Не Фли.Пол.Пустая() Тогда
 Фпо.Пол     = Подрядчик.Перечисления.ПолФизическихЛиц.Получить(Перечисления.ПолФизическихЛиц.Индекс(Фли.Пол));
 КонецЕсли; 
 Фпо.МестоРождения  = Фли.МестоРождения;
 Фпо.Подразделение  = Подразделение;
 Фпо.Записать();
 
 Запрос = Новый Запрос( 
 "ВЫБРАТЬ
 | ФИОФизЛицСрезПоследних.Фамилия,
 | ФИОФизЛицСрезПоследних.Имя,
 | ФИОФизЛицСрезПоследних.Отчество
 |ИЗ
 | РегистрСведений.ФИОФизЛиц.СрезПоследних КАК ФИОФизЛицСрезПоследних
 |ГДЕ
 | ФИОФизЛицСрезПоследних.ФизЛицо = &ФизЛицо"
 );
 Запрос.УстановитьПараметр("ФизЛицо", Фли);
 Таб = Запрос.Выполнить().Выгрузить();
 Если Таб.Количество() > 0 Тогда
 
  НаборЗаписей = Подрядчик.РегистрыСведений.ФИОФизЛиц.СоздатьНаборЗаписей();
  НаборЗаписей.Отбор.ФизЛицо.Установить(Фпо.Ссылка);

  НовЗапись = НаборЗаписей.Добавить();
  НовЗапись.ФизЛицо = Фпо.Ссылка;
  НовЗапись.Период = ТекущаяДата();
  НовЗапись.Фамилия = Таб[0].Фамилия;
  НовЗапись.Имя  = Таб[0].Имя; 
  НовЗапись.Отчество = Таб[0].Отчество;
  
  НаборЗаписей.Записать(Истина);
 
 КонецЕсли;
 
КонецПроцедуры

       - добавляем процедуру ЗаполнитьПодразд (вызывается из процедуры ПодСинхронизация):

Процедура ЗаполнитьПодразд(Физлицо)
 ПодрОрг = Подрядчик.Справочники.ПодразделенияОрганизаций;
 Подразделение = ПодрОрг.ПустаяСсылка();
 Запрос = Новый Запрос( 
 "ВЫБРАТЬ
 | СотрудникиОрганизаций.ТекущееПодразделениеОрганизации КАК Подразделение,
 | СотрудникиОрганизаций.ДатаУвольнения
 |ИЗ
 | Справочник.СотрудникиОрганизаций КАК СотрудникиОрганизаций
 |ГДЕ
 | СотрудникиОрганизаций.Физлицо = &Физлицо"
 ); 
 Запрос.УстановитьПараметр("Физлицо", Физлицо);
 Таб = Запрос.Выполнить().Выгрузить();
 Для каждого Та Из Таб Цикл
  Если Та.ДатаУвольнения = Дата(1,1,1) Тогда
   Если Не Та.Подразделение.Пустая() Тогда
    Подразделение = ПодрОрг.НайтиПоКоду(Та.Подразделение.Код);
   КонецЕсли; 
  КонецЕсли; 
 КонецЦикла; 
КонецПроцедуры

 

           Порядок работы:

       - по кнопке "Путь расположения ЗУП" определяем место расположение ЗУП

      

       - по кнопке "Синхронизация с Подрядчиком" текущее физлицо создается в Подрядчике. В приведенном

         примере копируется Бабенко

       

 

       - при попытке перенести физлицо, уже существующее в Подрядчике, выдается предупреждение и перенос не осуществляется

 

 

Сушко

См. также

SALE! 10%

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    137993    759    292    

404

Перенос данных 1C Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос документов, начальных остатков и справочной информации из УПП 1.3 в ERP 2 | из УПП 1.3 в УТ 11 | из УПП в КА 2 | Правила конвертации (КД 2) в продаже с 2015 года, постоянно работаем над их развитием | Более 360 предприятий выполнили переход с использованием этого продукта! | Сэкономьте время - используйте готовое решение для перехода! | Позволяет перенести из УПП 1.3 в ERP / УТ 11 / КА 2 всю возможную информацию | В переносе есть фильтр по организации и множество других опциональных параметров выгрузки | Есть несколько алгоритмов выгрузки остатков на выбор

45650 руб.

04.08.2015    162645    368    273    

358

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

45650 руб.

15.04.2019    70290    173    146    

116

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.228.x) и БП 3.0 (3.0.154.x). Правила подходят для версии ПРОФ и КОРП.

28000 руб.

15.12.2021    21735    144    40    

104

Перенос данных 1C Системный администратор Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

В продаже с 2014г. | Воспользовались более 122 предприятий! | Перенос данных из БП 3.0 в УТ 11 | из БП 3.0 в КА 2 | из БП 3.0 в ERP | Сэкономьте свое время - используйте готовое решение для перехода! | Постоянно работаем над развитием переноса данных | Обновляем на новые релизы 1С | Есть фильтр выгрузки по организациям | Переносятся начальные остатки на выбранную дату, документы за период времени и вся возможная справочная информация | Перенос сделан на технологии КД 2 (правила конвертации данных)

45650 руб.

31.10.2014    234042    93    330    

301

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 руб.

24.06.2020    62307    50    27    

80

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3.87.x и УТ 11.5.16.x

28000 руб.

23.07.2020    48348    208    64    

170

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    184457    572    509    

516
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. vasiliy_b 284 27.11.14 09:53 Сейчас в теме
Почему не использовали правила конвертации?
Так получится меньше изменений в самой конфигурации.
Puk2; Doomino; davdykin; +3 Ответить
7. AlexO 135 16.12.14 10:36 Сейчас в теме
(1) vasiliy_b,
Почему не использовали правила конвертации?
а зачем они здесь вообще нужны?
Так получится меньше изменений в самой конфигурации.

Перенос физлица потребовал изменений в конфигурации? Внешние обработки уже не в почете?
(3) vasiliy_b,
Например сделать внешнюю обработку для справочника, в которой через правила конвертации выгружать текущий элемент справочника

Для правил вообще не нужна своя уникальная ВО. Как и правила обмена - для своей ВО.
(5) Doomino,
и даже внешнюю обработку писать не надо

Совершенно верно. Но народу надо поиграться ))
2. VitRu 6 27.11.14 15:40 Сейчас в теме
В БП нам не нужны, за редким исключением, сотрудники. Этот обмен и написан на это самое редкое исключение (подотчетные лица, водители, ответственные лица). Текучка рабочего персонала значительна. Переносить всех, так просто вредно.
3. vasiliy_b 284 28.11.14 11:13 Сейчас в теме
Почему всех, можно же выборочно переносить. Например сделать внешнюю обработку для справочника, в которой через правила конвертации выгружать текущий элемент справочника, во второй конфигурации подобную обработку, только для загрузки полученного файла.
PS: сам пока не пробовал, но вроде как у в новых конфигурациях сейчас еще и веб сервис запустили, для правил обмена. Так что можно вообще выгружать данные без промежуточного файла.
4. VitRu 6 28.11.14 12:32 Сейчас в теме
Я подумывал над вариантом, о котором Вы говорите, но этот мне показался более удобным в эксплуатации. Как и с физлицами, у меня сделан перенос номенклатурных групп (только наоборот Подрядчик->ЗУП), с регламентированием ведения этого справочника в обеих конфигурациях. Работает уже давно, все довольны. Еще тогда я хотел сделать через Правила, но как-то "коряво" получалось. А ЗУП практически от этого не страдает. ФормаСписка1 все равно остается основной. ЗУП, к сожалению, все равно править приходится: формаТ61(расч.при ув.) при некоторых обстоятельствах кривые начисления показывает; по отмене проведения СдельногоНаряда вопросики; запись документа ОтражениеЗарплатыВРеглУчете правил и еще есть правки, но все по подписке на события и новыми объектами. Накатываю обновления без проблем.
5. Doomino 53 03.12.14 10:21 Сейчас в теме
Вообще-то при использовании конвертации данных не нужно вносить никаких изменений в конфигурации, и даже внешнюю обработку писать не надо - Универсальный обмен XML с диска ИТС прекрасно справляется. Готовых правил конвертации для переноса физлиц на Инфостарте полно.

Возможно, в вашем частном случае это решение и имеет право на жизнь, но тогда не понятно, зачем публиковать его здесь. На универсальность такой вариант не претендует.
6. VitRu 6 03.12.14 12:34 Сейчас в теме
Пользуюсь и Конфигурацией "Конвертация данных" и Универсальным обменом и все равно приходится, как в обсуждаемом случае, писать самому. Это связано с необходимостью обработки данных при переносе. Например: Организация, на тот момент, когда я начал с ней работать, больше половины года дублировала учет, ведя его и в 7.7 и 8.2. При этом никаких обменов не было. Справочники и документы создавались и там и там в ручную (разные коды, наименования, иерархии, состав документов, в 7-ке было то чего не было в 8-ке и наоборот и т.д.). Начинать год с "чистой 8-ки" они категорически отказывались (долго объяснять почему). Я думаю, специалисту все ясно. Я все выровнял и сейчас забыли про 7.7. Это моя первая публикация, хотел немного $m заработать, Вы наверное правы в отношении места публикации, я пока в этом слабо ориентируюсь.
Оставьте свое сообщение