Функция заполнения документа word по шаблону. Аналог функции CRM_ЗаменитьШаблонВВордеНаТекст

Публикация № 364753

Разработка - Универсальные функции

Word заменить текст шаблон Универсальная функция CRM_ЗаменитьШаблонВВордеНаТекст

В организации ключи от CRM постоянно отваливались. Может это были проблемы сервака или самих ключей, но встала задача выполнения работниками тех же функций и без ключей защиты.

Основным функционалом, которым мы пользовались являлась печать договоров и коммерческих предложений из 1С в Word.

В crm это было реализована таким образом: создавался макет договора в формате doc – docx, и сохранялся на диске. Затем в коде получали этот договор, сохраняли на диске под другим именем и уже в этой копии заменялся текст на необходимый. Например, чтобы вставить в макет номер договора у нас нужно было вставить в этот макет текст вида {Номер}.  Обязанности по замене в crm выполняла функция CRM_ЗаменитьШаблонВВордеНаТекст, в которую передавался объект Word. Код этой функции зашит в ключ защиты, что и вызывало такие проблемы.

 

Предлагаю аналог функции «CRM_ЗаменитьШаблонВВордеНаТекст», выполняемый без ключа защиты

////////////////////////////////////////////////////////////////////////////////
//
// Функция ЗаменитьШаблонВВордеНаТекст
// 
// Описание:
//  Ищет, заданный текст в Word Документе. Если текст найден возвращает Истина. 
// 	Также, если передавать Параметр везде, то и выполняет замену найденного текста
// Параметры (название, тип, дифференцированное значение)
// 	Ворд - comobject Word, 
//  ТекстНайти - тип Строка, текст для поиска в документе
//  ТекстЗаменить - тип Строка, текст, на который будет заменятся ТекстНайти, 
// 	Везде - тип Булево (Если не передается, принимает значение Неопределено),
//  указывает где следует производить замену
// ОСНОВНЫЕ ПАРАМЕТРЫ ПЕРЕДАВАЕМЫЕ В ОБЪЕКТ FIND
//  УчитыватьРегистр - Тип Булево.
//  ИскатьЦелоеСлово - Тип Булево.
// 	ИспользоватьДопЗнаки - Тип Булево.
//  ИскатьКакЗвучит - Тип Булево.
// Возвращаемое значение: Истина ИЛИ Ложь	 	
Функция ЗаменитьШаблонВВордеНаТекст(Ворд, Знач ТекстНайти, ОбластьПоиска = Неопределено, Знач ТекстЗаменить = "", Везде = Неопределено, 
	УчитыватьРегистр = Ложь, ИскатьЦелоеСлово = Истина, ИспользоватьДопЗнаки = Ложь, ИскатьКакЗвучит = Ложь)
	
	//Колво раз, сколько нужно заменять текст в документе	
	Если Везде = Неопределено Тогда
		Колво = 0; //ни разу		
	ИначеЕсли Везде Тогда 
		Колво = 2;//Все 
	Иначе 
		Колво = 1;//1 раз
	КонецЕсли; 
	Если ОбластьПоиска = Неопределено Тогда
		ОбластьПоиска = Ворд.ActiveDocument.Content;		
	КонецЕсли; 
	//Если Текст больше 255 знаков, 
	//то вводим его методом печати, а не вставкой
	Если СтрДлина(ТекстЗаменить) > 255 И Колво > 0 Тогда
		ОбластьПоиска.Select();
		ОбластьПоиска	= Ворд.Selection;
		Find			= ОбластьПоиска.Find;
		Найден			= Ложь;
		Попытка
			Пока Find.Execute(ТекстНайти, УчитыватьРегистр, ИскатьЦелоеСлово, ИспользоватьДопЗнаки, ИскатьКакЗвучит) Цикл
				//Печатаем текст замены, если найден
				Ворд.Selection.TypeText(ТекстЗаменить);
				Найден = Истина;
				Если Колво = 1 Тогда
					Прервать 	
				КонецЕсли; 			
			КонецЦикла;
			Возврат Найден;
		Исключение
			Возврат Ложь;	
		КонецПопытки;
	Иначе
		Если Колво = 1 Тогда
			ОбластьПоиска.Select();
			ОбластьПоиска = Ворд.Selection;
		КонецЕсли; 
		
		Find = ОбластьПоиска.Find;
		//Убираем форматирование, чтобы оно не влияло на поиск
		Find.ClearFormatting();
		
		//Параметры объекта Find
		//1 - ТекстПоиска, тип Строка - по умолчанию "", можно использовать для поиска специальные символы:
		// "^p" - для поиска параграфов, "^t" - сиволы табуляции
		//2- УчитыватьРегистр, тип Булево - по умолчанию Ложь
		//3 - ИскатьЦелоеСлово, тип Булево - по умолчанию Истина
		//4 - ИспользоватьДопЗнаки - использует подстановочные знаки - по умолчанию Ложь
		//5 - ИскатьКакЗвучит - Ищет слова похожие по звучанию - по умолчанию Ложь
		//6 - НаправлениеВперед - Указывет направаление поиска вперед - по умолчанию Ложь
		//9 - ИскатьФорматирование - Указывает необходимо ли искать по форматированию - по умолчанию Ложь
		//10 - ТекстЗаменить - Текст для замены
		//11 - Колво - указыавет, сколько раз произоводить замену: 2 - во всем документе, 1 - только первый найденный, 0 - нигде
		Попытка
			Возврат Find.Execute(ТекстНайти,УчитыватьРегистр,ИскатьЦелоеСлово,ИспользоватьДопЗнаки, ИскатьКакЗвучит,,,,,ТекстЗаменить,Колво)
		Исключение
			Возврат Ложь;
		КонецПопытки;
	КонецЕсли;
КонецФункции

P.S. Пишите свои замечания по улучшению кода


Мои работы:

Общее

Перенос данных XML с Анализом и выборочной загрузкой.

Универсальный редактор таблиц и движения документа (LITE) (Обычная Форма)

Универсальный редактор таблиц и движения документа (PRO) (Обычная Форма)

Универсальный редактор Таблиц и Движений документов (Управляемая форма)

Запуск 1С под другим пользователем без пароля.

 

Управление торговлей 11

Установка цен в УТ11. Произвольный запрос к данным ИБ

 

ЗУП 2.5

Скрываем неиспользуемые виды расчета

Резервы отпусков в Документе "Отражение Зарплаты в Регламентированном Учете" (Оценочные Обязательства)

 

Комплексная И УПП

Форма работы с сотрудниками, как из зуп 2.5

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. script 226 05.06.15 01:03 Сейчас в теме
Функция CRM_ЗаменитьШаблонВВордеНаТекст(глКомпонента, Ворд, Знач ШаблонВВорде, Знач ТекстЗамены, Везде = Истина) Экспорт
Попытка
	Если Везде Тогда
		Везде = 1;
	КонецЕсли;

            НетОшибок = Истина;
            
            Selection = Ворд.ActiveDocument.Content;
            //Selection.Find.ClearFormatting();
            //Selection.Find.Replacement.ClearFormatting();
            //
            //Selection.Find.Forward = True;
            //Selection.Find.Wrap = wdFindContinue;
            //
            //Selection.Find.Format = False;
            //Selection.Find.MatchCase = False;
            //Selection.Find.MatchWholeWord = False;
            //Selection.Find.MatchWildcards = False;
            //Selection.Find.MatchSoundsLike = False;
            //Selection.Find.MatchAllWordForms = False;
            //
            //Selection.Find.Text = "";
            //Selection.Find.Replacement.Text = "";
            
            wdReplaceNone = 00000000; // не заменять
            wdReplaceOne  = 00000001; // заменять одно вхождение/по порядку
            wdReplaceAll  = 00000002; // заменить все вхождения
            
            // Начало табличной части
            Если (ШаблонВВорде = "{НачалоТаблицыОбязательныйПрефикс}") Тогда
                
                ПоискИЗамена = Selection.Find;
                ПоискИЗамена.Forward = -1;
                ПоискИЗамена.Text = ШаблонВВорде;
                ПоискИЗамена.Replacement.Text = "";
                ПоискИЗамена.Execute(, , , , , , , , , ,wdReplaceOne);
                
                Если ПоискИЗамена.Found Тогда
                    
                    Таблица = ПоискИЗамена.Parent;
                    Таблица.Select();
                    
                Иначе
                    
                    НетОшибок = Ложь;
                    
                    Если Константы.script_ВключитьРежимОтладки.Получить() Тогда
                        Сообщить(ОписаниеОшибки());
                    КонецЕсли;
                    
                КонецЕсли;
                
            Иначе
                
                Если Везде = 1 Тогда
                    
                    ПоискИЗамена = Selection.Find;
                    ПоискИЗамена.Forward = Истина;
                    ПоискИЗамена.ClearFormatting();
                    ПоискИЗамена.Replacement.ClearFormatting();	
                    
                    ПоискИЗамена.Text             = ШаблонВВорде;
                    ПоискИЗамена.Replacement.Text = ТекстЗамены;
                    ПоискИЗамена.Execute(, , , , , , , , , ,wdReplaceAll);
                    
                Иначе
                    
                    ПоискИЗамена                  = Selection.Find;
                    ПоискИЗамена.ClearFormatting();
                    ПоискИЗамена.Forward          = -1;
                    ПоискИЗамена.Wrap             = 1;
                    ПоискИЗамена.Text             = ШаблонВВорде;
                    ПоискИЗамена.Replacement.Text = ТекстЗамены;
                    ПоискИЗамена.Execute(, , , , , ,1 ,1 , , ,wdReplaceOne);
                    Если ПоискИЗамена.Found Тогда
                        
                        Таблица = ПоискИЗамена.Parent;
                        Таблица.Select();
                        
                    Иначе	
                        
                        НетОшибок = Ложь;
                        
                        Если Константы.script_ВключитьРежимОтладки.Получить() Тогда
                            Сообщить(ОписаниеОшибки());
                        КонецЕсли;
                        
                    КонецЕсли;
                КонецЕсли;
            КонецЕсли;
            
        КонецЕсли;
        // - {SCRIPT} 
		
    Исключение КонецПопытки;
	
Возврат Истина;
	
КонецФункции
Показать
karpik666; +1 Ответить
4. karpik666 2923 05.06.15 03:41 Сейчас в теме
(1) script, это откуда такое счастье? Это ваш код или это закрытый модуль? :-)
2. script 226 05.06.15 01:06 Сейчас в теме
Функция CRM_ЗаменитьШаблонВOpenOfficeНаТекст(глКомпонента, Параметры, ТегиКолонок) Экспорт
		Попытка
			Если ТегиКолонок Тогда
				
				Для Каждого Тег Из Параметры.ТаблицаТегов Цикл //заполнение строк номенклатуры и итогов по разделам
					Результат = CRM_ПолучитьРезультатВыполненияДействия(Тег.Действие, Параметры.СтрокаМассива, Параметры.Параметры);
					
					СтруктураПараметров = Новый Структура;
					СтруктураПараметров.Вставить("ОбъектOpenOffice"	, Параметры.Параметры.ОбъектВорд);
					СтруктураПараметров.Вставить("СтрокаПоиска"		, Тег.Представление);
					СтруктураПараметров.Вставить("СтрокаЗамены"		, CRM_ОбработатьСтрокуЗамены(Результат));
					
					CRM_ЗаменитьШаблонВOpenOfficeНаТекст(глКомпонента, СтруктураПараметров, Ложь);
					
				КонецЦикла;	
				
			Иначе
				
				OpenOffice = Параметры.ОбъектOpenOffice;
				Replace               = OpenOffice.CreateReplaceDescriptor();
				Replace.SearchString  = Параметры.СтрокаПоиска;
				Replace.ReplaceString = CRM_ОбработатьСтрокуЗамены(Параметры.СтрокаЗамены);
				
				OpenOffice.ReplaceAll(Replace);
				
			КонецЕсли;
			
			Возврат Истина;
			
		Исключение
			
			Сообщить(ОписаниеОшибки());
			Возврат Ложь;
			
		КонецПопытки		
	
КонецФункции

Показать
3. h00k 42 05.06.15 03:41 Сейчас в теме
(0) ОМГ, а остальные защищенные процедуры и функции не нужны?!
Всегда думал что в црм основные функции это работа с бизнес процессами и т.п., а оказывается вот оно как, замена шаблона в ворде важнее...

П.С.: Полное отключение защиты - 5 минут, производится изменением пары строк в конфигурации и его гораздо проще поддерживать чем "дописанные" процедуры. Но гораздо правильнее сначала научиться настраивать ключи защиты, так-как защита у рарус не самая "глючная" и если возникли такие сложности, то это говорит, скорее всего, о "кривой" настройке сервера...
5. karpik666 2923 05.06.15 03:47 Сейчас в теме
(3) h00k, конфигурации уже 8 лет, не обновлялась и столько же ключам, может действительно виноват сервак, но им занимался другой человек, еще был конфликт из за Ос, когда на сервер поставили Windows 2012. Про строчки знаю, которые нужно закомментировать, и бизнес процессы работают и без ключа, а вот доп функции нет, так как код зашит в ключ защиты :-(
8. h00k 42 05.06.15 05:41 Сейчас в теме
(5)
Про строчки знаю, которые нужно закомментировать,

Просто закомментировать - это не решение, это потеря основного функционала.

поводом отказаться от защиты crm это еще то, что с ней конфигурация запускается капец как долго, пока пройдут все проверки=)

На правильно настроенной системе проверка файлов защиты в 1.4 занимает пару секунд, а в 2.0 и того быстрее.
А по поводу отключения защиты, я могу вспомнить лишь один случай, когда это имело смысл - необходимо было заставить црм 1.4 работать на линукс.
6. karpik666 2923 05.06.15 03:50 Сейчас в теме
(3) h00k, большинство функций не нужны были, хотя нужно было еще штрихкод вставлять, но эту проблему решили наподобии этого кода.
7. karpik666 2923 05.06.15 04:24 Сейчас в теме
(3) h00k, поводом отказаться от защиты crm это еще то, что с ней конфигурация запускается капец как долго, пока пройдут все проверки=)
9. script 226 05.06.15 09:25 Сейчас в теме
Отключать защиту приходится при серьезной доработке црм.
Я собираюсь, начать публиковать цикл статей о том, чего так не хватает в црм 1.4, и как это реализовать. И в некоторых случаях, без обхода защищенных функций, просто не обойтись.
10. StepanBY 24.03.20 10:44 Сейчас в теме
(9)

Может поделитесь содержанием или описанием работы

ВыбратьСледующиеТочкиМаршрута
ПолучитьСписокВыбораНастройкиУсловия
ПрименитьФильтр
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76761    Serginio    108    

Отпускной период (период основного отпуска) - как его узнать

Зарплата Универсальные функции v8 v8::СПР v8::УФ ЗУП3.x Россия БУ Бесплатно (free)

Пришла мне задача где нужно получить отпускной период, на просторах сети решения я не нашел. Решил поделиться с вами своим решением.

26.10.2020    200    Danila7Zz    1    

Произвольные колонтитулы и повтор шапки таблицы в табличном документе (функция)

Универсальные функции v8 Бесплатно (free)

Пример рекурсивной функции, при помощи которой в табличный документ можно выводить верхний или нижний колонтитулы с произвольным содержимым, а также делать повтор шапки таблицы (или таблиц, если их несколько).

07.10.2020    943    ellavs    1    

Печать в word, pdf через html

Печать Практика программирования Универсальные функции v8 Россия Бесплатно (free)

При работе с клиентами возникла задача: использовать форматированный документ. Итак, существует справочник, в нем табличная часть. Для каждой строки требуется ввести описание, причем описание имеет тип форматированный документ. Потребовалось организовать печать табличной части справочника с описанием для каждой строки. Тип данных "Форматированный документ" не может выводится в табличный документ, поэтому пришлось организовывать печать через Microsoft Word.

11.09.2020    785    arr    4    

Универсальный редактор табличных частей и движений документов (PRO) (Обычная Форма) Промо

Универсальные обработки Обработка документов v8 1cv8.cf Платные (руб)

Устали редактировать документы вручную? Сэкономьте время и деньги, ускорив рутинную работу с документами.

1000 руб.

25.01.2016    22178    10    4    

Самый простой парсинг и обработка веб-страниц в 1С

WEB Универсальные функции v8 1cv8.cf Бесплатно (free)

Рассмотрим самый простой парсинг веб-страниц средствами платформы 1С и еще некоторые полезные приемы работы с веб-страницами.

07.08.2020    4773    YPermitin    18    

Выполнение внешней обработки по расписанию для управляемого и обычного приложения

БСП (Библиотека стандартных подсистем) Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Использование БСП для выполнения внешних обработок в управляемом и обычном приложении

06.08.2020    1422    RPGrigorev    0    

Пользовательское поле СКД одной процедурой

Практика программирования Универсальные функции v8 Бесплатно (free)

Быстрое создание пользовательского поля "выражение" одной процедурой

05.08.2020    1591    Yashazz    0    

Универсальные функции с примерами использования Промо

Универсальные функции v8 Бесплатно (free)

14 универсальных функций, с примерами использования - для обычного и управляемого интерфейса

26.02.2016    41319    unichkin    46    

Полезные встроенные функции для работы с печатными формами и не только на УТ 11.4 и БП 3.0 (сравнение)

Универсальные функции v8 БП3.0 УТ11 Россия Бесплатно (free)

В данном обзоре приведу примеры встроенных используемых функций для работы с печатными формами на примерах конфигураций Управление торговлей 11.4 и Бухгалтерия 3.0.

10.07.2020    3020    quazare    5    

Вывод дерева в табличный документ СКД

Практика программирования Универсальные функции v8 v8::СКД Бесплатно (free)

Вывод содержимого элемента формы "ДанныеФормыДерево" в табличный документ средствами СКД.

09.07.2020    2648    Yashazz    6    

Ещё немного функционального стиля в 1С или Как нам отфильтровать таблицу значений

Универсальные функции v8 Россия Бесплатно (free)

Потребовалось накладывать хитрые отборы на таблицу значений в сотни строк и десятки колонок, однако Скопировать со структурой отбора мне не подошло. Пришлось немного покреативить, подсмотрев, как это делается в других языках - возможно, получилось несколько топорно, но тем не менее - работает.

16.05.2020    2847    GlebHappy    34    

Минимализмы 3 Промо

Практика программирования Универсальные функции v8 Бесплатно (free)

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    46800    ildarovich    45    

Сходство Джаро - Винклера. Нечеткое сравнение строк

Универсальные функции v8 Россия Бесплатно (free)

В области информатики и статистики сходство Джаро - Винклера представляет собой меру схожести строк для измерения расстояния между двумя последовательностями символов. В публикации рассмотрены некоторые особенности алгоритма, и представлен вариант его реализации на языке 1С.

25.12.2019    7087    brooho    17    

Функция - Формат государственного номера автомобиля

Универсальные функции v8 Автомобили, автосервисы Россия Бесплатно (free)

Возникла необходимость в приведении к единому формату хранящихся, и вводимых вновь, автомобильных Регистрационных знаков - Гос.номер.

23.12.2019    3791    brooho    4    

Полезности | Дерево значений | Обычные формы |

Практика программирования Универсальные функции v8 Бесплатно (free)

Полезные функции при работе с деревом значений.

04.12.2019    5704    Mellow    7    

Универсальная функция для программного выполнения СКД Промо

Инструментарий разработчика Универсальные функции v8::СКД 1cv8.cf Бесплатно (free)

Часто встречаются вопросы на форумах о программном формировании СКД. Вроде и информации много по этому поводу, но... Все как всегда :) Собственно, в описании без лишних слов выложен текст общей функции, в которую, для выполнения отчета, нужно передать (минимум 2 параметра): СКД и ТабличныйДокумент.

20.05.2015    30649    dj_serega    18    

Обработка расширением на клиенте

Расширения Универсальные функции v8::УФ 1cv8.cf Бесплатно (free)

Описываю нетривиальный прием работы с расширением, который позволит относительно быстро реализовывать некоторые обработки данных. Суть: обработка данных на клиенте с использованием методов, которые реализованы разработчиком конфигурации на форме объекта. Если эти методы есть вне модуля формы объекта (общий модуль, модуль менеджера, модуль объекта)- лучше сделать обработку более простым способом.

31.10.2019    7167    EvgenURNN    10    

Использование XML-схемы из макета внешней обработки

Обмен через XML Универсальные функции v8 1cv8.cf Бесплатно (free)

Простой способ использования XML-схем из макета внешней обработки.

28.10.2019    10975    Olesia_Matusevich    10    

Быстрое создание наполненных коллекций

Практика программирования Универсальные функции v8 1cv8.cf Бесплатно (free)

Разберем самые частые способы создания коллекции, значения которой известны заранее. И сравним скорость их выполнения.

28.10.2019    7222    SeiOkami    66    

Выполнение произвольного кода в фоновых заданиях Промо

Универсальные функции v8 Бесплатно (free)

Если надо быстро провести 100`000 документов...

13.01.2016    24690    unichkin    13    

Преобразование XML в таблицу значений или иной объект 1С методом XSL преобразования

Универсальные функции Обмен через XML v8 1cv8.cf Бесплатно (free)

Сразу открою интригу, напрямую прочитать XML, не содержащий объект 1С, не удастся. Статья раскрывает способы привести XML к формату, который возможно прочитать средствами платформы.

24.10.2019    11500    kraspila    30    

Обертка функций Excel на русском. Ускорение процесса разработки.

Загрузка и выгрузка в Excel Универсальные функции v8 Бесплатно (free)

Устали переключаться с русского на английский и обратно при работе с таблицами Excel из 1С? Сборка наиболее необходимых функций и методов работы с Excel, обернутых в функции 1С на русском языке.

24.10.2019    7281    DmitryKotov    6    

Функция СтрШаблон с именованными маркерами

Универсальные функции v8 1cv8.cf Бесплатно (free)

Функция позволяет задавать именованные маркеры формата [Имя], в отличии от типовых нумерованных формата %n

1 стартмани

21.10.2019    4514    kirinalex    27    

Распределение оплаты по товарам Промо

Практика программирования Универсальные функции v8 1cv8.cf Бесплатно (free)

Учебная задача. Оплата приходит по заказу. Требуется запросом распределить её по товарам. Практическая задача была сложнее. Упростил специально для иллюстрации. Сначала собираем в одну таблицу заказы и товары. Затем ОБЪЕДИНТЬ ВСЕ с оплатами. Потом намазываем оплату на товар.

04.08.2014    19176    Трактор    5    

Полезняшки по СКД и построителям. Просто код

Практика программирования Универсальные функции v8 v8::СКД Бесплатно (free)

Полезные процедуры и функции для работы с построителями и СКД. Просто исходник.

10.10.2019    10077    Yashazz    45    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    32028    ids79    16    

Сканируем без сканера или MXL to JPG Промо

Внешние источники данных Универсальные функции Печатные формы документов v8 1cv8.cf Бесплатно (free)

Хотите конвертировать документы в формат изображения менее чем за минуту, не имея сканера? Тогда эта статья для вас.

24.05.2012    34156    shakmaev    47    

Сохранение запроса со всеми параметрами и временными таблицами

Универсальные функции v8 v8::УФ Россия Бесплатно (free)

Функция сохранения запроса со всеми параметрами и временными таблицами в формате *.q1c для открытия в консоли запросов с диска ИТС.

13.05.2019    6523    Serge R    5    

Иерархия справочника Сверху Вниз. Получаем произвольное количество родителей "верхнего" уровня

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Иерархия справочника Сверху Вниз. Функция для получения произвольного количества родителей "верхнего" уровня. На примере справочника "Номенклатура".

28.03.2019    6163    obsfromekb    11    

Доработка проведения типовых документов в УТ 11.4, КА 2.4, ЕРП 2.4

Практика программирования Универсальные функции Разработка v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Бесплатно (free)

Различные варианты корректировки типовых механизмов проведения документов, без корректировки основной конфигурации. Использование расширений, подписок на событие и механизма локализации типовых документов.

22.03.2019    18065    ids79    16    

Добавление отчетов в типовые конфигурации 1С

Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем) v8::УФ v8::СКД 1cv8.cf Бесплатно (free)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    55256    ids79    46    

Расширение конструктора мобильного рабочего места для варианта "клиент 1С+RDP" (для любых wi-fi терминалов). Экосистема решений Simple WMS

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Универсальные функции Мобильная разработка Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8::УФ УУ Бесплатно (free)

Развитие проекта «Конструктор мобильного клиента на Android» https://infostart.ru/public/976636/ для устройств не на Андроиде (работающих в режиме RDP). В отличие от варианта Android работа на терминалах происходит в режиме 1С:Предприятие через RDP а конфигурации мобильных клиентов полностью совместимы для обоих версий. Т.е. конфигурация единая, создается один раз и ее может читать как Android -устройство, так и 1С-клиент на RDP без необходимости какой либо переделки.

05.02.2019    13099    informa1555    10    

Работа со строками: от простого к сложному

Практика программирования Универсальные функции v8 Бесплатно (free)

Простые примеры работы со строками, в конце более читаемый разбор сложных текстов.

14.01.2019    31537    Evg-Lylyk    17    

Нумерация колонок субконто при выгрузке набора записей регистра бухгалтерии в таблицу значений

Универсальные функции v8 Бесплатно (free)

Решение проблемы несовпадения номеров колонок с номерами субконто на счете при выгрузке в таблицу значений.

14.01.2019    5660    The Ded    6    

Многопоточное восстановление последовательностей

Производительность и оптимизация (HighLoad) Практика программирования Математика и алгоритмы Универсальные функции v8 Бесплатно (free)

Универсальный алгоритм многопоточного фонового восстановления любой последовательности.

05.12.2018    13376    _ASZ_    33    

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке

Универсальные функции Зарплата Управление персоналом (HRM) Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Бесплатно (free)

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    91136    GeterX    121    

Кадровые данные сотрудников в ЗУП 3.1 в отчетах

Универсальные функции Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия Бесплатно (free)

Параметры используемые для получения данных сотрудников в ЗУП 3.1. Пригодится для разработки отчетов как напоминалка.

07.11.2018    34342    fromlion    23    

Добавление расшифровки в стандартные и добавленные внешние отчеты со стандартной формой отчета на СКД

Универсальные функции v8::УФ v8::СКД ERP2 УТ11 Россия Бесплатно (free)

Описан способ добавления расшифровки отчета на СКД как встроенного в систему, так и добавленного внешнего отчета.

27.09.2018    10948    bmk74    8    

Функция НайтиФайлы() в каталоге netshare на Linux - обход ошибки работы

Практика программирования Универсальные функции v8 Бесплатно (free)

Решение проблемы применения функции НайтиФайлы() в каталоге с netshare на Linux-сервере - не работает поиск файлов по указанной маске (шаблону)

19.09.2018    6340    drmaxart    3    

Простой способ программно открыть заполненную форму нового (незаписанного) документа в тонком клиенте

Универсальные функции v8 Бесплатно (free)

В этой публикации я поделюсь своим способом открывать программно новый незаписанный документ в тонком клиенте. Для использования этого способа потребуется немного модифицировать конфигурацию. Добавив универсальные процедуру и функцию, можно будет использовать их для любых документов/справочников.

09.06.2018    11401    Serge R    12    

Генерация временного ряда запросом

Универсальные функции v8 v8::Запросы 1cv8.cf Бесплатно (free)

Способ генерации последовательности дат средствами языка запроса 1С.

07.05.2018    8758    dim_zal    6    

Таблица значений в Таблицу HTML - функция с возможностью настройки цвета шапки, заголовков, выравнивания и размера колонок

Практика программирования Универсальные функции v8 1cv8.cf Бесплатно (free)

Если вам нужно быстро получить таблицу значений в виде строкового типа 1С в формате HTML, вам поможет эта функция, включена возможность автоматического вывода столбца пункт по порядку.

22.12.2017    25542    rpgshnik    22