1C + ЭДО Мегафон

Публикация № 437112

Разработка - Практика программирования

ЭДО

Тестируем модуль обмена 1С с ЭДО Мегафон (модуль прилагается пользователям ресурса ЭДО Мегафон бесплатно).

Пару недель назад получил приглашение от партнера ПАО Мегафон для участия в электронном документообороте, и хотел бы поделиться, что нового для себя открыл в этой системе. Начнем с регистрации, переходим на ссылку ресурса https://doc.megafon.ru/Account/Login вносим свой почтовый адрес и далее реквизиты компании, все достаточно просто и понятно, пару подтверждений и мы уже в личном кабинете. Для нас уже подготовлено заявление на присоединение к СЭД, и первым делом начнем с регистрации электронной подписи, для этого мы можем использовать уже имеющийся для сдачи отчетности ключ и сертификат. Как ни странно, на всю эту операцию понадобилось минуты две, и пока мы ждем подтверждение по СЭД, посмотрим раздел "Документы". В нем мы можем создать по шаблону формализованные документы, делаем сразу документ "Акт на работы"  и сохраним его, подписывать мы пока не можем. Второй вариант: сканируем наш акт и крепим через загрузку произвольных форм, третий вариант: можем загружать «xml» версию акта, но ее у нас пока готовой нет. Пока все это проделывали, уже пришло подтверждение заявления, и теперь можем подписать документы. Пробуем подписать, но «Chrome» ругается на поддержу NАPI, поэтому его закрываем и переходим в имеющийся встроенный «Explorer», в нем все спокойно подписываем и жмем "Получить/Отправить", документооборот с нашей стороны готов.  На тестирование ресурса дается 14 дней, и предлагает приобрести тарифы, которые на мой взгляд на текущий момент самые гибкие, меня устроит тариф 100 документов на год стоимостью 1000 рублей, его и выбираем. После окончания тестового периода автоматически переходим на тариф "0", который может только принимать входящие документы, т.к. они бесплатны.

Смотрим дальше интерфейс ресурса, в нем видим раздел "Модуль 1С", в котором находится сам модуль и инструкция к нему. Что хотим получить, естественно обмениваться с ресурсом документами из учетной системы в режиме клиента, для этого нам и понадобится настроить данную обработку. Пробуем открыть обработку под 8.3 платформой управляемый режим - ошибка, переходим в обычный режим толстого клиента и в нем видим окно входа, сразу предлагающее логин и пароль нашей регистрации. Проходим регистрацию и получаем интерфейс, по функционалу схожий с веб-ресурсом, т.е. можем уже документы отправлять прямо из 1С. Но всего этого будет мало для компании с оборотом документов более 500 листов в день, рассылать такое количество клиентам будет трудозатратно. Открываем конфигуратор и начинаем подготовку к разработке: 1. Обменника в управляемом режиме; 2. Настройке плана обмена для регистрации ЭДО, с возможностью автоматической рассылки проведенных документов.

Пока наши специалисты готовят задание, посмотрим, что же предлагает готового обработка. Модуль формы и модуль объекта говорит о том, что управляемый режим все же не предусмотрен. Поддерживаемые для интеграции конфигурации 1С:  некая "Универсальная интеграция", "Интеграция бухгалтерия", "УПП13", "КА", "УТ102", "УТ103" и зачем-то выделена "Интеграция АльфаАвто41". Просматривая список всех модулей, имя самой обработки "UnicloudBusiness365", делаем вывод что за основу взят проект компании "ЮниКлауд Лабс" - эта компания создана в 2011 году, входит в группу компаний АйТи, является резидентом «Сколково» с сентября 2011 года. В январе 2012 года получила грант от фонда «Сколково» на развитие. Компания имеет офисы в Москве и УфеСистема «Unicloud Business 365» была анонсирована в середине 2012 года. Она представляет собой облачный сервис для совместной работы сотрудников небольшой компании, включающий управление поручениями, учет и ведение клиентов, проектную деятельность и работу с первичными документами. Система интегрирована с операторами электронного документооборота – «Калуга Астрал», «СКБ Контур», «Такском». Есть хороший видеоматериал,демонстрирующий функционал "UnicloudBusiness365" системы https://www.youtube.com/watch?v=Tky1HgCL-6g.

Продолжим дальше, теперь у нас есть информация, что основой ресурса является функционал интеграции с нашими почтовыми ящиками, все это хорошо, но интересует, как же происходит обмен с технической точки зрения. Модуль JSON наводит на мысль, что использован данный формат, но фактов пока нет, предполагалось, что все же в «xml» формате. Смотрим найденную команду выгрузки, она же оказалась и командой загрузки:

функция ВызовАпиБизнес365(АдресРесурса, Метод, ТелоЗапроса = неопределено, CАвторизацией = Истина, СОкномОшибки = истина) экспорт
	ВывестиОкноАвторизации = ложь;
	ВывестиОкноОшибки = ложь;
	Попытка
		НастройкиАпи = НастройкиАпиБизнес365();
		Соединение = Новый HTTPСоединение(НастройкиАпи.host,НастройкиАпи.port , , , ); 
		Заголовки = Новый Соответствие();
		Заголовки.Вставить("host", НастройкиАпи.hostport);
		Заголовки.Вставить("Content-Type", "application/json");
		АдресРесурсаПолный = НастройкиАпи.apiversion + АдресРесурса;
		Если CАвторизацией = Истина тогда
			дата = ТекущаяДата();
			данные = Строка(дата) + АдресРесурсаПолный;
			ключ = Нрег(ОдинСАдаптер_НастройкиТекущегоПользователя_ПолучитьНастройку("Бизнес365КлючПользователя"));
			hash = ПолучитьМодуль("Модуль_SHA1").ПолучитьSHA(ключ, данные);
			hash64 = ПолучитьМодуль("Модуль_Base64").КодироватьМассивБайтовВСтроку6Бит(hash);
			логинПользователя = ОдинСАдаптер_НастройкиТекущегоПользователя_ПолучитьНастройку("Бизнес365ЛогинПользователя");
			Заголовки.Вставить("X-Authorization", ?(ЗначениеЗаполнено(логинПользователя),логинПользователя,"")  + ":" + hash64 + ":auth2");
			Заголовки.Вставить("X-Date", дата);
		КонецЕсли;
		Если Метод = "POST" тогда
			Запрос = Новый HTTPЗапрос(АдресРесурсаПолный, Заголовки);
			Если ЗначениеЗаполнено(ТелоЗапроса)=Истина тогда
				ТелоJson = ПолучитьМодуль("Модуль_JSON").ЗаписатьJSON(ТелоЗапроса, ИСТИНА);
				Запрос.УстановитьТелоИзСтроки(ТелоJson);
			КонецЕсли;
			Ответ = Соединение.ОтправитьДляОбработки(Запрос); 
		КонецЕсли;
		Если Метод = "GET" тогда
			Если ЗначениеЗаполнено(ТелоЗапроса)=Истина тогда
				Первый = Истина;
				Для Каждого Элемент Из ТелоЗапроса Цикл
					Если Первый Тогда
						АдресРесурсаПолный = АдресРесурсаПолный + "?";
						Первый = Ложь;
					Иначе
						АдресРесурсаПолный = АдресРесурсаПолный + "&";
					КонецЕсли;
					АдресРесурсаПолный = АдресРесурсаПолный + Элемент.Ключ;
					АдресРесурсаПолный = АдресРесурсаПолный + "=";
					АдресРесурсаПолный = АдресРесурсаПолный + Элемент.Значение;
				КонецЦикла;
			КонецЕсли;
            Запрос = Новый HTTPЗапрос(АдресРесурсаПолный, Заголовки);
			Ответ = Соединение.Получить(Запрос); 
		КонецЕсли;
		РезультатJson = Ответ.ПолучитьТелоКакСтроку();
		Результат = ПолучитьМодуль("Модуль_JSON").ПрочитатьJSON(РезультатJson, ИСТИНА);
		Data = Результат["Data"];
		Если Ответ.КодСостояния = 401 Тогда
			ВывестиОкноАвторизации = истина;
		ИначеЕсли Результат["Status"]["Code"] <> "Ok" Тогда
			ТекстИсключения = Результат["Status"]["Message"];
			Если CАвторизацией И СОкномОшибки Тогда
				ВывестиОкноОшибки = истина;
			КонецЕсли;
		КонецЕсли;
	Исключение
		ВызватьИсключение ("Ошибка при запросе к " + НастройкиИмяСистемы());
	КонецПопытки;
	Если ВывестиОкноАвторизации Тогда
		РешениеОшибкиАвторизации();
		Возврат ВызовАпиБизнес365(АдресРесурса, Метод, ТелоЗапроса, CАвторизацией)
	КонецЕсли;
	Если ВывестиОкноОшибки Тогда
		РешениеОшибки(ТекстИсключения);
		Возврат ВызовАпиБизнес365(АдресРесурса, Метод, ТелоЗапроса, CАвторизацией)
	КонецЕсли;
	Если ЗначениеЗаполнено(ТекстИсключения) Тогда
	    ВызватьИсключение (ТекстИсключения);
	КонецЕсли;
    Возврат Data;
конецФункции

...вот и нашлось "ТелоJSON"- значит, обмен с узлом в формате JSON, и недавно подготовленная публикация //infostart.ru/public/436405/ на данную тему пригодится, тем более, что планируем интегрироваться не только с 1С 8.3 платформой, но и с базами на различных СУБД. Код модуля достаточно "прозрачный", на подготовку задания для ускорения обмена, думаю, уйдет не так много времени, и результат нас устроит.

Продолжение следует...

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. romanco 13 21.12.15 22:37 Сейчас в теме
Может быть что-то поменялось за последние полгода, но по ЭДО с клиентами они вроде бы не работают.
ПАО Мегафон ваш клиент или поставщик услуг?
2. JetBrain 22.12.15 05:59 Сейчас в теме
(1) romanco, ...и клиент и поставщик. ЭДО не только для внутренней работы с Мегафоном, список контрагентов любой можно создать. Удобство системы к примеру в том, что даже если у вашей компании почта не корпоративная, то контролировать обмен документами будет очень удобно и просто.
3. worker1c 114 22.12.15 09:47 Сейчас в теме
Через чей сервис производится обмен данными,см НастройкиАпиБизнес365(), Мегафон или оператора ЭДО?
Возможно ли обмениваться счет-фактурами?
Что такое интеграция с почтовыми ящиками?
4. JetBrain 22.12.15 14:19 Сейчас в теме
(3) worker1c, узлы обмена видимо меги:
функция НастройкиАпиБизнес365() экспорт
	система = НастройкиСистемаБизнес365();
	Если система = "system.megafon" Тогда
		Возврат Новый Структура(
				"host, port, hostport, apiversion", 
				"system.megafon.ru", 8081, "system.megafon.ru:8081", "/api/1.0");
	ИначеЕсли система = "system.system" Тогда
		Возврат Новый Структура(
				"host, port, hostport, apiversion", 
				"api.system.ru", , "api.system.ru", "/api/1.0");
	ИначеЕсли система = "production" Тогда
		Возврат Новый Структура(
				"host, port, hostport, apiversion",
				"doc.megafon.ru", "8081", "doc.megafon.ru:8088", "/api/1.0");
	Иначе
		Возврат Новый Структура(
				"host, port, hostport, apiversion", 
				"developer.business365.ru", "8088", "developer.business365.ru:8088", "/api/1.0");
    КонецЕсли;
конецФункции
Показать

Документы делятся на два типа, формализованных и неформализованных (по ним лимит почти в 10 раз больше). Счет-фактура да есть.
Интеграцию лучше посмотреть видео про Бизнес365 в паблике, для самого сервиса ЭДО нужен только адрес почты для регистрации и входа.
Оставьте свое сообщение

См. также

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    36815    unichkin    46    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    22187    ids79    26    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    20671    John_d    22    

Последовательности событий. Шпаргалка

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    15434    kuzyara    33    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    29336    tormozit    100    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    16283    YPermitin    72    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    7886    Sibars    19    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    30319    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    77215    tormozit    131    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    43886    rpgshnik    63    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    45454    ids79    54    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    26235    YPermitin    24    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    47511    tormozit    40    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    24862    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    30109    ids79    16    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    72418    ids79    49    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    43847    tormozit    74    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    31663    avalakh    22    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    21652    json    13    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    53508    ids79    11    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    15858    m-rv    2    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    33871    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    25153    YPermitin    14    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    19300    SeiOkami    50    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    19875    m-rv    17    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    41859    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    48997    ids79    25    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    23964    dmurk    144    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    29998    m-rv    21    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    40461    YPermitin    30    

Выполнение внешней обработки в фоновом задании

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    28439    Eret1k    23    

Интеграция решений на 1С и сервиса обмена данными RabbitMQ

Внешние источники данных v8 1cv8.cf Бесплатно (free)

"Hello world" из 1С на сервер RabbitMQ и обратно. Полностью открытый код 1С! Реализация протестирована на 1С 8.3.12.1714 (x64).

24.04.2019    18094    Eret1k    52    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    27998    itriot11    34    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    34280    ellavs    126    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    26566    ellavs    88    

RabbitMQ + Конвертация Данных 3.0

Внешние источники данных Обмен через XML Интеграция Перенос данных из 1C8 в 1C8 v8 КД Бесплатно (free)

Предлагаем ознакомиться с хронологией проекта, проследить ход мыслей от снятия потребностей до реализации, и решить, удалось ли проектной команде найти оптимальное архитектурное решение под конкретный кейс заказчика путем совмещения двух известных, но до сих пор не пересекавшихся технологий, и получилось ли сложить плюсы и устранить минусы каждой из них.

21.03.2019    25603    barelpro    82    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    75512    Serginio    108    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    30417    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    36133    Смешной 1С    27    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    20993    Vladimir Litvinenko    27    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    33729    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    36984    ids79    9    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    28887    grumagargler    28    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    25789    ids79    31    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    39600    ids79    72    

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации

Практика программирования Обмен через XML v8 v8::УФ БП3.0 УТ11 Россия Бесплатно (free)

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    35896    ids79    40    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Практика программирования v8 Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    51816    m-rv    61    

Программное заполнение пользовательских параметров и отборов СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    44140    Unk92    21