Изменения параметра или отбора типа Дата в форме отчета

Публикация № 454913

Разработка - Универсальные функции

Унивельсальные функции конецгода конецполугодия конецквартала конецмесяца конецнедели конецдня началодная началонедели началомесяца началоквартала Началополугодия началогода

Иногда в отчетах стандартных периодов (Начало текущего месяца, начало следующего месяца и т.д.) недостаточно. Приходится ставить произвольную дату и устанавливать периоды вручную (конец месяца, конец недели и т.д.).
В публикации выложен листинг кода, который должен ускорить установку параметров и отборов с типом Дата.

Описание

Данные функции реализованы в форме отчета.

Поиск поля для изменения выполняется по "Наименованию" отбора или параметра. Поэтому если имя поля отбора = имени параметра, будет выполнена замена значения параметра.

Пример (нюанс):

Есть параметр - "Дата"
Есть отбор - "Дата"

При изменении отбора будет выполнена корректировка параметра.


Реализация

1. Для реализации текущего функционала нужно создать 11 команд отчета.

УстановитьДатуВКонецГода
УстановитьДатуВКонецДня
УстановитьДатуВКонецМесяца
УстановитьДатуВКонецНедели
УстановитьДатуВКонецПолугодия
УстановитьДатуВНачалоГода
УстановитьДатуВНачалоДня
УстановитьДатуВНачалоМесяца
УстановитьДатуВНачалоНедели
УстановитьДатуВНачалоПолугодия
УстановитьДатуВТекущееВремя

2. Вынести созданные команды в контекстное меню табличного поля "КомпоновщикНастроекПользовательскиеНастройки":

//infostart.ru/upload/iblock/f33/%D0%A1%D0%BD%D0%B8%D0%BC%D0%BE%D0%BA2.PNG

3. В модуль формы отчета вставить следующий листинг:

&НаКлиенте
Процедура ИзменитьПараметрДата(Команда)
	
	// КомпоновщикНастроекПользовательскиеНастройки - это имя табличного поля с настройками отчета
	ТекущиеДанные = Элементы.КомпоновщикНастроекПользовательскиеНастройки.ТекущиеДанные;
	Если ТекущиеДанные = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	ИмяКоманды = Команда.Имя;
	
	
	Если Найти(ИмяКоманды, "УстановитьДату") Тогда
		
		ЗначениеИзменено = Ложь;
		
		// Первым делом выполним поиск поля в параметрах отчета
		#Область Изменения_в_параметрах
		ЭлементыПараметров = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.ДоступныеПараметры.Элементы;
		Для Каждого ТекущийЭлементПараметров Из ЭлементыПараметров Цикл
			// Перебот параметров отчета
			
			Если ТекущиеДанные.Настройка = ТекущийЭлементПараметров.Заголовок Тогда
				
				ЭлементыПользовательскихНастроек = Отчет.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
				Для Каждого ТекущийЭлементПользовательскойНастройки Из ЭлементыПользовательскихНастроек Цикл
					// Перебор элементов пользовательских параметров
					
					Если ТекущийЭлементПараметров.Параметр = ТекущийЭлементПользовательскойНастройки.Параметр Тогда
						// Нам нужен пользовательский параметр
						
						ЗначениеДляПреобразования = Неопределено;
						Если		ТипЗнч(ТекущийЭлементПользовательскойНастройки.Значение) = Тип("Дата") Тогда
							ЗначениеДляПреобразования = ТекущийЭлементПользовательскойНастройки.Значение;
						ИначеЕсли	ТипЗнч(ТекущийЭлементПользовательскойНастройки.Значение) = Тип("СтандартнаяДатаНачала") Тогда
							ЗначениеДляПреобразования = ТекущийЭлементПользовательскойНастройки.Значение.Дата;
						КонецЕсли;
						
						Если Не ЗначениеДляПреобразования = Неопределено Тогда
							
							// Вызов процедуры изменения даты
							ИзменитьЗначениеПараметраДата(ИмяКоманды, ЗначениеДляПреобразования);
							
							ЗначениеИзменено = Истина;
							
							Если		ТипЗнч(ТекущийЭлементПользовательскойНастройки.Значение) = Тип("Дата") Тогда
								ТекущийЭлементПользовательскойНастройки.Значение		= ЗначениеДляПреобразования;
							ИначеЕсли	ТипЗнч(ТекущийЭлементПользовательскойНастройки.Значение) = Тип("СтандартнаяДатаНачала") Тогда
								ТекущийЭлементПользовательскойНастройки.Значение.Дата	= ЗначениеДляПреобразования;
							КонецЕсли;
							
						КонецЕсли;
						
						Прервать;
						
					КонецЕсли;
					
				КонецЦикла;
				
				Прервать;
				
			КонецЕсли;
			
		КонецЦикла;
		#КонецОбласти
		
		// Если в параметрах поле не было найдено, выполним поиск по отборам
		#Область Изменения_в_отборах
		Если Не ЗначениеИзменено Тогда
			
			ЭлементыПользовательскихНастроек = Отчет.КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
			Для Каждого ТекущийЭлементПользовательскойНастройки Из ЭлементыПользовательскихНастроек Цикл
				// Перебор пользовательских настроек
				
				Если ТипЗнч(ТекущийЭлементПользовательскойНастройки) = Тип("ОтборКомпоновкиДанных") Тогда
					// Анализируем только отборы отчета
					
					Для Каждого ТекущийЭлементОтбора Из ТекущийЭлементПользовательскойНастройки.Элементы Цикл
						// Перебираем элементы отборов
						
						Если ВРег(СтрЗаменить(ТекущиеДанные.Настройка, " ", "")) = ВРег(ТекущийЭлементОтбора.ЛевоеЗначение) Тогда
							// Выполняем замену если синоним отбора (тот который в активной строке на форме) равен синониму отбора
							
							ЗначениеДляПреобразования = Неопределено;
							Если		ТипЗнч(ТекущийЭлементОтбора.ПравоеЗначение) = Тип("Дата") Тогда
								ЗначениеДляПреобразования = ТекущийЭлементОтбора.ПравоеЗначение;
							ИначеЕсли	ТипЗнч(ТекущийЭлементОтбора.ПравоеЗначение) = Тип("СтандартнаяДатаНачала") Тогда
								ЗначениеДляПреобразования = ТекущийЭлементОтбора.ПравоеЗначение.Дата;
							КонецЕсли;
							
							Если Не ЗначениеДляПреобразования = Неопределено Тогда
								
								// Вызов процедуры изменения даты
								ИзменитьЗначениеПараметраДата(ИмяКоманды, ЗначениеДляПреобразования);
								
								ЗначениеИзменено = Истина;
								
								Если		ТипЗнч(ТекущийЭлементОтбора.ПравоеЗначение) = Тип("Дата") Тогда
									ТекущийЭлементОтбора.ПравоеЗначение			= ЗначениеДляПреобразования;
								ИначеЕсли	ТипЗнч(ТекущийЭлементОтбора.ПравоеЗначение) = Тип("СтандартнаяДатаНачала") Тогда
									ТекущийЭлементОтбора.ПравоеЗначение.Дата	= ЗначениеДляПреобразования;
								КонецЕсли;
								
							КонецЕсли;
							
							Прервать;
							
						КонецЕсли;
						
					КонецЦикла;
					
					Прервать;
					
				КонецЕсли;
				
			КонецЦикла;
			
		КонецЕсли;
		#КонецОбласти
		
	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Процедура ИзменитьЗначениеПараметраДата(ИмяКоманды, ЗначениеДляПреобразования)  
	
	Если		Найти(ИмяКоманды, "ВНачалоГода") Тогда
		
		ЗначениеДляПреобразования = НачалоГода(ЗначениеДляПреобразования);
		
	ИначеЕсли	Найти(ИмяКоманды, "ВНачалоПолугодия") Тогда
		
		Если Месяц(ЗначениеДляПреобразования) >= 7 Тогда
			ЗначениеДляПреобразования = ДобавитьМесяц(НачалоГода(ЗначениеДляПреобразования), 6);
		Иначе
			ЗначениеДляПреобразования = НачалоГода(ЗначениеДляПреобразования);
		КонецЕсли;
		
	ИначеЕсли	Найти(ИмяКоманды, "ВНачалоМесяца") Тогда
		
		ЗначениеДляПреобразования = НачалоМесяца(ЗначениеДляПреобразования);
		
	ИначеЕсли	Найти(ИмяКоманды, "ВНачалоНедели") Тогда
		
		ЗначениеДляПреобразования = НачалоНедели(ЗначениеДляПреобразования);
		
	ИначеЕсли	Найти(ИмяКоманды, "ВНачалоДня") Тогда
		
		ЗначениеДляПреобразования = НачалоДня(ЗначениеДляПреобразования);
		
	ИначеЕсли	Найти(ИмяКоманды, "ВТекущееВремя") Тогда
		
		ЗначениеДляПреобразования = ТекущаяДата();
		
	ИначеЕсли	Найти(ИмяКоманды, "ВКонецДня") Тогда
		
		ЗначениеДляПреобразования = КонецДня(ЗначениеДляПреобразования);
		
	ИначеЕсли	Найти(ИмяКоманды, "ВКонецНедели") Тогда
		
		ЗначениеДляПреобразования = КонецНедели(ЗначениеДляПреобразования);
		
	ИначеЕсли	Найти(ИмяКоманды, "ВКонецМесяца") Тогда
		
		ЗначениеДляПреобразования = КонецМесяца(ЗначениеДляПреобразования);
		
	ИначеЕсли	Найти(ИмяКоманды, "ВКонецПолугодия") Тогда
		
		Если Месяц(ЗначениеДляПреобразования) >= 7 Тогда
			ЗначениеДляПреобразования = КонецГода(ЗначениеДляПреобразования);
		Иначе
			ЗначениеДляПреобразования = ДобавитьМесяц(КонецГода(ЗначениеДляПреобразования), -6);
		КонецЕсли;
		
	ИначеЕсли	Найти(ИмяКоманды, "ВКонецГода") Тогда
		
		ЗначениеДляПреобразования = КонецГода(ЗначениеДляПреобразования);
		
	КонецЕсли;
	
КонецПроцедуры // ИзменитьЗначениеПараметраДата

4. Подвязать созданные команды под процедуру "ИзменитьПараметрДата"


После проведенных действий сдвиг даты в конец периода можно осуществить в несколько кликов.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Godman 66 12.02.16 14:14 Сейчас в теме
Никогда не мог понять - почему в стандартном периоде есть "начало дня", но нет "конец дня"? Лично мне "начало дня" ни разу не был нужен, зато я должен каждый раз что-то допиливать чтобы получить конец дня.
2. dj_serega 374 12.02.16 15:14 Сейчас в теме
(1) Godman, Аналогично :(
Максимум что можно вытянуть это "Начало текущего дня - Начало следующего дня". Но в таком случаем попадают документы на "00:00:00".
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    76761    Serginio    108    

Отпускной период (период основного отпуска) - как его узнать

Зарплата Универсальные функции v8 v8::СПР v8::УФ ЗУП3.x Россия БУ Бесплатно (free)

Пришла мне задача где нужно получить отпускной период, на просторах сети решения я не нашел. Решил поделиться с вами своим решением.

26.10.2020    198    Danila7Zz    1    

Произвольные колонтитулы и повтор шапки таблицы в табличном документе (функция)

Универсальные функции v8 Бесплатно (free)

Пример рекурсивной функции, при помощи которой в табличный документ можно выводить верхний или нижний колонтитулы с произвольным содержимым, а также делать повтор шапки таблицы (или таблиц, если их несколько).

07.10.2020    943    ellavs    1    

Печать в word, pdf через html

Печать Практика программирования Универсальные функции v8 Россия Бесплатно (free)

При работе с клиентами возникла задача: использовать форматированный документ. Итак, существует справочник, в нем табличная часть. Для каждой строки требуется ввести описание, причем описание имеет тип форматированный документ. Потребовалось организовать печать табличной части справочника с описанием для каждой строки. Тип данных "Форматированный документ" не может выводится в табличный документ, поэтому пришлось организовывать печать через Microsoft Word.

11.09.2020    784    arr    4    

Универсальные функции с примерами использования Промо

Универсальные функции v8 Бесплатно (free)

14 универсальных функций, с примерами использования - для обычного и управляемого интерфейса

26.02.2016    41319    unichkin    46    

Самый простой парсинг и обработка веб-страниц в 1С

WEB Универсальные функции v8 1cv8.cf Бесплатно (free)

Рассмотрим самый простой парсинг веб-страниц средствами платформы 1С и еще некоторые полезные приемы работы с веб-страницами.

07.08.2020    4773    YPermitin    18    

Выполнение внешней обработки по расписанию для управляемого и обычного приложения

БСП (Библиотека стандартных подсистем) Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Использование БСП для выполнения внешних обработок в управляемом и обычном приложении

06.08.2020    1419    RPGrigorev    0    

Пользовательское поле СКД одной процедурой

Практика программирования Универсальные функции v8 Бесплатно (free)

Быстрое создание пользовательского поля "выражение" одной процедурой

05.08.2020    1591    Yashazz    0    

Минимализмы 3 Промо

Практика программирования Универсальные функции v8 Бесплатно (free)

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    46799    ildarovich    45    

Полезные встроенные функции для работы с печатными формами и не только на УТ 11.4 и БП 3.0 (сравнение)

Универсальные функции v8 БП3.0 УТ11 Россия Бесплатно (free)

В данном обзоре приведу примеры встроенных используемых функций для работы с печатными формами на примерах конфигураций Управление торговлей 11.4 и Бухгалтерия 3.0.

10.07.2020    3020    quazare    5    

Вывод дерева в табличный документ СКД

Практика программирования Универсальные функции v8 v8::СКД Бесплатно (free)

Вывод содержимого элемента формы "ДанныеФормыДерево" в табличный документ средствами СКД.

09.07.2020    2648    Yashazz    6    

Команда "Вывести список" для динамического списка. Программное выполнение (вариант)

Универсальные функции v8::УФ 1cv8.cf Бесплатно (free)

Делаем свою кнопку вместо "Вывести список" из пункта "ещё" динамического списка.

11.06.2020    3094    DanDy    58    

Универсальная функция для программного выполнения СКД Промо

Инструментарий разработчика Универсальные функции v8::СКД 1cv8.cf Бесплатно (free)

Часто встречаются вопросы на форумах о программном формировании СКД. Вроде и информации много по этому поводу, но... Все как всегда :) Собственно, в описании без лишних слов выложен текст общей функции, в которую, для выполнения отчета, нужно передать (минимум 2 параметра): СКД и ТабличныйДокумент.

20.05.2015    30648    dj_serega    18    

Ещё немного функционального стиля в 1С или Как нам отфильтровать таблицу значений

Универсальные функции v8 Россия Бесплатно (free)

Потребовалось накладывать хитрые отборы на таблицу значений в сотни строк и десятки колонок, однако Скопировать со структурой отбора мне не подошло. Пришлось немного покреативить, подсмотрев, как это делается в других языках - возможно, получилось несколько топорно, но тем не менее - работает.

16.05.2020    2847    GlebHappy    34    

Сходство Джаро - Винклера. Нечеткое сравнение строк

Универсальные функции v8 Россия Бесплатно (free)

В области информатики и статистики сходство Джаро - Винклера представляет собой меру схожести строк для измерения расстояния между двумя последовательностями символов. В публикации рассмотрены некоторые особенности алгоритма, и представлен вариант его реализации на языке 1С.

25.12.2019    7087    brooho    17    

Функция - Формат государственного номера автомобиля

Универсальные функции v8 Автомобили, автосервисы Россия Бесплатно (free)

Возникла необходимость в приведении к единому формату хранящихся, и вводимых вновь, автомобильных Регистрационных знаков - Гос.номер.

23.12.2019    3791    brooho    4    

Выполнение произвольного кода в фоновых заданиях Промо

Универсальные функции v8 Бесплатно (free)

Если надо быстро провести 100`000 документов...

13.01.2016    24690    unichkin    13    

Полезности | Дерево значений | Обычные формы |

Практика программирования Универсальные функции v8 Бесплатно (free)

Полезные функции при работе с деревом значений.

04.12.2019    5704    Mellow    7    

Обработка расширением на клиенте

Расширения Универсальные функции v8::УФ 1cv8.cf Бесплатно (free)

Описываю нетривиальный прием работы с расширением, который позволит относительно быстро реализовывать некоторые обработки данных. Суть: обработка данных на клиенте с использованием методов, которые реализованы разработчиком конфигурации на форме объекта. Если эти методы есть вне модуля формы объекта (общий модуль, модуль менеджера, модуль объекта)- лучше сделать обработку более простым способом.

31.10.2019    7167    EvgenURNN    10    

Использование XML-схемы из макета внешней обработки

Обмен через XML Универсальные функции v8 1cv8.cf Бесплатно (free)

Простой способ использования XML-схем из макета внешней обработки.

28.10.2019    10975    Olesia_Matusevich    10    

Распределение оплаты по товарам Промо

Практика программирования Универсальные функции v8 1cv8.cf Бесплатно (free)

Учебная задача. Оплата приходит по заказу. Требуется запросом распределить её по товарам. Практическая задача была сложнее. Упростил специально для иллюстрации. Сначала собираем в одну таблицу заказы и товары. Затем ОБЪЕДИНТЬ ВСЕ с оплатами. Потом намазываем оплату на товар.

04.08.2014    19176    Трактор    5    

Быстрое создание наполненных коллекций

Практика программирования Универсальные функции v8 1cv8.cf Бесплатно (free)

Разберем самые частые способы создания коллекции, значения которой известны заранее. И сравним скорость их выполнения.

28.10.2019    7222    SeiOkami    66    

Преобразование XML в таблицу значений или иной объект 1С методом XSL преобразования

Универсальные функции Обмен через XML v8 1cv8.cf Бесплатно (free)

Сразу открою интригу, напрямую прочитать XML, не содержащий объект 1С, не удастся. Статья раскрывает способы привести XML к формату, который возможно прочитать средствами платформы.

24.10.2019    11500    kraspila    30    

Обертка функций Excel на русском. Ускорение процесса разработки.

Загрузка и выгрузка в Excel Универсальные функции v8 Бесплатно (free)

Устали переключаться с русского на английский и обратно при работе с таблицами Excel из 1С? Сборка наиболее необходимых функций и методов работы с Excel, обернутых в функции 1С на русском языке.

24.10.2019    7281    DmitryKotov    6    

Сканируем без сканера или MXL to JPG Промо

Внешние источники данных Универсальные функции Печатные формы документов v8 1cv8.cf Бесплатно (free)

Хотите конвертировать документы в формат изображения менее чем за минуту, не имея сканера? Тогда эта статья для вас.

24.05.2012    34156    shakmaev    47    

Функция СтрШаблон с именованными маркерами

Универсальные функции v8 1cv8.cf Бесплатно (free)

Функция позволяет задавать именованные маркеры формата [Имя], в отличии от типовых нумерованных формата %n

1 стартмани

21.10.2019    4514    kirinalex    27    

Полезняшки по СКД и построителям. Просто код

Практика программирования Универсальные функции v8 v8::СКД Бесплатно (free)

Полезные процедуры и функции для работы с построителями и СКД. Просто исходник.

10.10.2019    10077    Yashazz    45    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    32027    ids79    16    

Сохранение запроса со всеми параметрами и временными таблицами

Универсальные функции v8 v8::УФ Россия Бесплатно (free)

Функция сохранения запроса со всеми параметрами и временными таблицами в формате *.q1c для открытия в консоли запросов с диска ИТС.

13.05.2019    6523    Serge R    5    

Иерархия справочника Сверху Вниз. Получаем произвольное количество родителей "верхнего" уровня

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Иерархия справочника Сверху Вниз. Функция для получения произвольного количества родителей "верхнего" уровня. На примере справочника "Номенклатура".

28.03.2019    6163    obsfromekb    11    

Доработка проведения типовых документов в УТ 11.4, КА 2.4, ЕРП 2.4

Практика программирования Универсальные функции Разработка v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Бесплатно (free)

Различные варианты корректировки типовых механизмов проведения документов, без корректировки основной конфигурации. Использование расширений, подписок на событие и механизма локализации типовых документов.

22.03.2019    18065    ids79    16    

Добавление отчетов в типовые конфигурации 1С

Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем) v8::УФ v8::СКД 1cv8.cf Бесплатно (free)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    55253    ids79    46    

Расширение конструктора мобильного рабочего места для варианта "клиент 1С+RDP" (для любых wi-fi терминалов). Экосистема решений Simple WMS

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Универсальные функции Мобильная разработка Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8::УФ УУ Бесплатно (free)

Развитие проекта «Конструктор мобильного клиента на Android» https://infostart.ru/public/976636/ для устройств не на Андроиде (работающих в режиме RDP). В отличие от варианта Android работа на терминалах происходит в режиме 1С:Предприятие через RDP а конфигурации мобильных клиентов полностью совместимы для обоих версий. Т.е. конфигурация единая, создается один раз и ее может читать как Android -устройство, так и 1С-клиент на RDP без необходимости какой либо переделки.

05.02.2019    13099    informa1555    10    

Работа со строками: от простого к сложному

Практика программирования Универсальные функции v8 Бесплатно (free)

Простые примеры работы со строками, в конце более читаемый разбор сложных текстов.

14.01.2019    31535    Evg-Lylyk    17    

Нумерация колонок субконто при выгрузке набора записей регистра бухгалтерии в таблицу значений

Универсальные функции v8 Бесплатно (free)

Решение проблемы несовпадения номеров колонок с номерами субконто на счете при выгрузке в таблицу значений.

14.01.2019    5660    The Ded    6    

Многопоточное восстановление последовательностей

Производительность и оптимизация (HighLoad) Практика программирования Математика и алгоритмы Универсальные функции v8 Бесплатно (free)

Универсальный алгоритм многопоточного фонового восстановления любой последовательности.

05.12.2018    13373    _ASZ_    33    

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке

Универсальные функции Зарплата Управление персоналом (HRM) Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Бесплатно (free)

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    91132    GeterX    121    

Кадровые данные сотрудников в ЗУП 3.1 в отчетах

Универсальные функции Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия Бесплатно (free)

Параметры используемые для получения данных сотрудников в ЗУП 3.1. Пригодится для разработки отчетов как напоминалка.

07.11.2018    34340    fromlion    23    

Добавление расшифровки в стандартные и добавленные внешние отчеты со стандартной формой отчета на СКД

Универсальные функции v8::УФ v8::СКД ERP2 УТ11 Россия Бесплатно (free)

Описан способ добавления расшифровки отчета на СКД как встроенного в систему, так и добавленного внешнего отчета.

27.09.2018    10948    bmk74    8    

Функция НайтиФайлы() в каталоге netshare на Linux - обход ошибки работы

Практика программирования Универсальные функции v8 Бесплатно (free)

Решение проблемы применения функции НайтиФайлы() в каталоге с netshare на Linux-сервере - не работает поиск файлов по указанной маске (шаблону)

19.09.2018    6340    drmaxart    3    

Простой способ программно открыть заполненную форму нового (незаписанного) документа в тонком клиенте

Универсальные функции v8 Бесплатно (free)

В этой публикации я поделюсь своим способом открывать программно новый незаписанный документ в тонком клиенте. Для использования этого способа потребуется немного модифицировать конфигурацию. Добавив универсальные процедуру и функцию, можно будет использовать их для любых документов/справочников.

09.06.2018    11401    Serge R    12    

Генерация временного ряда запросом

Универсальные функции v8 v8::Запросы 1cv8.cf Бесплатно (free)

Способ генерации последовательности дат средствами языка запроса 1С.

07.05.2018    8758    dim_zal    6