Удаление лишних данных

25.11.16

База данных - Чистка данных

Настало то время, когда на SSD винчестерах размером 120 Гб начало заканчиваться место.  В связи с этим, было принято решение проанализиривать возможность уменьшения занимаемого места БД. Без веского обоснования у нас никакие работы не производятся, просто так оптимизацией никто заниматься не даст. 1. Выявление таблиц БД, занимающих много места. 2. Очистка записей регистров накопления. 3. Тестирование.

Выявление таблиц БД, занимающих много места.

Для начала я решил выяснить, какие данные занимают много места. Хотел решить этот вопрос по-простому - скачать обработку с Infostart. По-простому получилось как-то не очень просто, оказалось, надо еще с обработкой разбираться. При помощи MS SQL, на мой взгляд, намного проще.

1. Выполняем запрос на MS SQL

USE [DatabaseName]
GO
CREATE TABLE #temp (
table_name sysname ,
row_count INT,
reserved_size VARCHAR(50),
data_size VARCHAR(50),
index_size VARCHAR(50),
unused_size VARCHAR(50))
SET NOCOUNT ON
INSERT #temp
EXEC sp_msforeachtable 'sp_spaceused ''?'''
SELECT a.table_name,
a.row_count,
COUNT(*) AS col_count,
a.data_size,
a.index_size 
FROM #temp a
INNER JOIN information_schema.columns b
ON a.table_name collate database_default
= b.table_name collate database_default
GROUP BY a.table_name, a.row_count, a.data_size, a.index_size
ORDER BY CAST(REPLACE(a.data_size, ' KB', '') AS integer) DESC
DROP TABLE #temp

Вместо [DatabaseName] нужно подставить название нужной базы.

2. Результат запроса прекрасно копируется в MS Excel. С помощью функции " ПОДСТАВИТЬ " избавляемся от " KB", и преобразуем значения из строк в числа. 

3. Вычисляем процент от занимаемого места.

4. По названию таблиц определям метаданные. 

тзСтруктураХранения = ПолучитьСтруктуруХраненияБазыДанных(,);
СтруктураОтбора = Новый Структура("ИмяТаблицыХранения", НазваниеТаблицы);
мстзСтруктураХранения = тзСтруктураХранения.НайтиСтроки(СтруктураОтбора);
	
тзРезультат = тзСтруктураХранения.Скопировать(мстзСтруктураХранения);
	
Для Каждого стзРезультат Из тзРезультат Цикл
	Сообщить("" + стзРезультат.Метаданные + "	" + стзРезультат.Назначение);
КонецЦикла;

В моем случае, получился результат, приведенный в таблице:

результат

Учет НДС (книги покупок/ продаж) в данной базе не ведется. Расчет с контрагентами (не путать со взаиморасчетами) также не ведется. Результат мы видим в таблице - регистры превратились в свалку.

Очистка записей регистров накопления

План работ:

  1. Внести изменения в алгоритмы, делающие записи по регистрам, которые нужно очистить.
  2.  Очистка регистров.
  3. Тестирование.

Изменение алгоритмов

Сначала я попробовал воспользоваться глобальным поиском в модулях по названию регистра. В результате получил большое количество совпадений.

Остановился на следующем методе. 

  • Выписал все возможные регистраторы (документы);
  • В каждом документе анализировал проведение документа.

Такой метод оказался намного проще, естественно, не даёт гарантированный 100% результат.

Очистка регистров

Для очистки регистров написал следующую обработку:

Процедура ОчиститРегистр(НаименованиеРегистра)
	Запрос = Новый Запрос();
	Запрос.Текст =
	"ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	" + НаименованиеРегистра + ".Регистратор,
	|	" + НаименованиеРегистра + ".Период КАК Период
	|ИЗ
	|	РегистрНакопления." + НаименованиеРегистра + " КАК " + НаименованиеРегистра + "
	|
	|УПОРЯДОЧИТЬ ПО
	|	Период УБЫВ";
	
    Выборка = Запрос.Выполнить().Выбрать();
	Индикатор = 0;
	ЭлементыФормы.Индикатор.МаксимальноеЗначение = Выборка.Количество();
	Пока Выборка.Следующий() Цикл
		нзРегистр = РегистрыНакопления[НаименованиеРегистра].СоздатьНаборЗаписей();
		нзРегистр.Отбор.Регистратор.Значение = Выборка.Регистратор;
		нзРегистр.Записать();		
		Индикатор = Индикатор + 1;
	КонецЦикла;	
	
	РегистрыНакопления[НаименованиеРегистра].ПересчитатьИтоги();
КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)
	// Вставить содержимое обработчика.
	СписокРегистров = Новый Массив();
	СписокРегистров.Добавить("НДСРасчетыСПокупателями");
	СписокРегистров.Добавить("НДСРасчетыСПоставщиками");
	СписокРегистров.Добавить("РасчетыСКонтрагентами");
	СписокРегистров.Добавить("НДСПредъявленный");
	
	ЭлементыФормы.Индикатор1.МаксимальноеЗначение = 4;
	Индикатор1 = 0;
	Для Каждого НаименованиеРегистра Из СписокРегистров Цикл
		Индикатор1 = Индикатор1 + 1;
		ОчиститРегистр(НаименованиеРегистра);	
	КонецЦикла;
	
КонецПроцедуры

Начальный вариант кода был без пересчета остатков по регистрам, я думал, что при удалении записей автоматически произойдет пересчет итогов, я ошибался.

О том, что при удалении записей из таблицы файл не уменьшается, я знал давно. Но раньше я это больше ассоциировал со справочниками, и почему-то не связывал с регистрами. А ведь именно в случае с регистрами очень часто записи удаляются. Восстанавление последовательности - регулярная операция. Следовательно, после восстановления последовательности документов нужно упаковывать таблицы регистров.

Тестирование

Тестирование я проводил следующим образом.

  • Перепроводил документы (за месяц);
  • Проверка на наличие записей в регистрах;
  • Проверка изменения остатков.

При правке кода для удаления проведения по регистру "Расчеты с покупателями", была возможность повредить код проведения по регситру "Заявки на расходование средств". Поэтому я решил проконтролировать остатки по данному регистру следующим образом:

  1. Остатки по регистру выгрузил в файл.
  2. Перепровел документы.
  3. Сравнил остатки в файле с  остатками в базе.

Код обработки:

Перем ТипДиалога;


Процедура ВыбФайлНачалоВыбора(Элемент, СтандартнаяОбработка)
	// Вставить содержимое обработчика.
	длгВыборФайла = Новый ДиалогВыбораФайла(ТипДиалога);
	Если длгВыборФайла.Выбрать() Тогда
		ВыбФайл = длгВыборФайла.ПолноеИмяФайла;		
	КонецЕсли;	
КонецПроцедуры

Процедура СохранитьНажатие(Элемент)
	// Вставить содержимое обработчика.
	Запрос = Новый Запрос();
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ЗаявкиНаРасходованиеСредствОстатки.ДоговорКонтрагента,
	|	ЗаявкиНаРасходованиеСредствОстатки.Сделка,
	|	ЗаявкиНаРасходованиеСредствОстатки.ЗаявкаНаРасходование,
	|	ЗаявкиНаРасходованиеСредствОстатки.СтатьяДвиженияДенежныхСредств,
	|	ЗаявкиНаРасходованиеСредствОстатки.Проект,
	|	ЗаявкиНаРасходованиеСредствОстатки.СуммаВзаиморасчетовОстаток,
	|	ЗаявкиНаРасходованиеСредствОстатки.СуммаУпрОстаток,
	|	ЗаявкиНаРасходованиеСредствОстатки.СуммаОстаток
	|ИЗ
	|	РегистрНакопления.ЗаявкиНаРасходованиеСредств.Остатки КАК ЗаявкиНаРасходованиеСредствОстатки";
	
	
	тзОстатки = Запрос.Выполнить().Выгрузить();
	ЗначениеВФайл(ВыбФайл, тзОстатки);	
КонецПроцедуры

Процедура СравнитьНажатие(Элемент)
	// Вставить содержимое обработчика.
	Запрос = Новый Запрос();
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ЗаявкиНаРасходованиеСредствОстатки.ДоговорКонтрагента,
	|	ЗаявкиНаРасходованиеСредствОстатки.Сделка,
	|	ЗаявкиНаРасходованиеСредствОстатки.ЗаявкаНаРасходование,
	|	ЗаявкиНаРасходованиеСредствОстатки.СтатьяДвиженияДенежныхСредств,
	|	ЗаявкиНаРасходованиеСредствОстатки.Проект,
	|	-ЗаявкиНаРасходованиеСредствОстатки.СуммаВзаиморасчетовОстаток КАК СуммаВзаиморасчетовОстаток,
	|	-ЗаявкиНаРасходованиеСредствОстатки.СуммаУпрОстаток КАК СуммаУпрОстаток,
	|	-ЗаявкиНаРасходованиеСредствОстатки.СуммаОстаток КАК СуммаОстаток
	|ИЗ
	|	РегистрНакопления.ЗаявкиНаРасходованиеСредств.Остатки КАК ЗаявкиНаРасходованиеСредствОстатки";
	
	
	тзРезультат = Запрос.Выполнить().Выгрузить();
	
	тзОстатки = ЗначениеИзФайла(ВыбФайл);
	
	Для Каждого стзОстатки Из тзОстатки Цикл
		стзРезультат = тзРезультат.Добавить();
		ЗаполнитьЗначенияСвойств(стзРезультат, стзОстатки);
	КонецЦикла;
	
	тзРезультат.Свернуть("ДоговорКонтрагента,Сделка,ЗаявкаНаРасходование,СтатьяДвиженияДенежныхСредств,Проект", "СуммаВзаиморасчетовОстаток,СуммаУпрОстаток,СуммаОстаток");
	Сч = тзРезультат.Количество();
	Пока Сч > 0 Цикл
		Сч = Сч - 1;
		стзРезультат = тзРезультат[Сч];
		Если стзРезультат.СуммаВзаиморасчетовОстаток = 0 
			И стзРезультат.СуммаУпрОстаток = 0 
			И стзРезультат.СуммаОстаток = 0  Тогда
			тзРезультат.Удалить(стзРезультат);
		КонецЕсли;
	КонецЦикла;
	
	тзРезультат.ВыбратьСтроку();
	
КонецПроцедуры


ТипДиалога = РежимДиалогаВыбораФайла.Открытие;

Заключение

Скорее всего, материал я изложил совсем не лаконично, а скорее наборот, но с чего-то надо начинать.  Главное, чтобы информация была полезной, а статью потом можно будет и переписать. 

MSSQL SQL размер таблиц очистка регистров

См. также

SALE! 10%

Выборочное удаление организаций из баз (управляемые формы), с удалением всех ссылающихся на эти организации данных

Чистка данных Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Платные (руб)

Позволяет удалить организации из любых программ на управляемых формах (БП 3.0, УТ 11, КА 2, ERP 2, ЗУП 3.0, УНФ, Розница 2.0 и пр.). Главное требование - программа должна содержать справочник "Организации". Реализован самый быстрый алгоритм непосредственного удаления объектов. Работает даже на базах большого размера. Для ускорения работы алгоритма не запускается проверка контроля ссылочной целостности. Проверку учета можно запустить отдельно с помощью дополнительной обработки. Необходимо перед удалением самостоятельно проверить базу на наличие перекрестных ссылок разных организаций в одном документе. Эту дополнительную обработку проверки перекрестных ссылок по запросу предоставляем бесплатно нашим покупателям.

3980 3582 руб.

16.03.2015    111554    175    75    

211

Правильная свертка или свертка базы по правилам

Свертка базы Чистка данных Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Обработка "Свертка базы по правилам" предназначена для свертки информационных баз системы программ "1С:Предприятие" версии 8.2. Основой обработки являются специальные правила свертки, которые создаются индивидуально для каждой конфигурации информационной базы. Встроенный в обработку генератор правил позволяет быстро создать правила свертки для любой конфигурации. Например, для конфигурации "1С:Бухгалтерия 8, ред. 3.0" правила свертки были созданы за 15 минут!

2400 руб.

22.07.2013    161723    607    527    

399

Удаление организаций из информационных баз 1С

Чистка данных Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Обработка предназначена для удаления организаций из любых информационных баз 1С, имеющих в своем составе справочник "Организации". Работает на обычных и управляемых формах, на базах любого формата и размера. Обработка проверялась на следующих типовых релизах 1С: БП 2.0.66.84, БП 3.0.71.77, БГУ 1.0.59.3, БГУ 2.0.65.17, УТ 10.3.55.3, УТ 11.4.10.57, ЗУП 3.1.11.106, ЗГУ 3.1.11.106, КА 2.4.9.98, УПП 1.3.126.1, УНФ 1.6.18.168, но должна работать и на более старых, так как обработке нужен только справочник "Организации".

3000 руб.

20.11.2019    26931    67    35    

72

Универсальное выборочное удаление данных из базы 1С (любые конфигурации на упр.формах: БП 3.0, УТ 11, КА 2, ERP, УНФ, ЗУП 3, Розница и т.д.)

Чистка данных Платформа 1С v8.3 Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Зарплата и кадры государственного учреждения 3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Платные (руб)

Обработка позволяет удобно выборочно удалить данные из базы 1С. Это могут быть как неиспользуемые элементы справочников, так и неактуальные организации. При этом есть возможность провести анализ пересечений документов с другими организациями и таким образом уберечься от того, что при удалении обороты по другой организации изменятся.

3350 руб.

28.11.2019    23521    39    16    

50

Замена Номенклатуры+Характеристики

Чистка данных Логистика, склад и ТМЦ Платформа 1С v8.3 План видов характеристик 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Платные (руб)

Настраиваемая обработка, позволяющая заменить пару: Номенклатура+Характеристика в документах, их движениях и независимых регистрах сведений. Без перепроведения. Поможет, если вы по каким-то причинам решили отказаться от характеристик

3600 руб.

04.08.2015    40726    86    70    

47

Алгоритм перехода на учет без серий для программного продукта "Управление торговлей" редакция 11 или Комплексная Автоматизация редакция 2. (отказ от серий, удаление серий, отмена серий, без серий, УТ, КА)

Оптовая торговля Логистика, склад и ТМЦ Чистка данных Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Если вы начали работать в программном продукте Управление Торговлей, редакция 11 или Комплексная Автоматизация редакция 2 и включили механизм учёта серий, то перейти обратно в учёт без серий будет не так-то просто. Сложность заключается в том, что нужно очистить серии в табличной части документа, например, Реализация Товаров и услуг. Предлагаем алгоритм перехода на учет без серий для программного продукта «Управление торговлей» редакция 11. (Очистка серий.)

2400 руб.

09.04.2019    28122    37    14    

39

Удаление битых ссылок 1С в базе без монопольного режима

Чистка данных Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Если в вашей информационной базе крутится очень много данных, или база должна быть доступна 24/7 (как в моем случае), или же вы боитесь запускать тестирование и исправление, НО существует потребность удалить битые ссылки, тогда эта обработка сможет Вам помочь. Обработка выявляет битые ссылки как в самих объектах метаданных, так и в их табличных частях(!), а так же может их удалить.

1800 руб.

23.08.2021    8992    14    3    

19
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. TODD22 18 25.11.16 11:25 Сейчас в теме
Без веского обоснования у нас никакие работы не производятся, просто так оптимизацией никто заниматься не даст.

Интересно как вы обосновали затраты такого количества времени и человеческих ресурсов, вместо покупки SSD под базу на 250 Гб?
На эту "оптимизацию" времени было затрачено на два SSD диска.... :)
Железо зачастую дешевле чем работа программиста. Учитывая что это увеличение объёма памяти. А не каких то важных(критичных к скорости) механизмов.
2. Swetlana 20 25.11.16 11:30 Сейчас в теме
(1) Нужно же обосновать покупку винчестера, просто так деньги на это не выделят. особенно если это бюджет)
HAMMER_59; +1 Ответить
5. HAMMER_59 241 25.11.16 12:21 Сейчас в теме
(1) Как раз с этого все и началось, со служебной на покупку новых SSD дисков на 250 Гб (установлены зеркалом).

В конкретном случае, дешевле было почистить базу. Стоимость дисков - порядка 16 тысяч рублей.
Работы я выполнил часов за 8. А за 8 часов я столько не зарабатываю.
3. olegmedvedev 64 25.11.16 11:34 Сейчас в теме
для файловой базы (где нельзя написать запрос)
1. Выполняем запрос на MS SQL
2. Результат запроса прекрасно копируется в MS Excel. С помощью функции " ПОДСТАВИТЬ " избавляемся от " KB", и преобразуем значения из строк в числа.
3. Вычисляем процент от занимаемого места.
4. По названию таблиц определям метаданные.

можно воспользоваться Размеры объектов файловой базы 1С 8.х
есть экспорт в эксель,хтмл,ворд
HAMMER_59; +1 Ответить
4. Fox-trot 152 25.11.16 11:40 Сейчас в теме
(3) тысячи их
ТС бесплатный совет
в запрос
Запрос.Текст =
	"ВЫБРАТЬ
	|	" + НаименованиеРегистра + ".Регистратор,
	|	" + НаименованиеРегистра + ".Период КАК Период
	|ИЗ
	|	РегистрНакопления." + НаименованиеРегистра + " КАК " + НаименованиеРегистра + "
	|
	|СГРУППИРОВАТЬ ПО
	|	" + НаименованиеРегистра + ".Регистратор,
	|	" + НаименованиеРегистра + ".Период
	|
	|УПОРЯДОЧИТЬ ПО
	|	Период УБЫВ";
Показать

вставить мащнейший операнд РАЗЛИЧНЫЕ и ваша обработка просто таки взлетит
я гарантирую это
paybaseme; HAMMER_59; +2 Ответить
6. HAMMER_59 241 25.11.16 12:25 Сейчас в теме
(4) Не взлетит, выполнение данного запроса занимает крайне малую часть времени от всей обработки.
Но замечание дельное, действительно в таких случаях нужно писать РАЗЛИЧНЫЕ. Исправил код.
7. v3rter 25.11.16 13:21 Сейчас в теме
Пройдет время, база вырастет и все равно придется )
корум; HAMMER_59; +2 Ответить
8. V.Nikonov 119 01.12.16 14:49 Сейчас в теме
На практике, часть Информации носит Управленческий характер. Актуальной она является ограниченный период времени...
Для примера в Базах УТ, информация Регистров ЗаказыПокупателей, Резервы - теряет со временем актуальность. Соответственно можно проработать процедуры Осторожно зачищающие старые движения и итоги... Только надо Хорошо Подумать о Смысловом назначении тех или других Регистров.
Варианты сворачивания Номенклатуры, Контрагентов - существенно более проблемные для сокращения Информации. Легче зачистить "лишние" Свойства и Справочник ХранилищеДополнительнойИнформации.

Это тоже может дать выигрыш в объёмах Базы. В конечном результате можно заметно продлить период жизни ИБ.
9. Serg O. 215 01.12.16 20:40 Сейчас в теме
есть статья про "ненужность" свертки базы
>> там есть Ваша проблема - перенос таблиц на другие диски
(причем даже на внешнее хранилище) - средствами SQL Server

см. http://infostart.ru/public/94040
10. sansys 76 07.01.17 12:25 Сейчас в теме
У меня назревает та-же проблема, к сожалению в базе уже обрезано всё, что можно. Пока склоняюсь пойти по "аппаратному" пути т.е. расширение дискового пространства. Но за статью однозначно плюс, возьму на вооружение.
Оставьте свое сообщение