Удаление лишних данных

Публикация № 563404

Администрирование - Администрирование данных 1С - Чистка базы

MSSQL SQL размер таблиц очистка регистров

17
Настало то время, когда на SSD винчестерах размером 120 Гб начало заканчиваться место.  В связи с этим, было принято решение проанализиривать возможность уменьшения занимаемого места БД. Без веского обоснования у нас никакие работы не производятся, просто так оптимизацией никто заниматься не даст. 1. Выявление таблиц БД, занимающих много места. 2. Очистка записей регистров накопления. 3. Тестирование.

Выявление таблиц БД, занимающих много места.

Для начала я решил выяснить, какие данные занимают много места. Хотел решить этот вопрос по-простому - скачать обработку с Infostart. По-простому получилось как-то не очень просто, оказалось, надо еще с обработкой разбираться. При помощи MS SQL, на мой взгляд, намного проще.

1. Выполняем запрос на MS SQL

USE [DatabaseName]
GO
CREATE TABLE #temp (
table_name sysname ,
row_count INT,
reserved_size VARCHAR(50),
data_size VARCHAR(50),
index_size VARCHAR(50),
unused_size VARCHAR(50))
SET NOCOUNT ON
INSERT #temp
EXEC sp_msforeachtable 'sp_spaceused ''?'''
SELECT a.table_name,
a.row_count,
COUNT(*) AS col_count,
a.data_size,
a.index_size 
FROM #temp a
INNER JOIN information_schema.columns b
ON a.table_name collate database_default
= b.table_name collate database_default
GROUP BY a.table_name, a.row_count, a.data_size, a.index_size
ORDER BY CAST(REPLACE(a.data_size, ' KB', '') AS integer) DESC
DROP TABLE #temp

Вместо [DatabaseName] нужно подставить название нужной базы.

2. Результат запроса прекрасно копируется в MS Excel. С помощью функции " ПОДСТАВИТЬ " избавляемся от " KB", и преобразуем значения из строк в числа. 

3. Вычисляем процент от занимаемого места.

4. По названию таблиц определям метаданные. 

тзСтруктураХранения = ПолучитьСтруктуруХраненияБазыДанных(,);
СтруктураОтбора = Новый Структура("ИмяТаблицыХранения", НазваниеТаблицы);
мстзСтруктураХранения = тзСтруктураХранения.НайтиСтроки(СтруктураОтбора);
	
тзРезультат = тзСтруктураХранения.Скопировать(мстзСтруктураХранения);
	
Для Каждого стзРезультат Из тзРезультат Цикл
	Сообщить("" + стзРезультат.Метаданные + "	" + стзРезультат.Назначение);
КонецЦикла;

В моем случае, получился результат, приведенный в таблице:

результат

Учет НДС (книги покупок/ продаж) в данной базе не ведется. Расчет с контрагентами (не путать со взаиморасчетами) также не ведется. Результат мы видим в таблице - регистры превратились в свалку.

Очистка записей регистров накопления

План работ:

  1. Внести изменения в алгоритмы, делающие записи по регистрам, которые нужно очистить.
  2.  Очистка регистров.
  3. Тестирование.

Изменение алгоритмов

Сначала я попробовал воспользоваться глобальным поиском в модулях по названию регистра. В результате получил большое количество совпадений.

Остановился на следующем методе. 

  • Выписал все возможные регистраторы (документы);
  • В каждом документе анализировал проведение документа.

Такой метод оказался намного проще, естественно, не даёт гарантированный 100% результат.

Очистка регистров

Для очистки регистров написал следующую обработку:

Процедура ОчиститРегистр(НаименованиеРегистра)
	Запрос = Новый Запрос();
	Запрос.Текст =
	"ВЫБРАТЬ РАЗЛИЧНЫЕ
	|	" + НаименованиеРегистра + ".Регистратор,
	|	" + НаименованиеРегистра + ".Период КАК Период
	|ИЗ
	|	РегистрНакопления." + НаименованиеРегистра + " КАК " + НаименованиеРегистра + "
	|
	|УПОРЯДОЧИТЬ ПО
	|	Период УБЫВ";
	
    Выборка = Запрос.Выполнить().Выбрать();
	Индикатор = 0;
	ЭлементыФормы.Индикатор.МаксимальноеЗначение = Выборка.Количество();
	Пока Выборка.Следующий() Цикл
		нзРегистр = РегистрыНакопления[НаименованиеРегистра].СоздатьНаборЗаписей();
		нзРегистр.Отбор.Регистратор.Значение = Выборка.Регистратор;
		нзРегистр.Записать();		
		Индикатор = Индикатор + 1;
	КонецЦикла;	
	
	РегистрыНакопления[НаименованиеРегистра].ПересчитатьИтоги();
КонецПроцедуры

Процедура КнопкаВыполнитьНажатие(Кнопка)
	// Вставить содержимое обработчика.
	СписокРегистров = Новый Массив();
	СписокРегистров.Добавить("НДСРасчетыСПокупателями");
	СписокРегистров.Добавить("НДСРасчетыСПоставщиками");
	СписокРегистров.Добавить("РасчетыСКонтрагентами");
	СписокРегистров.Добавить("НДСПредъявленный");
	
	ЭлементыФормы.Индикатор1.МаксимальноеЗначение = 4;
	Индикатор1 = 0;
	Для Каждого НаименованиеРегистра Из СписокРегистров Цикл
		Индикатор1 = Индикатор1 + 1;
		ОчиститРегистр(НаименованиеРегистра);	
	КонецЦикла;
	
КонецПроцедуры

Начальный вариант кода был без пересчета остатков по регистрам, я думал, что при удалении записей автоматически произойдет пересчет итогов, я ошибался.

О том, что при удалении записей из таблицы файл не уменьшается, я знал давно. Но раньше я это больше ассоциировал со справочниками, и почему-то не связывал с регистрами. А ведь именно в случае с регистрами очень часто записи удаляются. Восстанавление последовательности - регулярная операция. Следовательно, после восстановления последовательности документов нужно упаковывать таблицы регистров.

Тестирование

Тестирование я проводил следующим образом.

  • Перепроводил документы (за месяц);
  • Проверка на наличие записей в регистрах;
  • Проверка изменения остатков.

При правке кода для удаления проведения по регистру "Расчеты с покупателями", была возможность повредить код проведения по регситру "Заявки на расходование средств". Поэтому я решил проконтролировать остатки по данному регистру следующим образом:

  1. Остатки по регистру выгрузил в файл.
  2. Перепровел документы.
  3. Сравнил остатки в файле с  остатками в базе.

Код обработки:

Перем ТипДиалога;


Процедура ВыбФайлНачалоВыбора(Элемент, СтандартнаяОбработка)
	// Вставить содержимое обработчика.
	длгВыборФайла = Новый ДиалогВыбораФайла(ТипДиалога);
	Если длгВыборФайла.Выбрать() Тогда
		ВыбФайл = длгВыборФайла.ПолноеИмяФайла;		
	КонецЕсли;	
КонецПроцедуры

Процедура СохранитьНажатие(Элемент)
	// Вставить содержимое обработчика.
	Запрос = Новый Запрос();
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ЗаявкиНаРасходованиеСредствОстатки.ДоговорКонтрагента,
	|	ЗаявкиНаРасходованиеСредствОстатки.Сделка,
	|	ЗаявкиНаРасходованиеСредствОстатки.ЗаявкаНаРасходование,
	|	ЗаявкиНаРасходованиеСредствОстатки.СтатьяДвиженияДенежныхСредств,
	|	ЗаявкиНаРасходованиеСредствОстатки.Проект,
	|	ЗаявкиНаРасходованиеСредствОстатки.СуммаВзаиморасчетовОстаток,
	|	ЗаявкиНаРасходованиеСредствОстатки.СуммаУпрОстаток,
	|	ЗаявкиНаРасходованиеСредствОстатки.СуммаОстаток
	|ИЗ
	|	РегистрНакопления.ЗаявкиНаРасходованиеСредств.Остатки КАК ЗаявкиНаРасходованиеСредствОстатки";
	
	
	тзОстатки = Запрос.Выполнить().Выгрузить();
	ЗначениеВФайл(ВыбФайл, тзОстатки);	
КонецПроцедуры

Процедура СравнитьНажатие(Элемент)
	// Вставить содержимое обработчика.
	Запрос = Новый Запрос();
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ЗаявкиНаРасходованиеСредствОстатки.ДоговорКонтрагента,
	|	ЗаявкиНаРасходованиеСредствОстатки.Сделка,
	|	ЗаявкиНаРасходованиеСредствОстатки.ЗаявкаНаРасходование,
	|	ЗаявкиНаРасходованиеСредствОстатки.СтатьяДвиженияДенежныхСредств,
	|	ЗаявкиНаРасходованиеСредствОстатки.Проект,
	|	-ЗаявкиНаРасходованиеСредствОстатки.СуммаВзаиморасчетовОстаток КАК СуммаВзаиморасчетовОстаток,
	|	-ЗаявкиНаРасходованиеСредствОстатки.СуммаУпрОстаток КАК СуммаУпрОстаток,
	|	-ЗаявкиНаРасходованиеСредствОстатки.СуммаОстаток КАК СуммаОстаток
	|ИЗ
	|	РегистрНакопления.ЗаявкиНаРасходованиеСредств.Остатки КАК ЗаявкиНаРасходованиеСредствОстатки";
	
	
	тзРезультат = Запрос.Выполнить().Выгрузить();
	
	тзОстатки = ЗначениеИзФайла(ВыбФайл);
	
	Для Каждого стзОстатки Из тзОстатки Цикл
		стзРезультат = тзРезультат.Добавить();
		ЗаполнитьЗначенияСвойств(стзРезультат, стзОстатки);
	КонецЦикла;
	
	тзРезультат.Свернуть("ДоговорКонтрагента,Сделка,ЗаявкаНаРасходование,СтатьяДвиженияДенежныхСредств,Проект", "СуммаВзаиморасчетовОстаток,СуммаУпрОстаток,СуммаОстаток");
	Сч = тзРезультат.Количество();
	Пока Сч > 0 Цикл
		Сч = Сч - 1;
		стзРезультат = тзРезультат[Сч];
		Если стзРезультат.СуммаВзаиморасчетовОстаток = 0 
			И стзРезультат.СуммаУпрОстаток = 0 
			И стзРезультат.СуммаОстаток = 0  Тогда
			тзРезультат.Удалить(стзРезультат);
		КонецЕсли;
	КонецЦикла;
	
	тзРезультат.ВыбратьСтроку();
	
КонецПроцедуры


ТипДиалога = РежимДиалогаВыбораФайла.Открытие;

Заключение

Скорее всего, материал я изложил совсем не лаконично, а скорее наборот, но с чего-то надо начинать.  Главное, чтобы информация была полезной, а статью потом можно будет и переписать. 

17

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. TODD22 18 25.11.16 11:25 Сейчас в теме
Без веского обоснования у нас никакие работы не производятся, просто так оптимизацией никто заниматься не даст.

Интересно как вы обосновали затраты такого количества времени и человеческих ресурсов, вместо покупки SSD под базу на 250 Гб?
На эту "оптимизацию" времени было затрачено на два SSD диска.... :)
Железо зачастую дешевле чем работа программиста. Учитывая что это увеличение объёма памяти. А не каких то важных(критичных к скорости) механизмов.
2. Swetlana 10 25.11.16 11:30 Сейчас в теме
(1) Нужно же обосновать покупку винчестера, просто так деньги на это не выделят. особенно если это бюджет)
HAMMER_59; +1 Ответить
5. HAMMER_59 193 25.11.16 12:21 Сейчас в теме
(1) Как раз с этого все и началось, со служебной на покупку новых SSD дисков на 250 Гб (установлены зеркалом).

В конкретном случае, дешевле было почистить базу. Стоимость дисков - порядка 16 тысяч рублей.
Работы я выполнил часов за 8. А за 8 часов я столько не зарабатываю.
3. olegmedvedev 25.11.16 11:34 Сейчас в теме
для файловой базы (где нельзя написать запрос)
1. Выполняем запрос на MS SQL
2. Результат запроса прекрасно копируется в MS Excel. С помощью функции " ПОДСТАВИТЬ " избавляемся от " KB", и преобразуем значения из строк в числа.
3. Вычисляем процент от занимаемого места.
4. По названию таблиц определям метаданные.

можно воспользоваться Размеры объектов файловой базы 1С 8.х
есть экспорт в эксель,хтмл,ворд
HAMMER_59; +1 Ответить
4. Fox-trot 108 25.11.16 11:40 Сейчас в теме
(3) тысячи их
ТС бесплатный совет
в запрос
Запрос.Текст =
	"ВЫБРАТЬ
	|	" + НаименованиеРегистра + ".Регистратор,
	|	" + НаименованиеРегистра + ".Период КАК Период
	|ИЗ
	|	РегистрНакопления." + НаименованиеРегистра + " КАК " + НаименованиеРегистра + "
	|
	|СГРУППИРОВАТЬ ПО
	|	" + НаименованиеРегистра + ".Регистратор,
	|	" + НаименованиеРегистра + ".Период
	|
	|УПОРЯДОЧИТЬ ПО
	|	Период УБЫВ";
Показать

вставить мащнейший операнд РАЗЛИЧНЫЕ и ваша обработка просто таки взлетит
я гарантирую это
paybaseme; HAMMER_59; +2 Ответить
6. HAMMER_59 193 25.11.16 12:25 Сейчас в теме
(4) Не взлетит, выполнение данного запроса занимает крайне малую часть времени от всей обработки.
Но замечание дельное, действительно в таких случаях нужно писать РАЗЛИЧНЫЕ. Исправил код.
7. v3rter 25.11.16 13:21 Сейчас в теме
Пройдет время, база вырастет и все равно придется )
корум; HAMMER_59; +2 Ответить
8. V.Nikonov 119 01.12.16 14:49 Сейчас в теме
На практике, часть Информации носит Управленческий характер. Актуальной она является ограниченный период времени...
Для примера в Базах УТ, информация Регистров ЗаказыПокупателей, Резервы - теряет со временем актуальность. Соответственно можно проработать процедуры Осторожно зачищающие старые движения и итоги... Только надо Хорошо Подумать о Смысловом назначении тех или других Регистров.
Варианты сворачивания Номенклатуры, Контрагентов - существенно более проблемные для сокращения Информации. Легче зачистить "лишние" Свойства и Справочник ХранилищеДополнительнойИнформации.

Это тоже может дать выигрыш в объёмах Базы. В конечном результате можно заметно продлить период жизни ИБ.
9. Serg O. 181 01.12.16 20:40 Сейчас в теме
есть статья про "ненужность" свертки базы
>> там есть Ваша проблема - перенос таблиц на другие диски
(причем даже на внешнее хранилище) - средствами SQL Server

см. http://infostart.ru/public/94040
10. sansys 56 07.01.17 12:25 Сейчас в теме
У меня назревает та-же проблема, к сожалению в базе уже обрезано всё, что можно. Пока склоняюсь пойти по "аппаратному" пути т.е. расширение дискового пространства. Но за статью однозначно плюс, возьму на вооружение.
Оставьте свое сообщение

См. также

Новогодние скидки на авторское ПО Промо

В преддверии праздника в Маркетплейсе на Инфостарт действует скидка на все платные авторские программы. Размер скидок начинается от 10%. Советуем не откладывать покупки, многие наши партнеры повышают цены на свои продукты именно в начале нового года.

Удаление записей регистров и пересчет итогов в условиях нехватки места на диске 0

Статья Системный администратор Программист Нет файла v8 1cv8.cf Россия СУБД Бесплатно (free) Чистка базы

При обследовании базы нередко видишь незакрывающиеся регистры накопления с момента начала работы системы. Всегда есть два варианта: первый - закрываем  ежемесячно регистр в ноль и настраиваем бизнес процесс так, чтобы этот регистр правильно использовался, второй вариант - этот регистр не использовался и не будет использоваться в данной конфигурации. Второму варианту я и хочу посвятить данную статью.

17.04.2019    2006    semensemenbi4    8       

Как быстро "удалить все документы и движения" в базе (Альтернатива) 57

Статья Системный администратор Нет файла v8 Бесплатно (free) Чистка базы

Очень часто задают вопрос - как удалить все документы из базы, оставить только номенклатуру и настройки. Есть много различных вариантов (групповая обработка документов и справочников - да, работает, но медленно, у клиента в базе 460 000 документов проведенных - неделю будет удалять). Перенос данных - через ВыгрузкаЗагрузкаДанныхXML82.epf - можно, но тоже долго и требует определенных навыков.

06.03.2018    16404    Tatitutu    21       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Если при рассылке закончилось место 5

Статья Системный администратор Программист Нет файла v8 Россия Windows Бесплатно (free) Чистка базы

С некоторого релиза, не могу сказать точно с какого, при проведении массовой рассылки писем с вложениями стало быстро заканчиваться место. Как я это обнаружил и что с этим сделал, напишу ниже. Очень приветствуются другие варианты решения в комментариях.

23.03.2017    7260    hydro2588_2015    19       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Версионирование объектов в 1С УПП 1.3. Фикс дублей 11

Статья Системный администратор Программист Нет файла v8 УПП1 Россия Windows Бесплатно (free) Чистка базы Производительность и оптимизация (HighLoad)

В 1С УПП 1.3 есть такой замечательный механизм "версионирование объектов", который позволяет узнать: кто, когда и что изменил в документах и справочниках. Но есть недочеты в этой системе, программа не проверяет, является ли текущая записываемая версия объекта дублем (аналогична предыдущей версии), что в итоге захламляет базу и существенно увеличивает её объем.

1 стартмани

16.11.2015    11764    tehas    4       

БГУ 1.0. Чистим отчётность 11

Статья Системный администратор Нет файла v8 БГУ Государственные, бюджетные структуры Россия БУ Windows Бесплатно (free) Чистка базы

Временами встречается проблема с заполнением бюджетной (бухгалтерской) отчётности в БГУ 1.0. По разным причинам отчётность может заполняться неправильно или не заполняться совсем. В данной статье приведена методика быстрой «чистки» отчётности.

29.09.2015    14258    Sergey123321    6       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.127.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Задвоение элементов плана счетов в базе на SQL. 3

Статья Программист Нет файла v8 Windows Бесплатно (free) Чистка базы

Иногда приходится разбираться с "грехами отцов", когда приходишь к клиенту, а до тебя наделали делов. Вот, собственно, проблема: Настраивали когда-то план обмена, все работало штатно. Потом обмен пошел не как надо и в справочниках появились задвоенные предопределенные элементы. В общем, на Инфостарте нашел кучу обработок, которые помогут. Но тут оказалось, что если работать с элементом "ПланСчетов", эти обработки бесполезны.

27.08.2015    7184    vasyalisk88    17       

Фоновое Задание "Удаление помеченных объектов" (не монопольно) 40

Статья Программист Нет файла v8 1cv8.cf Россия Windows Бесплатно (free) Чистка базы

Подробное описание немонопольного удаления помеченных объектов, реализованное как Фоновое Задание.

02.08.2013    19847    shvo65    10       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Как свертывать большую базу 1C 8 в максимально короткие сроки (1С 8.1, 8.2) 62

Статья Системный администратор Программист Нет файла v8 УТ10 Windows Бесплатно (free) Свертка базы Чистка базы Производительность и оптимизация (HighLoad)

Как свертывать большую базу 1C 8 в максимально короткие сроки (1С 8.1, 8.2). Любая база данных со временем разрастается до огромных размеров, что делает его более медлительным и работать в нем порой бывает очень тяжело. По этому периодически базу свертывают, т.е. до определенной даты все документы и движения удаляются и вводятся начальные остатки. Соответственно всегда есть архивная база за прошлые периоды. Пример свертки базы 1С на SQL приведен здесь.

14.06.2013    56538    setrak    21       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

Удаление помеченных объектов группами 10

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Чистка базы

Предлагаемая обработка поможет в тех случаях когда в базе накопилось много помеченных на удаление объектов и штатными средствами удалить их не получается.

28.09.2010    12979    283    mrWatson    13       

Перенос документов и справочников ERP 2 / КА 2 / УТ 11 => БП 3.0 Промо

Перенос позволяет настроить собственный обмен данными между указанными программами, альтернативный предлагаемому фирмой 1С. Предоставляем техподдержку по всем вопросам данного обмена. Можем подключиться к вам удаленно для разбора ситуаций. Оперативно обновляем при выходе новых релизов 1С. Бесплатные обновления в течение полугода.

19700 руб.

Очистка БД от документов всех организаций (фирм) кроме указанной 50

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Чистка базы

Надо было скинуть слепок БД в вышестоящую организацию, но руководство справедливо решило, что все что по этой организации пусть видят, а вот остальные движения там на фиг не нужны, ну и накорябал сие, может ещё кому нить пригодится... Пользуйтесь

23.05.2010    29859    612    Farpost    15       

Универсальная обработка aaDeleteUpdate для 1C v8.2 4

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Бесплатно (free) Чистка базы Инструментарий разработчика

В 1С к сожалению в языке запросов отсутствуют Delete и Update. Данная обработка немного решает эту проблему для объектных типов (справочник, документ, ..)

05.05.2010    3697    78    vadimsntn    1       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Универсальная обработка aaDeleteUpdate 6

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Бесплатно (free) Чистка базы Инструментарий разработчика

К сожалению в языке запросов 1С отсутствуют Delete и Update. Данная обработка немного решает эту проблему для объектных типов (справочник, документ, ..) Выкладываю заново - исправил ошибку

12.04.2010    2999    58    vadimsntn    7       

Поиск ссылок на объект для последующего удаления объектов. 271

Инструменты и обработки Системный администратор Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Чистка базы Поиск данных

Иногда бывает нужно найти все ссылки на конкретный документ или любой другой объект системы, чтобы все это удалить...

12.01.2010    48452    2623    YAN    44       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

С 2020 года сервис «Продление поддержки конфигурации 1С:УПП» подорожает вдвое Промо

Успейте продлить поддержку УПП до повышения цен! Фирма «1С» предупредила об изменении цен на сервис «Продление поддержки конфигурации "1С:Управление производственным предприятием"». С 1 января 2020 года сервис подорожает в два раза.

Полное удаление организации из базы 48

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Бесплатно (free) Чистка базы

Полное удаление Организации и всех зависимых объектов для версии 8.0

27.02.2009    36737    3653    ganelin    26       

Очный семинар по регулярному менеджменту Александра Фридмана "Вы или Хаос", 12 декабря 2019 г. , Санкт-Петербург Промо

Семинар по регулярному менеджменту от Александра Фридмана для собственников, первых лиц и топов. Технология управленческого планирования, комплексного управления временем и другими ресурсами, выполнением поручений, делами, информацией, контактами (встречи-звонки-почта).

от 11000 до 29000 рублей

Групповая обработка документов (признаки и непосредственное удаление) 28

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Бесплатно (free) Сервисные утилиты Чистка базы Обработка документов

Обработка сделана для более наглядного отображения процесса групповой работы с документами, чем штатная. И никак не претендует на оригинальность жанра. Требовалась простота и наглядность по работе с признаками документов и их непосредственным удалением из базы.

16.01.2008    20364    1175    Шёпот теней    18       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.