Заполнение ОГРН с использованием Инструментов разработчика

Публикация № 610851 14.04.17

Пользовательские инструменты - Обработка справочников

загрузка ОГРН ИР Инструменты разработчика

Вот и до нашей организации добралось требование указывать в отчетности для ГлавКонтроля ОГРН контрагента. Как всегда, задача возникла внезапно, и решить ее нужно было "вчера".

Обозрев просторы интернетов, стало понятно, что владельцы информации сделали все, чтобы максимально затруднить массовое получение такой информации. К счастью, добрый человек  Sirruf, опубликовал обработку, позволяющую получать ОГРН с разных сайтов, в том числе,  fedresurs.ru.

Так как задача была срочная и одноразовая, было решено не городить огородов, а написать алгоритм для Инструментов разработчика уважаемого Сергея Старых (tormozit), позаимствовав процедуру получения данных из обработки ВводКонтрагентовПоДаннымФНС_ОбычныеФормы.

Опубликую это здесь, может кому-то пригодится.

Итак:

В конце концов, я решил использовать инструмент Консоль запросов (ИР).

В справочник Контрагенты был добавлен реквизит ахОГРН, который и требовалось заполнить актуальными данными.

Почему реквизит справочника?

Конечно, в соответствии с 1CZen, правильнее было бы добавить в конфигурацию новую таблицу, например РС:ОГРНКонтрагентов, раз уж не предусмотрено в типовой конфигурации УПП реквизита ОГРН в справочнике Контрагенты. но мы решили, что ОГРН - это у контрагента раз и навсегда, поэтому все-таки добавили именно реквизит справочника.

Запросом отобрал необходимых контрагентов и заявил дополнительные реквизиты, которые будут заполняться на последующем шаге:

ВЫБРАТЬ
	Контрагенты.Родитель КАК Родитель,
	Контрагенты.Код КАК КонтрагентКод,
	Контрагенты.Ссылка КАК КонтрагентСсылка,
	Контрагенты.НаименованиеПолное КАК ПолноеНаименование,
	Контрагенты.ИНН КАК СпрИНН,
	Контрагенты.КПП КАК СпрКПП,
	выразить("" как Строка(300)) КАК Наименование,
	выразить("" как Строка(15)) КАК ИНН,
	выразить("" как Строка(15)) КАК КПП,
	выразить("" как Строка(30))  КАК ОГРН,
	выразить("" как Строка(300))  КАК Адрес,
	выразить("" как Строка(300))  КАК url
ИЗ
	Справочник.Контрагенты КАК Контрагенты
ГДЕ  Истина
	И Контрагенты.Родитель = &РодительПапкаСбыт
	И НЕ Контрагенты.ЭтоГруппа
	И Контрагенты.ЮрФизЛицо = &ЮрФизЛицоЮрЛицо

Далее, заполнил текст модуля "Обработка строки результата" процедурой получения данных. Сервис fedresurs.ru был выбран из-за отсутствия необходимости ввода капчи на каждый запрос. Хотя, боюсь, что это скоро прикроют и капчу все-таки навесят. Сегодня, 14.04.2017, я этим алгоритмом загружал данные в копию информационной базы - капчи не было.

К тексту модуля небольшое пояснение:

Действие выполняется в два этапа: на первом этапе получаются данные от вебсервиса для контрагента (по ИНН) текущей строки набора данных и их запись в ячейки строки таблицы данных. На втором этапе получается объект справочника Контрагенты из ссылки в текущей строке набора данных и полученные данные записываются в объект. Так как в модуле Обработка результата Консоли запросов (ИР) результирующий набор данных (внезапно!)  а переносить получение данных в процедуру Обработка результата мне было лениво, оба этапа реализованы в одном модуле Обработка строки результата, а этап выбирается значением переменной ПолучениеИзInternet. Когда она равна правде - происходить загрузка данных, если ее установить в неправду - данные из набора данных записываются в справочник.

Кроме кода ОГРН, вебсервис возвращает еще правильное наименование контрагента и его юридический адрес. Посчитав, что это важные для выверки данные, я решил сохранить их в неиспользуемом у нас реквизите справочника ДополнительноеОписание. Туда же дописывается ссылка, по которой можно открыть страницу с данными этого контрагента на fedresurs.ru.

// Заполнение Адрес, ОГРН, url и правильного Наименования в Результат-коллекция
// данные для заполнения берутся с сайта http://www.fedresurs.ru
// алгоритм чтения страницы и разбора параметров взят из //infostart.ru/public/281276/

ФР = "http://se.fedresurs.ru";
ПолучениеИзInternet = ложь;
Состояние(СтрокаРезультата.ПолноеНаименование);

Если Не ПолучениеИзInternet Тогда
	КонтрагентОбъект = Справочники.Контрагенты.НайтиПоКоду(СтрокаРезультата.КонтрагентКод).ПолучитьОбъект();
	КонтрагентОбъект.ахОГРН = СтрокаРезультата.ОГРН;
	КонтрагентОбъект.ДополнительноеОписание = 
		 СтрокаРезультата.Наименование+Символы.ПС
		+"---***---"+Символы.ПС
		+СтрокаРезультата.Адрес+Символы.ПС
		+"---***---"+Символы.ПС
		+СтрокаРезультата.url;
	КонтрагентОбъект.Записать();
Иначе
	
	зИНН = СокрЛП(СтрокаРезультата.СпрИНН);
	Если СтрДлина(зИНН) <> 10 Тогда
		СтрокаРезультата.ИНН = "***UNKNOWN INN***";
		
	ИначеЕсли ПустаяСтрока(СтрокаРезультата.Адрес) тогда
		
		ГетЗапрос = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
		ГетЗапрос.SetTimeouts(10000, 10000, 10000, 10000);
		СтрокаЗапроса = ФР+"/companies?filter=" + зИНН;
		ГетЗапрос.Open("GET", СтрокаЗапроса, 0); 
		
		Попытка
			ГетЗапрос.Send();
			ГетЗапрос.WaitForResponse();
		Исключение
			Сообщить(ОписаниеОшибки());
		КонецПопытки;
		
		ResponseText = ГетЗапрос.ResponseText();
		
		ResponseText = СтрЗаменить(ResponseText, Символы.ВК + Символы.ПС, "");
		
		Шаблон = "<div class=""vcard listItem""(.*?)</div>\s*</div>";
		
		СтрокаПоиска = ResponseText;
		//=====================>>>[НайтиВхожденияШаблона]
		//	ВхожденияШаблона = НайтиВхожденияШаблона(ResponseText, ШаблонПоиска);
		МассивСтрок = Новый Массив;
		RegExp = Новый COMОбъект("VBScript.RegExp");
		RegExp.IgnoreCase = Истина; //Игнорировать регистр
		RegExp.Global = Истина; //Поиск всех вхождений шаблона
		RegExp.MultiLine = Ложь; //Многострочный режим
		
		RegExp.Pattern = Шаблон; 
		Matches=RegExp.Execute(СтрокаПоиска);
		ЧислоВхождений=Matches.Count();
		Если ЧислоВхождений>0 Тогда 
			Для к = 0 По ЧислоВхождений-1 Цикл
				Match = Matches.Item(к);
				
				SubMatches = Match.SubMatches;
				ЧислоПодвыражений=SubMatches.Count();
				
				МассивПодстрок = Новый Массив;
				
				Для н = 0 По ЧислоПодвыражений-1 Цикл
					SubMatch=SubMatches.Item(н);
					Если SubMatch="" Тогда
						Продолжить;
					КонецЕсли;    
					
					МассивПодстрок.Добавить(SubMatch);
					
				КонецЦикла;    
				
				Если МассивПодстрок.Количество() > 0 тогда
					МассивСтрок.Добавить(МассивПодстрок);
				КонецЕсли;
				
			КонецЦикла;
		КонецЕсли;
		
		//=====================<<<[НайтиВхожденияШаблона]
		ВхожденияШаблона = МассивСтрок;	
		
		МассивСтрок = Новый Массив;
		Для каждого ТекВхождение из ВхожденияШаблона цикл
			РезПоискаСтр = ТекВхождение[0];
			//=====================>>>[РазобратьЭлементРезультатаПоискаФР]
			Результат = Новый Соответствие;
			
			ШаблонПоискаНаименования = "onclick="" window.location.assign\('(.*?)'.*<span class=""fn org"".*?>(.*?)<";
			
			
			СтрокаПоиска = РезПоискаСтр;
			Шаблон = ШаблонПоискаНаименования;
			//=====================>>>[НайтиВхожденияШаблона]
			//	ВхожденияШаблона = НайтиВхожденияШаблона(РезПоискаСтр, ШаблонПоискаНаименования);
			МассивСтрок = Новый Массив;
			RegExp = Новый COMОбъект("VBScript.RegExp");
			RegExp.IgnoreCase = Истина; //Игнорировать регистр
			RegExp.Global = Истина; //Поиск всех вхождений шаблона
			RegExp.MultiLine = Ложь; //Многострочный режим
			
			RegExp.Pattern = Шаблон; 
			Matches=RegExp.Execute(СтрокаПоиска);
			ЧислоВхождений=Matches.Count();
			Если ЧислоВхождений>0 Тогда 
				Для к = 0 По ЧислоВхождений-1 Цикл
					Match = Matches.Item(к);
					
					SubMatches = Match.SubMatches;
					ЧислоПодвыражений=SubMatches.Count();
					
					МассивПодстрок = Новый Массив;
					
					Для н = 0 По ЧислоПодвыражений-1 Цикл
						SubMatch=SubMatches.Item(н);
						Если SubMatch="" Тогда
							Продолжить;
						КонецЕсли;    
						
						МассивПодстрок.Добавить(SubMatch);
						
					КонецЦикла;    
					
					Если МассивПодстрок.Количество() > 0 тогда
						МассивСтрок.Добавить(МассивПодстрок);
					КонецЕсли;
					
				КонецЦикла;
			КонецЕсли;
			
			//=====================<<<[НайтиВхожденияШаблона]
			ВхожденияШаблона = МассивСтрок;	
			
			Если ВхожденияШаблона.Количество() > 0 тогда
				Результат.Вставить("url", ВхожденияШаблона[0][0]);
				СтрокаРезультата.url = ФР + СокрЛП(ВхожденияШаблона[0][0]);
				
				Наим = СокрЛП(ВхожденияШаблона[0][1]);
				Наим = СтрЗаменить(Наим, "&quot;", "");
				СтрокаРезультата.Наименование = Наим;
				Результат.Вставить("NAME", Наим);
			КонецЕсли;
			
			
			ШаблонПоискаИНН = "ИНН&nbsp;(\d+)";
			
			СтрокаПоиска = РезПоискаСтр;
			Шаблон = ШаблонПоискаИНН;
			//=====================>>>[НайтиВхожденияШаблона]
			//	ВхожденияШаблона = НайтиВхожденияШаблона(РезПоискаСтр, ШаблонПоискаИНН);
			МассивСтрок = Новый Массив;
			RegExp = Новый COMОбъект("VBScript.RegExp");
			RegExp.IgnoreCase = Истина; //Игнорировать регистр
			RegExp.Global = Истина; //Поиск всех вхождений шаблона
			RegExp.MultiLine = Ложь; //Многострочный режим
			
			RegExp.Pattern = Шаблон; 
			Matches=RegExp.Execute(СтрокаПоиска);
			ЧислоВхождений=Matches.Count();
			Если ЧислоВхождений>0 Тогда 
				Для к = 0 По ЧислоВхождений-1 Цикл
					Match = Matches.Item(к);
					
					SubMatches = Match.SubMatches;
					ЧислоПодвыражений=SubMatches.Count();
					
					МассивПодстрок = Новый Массив;
					
					Для н = 0 По ЧислоПодвыражений-1 Цикл
						SubMatch=SubMatches.Item(н);
						Если SubMatch="" Тогда
							Продолжить;
						КонецЕсли;    
						
						МассивПодстрок.Добавить(SubMatch);
						
					КонецЦикла;    
					
					Если МассивПодстрок.Количество() > 0 тогда
						МассивСтрок.Добавить(МассивПодстрок);
					КонецЕсли;
					
				КонецЦикла;
			КонецЕсли;
			
			//=====================<<<[НайтиВхожденияШаблона]
			ВхожденияШаблона = МассивСтрок;	
			
			Если ВхожденияШаблона.Количество() > 0 тогда
				//				Результат.Вставить("INN", ЗаменитьКривыеСимволы(СокрЛП(ВхожденияШаблона[0][0])));
				Результат.Вставить("INN", СокрЛП(ВхожденияШаблона[0][0]));
				СтрокаРезультата.ИНН = СокрЛП(ВхожденияШаблона[0][0]);
			КонецЕсли;
			
			ШаблонПоискаОГРН = "ОГРН&nbsp;(\d+)";
			СтрокаПоиска = РезПоискаСтр;
			Шаблон = ШаблонПоискаОГРН;
			//=====================>>>[НайтиВхожденияШаблона]
			// ВхожденияШаблона = НайтиВхожденияШаблона(РезПоискаСтр, ШаблонПоискаОГРН);
			МассивСтрок = Новый Массив;
			RegExp = Новый COMОбъект("VBScript.RegExp");
			RegExp.IgnoreCase = Истина; //Игнорировать регистр
			RegExp.Global = Истина; //Поиск всех вхождений шаблона
			RegExp.MultiLine = Ложь; //Многострочный режим
			
			RegExp.Pattern = Шаблон; 
			Matches=RegExp.Execute(СтрокаПоиска);
			ЧислоВхождений=Matches.Count();
			Если ЧислоВхождений>0 Тогда 
				Для к = 0 По ЧислоВхождений-1 Цикл
					Match = Matches.Item(к);
					
					SubMatches = Match.SubMatches;
					ЧислоПодвыражений=SubMatches.Count();
					
					МассивПодстрок = Новый Массив;
					
					Для н = 0 По ЧислоПодвыражений-1 Цикл
						SubMatch=SubMatches.Item(н);
						Если SubMatch="" Тогда
							Продолжить;
						КонецЕсли;    
						
						МассивПодстрок.Добавить(SubMatch);
						
					КонецЦикла;    
					
					Если МассивПодстрок.Количество() > 0 тогда
						МассивСтрок.Добавить(МассивПодстрок);
					КонецЕсли;
					
				КонецЦикла;
			КонецЕсли;
			
			//=====================<<<[НайтиВхожденияШаблона]
			ВхожденияШаблона = МассивСтрок;	
			
			Если ВхожденияШаблона.Количество() > 0 тогда
				//				Результат.Вставить("OGRN", ЗаменитьКривыеСимволы(СокрЛП(ВхожденияШаблона[0][0])));
				Результат.Вставить("OGRN", СокрЛП(ВхожденияШаблона[0][0]));
				СтрокаРезультата.ОГРН = СокрЛП(ВхожденияШаблона[0][0]);
			КонецЕсли;
			
			ШаблонПоискаАдреса = "Адрес:&nbsp;(.*?)<";
			СтрокаПоиска = РезПоискаСтр;
			Шаблон = ШаблонПоискаАдреса;
			//=====================>>>[НайтиВхожденияШаблона]
			// ВхожденияШаблона = НайтиВхожденияШаблона(РезПоискаСтр, ШаблонПоискаАдреса);
			МассивСтрок = Новый Массив;
			RegExp = Новый COMОбъект("VBScript.RegExp");
			RegExp.IgnoreCase = Истина; //Игнорировать регистр
			RegExp.Global = Истина; //Поиск всех вхождений шаблона
			RegExp.MultiLine = Ложь; //Многострочный режим
			
			RegExp.Pattern = Шаблон; 
			Matches=RegExp.Execute(СтрокаПоиска);
			ЧислоВхождений=Matches.Count();
			Если ЧислоВхождений>0 Тогда 
				Для к = 0 По ЧислоВхождений-1 Цикл
					Match = Matches.Item(к);
					
					SubMatches = Match.SubMatches;
					ЧислоПодвыражений=SubMatches.Count();
					
					МассивПодстрок = Новый Массив;
					
					Для н = 0 По ЧислоПодвыражений-1 Цикл
						SubMatch=SubMatches.Item(н);
						Если SubMatch="" Тогда
							Продолжить;
						КонецЕсли;    
						
						МассивПодстрок.Добавить(SubMatch);
						
					КонецЦикла;    
					
					Если МассивПодстрок.Количество() > 0 тогда
						МассивСтрок.Добавить(МассивПодстрок);
					КонецЕсли;
					
				КонецЦикла;
			КонецЕсли;
			
			//=====================<<<[НайтиВхожденияШаблона]
			ВхожденияШаблона = МассивСтрок;	
			
			
			Если ВхожденияШаблона.Количество() > 0 тогда
				//				Результат.Вставить("ADRESTEXT", ЗаменитьКривыеСимволы(СокрЛП(ВхожденияШаблона[0][0])));
				Результат.Вставить("ADRESTEXT", СокрЛП(ВхожденияШаблона[0][0]));
				СтрокаРезультата.Адрес = СокрЛП(ВхожденияШаблона[0][0]);
			КонецЕсли;
			
			
			//=====================<<<[РазобратьЭлементРезультатаПоискаФР]
			//		МассивСтрок.Добавить(РазобратьЭлементРезультатаПоискаФР(РезПоиска));
			МассивСтрок.Добавить(Результат);
		КонецЦикла;
	КонецЕсли;
КонецЕсли;

заполнение таблицы для 4848 строк прошло за 14 минут

Выполнение завершено, обработано 4 848 элементов за 0:13:57 (837 сек). Грубое среднее время обработки элемента - 172,65 мс

Готовый файл для Консоли запросов (ИР) можно скачать ниже.

Скачать файлы

Наименование Файл Версия Размер
Заполнение ОГРН с использованием инструментов разработчика:

.sel 23,31Kb
4
.sel 23,31Kb 4 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Передача больших пакетов через веб-сервисы Промо

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

06.12.2015    74077    Infostart    19    

Интеграция (Ich will version)

Идеи и тренды в разработке WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Поговорим про интеграцию с точки зрения архитектора.

1 стартмани

16.09.2022    3280    botokash    66    

Модуль переводов и платежей QIWI

Розничная торговля WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 11 1С:Управление торговлей 11 Россия Россия Абонемент ($m) Абонемент ($m)

Инструкция по установке и работе "Модуля переводов и платежей QIWI" для УТ11.4. Публикация создана с целью размещения актуальной онлайн инструкции по работе пользователей с функционалом оформления платежей или переводов КИВИ через РМК в УТ11.4, а также для описания установки модуля в УТ 11.4 и размещения необходимых библиотек dll.

03.06.2022    572    Rastopchinss    5    

Тестирование API 1C Postman

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Тестирование вашего API, который вы сделали на 1С.

1 стартмани

18.08.2021    6691    kolya_tlt    7    

Демо связи веб сервисов 1С и php Промо

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Демонстрация обращения к веб сервису 1С из php. Пример простейший, уровня hello world. Дана одна страница и информационная база 1С с одним справочником и одним веб сервисом. Веб сервис выдаёт содержимое справочника по запросу странички.

1 стартмани

19.07.2013    33308    Трактор    20    

Создаем интернет-магазин на бесплатной CMS PrestaShop с открытым кодом за 60 минут

Розничная торговля WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Оперативный учет Оперативный учет 1С:Управление торговлей 11 1С:Управление торговлей 11 Управленческий учет Управленческий учет Абонемент ($m) Абонемент ($m)

Описано пошаговое создание полноценного действующего интернет-магазина. Бесплатно. Без программирования. Без навыков администрирования. Для "чайников".

1 стартмани

31.05.2021    2690    andryandry    0    

Создаем расширение для скрытия дополнительной информации с формы справочника Партнеры

Обработка справочников Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Всем привет. Статью создал в первую очередь для себя и себе подобных, тех, кто только начинает разбираться в дебрях 1С. Речь здесь пойдет о справочнике "Партнеры", а точнее формы списка этого справочника. Итак. Мы начинаем.

1 стартмани

29.09.2020    913    VID1234    2    

Перенос всех логов в Elasticsearch

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

В качестве стандартного места хранения логов в "1С:Предприятие" используется Журнал регистрации. Также часто для хранения служебных событий создают специальные Регистры сведений. Но у этих решений есть свои недостатки. В статье описан подход для хранения любых логов в самой популярной свободной поисковой системе Elasticsearch.

1 стартмани

15.07.2020    6895    kuleshov.x    5    

Примеры пользования web сервисов 1С из браузера Промо

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Даны примеры реализации доступа к web сервисам 1С из браузера. Примеры web сервисов, а также javascript'ы для доступа к этим сервисам. AJAX доступ к 1С.

1 стартмани

29.06.2008    159423    Трактор    233    

1С+Firebase. Оперативное отображение информации

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Появилась задача по отображению информации из базы в "режиме реального времени" с возможностью масштабирования количества подключенных клиентов (неплохо бы уметь подключаться с мобильных устройств), плавающей нагрузкой и минимальными затратами на разработку без изобретения сложных велосипедов. В уме довольно быстро всплыло "Firebase". Далее небольшой опыт реализации взаимодействия с Firestore для раскрашивания объектов карты.

1 стартмани

06.04.2020    4206    oyti    2    

Синтез речи из текста с помощью Яндекс SpeechKit

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В статье описан процесс подключения Яндекс SpeechKit API и программная реализация синтеза речи из текста с помощью этого API. Тестировалось на релизе платформы 8.3.16.1224. Может использоваться в любой конфигурации. Синтез речи может использоваться для самых разных целей, в моём случае потребовалось перевести лекции из текстовых файлов в звук

1 стартмани

05.04.2020    14474    m0zg153    2    

На хайпе: интегрируем 1С с сервисом видеоконференций Zoom

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

По причине коронавируса всем резко понадобились видеоконференции, а Зум (zoom.us) - одна из самых популярных платформ для этого. Когда пользователей и трансляций в зуме много, возникает необходимость в автоматизации. Рассматривается интеграция 1С с Zoom через API - от регистрации в сервисе до создания конференции из 1С.

1 стартмани

04.04.2020    18406    muzipov    5    

Вариант реализации REST API для 1С-Битрикс Управление сайтом

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Россия Россия Абонемент ($m) Абонемент ($m)

В статье опишу вариант обмена 1С УТ 11.4 и 1С-Битрикс управление сайтом с иcпользованием компонентов Symfony, в качестве примера обмен данными по товарам.

1 стартмани

28.01.2020    12782    malikov_pro    3    

Разбираемся с web-kit в 1С, на примере интеграции TinyMCE в управляемую форму в УТ 11.4. Допиливаем обмен с сайтом в УТ 11.4

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы 1С:Управление торговлей 11 1С:Управление торговлей 11 Абонемент ($m) Абонемент ($m)

Многие уже знают, что в релизе платформы 8.3.14.1565, браузер Internet Explorer был заменен на Web-Kit, это на самом деле большой шаг вперед, но я уверен, многим, как и мне, пока не совсем понятно, что к чему. Возник опыт использования web-kit в 1С, вызова JS из 1С и вызова 1С из JS. Давайте вместе попробуем понять, чем одно отличается от другого, и заодно сделаем, что-нибудь полезное. Да и наверняка многим придется переписывать свои подобные поделки после обновления на новую платформу, так что надеюсь мой опыт окажется полезным.

2 стартмани

08.12.2019    10928    Бэнни    25    

"Живые" картинки со Snap.SVG

WEB-интеграция Работа с интерфейсом Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

В статье рассмотрен пример использования http-сервисов для визуализации данных

1 стартмани

24.10.2019    16334    blackhole321    7    

Интеграция 1С с сайтом (магазином) WordPress (WooCommerce) с помощью Rest API сайта. Часть 1. Авторизация

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Интеграция 1С с сайтом (магазином) WordPress (WooCommerce) с помощью функционала Rest API предоставляемого платформой (CMS) WordPress (WooCommerce). Без дополнительных приложений на PHP/вставьте сюда любой другой язык программирования/.

1 стартмани

12.10.2019    56792    osivv    39    

АИТП. Автоматизируем управление ресурсами на примере Яндекс.Почта для домена

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В статье демонстрируется использование программного пакета АИТП для автоматизации предоставления ИТ-ресурсов сотрудникам на примере управления почтовыми ящиками Яндекс.Почта для домена.

1 стартмани

26.08.2019    7134    blackhole321    4    

Использование HTTP-сервиса для создания "фронтенда" HTML/CSS/jQuery с кэшированием

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В статье описан способ создания "фронтенда" на HTML/CSS/jQuery и скрипт кеширования AJAX запросов на PHP.

1 стартмани

06.08.2019    16466    Sedaiko    28    

Обмен с интернет-магазином на платформе DOCPART

WEB-интеграция Оптовая торговля Розничная торговля Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В настоящее время существует множество платформ для создания интернет-магазинов. Удобные и не очень, платные или бесплатные. У каждого решения найдутся свои сторонники, но наличие оперативного обмена с учётной системой важно для любой платформы. В этой публикации мы рассмотрим одну из популярных платформ для создания интернет-магазина по продаже автозапчастей Docpart и организацию обмена данными с ней.

10 стартмани

04.07.2019    7580    Johny_v    25    

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере"

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    27454    dmitry1975    37    

Подключение к REST API через OAuth протокол из 1С

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

В статье описаны варианты подключения И решение граблей по подключению к REST API через протокол OAuth 2.0 из 1С. При разработке такого подключения для получения данных и загрузки в базу 1С я столкнулся с некоторыми проблемами, решил их и хочу поделиться этими наработками.

1 стартмани

06.09.2018    21435    chemezov    14    

HTTP Сервисы: Путь к своему сервису. Часть 1

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    181669    dsdred    45    

Создание подключаемой обработки табличной части с диалогом запроса параметров заполнения (управляемые формы)

Обработка документов Обработка справочников Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Пошаговый пример покажет, как сделать обработку табличной части для документа, предварительно открывающую диалоговое окно, где пользователь может указать требуемые характеристики (параметры), по которым произойдет обработка.

1 стартмани

03.05.2018    88850    Mirage78    27    

А чё это вы здесь делаете, а?

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Разработчикам тиражных обработок близка и понятна проблема обратной связи с пользователем. Много важного и полезного можно почерпнуть, зная, что делает бухгалтер, который запустил обработку. В большом мире вэба сбор статистики на сайте дело привычное и даже обязательное. Эта статья покажет практику применения инструментов сбора статистики из мира веба для обработок на платформе 1С:Предприятие.

1 стартмани

21.01.2018    25743    infosoft-v    42    

Пример заполнения/создания файла XML из XSD схемы, используя XDTO

WEB-интеграция Файловый обмен (TXT, XML, DBF), FTP Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Абонемент ($m) Абонемент ($m)

Добрый день, коллеги! Наконец-то дошли руки написать сию статью. Хочу поделиться своим опытом по разбору xsd схемы используя Фабрику XDTO, а также связанным с этим XML файлом. Думаю, наверняка кому-то понадобится.

1 стартмани

21.12.2017    67752    sandybaev    28    

Простой бесплатный DashBoard с помощью http сервиса

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    59973    dewersia    33    

Получение данных из Wialon Hosting через HTTP запросы (Remote API)

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Автомобили, автосервисы Автомобили, автосервисы Россия Россия Абонемент ($m) Абонемент ($m)

Статья будет полезна для быстрого старта работы с Wialon Hosting. Здесь я опишу основные принципы работы с системой Wialon через Remote API.

1 стартмани

12.09.2017    32812    maxopik2    30    

Передача большого количества объектов через Web-сервисы

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 1С:Управление торговлей 11 1С:Управление торговлей 11 Абонемент ($m) Абонемент ($m)

Один из вариантов передачи большого количества объектов при использовании Web-сервисов.

1 стартмани

31.01.2017    17050    SinglCOOLer    14    

Использование SoapUi для работы с веб-сервисами. Часть1

WEB-интеграция Платформа 1С v8.3 Платформа 1С v8.3 Абонемент ($m) Абонемент ($m)

Как работать с SoapUi для тестирования веб-сервисов .

1 стартмани

30.09.2016    145267    kiv1c    32