Транзакционная печать на примере БП3 и УТ10

Публикация № 685797

Разработка - Практика программирования

печать транзакции

Рассмотрим недостатки типовой подсистемы печати и один из вариантов её обхода – запись в транзакции модифицированного объекта, его печать и откат назад в исходное состояние на примерах для БП3 и УТ10.

Недостатки типовой подсистемы печати

Подсистема печати в типовых конфигурациях никогда не была дружелюбна к программисту. Поэтому если нужно решать нетривиальные задачи, то увы, приходится использовать извращения.

 

Очень жаль, что методисты из 1С не могут придумать рациональные и удобные подходы и алгоритмы к печати.

 

Основные недостатки подсистемы печати:

  1. В БП3 (и прочих конфигурациях на УФ) система почему-то заточена на быстродействие. Хотя любой принтер печатает медленнее, чем формируется форма. Зачем собирать несколько объектов в одном запросе, непонятно. Ведь код печати одного объекта был бы намного проще.
    Зачем эти сэкономленные миллисекунды исполнения, когда за ними стоят долгие часы разбирательств программистов в полученных сложных запросах?
    Подстановка в макеты используется перебором объекта ВыборкаИзРезультатаЗаброса, а его изменить нельзя, т.е. если нужно поставить небольшую заплатку, заменив типовое значение на свое, не получится, приходится чрезмерно усложнять код.
  2. В УТ10 нет единой точки в процедуру печати объекта, соответственно, если стоит задача перехватывать любую печать любого документа, не получится.

Транзакционная печать в БП3

Была поставлена задача – каждая строчка накладной реализации могла быть разбита на поставки несколькими машинами.

 

Соответственно, требовались печатные формы как по всей накладной, так и по отдельным машинам.

 

 

Чтобы добиться нужного эффекта, перед печатью нужно открыть транзакцию, оставить только нужные строки товара для конкретной машины, уменьшить количество до отправляемого этой машиной, пропорционально изменить сумму и отправить на печать.

 

Вот образцы полученных печатных форм.

 

Вся накладная, 20 брусов:

Первая машина, 18 брусов:

Вторая машина, 2 бруса (с маслом тут ошибка, потом она была исправлена):

 

Чтобы максимально эффективно достичь результата, нужно вставить заплатку в блок, который вызывается всегда при печати.

 

Дело в том, что печать реализации в БП3 может происходить в менеджере документа и в обработках типа «Печать ТТН».

 

В модуль УправлениеПечатьюСлужебныйКлиент в процедуру ВыполнитьПодключаемуюКомандуПечатиЗавершение, перед выполнением команды печати вставить код, определяющий, нужно использовать транзакционную печать или нет:

   

//ИЗМ Осипов 2016-03-20 ТранзакционнаяПечать чтобы выбрать текущую машину при печати накладной +
    Попытка
        ОписаниеКоманды.ДополнительныеПараметры.Вставить("ТекущаяМашина", ДополнительныеПараметры.Форма._ТекущаяМашина);
    Исключение
    КонецПопытки;
    //ИЗМ Осипов 2016-03-20 чтобы выбрать текущую машину при печати накладной -


…
Обработчик = ИмяОбработчика + "(ОписаниеКоманды)";
    Результат = Вычислить(Обработчик);

В процедуре СформироватьПечатныеФормы модуля УправлениеПечатью добавить в самом начале:

   

 //ИЗМ Осипов 2016-03-30 ТранзакционнаяПечать меняем объекты, соответственно номеру машины +
    Если ПараметрыПечати.Свойство("_ТекущаяМашина") И ПараметрыПечати._ТекущаяМашина <> 0 Тогда
        НачатьТранзакцию();
        Для Каждого Элемент Из МассивОбъектов Цикл
            Если ТипЗнч(Элемент) = Тип("ДокументСсылка._ЗаявкаПокупателя") Тогда
                ДО = Элемент.ПолучитьОбъект();
                Если ИмяМенеджераПечати = "Обработка.ПечатьТТН" Тогда
                    ДО.Номер = "66666666";
                КонецЕсли;
                _ДопСервер.ОбработатьДокументЗаявкиПокупателяДляПечати(ДО, ПараметрыПечати._ТекущаяМашина);
                ДО.ОбменДанными.Загрузка = истина;
                ДО.Записать();
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
    //ИЗМ Осипов 2016-03-30 ТранзакционнаяПечать меняем объекты, соответственно номеру машины -

И в самом конце этого модуля, перед возвратом результата, код по откату транзакции:

   

//ИЗМ Осипов Откатываем 2016-03-20 ТранзакционнаяПечать +
    Если ПараметрыПечати.Свойство("_ТекущаяМашина") И ПараметрыПечати._ТекущаяМашина <> 0 Тогда
        ОтменитьТранзакцию();
        Сч = 0;
        Для Каждого ТекПечатнаяФорма ИЗ КоллекцияПечатныхФорм Цикл
            Сч = СЧ + 1;
            Если Сч > ОбъектыПечати.Количество() Тогда Продолжить; КонецЕсли;
            ТекОбъект = ОбъектыПечати[Сч - 1];

            ПравильныйНомер = ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать(ТекОбъект.Значение.Номер, Истина, Ложь);
            ПравильныйНомер = ПравильныйНомер + "/" + ПараметрыПечати._ТекущаяМашина;

            ТекОбласть = ТекПечатнаяФорма.ТабличныйДокумент.НайтиТекст("66666666", , , );
            Если ТекОбласть <> Неопределено Тогда
                ТекОбласть.Текст = ПравильныйНомер;
            КонецЕсли;

        КонецЦикла;

    КонецЕсли;
    //ИЗМ Осипов 2016-03-20 ТранзакционнаяПечать -

Он не обязательный, т.к. когда управление вернется пользователю, транзакция автоматически изменится.

 

Ну и соответственно, код, который обрабатывает документ перед печатью в случае, когда требуется вывести данные только по одной машине, а не в целом по документу:

Функция ОбработатьДокументЗаявкиПокупателяДляПечати(ДО, НомерМашины) Экспорт
    Всего = ДО.Товары.Количество();
    Для Инд = 1 ПО Всего Цикл
        Строка = ДО.Товары[Всего-Инд];
        ИскСтрокиМашин = ДО._Машины.НайтиСтроки(Новый Структура("_КлючСтроки", Строка._КлючСтроки));
        ОбщееКоличествоПоМашинам = 0;
        РезКоличество = 0;
        Для Каждого ИскСтрокаМашин ИЗ ИскСтрокиМашин Цикл
            ОбщееКоличествоПоМашинам = ОбщееКоличествоПоМашинам + ИскСтрокаМашин.Количество;
            Если ИскСтрокаМашин.НомерМашины = НомерМашины Тогда
                РезКоличество = ИскСтрокаМашин.Количество;
            КонецЕсли;
        КонецЦикла;
        //Если по машинам не распределено
        Если ОбщееКоличествоПоМашинам = 0 Тогда
            РезКоличество = Строка.Количество;
        КонецЕсли;
        ИсходноеКоличество = Строка.Количество;
        Строка.Количество = РезКоличество;
        Если Строка.Количество = 0 ИЛИ ИсходноеКоличество = 0 Тогда
        Иначе
            //Делим суммы пропорционально количеству
            Строка.Сумма = Строка.Сумма * Строка.Количество / ИсходноеКоличество;
            Строка.СуммаНДС = Строка.СуммаНДС * Строка.Количество / ИсходноеКоличество;
        КонецЕсли;

    КонецЦикла;
КонецФункции

Обратите внимание, как обработана замена номера, чтобы печатался номер машины через слэш.

Транзакционная печать в УТ10

В УТ10 мне понадобилась транзакционная печать в других целях. Заказчик поставил задачу заменять при печати наименование товара во всех торговых документах. Если бы это происходило всегда, можно было бы поменять полное наименование, но нужно было чтобы старые документы перепечатывались бы без изменения.

 

Соответственно, перед печатью документа нужно изменять наименование товара:

Функция НужнаТранзакционнаяПечать(Объект)Экспорт
    //Осипов 2016-03-24 Замена наименования... +++
    Если Объект.Дата >= '20160323' И НЕ Объект.Модифицированность() Тогда
        ТранзакцияОткрыта = ложь;
        ТекСсылка = Объект.Ссылка;
        Если ТипЗнч(ТекСсылка) = Тип("ДокументСсылка.СчетФактураВыданный")  Тогда
            ТекСсылка = ТекСсылка.ДокументОснование;
        КонецЕсли;      Если ТекСсылка.Метаданные().ТабличныеЧасти.Найти("Товары") <> Неопределено Тогда
            Маркер = "Палка "; ДлинаМаркера = СтрДлина(Маркер);
            НовыйМаркер = "Палка для коррекции ";
            ДлинаНовогоМаркера = СтрДлина(НовыйМаркер);
            Для Каждого ТекСтрока Из ТекСсылка.Товары Цикл
                ТекНаименование = ТекСтрока.Номенклатура.НаименованиеПолное;
                Если
                    Лев(ТекНаименование, ДлинаМаркера) = Маркер И
                    Лев(ТекНаименование, ДлинаНовогоМаркера) <> НовыйМаркер
                Тогда
                    Если НЕ ТранзакцияОткрыта Тогда
                        НачатьТранзакцию();
                        ТранзакцияОткрыта = истина;
                    КонецЕсли;
                    О = ТекСтрока.Номенклатура.ПолучитьОбъект();
                    О.НаименованиеПолное = СтрЗаменить(О.НаименованиеПолное, Маркер, НовыйМаркер);
                    О.ОбменДанными.Загрузка = истина;
                    О.Записать();;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
    КонецЕсли;
    //Осипов 2016-03-24 Замена наименования... --

    Возврат ТранзакцияОткрыта;
КонецФункции

 

Осталось выяснить, где вставить вызов этой процедуры.

Печать происходит методами Объект.Печать и НапечататьВнешнююФорму.

Эти методы вызываются в модуле УниверсальныеМеханизмы в двух  местах - в процедуре ОткрытьФормуВыбораПечатныхФормОбъекта и ПечатьПоДополнительнойКнопке. Да, программистам 1С не хватило ума вынести одинаковый код в отдельную функцию, мы наблюдаем обычный копи-паст.

 

Если ... Тогда
    ТабДокумент = НапечататьВнешнююФорму(Объект.Ссылка, Расшифровка);
    НапечататьДокумент(ТабДокумент,  ....);
Иначе
    Объект.Печать(...);
КонецЕсли;

 

В процедуре печати учтено, что объект может быть модифицирован, тогда он не печатается.

 

В случае ошибки может долго висеть предупреждение, и транзакция будет открыта, это недостатки решения, но такое бывает редко. В УФ отказались от модальности, такое не грозит.

Если бы не было условия даты документа, можно было использовать обработку макета перед печатью в функции НапечататьДокумент, она вызывается для всех документов. Но в эту функцию, к сожалению, не всегда передается ссылка.

 

Транзакция сама откатывается, массовых печатей нет. Но даже если будет массовая печать, не страшно - замена пройдет нормально, дважды маркер меняться не будет.

 

Вот как вставлять вызов процедуры:

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. shard 257 18.10.17 13:16 Сейчас в теме
я в подобных ситуациях (когда требуется изменить результат запроса, текст которого очень не хочется ковырять) применяю врезку:
1) выгружаю результат типового запроса в таблицу
2) обрабатываю таблицу как необходимо
3) получившуюся таблицу передаю параметров в свой запрос, результат которого записываю в переменную выборки или результата типового запроса
Оставьте свое сообщение

См. также

Serverless (Faas) в 1С. Создание и вызов Yandex Cloud Functions Промо

Универсальные функции Практика программирования v8 Бесплатно (free)

"Я не могу просто взять и скопировать код с гитхаба", "у нас 1С микросервисами окружена", "возможностей мало" - частые фразы 1С разработчиков. которым не хватает возможностей платформы в современном мире. Faas, конечно, история не новая, но нас сдерживало 152ФЗ и задержки по пингам. Для того, чтобы действительно использовать в 1С код, к примеру, на Python, надо было приложить усилия. Теперь всё намного проще - берём и используем.

28.12.2020    3661    comol    21    

Базовые вещи БСП, которые облегчат жизнь программисту 1С

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Бесплатно (free)

В данной публикации я опишу полезные процедуры и функции модуля общего назначения библиотеки стандартных подсистем, обязательные к использованию любым программистом 1С.

30.08.2020    9705    quazare    33    

Форма выбора (подбор) в управляемых формах

Практика программирования v8 v8::УФ 1cv8.cf Россия Бесплатно (free)

Разбор небольших примеров того, как правильно открывать форму выбора (подбора) в управляемых формах, не прибегая к модальным окнам.

08.05.2020    30650    user5300    16    

Программная работа с настройками СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Нюансы программной работы с настройками системы компоновки данных в отчетах и динамических списках. Обзор всех видов настроек компоновки. Что в каких случаях правильно применять. В качестве примера рассмотрена работа с отборами и группировками.

27.01.2020    35053    ids79    26    

Использование программных перечислений, ч.1: строковые константы Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Часто ли у вас возникает необходимость в коде выполнять сравнение на строку?

10.12.2016    38220    unichkin    74    

[СКД] Программное создание схемы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    28934    John_d    22    

Последовательности событий при проведении документа 1С. Шпаргалка + про формы + про расширения

Практика программирования v8 Россия Бесплатно (free)

Собрал информацию о событиях/подписках/расширениях в одном месте.

30.12.2019    21864    kuzyara    38    

30 задач. Странных и не очень

Практика программирования v8 Бесплатно (free)

30 задач на знание языка программирования 1С и некоторого поведения платформы. Маленьких. Странных и не очень.

02.12.2019    18413    YPermitin    58    

Вспомогательные инструкции в коде 1С Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    31673    tormozit    104    

Как передать IP адрес, который вызвал HTTP запрос в 1C (для веб-сервера Apache)

Практика программирования v8 Бесплатно (free)

Столкнулся с задачей получения IP адреса, который вызывает http сервис 1С. Итак, решение:

22.11.2019    9334    Sibars    19    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Бесплатно (free)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    32384    HostHost    40    

Таблица значений. Нюансы

Практика программирования v8 Бесплатно (free)

Обзор некоторых аспектов использования общеизвестного инструмента 1С.

01.10.2019    38348    Yashazz    50    

Оформление и рефакторинг сложных логических выражений Промо

Практика программирования v8 Россия Бесплатно (free)

В сложных логических выражениях нередко самому автору спустя какое-то время тяжело разобраться, не говоря уже о других программистах. Предлагаемая методика позволяет повысить наглядность таких выражений путем оформления в виде И-ИЛИ дерева и одновременно выполнять их рефакторинг.

20.09.2012    78984    tormozit    131    

О программе Postman для тестирования API и для чего она нужна 1С-нику

Практика программирования Программное обеспечение (software) v8 Бесплатно (free)

Для чего нужна программа Postman для тестирования API и какая от него польза для 1С-программиста.

24.09.2019    13847    budidich    28    

[Шпаргалка] Программное создание элементов формы

Практика программирования Работа с интерфейсом v8 1cv8.cf Бесплатно (free)

Программное создание практически всех популярных элементов формы.

06.09.2019    62012    rpgshnik    68    

Агрегатные функции СКД, о которых мало кто знает

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    55905    ids79    54    

Запись значения в поле ввода/формы со срабатыванием события ПриИзменении Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Иногда возникает необходимость после записи значения в какое либо поле ввода/формы вызвать для него обработчик события ПриИзменении, а о вызове самого события приходится только мечтать. В этой статье приводится программный способ вызова этого события.

11.07.2007    49665    tormozit    48    

Регистры бухгалтерии. Общая информация

Практика программирования Математика и алгоритмы v8 v8::БУ БУ Бесплатно (free)

Общая информация о внутреннем устройстве регистров бухгалтерии.

05.09.2019    31785    YPermitin    24    

Три костыля. Сказ про фокусы в коде

Практика программирования v8 Бесплатно (free)

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    26792    YPermitin    80    

Отслеживание выполнения фонового задания

Практика программирования Универсальные функции Разработка v8 1cv8.cf Бесплатно (free)

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    34201    ids79    16    

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере Промо

Практика программирования v8 1cv8.cf Россия Бесплатно (free)

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    46250    tormozit    74    

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    100426    ids79    56    

Фоновое выполнение кода в 1С - это просто

Практика программирования v8 1cv8.cf Бесплатно (free)

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    41899    avalakh    26    

Разбираемся с параметрами редактирования СКД

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Связь по типу, Параметры выбора, Связи параметров выбора

31.07.2019    27578    json    15    

Выгрузка документа по условию Промо

Практика программирования Разработка v8 Бесплатно (free)

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    16342    m-rv    2    

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    71471    ids79    12    

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ

Инструментарий разработчика Практика программирования v8 v8::СКД Бесплатно (free)

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    38846    ids79    27    

Регистры сведений. За кулисами

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    27757    YPermitin    14    

Как прикрутить ГУИД к регистру сведений Промо

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    20842    m-rv    17    

"Меньше копипаста!", или как Вася универсальную процедуру писал

Практика программирования Разработка v8 v8::СКД 1cv8.cf Бесплатно (free)

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    20222    SeiOkami    50    

Работа с настройками системы компоновки данных

Практика программирования v8 v8::СКД 1cv8.cf Бесплатно (free)

Варианты отчетов, работа с настройками вариантов: структура группировок, поля отчета, отборы, сортировка, условное оформление, другие настройки, настройки отображения диаграмм.

02.07.2019    55607    ids79    17    

Создание отчетов с помощью СКД - основные понятия и элементы

Практика программирования Математика и алгоритмы v8 v8::СКД Бесплатно (free)

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    58239    ids79    26    

Как сделать запрос на изменение данных Промо

Практика программирования v8 v8::Запросы 1cv8.cf Бесплатно (free)

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    31857    m-rv    21    

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017

Практика программирования Производительность и оптимизация (HighLoad) v8 v8::Запросы Бесплатно (free)

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    26688    dmurk    146    

Регистры накопления. Структура хранения в базе данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    47703    YPermitin    30    

О расширениях замолвите слово...

Практика программирования Разработка v8 Бесплатно (free)

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    37259    ellavs    126    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Практика программирования v8 1cv8.cf Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    28727    itriot11    34    

Git-репозитории для 1С-кода (опыт использования при небольших проектах)

Практика программирования v8 Бесплатно (free)

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    28302    ellavs    90    

Трюки с внешними источниками данных

Практика программирования Разработка v8 1cv8.cf Бесплатно (free)

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    33665    YPermitin    53    

Ошибки при работе с хранилищем конфигурации и способы их решения

Практика программирования v8 Бесплатно (free)

В статье собраны наиболее распространенные ошибки при работе с хранилищем конфигурации и способы их обхода и решения.

01.03.2019    45805    Смешной 1С    30    

Использование классов .Net в 1С для новичков Промо

Практика программирования Разработка внешних компонент Универсальные функции v7.7 v8 Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    77940    Serginio    110    

Разработка и сценарное тестирование с Vanessa-ADD. Отчетность Allure. Автоматизация запуска сценариев

Практика программирования Vanessa Automation v8 Россия Бесплатно (free)

Формируем отчетность о результатах выполнения сценариев. Автоматизируем запуск.

26.02.2019    23663    Vladimir Litvinenko    28    

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С Промо

Математика и алгоритмы Практика программирования v8 v8::blocking 1cv8.cf Бесплатно (free)

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    36758    ids79    40    

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS)

Практика программирования БСП (Библиотека стандартных подсистем) Роли и права v8 v8::Права Бесплатно (free)

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    44461    ids79    11    

EnterpriseData – часть 2. Процесс выгрузки данных

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    28574    ids79    31    

Тестер: частые вопросы Промо

Практика программирования v8 Бесплатно (free)

Ошибкам бой - тесты норма жизни!

25.07.2018    29927    grumagargler    28    

Новый подход к обмену данными EnterpriseData

Практика программирования Обмен через XML v8 v8::УФ Россия Бесплатно (free)

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    44423    ids79    72