Транзакционная печать на примере БП3 и УТ10

Публикация № 685797 13.10.17

Приемы и методы разработки - Механизмы платформы 1С

печать транзакции

Рассмотрим недостатки типовой подсистемы печати и один из вариантов её обхода – запись в транзакции модифицированного объекта, его печать и откат назад в исходное состояние на примерах для БП3 и УТ10.

Недостатки типовой подсистемы печати

Подсистема печати в типовых конфигурациях никогда не была дружелюбна к программисту. Поэтому если нужно решать нетривиальные задачи, то увы, приходится использовать извращения.

Очень жаль, что методисты из 1С не могут придумать рациональные и удобные подходы и алгоритмы к печати. 

Основные недостатки подсистемы печати:

  1. В БП3 (и прочих конфигурациях на УФ) система почему-то заточена на быстродействие. Хотя любой принтер печатает медленнее, чем формируется форма. Зачем собирать несколько объектов в одном запросе, непонятно. Ведь код печати одного объекта был бы намного проще.
    Зачем эти сэкономленные миллисекунды исполнения, когда за ними стоят долгие часы разбирательств программистов в полученных сложных запросах?
    Подстановка в макеты используется перебором объекта ВыборкаИзРезультатаЗаброса, а его изменить нельзя, т.е. если нужно поставить небольшую заплатку, заменив типовое значение на свое, не получится, приходится чрезмерно усложнять код.
  2. В УТ10 нет единой точки в процедуру печати объекта, соответственно, если стоит задача перехватывать любую печать любого документа, не получится.

Транзакционная печать в БП3

Была поставлена задача – каждая строчка накладной реализации могла быть разбита на поставки несколькими машинами.

Соответственно, требовались печатные формы как по всей накладной, так и по отдельным машинам.

 

 

Чтобы добиться нужного эффекта, перед печатью нужно открыть транзакцию, оставить только нужные строки товара для конкретной машины, уменьшить количество до отправляемого этой машиной, пропорционально изменить сумму и отправить на печать.

Вот образцы полученных печатных форм.

Вся накладная, 20 брусов:

Первая машина, 18 брусов:

Вторая машина, 2 бруса (с маслом тут ошибка, потом она была исправлена):

 

Чтобы максимально эффективно достичь результата, нужно вставить заплатку в блок, который вызывается всегда при печати.

Дело в том, что печать реализации в БП3 может происходить в менеджере документа и в обработках типа «Печать ТТН».

В модуль УправлениеПечатьюСлужебныйКлиент в процедуру ВыполнитьПодключаемуюКомандуПечатиЗавершение, перед выполнением команды печати вставить код, определяющий, нужно использовать транзакционную печать или нет:

 

//ИЗМ Осипов 2016-03-20 ТранзакционнаяПечать чтобы выбрать текущую машину при печати накладной +
    Попытка
        ОписаниеКоманды.ДополнительныеПараметры.Вставить("ТекущаяМашина", ДополнительныеПараметры.Форма._ТекущаяМашина);
    Исключение
    КонецПопытки;
    //ИЗМ Осипов 2016-03-20 чтобы выбрать текущую машину при печати накладной -


…
Обработчик = ИмяОбработчика + "(ОписаниеКоманды)";
    Результат = Вычислить(Обработчик);

В процедуре СформироватьПечатныеФормы модуля УправлениеПечатью добавить в самом начале:

 //ИЗМ Осипов 2016-03-30 ТранзакционнаяПечать меняем объекты, соответственно номеру машины +
    Если ПараметрыПечати.Свойство("_ТекущаяМашина") И ПараметрыПечати._ТекущаяМашина <> 0 Тогда
        НачатьТранзакцию();
        Для Каждого Элемент Из МассивОбъектов Цикл
            Если ТипЗнч(Элемент) = Тип("ДокументСсылка._ЗаявкаПокупателя") Тогда
                ДО = Элемент.ПолучитьОбъект();
                Если ИмяМенеджераПечати = "Обработка.ПечатьТТН" Тогда
                    ДО.Номер = "66666666";
                КонецЕсли;
                _ДопСервер.ОбработатьДокументЗаявкиПокупателяДляПечати(ДО, ПараметрыПечати._ТекущаяМашина);
                ДО.ОбменДанными.Загрузка = истина;
                ДО.Записать();
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
    //ИЗМ Осипов 2016-03-30 ТранзакционнаяПечать меняем объекты, соответственно номеру машины -

И в самом конце этого модуля, перед возвратом результата, код по откату транзакции:

//ИЗМ Осипов Откатываем 2016-03-20 ТранзакционнаяПечать +
    Если ПараметрыПечати.Свойство("_ТекущаяМашина") И ПараметрыПечати._ТекущаяМашина <> 0 Тогда
        ОтменитьТранзакцию();
        Сч = 0;
        Для Каждого ТекПечатнаяФорма ИЗ КоллекцияПечатныхФорм Цикл
            Сч = СЧ + 1;
            Если Сч > ОбъектыПечати.Количество() Тогда Продолжить; КонецЕсли;
            ТекОбъект = ОбъектыПечати[Сч - 1];

            ПравильныйНомер = ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать(ТекОбъект.Значение.Номер, Истина, Ложь);
            ПравильныйНомер = ПравильныйНомер + "/" + ПараметрыПечати._ТекущаяМашина;

            ТекОбласть = ТекПечатнаяФорма.ТабличныйДокумент.НайтиТекст("66666666", , , );
            Если ТекОбласть <> Неопределено Тогда
                ТекОбласть.Текст = ПравильныйНомер;
            КонецЕсли;

        КонецЦикла;

    КонецЕсли;
    //ИЗМ Осипов 2016-03-20 ТранзакционнаяПечать -

Он не обязательный, т.к. когда управление вернется пользователю, транзакция автоматически изменится.

Ну и соответственно, код, который обрабатывает документ перед печатью в случае, когда требуется вывести данные только по одной машине, а не в целом по документу:

Функция ОбработатьДокументЗаявкиПокупателяДляПечати(ДО, НомерМашины) Экспорт
    Всего = ДО.Товары.Количество();
    Для Инд = 1 ПО Всего Цикл
        Строка = ДО.Товары[Всего-Инд];
        ИскСтрокиМашин = ДО._Машины.НайтиСтроки(Новый Структура("_КлючСтроки", Строка._КлючСтроки));
        ОбщееКоличествоПоМашинам = 0;
        РезКоличество = 0;
        Для Каждого ИскСтрокаМашин ИЗ ИскСтрокиМашин Цикл
            ОбщееКоличествоПоМашинам = ОбщееКоличествоПоМашинам + ИскСтрокаМашин.Количество;
            Если ИскСтрокаМашин.НомерМашины = НомерМашины Тогда
                РезКоличество = ИскСтрокаМашин.Количество;
            КонецЕсли;
        КонецЦикла;
        //Если по машинам не распределено
        Если ОбщееКоличествоПоМашинам = 0 Тогда
            РезКоличество = Строка.Количество;
        КонецЕсли;
        ИсходноеКоличество = Строка.Количество;
        Строка.Количество = РезКоличество;
        Если Строка.Количество = 0 ИЛИ ИсходноеКоличество = 0 Тогда
        Иначе
            //Делим суммы пропорционально количеству
            Строка.Сумма = Строка.Сумма * Строка.Количество / ИсходноеКоличество;
            Строка.СуммаНДС = Строка.СуммаНДС * Строка.Количество / ИсходноеКоличество;
        КонецЕсли;

    КонецЦикла;
КонецФункции

Обратите внимание, как обработана замена номера, чтобы печатался номер машины через слэш.

Транзакционная печать в УТ10

В УТ10 мне понадобилась транзакционная печать в других целях. Заказчик поставил задачу заменять при печати наименование товара во всех торговых документах. Если бы это происходило всегда, можно было бы поменять полное наименование, но нужно было чтобы старые документы перепечатывались бы без изменения.

Соответственно, перед печатью документа нужно изменять наименование товара:

Функция НужнаТранзакционнаяПечать(Объект)Экспорт
    //Осипов 2016-03-24 Замена наименования... +++
    Если Объект.Дата >= '20160323' И НЕ Объект.Модифицированность() Тогда
        ТранзакцияОткрыта = ложь;
        ТекСсылка = Объект.Ссылка;
        Если ТипЗнч(ТекСсылка) = Тип("ДокументСсылка.СчетФактураВыданный")  Тогда
            ТекСсылка = ТекСсылка.ДокументОснование;
        КонецЕсли;      Если ТекСсылка.Метаданные().ТабличныеЧасти.Найти("Товары") <> Неопределено Тогда
            Маркер = "Палка "; ДлинаМаркера = СтрДлина(Маркер);
            НовыйМаркер = "Палка для коррекции ";
            ДлинаНовогоМаркера = СтрДлина(НовыйМаркер);
            Для Каждого ТекСтрока Из ТекСсылка.Товары Цикл
                ТекНаименование = ТекСтрока.Номенклатура.НаименованиеПолное;
                Если
                    Лев(ТекНаименование, ДлинаМаркера) = Маркер И
                    Лев(ТекНаименование, ДлинаНовогоМаркера) <> НовыйМаркер
                Тогда
                    Если НЕ ТранзакцияОткрыта Тогда
                        НачатьТранзакцию();
                        ТранзакцияОткрыта = истина;
                    КонецЕсли;
                    О = ТекСтрока.Номенклатура.ПолучитьОбъект();
                    О.НаименованиеПолное = СтрЗаменить(О.НаименованиеПолное, Маркер, НовыйМаркер);
                    О.ОбменДанными.Загрузка = истина;
                    О.Записать();;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
    КонецЕсли;
    //Осипов 2016-03-24 Замена наименования... --

    Возврат ТранзакцияОткрыта;
КонецФункции

Осталось выяснить, где вставить вызов этой процедуры.

Печать происходит методами Объект.Печать и НапечататьВнешнююФорму.

Эти методы вызываются в модуле УниверсальныеМеханизмы в двух  местах - в процедуре ОткрытьФормуВыбораПечатныхФормОбъекта и ПечатьПоДополнительнойКнопке. Да, программистам 1С не хватило ума вынести одинаковый код в отдельную функцию, мы наблюдаем обычный копи-паст.

Если ... Тогда
    ТабДокумент = НапечататьВнешнююФорму(Объект.Ссылка, Расшифровка);
    НапечататьДокумент(ТабДокумент,  ....);
Иначе
    Объект.Печать(...);
КонецЕсли;

В процедуре печати учтено, что объект может быть модифицирован, тогда он не печатается.

В случае ошибки может долго висеть предупреждение, и транзакция будет открыта, это недостатки решения, но такое бывает редко. В УФ отказались от модальности, такое не грозит.

Если бы не было условия даты документа, можно было использовать обработку макета перед печатью в функции НапечататьДокумент, она вызывается для всех документов. Но в эту функцию, к сожалению, не всегда передается ссылка. 

Транзакция сама откатывается, массовых печатей нет. Но даже если будет массовая печать, не страшно - замена пройдет нормально, дважды маркер меняться не будет.

Вот как вставлять вызов процедуры:

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. shard 271 18.10.17 13:16 Сейчас в теме
я в подобных ситуациях (когда требуется изменить результат запроса, текст которого очень не хочется ковырять) применяю врезку:
1) выгружаю результат типового запроса в таблицу
2) обрабатываю таблицу как необходимо
3) получившуюся таблицу передаю параметров в свой запрос, результат которого записываю в переменную выборки или результата типового запроса
Оставьте свое сообщение

См. также

Программные перечисления, ч.2: приемы кэширования при разработке Промо

Универсальные функции Механизмы платформы 1С Запросы Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    30735    unichkin    18    

Идентификатор объекта в запросе. Вы этого хотели?

Запросы Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Запросы Запросы Бесплатно (free) Бесплатно (free)

В платформе 8.3.22 появилась возможность получать идентификатор в запросе. Лично я ждал этого давно, но по итогу ждал большего. Что не так?

12.01.2023    4907    dsdred    13    

Маленькие хитрости большой платформы (часть 1)

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Ничего сверхсекретного, просто несколько полезных приёмов, как упростить себе жизнь и ускорить разработку: от банальных советов до неочевидных, на первый взгляд, приёмов.

29.12.2022    3293    zeltyr    25    

Практическая шпаргалка по новым возможностям языка запросов 1С

Механизмы платформы 1С Запросы Платформа 1С v8.3 Платформа 1С v8.3 Запросы Запросы Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

В предлагаемой статье решил привести примеры применения новых возможностей языка запросов 1С, начиная с версии платформы 8.3.20.

21.11.2022    13487    quazare    33    

Использование классов .Net в 1С для новичков Промо

Механизмы платформы 1С Платформа 1С v7.7 Платформа 1С v7.7 Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    90587    Serginio    116    

Асинхронное нечто, или так, как раньше!

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Все же знают, что раньше было лучше! Возврат к истокам и погружение в детали...

23.10.2022    4003    starik-2005    38    

Подготовка к экзамену "Специалист по платформе". Часть 1

Механизмы платформы 1С Подготовка к аттестации Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Нашел свои записки к подготовке к экзамену "Специалист по платформе", может кому пригодится :)

17.10.2022    1726    Drfreeman    1    

О цикле обратном замолвите слово...

Механизмы платформы 1С Языки и среды Платформа 1С v8.3 Платформа 1С v8.3 Платформа 1C v8.2 Платформа 1C v8.2 Бесплатно (free) Бесплатно (free)

Однажды, написав статью, расписывающую достоинства 1С, я упомянул среди недостатков - мне не хватает "обратного цикла". При этом, столкнулся с непониманием - "а зачем тебе обратный цикл". Сегодня я отвечу на этот вопрос.

08.09.2022    4377    DrAku1a    69    

1С и Unicode

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Разбираемся, как 1С работает с текстом и отдельными символами в контексте Unicode.

05.09.2022    2960    Irwin    30    

Шпаргалка по функциям АСИНХ

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Россия Россия Бесплатно (free) Бесплатно (free)

При знакомстве с новой механикой работы с асинхронностью (обещание, ждать и асинх) делал пометки, которыми и хочу поделиться. Ничего сверхъестественного в них нет, просто небольшие примеры и некоторые всплывшие нюансы использования.

29.07.2022    10028    zeltyr    16    

Вспомогательные инструкции в коде 1С Промо

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    39791    tormozit    107    

Экспертный кейс. История расследования одного небыстрого закрытия месяца в 1C:ERP. Пример неочевидных путей расследования в виде детективной истории

HighLoad оптимизация Механизмы платформы 1С Запросы Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Бесплатно (free) Бесплатно (free)

В данной статье хотим рассказать об одном нашем непростом расследовании, в котором удалось собрать сразу несколько проблем на разных уровнях инфраструктуры заказчика и изначальной методологии ведения учета. Само расследование в какой-то момент стало напоминать детективную историю, с роялями в кустах, ошибками платформы, странным поведением пользователей и магическим поведением хорошо знакомых механизмов. Но мы реалисты, поэтому все проблемы были выявлены и устранены ;)

11.07.2022    4998    it-expertise    27    

Состав индексов с дополнительным упорядочиванием на уровне СУБД (MS SQL) при индексации реквизитов

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

В момент обсуждения с коллегами работы индексов в 1С был затронут один из вопросов, который касался темы - каким образом происходит построение индексов при индексации реквизитов у объектов 1С (конкретнее, когда свойство реквизита "Индексировать" устанавливается в "Индексировать с доп. упорядочиванием"). Ранее я всегда опирался на знания, полученные в процессе чтения официальной документации от компании 1С, опубликованной на ITS. Наши мнения в этом вопросе разошлись и, как оказалось позже, мои знания не были актуальными, в итоге было проведено некоторое исследование по данному вопросу, чтобы выяснить истину.

15.06.2022    2325    sinichenko_alex    9    

Динамическое обновление - это зло?

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Копнем глубже в тему "Что же такое динамическое обновление" и почему оно может привести к проблемам. И может ли?

09.05.2022    15034    Infostart    77    

Как прикрутить ГУИД к регистру сведений Промо

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    24789    m-rv    18    

Об одной неочевидной проблеме перехода на версию платформы 8.3.20

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

При переходе на платформу 8.3.20 мы столкнулись с ошибкой "Повторяющийся псевдоним "Ссылка" Ссылка AS Ссылка,Presentation AS Presentation,Ссылка AS Ссылка" в ряде типовых конфигураций. Причём, эта проблема оказались неизвестна ни Яндексу, ни Гуглу. Путём мучительных экспериментов нам удалось найти решение. Пока я ещё не уверен, действительно это решение или обходной костыль, а настоящая проблема -- в чём-то другом, но это решение работает в ситуации, когда всё сломалось, а проблему надо решать срочно. Предположительная причина: платформа 8.3.20 более строго относится к типизации данных в запросах, чем предыдущие версии, вываливая в случае несоблюдения новшеств малопонятные ошибки.

08.04.2022    5900    Kernelbug    26    

Отборы динамического списка

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Динамический список предоставляет несколько объектов "Отбор". В статье разбирается, какой для чего нужен и как их использовать на форме. Рассматриваются только возможности платформы (без БСП).

28.03.2022    17988    Gladkov_Anton    5    

Фишки платформы 1С 8.3 для начинающего разработчика

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Бесплатно (free) Бесплатно (free)

В данной заметке рассмотрены вспомогательные инструменты платформы, которыми часто пренебрегают начинающие программисты 1С.

11.03.2022    9961    Dimbayyyy    98    

Метод формирования движений в типовых регистрах нетиповыми регистраторами Промо

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    31978    itriot11    34    

Экспертный кейс. Расследование деградации производительности системы. Проведение документа “Поступление товаров и услуг” (1С:ERP 2)

Механизмы платформы 1С Запросы HighLoad оптимизация Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 Бесплатно (free) Бесплатно (free)

В ходе проведения нагрузочного тестирования одним из наших клиентов была выявлена сильная деградация производительности системы в целом и, в частности, выполнения ключевой операции “Проведение документа поступление товаров и услуг” в течение выполнения теста. Согласно данным подсистемы БСП “Оценка производительности”, время выполнения ключевой операции “Проведение документа поступление товаров и услуг” возрастало в процессе тестирования с 15-20 секунд в начале тестирования до 150-200 секунд в его финале.

02.03.2022    3778    it-expertise    48    

Модульная архитектура или пара слов о расширениях. Часть I (мысли, рассуждения)

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Статья-размышление о том, какое может быть применение технологии расширений 1С и зачем нам, разработчикам/программистам на 1С, знать общепринятые паттерны проектирования приложений. Итак, а что если я вам скажу, что технология расширений 1С - это одно из прекрасных новшеств компании 1С? Пусть эта статья будет хвалебной одой расширениям 1С.

14.02.2022    5985    amon_ra    67    

Синхронный и асинхронный вызов в новых версиях платформы

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Начиная с платформы 8.3.18.1128 переработана технология работы с асинхронными вызовами. В данной статье хочу описать новые асинхронные вызовы и сравнить их с предыдущими на примере функции - Вопрос на клиенте.

31.01.2022    5938    Shining_ninja    17    

Ускоряем 1С: модули с повторным использованием возвращаемых значений Промо

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    63679    m-rv    64    

Несколько простых приемов для удобной работы в конфигураторе

Универсальные функции Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Простая и удобная среда разработки 1С:Предприятия позволяет практически любому человеку начать работать под капотом 1С - в конфигураторе. Время идет, новички становятся программистами, специалистами, а об удобных приемах работы узнают годами, по ходу своего карьерного пути. А здорово было бы, если бы все знали удобные приемы в начале своего пути? Эти несколько приемов будут полезны новичкам, так как они затрагивают ту область работы, с которой приходится сталкиваться в начале карьеры.

12.11.2021    11411    acces969    95    

Как спроектировать структуру регистра сведений

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Запросы Запросы Бесплатно (free) Бесплатно (free)

«Что может быть проще?» — это первое, что приходит в голову. Но что, если это не так? В этой статье мы попробуем затронуть некоторые вопросы, которые могут возникнуть при проектировании больших регистров.

08.11.2021    8194    Neti    60    

О вложенных попытках, исключениях и о представлении ошибок

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

В данной статье, на небольшом примере, мне бы хотелось показать, как себя ведут вложенные "Попытка-Исключение". А также о том, чем отличаются методы ОписаниеОшибки() и ИнформацияОбОшибке().

07.11.2021    9962    Nicholas    22    

Регулярные выражения без внешних компонент? Легко! Промо

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Сложный способ организовать проверку строки с помощью регулярного выражения в 1С. При этом ни одна внешняя компонента не пострадала. Ну и от платформы (Linux, MustDie) - не зависит.

04.03.2016    78949    starik-2005    111    

Обработчик ожидания. Нюансы

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

ПодключитьОбработчикОжидания: некоторые подробности и особенности работы

24.08.2021    21758    Yashazz    25    

Прогресс-бар в поле динамического списка

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Изображаем прогресс-бары в колонке динамического списка

23.08.2021    4286    Yashazz    13    

ПриПолученииДанныхНаСервере + Контекст формы. Лайфхак

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Передать свои произвольные данные в событие, которое "без контекста"? Легко!

13.08.2021    6575    Yashazz    16    

Методика переопределения и вызова обработчиков событий обычной формы Промо

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Россия Россия Бесплатно (free) Бесплатно (free)

Каждый из нас хотя бы раз задумывался над тем, как было бы удобно, если бы мы могли переопределять обработчики событий формы, сохраняя возможность вызова старого обработчика независимо от его имени. В этой статье изложен метод, который позволяет реализовать эту возможность.

24.06.2007    91873    tormozit    31    

Новичок новичку: как добавить программно кнопку на форму путем расширения

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Россия Россия Бесплатно (free) Бесплатно (free)

Рассказываю очень простым языком, как добавить программно кнопку в типовую конфигурацию. Сам новичок в этом деле и рассказываю на "новичковом" языке.

13.05.2021    34770    user1312100    26    

Программное создание расширения

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Создание нового расширения "на лету", только штатными средствами 1С.

06.04.2021    6564    Yashazz    15    

Отладка подключаемых обработок Промо

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

На самом деле для этого не нужно ни изменять конфигурацию, ни пользоваться вспомогательной обработкой-отладчиком.. Все просто :)

04.01.2017    89101    unichkin    120    

Советы из Желтой тетради 📒 #1

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

В этой публикации я собрал в одном месте часть советов и лайфхаков, которые открыл для себя в последнее время. Регулярно я публикую их в своём телеграм-блоге "Жёлтая тетрадь 📒 Блог программиста 1С", здесь же - дайджест этих публикаций.

15.03.2021    6217    builin    120    

Расширенный автоподбор при вводе по строке в поле ввода в управляемых формах

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Началось все с того, что штатный автоподбор при вводе по строке в поле ввода для некоторых больших справочников устраивать перестал. Вообще, для способа поиска строки "Любая часть" он работает на первый взгляд очень хорошо: работает как полнотекстовый (т.е. по нескольким словам) даже без активации полнотекстового поиска, красиво подсвечивает слова поиска в результатах. Казалось бы, все отлично. Но есть неприятное ограничение - всего лишь 10 значений в результирующем списке (у вас может быть несколько больше, так как платформа неявно добавляет результаты поиска по истории ввода). Для небольших справочников или справочников с разнородным ассортиментом все хорошо. Но не в моей ситуации. А простых путей увеличить количество выдаваемых строк на момент написания статьи мне обнаружить не удалось. Пришлось полностью переопределять автоподбор. Ниже речь пойдет именно об этом. И, к слову, в типовых конфигурациях для некоторых справочников используются похожие приемы для увеличения количества строк результата автоподбора.

21.01.2021    9401    herfis    9    

Недокументированное использование стандартных обработок из меню "Все функции". Промо

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Рассмотрены возможности произвольного использования стандартных функций, вызываемых из меню платформы "Все функции" - "Стандартные" (Активные пользователи, Журнал регистрации, Поиск ссылок на объект, Проведение документов ...).

19.06.2015    127994    ekaruk    143    

О формах 1С замолвите слово... Необычное использование знакомого всем объекта

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Неочевидно, но форму 1С можно использовать как универсальный объект, который доступен на клиенте и имеет уникальный набор свойств, методов, событий и конструктор, принимающий параметры. При этом у формы может не быть интерфейса, и ее можно даже не открывать. О реальных примерах применения такого подхода пойдет рассказ.

13.01.2021    10179    CyberCerber    46    

Наследование свойств элементов, или Как пользователь может сломать вашу форму

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Платформа 1C v8.2 Платформа 1C v8.2 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

В 1С можно установить свойства ТолькоПросмотр, Доступность и Видимость не только на элементы формы, но и на группы элементов. Но стоит ли так делать? Оказывается, пользователь может обойти запреты, которые установлены на папку. Об этом подробнее в видео.

12.01.2021    6145    SeiOkami    27    

Ускоряем медленный/долгий и тормозной стандартный поиск по динамическому списку, настраиваем его под себя

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Пользователи привыкли искать на форме списка, но, вбивая в поиск некорректные данные, могут завесить всю систему, а если еще искать нужно по НЕ полям списка, то решение только в своём поиске - все это решим в публикации с открытым кодом.

14.12.2020    38133    SizovE    2    

Простая и быстрая эмуляция операций с битовыми строками Промо

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Битовые строки могли бы упростить реализацию некоторых алгоритмов на языке платформы «1С: Предприятие 8». Но пока в платформе операций с битовыми строками нет. В то же время уже сделанные попытки смоделировать эти операции преобразованиями над числами опираются на циклы обработки отдельных битов, что плохо сказывается на скорости их работы. Предлагается новое простое решение, основанное на представлении битовых строк строками символов «0» и «1». Приводится примеры кода выполнения основных логических операций AND, OR, XOR, NO без использования циклов. В качестве прикладной задачи рассмотрено получение последовательных значений кода Грэя, который можно использовать для ускорения перебора вариантов.

22.06.2016    31201    ildarovich    14    

Передача параметров по значению в языке 1С

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 ИТ-компания ИТ-компания Бесплатно (free) Бесплатно (free)

Все мы знаем, что в 1С можно написать такое: Процедура ОбработатьОбъект(Знач Объект) КонецПроцедуры Т.е. тем самым мы передаем в процедуру параметр по значению Далее в статье будут рассмотрены некоторые особенности передачи по значению объектов НЕпримитивных типов.

26.11.2020    5742    direktorSan    9    

Установка отбора для поля ввода управляемой формы через ПараметрыВыбора (без переопределения событий "НачалоВыбора", "Автоподбор")

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Управляемые формы Управляемые формы Бесплатно (free) Бесплатно (free)

Зачастую возникает необходимость ограничить вывод элементов какого-нибудь справочника или перечисления при редактировании поля ввода (отфильтровать доступные для выбора элементы) эта публикация показывает простой и эффективный способ реализации этого.

15.11.2020    15049    Eugen-S    11    

Групповое изменение реквизитов объектов расширений

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Комплексная автоматизация 2.х Бесплатно (free) Бесплатно (free)

Доработка встроенной обработки "Групповое изменение реквизитов" для возможности изменения ссылочных реквизитов с ссылками на объекты расширения. Работает в Комплексной конфигурации 2.4.

07.11.2020    2962    Alfn    14    

Расширения конфигурации. Полезные советы для разработки Промо

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Полезные советы для разработки и применения расширений. Как подключить отладку, как сохранять данные, последовательность обработчиков, использование модуля менеджера и другое.

12.01.2016    373425    mrXoxot    209    

Лайфхаки для разработчиков 1С. Часть 1

Универсальные функции Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Россия Россия Бесплатно (free) Бесплатно (free)

Собрали 20 лайфхаков, которые используют наши программисты при работе с 1С. Формы, контрагенты, СКД, процедуры, глюки платформы и многое другое. В этой статье публикуем первую часть.

30.09.2020    9116    Neti    47    

Контекст любого объекта конструкцией #Если Фамилия Тогда

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Делаем инициализацию переменной в "своей" инструкции препроцессора, для получения контекстной подсказки объекта через точку. В дальнейшем в компилированном коде сама инициализация игнорируется, т.к. "своя" инструкция препроцессора НИКОГДА не выполняется.

17.08.2020    3409    sapervodichka    36    

Новое отображение ошибок в 1С

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv8 Бесплатно (free) Бесплатно (free)

Рассмотрим развитие механизма отображения ошибок в 1С (начиная с 8.3.17)

10.08.2020    35325    SeiOkami    45    

Динамический список, ключи записей. Нюансы

Механизмы платформы 1С Платформа 1С v8.3 Платформа 1С v8.3 Бесплатно (free) Бесплатно (free)

Заметки об особенностях динамических списков с произвольным запросом и видом ключа, отличным от "Авто"

07.08.2020    10459    Yashazz    6