Еще об ошибках в новых налоговых накладных конфигурации "Бухгалтерский учет для Украины" (релиз 280)

21.01.11

Задачи пользователя - Адаптация типовых решений

Ошибки и недоработки в налоговой накладной и приложении 2 (релиз 280)

Новые налоговые 1С точно сделала тяп-ляп. Просто чтобы отвязались. Похоже, что команды разработчиков даже держали в руках различные постановления. Так, в печатных формах для 8-ки даты сделаны сплошными клетками (т.е. 15012011), а в 7.7 с точками (15.01.2011). И как правильно?.. Правда у меня уже бухгалтера хотели дату без точек.

UPD. Исправленные печатные формы выложил тут.

Налоговая накладная. Почему-то не сделан выбор вида договора. В 8-ке он есть, а в 7.7 будьте добры писать ручками. Бухам это дело не понравилось, и они потребовали прекратить ущемление прав и свобод по платформенному признаку. Чтобы сделать выбор вида договора из списка:

1) на форме налоговой в слое "дополнительный" убираем поле "ВидДоговора" и на его место устанавливаем "Поле со списком" (аналогичное имеющемуся полю "спТипПричины" только покороче : )).

Свойства: идентификатор - 'спВидДоговора'; формула - 'ИзмВидДоговора()' (см. скриншот)

В тексте модуля формы:

1) перед процедурой "ПриОткрытии" вставляем две новых:

 

// ===============================
Процедура ИзмВидДоговора()
    Инд = спВидДоговора.ТекущаяСтрока();
    Если Инд <> 0 Тогда
        ТекВидДоговора = спВидДоговора.ПолучитьЗначение(Инд);
        Если ТекВидДоговора <> ВидДоговора Тогда
            ВидДоговора = ТекВидДоговора;
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры

// ===============================
Процедура ЗаполнитьВидДоговора()
    спВидДоговора.УдалитьВсе();
    спВидДоговора.ДобавитьЗначение("Договір поставки");
    спВидДоговора.ДобавитьЗначение("Договір купівлі-продажу");
    спВидДоговора.ДобавитьЗначение("Договір комісії");
    спВидДоговора.ДобавитьЗначение("Договір бартерної поставки");
    спВидДоговора.ДобавитьЗначение("Договір консигнації");
    спВидДоговора.ДобавитьЗначение("Договір поруки");
    спВидДоговора.ДобавитьЗначение("Договір доручення");
    спВидДоговора.ДобавитьЗначение("Договір довірчого управління");
    спВидДоговора.ДобавитьЗначение("Договір відповідального зберігання");
    спВидДоговора.ДобавитьЗначение("Договір складського зберігання");
    спВидДоговора.ДобавитьЗначение("Договір про надання посередницьких послуг");
    спВидДоговора.ДобавитьЗначение("Договір про виконання роботи");
    спВидДоговора.ДобавитьЗначение("Договір про надання послуг");
    спВидДоговора.ДобавитьЗначение("Договір про інформаційно-довідкове обслуговування");
    спВидДоговора.ДобавитьЗначение("Договір поставки оптової партії");
    // если ВидДоговора есть в новом списке - спозиционируемся на него
    Инд = спВидДоговора.НайтиЗначение(СокрЛП(ВидДоговора));
    Если Инд = 0 Тогда
        // нет такого в списке
        спВидДоговора.ТекущаяСтрока(1);
        ВидДоговора = спВидДоговора.ПолучитьЗначение(1);
    Иначе
        спВидДоговора.ТекущаяСтрока(Инд);
    КонецЕсли;

КонецПроцедуры



2) в процедуре "ПриОткрытии" добавляем вызов  процедуры 'ЗаполнитьВидДоговора()'.

Например перед или после вызова 'ЗаполнитьТипыПричин()'.

 

Приложение 2. Даже когда у себя документы не оставляем печатает в шапке причину 02.

Для исправления в модуле формы правим процедуру печати.

Процедура 'Печать2011'. Строку 156 нужно взять в условие. Изначально часть процедуры выглядит так:

   

Для Страница = 1 По 2 Цикл
        Таб.ВывестиСекцию( "Пустота" );
        Если Страница = 1 Тогда
            Оригинал = ?(НалоговаяНакладная.Оставляем = 1, "","Х");;
            Копия = "";
            ЕРПН = ?(ЕРНН = 1, "Х","");
            ОстаетсяПеч = ?(НалоговаяНакладная.Оставляем = 1, "Х","");
            ТипПричиныПеч = Сред(НалоговаяНакладная.ТипПричины,2,2);
        ИначеЕсли Страница = 2 Тогда
            Копия = "Х";
            Оригинал = "";
            ТипПричиныПеч = "";
            ЕРПН = "";
            ОстаетсяПеч = "";
        КонецЕсли;



 

После исправления:

   

Для Страница = 1 По 2 Цикл
        Таб.ВывестиСекцию( "Пустота" );
        Если Страница = 1 Тогда
            Оригинал = ?(НалоговаяНакладная.Оставляем = 1, "","Х");;
            Копия = "";
            ЕРПН = ?(ЕРНН = 1, "Х","");
            ОстаетсяПеч = ?(НалоговаяНакладная.Оставляем = 1, "Х","");
            Если НалоговаяНакладная.Оставляем = 1 Тогда
                ТипПричиныПеч = Сред(НалоговаяНакладная.ТипПричины,2,2);
            КонецЕсли;
        ИначеЕсли Страница = 2 Тогда
            Копия = "Х";
            Оригинал = "";
            ТипПричиныПеч = "";
            ЕРПН = "";
            ОстаетсяПеч = "";
        КонецЕсли;



 

Если публикация оказалась вам полезной - не забудьте вернуться и поставить плюсик.

 

См. также

Улучшенная обработка "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7

Печатные формы Адаптация типовых решений Программист Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Приятное улучшение обработки "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7 для более комфортной работы с "любимой семерочкой".

1 стартмани

04.02.2022    3236    1    igor7777    0    

3

Расчет страховых взносов в 1С 7.7 "Учет и отчетность предпринимателя, ред. 1.2" с апреля 2020

Адаптация типовых решений Программист Платформа 1С v7.7 Конфигурации 1cv7 Россия Бухгалтерский учет ФОМС, ЕФС Бесплатно (free)

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

09.04.2020    20024    Юджин58    39    

5

Дистрибьюция 7.7. Часть 1. Жизненный цикл заявки покупателя. Одна заявка покупателя, много адресов доставки.

Адаптация типовых решений Программист Платформа 1С v7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Управленческий учет Бесплатно (free)

Описан способ работы с учетом расписания с приоритетными покупателями - торговыми сетями (основными покупателями) в торговой или комплексной учетной системе на 1С 7.7. Множественная заявка покупателя на несколько торговых точек.

14.10.2019    6097    ksnik    14    

3

Как в торговле 7.7 печатать код ТНВЭД в счет-фактуре

Операции по ВЭД Адаптация типовых решений Программист Оперативный учет 7.7 1С:Торговля и склад 7.7 Россия Бухгалтерский учет НДС Бесплатно (free)

В данной статье хотел поделиться опытом, как в Торговле 7.7 ( релиз 994) сделать возможность выводить код ТНВЭД в печатную форму счета-фактуры. Сразу скажу, что нужно это только тем, кто осуществляет экспорт в страны таможенного союза. Остальные могут не волноваться.

15.11.2017    11872    AndKovalchuk    0    

1

Предельные базы взносов в ПФР, ФСС, ФФОМС 2015 в 1С: Бухгалтерия 7.7

Зарплата Адаптация типовых решений Программист Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Реализация Постановления Правительства РФ 1316 от 04.12.14 для типовой конфигурации "Бухгалтерский учет 7.7" рел. 7.70.590

1 стартмани

31.12.2014    23976    9    Sergey1CSpb    2    

0
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. kompas-dm 781 21.01.11 15:29 Сейчас в теме
(0) В 7.7. : Можно, конечно, но эти ляпы не фатальны. Добьют и ручками. Релиз 280 промежуточный. Думаю, исправят.
А что делать, у кого нет 1С-ника :?:
2. babylon_5 55 21.01.11 15:45 Сейчас в теме
(1) Ну, например, то же что делают мои клиенты. Обращаться к внешнему 1С-нику. :D
А релиз... исправят, конечно. Только людям работать нужно сейчас, а не тогда когда исправят ляпы и ошибки.
3. yw_prog 27.01.11 10:23 Сейчас в теме
Не могу скачать печатную форму :(
4. xxl-30 27.01.11 13:29 Сейчас в теме
неправильно убирать с формы документа поле ВидДоговора, а если захочется вписать что-то другое?
коректнее поставить у поля в свойстве галку "Имеет кнопку выбора" в процедуру
Процедура ПриНачалеВыбораЗначения(Рекв,ФлагСтандОбр)
вставить условие

		ИначеЕсли  Рекв = "ВидДоговора" Тогда
		ВыбратьВидДоговора();  
		ФлагСтандОбр = 0;	

добавить процедуру
Процедура ВыбратьВидДоговора()
	Перем Выб;
	спВидДоговора = СоздатьОбъект("СписокЗначений");
    спВидДоговора.ДобавитьЗначение("Договір поставки");
    спВидДоговора.ДобавитьЗначение("Договір купівлі-продажу");
    спВидДоговора.ДобавитьЗначение("Договір комісії");
    спВидДоговора.ДобавитьЗначение("Договір бартерної поставки");
    спВидДоговора.ДобавитьЗначение("Договір консигнації");
    спВидДоговора.ДобавитьЗначение("Договір поруки");
    спВидДоговора.ДобавитьЗначение("Договір доручення");
    спВидДоговора.ДобавитьЗначение("Договір довірчого управління");
    спВидДоговора.ДобавитьЗначение("Договір відповідального зберігання");
    спВидДоговора.ДобавитьЗначение("Договір складського зберігання");
    спВидДоговора.ДобавитьЗначение("Договір про надання посередницьких послуг");
    спВидДоговора.ДобавитьЗначение("Договір про виконання роботи");
    спВидДоговора.ДобавитьЗначение("Договір про надання послуг");
    спВидДоговора.ДобавитьЗначение("Договір про інформаційно-довідкове обслуговування");
    спВидДоговора.ДобавитьЗначение("Договір поставки оптової партії");

	Выб = ВидДоговора; 
	Если спВидДоговора.ВыбратьЗначение(Выб,,,,2) = 1 Тогда
		ВидДоговора = Выб;
	КонецЕсли;
КонецПроцедуры
Показать


ещо для полного счастья необходимо обработать телефон убрав скобки пробелы тире
Функция ФорматироватьТелефон(Телефон)   
	Телефон = СокрЛП(Телефон); 
	НовТелефон = "";
	Для а = 1 по СтрДлина(Телефон) Цикл 
		ТекСимвол = Сред(Телефон,а,1);  
		Если Найти(",;", ТекСимвол) > 0 Тогда  
			//это разделитель номеров, дальше не ищем
			Прервать;
		ИначеЕсли (КодСимв("0") <= КодСимв(ТекСимвол)) и (КодСимв(ТекСимвол) <= КодСимв("9")) Тогда
			//это цифра
			НовТелефон=НовТелефон + ТекСимвол;    
		КонецЕсли;
	КонецЦикла;
	Возврат НовТелефон;
КонецФункции
Показать
Оставьте свое сообщение