Подключение к REST API через OAuth протокол из 1С

29.02.20

Интеграция - WEB-интеграция

В статье описаны варианты подключения И решение граблей по подключению к REST API через протокол OAuth 2.0 из 1С. При разработке такого подключения для получения данных и загрузки в базу 1С я столкнулся с некоторыми проблемами, решил их и хочу поделиться этими наработками.

Скачать исходный код

Наименование Файл Версия Размер
Подключение к REST API через OAuth протокол из 1С:
.epf 16,91Kb
55
.epf 1.0 16,91Kb 55 Скачать

Введение

Задача: подключение к REST API по протоколу Oauth 2.0 и получение данных от API для дальнейшего парсинга и загрузки в БД.

Решение состоит из:
* Получение токена авторизации;
* Получение данных с использованием токена авторизации.

Получение токена авторизации

Получение токена авторизации выполняется при помощи POST запроса XTTP, при этом есть нюансы реализации этого запроса для x32 и x64 разрядных версий сервера 1С, а также особенности при работе этого запроса в веб клиенте.

XTTP запрос для получения токена OAuth выглядит следующим образом:

 
&НаКлиенте
Функция XTTPЗапросАвторизации()
	
	XTTPЗапрос = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
    Скрипт = Новый COMОбъект("MSScriptControl.ScriptControl");
    Скрипт.language = "javascript";
    Скрипт.AddObject("XTTPЗапрос", XTTPЗапрос);
    Скрипт.Eval("XTTPЗапрос.Option(4)=13056");
    
    XTTPЗапрос.Open("Post", "https://ваш_url/connect/token", 0);
    XTTPЗапрос.setRequestHeader("Content-Type", "application/x-www-form-urlencoded");
    
    ПараметрыPOST = "client_id=ваш_client_id" + "&";
    ПараметрыPOST = ПараметрыPOST + "grant_type=ваш_grant_type" + "&";
    ПараметрыPOST = ПараметрыPOST + "username=" + Логин + "&";
    ПараметрыPOST = ПараметрыPOST + "password=" + Пароль + "&";
    ПараметрыPOST = ПараметрыPOST + "redirect_uri=https://ваш_redirect_uri/callback";
	
    XTTPЗапрос.send(ПараметрыPOST);
	
	Возврат XTTPЗапрос;
	
КонецФункции

&НаКлиенте
Процедура Войти(Команда)
	
	Ответ = XTTPЗапросАвторизации();
    Если Ответ.Status = 200 Тогда
		СтрокаОтвета = Ответ.ResponseText;
	
		РезультатЧтения = ДесериализироватьJSONОтвет(СтрокаОтвета);
		Токен = РезультатЧтения.token; 
	КонецЕсли;

КонецПроцедуры

&НаСервереБезКонтекста
Функция ДесериализироватьJSONОтвет(СтрокаОтвета)
	
	ОтветJSON	= Новый ЧтениеJSON;
	ОтветJSON.УстановитьСтроку(СтрокаОтвета);

	РезультатЧтения	= ПрочитатьJSON(ОтветJSON);
	
	ОтветJSON.Закрыть();

	Возврат РезультатЧтения;

КонецФункции

 

Проблемы при работе с POST XTTP подключением авторизации

1. Ошибка при получении токена на x64 разрядном сервере 1С.

Можно столкнуться с проблемой, когда у клиента 1С в развернута в платном облачном сервисе, где возможности изменить параметры сервера или зарегистрировать дополнительные dll нет возможности, либо запрещено выполнять JavaScript, который в нашем коде создается в строке COMОбъект("MSScriptControl.ScriptControl").

То есть, если подключение XTTP описано на сервере, например в модуле объекта обработки и при этом сервер 1С x64 разрядный, то можно получить следующую ошибку: 

{ВнешняяОбработка.ЗагрузкаЧеков.МодульОбъекта(336)}: Ошибка при вызове конструктора (COMОбъект): -2147221164(0x80040154): Class not registered.

2. Ошибка при получении токена при помощи объекта "WinHttp.WinHttpRequest.5.1" на клиенте при работе в веб клиенте 1С.

Если XTTP подключение описано на клиенте в форме обработки, то при выполнении этого кода в браузере Chrome, можно получить следующую ошибку: 

{ВнешняяОбработка.ЗагрузкаЧеков.Форма.ФормаНастроек.Форма(187)}: Тип не определен (COMObject).

Ошибка связана с особенностями запуска ActiveX объектов в браузерах. В Internet explorer текст ошибки может отличаться.

Решение ошибок 

Для решения проблемы с исполнением кода на x64 разрядном сервере нужно перенести код подключения на клиент в форму обработки, так как это представлено в примере кода выше. Но при этом получается что в браузере это решение всё ещё работать не будет. Потому что браузер с нужным нам COM объектом работать не может и углубляться в причины этой проблемы будет просто потерей времени. Гораздо более быстрым решением станет реализация этого запроса при помощи JavaScript помещенного в элемент формы с видом ПолеHTMLдокумента.

Решение получения токена в веб клиенте

Есть различные варианты реализации подхода через ПолеHTMLДокумента. Например можно сделать кнопку "Войти" на форме и по этой кнопке вызывать скрипт описанный в HTML документе, а можно сверстать HTML, поместить его в ПолеHTMLДокумента, то есть кнопка "Войти" будет элементом HTML страницы. Я реализовывал второй вариант.

 
&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
// Для веб клиента отключаем элементы формы для подключения через запрос XTTP описанный выше, для не веб клиента соответственно наоборот.
	#Если ВебКлиент Тогда
		ЗаполнитьHTML();
		Элементы.ГруппаНастройкиСоединенияCOM.Видимость = Ложь;
// ГруппаНастройкиСоединенияCOM - содержит поля "Логин", "Пароль", и кнопку "Войти".
	#Иначе
		Элементы.ГруппаНастройкиСоединенияHTML.Видимость = Ложь;
// ГруппаНастройкиСоединенияHTML - содержит строковый реквизит Авторизация, который на форме имеет вид ПолеHTMLДокумента
	#КонецЕсли

КонецПроцедуры

&НаКлиенте
Процедура ЗаполнитьHTML()
	
	JavaScript = ПолучитьСкриптАвторизации();

	ТекстХТМЛ = 
	#Область HTMLДокумент
	"<html>
	|<head>
	|    <meta charset=""UTF-8"">
	|    <title>Авторизация</title>
	|</head>
	|<body>
	|    <form>
	|        <table>
	|            <tr>
	|                <td><label for=""loginField"">Логин</label></td>
	|                <td><input id=""loginField"" type=""text"" name=""login""></td>
	|            </tr>
	|            <tr>
	|                <td><label for=""passwordField"">Пароль</label></td>
	|                <td><input id=""passwordField"" type=""password"" name=""password""></td>
	|            </tr>
	|            <tr>
	|                <td colspan=""2"" style=""text-align: center"">
	|                    <input type=""button"" onClick=""authorize()"" value=""Войти"">
	|                </td>
	|            </tr>
	|        </table>
	|    </form>
	|	 <div id=""result"" style=""display:none""></div><div id=""status"" style=""display:none""></div>
	|	 <div id=""showMessage""></div>
	|</body>" + JavaScript + "
	|</html>";
	#КонецОбласти
	
	Авторизация = ТекстХТМЛ;

КонецПроцедуры

&НаКлиенте
Функция ПолучитьСкриптАвторизации()
	
	JavaScriptChrome = 
	#Область JavaScript
	"<script>
	|	window.onload
	|	{
// Если у нас отдельная форма настроек, то при первом открытии этой формы можно "запомнить"
//  значения логина и пароля, а при повторном открытии эти сохраненные данные заполнить в соответствующие поля в HTML.
	|	    var username = document.getElementById(""loginField"");
	|	    username.value = ""%1"";
	|	    var password = document.getElementById(""passwordField"");
	|	    password.value = ""%2"";
	|	}	
// Выполняем запрос к API и полученные данные помещаем в div result.
// А также вызываем функцию showMessage в которой выводим в форму сообщение 
//  о положительном или отрицательном результате выполнения запроса.
	|    function authorize() {
	|        var username = document.getElementById(""loginField"");
	|        var password = document.getElementById(""passwordField"");
	|        var details = {
	|            'client_id': 'ваш_client_id',
	|            'grant_type': 'ваш_grant_type',
	|            'username': username.value,
	|            'password': password.value,
	|            'redirect_uri': 'https://ваш_redirect_uri.com/callback'
	|        };
	|        var formBody = [];
	|        for (var property in details) {
	|            var encodedKey = encodeURIComponent(property);
	|            var encodedValue = encodeURIComponent(details[property]);
	|            formBody.push(encodedKey + ""="" + encodedValue);
	|        }
	|        formBody = formBody.join(""&"");
	|        fetch('https://ваш_url/connect/token', {
	|            method: 'POST',
	|            headers: {
	|                'Content-Type': 'application/x-www-form-urlencoded;charset=UTF-8'
	|            },
	|            body: formBody
	|        }).then(function(response) {
	|    		var status = document.getElementById(""status"");
	|  	  		status.innerHTML = response.status;
	|    		showMessage(response.status);
	|    		return response.json();
	|		}).then(function(answer) {
	|    		var result = document.getElementById(""result"");
	|  		  	result.innerHTML = answer.token;
	|		});
	|    }
	|	function showMessage(statusCode){
	|    	var showMessage = document.getElementById(""showMessage"");
	|    	if(statusCode == ""200"") {
	|        showMessage.innerHTML = ""Подключение выполнено, можно загружать данные."";
	|    	} else {
	|        showMessage.innerHTML = ""Подключение не выполнено, проверьте данные авторизации. Код ответа: "" + statusCode;
	|    	}
	|	}	
	|</script>";
	#КонецОбласти
	
// У Internet Explorer есть ограничения по использованию некоторых методов. 
// Поэтому лучше использовать древние проверенные методы.
	JavaScriptIE = 
	#Область JavaScript
	"<script>
// Аналогично сначала заполняем пароль и логин, если мы повторно открываем форму настроек.
	|	window.onload
	|	{
	|	    var username = document.getElementById(""loginField"");
	|	    username.value = ""%1"";
	|	    var password = document.getElementById(""passwordField"");
	|	    password.value = ""%2"";
	|	}	
// Выполняем запрос получения токена от API.
	|	function authorize() {
	|    	var username = document.getElementById(""loginField"");
	|    	var password = document.getElementById(""passwordField"");
	|		if (window.XMLHttpRequest) {
	|    		xmlhttp = new XMLHttpRequest();
	|		} else {
	|    		xmlhttp = new ActiveXObject(""Microsoft.XMLHTTP"");
	|		}
// Т.к. в 1С встроена 7я версия IE, рекомендую не писать циклов по конкатенации списка параметров, а просто описать их одной строкой,
//  иначе встроенный браузер может ругаться на ошибки скрипта.
	|		var data = ""password=""+password.value+""&username=""+username.value+""&grant_type=ваш_grant_type&client_id=ваш_client_id"";
	|		var xhr = xmlhttp;
	|		xhr.addEventListener(""readystatechange"", function () {
	|    		if (xhr.readyState == 4 && xhr.status == 200) {
	|        		var obj = JSON.parse(xhr.responseText);
	|        		result.innerHTML = obj.token;
	|        		status.innerHTML = xhr.status;
	|				showMessage(xhr.status);				
	|    		}
	|   		if (xhr.readyState == 4 && xhr.status != 200) {
	|        		status.innerHTML = xhr.status;
	|    		}
	|		});
	|		xhr.open(""POST"", ""https://ваш_url/connect/token"");
	|		xhr.setRequestHeader(""Content-Type"", ""application/x-www-form-urlencoded"");
	|		xhr.send(data);	
	|   }
	|	function showMessage(statusCode){
	|    	var showMessage = document.getElementById(""showMessage"");
	|    	if(statusCode == ""200"") {
	|        	showMessage.innerHTML = ""Подключение выполнено, можно загружать данные."";
	|    	} else {
	|        	showMessage.innerHTML = ""Подключение не выполнено, проверьте данные авторизации. Код ответа: "" + statusCode;
	|    	}
	|	}	
	|</script>";
	#КонецОбласти
	
	ТекущийБраузер = ОпределитьБраузер();
	
// Определяем браузер и используем подходящий нам скрипт.
	Если ТекущийБраузер = "IE" Тогда
		JavaScript = JavaScriptIE;
	Иначе
// Данный скрипт так же работает и в Firefox, на остальных браузерах не тестировал, т.к. посчитал это нецелесообразным 
//  и в случае необходимости за доп. время буду дорабатывать по требованию клиента
		JavaScript = JavaScriptChrome;
	КонецЕсли;
	
	JavaScript = СтрШаблон(JavaScript, Логин, Пароль);

	Возврат JavaScript;
	
КонецФункции

&НаКлиенте
Функция ОпределитьБраузер()
	
	СистемнаяИнформация = Новый СистемнаяИнформация; 
	ТекущаяСистема = СистемнаяИнформация.ИнформацияПрограммыПросмотра;
	
	Если ПустаяСтрока(ТекущаяСистема) Тогда
		Возврат "ТонкийКлиент";
	ИначеЕсли СтрНайти(ВРег(ТекущаяСистема), "CHROME") Тогда
		Возврат "Chrome";
	ИначеЕсли СтрНайти(ВРег(ТекущаяСистема), "FIREFOX") Тогда 
		Возврат "Firefox";
	Иначе
		Возврат "IE";
	КонецЕсли;
	
КонецФункции

Токен получен. Соответственно токен нужно положить в какой-нибудь реквизит, либо передать токен в основную форму обработки, если форму авторизации вы сделали как отдельную форму настройки.

Получение данных из API с использованием токена авторизации

Для получения данных с использованием токена нужно описать XTTP запрос, но уже GET. Аналогично получению токена, реализация для веб клиента и тонкого клиента будут различаться. Для веб клиента это HTML+JavaScript, для тонкого клиента это XTTP с использованием COM "WinHttp.WinHttpRequest.5.1".

Есть некоторые общие функции для формирования параметров, которые подставляются в запрос.

 
#Область ВспомогательныеПроцедурыИФункции

&НаСервереБезКонтекста
Функция ПараметрыURLЗапроса(ДатаНачала, ДатаОкончания)
	
	ПараметрыURLЗапроса	= Новый Структура;
	ПараметрыURLЗапроса.Вставить("skip", 0);
	ПараметрыURLЗапроса.Вставить("take", 50);
	ПараметрыURLЗапроса.Вставить("fromDate", XMLСтрока(ДатаНачала)+"Z");
	ПараметрыURLЗапроса.Вставить("toDate", XMLСтрока(ДатаОкончания)+"Z");
	
	Возврат ПараметрыURLЗапроса;
	
КонецФункции

&НаСервереБезКонтекста
Функция СтрокаПараметровURLЗапроса_Преобразовать(ПараметрыURLЗапроса) 
	
	СтрокаПараметровURLЗапроса	= "";
	
	Для каждого КлючЗначение из ПараметрыURLЗапроса Цикл
		
		СтрокаПараметровURLЗапроса	= СтрокаПараметровURLЗапроса + КлючЗначение.Ключ + "=" + КодироватьСтроку(КлючЗначение.Значение, СпособКодированияСтроки.КодировкаURL) + "&";
		
	КонецЦикла;
	
	Если Прав(СтрокаПараметровURLЗапроса, 1) = "&" Тогда
		СтрокаПараметровURLЗапроса	= Лев(СтрокаПараметровURLЗапроса, СтрДлина(СтрокаПараметровURLЗапроса) - 1);
	КонецЕсли;
	
	Возврат СтрокаПараметровURLЗапроса;
	
КонецФункции

#КонецОбласти

 

Реализация получения данных для тонкого клиента

 
&НаКлиенте
Функция XTTPЗапросДанных()
	
	XTTPЗапрос = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
    Скрипт = Новый COMОбъект("MSScriptControl.ScriptControl");
    Скрипт.language = "javascript";
    Скрипт.AddObject("XTTPЗапрос", XTTPЗапрос);
	Скрипт.Eval("XTTPЗапрос.Option(2)=1251");
	Скрипт.Eval("XTTPЗапрос.Option(4)=13056"); // intSslErrorIgnoreFlags
	Скрипт.Eval("XTTPЗапрос.Option(6)=true");  // blnEnableRedirects
	Скрипт.Eval("XTTPЗапрос.Option(12)=true"); // blnEnableHttpsToHttpRedirects 
	
	// Формирование GET запроса 
	АдресСервиса = "https://ваш_url/A/B/C";
	ПараметрыURLЗапроса = ПараметрыURLЗапроса(Объект.ДатаНачала, КонецДня(Объект.ДатаОкончания));
	
	СтрокаПараметровURLЗапроса = СтрокаПараметровURLЗапроса_Преобразовать(ПараметрыURLЗапроса);
	СтрокаGetЗапроса = АдресСервиса + "?" + СтрокаПараметровURLЗапроса;
	
    XTTPЗапрос.Open("GET", СтрокаGetЗапроса, 0);
	XTTPЗапрос.setRequestHeader("Origin", "*");
    XTTPЗапрос.setRequestHeader("Authorization", "Bearer " + Объект.Токен);
    XTTPЗапрос.setRequestHeader("Content-Type", "application/json");
	
	XTTPЗапрос.send();
	
	Объект.Статус = Строка(XTTPЗапрос.Status);
	Если XTTPЗапрос.Status = 200 Тогда
		Возврат XTTPЗапрос.ResponseText; // результат запроса JSON строка, которую будем парсить и грузить эти данные в БД.
	Иначе
		Возврат "";
	КонецЕсли;
	
КонецФункции

Есть нюанс в заголовке XTTPЗапрос.setRequestHeader("Origin", "*"), чтобы запрос к API работал с этим заголовком, нужно обсуждать параметры API с теми кто им заведует. Насколько я знаю, в настройку Origin на сервере API нужно устанавливать значение адреса домена с которого осуществляется подключение. Без настройки этого заголовка на сервере и установки этого заголовка в коде 1С может возникать ошибка авторизации 403.

Реализация получения данных для веб клиента

Аналогично авторизации, необходимо при создании формы заполнить содержание HTML документа на форме. При этом не получиться сделать поле HTML на форме 1С невидимым, иначе оно не инициализируется. Поэтому просто делаем все элементы HTML разметки невидимыми при помощи display:none.

 
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	ТекстХТМЛ = 
	#Область HTMLДокумент
	"<html>
	|<head>
	|    <meta charset=""UTF-8"">
	|    <title>Загрузка данных</title>
	|</head>
	|<body>
	|    <form>
	|    	<input id=""enter"" type=""button"" value=""Загрузить данные"" style=""display:none"">
	|    </form>
	|	 <div id=""result"" style=""display:none""></div><div id=""status"" style=""display:none""></div>
	|</body> 
	|</html>";
	#КонецОбласти
	
	ЗагрузкаHTML = ТекстХТМЛ;

КонецПроцедуры

Т.к. время запроса к серверу может в зависимости от нагрузки на сервер быть разным, то нужно предусмотреть ожидание получения результата. Поэтому получения данных из HTML+JS у меня реалезовано не через функцию, а процедуру, в которой после выполнения скрипта подключается обработчик ожидания с вызовом функции, и в этой функции после того как мы увидели, что результат запроса был помещен в div "result" JavaScript'ом, мы получаем из этого div'а текст JSON и отправляем его на обработку в другие процедуры и функции.

 
#Область ЗагрузкаДанныхВебКлиент

&НаКлиенте
Процедура ЗагрузитьДанныеСПомощьюJavaScript()
	
	// Формирование GET запроса 
	АдресСервиса = "https://ваш_url/A/B/C";
	ПараметрыURLЗапроса = ПараметрыURLЗапроса(Объект.ДатаНачала, КонецДня(Объект.ДатаОкончания));
	
	СтрокаПараметровURLЗапроса = СтрокаПараметровURLЗапроса_Преобразовать(ПараметрыURLЗапроса);
	СтрокаGetЗапроса = АдресСервиса + "?" + СтрокаПараметровURLЗапроса;
	
	JavaScript = ПолучитьJavaСкриптЗагрузкиДанных(СтрокаGetЗапроса, Объект.Токен);
	
	ДИВ = Элементы.ЗагрузкаHTML.Документ.getElementById("enter");
    
    НашлиАтрибут = ДИВ.getAttributeNode("onclick");
    Если НашлиАтрибут <> Null Тогда
        ДИВ.removeAttribute("onclick");
    КонецЕсли; 
    
    Атрибут  = Элементы.ЗагрузкаHTML.Документ.createAttribute("onclick");
    Атрибут.value = JavaScript;
    ДИВ.attributes.setNamedItem(Атрибут); 
    
    ДИВ.click();
	
	КоличествоВызовов = 0;

// Ожидаем когда в div result появится текст JSON
	ПодключитьОбработчикОжидания("ПолучитьРезультатЗапросаВРежимеОжидания", 1, Ложь);
	
КонецПроцедуры

&НаКлиенте
Процедура ПолучитьРезультатЗапросаВРежимеОжидания()
	
	Отказ = Ложь;
	КоличествоВызовов = КоличествоВызовов + 1;
	
	ДИВResult = Элементы.ЗагрузкаHTML.Документ.getElementById("result");
	ДИВStatus = Элементы.ЗагрузкаHTML.Документ.getElementById("status");
	Объект.Статус = ДИВStatus.innerHTML;
	СтрокаJSON 	  = ДИВResult.innerHTML;
	
// Подождали 20 секунд, считаем что что то пошло не так и прекращаем загрузку. 
// Количество секунд регулируется на свое усмотрение.
	Если КоличествоВызовов > 20 Тогда
		ТекстОтказа = НСтр("ru='Данные от сервера не получены в течении %1 секунд'");
		ТекстОтказа = СтрШаблон(ТекстОтказа, КоличествоВызовов);
		ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОтказа);
		ОтключитьОбработчикОжидания("ПолучитьРезультатЗапросаВРежимеОжидания");
		Возврат;
	Иначе
		Если (Не ПустаяСтрока(СтрокаJSON) Или Не ПустаяСтрока(Объект.Статус)) Тогда
			
			ОтключитьОбработчикОжидания("ПолучитьРезультатЗапросаВРежимеОжидания");
			Если ПустаяСтрока(СтрокаJSON) Тогда
				ТекстОтказа = НСтр("ru='Данные от сервера не получены. Код ответа: %1'");
				ТекстОтказа = СтрШаблон(ТекстОтказа, Объект.Статус);
				ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОтказа);
				Возврат;
			Иначе
// Появился в div result текст JSON, отправляем его на обработку.
				ОбработкаДанныхНаСервере(СтрокаJSON, Отказ, ТекстОтказа);	
			КонецЕсли;
			
			Если Отказ Тогда
				ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстОтказа);
			КонецЕсли;
			
		КонецЕсли;	
	КонецЕсли;	
	
КонецПроцедуры

&НаКлиенте
Функция ПолучитьJavaСкриптЗагрузкиДанных(СтрокаGetЗапроса, Токен)

	JavaScriptChrome = 
	#Область JavaScriptChrome
	"fetch(""%1"", {
	|		method: ""GET"",
	|		headers: {
	|			""Content-Type"": ""application/json"",
	|			""Authorization"": ""Bearer %2""}
	| }).then(function(response) {
	|
	|     var status = document.getElementById(""status"");
	|     status.innerHTML = response.status;
	|
	|	if(response.status==200) {
	|		return response.json();
	|	 }
	| }).then(function(data) {
	|     var result = document.getElementById(""result"");
	|     result.innerHTML = JSON.stringify(data);
	| }).catch(function(err) {  
	|	var result = document.getElementById(""result"");
	|     result.innerHTML = err;  
	|});";
	#КонецОбласти
		
	JavaScriptIE = 
	#Область JavaScriptIE
	"if (window.XMLHttpRequest) {
	|        xmlhttp = new XMLHttpRequest();
	|    } else {
	|        xmlhttp = new ActiveXObject(""Microsoft.XMLHTTP"");
	|    }
	|var xhr = xmlhttp;
	|xhr.onreadystatechange=function()
	|{
	|  if (xhr.readyState==4 && xhr.status==200)
	|  {
	|   var result = document.getElementById(""result"");
	|	result.innerHTML = xhr.responseText;	
	|  } 
	|  if (xhr.readyState==4 && xhr.status!=200)
	|  {
	|   var status = document.getElementById(""status"");
	|	status.innerHTML = xhr.status;	
	|  } 
	|} 
	|xhr.open(""GET"", ""%1"", false);
	|xhr.setRequestHeader(""Origin"", ""*"");
	|xhr.setRequestHeader(""Content-Type"", ""application/json"");
	|xhr.setRequestHeader(""Authorization"", ""Bearer %2"");
	|xhr.send();";
	#КонецОбласти
		 
	ТекущийБраузер = ОпределитьБраузер();
	
	Если ТекущийБраузер = "Chrome" Тогда
		JavaScript = JavaScriptChrome;
	Иначе
		JavaScript = JavaScriptIE;
	КонецЕсли;
	
	JavaScript = СтрШаблон(JavaScript, СтрокаGetЗапроса, Токен);

	Возврат JavaScript;
	
КонецФункции

&НаКлиенте
Функция ОпределитьБраузер()
	
	СистемнаяИнформация = Новый СистемнаяИнформация; 
	ТекущаяСистема = СистемнаяИнформация.ИнформацияПрограммыПросмотра;
	
	Если ПустаяСтрока(ТекущаяСистема) Тогда
		Возврат "ТонкийКлиент";
	ИначеЕсли СтрНайти(ВРег(ТекущаяСистема), "CHROME") Тогда
		Возврат "Chrome";
	ИначеЕсли СтрНайти(ВРег(ТекущаяСистема), "FIREFOX") Тогда 
		Возврат "Firefox";
	Иначе
		Возврат "IE";
	КонецЕсли;
	
КонецФункции

#КонецОбласти

 

Проблемы при работе с GET XTTP подключением получения данных

Чуть выше я уже кратко упомянул проблему, которая возникает при попытке получения данных, когда уже вроде бы должно всё работать. У нас есть токен авторизации, но когда мы пытаемся подключиться для получения данных, мы получаем ошибку авторизации 403. Она так же может отображаться в 1С следующим образом:

{ВнешняяОбработка.ЗагрузкаЧеков.МодульОбъекта(62)}: Ошибка при вызове метода контекста (Получить): Ошибка работы с Интернет:   Couldn't resolve host name.

Чтобы понять, что надо использовать заголовок Origin и настраивать его на сервере API, а не искать причину в чем то другом, нужно сделать следующее:

1. Создать и сохранить у себя на ПК новый HTML документ следующего вида

 
<!doctype html>

<head>
    <meta charset="UTF-8">
    <title>Авторизация</title>
</head>
<body>
    <form>
        <table>
            <tr>
                <td><label for="loginField">Логин</label></td>
                <td><input id="loginField" type="text" name="login"></td>
            </tr>
            <tr>
                <td><label for="passwordField">Пароль</label></td>
                <td><input id="passwordField" type="password" name="password" value=""></td>
            </tr>
            <tr>
                <td colspan="2" style="text-align: center">
                    <input type="button" onClick="authorize()" value="Войти">
                </td>
            </tr>
        </table>
    </form>
    <div id="result"></div>
    <div id="resultJSON"></div>
    <div id="status"></div>
    <div id="showResult"></div>

    <form>
        <input type="button" onClick="getData()" value="Получить данные по токену">
    </form>
    <div id="statusGet"></div>
</body>
<script>
    window.onload
    {
        var username = document.getElementById("loginField");
        var password = document.getElementById("passwordField");
    //Заполним сразу пользователя и пароль, чтобы спокойно экспериментировать и не вбивать эти данне при каждом обновлении страницы
        username.value = "";
        password.value = "";
    }

    function authorize() {

        var username = document.getElementById("loginField");
        var password = document.getElementById("passwordField");

        // Заполняем наши параметры
        var details = {
            'client_id': 'ваш_client_id',
            'grant_type': 'ваш_grant_type',
            'username': username.value,
            'password': password.value,
            'redirect_uri': 'https://ваш_redirect_uri/callback'
        };

        var formBody = [];
        for (var property in details) {
            var encodedKey = encodeURIComponent(property);
            var encodedValue = encodeURIComponent(details[property]);
            formBody.push(encodedKey + "=" + encodedValue);
        }
        formBody = formBody.join("&");

        // Заполняем наши параметры
        fetch('https://ваш_url/connect/token', {
            method: 'POST',
            headers: {
                'Content-Type': 'application/x-www-form-urlencoded;charset=UTF-8'
            },
            body: formBody
        }).then(function(response) {
            var status = document.getElementById("status");
            status.innerHTML = response.status;
            showResult(response.status);

            return response.json();
        }).then(function(answer) {
            var result = document.getElementById("result");
            result.innerHTML = answer.token;
        })

    }
     function showResult(statusCode){
         var showResult = document.getElementById("showResult");
         if(statusCode == "200") {
             showResult.innerHTML = "Подключение выполнено, можно данные получены.";
         } else {
             showResult.innerHTML = "Подключение не выполнено, проверьте данные авторизации. Код ответа: " + statusCode;
         }
     }

    function getData() {

        // Указываем наш URL и наши параметры
        var result = document.getElementById("result");
        fetch('https://ваш_url_api/A/B/C?skip=0&take=50&fromDate=2018-08-01T08%3A56%3A35Z&toDate=2018-08-18T08%3A56%3A35Z', {
				method: 'GET',
				headers: {
					'Content-Type': 'application/json',
					'Authorization': 'Bearer ' + result.innerHTML} // должнен подставиться токен, можно его вставить сюда строкой напрямую
         }).then(function(response) {
        
             var status = document.getElementById("statusGet");
             status.innerHTML = response.status;
             showResult(response.status);
        
			if(response.status==200) {
				return response.json();
			 }
         }).then(function(data) {
            var resultJSON = document.getElementById("resultJSON");
            resultJSON.innerHTML = JSON.stringify(data);
         }).catch(function(err) {  
			var resultJSON = document.getElementById("resultJSON");
            resultJSON.innerHTML = err;
		});

    }

</script>
</html>

Заполняем собственные логин, пароль, и другие параметры в скрипте, и сначала нажимаем "Войти", чтобы получить токен в <div id="result">, а затем нажимаем "Получить данные по токену", чтобы получить данные JSON в <div id="resultJSON">.

2. Открываем этот HTML в специальном режиме браузера Chrome:

 
"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --user-data-dir="C://Chrome dev session" --disable-web-security

Открыв браузер таким образом, будет отключена защита браузера CORS, и можно проверить, наш запрос в 1С не работает потому что срабатывает эта защита, или по какой-то другой причине. То есть, если возникнет ошибка в этом режиме браузера и данные мы не получили, то дело НЕ в CORS, а если в этом режиме браузера загружается, а в 1С не грузится с ошибкой "Couldn't resolve host name", то это проблема связана с CORS.

Также можно использовать программу Postman и попробовать выполнить запрос в этой программе.

Дополнительные настройки

Помимо этой проблемы стоит так же предусмотреть возможные проблемы при работе в IE. Рекомендую выполнить следующие настройки в своей системе:
1. IE свойства браузера - зайти в вкладку "Дополнительно" и установить флаг «Разрешать запуск активного содержимого файлов на моем компьютере»;

2. Если установлен Касперский - нужно снять флаг с настройки «Внедрять в трафик скрипт взаимодействия с веб-страницами», который находится в "Настройки"(шестеренка) -> "Сеть".

OAuth REST API

См. также

Интеграция Альфа Авто 5 / Альфа Авто 6 и AUTOCRM / Инфотек

Сайты и интернет-магазины WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 1С:Управление торговлей 11 Автомобили, автосервисы Россия Управленческий учет Платные (руб)

Интеграционный модуль обмена между конфигурацией Альфа Авто 5 и Альфа Авто 6 и порталом AUTOCRM. Данный модуль универсален. Позволяет работать с несколькими обменами AUTOCRM разных брендов в одной информационной базе в ручном и автоматическом режиме.

36000 руб.

03.08.2020    16179    14    18    

14

Интеграция 1С — Битрикс24. Обмен задачами

Сайты и интернет-магазины Интеграция WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Платные (руб)

Интеграция 1С и Битрикс24. Разработка имеет двухстороннюю синхронизацию 1С и Битрикс24 задачами. Решение позволяет создавать пользователя в 1С из Битрикс24 и наоборот. Данная разработка технически подходит под все основные конфигурации линейки продуктов 1С:Предприятие 8.3 (платформа начиная с 8.3.23). При приобретении предоставляется 1 месяц бесплатных обновлений разработки. Доступна демо-версия продукта с подключением Вашего Битрикс24

5040 руб.

04.05.2021    18295    10    15    

16

Модуль для обмена "1С:Предприятие 8. УАТ. ПРОФ" с FortMonitor

WEB-интеграция 8.3.8 Конфигурации 1cv8 Автомобили, автосервисы Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Расширение предназначено для конфигурации "1С:Предприятие 8. Управление Автотранспортом. ПРОФ". Функционал модуля: 1. Заполнение регистров сведений по подсистеме "Мониторинг", а именно: события по мониторингу, координаты по мониторингу, пробег и расход по мониторингу, текущее местоположение ТС по мониторингу 2. Заполнение путевого листа: пробег по мониторингу, время выезда/заезда, табличная часть ГСМ, места стоянок по геозонам. 3. Отчеты по данным загруженным в регистры сведений. 4. Предусмотрена автоматическая загрузка данных в фоновом режиме (условия работы данной загрузке читайте в описании товара) Модуль работает без включенной константы по настройкам мониторинга. Модуль формы предоставляется с открытым кодом, общий модуль защищен. Любой заинтересованный пользователь, имеет возможность скачать демо-версию расширения.

22656 руб.

25.05.2021    13039    34    8    

13

Автоматическая загрузка файлов (например, прайс-листов) из электронной почты, FTP, HTTP, их обработка и выгрузка на FTP (на сайт) и для других целей

Прайсы WEB-интеграция Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Автомобили, автосервисы Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Программа с заданным интервалом времени (или по ручной команде) скачивает файлы (например, прайс-листы поставщиков) из различных источников: письма электронной почты, FTP или HTTP-адреса, и сохраняет их в каталог упорядоченной структуры. При этом извлекает файлы из архивов, может переименовывать файлы и менять их формат (csv, xls, txt). Можно настроить выгрузку обработанных файлов на сайт (через FTP-подключение). Программа будет полезна компаниям, у которых есть большое количество поставщиков и/или прайс-листы поставщиков обновляются часто (необязательно прайс-листы, файлы могут быть любого назначения). Собранные таким образом актуальные версии прайс-листов можно выгрузить с помощью программы себе на сайт (или на любой FTP-сервер) или выполнить другие необходимые задачи.

25200 руб.

28.05.2015    85577    26    51    

50

Интеграция с сервисом vetmanager

WEB-интеграция Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бытовые услуги, сервис Платные (руб)

Внешняя обработка разрабатывалась для загрузки документов из Ветменеджер в 1С: Бухгалтерия 3.0

12000 руб.

02.02.2021    16684    43    49    

24
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. bulpi 215 06.09.18 12:50 Сейчас в теме
Автор, просмотрите статью. Похоже, какие-то рисунки должны быть, но их нет и ничего не понятно.
meowmeow; +1 Ответить
2. VZhulanov 4 08.11.18 19:50 Сейчас в теме
Спасибо за примеры
Долго мучался с авторизацией и получением токена
помогла строка
XTTPЗапрос.setRequestHeader("Content-Type", "application/x-www-form-urlencoded")

только ее мне и не хватало
chemezov; +1 Ответить
3. user774630 25.03.19 13:08 Сейчас в теме
Большое спасибо!
Для тонкого клиента заработал такой код (без COM-объектов)
МассивПараметров = Новый Массив;
	МассивПараметров.Добавить("client_id=***");	
	МассивПараметров.Добавить("client_secret=***");
	МассивПараметров.Добавить("grant_type=client_credentials");
	МассивПараметров.Добавить("redirect_uri=https://***/oauth/token");
	
	АдресРесурса = "?" + СтрСоединить(МассивПараметров, "&");
	
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
	
	HTTPЗапрос = Новый HTTPЗапрос(АдресРесурса, Заголовки);
	
	HTTP = Новый HTTPСоединение("***/oauth/token",,,,,,Новый ЗащищенноеСоединениеOpenSSL,Истина);
	HTTPОтвет = HTTP.ОтправитьДляОбработки(HTTPЗапрос);
	
	СтрокаОтвета = HTTPОтвет.ПолучитьТелоКакСтроку();
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(СтрокаОтвета);
	
	СтруктураОтвета = ПрочитатьJSON(ЧтениеJSON);
	
	Если СтруктураОтвета.Свойство("access_token") Тогда
		access_token = СтруктураОтвета.access_token;
	КонецЕсли;
Показать
chemezov; +1 Ответить
4. uno-c 237 01.05.19 09:30 Сейчас в теме
access token для google api можно также получать с помощью авторизации сервер-сервер, без редиректов и подтверждения пользователя.
chemezov; +1 Ответить
5. chemezov 47 10.06.19 15:29 Сейчас в теме
Опять пропали две картинки в последнем разделе. Продублирую лучше в комментарии.
Дополнительно:
Помимо этой проблемы стоит так же предусмотреть возможные проблемы при работе в IE. Рекомендую выполнить следующие настройки в своей системе:
1. IE свойства браузера - зайти в вкладку "Дополнительно" и установить флаг «Разрешать запуск активного содержимого файлов на моем компьютере»;

2. Если установлен Касперский - нужно снять флаг с настройки «Внедрять в трафик скрипт взаимодействия с веб-страницами», который находится в "Настройки"(шестеренка) -> "Сеть".
Прикрепленные файлы:
6. deman_ru 19 07.10.19 13:22 Сейчас в теме
Подскажите, а можно ли авторизоваться по token в базе опубликованной на web - сервере с использованием протокола OAuth?
7. chemezov 47 08.10.19 08:30 Сейчас в теме
(6)Для этого нужно писать свой веб клиент. Стандартный такой возможности не предусматривает.
8. Vix 28 12.11.19 15:20 Сейчас в теме
(7)Спасибо за пример, только начинаю разбираться с подобной задачей, разница только в том, что нужно на форме 1С нажимать кнопку авторизации, а открываться будет браузер гугл хром, откуда приходить будут токены, которые нужно встроить в заголовки запроса, а так же можно получить и json. По кнопке выход, допустим удалять токен. Что можете посоветовать к изучению данной задачи?
9. chemezov 47 16.11.19 18:28 Сейчас в теме
(8)Затрудняюсь ответить. Не знаю как из 1С программно открыть Хром
10. user1074814 06.12.19 13:08 Сейчас в теме
Для тех кто на 64 сервере, и выдает ошибку класса на строке с MSScriptControl.ScriptControl
Вам нужно добавить на сервер новую dll, скачать её можно отсюда:
https://tablacus.github.io/scriptcontrol_en.html
11. chemezov 47 24.01.20 03:08 Сейчас в теме
Эх, мдаа. Чудный редактор статьи. Поправил пару слов, теперь все вставки кода пропали...
12. chemezov 47 08.12.20 11:13 Сейчас в теме
Для решения ошибки:
Произошла исключительная ситуация (WinHttp.WinHttpRequest): Не удается установить соединение с сервером

Помог комментарий из https://infostart.ru/1c/articles/1024217/
У меня windows 7 помогло конкретно вот это:
далее еще запустить фикс - делает тоже что описано в этой статье, только автоматом
https://support.microsoft.com/en-us/help/3140245/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-wi
13. LineykaSBK 5 01.11.22 12:43 Сейчас в теме
Подскажите пож-та. У яндекса так же и у майла при настройки почты в 1С ошибки, мол зайдите и настройте почту для приложения. настраиваю и там и там, в 1С все время говорит что не удалось авторизоваться. Делал пароли и для приложений и пробовал через них и главным паролем пробовал - ни как.
В итоге решил попробовать настроить почту через вэб авторизацию. настроил на стороне почтового сервера все, только вот вопрос, 1С говорит в помощнике, скопируйте этот Callback URL и вставьте http://localhost/oauth2 в соответствующее поле на стороне настройки приложения в почте.
копирую это из помощника настройки подключения почты http://localhost/oauth2, вставляю, пытаюсь и все, ничего дальше не происходит, висит пустое окно.
Я так и не понял что это за ссылка такая у 1С генерируется в поле http://localhost/oauth2
14. chemezov 47 03.11.22 10:15 Сейчас в теме
(13)
Я так и не понял что это за ссылка такая у 1С генерируется в поле http://localhost/oauth2

Боюсь не смогу подсказать. Очень давно я писал эту обработку и в такие детали насколько я помню не углублялся. Я уже успел забыть весь синтаксис JavaScript слишком другие задачи за прошедшее время мне приходилось решать.

Если удастся разобраться, и вы напишите на инфостарте статью с решением этой проблемы, просьба оставить ссылку на вашу статью с решением в комментариях тут. Возможно кому-то в последствии это очень поможет.
Оставьте свое сообщение