Функция НайтиФайлы() в каталоге netshare на Linux - обход ошибки работы

25.10.18

Разработка - Универсальные функции

Решение проблемы применения функции НайтиФайлы() в каталоге с netshare на Linux-сервере - не работает поиск файлов по указанной маске (шаблону)

Предыстория: у клиента на ЖД терминале сервер работает под ОС Linux. Компьютер ЖД весовой при взвешивании вагонов сохраняет локально фотографии, но сервер по локальной сети через netshare имеет возможность получить эти файлы по обычному пути. При необходимости вывести фотографии за определенный момент времени необходимо выполнить поиск файлов по шаблону имени, которое как раз составляется по дате и времени, использование стандартной функции НайтиФайлы() с Windows проблем не вызвало - все ищется, но под Linux НайтиФайлы() с поиском по маске не работает - результат пустой, ищет только по полному четкому имени конкретного файла . Решение было найдено через использование вызова команды Linux "find" через командную оболочку (ЗапуститьПриложение) и вывода результатов поиска (текст с перечнем имен найденных файлов построчно) в текстовый файл с последующим его чтением.

ИмяФайлаСписка = ПолучитьИмяВременногоФайла("txt");
Команда = СтрШаблон("find %1/%2*.jpg > %3", ИмяКаталога, ШаблонВремени, ИмяФайлаСписка);
ЗапуститьПриложение(Команда,, Истина);
	
Файл = Новый Файл(ИмяФайлаСписка);
Если НЕ Файл.Существует() Тогда
    Сообщить("Файлы не обнаружены");
	Возврат;
КонецЕсли; 
	
НайденныеФайлы = Новый Массив;
Чтение = Новый ЧтениеТекста(ИмяФайлаСписка);
ПутьКФайлу = Чтение.ПрочитатьСтроку();
Пока ЗначениеЗаполнено(ПутьКФайлу) цикл
			
	НайденныеФайлы.Добавить(ПутьКФайлу);
	ПутьКФайлу = Чтение.ПрочитатьСтроку();
		
КонецЦикла;

Чтение.Закрыть();

Быть может, такая проблема возникала еще у кого-то. С причиной подобного бага конкретно на данном дистрибутиве Linux не разбирался, возможно дело именно в использовании netshare.

Linux netshare НайтиФайлы

См. также

Универсальные функции Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Благодаря этим пяти строчкам можно больше не заморачиваться с загрузкой из внешних файлов. Пользуюсь везде, всегда и постоянно.

21.05.2024    12127    dimanich70    80    

125

Универсальные функции Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Задача: вставить картинку из буфера обмена на форму средствами платформы 1С.

1 стартмани

18.03.2024    3405    3    John_d    11    

57

Универсальные функции Программист Стажер Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Пришлось помучиться с GUID-ами немного, решил поделиться опытом, мало ли кому пригодится.

12.02.2024    8595    atdonya    22    

55

Универсальные функции Программист Платформа 1С v8.3 Бесплатно (free)

На заключительных этапах, когда идет отладка или доработка интерфейса, необходимо много раз переоткрыть внешний объект. Вот один из способов автоматизации этого.

30.11.2023    4779    ke.92@mail.ru    16    

65

WEB-интеграция Универсальные функции Механизмы платформы 1С Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

При работе с интеграциями рано или поздно придется столкнуться с получением JSON файлов. И, конечно же, жизнь заставит проверять файлы перед тем, как записывать данные в БД.

28.08.2023    11629    YA_418728146    7    

156

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2866    43    progmaster    8    

4

Инструментарий разработчика Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Копирует в буфер значения из списков, из ячеек отчетов, таблиц, настроек списков, других отборов и вставляет в выбранную настройку отбора. Работает с Объект не найден. Работает как в одной так и между разными базами 1С. Использует комбинации [Alt+C] Копировать список, [Alt+V] Вставить список. Также для копирования данных используется стандартная [Ctrl+C] (например из открытого xls, mxl, doc и т.п. файла скопировать список наименований)

1 стартмани

13.10.2022    17274    152    sapervodichka    112    

134
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Armando 1400 19.09.18 22:54 Сейчас в теме
Не бага, а фича. https://its.1c.ru/db/v83doc#bookmark:dev:TI000001209
"Еще одной особенностью ОС Linux является то, что в ней нет возможности обращаться к сетевым ресурсам, используя UNC-нотацию (в этом случае адрес имеет следующий вид: \\server\folder\folder\file.ext). Поэтому, при необходимости использовать какой-либо внешний сетевой ресурс, его необходимо предварительно смонтировать на корневую файловую систему."
drmaxart; +1 Ответить
2. albertik88 11 17.07.20 06:23 Сейчас в теме
Добрый день! Столкнулся с такой же проблемой, нужно из 1с под линуксом открыть файл с сервера, пытаюсь реализовать по аналогии с вашим решением, но у меня получается что переменная "ПутьКФайлу" получается пустой, хотя нужный файл присутствует на сервере, и не понятна ваша команда

Команда = СтрШаблон("find %1/%2*.jpg > %3", ИмяКаталога, ШаблонВремени, ИмяФайлаСписка);

а именно "> %3" - могли бы пояснить что это?

вот кусок моего кода:

ПутьКТому = "smb://192.168.1.252/up_doc";
					
ИмяФайлаСписка = ПолучитьИмяВременногоФайла("txt");
					
Команда = СтрШаблон("find %1 -name %2* > %3", ПутьКТому, ИмяФайлаВТоме, ИмяФайлаСписка);
ЗапуститьПриложение(Команда,, Истина);
					
Файл = Новый Файл(ИмяФайлаСписка);
Если НЕ Файл.Существует() Тогда
    Сообщить("Файлы не обнаружены");
Иначе
    НайденныеФайлы = Новый Массив;
    Чтение = Новый ЧтениеТекста(ИмяФайлаСписка);
    ПутьКФайлу = Чтение.ПрочитатьСтроку();
    Пока ЗначениеЗаполнено(ПутьКФайлу) цикл
    	    НайденныеФайлы.Добавить(ПутьКФайлу);
            ПутьКФайлу = Чтение.ПрочитатьСтроку();
    КонецЦикла;

    Чтение.Закрыть();
    КонецЕсли;
Показать
3. drmaxart 149 08.08.20 08:39 Сейчас в теме
(2) Добрый день! "> %3" в скрипте означает перенаправление вывода в указанный файл. Так бы список найденных файлов вывелся в командную строку, а при этой конструкции он выводится в файл, который мы уже из 1С можем прочитать
Оставьте свое сообщение