Отпуск по уходу за ребенком. Печать расчета среднего заработка

23.09.11

Задачи пользователя - Адаптация типовых решений

Печать расчета среднего заработка в документе "отпуск по уходу за ребенком" по старым/новым правилам, реализованная в ЗиК 7.70.313, содержит досадную ошибку - если вызвать печать в уже проведенном документе, всегда выдается отчет для новых правил.

Для исправления внесем небольшое изменение в документ ОтпускПоУходуЗаРебенком, форма, модуль:

//******************************************************************************
// Печать()
//
//
Процедура Печать(ПараметрПечати="") 
 
        Если Выбран() = 0 Тогда
                Если Вопрос("Распечатать можно только записанный документ."+РазделительСтрок+" Записать и распечатать документ?","Да+Нет")="Нет" Тогда
                        Возврат
                КонецЕсли;
                Если ПроверкаПередЗаписью() = 1 Тогда
                        ПолучитьДанныеОтпускаПоУходуЗаРебенком();
                        Записать();
                Иначе
                        Возврат;
                КонецЕсли;
        КонецЕсли;
 
        БюджетнаяОрганизация = глБюджетнаяОрганизация();
 
        Если ПустоеЗначение(ПараметрПечати) = 0 Тогда
                // нам сказали - "напечатай, пожалуйста, одну табличку"
                // и, естественно, сказали, какую именно.
                ИмяИсходнойТаблицы = "";
                ПараметрПечати.ПолучитьЗначение(1,ИмяИсходнойТаблицы);
                ИмяОтчета = ИмяИсходнойТаблицы;
        Иначе
                СпПечати = СоздатьОбъект("СписокЗначений");
 
                СпПечати.ДобавитьЗначение("Т-6","Т-6");
                СпПечати.ДобавитьЗначение("РасчетСреднегоЗаработка","Расчет среднего заработка");
 
                ИмяИсходнойТаблицы = ""; 
               Пункт = "";
                Если СпПечати.ВыбратьЗначение(ИмяИсходнойТаблицы,,Пункт,,1) = 1 Тогда
                        ИмяОтчета=""; 
                       СпПечати.ПолучитьЗначение(Пункт,ИмяОтчета);
                Иначе
                        Возврат
                КонецЕсли;
        КонецЕсли;
 
        Если (ИмяИсходнойТаблицы = "Т-6")Тогда
                ПечатьТ6(ИмяИсходнойТаблицы);
        Иначе  
  // Здесь для выбора варианта печати программисты 1С использовали переменную, которую "забыли" инициализировать
                //Если ТипРасчетаБольничного=Перечисление.ТипРасчетаБольничного.С2011года Тогда
  // Используем для выбора состояние флага
                Если РасчетПоПравилам2010Года = 0 Тогда
                        ПечатьРасчетСреднего2011();
                Иначе
                        ПечатьРасчетСреднего(); 
               КонецЕсли;
 
        КонецЕсли;      
 
КонецПроцедуры //Печать

См. также

Улучшенная обработка "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7

Печатные формы Адаптация типовых решений Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Приятное улучшение обработки "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7 для более комфортной работы с "любимой семерочкой".

1 стартмани

04.02.2022    3233    1    igor7777    0    

3

Расчет страховых взносов в 1С 7.7 "Учет и отчетность предпринимателя, ред. 1.2" с апреля 2020

Адаптация типовых решений Платформа 1С v7.7 Конфигурации 1cv7 Россия Бухгалтерский учет ФОМС, ЕФС Бесплатно (free)

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

09.04.2020    20004    Юджин58    39    

5

Дистрибьюция 7.7. Часть 1. Жизненный цикл заявки покупателя. Одна заявка покупателя, много адресов доставки.

Адаптация типовых решений Платформа 1С v7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Управленческий учет Бесплатно (free)

Описан способ работы с учетом расписания с приоритетными покупателями - торговыми сетями (основными покупателями) в торговой или комплексной учетной системе на 1С 7.7. Множественная заявка покупателя на несколько торговых точек.

14.10.2019    6090    ksnik    14    

3

Как в торговле 7.7 печатать код ТНВЭД в счет-фактуре

Операции по ВЭД Адаптация типовых решений Оперативный учет 7.7 1С:Торговля и склад 7.7 Россия Бухгалтерский учет НДС Бесплатно (free)

В данной статье хотел поделиться опытом, как в Торговле 7.7 ( релиз 994) сделать возможность выводить код ТНВЭД в печатную форму счета-фактуры. Сразу скажу, что нужно это только тем, кто осуществляет экспорт в страны таможенного союза. Остальные могут не волноваться.

15.11.2017    11867    AndKovalchuk    0    

1

Предельные базы взносов в ПФР, ФСС, ФФОМС 2015 в 1С: Бухгалтерия 7.7

Зарплата Адаптация типовых решений Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Реализация Постановления Правительства РФ 1316 от 04.12.14 для типовой конфигурации "Бухгалтерский учет 7.7" рел. 7.70.590

1 стартмани

31.12.2014    23974    9    Sergey1CSpb    2    

0
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
0. Gr@nd@d 13 30.09.11 06:14 Сейчас в теме
Печать расчета среднего заработка в документе "отпуск по уходу за ребенком" по старым/новым правилам, реализованная в ЗиК 7.70.313, содержит досадную ошибку - если вызвать печать в уже проведенном документе, всегда выдается отчет для новых правил.


Перейти к публикации

1. mvoda 30.09.11 06:14 Сейчас в теме
Исправления внесла, документ вообще перестал работать, не открывается
2. Gr@nd@d 13 30.09.11 06:22 Сейчас в теме
Хм... очень странно - изменение то мизерное, да и проверено на рабочей конфигурации.

1) Внеся изменения, сделайте проверку синтаксиса - возможно просто допустили описку при внесении ?
2) Изменения вносили в версию ЗиК 7.70.313 ?
3. safia-med 03.09.14 12:10 Сейчас в теме
Как раньше без неё жили? Спасибо.
Оставьте свое сообщение