Невидимость помеченной на удаление номенклатуры и характеристики номенклатуры (ERP 2.5, УТ 11.5, КА 2.5, Розница 2.3)

11.05.22

База данных - Чистка данных

Расширение для типовых конфигураций. Позволяет сделать невидимым помеченные на удаление номенклатуру и характеристику номенклатуры при выборе и подборе во всех документах, где нужно выбирать или подбирать Номенклатуру и Характеристику номенклатуры, например в документах: Заказ клиента, Заказ поставщику, Реализация товаров и услуг, Приобретение товаров и услуг и т.д.

Скачать файлы

Наименование Файл Версия Размер
Невидимость помеченной на удаление номенклатуры и характеристики номенклатуры (ERP 2.5, УТ 11.5, КА 2.5):
.cfe 82,56Kb
32
.cfe 82,56Kb 32 Скачать
Невидимость помеченной на удаление номенклатуры и характеристики номенклатуры (Розница 2.3):
.cfe 44,39Kb
9
.cfe 44,39Kb 9 Скачать

Когда справочник наполняется помеченными на удаление объектами и долго не представляется возможным удалить помеченные на удаление элементы, они начинают мешать пользователям выбирать значение справочника. Чтобы пользователям они не мешали,  было решено сделать данное расширение. В этом расширении при выборе или подборе Номенклатуры или Характеристики номенклатуры не видны элементы помеченные на удаление.

Например, у номенклатуры - Кондиционер ELEKTA имеется четыре характеристики. Характеристика "Автоуправление" помечена на удаление. Помеченная на удаление характеристика видна в списке всех характеристик.

 

 

При использовании данного расширения в заказе клиента при выборе характеристики, помеченной на удаление "Автоуправление" становится не видно.

 

 

также не видно помеченной на удаление характеристики "Автоуправление" при подборе номенклатуры по кнопке "Заполнить"

 

 

Теперь пользователь при выборе или подборе номенклатуры или характеристики номенклатуры не сможет выбрать помеченный на удаление элемент.

 
Подключение расширения:

 

Работоспособность расширения тестировалось на следующих конфигурациях:

  • 1С:ERP Управление предприятием 2 (2.5.7.390)
  • 1С:ERP Управление предприятием 2 (2.5.8.175)
  • Комплексная автоматизация 2 (2.5.7.390)
  • Управление торговлей, редакция 11 (11.5.7.390)
  • 1С:ERP Управление строительной организацией 2 (2.5.6.291)

11-05-2022:

Добавил раширение для 1С-Розница 2.3

Работоспособность расширения тестировалось на следующих конфигурациях:

  • Розница, редакция 2.3 (2.3.10.43)
  • Розница, редакция 2.3 (2.3.11.33)

См. также

SALE! 10%

Выборочное удаление организаций из баз (управляемые формы), с удалением всех ссылающихся на эти организации данных

Чистка данных Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Платные (руб)

Позволяет удалить организации из любых программ на управляемых формах (БП 3.0, УТ 11, КА 2, ERP 2, ЗУП 3.0, УНФ, Розница 2.0 и пр.). Главное требование - программа должна содержать справочник "Организации". Реализован самый быстрый алгоритм непосредственного удаления объектов. Работает даже на базах большого размера. Для ускорения работы алгоритма не запускается проверка контроля ссылочной целостности. Проверку учета можно запустить отдельно с помощью дополнительной обработки. Необходимо перед удалением самостоятельно проверить базу на наличие перекрестных ссылок разных организаций в одном документе. Эту дополнительную обработку проверки перекрестных ссылок по запросу предоставляем бесплатно нашим покупателям.

3980 3582 руб.

16.03.2015    110299    170    74    

205

Правильная свертка или свертка базы по правилам

Свертка базы Чистка данных Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Обработка "Свертка базы по правилам" предназначена для свертки информационных баз системы программ "1С:Предприятие" версии 8.2. Основой обработки являются специальные правила свертки, которые создаются индивидуально для каждой конфигурации информационной базы. Встроенный в обработку генератор правил позволяет быстро создать правила свертки для любой конфигурации. Например, для конфигурации "1С:Бухгалтерия 8, ред. 3.0" правила свертки были созданы за 15 минут!

2400 руб.

22.07.2013    160499    601    527    

392

Замена Номенклатуры+Характеристики

Чистка данных Логистика, склад и ТМЦ Платформа 1С v8.3 План видов характеристик 1С:Комплексная автоматизация 1.х 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Платные (руб)

Настраиваемая обработка, позволяющая заменить пару: Номенклатура+Характеристика в документах, их движениях и независимых регистрах сведений. Без перепроведения. Поможет, если вы по каким-то причинам решили отказаться от характеристик

3600 руб.

04.08.2015    40289    86    70    

47

Универсальное выборочное удаление данных из базы 1С (любые конфигурации на упр.формах: БП 3.0, УТ 11, КА 2, ERP, УНФ, ЗУП 3, Розница и т.д.)

Чистка данных Платформа 1С v8.3 Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Зарплата и кадры государственного учреждения 3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Платные (руб)

Обработка позволяет удобно выборочно удалить данные из базы 1С. Это могут быть как неиспользуемые элементы справочников, так и неактуальные организации. При этом есть возможность провести анализ пересечений документов с другими организациями и таким образом уберечься от того, что при удалении обороты по другой организации изменятся.

3350 руб.

28.11.2019    23065    38    16    

49

Универсальная обработка удаления данных

Чистка данных Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv7 Россия Платные (руб)

Универсальная обработка удаления как помеченных, так и не помеченных объектов конфигураций 1С 7.7, 8.2, 8.3.

2000 руб.

05.02.2019    18724    18    0    

21

Удаление организаций из информационных баз 1С

Чистка данных Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Обработка предназначена для удаления организаций из любых информационных баз 1С, имеющих в своем составе справочник "Организации". Работает на обычных и управляемых формах, на базах любого формата и размера. Обработка проверялась на следующих типовых релизах 1С: БП 2.0.66.84, БП 3.0.71.77, БГУ 1.0.59.3, БГУ 2.0.65.17, УТ 10.3.55.3, УТ 11.4.10.57, ЗУП 3.1.11.106, ЗГУ 3.1.11.106, КА 2.4.9.98, УПП 1.3.126.1, УНФ 1.6.18.168, но должна работать и на более старых, так как обработке нужен только справочник "Организации".

3000 руб.

20.11.2019    26370    65    29    

70

Алгоритм перехода на учет без серий для программного продукта "Управление торговлей" редакция 11 или Комплексная Автоматизация редакция 2. (отказ от серий, удаление серий, отмена серий, без серий, УТ, КА)

Оптовая торговля Логистика, склад и ТМЦ Чистка данных Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Если вы начали работать в программном продукте Управление Торговлей, редакция 11 или Комплексная Автоматизация редакция 2 и включили механизм учёта серий, то перейти обратно в учёт без серий будет не так-то просто. Сложность заключается в том, что нужно очистить серии в табличной части документа, например, Реализация Товаров и услуг. Предлагаем алгоритм перехода на учет без серий для программного продукта «Управление торговлей» редакция 11. (Очистка серий.)

2400 руб.

09.04.2019    27841    36    14    

38
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. user595534_koshkina 26.04.22 08:34 Сейчас в теме
Расширение супер, спасибо!
Это то, что было крайне необходимо!
aibasoft; skmMining; user1778480; SergAl; +4 Ответить
2. Dem0 18 26.04.22 09:42 Сейчас в теме
Задача нужная, несколько раз приходилось делать, под разные конфигурации.
Автор, напиши, как реализовано, рлс, условное оформление или еще как-то?
3. Vladimir_D 119 26.04.22 10:55 Сейчас в теме
(2)Раз в описании написано, что в подборе или выборе, то значит поправил текст запроса для подбора. А в выборе еще проще - в настройках поля настроить отбор, но тут уже тоже лучше добавить в запрос динамического списка дополнительное условие на пометку удаления. В целом, ничего сложного.
4. may1c 2 26.04.22 14:02 Сейчас в теме
Подскажите, а при вводе в в строке документа номенклатура и характеристика тоже не будет подбираться?
Student1C; +1 Ответить
5. SergAl 759 26.04.22 14:32 Сейчас в теме
(4) Добрый день! Вы имеете ввиду, что если знать наименование помеченной на удаление номенклатуры или характеристики и вводить в строке это наименование с клавиатуры, то возможно ли его выбрать?
10. may1c 2 28.04.22 08:46 Сейчас в теме
(5)именно так
11. SergAl 759 28.04.22 08:56 Сейчас в теме
(10) если вводить с клавиатуры, зная при этом наименование, то расширение позволит это сделать.
18. PrinzOfMunchen 83 06.06.22 07:08 Сейчас в теме
(11) Впишитесь в обработку получения данных выбора
6. user595534_koshkina 26.04.22 16:08 Сейчас в теме
Возникла ошибка у бухгалтерии при создании документа "Списание на расходы", просьба посмотреть.
Прикрепленные файлы:
7. SergAl 759 26.04.22 16:53 Сейчас в теме
(6) Поправил.
13. user595534_koshkina 28.04.22 12:27 Сейчас в теме
(7) Да, сейчас все работает, спасибо!
8. Sanario 24 28.04.22 03:18 Сейчас в теме
А как ведет себя расширение, если подбор не визуальный, а например через ввод по строке?
9. SergAl 759 28.04.22 08:08 Сейчас в теме
(8) Вы имеете ввиду, что если знать наименование помеченной на удаление номенклатуры или характеристики и вводить в строке это наименование с клавиатуры?
14. Student1C 57 02.05.22 19:57 Сейчас в теме
(8) Чуть выше уже ответили, что даст выбрать )
17. oldcopy 171 30.05.22 12:35 Сейчас в теме
(14) Для таких целей мы при установке пометки удаления сразу добавляем к наименованию префикс, которого точно нет и быть не может у нормальной позиции справочника, скажем, 000.

Получается вместо условных Хлеб Белый - 000Хлеб Белый. Подбором выбрать такое трудно и сразу визуально видно, что что-то пошло не так. Хотя народ у нас талантливый, их такие мелочи не смущают.
19. PrinzOfMunchen 83 06.06.22 07:15 Сейчас в теме
(17) Если формы управляемые, то всё намного проще.
Процедура ОбработкаПолученияДанныхВыбора(ДанныеВыбора, Параметры, СтандартнаяОбработка) Экспорт

	Если Не КонтролироватьВыборЭлементов() Тогда
		Возврат;
	КонецЕсли; 	
	
	Отбор = Новый Структура;
	Если НЕ Параметры.Свойство("Отбор") Тогда
		Параметры.Вставить("Отбор", Отбор);
	КонецЕсли; 
	
	Параметры.Отбор.Вставить("ПометкаУдаления", Ложь);
	
КонецПроцедуры

Процедура ОбработкаПолученияФормы(ВидФормы, Параметры, ВыбраннаяФорма, ДополнительнаяИнформация, СтандартнаяОбработка) Экспорт
	
	Если Не КонтролироватьВыборЭлементов() Тогда
		Возврат;
	КонецЕсли; 	
	
	Если ВидФормы = "ФормаВыбора" Тогда
		
		Отбор = Новый Структура;
		Если НЕ Параметры.Свойство("Отбор") Тогда
			Параметры.Вставить("Отбор", Отбор);
		КонецЕсли; 
		
		Параметры.Отбор.Вставить("ПометкаУдаления", Ложь);
			
	КонецЕсли; 
	
КонецПроцедуры
Показать
20. oldcopy 171 06.06.22 13:47 Сейчас в теме
(19) Это слишком радикально, бывают и ошибочные пометки на удаление.
12. Sanario 24 28.04.22 09:21 Сейчас в теме
Ну да. Например характеристику пометили на удаление. У них то наименования не уникальные, подбор вводом и как себя поведет расширение?
15. neverx6 10.05.22 22:54 Сейчас в теме
Добрый, будет ли работать с розницей 2.3?
16. SergAl 759 11.05.22 09:28 Сейчас в теме
(15) Добрый день! Создал расширение для Розницы 2.3.
21. user1921397 04.04.23 12:58 Сейчас в теме
Отличное расширение, то что было нужно )
Оставьте свое сообщение