Перенос и очистка дополнительных реквизитов справочников

23.05.21

База данных - Чистка данных

Обработка для облегчения переноса значений дополнительных реквизитов в основные с последующей очисткой. Работает с любым справочником, у которого есть набор свойств и табличная часть "Дополнительные реквизиты". Весь код в статье.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Замена и очистка дополнительных реквизитов
.epf 10,80Kb
23
23
1 SM
Скачать Купить за 1 850 руб.

Тестирование проводилось на:

Платформа: 1С:Предприятие 8.3 (8.3.18.1334)

Конфигурация: 1С:ERP Управление предприятием 2 (2.5.6.144)

Старт работы:

  1. Выбрать набор свойств, табличная часть с доп. реквизитам заполниться сама, если таковые существуют
  2. Задать настройки выполнения
  3. В табличной части задать наименование основного реквизита (как в конфигураторе) если необходим перенос и флаг "Очистить" если необходимо очистить значения. Перенос будут выполнен ДО очистки.

У всех настроек есть подсказки. Полный список:

  1. Кнопка "Проверить". Проверит ТЧ на корректность заполнения. Если не назначено действий или основной реквизит написан неправильно - строка подсветится красным, при начале обработки такие строки будут удалены.
  2. Поле "Обработать". Указывает количество элементов справочника, которые нужно обработать. Элементы сортируются по наименованию. Если указано 0, будут обработаны все элементы.
  3. Флаг "Проверять основной реквизит". Проверяет основной реквизит после переноса. Если основной реквизит пустой, элемент не запишется и будет сгенерирована ошибка.
  4. Флаг "Останавливать при ошибке". При первой же ошибке записи данных обработка будет остановлена. В ином случае обработка продолжит обрабатывать другие элементы. Все ошибки будут сохранены в журнале регистрации.

Код:

 
&НаКлиенте
Процедура НаборСвойствПриИзменении(Элемент)
	ЗаполнитьИмяСправочника();
	Если ЗначениеЗаполнено(НаборСвойств) Тогда
		ЗаполнитьТаблицуДополнительныеРеквизиты();
	КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьИмяСправочника()
	
	ИмяСправочника = ?(ЗначениеЗаполнено(НаборСвойств.ИмяПредопределенныхДанных), НаборСвойств.ИмяПредопределенныхДанных, НаборСвойств.ИмяПредопределенногоНабора);
	ИмяСправочника = Прав(ИмяСправочника, СтрДлина(ИмяСправочника)-СтрНайти(ИмяСправочника, "_"));
	НайтиВторойЗнак = СтрНайти(ИмяСправочника, "_");
	Если НайтиВторойЗнак <> 0 Тогда
		ИмяСправочника = Лев(ИмяСправочника, НайтиВторойЗнак - 1);
	КонецЕсли;
		
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьТаблицуДополнительныеРеквизиты()
	
	ДополнительныеРеквизиты.Очистить();
		
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	ДополнительныеРеквизитыИСведения.Ссылка КАК ДополнительныйРеквизит
		|ИЗ
		|	ПланВидовХарактеристик.ДополнительныеРеквизитыИСведения КАК ДополнительныеРеквизитыИСведения
		|ГДЕ
		|	НЕ ДополнительныеРеквизитыИСведения.ЭтоДополнительноеСведение
		|	И ДополнительныеРеквизитыИСведения.НаборСвойств = &НаборСвойств
		|
		|УПОРЯДОЧИТЬ ПО
		|	ДополнительныеРеквизитыИСведения.Имя";
	
	Запрос.УстановитьПараметр("НаборСвойств", НаборСвойств); 
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		СтрокаТЗ = ДополнительныеРеквизиты.Добавить();
		ЗаполнитьЗначенияСвойств(СтрокаТЗ, ВыборкаДетальныеЗаписи); 
	КонецЦикла;
	
КонецПроцедуры

&НаКлиенте
Процедура ВыполнитьКод(Команда)
	Продолжаем = ПроверитьДанные();
	Если Не Продолжаем Тогда Возврат КонецЕсли;
	ВыполнитьОбрабатываниеДанных();
КонецПроцедуры

&НаКлиенте
Процедура Проверить(Команда)
	ПроверитьДанные(Ложь);
КонецПроцедуры

&НаСервере
Функция ПроверитьДанные(УдалятьСтроки = Истина)
	
	Попытка
		ЭлементСправочника = Справочники[ИмяСправочника].СоздатьЭлемент();
	Исключение
		Сообщить("Справочник " + ИмяСправочника + " не поддерживается обработкой");
		Возврат Ложь;
	КонецПопытки;
	
	Для каждого СтрокаТЗ Из ДополнительныеРеквизиты Цикл
		Если СтрокаТЗ.ДополнительныйРеквизит.НаборСвойств <> НаборСвойств Тогда
			СтрокаТЗ.УдалитьСтроку = Истина;
		ИначеЕсли Не ЗначениеЗаполнено(СтрокаТЗ.ОсновнойРеквизит) И СтрокаТЗ.Очистить = Ложь Тогда
			СтрокаТЗ.УдалитьСтроку = Истина;
		ИначеЕсли ЗначениеЗаполнено(СтрокаТЗ.ОсновнойРеквизит) Тогда
			Попытка
				РеквизитСправочника = ЭлементСправочника[СтрокаТЗ.ОсновнойРеквизит];
				СтрокаТЗ.УдалитьСтроку = Ложь;
			Исключение
				Сообщить("Реквизит " + СтрокаТЗ.ОсновнойРеквизит + " не найден!"); 
				СтрокаТЗ.УдалитьСтроку = Истина;
			КонецПопытки;	
		Иначе
			СтрокаТЗ.УдалитьСтроку = Ложь;
		КонецЕсли;	
	КонецЦикла;
	
	Если УдалятьСтроки Тогда
		ТЗКопия = Новый ТаблицаЗначений;
		ТЗКопия = ДополнительныеРеквизиты.Выгрузить(Новый Структура("УдалитьСтроку", Ложь));
		ДополнительныеРеквизиты.Очистить();
		ДополнительныеРеквизиты.Загрузить(ТЗКопия);
	КонецЕсли;
	
	Если ДополнительныеРеквизиты.Количество() = 0 Тогда
		Сообщить("Не назначенны действия для обработки данных");
		Возврат Ложь;
	Иначе
		Возврат Истина;
	КонецЕсли;
	
КонецФункции

&НаСервере
Процедура ВыполнитьОбрабатываниеДанных()
		
	Запрос = Новый Запрос;
	Запрос.Текст = СтрШаблон( 
		"ВЫБРАТЬ %1
		|	ДополнительныеРеквизиты.Ссылка КАК Ссылка,
		|	ДополнительныеРеквизиты.Свойство КАК Свойство,
		|	ДополнительныеРеквизиты.Значение КАК Значение
		|ИЗ
		|	Справочник.%2.ДополнительныеРеквизиты КАК ДополнительныеРеквизиты
		|ГДЕ
		|	ДополнительныеРеквизиты.Свойство В(&Свойство)
		|
		|УПОРЯДОЧИТЬ ПО
		|	ДополнительныеРеквизиты.Ссылка.Наименование
		|ИТОГИ ПО
		|	Ссылка"
		,?(ЗначениеЗаполнено(КвоОбработать), "ПЕРВЫЕ " + Формат(КвоОбработать, "ЧГ=0"), ""), ИмяСправочника);
	
	Запрос.УстановитьПараметр("Свойство", ДополнительныеРеквизиты.Выгрузить(,"ДополнительныйРеквизит"));
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаСсылка = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
	
	Пока ВыборкаСсылка.Следующий() Цикл
		
		ОбъектРаботы = ВыборкаСсылка.Ссылка.ПолучитьОбъект();
		ОбъектМодифицирован = Ложь;
		
		ВыборкаДетальныеЗаписи = ВыборкаСсылка.Выбрать();
		
		Попытка
			Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
				
				ПараметрОтбора = Новый Структура;
				ПараметрОтбора.Вставить("ДополнительныйРеквизит", ВыборкаДетальныеЗаписи.Свойство);
				СтрокаТЗ = ДополнительныеРеквизиты.НайтиСтроки(ПараметрОтбора);
				
				ИмяРеквизита = СтрокаТЗ[0].ОсновнойРеквизит;
				
				Если ЗначениеЗаполнено(ИмяРеквизита) Тогда
				
					ЗначениеОсновногоРеквизита = ОбъектРаботы[ИмяРеквизита];
					
					//Здесь можно обработать значение дополнительного реквизита (ВыборкаДетальныеЗаписи.Значение), перед помещением в основной
					ОбъектРаботы[ИмяРеквизита] = ВыборкаДетальныеЗаписи.Значение;
					
					Если ОбъектРаботы[ИмяРеквизита] <> ЗначениеОсновногоРеквизита Тогда
						Если ПроверятьОсновнойРеквизит Тогда
							Если ЗначениеЗаполнено(ОбъектРаботы[ИмяРеквизита]) Тогда
								ОбъектМодифицирован = Истина;
							Иначе
								ТекстОшибки = "После переноса доп. реквизита, основной реквизит стал пустым. Обработка элемента прервана.";
								ЗаписьЖурналаРегистрации("Обработка доп. реквизитов", УровеньЖурналаРегистрации.Ошибка, ОбъектРаботы.Метаданные(), ОбъектРаботы.Ссылка, ТекстОшибки); 
								Если Останаливать Тогда 
									Сообщить("Обработка прервана по ошибке. Посмотрите журнал регистрации");
									Возврат; 
								Иначе Продолжить КонецЕсли;
							КонецЕсли;
						Иначе 
							ОбъектМодифицирован = Истина;
						КонецЕсли;
					КонецЕсли;
				КонецЕсли;
				
				Если СтрокаТЗ[0].Очистить = Истина Тогда
					Строка = ОбъектРаботы.ДополнительныеРеквизиты.Найти(ВыборкаДетальныеЗаписи.Свойство, "Свойство");
					ОбъектРаботы.ДополнительныеРеквизиты.Удалить(Строка.НомерСтроки - 1);
					ОбъектМодифицирован = Истина;
				КонецЕсли;
				
			КонецЦикла;
			
			Если ОбъектМодифицирован Тогда
				ОбъектРаботы.ОбменДанными.Загрузка = Истина;
				ОбъектРаботы.Записать();
			КонецЕсли;
			
		Исключение
			ТекстОшибки = ОписаниеОшибки();
			ЗаписьЖурналаРегистрации("Обработка доп. реквизитов", УровеньЖурналаРегистрации.Ошибка, ОбъектРаботы.Метаданные(), ОбъектРаботы.Ссылка, ТекстОшибки); 
			Если Останаливать Тогда
				Сообщить("Обработка прервана по ошибке. Посмотрите журнал регистрации");
				Возврат; 
			КонецЕсли;	
		КонецПопытки;
		
	КонецЦикла;
	
	Сообщить("Обработка выполнена успешно");
		
КонецПроцедуры

 

обработка реквизиты дополнительные очистка перенос

См. также

Чистка данных Системный администратор Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 1С:Управление торговлей 10 1С:Управление торговлей 11 Платные (руб)

Данные обработки помогут Вам легко и, главное быстро, выполнить удаление любых данных в Ваших базах 1С на платформах 8.1-8.3. Обработки помогут легко просмотреть связи ссылок в виде дерева, выбрать что удалять, а что нет, используя любые отборы. Это позволит уменьшить объем лишней и не нужной информации в справочниках и документах, планах видов характеристик и др. объектах и облегчит работу с данными пользователям и Вам. Понятное расположение команд и настроек, в сочетании с описанием и справкой, еще упростят процесс. (Обновление от 04.10.2023, версия 4.2)

9600 руб.

22.02.2013    137315    252    144    

423

Чистка данных Системный администратор Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Розница 3.0 Платные (руб)

Позволяет удалить организации из любых из информационных баз 1С на управляемых формах (БП 3.0, УТ 11, КА 2, ERP 2, ЗУП 3.0, УНФ, Розница 2.0 и пр.). Главное требование - программа должна содержать справочник "Организации". Реализован самый быстрый алгоритм непосредственного удаления объектов. Работает даже на базах большого размера. Для ускорения работы алгоритма не запускается проверка контроля ссылочной целостности. Проверку учета можно запустить отдельно с помощью дополнительной обработки. Необходимо перед удалением самостоятельно проверить базу на наличие перекрестных ссылок разных организаций в одном документе. Эту дополнительную обработку проверки перекрестных ссылок по запросу предоставляем бесплатно нашим покупателям.

3582 руб.

16.03.2015    124400    188    77    

225

Чистка данных Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Платные (руб)

Данные обработки помогут Вам быстро и просто выполнить перезапись любых ссылочных объектов, а также провести/снять с проведения документы с возможностью выбора регистров и произвольными отборами, в Ваших базах 1С на платформах 8.1-8.3. Обработка позволят найти документы с движениями или без них. Все это дает Вам мощный инструмент для работы. Понятное расположение команд и настроек, в сочетании с описанием и справкой, еще упростят процесс. А также обновления Вы получаете бесплатно в течение года с момента приобретения данных обработок! Данные обработки входят в ТОП-100 продаж, что является залогом популярности, надежности в работе, и признанием других покупателей.

7200 руб.

17.09.2013    804098    56    51    

93

Чистка данных Программист Пользователь Платформа 1С v8.3 Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Зарплата и кадры государственного учреждения 3 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Платные (руб)

Обработка позволяет удобно и выборочно удалить данные из базы 1С. Это могут быть как неиспользуемые элементы справочников, так и неактуальные организации. При этом есть возможность провести анализ пересечений документов с другими организациями и таким образом уберечься от того, что при удалении обороты по другой организации изменятся.

3350 руб.

28.11.2019    25069    51    16    

66

Оптовая торговля Логистика, склад и ТМЦ Чистка данных Программист Бухгалтер Пользователь Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Если вы начали работать в программном продукте Управление Торговлей, редакция 11 или Комплексная Автоматизация редакция 2 и включили механизм учёта серий, то перейти обратно в учёт без серий будет не так-то просто. Сложность заключается в том, что нужно очистить серии в табличной части документа, например, Реализация Товаров и услуг. Предлагаем алгоритм перехода на учет без серий для программного продукта «Управление торговлей» редакция 11. (Очистка серий.)

2400 руб.

09.04.2019    28617    40    14    

42

Чистка данных Программист Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Если в вашей информационной базе крутится очень много данных, или база должна быть доступна 24/7 (как в моем случае), или же вы боитесь запускать тестирование и исправление, НО существует потребность удалить битые ссылки, тогда эта обработка сможет Вам помочь. Обработка выявляет битые ссылки как в самих объектах метаданных, так и в их табличных частях(!), а так же может их удалить.

2400 руб.

23.08.2021    9582    16    3    

22

Чистка данных Системный администратор Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Такое бывает? Удалили документ, а проводки (движения) остались? Эта простая обработка решает данную проблему.. почему по проводкам? да потому что обычно такие вещи замечают именно бухгалтера.на самом же деле данная обработка при нахождении документа удаленного или помеченного на удаление и имеющего движения очищает все движения без исключений.

1200 руб.

06.02.2012    36009    362    30    

31

Чистка данных Системный администратор Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

в современных конфигурациях стало очень много регистров сведений, хранящих вспомогательную и периодическую информацию и администраторы информационных систем стали сталкиваться с проблемой удаления помеченных на удаление объектов, так как ссылки на них хранятся в многочисленных регистрах сведений. Помочь почистить базу от ненужных записей предназначенная данная внешняя обработка на управляемой форме, которая ищет записи во всех регистрах сведений по помеченным на удаление объектах и очищает по ним записи их после использования данной обработки дальше можно смело пользоваться типовой обработкой удаление помеченных на удаление и проблем с удалением не возникнет! Удачи всем!

1200 руб.

21.01.2022    7449    6    6    

11
Оставьте свое сообщение