Разбиение произвольного периода на интервалы с исключением дат

02.02.22

Разработка - Универсальные функции

Аналог функции РазложитьНаПериоды, но мне нужно было исключить из этого периода список дат между начальной и конечной датой.

Скачать исходный код

Наименование Файл Версия Размер
Разбиение произвольного периода на интервалы с исключением дат:
.7z 4,88Kb
0
.7z 4,88Kb Скачать

Не нашел решение данной задачи на просторах интернета.

Есть выбранный период, из которого нужно исключить даты, тем самым будут подпериоды без этих дат. Решение считаю не идеальным. Думал, получится за один проход циклом, но получилось аж в 2 процедуры. Возможно, будет предложено более простое решение. Во вложении обработка (см. картинку) с тем же самым алгоритмом.

Функция РазбитьПериодИсключениемДат(ДатаНачала, ДатаОкончания, ТЗИсключенияДат)

    ТЗ = Новый ТаблицаЗначений;
    ТЗ.Колонки.Добавить("Дата");
    ТЗ.Колонки.Добавить("ЭтоИсключение");  	
	
	ТЗПериоды = Новый ТаблицаЗначений;
	ТЗПериоды.Колонки.Добавить("ДатаНачала");  
	ТЗПериоды.Колонки.Добавить("ДатаОкончания"); 
	
	ПериодДатаНачала    = ДатаНачала;
	ПериодДатаОкончания = ДатаОкончания; 
	
	//Заполним таблицу ТЗ с отметкой дат которые нам не нужны
	Пока ПериодДатаНачала <= ПериодДатаОкончания Цикл 	
		
		НоваяСтрока = ТЗ.Добавить();
		НоваяСтрока.Дата = ПериодДатаНачала;
		
		МассивСтрокДата = ТЗИсключенияДат.НайтиСтроки(Новый Структура("Период", ПериодДатаНачала));					
		Если МассивСтрокДата.Количество() > 0 Тогда 
			НоваяСтрока.ЭтоИсключение = Истина;	
		Иначе 		
			НоваяСтрока.ЭтоИсключение = Ложь;				
		КонецЕсли;
		
		ПериодДатаНачала = НачалоДня(КонецДня(ПериодДатаНачала) + 1);
	КонецЦикла;	  
	
	//Обходим заполненную таблицу ТЗ
	Индекс = 0;  
	КоличествоСтрок = ТЗ.Количество() - 1;
	Пока Индекс <= КоличествоСтрок Цикл 
		
		ТекущаяСтрока = ТЗ[Индекс];  
		
		Если ТекущаяСтрока.ЭтоИсключение = Истина Тогда 
			Индекс = Индекс + 1;			
		Иначе  
			ПериодНачала = НачалоДня(ТекущаяСтрока.Дата); 			
			ИндексДатаОкончания = ПолучитьИндексДатаОкончания(ТЗ, Индекс, КоличествоСтрок);
			ПериодОкончания = НачалоДня(ТЗ[ИндексДатаОкончания].Дата); 
			
			НоваяСтрока = ТЗПериоды.Добавить();
			НоваяСтрока.ДатаНачала    = ПериодНачала;
			НоваяСтрока.ДатаОкончания = ПериодОкончания;
			
			Индекс = ИндексДатаОкончания + 1;
		КонецЕсли;				
		
	КонецЦикла;  
	
	Возврат ТЗПериоды;

КонецФункции 

Функция ПолучитьИндексДатаОкончания(ТЗ, Индекс, КоличествоСтрок)
	
	ИндексДатаОкончания = 0;
	Пока Индекс <= КоличествоСтрок Цикл 		
		ТекущаяСтрока = ТЗ[Индекс];    	
		Если ТекущаяСтрока.ЭтоИсключение = Истина Тогда 
			ИндексДатаОкончания = Индекс - 1;	
			Прервать; 
		Иначе 
			ИндексДатаОкончания = Индекс;	
		КонецЕсли;	
		Индекс = Индекс + 1;
	КонецЦикла;  
	                           
	Возврат ИндексДатаОкончания; 
	
КонецФункции   
	

Обработка протестирована на: Зарплата и управление персоналом, Зарплата и кадры государственного учреждения, редакция 3.1 (3.1.20.97), платформа: 1С:Предприятие 8.3 (8.3.19.1229). Но можно использовать и в других конфигурациях на управляемых формах.

обработка разложить на периоды

См. также.

Универсальные функции Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Благодаря этим пяти строчкам можно больше не заморачиваться с загрузкой из внешних файлов. Пользуюсь везде, всегда и постоянно.

21.05.2024    9973    dimanich70    79    

119

Универсальные функции Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Задача: вставить картинку из буфера обмена на форму средствами платформы 1С.

1 стартмани

18.03.2024    3253    3    John_d    11    

57

Универсальные функции Программист Стажер Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Пришлось помучиться с GUID-ами немного, решил поделиться опытом, мало ли кому пригодится.

12.02.2024    7033    atdonya    22    

55

Универсальные функции Программист Платформа 1С v8.3 Бесплатно (free)

На заключительных этапах, когда идет отладка или доработка интерфейса, необходимо много раз переоткрыть внешний объект. Вот один из способов автоматизации этого.

30.11.2023    4589    ke.92@mail.ru    16    

64

WEB-интеграция Универсальные функции Механизмы платформы 1С Программист Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

При работе с интеграциями рано или поздно придется столкнуться с получением JSON файлов. И, конечно же, жизнь заставит проверять файлы перед тем, как записывать данные в БД.

28.08.2023    10811    YA_418728146    7    

149

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2641    40    progmaster    8    

4

Инструментарий разработчика Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Копирует в буфер значения из списков, из ячеек отчетов, таблиц, настроек списков, других отборов и вставляет в выбранную настройку отбора. Работает с Объект не найден. Работает как в одной так и между разными базами 1С. Использует комбинации [Alt+C] Копировать список, [Alt+V] Вставить список. Также для копирования данных используется стандартная [Ctrl+C] (например из открытого xls, mxl, doc и т.п. файла скопировать список наименований)

1 стартмани

13.10.2022    16976    151    sapervodichka    112    

133
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. ixijixi 1825 02.02.22 11:02 Сейчас в теме
Надо ildarovichа звать. Мне в похожей теме https://infostart.ru/public/147834/ быстро код оптимизировали)
4. dendzu 88 02.02.22 12:41 Сейчас в теме
(1)Да тоже видел эту статью когда решал этот вопрос.
2. it@contlog.ru 02.02.22 12:32 Сейчас в теме
Это можно и запросом сделать.
3. dendzu 88 02.02.22 12:41 Сейчас в теме
(2)Запросом подумал вообще повязну...
Оставьте свое сообщение