Автоприкрепление документов в ДИАДОК

20.02.23

Интеграция - ЭДО и ОФД

"А можно, чтоб подписанные контрагентом документы сами в присоединённые файлы добавлялись?" Ответ сотрудников Диадок: можно. С вас 53 000 (с год назад) или ну хотя бы 30 000 (на днях) ... ага, деньги вы заплатили ... и полная база со всеми доступами, иначе мы пальцем не пошевелим!" Мой ответ: можно. Забирайте.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки для того, чтобы самостоятельно ее доработать для вашей базы данных. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в вашей базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке Купить один файл
Автоприкрепление документов в ДИАДОК:
.txt 7,26Kb
15
15
1 SM
Скачать Купить за 1 850 руб.

Процедуры предназначены для добавления в модуль ФормаУправляемая того модуля Диадок, который внешняя обработка (и для лишения дохода тех, кто сначала требует оплатить счёт, а потом ставит условия вразрез с политикой конфиденциальности). Тестировалось на модуле 4.28.1, БП 3.0.130.22.

Что умеют:

Автоматом прикреплять pdf по всем документам, которые считаны с сервера, с отбором (по умолчанию) по статусу "Подписан контрагентом", а дальше как сами захотите.

Используют процедуры модуля "Ядро", то есть надо послеживать за их синтаксисом.

Ориентируются на СписокДокументов в обработке, но можно и передать в функцию аналогичную таблицу.

Вызов: втыкаете ПроверитьОбновитьПрисоединенныеФайлы() туда, где вам нравится. Я воткнула после обновления списка документов. Всё можно сделать оптимальнее, особенно если вы узнаете, как достучаться до API Диадока таким образом, чтобы получать таблицу только свежеподписанных.

Желающие получить готовую доработку: выложить на ИС диадоковский модуль я всё равно не могу, ибо авторские права. Но воткнуть уже известное всяко дешевле!

Главная процедура (для затравки - а сапиенти и без прочего сат):
 

&НаСервере
Процедура ПроверитьОбновитьПрисоединенныеФайлы()      
	Для каждого стросп из Объект.СписокДокументов Цикл  
		Если не стросп.Статус="Подписан контрагентом" Тогда Продолжить; КонецЕсли;
		Если не ЗначениеЗаполнено(стросп.Документ) Тогда Продолжить; КонецЕсли;
		//Тут можно добавить условия - по виду объектов, ещё по чему-то
		ИмяФайлаПечатнойФормы = стросп.ПредставлениеДокументаДиадок + " - " + стросп.DocumentId + ".pdf"; 
		ВладелецФайла=стросп.Документ;
		ПереопределитьВладельцаФайла(ВладелецФайла); //здесь мы можем изменить владельца как нам угодно
		Если ПрикрепленныйФайлСуществует(ВладелецФайла,ИмяФайлаПечатнойФормы) Тогда Продолжить; КонецЕсли; //не обновляем
		ОписаниеФайла="подписал документ и завершил документооборот";
		Документ = ДокументИзДанныхСтрокиТЧ(стросп); //вызов процедуры модуля той же ФормаУправляемая
	 	ДвоичныеДанныеПечатнойФормы = Модуль_ЯдроНаСервере().Документы_ПечатнаяФормаСервераДиадок(Документ.Идентификаторы);
		ПрисоединитьФайлПДФ(ВладелецФайла,ДвоичныеДанныеПечатнойФормы,ИмяФайлаПечатнойФормы,ОписаниеФайла);
	КонецЦикла;
КонецПроцедуры


P.S. Кусок кода прикрепления файла через БСП честно упёрт отсюда: https://bv-dev.ru/1c-software-attachment-of-a-file-to-document/ - у меня был свой вызов, но чуть длиннее.

P.P.S. Возможно, проверка наличия присоединённого файла тоже оптимизируется, но пользователей уже устраивает, а премию ещё не дали.

P.P.P.S. Полагаю, в расширение оно втыкается примерно с той же степенью сложности, но - см.выше. 

P.P.P.P.S. О! десять дней спустя "ничего не будем делать без полного доступа к вашей базе" - "вы можете подписать у менеджера соглашение о неразглашении". С этого начинать надо было... а теперь - пользуйтесь на здоровье!

pdf присоединенные файлы Диадок

См. также

SALE! 25%

Кассовые операции Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Программист Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Россия Бухгалтерский учет Налоговый учет Управленческий учет Платные (руб)

В публикации размещены специализированные обработки для загрузки кассовых чеков в базах 1С (для локальных баз): '1С:Бухгалтерия предприятия, ред. 3.0', '1С:Управление нашей фирмой 8, ред. 3.0', '1С:Комплексная автоматизация, ред. 2.5', ‘1С:ERP Управление предприятием, ред. 2’ и ‘1С:Управление торговлей, ред. 11.5’. Вы просто сканируете QR коды с бумажных и электронных чеков c помощью мобильного приложения ФНС и чеки автоматически (без ручного ввода) загружаются в документы 'Авансовый отчет', 'Расходы предпринимателя', 'Путевой лист', 'Приходная накладная', 'Поступление (акты, накладные, УПД)', 'Приобретение товаров и услуг', 'Отчет о розничных продажах' и 'Поступление денежных документов'.

12960 9720 руб.

19.08.2020    66355    312    73    

213

Документооборот и делопроизводство (СЭД) ЭДО и ОФД Учет документов Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Мощный, единый инструмент для решения всех проблем, связанных с переходом на ЭДО. Экономит бумагу и время - организует архив оригиналов первичных документов прямо в базе 1С, в прикрепленных файлах к соответствующим документам. С помощью комплексного отчета по ошибкам в ЭДО позволяет выявить и исправить все возможные ошибки - ошибочно сопоставленные документы, не подписанные документы, подписанные, но не загруженные в 1С документы. Автоматически сопоставляет не сопоставленные между собой документы. Может работать по расписанию и присылать отчет о состоянии архива/по ошибкам на почту. Взаимодействует напрямую с сервисами Диадок/СБИС, имеет интуитивно понятный интерфейс и учитывает 3-х летний опыт 40+ клиентов.

14880 руб.

17.12.2018    44855    62    51    

75

Кассовые операции ЭДО и ОФД Бухгалтер Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Согласно 54-ФЗ по правилам ведения кассовых операций необходимо оформлять приходные кассовые ордера (ПКО) и расходные кассовые ордера (РКО) на основании чеков ККМ. Все данные о чеках, можно взять на сайте оператора фискальных данных (ОФД). Обработка загрузки данных из ОФД в 1С сделает за вас в 1С - ПКО и РКО, Операции по платежным картам или Отчет о розничных продажах (может создать номенклатуру в 1С, указать налоги и др. реквизиты в документах в зависимости от налогообложения ККМ в торговой точке). Проверено на: OFD.RU / Первый ОФД / Такском / Платформа ОФД / Ярус / ОФД Яндекс / ОФД Астрал /ОФД СБИС / Гарант ОФД / КОРУС ОФД / КОНТУР ОФД / ОФД АО Тандер / ИнитПро / Группа Элемент/

3600 руб.

09.08.2017    149140    876    372    

532

Оптовая торговля Производство готовой продукции (работ, услуг) Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Бухгалтер Платформа 1С v8.3 Бухгалтерский учет Управляемые формы 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Выгрузка УПД, товарной накладной ТОРГ-12, акта, счета-фактуры по реализации (в БП сч-ф на аванс) в xml-файл в формате ФНС приказ 820 от 19.12.2018. Выгрузка УКД и корректировочного счета-фактуры в xml-файл в формате ФНС приказ 736 от 12.10.2020. Выгрузка товарной накладной в xml-файл ФНС приказ 551 от 13.11.2015, редакция 08.04.2019. Выгрузка акта приемки-сдачи работ (услуг) в xml-файл ФНС приказ 552 от 13.11.2015, редакция 08.04.2019. Добавлена выгрузка счетов на оплату по документам ЗаказПокупателя (в УНФ), ЗаказКлинета (в УТ / КА / ERP), СчетНаОплатуПокупателю (в БП). Добавлена обработка Выгрузка УПД c документов реализации 1С в Контур.Диадок по API.

15600 руб.

13.04.2018    83080    394    9    

429

Регламентированный учет и отчетность Обмен с ГосИС ЭДО и ОФД Бухгалтер Пользователь Платформа 1С v8.3 1С:Управление торговлей 11 Оптовая торговля, дистрибуция, логистика Россия Управленческий учет Платные (руб)

Работаете по контрактной схеме, сталкивались с проблемой, что в контракте жестко указаны наименование, цена, единица измерения товара. И не все готовы создавать новую номенклатуру под каждый контракт или менять наименование и единицу измерения для уже имеющейся. Тем более, бывает так, что контракт - это формальность. Контракт не описывает жесткие условия поставки, нужно соблюсти правильность в предоставлении документов. Данное решение позволит вам оперировать своей номенклатурой при оформлении реализаций по государственному контракту в УТ 11.5 и КА 2.5.11, в то же время выводить на печать документы, соответствующие данным контракта. Реализована выгрузка для сайта госзакупок (ЕИС) по 44-ФЗ.

40800 руб.

19.12.2022    10726    20    19    

17

ЭДО и ОФД Файловый обмен (TXT, XML, DBF), FTP Обмен с ГосИС Бухгалтер Пользователь Платформа 1С v8.3 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Россия Бухгалтерский учет Платные (руб)

Групповая выгрузка файлов из 1С в формате XML для ЭДО в каталог по приказу №820 ФНС для Контур.Диадок, СБИС и других провайдеров ЭДО. Поддержка УНФ 1.6, УНФ 3.0 Поддержка УТ 10.3, УПП 1.3 Поддержка Розница 2.3 Добавлена выгрузка непосредственно из документа

18000 руб.

15.12.2022    6992    108    26    

18

ЭДО и ОФД Загрузка и выгрузка в Excel Бухгалтер Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Кто получает документы через Контур.ДиаДок (XML файл формат 820) и набивает их вручную в 1С, тот наверняка хотел бы автоматизировать этот процесс. Поддержка конфигураций: Бухгалтерии 3, УПП 1.3, 1С:КА 2.4 и 1С:КА 2.5, УТ10, УТ11.4 и УТ11.5. Выгрузка XML в формате 820 для диадок из БУХ3

3600 руб.

11.02.2020    89878    286    156    

209
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. stsasha87 135 20.02.23 17:52 Сейчас в теме
Поделюсь тоже своими раскопками. Единственная разница в том, что к документу прикрепляется архив, внутри которого подписанный pdf и сами файлы подписей.
Вызываю из модуля объекта обработки из процедуры СписокДокументов_Обновить.
Через подключаемый модуль, увы, не сделать это.
Вот урезанный кусок кода для примера:

Код
cleaner_it; e.kogan; Yashazz; sapervodichka; +4 Ответить
4. e.kogan 1893 21.02.23 20:56 Сейчас в теме
(1) Я тоже подумывала туда воткнуться, но решила, что хватит и текущего )
2. tpkpsd 21.02.23 10:04 Сейчас в теме
Одно время играл в догонялки с их отделом разработки, втыкая свои вставки в очередные релизы. Психанул, воткнул во внешний модуль.
Я похожую задачу воткнул в регламент
Обработка = ВнешниеОбработки.Создать("путь к Диадок 1С.epf", Ложь);
Обработка.ИнициализироватьОбщийКонтекст();
Ядро = Обработка.Модуль_Ядро();
         
Ядро.Авторизация_ПоПаролю(Логин, Пароль);
Ядро.КонтекстСеанса_ДляСлужебнойУчетнойЗаписи();

Ядро.ТипыДокументовAPI_ПроверитьНаличие();  

ПараметрыСписка = Ядро.Контракт_ПараметрыПолученияСпискаДокументов();
ПараметрыСписка.Режим                      = "ОтправленныеДокументы";
ПараметрыСписка.НачалоПериода              = НачалоДня(Дата);
ПараметрыСписка.КонецПериода               = КонецДня(ТекущаяДата());
ПараметрыСписка.ПоказыватьЗавершенные      = Ложь;
ПараметрыСписка.РежимОтбораПоПериоду       = "ПоДатеОтправкиИлиПолучения";
ПараметрыСписка.ВключитьОтборПоОрганизации = Ложь;
ПараметрыСписка.ВключитьОтборПоКонтрагенту = Ложь;
ПараметрыСписка.ВключитьОтборПоСтатусу     = Истина;
ПараметрыСписка.ОтборПоСтатусу             = "Подписан контрагентом";

СтруктураДокумента = Новый Структура;
СтруктураДокумента.Вставить("BoxId", НашИдОтправителя); 

СписокДокументов = Ядро.СписокДокументов_Документы(ПараметрыСписка);

Для Каждого х ИЗ СписокДокументов Цикл    
  СтруктураДокумента.Вставить("DocumentId", х.DocumentId);
  СтруктураДокумента.Вставить("LetterId",   х.LetterId);    
  ПечатнаяФорма = Ядро.Документы_ПечатнаяФормаСервераДиадок(СтруктураДокумента); //пдф
КонецЦикла;
    
Обработка.ЗавершитьРаботуМодуля();
Показать
Maksis; cleaner_it; e.kogan; stsasha87; +4 Ответить
3. stsasha87 135 21.02.23 17:44 Сейчас в теме
(2) В идеале хотелось тоже что-то подобное, но не получилось, т.к. в базе много организаций и авторизация у всех в обработке по сертификату происходит. А это код на клиенте, его в рег задание не засунуть((
5. tpkpsd 22.02.23 08:11 Сейчас в теме
(3) 1) процепите логин:пасс на сертификат (у меня так)
2) установить криптопро на сервак и играйте отпечатками
ubnkfl; e.kogan; +2 Ответить
Оставьте свое сообщение