Автоприкрепление документов в ДИАДОК

20.02.23

Интеграция - ЭДО и ОФД

"А можно, чтоб подписанные контрагентом документы сами в присоединённые файлы добавлялись?" Ответ сотрудников Диадок: можно. С вас 53 000 (с год назад) или ну хотя бы 30 000 (на днях) ... ага, деньги вы заплатили ... и полная база со всеми доступами, иначе мы пальцем не пошевелим!" Мой ответ: можно. Забирайте.

Скачать файлы

Наименование Файл Версия Размер
Автоприкрепление документов в ДИАДОК:
.txt 7,26Kb
13
.txt 7,26Kb 13 Скачать

Процедуры предназначены для добавления в модуль ФормаУправляемая того модуля Диадок, который внешняя обработка (и для лишения дохода тех, кто сначала требует оплатить счёт, а потом ставит условия вразрез с политикой конфиденциальности). Тестировалось на модуле 4.28.1, БП 3.0.130.22.

Что умеют:

Автоматом прикреплять pdf по всем документам, которые считаны с сервера, с отбором (по умолчанию) по статусу "Подписан контрагентом", а дальше как сами захотите.

Используют процедуры модуля "Ядро", то есть надо послеживать за их синтаксисом.

Ориентируются на СписокДокументов в обработке, но можно и передать в функцию аналогичную таблицу.

Вызов: втыкаете ПроверитьОбновитьПрисоединенныеФайлы() туда, где вам нравится. Я воткнула после обновления списка документов. Всё можно сделать оптимальнее, особенно если вы узнаете, как достучаться до API Диадока таким образом, чтобы получать таблицу только свежеподписанных.

Желающие получить готовую доработку: выложить на ИС диадоковский модуль я всё равно не могу, ибо авторские права. Но воткнуть уже известное всяко дешевле!

Главная процедура (для затравки - а сапиенти и без прочего сат):
 

&НаСервере
Процедура ПроверитьОбновитьПрисоединенныеФайлы()      
	Для каждого стросп из Объект.СписокДокументов Цикл  
		Если не стросп.Статус="Подписан контрагентом" Тогда Продолжить; КонецЕсли;
		Если не ЗначениеЗаполнено(стросп.Документ) Тогда Продолжить; КонецЕсли;
		//Тут можно добавить условия - по виду объектов, ещё по чему-то
		ИмяФайлаПечатнойФормы = стросп.ПредставлениеДокументаДиадок + " - " + стросп.DocumentId + ".pdf"; 
		ВладелецФайла=стросп.Документ;
		ПереопределитьВладельцаФайла(ВладелецФайла); //здесь мы можем изменить владельца как нам угодно
		Если ПрикрепленныйФайлСуществует(ВладелецФайла,ИмяФайлаПечатнойФормы) Тогда Продолжить; КонецЕсли; //не обновляем
		ОписаниеФайла="подписал документ и завершил документооборот";
		Документ = ДокументИзДанныхСтрокиТЧ(стросп); //вызов процедуры модуля той же ФормаУправляемая
	 	ДвоичныеДанныеПечатнойФормы = Модуль_ЯдроНаСервере().Документы_ПечатнаяФормаСервераДиадок(Документ.Идентификаторы);
		ПрисоединитьФайлПДФ(ВладелецФайла,ДвоичныеДанныеПечатнойФормы,ИмяФайлаПечатнойФормы,ОписаниеФайла);
	КонецЦикла;
КонецПроцедуры


P.S. Кусок кода прикрепления файла через БСП честно упёрт отсюда: https://bv-dev.ru/1c-software-attachment-of-a-file-to-document/ - у меня был свой вызов, но чуть длиннее.

P.P.S. Возможно, проверка наличия присоединённого файла тоже оптимизируется, но пользователей уже устраивает, а премию ещё не дали.

P.P.P.S. Полагаю, в расширение оно втыкается примерно с той же степенью сложности, но - см.выше. 

P.P.P.P.S. О! десять дней спустя "ничего не будем делать без полного доступа к вашей базе" - "вы можете подписать у менеджера соглашение о неразглашении". С этого начинать надо было... а теперь - пользуйтесь на здоровье!

pdf присоединенные файлы Диадок

См. также

Расширение для работы с ЭДО и сервисами: Диадок, СБИС, ЭДО Лайт, Signatura.pro, Астрал.ЭДО, Честный Знак и др. Поддержка МЧД для СБИС и Диадок. Для обычных форм - внешняя обработка. Поддержка Linux.

ЭДО и ОФД Обмен с ГосИС 8.3.14 1С:Управление торговлей 10 Бухгалтерский учет Управленческий учет Платные (руб)

Рабочее место для работы с ЭДО из 1С : Диадок, СБИС, ЭДО Лайт (Lite), Signatura.pro, Астрал.ЭДО, ГИС МТ (Честный знак, ЦРПТ). Создание УПД, УКД, ТОРГ12, Акта и отправка сразу из 1С (сохранение в файл и последующая загрузка через личный кабинет не требуется). Также поддерживается: отправка печатных форм, произвольных файлов, подписание, отклонение, аннулирование документов. Поддержка МЧД для СБИС и Диадок.

3600 руб.

16.12.2020    33610    241    196    

70

SALE! 25%

Загрузка чеков ФНС в документы 1С:БП, 1С:УНФ, 1С:ERP, 1С:КА, 1С:УТ и 1С:БГУ 2.0

Кассовые операции Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Россия Бухгалтерский учет Налоговый учет Управленческий учет Платные (руб)

В публикации размещены специализированные обработки для загрузки чеков в базах 1С (для локальных баз): '1С:Бухгалтерия предприятия, ред. 3.0', '1С:Управление нашей фирмой 8, ред. 3.0', '1С:Комплексная автоматизация, ред. 2.5', ‘1С:ERP Управление предприятием, ред. 2’ и ‘1С:Управление торговлей, ред. 11.5’. Вы просто сканируете QR коды с бумажных и электронных чеков c помощью мобильного приложения ФНС и чеки автоматически (без ручного ввода) загружаются в документы 'Авансовый отчет', 'Расходы предпринимателя', 'Путевой лист', 'Приходная накладная', 'Поступление (акты, накладные, УПД)', 'Приобретение товаров и услуг', 'Отчет о розничных продажах' и 'Поступление денежных документов'.

12960 9979 руб.

19.08.2020    60484    256    72    

184

Загрузка в 1С:Бухгалтерию 3.0, 1С:КА 2.4, 2.5, УНФ 1.6/3.0 данных из ОФД о денежных поступлениях (чеках)

Кассовые операции ЭДО и ОФД Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Согласно 54-ФЗ по правилам ведения кассовых операций необходимо оформлять приходные кассовые ордера (ПКО) и расходные кассовые ордера (РКО) на основании чеков ККМ. Все данные о чеках, можно взять на сайте оператора фискальных данных (ОФД). Эта обработка сделает за вас в 1С - ПКО и РКО, Операции по платежным картам или Отчет о розничных продажах (может создать номенклатуру в 1С, указать налоги и др. реквизиты в документах в зависимости от налогообложения ККМ в торговой точке). Проверено на: OFD.RU / Первый ОФД / Такском / Платформа ОФД / Ярус / ОФД Яндекс / ОФД Астрал /ОФД СБИС / Гарант ОФД / КОРУС ОФД / КОНТУР ОФД / ОФД АО Тандер / ИнитПро / Группа Элемент/

5640 руб.

09.08.2017    144102    826    371    

503

Выгрузка УПД реализации в xml ФНС для загрузки в ЭДО: Диадок, СБИС, Такском, КОРУС, Астрал и прочие. Обработка на управляемых формах для БП 3.0, УНФ 1.6 / 3.0, УТ 11.4 / 11.5, КА 2, ERP 2 (Приказ ФНС №820 от 19.12.2018, 736 от 12.10.2020)

Оптовая торговля Производство готовой продукции (работ, услуг) Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Платформа 1С v8.3 Бухгалтерский учет Управляемые формы 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Выгрузка УПД, товарной накладной ТОРГ-12, акта, счета-фактуры по реализации (в БП сч-ф на аванс) в xml-файл в формате ФНС приказ 820 от 19.12.2018. Выгрузка УКД и корректировочного счета-фактуры в xml-файл в формате ФНС приказ 736 от 12.10.2020. Выгрузка товарной накладной в xml-файл ФНС приказ 551 от 13.11.2015, редакция 08.04.2019. Выгрузка акта приемки-сдачи работ (услуг) в xml-файл ФНС приказ 552 от 13.11.2015, редакция 08.04.2019. Добавлена выгрузка счетов на оплату по документам ЗаказПокупателя (в УНФ), ЗаказКлинета (в УТ / КА / ERP), СчетНаОплатуПокупателю (в БП).

9600 руб.

13.04.2018    79557    379    9    

419

Загрузка документов поступления в 1С из XML формата 820 (Контур.Диадок) для УТ10, УТ11, Бух3, КА2, КА2.5, УПП1.3 и обработка выгрузки УПД в Контур Диадок и СБИС для 1С:Бухгалтерии 3

ЭДО и ОФД Загрузка и выгрузка в Excel Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Кто получает документы через Контур.ДиаДок (XML файл формат 820) и набивает их вручную в 1С, тот наверняка хотел бы автоматизировать этот процесс. Поддержка конфигураций: Бухгалтерии 3, УПП 1.3, 1С:КА 2.4 и 1С:КА 2.5, УТ10, УТ11.4 и УТ11.5. Выгрузка XML в формате 820 для диадок из БУХ3

3600 руб.

11.02.2020    84902    259    155    

176

Заполнение авансовых отчетов и поступлений товаров по онлайн-чекам ФНС [Расширение для БП, КА2, ERP, УТ]

ККМ ЭДО и ОФД Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Бухгалтерский учет Платные (руб)

Позволяет загружать онлайн чеки в формате JSON из официального мобильного приложения "Проверка чеков ФНС" и заполнять документы «Авансовый отчет» и «Приобретение товаров». Помощник заполнения поможет найти /создать номенклатуру и номенклатуру поставщика по указанным настройкам и перенесет данные чеков в документы учетной системы. Данные чеков из мобильного приложения можно выгружать как по каждому чеку в отдельности, так и выпиской за период.

5400 руб.

09.06.2020    29546    107    39    

99

ЭДО: организация архива оригиналов первичных документов, комплексный отчет по ошибкам

Документооборот и делопроизводство (СЭД) ЭДО и ОФД Учет документов Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Мощный, единый инструмент для решения всех проблем, связанных с переходом на ЭДО. Экономит бумагу и время - организует архив оригиналов первичных документов прямо в базе 1С, в прикрепленных файлах к соответствующим документам. С помощью комплексного отчета по ошибкам в ЭДО позволяет выявить и исправить все возможные ошибки - ошибочно сопоставленные документы, не подписанные документы, подписанные, но не загруженные в 1С документы. Автоматически сопоставляет не сопоставленные между собой документы. Может работать по расписанию и присылать отчет о состоянии архива/по ошибкам на почту. Взаимодействует напрямую с сервисами Диадок/СБИС, имеет интуитивно понятный интерфейс и учитывает 3-х летний опыт 40+ клиентов.

14880 руб.

17.12.2018    42944    49    51    

65
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. stsasha87 135 20.02.23 17:52 Сейчас в теме
Поделюсь тоже своими раскопками. Единственная разница в том, что к документу прикрепляется архив, внутри которого подписанный pdf и сами файлы подписей.
Вызываю из модуля объекта обработки из процедуры СписокДокументов_Обновить.
Через подключаемый модуль, увы, не сделать это.
Вот урезанный кусок кода для примера:

Код
cleaner_it; e.kogan; Yashazz; sapervodichka; +4 Ответить
4. e.kogan 1886 21.02.23 20:56 Сейчас в теме
(1) Я тоже подумывала туда воткнуться, но решила, что хватит и текущего )
2. tpkpsd 21.02.23 10:04 Сейчас в теме
Одно время играл в догонялки с их отделом разработки, втыкая свои вставки в очередные релизы. Психанул, воткнул во внешний модуль.
Я похожую задачу воткнул в регламент
Обработка = ВнешниеОбработки.Создать("путь к Диадок 1С.epf", Ложь);
Обработка.ИнициализироватьОбщийКонтекст();
Ядро = Обработка.Модуль_Ядро();
         
Ядро.Авторизация_ПоПаролю(Логин, Пароль);
Ядро.КонтекстСеанса_ДляСлужебнойУчетнойЗаписи();

Ядро.ТипыДокументовAPI_ПроверитьНаличие();  

ПараметрыСписка = Ядро.Контракт_ПараметрыПолученияСпискаДокументов();
ПараметрыСписка.Режим                      = "ОтправленныеДокументы";
ПараметрыСписка.НачалоПериода              = НачалоДня(Дата);
ПараметрыСписка.КонецПериода               = КонецДня(ТекущаяДата());
ПараметрыСписка.ПоказыватьЗавершенные      = Ложь;
ПараметрыСписка.РежимОтбораПоПериоду       = "ПоДатеОтправкиИлиПолучения";
ПараметрыСписка.ВключитьОтборПоОрганизации = Ложь;
ПараметрыСписка.ВключитьОтборПоКонтрагенту = Ложь;
ПараметрыСписка.ВключитьОтборПоСтатусу     = Истина;
ПараметрыСписка.ОтборПоСтатусу             = "Подписан контрагентом";

СтруктураДокумента = Новый Структура;
СтруктураДокумента.Вставить("BoxId", НашИдОтправителя); 

СписокДокументов = Ядро.СписокДокументов_Документы(ПараметрыСписка);

Для Каждого х ИЗ СписокДокументов Цикл    
  СтруктураДокумента.Вставить("DocumentId", х.DocumentId);
  СтруктураДокумента.Вставить("LetterId",   х.LetterId);    
  ПечатнаяФорма = Ядро.Документы_ПечатнаяФормаСервераДиадок(СтруктураДокумента); //пдф
КонецЦикла;
    
Обработка.ЗавершитьРаботуМодуля();
Показать
Maksis; cleaner_it; e.kogan; stsasha87; +4 Ответить
3. stsasha87 135 21.02.23 17:44 Сейчас в теме
(2) В идеале хотелось тоже что-то подобное, но не получилось, т.к. в базе много организаций и авторизация у всех в обработке по сертификату происходит. А это код на клиенте, его в рег задание не засунуть((
5. tpkpsd 22.02.23 08:11 Сейчас в теме
(3) 1) процепите логин:пасс на сертификат (у меня так)
2) установить криптопро на сервак и играйте отпечатками
ubnkfl; e.kogan; +2 Ответить
Оставьте свое сообщение