Работа со списком значений ОБНОВЛЕНО 10.08.09

10.08.09

Разработка - Универсальные функции

Подсистема работы со списком значений (к возможностям стандартной формы работы со списком, возникающей, к примеру, при установке отбора "в списке", добавлена загрузка произвольного набора данных из табличного документа). ПРОВЕРЯЛАСЬ ТОЛЬКО ДЛЯ СКД!

Скачать исходный код

Наименование Файл Версия Размер
РаботаСоСписком.cf
.1237490741 38,85Kb
187
.1237490741 38,85Kb 187 Скачать бесплатно

Подсистема состоит из четырёх общих форм (любители минимизации изменений могут сократить это число до двух), один общий макет и один модуль (опять-таки, можно интегрировать в формы и не переносить модуль). В системе создан один отчёт для примера.

Суть разработки состоит в довольно простом вопросе, часто задаваемом от пользователей: "у меня есть список объектов, хочу посмотреть отчёт только по ним, а в списке сотни строк". Для автоматизации такого рода задач и создана эта подсистема.

Вкратце о её работе:

В форме, содержащей таблицу отбора СКД, в процедуру "При открытии" добавляется пять строчек:

	 Для каждого КолонкаОтбора из ЭлементыФормы.БыстрыйОтбор.Колонки Цикл
    Если Найти(КолонкаОтбора.Имя,"Значение")<>0 и Найти(КолонкаОтбора.Имя,"Дата")=0 Тогда
        КолонкаОтбора.ЭлементУправления.УстановитьДействие("НачалоВыбора",Новый Действие("БыстрыйОтборЗначениеНачалоВыбора"));
    КонецЕсли;
КонецЦикла;
где "БыстрыйОтбор" -  имя элемента формы, связанного с отбором СКД,

и процедура

	 Процедура БыстрыйОтборЗначениеНачалоВыбора(Элемент, СтандартнаяОбработка)
    ДополнительныйРАТ.ОбработатьУстановкуОтбора(ЭтаФорма,Элемент,СтандартнаяОбработка);
КонецПроцедуры
В конфигурацию минимально вставляются две общие формы - ФормаСпискаОтбора и ФормаВводаТаблицы.

Дальнейшее см. образец - Отчет1.

Обновлено (добавлена работа с многотипными списками).

Обновлено 10.08.09 - удалён макет таблицы для загрузки, добавлена процедура в дополнительном модуле, что позволяет сократить добавления в отчёте до минимума строк.

Планируется: установку обработчика для колонки табполя отбора также вынести в дополнительный модуль (пока не проверяла, возможно ли это).

 

P.S. Конечно, это можно оптимизировать! Но именно сейчас времени на это у меня нет.

P.P.S. Будет время - отшлифую, а пока НИЧЕГО дорабатываться мной не будет.

P.P.P.S. Но за конструктивные замечания - спасибо.

См. также

Вставляем картинку из буфера обмена (платформа 1С 8.3.24)

Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Задача: вставить картинку из буфера обмена на форму средствами платформы 1С.

1 стартмани

18.03.2024    2881    2    John_d    11    

56

GUID в 1С 8.3 - как с ними быть

Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

Пришлось помучиться с GUID-ами немного, решил поделиться опытом, мало ли кому пригодится.

12.02.2024    5028    atdonya    22    

51

Переоткрытие внешних обработок

Универсальные функции Платформа 1С v8.3 Бесплатно (free)

На заключительных этапах, когда идет отладка или доработка интерфейса, необходимо много раз переоткрыть внешний объект. Вот один из способов автоматизации этого.

30.11.2023    4099    ke.92@mail.ru    16    

62

Валидация JSON через XDTO (включая массивы)

WEB-интеграция Универсальные функции Механизмы платформы 1С Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

При работе с интеграциями рано или поздно придется столкнуться с получением JSON файлов. И, конечно же, жизнь заставит проверять файлы перед тем, как записывать данные в БД.

28.08.2023    9365    YA_418728146    6    

143

Печать непроведенных документов для УТ, КА, ERP. Настройка печати по пользователям, документам и печатным формам

Пакетная печать Печатные формы Адаптация типовых решений Универсальные функции Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Расширение для программ 1С:Управление торговлей, 1С:Комплексная автоматизация, 1С:ERP, которое позволяет распечатывать печатные формы для непроведенных документов. Можно настроить, каким пользователям, какие конкретные формы документов разрешено печатать без проведения документа.

2 стартмани

22.08.2023    2218    24    progmaster    7    

3

Расширение: Быстрые отборы через буфер [Alt+C] Копировать список, [Alt+V] Вставить список, [Ctrl+C] Копировать из файлов

Инструментарий разработчика Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 1С:Розница 2 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Копирует в буфер значения из списков, из ячеек отчетов, таблиц, настроек списков, других отборов и вставляет в выбранную настройку отбора. Работает с Объект не найден. Работает как в одной так и между разными базами 1С. Использует комбинации [Alt+C] Копировать список, [Alt+V] Вставить список. Также для копирования данных используется стандартная [Ctrl+C] (например из открытого xls, mxl, doc и т.п. файла скопировать список наименований)

1 стартмани

13.10.2022    16342    142    sapervodichka    112    

130

Система контроля ведения учета [БСП]

Универсальные функции Механизмы типовых конфигураций БСП (Библиотека стандартных подсистем) Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

В данном материале рассмотрим типовой алгоритм подсистемы контроля учета БСП в конфигурациях на примерах.

18.07.2022    7349    quazare    8    

110
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. tsd 105 21.03.09 07:51 Сейчас в теме
Ежели я правильно понял, то мы, типа один раз список сотнями строк заполним, а потом будем из этого списка автоматически в филтры любых отчетов подставлять?

А сделать в справочниках иерархически упорядоченную структуру что мешает? И в филтры отчетов выбирать не сотни позиций, а десяток групп от силы.
+
2. e.kogan 1892 23.03.09 11:18 Сейчас в теме
Знаете, есть такие справочники и такие позиции, которые в группы не объединишь. Никак. Принципиально. А пользователю отчёт почему-то именно по ним потребовался.
+
Оставьте свое сообщение