Прием оплаты (денежные средства к поступлению) в 1С: Розница

29.12.23

Учетные задачи - Кассовые операции

Обработка автоматизирует процесс "Принять оплату" (формирования ПКО) по документам "Выемка ДС из кассы ККМ", которые скопились на вкладке "Денежные средства к поступлению". Для 1С: Розница редакции 2.3! В публикации есть информация для самостоятельного создания обработки!

Скачать исходный код

Наименование Файл Версия Размер
1С Розница - Принять оплату (Денежные средства к поступлению):
.epf 13,77Kb
0
.epf 13,77Kb Скачать

В конфигурации 1С:Розница при "Выемке денежных средств из кассы ККМ" создается одноименный документ. Эти деньги необходимо принять в кассу магазина (организации). Для этого нужно создать приходный кассовый ордер (принять оплату).

К сожалению, если по каким-то причинам на вкладке "Денежные средства к поступлению" - в журнале "Приходный кассовый ордер" скопилось много документов "Выемка ДС из кассы ККМ", то принимать оплату (ПКО) в ручную - может быть очень утомительно (что в принципе и случилось). В этом случае вам очень поможет обработка, с помощью которой можно автоматизировать процесс "Принять оплату". При этом "ПКО" будет проведён той же  датой что и "Выемка ДС из кассы ККМ".

Создаём обработку, добавляем "ТаблицаФормы" в "Табличные части"

 

 

  • Выбор - Булево
  • Ссылка - ДокументСсылка.ВыемкаДенежныхСредствИзКассыККМ
  • Дата - Дата
  • Номер - Строка
  • Организация - СправочникСсылка.Организации
  • СправочникСсылка.Кассы
  • СуммаКОплате - Число
  • РаспоряжениеОплачено - Булево
  • СуммаДокумента - Число
  • ХозяйственнаяОперацияКПоступлению - ПеречислениеСсылка.ХозяйственныеОперации
  • ДокументыВыемкаДенегСоответствующиеМагазинуКассы - Булево

Для формы создаём четыре команды:

 

 

Сама форма:

 

 
Код:

 

&НаСервере
Процедура ЗаполнитьНаСервере()  
	
	Макет =  РеквизитФормыВЗначение("Объект").ПолучитьМакет("Макет");
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ РАЗРЕШЕННЫЕ
		|	ДенежныеСредстваКПоступлениюНаличныеОбороты.Регистратор КАК Ссылка,
		|	ДенежныеСредстваКПоступлениюНаличныеОбороты.Регистратор.Дата КАК Дата,
		|	ДенежныеСредстваКПоступлениюНаличныеОбороты.Регистратор.Номер КАК Номер,
		|	ДенежныеСредстваКПоступлениюНаличныеОбороты.Организация КАК Организация,
		|	ДенежныеСредстваКПоступлениюНаличныеОбороты.Касса КАК Касса,
		|	ВЫБОР
		|		КОГДА ЕСТЬNULL(ДенежныеСредстваКПоступлениюНаличныеОстатки.СуммаОстаток, 0) > 0
		|			ТОГДА ЕСТЬNULL(ДенежныеСредстваКПоступлениюНаличныеОстатки.СуммаОстаток, 0)
		|		ИНАЧЕ 0
		|	КОНЕЦ КАК СуммаКОплате,
		|	ВЫБОР
		|		КОГДА ЕСТЬNULL(ДенежныеСредстваКПоступлениюНаличныеОстатки.СуммаОстаток, 0) <= 0
		|			ТОГДА ИСТИНА
		|		ИНАЧЕ ЛОЖЬ
		|	КОНЕЦ КАК РаспоряжениеОплачено,
		|	ДенежныеСредстваКПоступлениюНаличныеОбороты.СуммаПриход КАК СуммаДокумента,
		|	ДенежныеСредстваКПоступлениюНаличныеОбороты.Регистратор.ХозяйственнаяОперация КАК ХозяйственнаяОперацияКПоступлению,
		|	ВЫБОР
		|		КОГДА ДенежныеСредстваКПоступлениюНаличныеОбороты.Регистратор ССЫЛКА Документ.ВыемкаДенежныхСредствИзКассыККМ
		|			ТОГДА ВЫБОР
		|					КОГДА ВыемкаДенежныхСредствИзКассыККМ.Магазин = &Магазин
		|						ТОГДА ИСТИНА
		|					КОГДА &Магазин = НЕОПРЕДЕЛЕНО
		|						ТОГДА ИСТИНА
		|					ИНАЧЕ ЛОЖЬ
		|				КОНЕЦ
		|		ИНАЧЕ ИСТИНА
		|	КОНЕЦ КАК ДокументыВыемкаДенегСоответствующиеМагазинуКассы
		|ИЗ
		|	РегистрНакопления.ДенежныеСредстваКПоступлениюНаличные.Обороты(, , Регистратор, {(Организация) КАК Организация, (Касса) КАК Касса}) КАК ДенежныеСредстваКПоступлениюНаличныеОбороты
		|		ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ДенежныеСредстваКПоступлениюНаличные.Остатки(, {(Организация) КАК Организация, (Касса) КАК Касса}) КАК ДенежныеСредстваКПоступлениюНаличныеОстатки
		|		ПО (ДенежныеСредстваКПоступлениюНаличныеОстатки.ДокументПередачи = ДенежныеСредстваКПоступлениюНаличныеОбороты.ДокументПередачи)
		|		ЛЕВОЕ СОЕДИНЕНИЕ Документ.ВыемкаДенежныхСредствИзКассыККМ КАК ВыемкаДенежныхСредствИзКассыККМ
		|		ПО (ВыемкаДенежныхСредствИзКассыККМ.Ссылка = (ВЫРАЗИТЬ(ДенежныеСредстваКПоступлениюНаличныеОбороты.Регистратор КАК Документ.ВыемкаДенежныхСредствИзКассыККМ)))
		|ГДЕ
		|	ДенежныеСредстваКПоступлениюНаличныеОбороты.Регистратор.ХозяйственнаяОперация В (ЗНАЧЕНИЕ(Перечисление.ХозяйственныеОперации.ВыдачаДенежныхСредствВДругуюКассу), ЗНАЧЕНИЕ(Перечисление.ХозяйственныеОперации.ВыдачаДенежныхСредствВДругуюОрганизацию), ЗНАЧЕНИЕ(Перечисление.ХозяйственныеОперации.ВыдачаДенежныхСредствИзКассыККМ), ЗНАЧЕНИЕ(Перечисление.ХозяйственныеОперации.ВнутренняяПередачаДенежныхСредств))
		|	И ВыемкаДенежныхСредствИзКассыККМ.Магазин = &Магазин
		|	И ВЫБОР
		|			КОГДА ЕСТЬNULL(ДенежныеСредстваКПоступлениюНаличныеОстатки.СуммаОстаток, 0) > 0
		|				ТОГДА ЕСТЬNULL(ДенежныеСредстваКПоступлениюНаличныеОстатки.СуммаОстаток, 0)
		|			ИНАЧЕ 0
		|		КОНЕЦ <> 0
		|
		|УПОРЯДОЧИТЬ ПО
		|	Дата";
	
	Запрос.УстановитьПараметр("Магазин", Магазин);
	
	РезультатЗапроса = Запрос.Выполнить();    
	Объект.ТаблицаФормы.Загрузить(РезультатЗапроса.Выгрузить());
	ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
	ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
	ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
	ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
	ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
	
	ТабличныйДокумент.Очистить();
	ТабличныйДокумент.Вывести(ОбластьЗаголовок);
	ТабличныйДокумент.Вывести(ОбластьШапкаТаблицы);
	ТабличныйДокумент.НачатьАвтогруппировкуСтрок();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
		ТабличныйДокумент.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
	КонецЦикла;
	
	ТабличныйДокумент.ЗакончитьАвтогруппировкуСтрок();
	ТабличныйДокумент.Вывести(ОбластьПодвалТаблицы);
	ТабличныйДокумент.Вывести(ОбластьПодвал);

КонецПроцедуры	

&НаКлиенте
Процедура Заполнить() 
	ЗаполнитьНаСервере(); 
КонецПроцедуры	

&НаСервере
Процедура ПринятьОплатуСервер(Строка)
	
	СтруктураОснования = Новый Структура;
	СтруктураОснования.Вставить("ДокументОснования", Строка.Ссылка);
	СтруктураОснования.Вставить("Касса", Касса);
	СтруктураОснования.Вставить("ХозяйственнаяОперация", ХозяйственнаяОперация); 
	СтруктураОснования.Вставить("Кассир", Кассир);
	НовыйДокументПриходныйКассовыйОрдер(СтруктураОснования);
	
КонецПроцедуры	

&НаКлиенте
Процедура ПринятьОплату(Команда)
	ОКСервер();
КонецПроцедуры  

&НаСервере
Процедура НовыйДокументПриходныйКассовыйОрдер(Основание = Неопределено)
	
	Документ = Документы.ПриходныйКассовыйОрдер.СоздатьДокумент();
	Документ.Дата = Основание.ДокументОснования.Дата;              
	Документ.Касса = Основание.Касса;
	Документ.Организация = Основание.ДокументОснования.Организация;
	Документ.КассаККМ = Основание.ДокументОснования.КассаККМ;
	Документ.СуммаДокумента = Основание.ДокументОснования.СуммаДокумента;    
	Документ.ДокументОснование = Основание.ДокументОснования;
	Документ.ХозяйственнаяОперация = Основание.ХозяйственнаяОперация;
	Документ.Ответственный = Основание.Кассир;
	Документ.ПринятоОт = Основание.ДокументОснования.Ответственный;
	Документ.Основание = Основание.ДокументОснования;
	Документ.ВТомЧислеНДС = "Без налога (НДС)";
	Попытка
		Документ.Записать(РежимЗаписиДокумента.Проведение);
	Исключение	
	КонецПопытки; 
	
КонецПроцедуры

&НаСервере
Процедура ОкСервер()
	
	ТЗ = РеквизитФормыВЗначение("Объект.ТаблицаФормы");  
	Для Каждого Строка Из ТЗ Цикл  
		Если Строка.Выбор Тогда 
			ПринятьОплатуСервер(Строка);
		КонецЕсли;
	КонецЦикла;
	ЗаполнитьНаСервере();
	
КонецПроцедуры	

&НаСервере
Процедура КассаПриИзмененииСервер()
	Магазин = Касса.Магазин;
КонецПроцедуры

&НаКлиенте
Процедура КассаПриИзменении(Элемент)
	КассаПриИзмененииСервер();
	ЗаполнитьНаСервере();
КонецПроцедуры


&НаСервере
Процедура ПриОткрытииНаСервере()
    ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПоступлениеДенежныхСредствИзКассыККМ
КонецПроцедуры


&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ПриОткрытииНаСервере();
КонецПроцедуры


&НаСервере
Процедура ВыбратьВсеНаСервере()
	
	ТЗ = РеквизитФормыВЗначение("Объект.ТаблицаФормы");  
	Для Каждого Строка Из ТЗ Цикл  
		Строка.Выбор = Истина;
	КонецЦикла;	  
	
КонецПроцедуры


&НаКлиенте
Процедура ВыбратьВсе(Команда)
	ВыбратьВсеНаСервере();
КонецПроцедуры


&НаСервере
Процедура СнятьВыборНаСервере()
	
	ТЗ = РеквизитФормыВЗначение("Объект.ТаблицаФормы");  
	Для Каждого Строка Из ТЗ Цикл  
		Строка.Выбор = Ложь;  
	КонецЦикла;
	
КонецПроцедуры


&НаКлиенте
Процедура СнятьВыбор(Команда)
	СнятьВыборНаСервере();
КонецПроцедуры

 

Проверено на релизе 1С: Розница редакция 2.3 (2.3.13.10)

Проверено на следующих конфигурациях и релизах:

  • Розница, редакция 2.3, релизы 2.3.13.10

принять оплату денежные средства к поступлению выемка дс из кассы ккм приходный кассовый ордер розница

См. также

ККТ-ОНЛАЙН 54-ФЗ: Обработка для работы онлайн касс АТОЛ, ШТРИХ, VIKI PRINT и т.д. МАРКИРОВКА (Разрешит. режим) + ЭКВАЙРИНГ + БЕСПЛАТНЫЙ ДЕМО

ККМ Кассовые операции Розничная торговля Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия 1.6 1С:Бухгалтерия автономного учреждения 1С:CRM ПРОФ, КОРП Россия Платные (руб)

Универсальная обработка для обслуживания любых фискальных регистраторов (ККТ), в том числе Веб сервер АТОЛ. Работает в соответствии с 54-ФЗ. (ФФД 1.0, ФФД 1.05, ФФД 1.1). Подключайте любую онлайн кассу к практически любой конфигурации. Нет необходимости обновлять 1С. Можно бесплатно скачать и протестировать. Может работать одновременно с несколькими онлайн-кассами, либо одной с разных рабочих мест. (через RDP, TCP\IP или веб-сервер) Позволяет разделить один чек сразу на несколько ККТ или на несколько систем налогообложения. Поддерживает разрешительный режим. Можно настроить собственный шаблонов чека. Можно использовать эквайринг там, где он не поддерживается. Работает на LINUX и Windows ЭМУЛЯТОР + ЭКВАЙРИНГ + МАРКИРОВКА + ПОДДЕРЖКА ФФД 1.2

6000 руб.

27.02.2017    766260    4694    9501    

2792

54-ФЗ и Разрешительный режим. Обработки для подключения онлайн-касс к 1С 8 (поддержка Маркировки) + Эмулятор + ФФД 1.2

ККМ Кассовые операции Розничная торговля Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:Розница 2 1С:Управление производственным предприятием 1С:Бухгалтерия государственного учреждения 1С:Бухгалтерия автономного учреждения Россия Платные (руб)

Обработка осуществляет обслуживание ККТ АТОЛ, Штрих и Меркурий для конфигураций "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "БП 2.0" и других отраслевых решений, построенных на основе указанных выше конфигурациях. Поддерживает возможность параллельно пробития чеков на одной ККМ несколькими пользователями. Поддерживает Веб-сервер Атол. Соответствует требованиям 54-ФЗ. Поддерживает ФФД 1.0, 1.05, 1.1 и 1.2. Разделяет чеки по нескольким СНО. Поддерживает механизмы подключения ККТ по TCP/IP, для работы через RDP или интернет. Поддержка маркировки и разрешительного режима.

5400 руб.

25.05.2015    317903    1851    3012    

998

Печать кассовых чеков на одну ККМ с нескольких рабочих мест для 1С:УТ11.х, КА2.х, Розница 2.х, УНФ, ERP 2.х, БП 3, БГУ2

ККМ Кассовые операции Розничная торговля Обмен с ГосИС Бухгалтерский учет Оперативный учет Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Платные (руб)

Расширение конфигурации для УТ 11.4, 11.5, КА 2.4, 2.5, Розница 3.0, 2.3 и 2.2, УНФ 1.6, УНФ 3x, ERP 2.4, 2.5, БП 3, БГУ2 (Управляемые формы) позволяет выполнять печать кассовых чеков на одну ККМ 54-ФЗ с нескольких рабочих мест. НИКАКИХ НАСТРОЕК В РАЗРАБОТКЕ - ПОДКЛЮЧИЛ И ПЕЧАТАЙ. Если у вас несколько отделов и одна ККМ - печатайте на одной ККМ! Если у вас две ККМ и одна поломалась - печатайте на одной ККМ, пока ремонтируете другую!

4000 руб.

27.08.2018    116905    993    565    

835

Загрузка чеков ФНС в документы 1С:БП, 1С:УНФ, 1С:ERP, 1С:КА и 1С:УТ

Кассовые операции Файловый обмен (TXT, XML, DBF), FTP ЭДО и ОФД Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 Россия Бухгалтерский учет Налоговый учет Управленческий учет Платные (руб)

В публикации размещены специализированные обработки для загрузки чеков в базах 1С (для локальных баз): '1С:Бухгалтерия предприятия, ред. 3.0', '1С:Управление нашей фирмой 8, ред. 3.0', '1С:Комплексная автоматизация, ред. 2.5', ‘1С:ERP Управление предприятием, ред. 2’ и ‘1С:Управление торговлей, ред. 11.5’. Вы просто сканируете QR коды с бумажных и электронных чеков c помощью мобильного приложения ФНС и чеки автоматически (без ручного ввода) загружаются в документы 'Авансовый отчет', 'Расходы предпринимателя', 'Путевой лист', 'Приходная накладная', 'Поступление (акты, накладные, УПД)', 'Приобретение товаров и услуг', 'Отчет о розничных продажах' и 'Поступление денежных документов'.

12960 руб.

19.08.2020    65302    303    73    

211

Загрузка в 1С:Бухгалтерию 3.0, 1С:КА 2.4, 2.5, УНФ 1.6/3.0 данных из ОФД о денежных поступлениях (чеках)

Кассовые операции ЭДО и ОФД Платформа 1С v8.3 Бухгалтерский учет 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Платные (руб)

Согласно 54-ФЗ по правилам ведения кассовых операций необходимо оформлять приходные кассовые ордера (ПКО) и расходные кассовые ордера (РКО) на основании чеков ККМ. Все данные о чеках, можно взять на сайте оператора фискальных данных (ОФД). Эта обработка сделает за вас в 1С - ПКО и РКО, Операции по платежным картам или Отчет о розничных продажах (может создать номенклатуру в 1С, указать налоги и др. реквизиты в документах в зависимости от налогообложения ККМ в торговой точке). Проверено на: OFD.RU / Первый ОФД / Такском / Платформа ОФД / Ярус / ОФД Яндекс / ОФД Астрал /ОФД СБИС / Гарант ОФД / КОРУС ОФД / КОНТУР ОФД / ОФД АО Тандер / ИнитПро / Группа Элемент/

3600 руб.

09.08.2017    148179    867    372    

527

Разбитие чека ККМ по группам товаров и пробитие их на разных кассах, подключенных к одному рабочему месту. Расширение для УТ 11.5, УТ 11.4, КА 2.5

Кассовые операции ККМ Платформа 1С v8.3 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Расширение для 1С:Управление торговлей 11.5 и 11.4, которое позволяет из рабочего места кассира разбивать чек ККМ на несколько чеков и пробивать их на разных кассах подключенных к одному РМК. Можно пробивать разные группы товаров по разным организациям на разных кассовых аппаратах.

5880 руб.

22.08.2022    10125    15    15    

19

Товарный чек вместо фискального (онлайн) чека с печатью QR-кода для 1С:Розница 2.3, 3.0, 1С:УТ/1С:КА

Розничная торговля Кассовые операции Платформа 1С v8.3 1С:Розница 2 Розничная и сетевая торговля (FMCG) Россия Платные (руб)

Расширение позволяет напечатать товарный чек без необходимости пробивать фискальный (онлайн) чек. При этом в системе данный чек имеет статус "пробитый", а значит попадет в отчет о розничных продажах при закрытии смены, но НЕ попадет в Z-отчет на кассе ККМ. При печати товарного чека ему автоматически подставляется оплата наличными, равная сумме чека.

3600 руб.

22.12.2020    27713    80    120    

81

Управление ККМ Атол и Штрих нового поколения (он-лайн ККТ под 54-ФЗ) с помощью текстового ini.файла для 1с77, 1с8Х любых конфигураций

Кассовые операции ККМ Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv7 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Программа для управления ККМ Атол и Штрих нового поколения (он-лайн ККТ под 54-ФЗ) с помощью текстового файла (ini файла) с изменениями  включена 1 лицензия  Для любых программ, которые умеют работать с текстовыми файлами. Внутри комплекта есть готовые к использованию обработки

4800 руб.

31.07.2017    165352    564    604    

197
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. OlegAr 21 30.12.23 16:54 Сейчас в теме
приемлемо, у меня была такая ситуация, кассирам не интересно , да и не знают как вести кассовый учет.
+
Оставьте свое сообщение