АРМ "Запись на ремонт" для Альфа-Авто: Автосервис+Автозапчасти. Редакция 4.1

17.11.14

Учетные задачи - Производство готовой продукции (работ, услуг)

АРМ записи на ремонт, правленный под контекст 4 редакции Альфа-Авто.

Скачать исходный код

Наименование Файл Версия Размер
Обработка АРМа
.epf 198,15Kb
30
.epf 198,15Kb 30 Скачать
Отчёт о сравнении конфигураций с необходимыми изменениями
.mxl 167,87Kb
16
.mxl 167,87Kb 16 Скачать

Как известно, АРМы объявились лишь в 5 редакции Альфа-Авто. Но некоторые официальные пользователи не могут перейти на эту редакцию ввиду сильной измененности типовой конфигурации, а новые возможности заполучить хочется.

Поэтому предлагается вашему вниманию измененная обработка под предыдущую редакцию, а также файл отчёта о сравнении, содержащий необходимые малочисленные изменения в конфигурации помимо добавленной обработки.

Альфа-Авто редакция 4 Запись на ремонт АРМ Автосервис

См. также

SALE! 50%

Отчет "Полный анализ себестоимости выпущенной продукции" для 1С:ERP (ЕРП), 1С:КА, 1С:ERP УХ

Производство готовой продукции (работ, услуг) Учет доходов и расходов Бухгалтер Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление холдингом 1С:Комплексная автоматизация 2.х Бухгалтерский учет Управленческий учет Платные (руб)

Данный отчет показывает себестоимость выпущенной продукции с разузлованием полуфабрикатов любых уровней, входящих в ее состав, до статей затрат и материалов. Отчет работает независимо от метода оценки стоимости товаров и подходит для любых производственных компаний с многопередельным производством. Отчет можно использовать как в типовой 1С:ERP, так и в отраслевых решениях на ее базе (например, 1С:ERP Управление птицеводческим предприятием и т.д.). Отчет подходит для анализа затрат на гособоронзаказы ГОЗ.

70000 35000 руб.

08.12.2021    24500    18    72    

30

SALE! 50%

Отчет "Полный анализ себестоимости реализованной продукции" для 1С:ERP (ЕРП), 1С:КА, 1С:ERP УХ

Производство готовой продукции (работ, услуг) Учет доходов и расходов Бухгалтер Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление холдингом 1С:Комплексная автоматизация 2.х Бухгалтерский учет Налоговый учет Платные (руб)

Данный отчет показывает себестоимость реализованной продукции в разузлованном виде, как с выделением входящих в нее полуфабрикатов любых уровней, так и свернутый до статей затрат и материалов, видов работ. Отчет работает независимо от метода оценки стоимости товаров и подходит для любых производственных компаний с многопередельным производством. Отчет можно использовать как в типовой 1С:ERP, так и в отраслевых решениях на ее базе (например, 1С:ERP Управление птицеводческим предприятием, Молокозавод и т.д.).Отчет подходит для анализа затрат на гособоронзаказы ГОЗ.

70000 35000 руб.

30.11.2022    11965    13    22    

20

Обмен с системой Меркурий через Web + Ветис.API для любых конфигураций (универсальная конфигурация Хамелеон Меркурий)

Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Обмен с ГосИС Программист Бухгалтер Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Сельское хозяйство и рыболовство Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Пищевая промышленность Россия Бухгалтерский учет Управленческий учет Платные (руб)

Универсальная конфигурация Хамелеон Меркурий для взаимодействия с системой Меркурий (тестовый+рабочий+демо контур) может использоваться для интеграции в любую конфигурацию на базе 1С, версии ПРОФ и выше. Основное отличие от других решений - работа через веб-интерфейс и API 2.0(API 2.1). Для удобства реализован общий интерфейс в виде обработки, схожей с интерфейсом Меркурий, но возможностей гораздо больше, т.к. при интеграции в Вашу учетную систему, можно на основании Ваших справочников и документов, создавать соответствующие документы и справочники в системе Меркурий и наоборот.

104000 руб.

08.11.2017    121530    294    140    

394
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. molodoi1sneg 17 17.11.14 15:11 Сейчас в теме
Сделайте нормальные скриншоты!
2. Князь 77 18.11.14 10:14 Сейчас в теме
Такие скриншоты нормальные?! :-)
3. Oleg1708 19.11.14 14:50 Сейчас в теме
Вообще в 4.1 есть запись на ремонт. обработка "ЗаписьНаРемонтИОбслуживание". Очень похожее на то что представлено. Шаг времени задан большой.
4. rngstr 05.02.15 06:32 Сейчас в теме
Добрый день. Вываливается ошибка при запуске.

{Форма.ИнтерфейсЗаписьНаРемонт.Форма(301,36)}: Переменная не определена (Планирование)
Для Каждого СтрокаПланирования Из <<?>>Планирование Цикл
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(335,2)}: Переменная не определена (Планирование)
<<?>>Планирование.Очистить();
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(346,10)}: Переменная не определена (Планирование)
Пока <<?>>Планирование.НайтиСтроки(Новый Структура("РабочееМесто,
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(358,27)}: Переменная не определена (Планирование)
НоваяСтрокаДокумента = <<?>>Планирование.Добавить();
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(372,25)}: Переменная не определена (Планирование)
ТаблицаПланирования = <<?>>Планирование.Выгрузить();
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(415,19)}: Переменная не определена (Планирование)
НоваяСтрока = <<?>>Планирование.Добавить();
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(428,36)}: Переменная не определена (Планирование)
Для каждого СтрокаПланирования Из <<?>>Планирование Цикл
5. Князь 77 05.02.15 07:37 Сейчас в теме
(4) rngstr, А конфигурация Альфа-Авто? Такая ошибка может выходить, если в конфигурации нет документа ЗаявкаНаРемонт с его табличной частью Планирование.
6. Touh_Of_soul) 18.11.16 15:44 Сейчас в теме
А можно конфу заместо файла Отчёт о сравнении конфигураций с необходимыми изменениями не понятно как по нему изменения вносить..
7. Бывалый77 21 23.11.16 04:35 Сейчас в теме
Альфа-Авто: Автосалон +Автосервис + Автозапчасти. Редакция 4.1 (4.1.01.20)

-------------
{Форма.ИнтерфейсЗаписьНаРемонт.Форма(3553,96)}: Слишком много фактических параметров (ЗаполнитьРаботамиПоВидуРемонта)
8. Бывалый77 21 23.11.16 04:50 Сейчас в теме
Потребовалось 2 исправления:
//1.
//++
Макет	= ОбработкаОбъект.ПолучитьМакет("HTMLStyles");//Обработки.АРМЗаписьНаРемонт.ПолучитьМакет("HTMLStyles");
//--

//-----------------------------------------------------------------------------------------------

//2. 
//Процедура ПредложитьЗаполнитьРаботамиПоВидуРемонта(ЭтаФорма=Неопределено)  Экспорт
//....
			//++
			//ЗаполнитьРаботамиПоВидуРемонта(РежимОбработкиРаботы,РежимОбработкиПланирование,ТаблицаРабот,ЭтаФорма);
			ЗаполнитьРаботамиПоВидуРемонта_неТиповая(РежимОбработкиРаботы,РежимОбработкиПланирование,ТаблицаРабот,ЭтаФорма);
			//--
			
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры

// Заполнение табличных частей "Работы" и "Планирование" по виду ремонта
// Параметры: РежимРаботы,РежимПланирование - обработка табличных частей
// 0 - не обрабатывать, 
// 1- заполнять без очистки, 
// 2 - заполнять с очисткой, 
// 3 - калькуляция, заполнять работы без исполнителей без очистки,
// 4 - калькуляция, заполнять работы без исполнителей с очисткой
Процедура ЗаполнитьРаботамиПоВидуРемонта_неТиповая(РежимРаботы=0, РежимПланирование=0, РаботыПоВидуРемонта, ЭтаФорма=Неопределено)  Экспорт
	
	Если РаботыПоВидуРемонта = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	// Очистим табличные части в зависимости от режимов
	Если РежимРаботы = 2 Тогда
		ЭтотОбъект.Работы.Очистить();
		ЭтотОбъект.Исполнители.Очистить();
	КонецЕсли;
	Если РежимРаботы = 4 Тогда
		ЭтотОбъект.Работы.Очистить();
	КонецЕсли;
	Если РежимПланирование = 2 Тогда
		ЭтотОбъект.Планирование.Очистить();
	КонецЕсли;
	
	// Заполним  
	МассивДобавленныхРабот = Новый СписокЗначений;
	Для Каждого СтрокаРабот Из РаботыПоВидуРемонта Цикл
		////ВидИспользованияАвтоработы = обПолучитьЗначениеСвойства(СтрокаРабот.Авторабота,ПланыВидовХарактеристик.СвойстваОбъектов.ВидИспользованияАвтоработы,Перечисления.ВидыИспользованияАвторабот.Производство);
		Если РежимРаботы > 0 Тогда
			// Поищем строку с такой работой в табличной части
			ТекСтрока = ЭтотОбъект.Работы.Найти(СтрокаРабот.Авторабота,"Работа");
			Если ТекСтрока <> Неопределено Тогда
				ТекСтрока.Количество = ТекСтрока.Количество + СтрокаРабот.Количество;
				ОбработкаРеквизита("Работы.Количество",ТекСтрока);
			Иначе
				ТекСтрока = ЭтотОбъект.Работы.Добавить();
				ТекСтрока.Работа = СтрокаРабот.Авторабота;
				ТекСтрока.Количество = СтрокаРабот.Количество;
				ОбработкаРеквизита("Работы.Работа",ТекСтрока);
				ТекСтрока.ИдентификаторРаботы = Новый УникальныйИдентификатор;
				Если ЭтаФорма<>Неопределено Тогда
					ЭтаФорма.ИдентификаторТекущейРаботы = ТекСтрока.ИдентификаторРаботы;
				КонецЕсли;
				МассивДобавленныхРабот.Добавить(ТекСтрока);
			КонецЕсли;
		КонецЕсли;
		Если РежимПланирование > 0 Тогда
			НоваяСтрока = ЭтотОбъект.Планирование.Добавить();
			НоваяСтрока.Авторабота = СтрокаРабот.Авторабота;
			ОбработкаРеквизита("Планирование.Авторабота",НоваяСтрока);
		КонецЕсли;
	КонецЦикла;
		
	////Если ЭтаФорма<>Неопределено Тогда
	////	Если МассивДобавленныхРабот.Количество() > 0 И РежимРаботы < 3 Тогда
	////		зфЗНЗаполнениеИсполнителей(ЭтаФорма,МассивДобавленныхРабот);	
	////	КонецЕсли;
	////КонецЕсли;
	
	#Если Клиент Тогда
	Если ЭтаФорма <> Неопределено Тогда
		Если РежимРаботы > 1 Тогда
			ВывестиПодвалСкидокРабот(ЭтаФорма);
		КонецЕсли;
		дкВывестиЗаголовокСуммаДокумента(ЭтаФорма);
	КонецЕсли;
	#КонецЕсли
	
КонецПроцедуры
Показать





Князь; +1 Ответить
9. Touh_Of_soul) 28.11.16 10:16 Сейчас в теме
(8)
Привет поделись мне как ты обновлял конфу через файл Отчёт о сравнении конфигураций с необходимыми изменениями ?


У меня версия Альфа-Авто: Автосалон +Автосервис + Автозапчасти. Редакция 4.1 (4.1.01.28)
Строки совсем не совпадают..
10. Touh_Of_soul) 28.11.16 10:19 Сейчас в теме
Жаль у него нет возможности вывода горизонтально исполнителей
11. Agasaki 29.11.16 10:23 Сейчас в теме
Здравствуйте! Вылетает такая ошибка:
{Обработка.АРМЗаписьНаРемонт.Форма.ИнтерфейсЗаписьНаРемонт.Форма(3553,96)}: Слишком много фактических параметров (ЗаполнитьРаботамиПоВидуРемонта)
ЗаполнитьРаботамиПоВидуРемонта(РежимОбработкиРаботы,РежимОбработкиПланирование,ТаблицаРабот,<<?>>ЭтаФорма); (Проверка: Толстый клиент (обычное приложение))
{Обработка.АРМЗаписьНаРемонт.Форма.ИнтерфейсЗаписьНаРемонт.Форма(3566,11)}: Процедура или функция с указанным именем уже определена (ЗаполнитьРаботамиПоВидуРемонта)
Процедура <<?>>ЗаполнитьРаботамиПоВидуРемонта(РежимРаботы=0, РежимПланирование=0, РаботыПоВидуРемонта, ЭтаФорма=Неопределено) Экспорт (Проверка: Толстый клиент (обычное приложение))
Оставьте свое сообщение