Пример программного заполнения дерева метаданных обработки "Выгрузка / загрузка данных XML"

30.10.15

Интеграция - Файловый обмен (TXT, XML, DBF), FTP

Обработка ВыгрузкаЗагрузкаДанныхXML - часто используемая палочка-выручалочка при обмене объектами по заданному отбору.
При этом можно облегчить себе жизнь, заполняя дерево метаданных необходимыми отборами программно.
В статье приведен пример заполнения дерева измененными документами по выбранной организации за указанный период (анализ изменений за период проводится по журналу регистрации).

Скачать исходный код

Наименование Файл Версия Размер
ВыгрузкаЗагрузкаДанныхXML82_ИС.epf
.epf 77,66Kb
21
.epf 77,66Kb 21 Скачать

Приступим...

Снимем все флаги с дерева метаданных:

	Для Каждого СтрокаУровень1 Из ДеревоМетаданных.Строки Цикл
		Для Каждого СтрокаУровень2 Из СтрокаУровень1.Строки Цикл
			Для Каждого СтрокаУровень3 Из СтрокаУровень2.Строки Цикл
				СтрокаУровень3.Выгружать = Ложь;
			КонецЦикла;
		КонецЦикла;
	КонецЦикла;

Создадим параметры для выборки изменений по журналу регистрации и выгрузим изменения в таблицу значений:

    ТабЖур = Новый ТаблицаЗначений;
    Фильтр = Новый Структура;
    // ограничение по датам
    Фильтр.Вставить("ДатаНачала", ДатаНачалаИзменений);
    Фильтр.Вставить("ДатаОкончания", ДатаОкончанияИзменений);
    // ограничение событиями, относящимися только к документам
    МассивСобытий = Новый Массив;
    МассивСобытий.Добавить("_$Data$_.Delete");
    МассивСобытий.Добавить("_$Data$_.New");
    МассивСобытий.Добавить("_$Data$_.Post");
    МассивСобытий.Добавить("_$Data$_.Unpost");    
    МассивСобытий.Добавить("_$Data$_.Update");
    Фильтр.Вставить("Событие", МассивСобытий);
    // список колонок
    КолонкиСтрокой = "Метаданные, Данные";

    ВыгрузитьЖурналРегистрации(ТабЖур, Фильтр, КолонкиСтрокой, , );

Обработаем полученную таблицу значений. Найденные документы поместим в таблицу значений с двумя колонками (имя метаданного, ссылка на объект):

	ТаблицаОтчета = Новый ТаблицаЗначений;
	ТаблицаОтчета.Колонки.Добавить("Метаданные");
	ТаблицаОтчета.Колонки.Добавить("Данные");

	Для Каждого СтрокаТЖ Из ТабЖур Цикл
		ТекстМетаданные = Строка(СтрокаТЖ.Метаданные);
		ТекстМетаданныеБезДокумента = СтрЗаменить(ТекстМетаданные, "Документ.", "");
		Данные = СтрокаТЖ.Данные;
		Если Найти(ТекстМетаданные, "Документ.") > 0 Тогда
			Если Данные.Метаданные().Реквизиты.Найти("Организация") <> Неопределено Тогда
				Если ЗначениеЗаполнено(Организация) И Данные.Организация <> Организация Тогда
					Продолжить;
				Иначе
					СтрокаТО = ТаблицаОтчета.Добавить();
					СтрокаТО.Метаданные = ТекстМетаданныеБезДокумента;
					СтрокаТО.Данные = Данные;
				КонецЕсли;
			КонецЕсли;
		Иначе
			Продолжить;
		КонецЕсли;
	КонецЦикла;

И дальше заполняем строки дерева, формируя списки по группам метаданных:

        ТаблицаОтчетаМетаданные = ТаблицаОтчета.Скопировать();
        ТаблицаОтчетаМетаданные.Свернуть("Метаданные");
	Для Каждого СтрокаТОМ Из ТаблицаОтчетаМетаданные Цикл
		СтруктураОтбора = Новый Структура;
		СтруктураОтбора.Вставить("Метаданные", СтрокаТОМ.Метаданные);
		СтрокиТО = ТаблицаОтчета.НайтиСтроки(СтруктураОтбора);
		СписокСсылок = Новый СписокЗначений;
		Для Каждого СтрокаТО Из СтрокиТО Цикл
			СписокСсылок.Добавить(СтрокаТО.Данные);
		КонецЦикла;
		ЗаполнитьДеревоНастроекОтборамиДокументов(СтрокаТОМ.Метаданные, СписокСсылок);
	КонецЦикла;

Процедура заполнения дерева:

Процедура ЗаполнитьДеревоНастроекОтборамиДокументов(ИмяМетаданного = "", СписокСсылок = "") Экспорт
		
	// выгрузка документов
	Для Каждого СтрокаУровень1 Из ДеревоМетаданных.Строки Цикл
			
		// уровень заголовка единственный
		БылиВВеткеДокументов = Ложь;
		Для Каждого СтрокаУровень2 Из СтрокаУровень1.Строки Цикл
			Если СтрокаУровень2.Метаданные <> "Документы" И НЕ БылиВВеткеДокументов Тогда
				Продолжить;
			Иначе
				Если НЕ БылиВВеткеДокументов Тогда
					БылиВВеткеДокументов = Истина;
					СтрокаУровень2.Выгружать = 1;					
					Для Каждого СтрокаУровень3 Из СтрокаУровень2.Строки Цикл
						Если СтрокаУровень3.Метаданные.Имя <> ИмяМетаданного Тогда
							Продолжить;
						КонецЕсли;				
						Сообщить("Заполнили флаги по " + ИмяМетаданного);
						СтрокаУровень3.Выгружать = 1;
						СтрокаУровень3.ИспользоватьОтбор = Истина;
						СтрокаУровень3.НастройкиПостроителя = УстановитьНастройкиПостроителяОтчетаДляСтроки(СтрокаУровень3, СписокСсылок);
					КонецЦикла;				
				КонецЕсли;
			КонецЕсли;
		КонецЦикла;
			
	КонецЦикла;		
	// конец обхода дерева
КонецПроцедуры

И самая главная процедура)

Функция УстановитьНастройкиПостроителяОтчетаДляСтроки(СтрокаДереваМетаданных, СписокКодов)
	
	ИтоговыйТекстЗапроса = ПолучитьТекстЗапросаПоСтроке(СтрокаДереваМетаданных, ЛОЖЬ, "");
	
	ПостроительОтчета = Новый ПостроительОтчета;
	
	ПостроительОтчета.Текст = ИтоговыйТекстЗапроса;
	
	ПостроительОтчета.ЗаполнитьНастройки();
	
	ПостроительОтчета.Отбор.Сбросить();	
	
	Отбор = ПостроительОтчета.Отбор.Добавить("Ссылка");
	Отбор.ВидСравнения = ВидСравнения.ВСписке;
	Отбор.Использование = Истина;
	Отбор.Значение = СписокКодов;
	
	Возврат ПостроительОтчета.ПолучитьНастройки();
	
КонецФункции

В прикрепленном файле обработка с вышеописанным кодом, отбор по организации и периоду вынесен на отдельную вкладку "Дополнительные настройки".

Вкладка настроек выглядит так:

Дополнительные настройки

А результат работы кода вот так:

Заполненное дерево настроек

То есть, все измененные типы объектов помечены к выгрузке, в отборах - списки ссылок.

P.S. И еще несколько простых и полезных программных приемов: //infostart.ru/public/399922/

выгрузказагрузкаданныхxml программное заполнение дерева метаданных анализ изменений по журналу регистрации

См. также

SALE! 10%

Синхронизация и обмен для ERP 2.5, КА 2.5, УТ 11.5 БП 3.0, Розница, УНФ и других с EnterpriseData (универсальный формат обмена), правила обмена

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Россия Платные (руб)

Правила в универсальном формате обмена для ERP 2.5, КА 2.5, УТ 11.5, БП 3.0, Розница, УНФ, для последних версий конфигураций. Ссылки на другие конфигурации в описании публикации. Правила совместимы со всеми другими версиями конфигураций новыми и старыми, поддерживающими обмен и синхронизацию в формате EnterpriseData. Не требуется синхронного обновления правил после обновления другой конфигурации, участвующей в обмене. Типовой обмен через планы обмена кнопкой Синхронизация вручную или автоматически по расписанию, или вручную обработкой.

25080 руб.

12.06.2017    136631    729    292    

393

Перенос данных из ERP 2 / КА 2 / УТ 11 в БП 3.0. Переносятся документы, начальные остатки и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Платные (руб)

Перенос данных из ERP в БП 3 | из КА 2 в БП 3 | из УТ 11 в БП 3 | из ЕРП в БП 3 | В продаже с 2019г. | Воспользовались более 176 предприятий! | Сэкономьте время - используйте готовое решение для перехода! | Перенос разработан в формате КД 2 (правила конвертации данных) | Переносятся все возможные виды документов, начальных остатков и нормативно-справочная информация| Можно опционально выгружать каждую пару "номенклатура+характеристика" как отдельную номенклатуру | Есть выгрузка настроек счетов учета и зарплатных данных из ERP / КА 2 | Можно проверить на вашем сервере перед покупкой, обращайтесь!

34650 руб.

15.04.2019    69494    166    141    

112

SALE! 10%

Перенос данных из УТ 10.3 в УТ 11.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 1С:Управление торговлей 11 Россия Управленческий учет Платные (руб)

Перенос данных из 1С:Управление торговлей 10.3 в 1С:Управление торговлей 11.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УТ 10.3 (10.3.87.x) и УТ 11.5 (11.5.16.x).

28000 25200 руб.

23.07.2020    47487    203    64    

164

SALE! 10%

Перенос данных из УПП 1.3 в БП 3.0. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:Бухгалтерия предприятия 3.0 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x) и БП 3.0 (3.0.151.x). Правила подходят для версии ПРОФ и КОРП.

28000 25200 руб.

15.12.2021    21070    138    38    

97

Перенос данных из ERP 2 / КА 2 в ЗУП 3. Переносятся остатки, документы и справочники

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет Управленческий учет Платные (руб)

Перенос данных из ERP в ЗУП 3 | из КА 2 в ЗУП | Воспользовались более 79 предприятий! | Предлагаем приобрести готовые правила конвертации данных (КД 2) для переноса остатков, документов с движениями и справочной информации 3 | В продаже с 2020г. | Оперативно обновляем правила до актуальных релизов 1С | Есть перенос начальной задолженности по зарплате и начальной штатной расстановки на выбранную дату | Обороты за прошлые годы (данные для расчета среднего) переносятся свернуто в документ "Перенос данных" | Есть фильтр по организациям | Документы за текущий период переносятся сразу с движениями, поэтому не потребуется делать перерасчеты | Перенос можно проверить перед покупкой, обращайтесь!

43450 руб.

03.12.2020    34805    83    58    

81

SALE! 10%

[ED2] Обмен УПП 1.3, КА 1.1, УТ 10.3 с EnterpriseData (универсальный формат обмена), обработка

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Платформа 1С v8.3 Платформа 1C v8.2 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Управление производственным предприятием Россия Платные (руб)

Регулярный обмен, выгрузка, перенос из КА 1.1, УПП 1.3, УТ 10.3 для обмена с любыми конфигурациями, поддерживающими обмен в формате EnterpriseData (КД3) - БП 3.0, ERP, КА 2, УТ 11, Розница 2, УНФ 1.6 и другими. Правила для старых и доработанных конфигураций не требуют синхронного обновления и совместимы с новыми и будущими конфигурациями. Обмен по расписанию, через папку, FTP, почту.

14580 руб.

18.02.2016    183616    565    508    

509

SALE! 10%

Переход и перенос данных из УПП 1.3 в ERP 2.5, КА 2.5. Переносятся документы (обороты за период), справочная информация и остатки

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление производственным предприятием 1С:ERP Управление предприятием 2 Бухгалтерский учет Управленческий учет Платные (руб)

Переход и перенос данных из 1С:Управление производственным предприятием 1.3 в 1С:ERP Управление предприятием 2.5 и 1С:Комплексную автоматизацию 2.5 с помощью правил обмена. Переносятся остатки, документы (обороты за период), справочная информация. Правила проверены на конфигурациях УПП 1.3 (1.3.227.x), ERP 2.5 (2.5.16.x), КА 2.5 (2.5.16.x) .

28000 25200 руб.

24.06.2020    61673    45    27    

75

Перенос данных из БП 3.0 в УНФ 3.0 / УНФ 1.6. Переносятся остатки, документы и справочная информация

Перенос данных 1C Файловый обмен (TXT, XML, DBF), FTP Программист Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление нашей фирмой 3.0 Россия Платные (руб)

В продаже с 2018г. | Воспользовались более 41 предприятия! | Правила конвертации (КД 2) для переноса данных из БП 3 в УНФ | Переносятся все виды документов, начальные остатки и вся возможная справочная информация | Есть фильтр по организациям | Оперативно обновляем на новые релизы | Оказываем техподдержку | В комплект файлов входит инструкция, авторская версия обработки "Универсальный обмен...", актуальные правила переноса данных и архив старых версий переноса | Учет в БП 3 должен быть корректным, некорректные данные не переносятся | Можно бесплатно проверить на вашем сервере до покупки!

45650 руб.

10.07.2018    68403    41    124    

46
Оставьте свое сообщение