Native компонента для чтения из Com порта

18.07.16

Разработка - Разработка внешних компонент

Компонента позволяет посредством ВнешнегоСобытия получать данные из Com-порта

Скачать файлы

Наименование Файл Версия Размер
Библиотека x32
.dll 109,50Kb
4
.dll 109,50Kb 4 Скачать
Библиотека x64
.dll 126,50Kb
3
.dll 126,50Kb 3 Скачать
Архив с обеими версиями
.rar 104,03Kb
94
.rar 104,03Kb 94 Скачать

Компонента поставляется в x32 и x64 вариантах.

Порядок подключения:

Из макета

ПодключитьВнешнююКомпоненту("Обработка.КомПорт.Макет.Библиотека","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native);
КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");

Из файла:

ПодключитьВнешнююКомпоненту("Путь к dll файлу","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native);
КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");

Свойства:

КомПорт.ИмяПорта(PortName) = "COM1"; // Имя ком порта

КомПорт.РазмерБлокаДанных(BlockSize) = 1; // Размер данных, который накопит компонента прежде чем 
                                          // вызовет внешнее событие (произвольное целое число)

КомПорт.Скорость(BaudRate) = 9600;        // Скорость работы Com порта (110, 300, 600, 1200, 2400, 
                                          // 4800, 9600, 14400, 19200, 38400, 56000, 57600, 115200,
                                          // 128000, 256000)
КомПорт.СтопБит(StopBits) = 0;            // 1 стоп бит = 0, 1.5 стоп бита = 1, 2 стоп бита = 2

КомПорт.БитДанных(DataBits) = 8;          // Количество бит данных (целое число)

КомПорт.Четность(Parity) = 0;             // Четность (NOPARITY=0, ODDPARITY=1,EVENPARITY=2,
                                          // MARKPARITY=3,SPACEPARITY=4)

Методы:

КомПорт.ОткрытьПорт(); // Открывает порт
КомПорт.ЗакрытьПорт(); // Закрывает порт

Все свойства устанавливаются до открытия порта. Для изменения свойств необходимо закрыть и заново открыть порт.

Внешнее событие:

Процедура ВнешнееСобытие(Источник, Событие, Данные) // Истичник = COM_PORT, Событие = DATA_BLOCK
	ПрочитанныеДанные = Данные;
КонецПроцедуры

Дополнительныая информация

Ссылка на объект компоненты должна быть доступна на протяжении всей работы с Com  портом, во избежании выгрузки компоненты платформой.

Например так:

Перем КомПорт

Процедура ПриОткрытии()
	ПодключитьВнешнююКомпоненту("Обработка.КомПорт.Макет.Библиотека","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native);    
КонецПроцедуры

Процедура ДействиеНачатьПрослушивание()
    КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");
    КомПорт = ОткрытьПорт();
КонецПроцедуры

Процедура ДействиеЗакончитьПрослушивание()
    КомПорт = ЗакрытьПорт();
    КомПорт = Неопределено;
КонецПроцедуры

Процедура ПриЗакрытии()
	Если КомПорт <> Неопределено Тогда
        КомПорт = ЗакрытьПорт();
        КомПорт = Неопределено;
    КонецЕсли;
КонецПроцедуры

КомПорт = Неопределено;

Планируется выход платной версии, с возможностью записи в COM порт и управлением сигнальными линиями.

Заключение

Внимание! Компонента выпущена в бета версии, никаких гарантий на ее работу не предусмотрено, хотя в настоящее время и работает в реальных решениях. Выложена для ознакомления и применения с целью сбора отзывов. Компонента не обременена лицензионными соглашениями и предоставляется для свободного использования на свое усмотрение как есть.

Внешняя компонента Ком порт Com port

См. также

Медиадисплей. Рекламный информационный монитор для покупателя.

Разработка внешних компонент POS терминал Рабочее место Розничная торговля Платформа 1С v8.3 1С:Комплексная автоматизация 1.х 1С:Управление торговлей 10 1С:Розница 2 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Реклама, PR и маркетинг Управленческий учет Платные (руб)

Монитор покупателя может отображать текущую покупку на кассовом месте, показывать видеорекламу, баннеры, во время простоя разворачивать рекламу на весь экран. Можно использовать в качестве графического меню-борда в кафе и видеовывески. Управление выводом на телевизор через hdmi-приставку на базе Windows или Android. В качестве устройства отображения можно использовать Android-планшеты, фоторамки с Android, монитор любого Windows-компьютера, доступного по сети. Настраивается ЛЮБОЙ ДИЗАЙН экрана!

16800 руб.

30.05.2017    50944    32    69    

40

Внешняя компонента для сканирования (замена TWAIN-компоненты БСП) (Native Win 32/64)

Разработка внешних компонент Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Внешняя компонента позволяет работать c TWAIN-совместимым оборудованием (сканерами, камерами) . Полностью совместима со стандартной TWAIN-компонентой из БСП и может применяться как ее замена без изменения вызовов, при этом может работать с 64-разрядной платформой, а так же имеет расширенную функциональность, например, сохранение результата непосредственно в PDF без использования сторонних утилит. Прекрасно работает на сервере, тонком клиенте и веб-клиенте (проверена работа в браузерах Google Chrome, Mozilla Firefox и Microsoft Internet Explorer).

2400 руб.

12.05.2020    24036    121    86    

76

Внешняя компонента WebSocket для 1С (c поддержкой Authorization token bearer)

Разработка внешних компонент Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Внешняя компонента в виде библиотеки (.dll файл), позволяющая посылать команды и получать ответы по протоколу WebSocket из 1С. Компонента работает только на стороне "клиента".

4440 руб.

22.06.2020    15263    10    32    

16

Внешняя компонента GraphQL клиент для 1С

Разработка внешних компонент Платформа 1С v8.3 Платформа 1C v8.2 Платные (руб)

Внешняя компонента, позволяющая посылать команды и получать ответы по GraphQL протоколу из 1С.Может быть использована при интеграции. В 1С работает на стороне "клиента".

4600 руб.

27.06.2023    1767    1    0    

1

Внешняя компонента для подключения 1С к телефонии Asterisk

Разработка внешних компонент Телефония, SIP Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Внешняя компонента выполнена по технологии Native API для 1С 8.х, обеспечивает доступ к программным АТС Asterisk (FreePBX, Elastix) через AMI интерфейс. Через него можно управлять многими функциями Asterisk (определение номеров, перевод звонков, набор телефона и т. д.)

1200 руб.

04.05.2018    43444    114    64    

57

Внешняя компонента печати PDF (Native Win 32/64)

Разработка внешних компонент Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Внешняя компонента позволяет печатать PDF файлы непосредственно из 1С, не используя при этом сторонних программ. Прекрасно работает на сервере, тонком клиенте и веб-клиенте. Основана на проекте PDFium из состава проекта Chromium/Chrome

1500 руб.

17.09.2018    33635    97    121    

104

Звонки из Microsoft Lync 2013 в 1С

Разработка внешних компонент Платформа 1С v8.3 Платные (руб)

Простая библиотека с открытым кодом, позволяющая получать информацию о звонках и мгновенных сообщениях Microsoft Lync 2013 в 1С, а также инициировать звонки и отправлять мгновенные сообщения. Библиотека оформлена в виде подсистемы.

2400 руб.

13.01.2015    15983    4    15    

11

Универсальный драйвер весового индикатора "UniServer AUTO: WeightIndicator"

Разработка внешних компонент Весы Платформа 1С v8.3 Платформа 1C v8.2 Конфигурации 1cv8 Платные (руб)

Универсальный драйвер весового индикатора "UniServer AUTO: WeightIndicator" предназначен для подключения весовых индикаторов автомобильных, вагонных , платформенных весов любых производителей к различным конфигурациям 32-х или 64-х разрядных платформ 1С v.8.x. Мощные функции WEB приложения позволяют настроить удаленное подключение с любой точки в локальной сети предприятия или через интернет. Уникальные возможности настройки протокола обмена, позволяют подключать весовые терминалы любых производителей, как существующие так и выпущенные в перспективе.

10800 руб.

19.04.2023    4797    2    2    

4
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. jaroslav.h 177 19.07.16 10:56 Сейчас в теме
Дуже дуже вдячний, якщо все гуд, то це супер, це то, що нам якраз треба з специфічним сканером штрих-кодів. Буду тестувати.
2. jaroslav.h 177 19.07.16 11:07 Сейчас в теме
Получаю
{Форма.Форма.Форма(7)}: Тип не определен (AddIn.allsp_1C_ComPort.allsp_1C_ComPort)
КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");

с таким подключением
&НаКлиенте
Перем КомПорт;

&НаКлиенте
Процедура ПриОткрытии()
	ПодключитьВнешнююКомпоненту("C:\ComPort_x64.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native); 
	КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");
КонецПроцедуры

Показать


да и
ПодключитьВнешнююКомпоненту("G:\WH-ОБМЕН\ComPort_x64.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native) = Ложь


Толстый клиент. Управляемое приложение.
4. compguru84 95 19.07.16 11:21 Сейчас в теме
(2) myr4ik07, Отвечу в ближайшее время
6. jaroslav.h 177 19.07.16 11:35 Сейчас в теме
(4)
спасибо, работает, бомба
&НаКлиенте
Перем КомПорт;

&НаКлиенте
Процедура ПриОткрытии()
	ПодключитьВнешнююКомпоненту("G:\log\ComPort_x32.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native);
	КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");
	КомПорт.ИмяПорта = "com3";	
	КомПорт.ОткрытьПорт();
КонецПроцедуры

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
	Сообщить(Данные);
	Сообщить(Источник);
	Сообщить(Событие);
КонецПроцедуры


Показать
compguru84; +1 Ответить
7. compguru84 95 19.07.16 11:37 Сейчас в теме
(6) myr4ik07, Это хорошо. Будут проблемы, пишите
jaroslav.h; +1 Ответить
9. RuslanGaliev 02.11.16 14:23 Сейчас в теме
(7) Компонента подключается, но внешнее событие так и не получил.
3. jaroslav.h 177 19.07.16 11:20 Сейчас в теме
У кого то подключилась данная компонента?
5. compguru84 95 19.07.16 11:23 Сейчас в теме
(3) myr4ik07, Подключать необходимо версию х32
8. sasha777666 317 20.10.16 13:23 Сейчас в теме
Как проверить используется ли порт чем-то другим
10. user921229 22.02.18 17:02 Сейчас в теме
ComPort_x64.dll не генерирует событие. кто нибудь подключал успешно?
11. herfis 485 22.02.18 17:26 Сейчас в теме
(10) Я после плясок вокруг разных наколенных компонет по работе с ком-портом остановился на старом добром MSCOMMLib, известном еще с 7.7 (майкрософтовский драйвер). Его повыпиливали, но по-прежнему можно найти, скачать и установить. Правда, чтобы он заработал, его еще нужно зарегистрировать, записав в реестр нужные ключи. Все это гуглится.
По внешнему событию через него работать не пробовал, но майкрософтовская дока говорит, что у него есть для этого событие OnComm. А в 8-ке есть оператор ДобавитьОбработчик, с помощью которого можно подписываться на события ком-объектов. Я таким образом успешно подписывался на события сторонних ком-объектов по работе со сканерами (которые не по технологии создания внешних компонент 1С писаны). Думаю, и тут должно получиться.
ЗЫ. И на всякий случай я бы заглянул в свежую библиотеку подключаемого оборудования - вдруг туда уже засунули православный драйвер.
12. tka4enk0 144 10.11.18 00:56 Сейчас в теме
Компонента вроде подключается. Открытие порта происходит без ошибок. Но внешнее событие не генерируется.
Так же если открыть какой нибудь монитор порта по этому номеру, то он свободно открывается и получается данные. Хотя при уже открытом порте должен был бы падать в ошибку.
criptid; Alv_prog; +2 Ответить
13. Alv_prog 24.12.18 13:16 Сейчас в теме
Почему автор не отвечает? Внешнее событие не генерируется!
"хотя в настоящее время и работает в реальных решениях" - это в каких интересно оно может работать, если не генерирует НИЧЕГО?
Что за обман? Хотите отзывов - ставьте скачку бесплатной! А так получается минус 1 стармани!
14. jaroslav.h 177 24.12.18 14:48 Сейчас в теме
(13)

&НаКлиенте
Перем КомПорт;

&НаКлиенте
Процедура ПриОткрытии()
    ПодключитьВнешнююКомпоненту("G:\log\ComPort_x32.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native);
    КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");
    КомПорт.ИмяПорта = "com3";    
    КомПорт.ОткрытьПорт();
КонецПроцедуры

&НаКлиенте
Процедура ВнешнееСобытие(Источник, Событие, Данные)
    Сообщить(Данные);
    Сообщить(Источник);
    Сообщить(Событие);
КонецПроцедуры
Показать
15. Alv_prog 24.12.18 15:30 Сейчас в теме
(14) я читать умею, и ваш код прочитал и попробовал использовать сразу же. Но у меня х64 платформа. Со всеми вытекающими. И не только я написал что нет внешнего события.
16. jaroslav.h 177 24.12.18 16:41 Сейчас в теме
(15) если ты прочитал что х64 не работает, зачем качать и возмущения высказывать, думаешь что то изменилось ...
17. jaroslav.h 177 24.12.18 16:42 Сейчас в теме
(15) плюс он же пишет "Внимание! Компонента выпущена в бета версии, никаких гарантий на ее работу не предусмотрено"
18. ut2k5 15 16.05.19 09:37 Сейчас в теме
спасибо за материал, очень помогли
19. e-rogov 10 02.10.20 07:14 Сейчас в теме
Запись в порт есть?
20. criptid 16.10.20 14:50 Сейчас в теме
Доброго всем, кто-нибудь победил почему внешнее событие не отрабатывает? 8.3.15.1830 x86, подключаю x32.dll
21. gor-shilov 17.08.22 11:24 Сейчас в теме
Все работает, но замечено следующее: ВнешнееСобытие работает постоянно, но вес показывает тот, который был на момент открытия порта. Далее вес не меняется в Данные. Но если добавить строчки с закрытием и открытием порта, то вес обновляется. Подскажите можно ли и надо ли это решать. Или ничего страшного от-того что порты постоянно открываю и закрываю.

Перем КомПорт;

Процедура КнопкаВыполнитьНажатие(Кнопка)
	ПодключитьВнешнююКомпоненту("C:\БазыSSD\ComPort_x32.dll","allsp_1C_ComPort",ТипВнешнейКомпоненты.Native);
        КомПорт = Новый("AddIn.allsp_1C_ComPort.allsp_1C_ComPort");
	КомПорт.ИмяПорта = "COM8"; 
	КомПорт.РазмерБлокаДанных = 18; 
	КомПорт.Скорость = 9600;
	КомПорт.СтопБит = 0;
	КомПорт.БитДанных = 8; 
	КомПорт.Четность = 0; 
        КомПорт.ОткрытьПорт();
КонецПроцедуры

Процедура ВнешнееСобытие(Источник, Событие, Данные) // Истичник = COM_PORT, Событие = DATA_BLOCK
	Если Источник = "COM_PORT" и Событие = "DATA_BLOCK" Тогда
		ЭтаФорма.ЭлементыФормы.НадписьВес.Заголовок = Число(Сред(Данные,7,10));
	КонецЕсли;
	//КомПорт.ЗакрытьПорт();
	//КомПорт.ОткрытьПорт();
КонецПроцедуры
Показать
22. Pawlick 10 27.08.23 21:52 Сейчас в теме
х64 не работает(((
Оставьте свое сообщение