Получение эВСД из ФГИС Меркурий по Ветис API 2.0 для 1С 7.7 ТиС 7.70.932 (измененной) + внешняя печатная форма

26.08.18

Интеграция - Обмен с ГосИС

Пример получения информации в 1С 7.7 (7.70.019) ТиС 7.70.932 (изменена) из ФГИС Меркурий (Ветис API 2.0)

Скачать исходный код

Наименование Файл Версия Размер
ПодборВСД.ert - основной модуль подбора, ветис.ert - правка настроек, ветреестр.ert - пример отчета для меркурианина
.zip 79,44Kb
7
.zip 79,44Kb 7 Скачать
Внешняя печатная форма ВСД.ert
.ert 35,00Kb
6
.ert 35,00Kb 6 Скачать

Задача:

Для передачи эВСД в Торговую Сеть через EDI нужно получить и сохранить УИД ВСД в доп. поле документа Реализация (ТиС) из ФГИС Меркурий используя Ветис API. (с Меркурием работает отдельный человек не связаный с 1С, ВСД формирует заранее на основании ранее переданых данных о предстоящих отгрузках)

Решение:

Добавлено свойство номенклатуры "Требуется ВСД" со значениями "Да" и "Нет"

Добавлена константа "БезВСД" типа "Справочник.ЗначениеСвойств" (для отметки номенклатуры которая не подлежит Вет. Контролю)

Для работы с Торговой Сетью создан Справочник.Грузополучатели подчиненый Контрагенты для выбора точки доставки.

Изменен документ "Реализация", добавлен реквизит шапки "Грузополучатель" Справочник.Грузополучатели, добавлен реквизит табличной части "ВСД" строка 36, добавлено текстовое поле в ТЧ на форме "ОткрытьВСД" с формулой "ВСД()", кнопка "Заполнить ВСД" функ. "ЗаполнитьВСД()", изменен модуль формы:

Добавлено

// Возвращает значок присутствия ВСД
// "" ВСД ненужна
// + ВСД есть
// ? нету нужна
// ! неопределено надо или нет
Функция ВСД()   
    Рез = "!";
    СвВСД = СоздатьОбъект("Справочник.СвойстваНоменклатуры");
    СвВСД.ИспользоватьВладельца(Номенклатура);
    ЕстьСвВСД = СвВСД.ВыбратьЭлементыПоРеквизиту("ВидСвойства",Константа.БезВСД.Владелец);
    Если ЕстьСвВСД = 1 Тогда
        СвВСД.ПолучитьЭлемент();
        Рез = ?(СвВСД.ЗначениеСвойства = Константа.БезВСД," ",?(ПустоеЗначение(ВСД)=1,"?","+"));
        Пока СвВСД.ПолучитьЭлемент()=1 Цикл
            Сообщить("Не однозначный тип ВСД "+Номенклатура.Наименование);
        КонецЦикла;
    КонецЕсли;
    Возврат Рез;
КонецФункции

Функция ЗаполнитьВСД()
    Парам = СоздатьОбъект("СписокЗначений");
    Парам.ДобавитьЗначение(Контекст,"ФормаДок");
    ОткрытьФормуМодально("Отчет",Парам,КаталогИБ() + "ExtForms\"+"ПодборВСД.ert");    
    Возврат "";
КонецФункции

Изменено

Процедура ПриНачалеРедактированияСтроки()

    Если (Форма.ТекущаяКолонка() = "ТекстПартия") и (Номенклатура.Выбран()=1) Тогда

...

    ИначеЕсли (Форма.ТекущаяКолонка() = "ОткрытьВСД") Тогда
        Если ((ОткрытьВСД="?")или(ОткрытьВСД="+")) Тогда
            СписВариантов = СоздатьОбъект("СписокЗначений");
            СписВариантов.ДобавитьЗначение(0, "Подбор ВСД");
            СписВариантов.ДобавитьЗначение(1, "Редактировать ВСД");
            Если ОткрытьВСД="+" Тогда 
                СписВариантов.ДобавитьЗначение(2, "Открыть ВСД");
            КонецЕсли;
            ВариантЗап = 0;
            Если СписВариантов.ВыбратьЗначение(ВариантЗап,,,60,1) <> 1 Тогда
                Возврат;
            КонецЕсли;
            Если ВариантЗап = 0 Тогда
                Парам = СоздатьОбъект("СписокЗначений");
                Парам.ДобавитьЗначение(Контекст,"ФормаДок");
                Парам.ДобавитьЗначение("Подбор","Команда");
                ОткрытьФормуМодально("Отчет",Парам,КаталогИБ() + "ExtForms\"+"ПодборВСД.ert");
            ИначеЕсли ВариантЗап = 1 Тогда
                сВСД = ВСД;
                Если ВвестиСтроку(сВСД,"Ид ВСД",39,,60)=1 Тогда
                    сВСД = СтрЗаменить(СтрЗаменить(Нрег(СокрЛП(сВСД)),"-","")," ","");
                    Если СтрДлина(сВСД)=32 Тогда
                        Для Сч=1 По 32 Цикл с = Сред(сВСД,Сч,1);
                            Если Найти("0123456789abcdef",с)=0 Тогда Сообщить("Не верный формат"); Возврат; КонецЕсли;
                        КонецЦикла;    
                        ВСД = Лев(сВСД,8)+"-"+Сред(сВСД,9,4)+"-"+Сред(сВСД,13,4)+"-"+Сред(сВСД,17,4)+"-"+Прав(сВСД,12);
                    ИначеЕсли СтрДлина(сВСД)=0 Тогда
                        ВСД = "";
                    Иначе
                        Сообщить("Не верный формат");
                    КонецЕсли;
                КонецЕсли;                                           
            ИначеЕсли ВариантЗап = 2 Тогда 
                ЗапуститьПриложение("https://mercury.vetrf.ru/pub/operatorui?_action=findVetDocumentFormByUuid&uuid="+Лев(ВСД,4)+"-"+Сред(ВСД,5,24)+"-"+Сред(ВСД,29,4)+"-"+Прав(ВСД,4));
            Иначе 
                Возврат;
            КонецЕсли;
        ИначеЕсли ОткрытьВСД="!" Тогда
            СвВСД = СоздатьОбъект("Справочник.СвойстваНоменклатуры");
            СвВСД.ИспользоватьВладельца(Номенклатура);
            СвВСД.Новый();
            СвВСД.ВидСвойства = Константа.БезВСД.Владелец;
            ЗнВСД = СоздатьОбъект("Справочник.ЗначенияСвойств");
            ЗнВСД.ИспользоватьВладельца(СвВСД.ВидСвойства);
            Если ЗнВСД.Выбрать("","ФормаСписка")=1 Тогда
                СвВСД.ЗначениеСвойства = ЗнВСД.ТекущийЭлемент();
                СвВСД.Записать();
            КонецЕсли;
        КонецЕсли;
    ИначеЕсли (Форма.ТекущаяКолонка() = "ОткрытьПартию") Тогда
...

Внешняя обработка "ПодборВСД.ert" реализовано получение и подбор ВСД из ФГИС Меркурий.

Все данные хранятся в списках значений и сохраняются в файлы.

Для редактирования/сохранения настроек и связи справочников с данными из Ветис API можно воспользоваться внешней обработкой "ветис.ert" (из другого проекта)

Внешняя печатная форма ВСДшек к накладной: Т.к. данные в ИБ и в Меркурий отличаются то данные для печати беру через веб с сайта (тот что в QR) .

QR рисуется с помощью ВК FormEx http://www.dorex.pro спасибо АЛьФу.

Результат близок к оригинальной печатной форме Меркурия "сжатое с расширенной информацией".

Результат:

Проект внедрен, работает для одного ХС/Площадки и одной Торговой сети, но APLM 12 трепит нервы манагерам.

Заказчик хочет менять проект, добабавить функциональность в плане автоматизации создания транспортного ВСД, поэтому этот можно считать закрытым.

ЗЫ:

Это просто пример реализации взаимодействия 1С 7.7 с Меркурий через Ветис. Код открыт но к сожалению часть кода не читабельно (писалось не для изучения), можно использовать для своих проектов. Если понравилась идея, обращайтесь, что-нибудь придумаем.

Меркурий Ветис

См. также

АИС: Онлайн-кассы для 1С 7.7 (с поддержкой маркировки ЕГАИС, ТАБАКА, ОБУВИ, ЛЕКАРСТВ, ШИН, ОДЕЖДЫ, МОЛОКА, ВОДЫ и пр.) и Обмен с 1С 7.7 Честный ЗНАК (ГИСМТ, ЦРПТ, ЭДО)

Оптовая торговля Розничная торговля ККМ ЭДО и ОФД Обмен с ГосИС Оперативный учет 7.7 Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Платные (руб)

Подключение фискального регистратора к 1С 7.7 в режиме онлайн-кассы (в соответствии с 54-ФЗ). Поддержка крайних версий драйверов ККТ: ДТО 10 и ДТО 8 для Атол, 4.15, 5.16 для Штрих-М. Поддержка протоколов ФФД 1.0, 1.05, 1.1 и 1.2, развитые настройки для применения частичных оплат и авансов в оптовой и розничной торговле. Поддержка чеков коррекции всех версий. Поддержка розничной продажи маркированной продукции (ЕГАИС, табак, обувь, лекарства, шины, одежда, белье, парфюмерия, молочная продукция, вода и пр.). Вывод электронного чека (на е-майл, телефон) по требованию покупателя, поддерживаются комбинированные типы оплаты, режим эмуляции печати чека на ФР. Полный цикл работы из 1С 7.7 с маркировкой Честный ЗНАК (ГИСМТ, ЦРПТ) из 1С 7.7. ЭДО (табак, обувь, шины, одежда, молочная продукция, вода и прочие группы товаров) для розницы и опта (приемка и оптовая отгрузка маркированной продукции). Поддерживается как объемно-сортовой учет (ОСУ) так и поштучный (поэкземплярный) учет.

2000 руб.

28.03.2017    465677    4300    3463    

2434

Интеграция 1С и ФГИС Меркурий

Оптовая торговля Производство готовой продукции (работ, услуг) Логистика, склад и ТМЦ Обмен с ГосИС Оперативный учет 7.7 Оперативный учет Управляемые формы 1С:Комплексная автоматизация 1.х 1С:Бухгалтерия 2.0 1С:Управление торговлей 10 1С:ERP Управление предприятием 2 1С:Бухгалтерия 1.6 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х 1С:Бухгалтерия 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 1С:Производство+Услуги+Бухгалтерия Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность Россия Управленческий учет Платные (руб)

Модуль интеграции устанавливается в вашу 1С. Сокращает время оформления ветсправок с 8 часов до 30 минут в день. Проверяет ошибки в каждом документе. Обмен данными с ФГИС Меркурий из 1С через ВетИС API

36000 руб.

14.04.2017    51974    100    44    

35

Обмен с системой Меркурий (полный цикл) через Ветис.API для 1С 7.7

Оптовая торговля Обмен с ГосИС Платформа 1С v7.7 Конфигурации 1cv7 Сельское хозяйство и рыболовство Оптовая торговля, дистрибуция, логистика Пищевая промышленность Бухгалтерский учет Платные (руб)

В обработке реализован полный цикл работы с ГИС Меркурий из 1С на платфоме 7.70.027 (поддерживается конфигурация "Торговля и Склад") через Ветис.API: реализованы процедуры обмена с подсистемами заявок и справочников Ветис.API в формате 2.0.

5040 руб.

03.07.2018    37051    79    27    

60

АИС: Обмен данными с ЕГАИС 4.0 для конфигураций 1С 7.7

Оптовая торговля Розничная торговля Обмен с ГосИС Оперативный учет 7.7 Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Бухгалтерский учет Управленческий учет Акцизы Платные (руб)

Полностью автоматизированный обмен данными между конфигурациями 1С 7.7 и универсальным транспортным модулем (УТМ) ЕГАИС для всех видов деятельности (Опт, Розница, Производство, Импорт). Для организации обмена с ЕГАИС требуется минимальная доработка конфигураций (поддерживается 1С: &amp;quot;Торговля и склад ред. 9.2&amp;quot;, 1С: &amp;quot;Бухгалтерия 7.7&amp;quot;, 1С: &amp;quot;УСН 7.7&amp;quot;, другие конфигурации по заказу, включая нетиповые). В данном программном продукте реализованы все технические требования ФСРАР по обмену с УТМ ЕГАИС (включая отправку чеков розничных продаж в ЕГАИС - требование с 01.07.16). Поддержана фиксация чеков ЕГАИС на онлайн-кассах (в соответствии с 54-ФЗ). Поддержана версия 3 документооборота и поштучный (помарочный) учет. Поддержан эксперимент Татарстана по маркировке нефасованного (кегового) пива.

3000 руб.

13.12.2015    135712    159    400    

146

Обмен с ЕГАИС из 1С V7.7

Оптовая торговля Розничная торговля Обмен с ГосИС Оперативный учет 7.7 1С:Торговля и склад 7.7 Бухгалтерский учет Акцизы Платные (руб)

Дорогие друзья! Предлагаю Вашему вниманию обработку, предназначенную для обмена данными из Вашей учетной системы с ЕГАИС, через универсальный транспортный модуль (УТМ). В обработке реализован весь функционал обмена: - загрузка справочных данных по контрагентам, производителям, импортерам алкогольной продукции; - загрузка справочных данных по номенклатуре алкогольной продукции; - загрузка остатков; - помощник сопоставления справочных данных и запись их в базу данных; - загрузка приходных ТТН и справок Б от поставщиков, отправка по ним актов всех типов, создание по ним приходных документов; - выгрузка расходных ТТН покупателям; - управление Марками и ведение Регистра 3; Обработку возможно использовать автономно, не внося изменений в Вашу Учетную систему. Код открыт.

6000 руб.

13.11.2015    123074    169    2529    

232

АИС: Обмен с ФГИС Меркурий (Ветис.API) для всех* конфигураций 1С 7.7

Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Обмен с ГосИС Оперативный учет 7.7 Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 1С:Упрощенное налогообложение 7.7 Сельское хозяйство и рыболовство Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Пищевая промышленность Россия Бухгалтерский учет Управленческий учет Платные (руб)

Полностью автоматизированный обмен между конфигурациями 1С 7.7 и ФГИС Меркурий через Ветис.API для всех видов деятельности (Опт, Розница, Производство). Для организации обмена с ФГИС Меркурий требуется минимальная доработка конфигураций (поддерживается "из коробки" 1С: "Торговля и склад ред. 9.2", 1С: "Комплексная ред. 4.5", 1С: "Бухгалтерия 7.7", 1С: "УСН 7.7", 1С Предприниматель, другие конфигурации по заказу, включая нетиповые и самописные). Модуль разработан таким образом, чтобы минимизировать затраты по внедрению в произвольную конфигурацию на базе 1С 7.7. Вы можете БЕСПЛАТНО скачать демо-версию без ограничения по функционалу и опробовать решение в полном объеме перед покупкой. В данном программном продукте реализованы все технические требования Россельхознадзора по обмену в формате 2.0 и 2.1. Решение прошло опытную эксплуатацию и тестирование на крупных объектах всех видов деятельности: Производство, Опт, Розница.

10000 руб.

21.11.2018    53227    155    105    

68

Онлайн проверка марок Честный знак при разрешительном порядке в розничной торговле для v.8 и 7.7

Обмен с ГосИС Платформа 1С v7.7 Платформа 1С v8.3 1С:Управление торговлей 10 Россия Абонемент ($m)

Уже с 01.04.2024 вводится так называемый "разрешительный" режим продажи маркированной продукции в розницу. Это значит, что перед продажей нужно запрашивать у сервиса ЦРПТ разрешение на реализацию каждой марки. Здесь кратко опишу, как это делается, и приложу примеры для 1С 8 и 7.7.

1 стартмани

15.03.2024    3109    38    kirlog    70    

18
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. GrafB 10 23.11.20 16:52 Сейчас в теме
Добрый день, Пытаюсь попробовать на тестовом контуре, подскажи пожалуйста что может означать данная ошибка:
"msxml6.dll: Сбой скачивания указанного ресурса."
2. GrafB 10 25.11.20 16:09 Сейчас в теме
(1) нашёл на другом форуме с чем связана моя ошибка, возможно из-за серверной винды. Решение: в коде заменить объект Msxml2.XMLHTTP на Msxml2.ServerXMLHTTP.
Оставьте свое сообщение