ТаблицаЗначений.ТаблицаЗначений - удобство обработки данных.

Публикация № 17080

Разработка - Практика программирования

2
Вложенные ТаблицыЗначений очень удобны для группирования данных при всяческих расчетах. Например расчет вложенных нормативов затрат сырья.
Технология проста и тривиальна. Приведу пример кода, из которого все будет понятно.
ТЗВозврат= СоздатьОбъект("ТаблицаЗначений"); 
ТЗВозврат.НоваяКолонка("Документ");
ТЗВозврат.НоваяКолонка("Подраздел","Справочник.Подразделения"); 
ТЗВозврат.НоваяКолонка("ПервПарам","Число",1,0); 
ТЗВозврат.НоваяКолонка("СуммаПервПарам","Число",15,2); 
ТЗВозврат.НоваяКолонка("МинСуммаПервПарам","Число",15,2);
ТЗВозврат.НоваяКолонка("КолЮрЛицПодраздел","Число",1,0); 
ТЗВозврат.НоваяКолонка("СуммаКолЮрЛиц","Число",15,2);
ТЗВозврат.НоваяКолонка("ОстПарам","Число",1,0);
ТЗВозврат.НоваяКолонка("ПарамАЙТи","Число",1,0); 
ТЗВозврат.НоваяКолонка("ДатЛог","Дата");
ТЗВозврат.НоваяКолонка("ДатСклад","Дата"); 
ТЗВозврат.НоваяКолонка("ГруппаОфис","Справочник.ОфисныеПомещения");  
ТЗВозврат.НоваяКолонка("КоэфОбъем","Число",5,2); 
ТЗВозврат.НоваяКолонка("ТЗРаспредел","ТаблицаЗначений");
	
Док = СоздатьОбъект("Документ.РезРаспределИздержек");
Док.ВыбратьДокументы(ДатаУсловий,ДатаУсловий);
Пока Док.ПолучитьДокумент()=1 Цикл 
	ТЗВозврат.НоваяСтрока(); 
	ТЗВозврат.Документ = Док.ТекущийДокумент();
	ТЗВозврат.Подраздел = Док.Подраздел;
	ТЗВозврат.ПервПарам = Док.ПервПарам;
	ТЗВозврат.СуммаПервПарам = Док.СуммаПервПарам;
	ТЗВозврат.МинСуммаПервПарам = Док.МинСуммаПервПарам;
	ТЗВозврат.КолЮрЛицПодраздел = Док.КолЮрЛицПодраздел;
	ТЗВозврат.СуммаКолЮрЛиц = Док.СуммаКолЮрЛиц;
	ТЗВозврат.ОстПарам = Док.ОстПарам;
	ТЗВозврат.ПарамАЙТи = Док.ПарамАЙТи;
	ТЗВозврат.ДатЛог = Док.ДатЛог;
	ТЗВозврат.ДатСклад = Док.ДатСклад;
	ТЗВозврат.ГруппаОфис = Док.ГруппаОфис;
	ТЗВозврат.КоэфОбъем = Док.КоэфОбъем;
	ТЗВозврат.ТЗРаспредел = СоздатьОбъект("ТаблицаЗначений");
	ТЗВозврат.ТЗРаспредел.НоваяКолонка("Подраздел","Справочник.Подразделения",,,"Подразделение",7); 
	ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолПерсонала","Строка",25,,"Колич. персонала",5);
	ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолЮрЛицПодраздел","Строка",25,,"Колич. юр. лиц",5);
	ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолРабМест","Строка",25,,"Колич. рабочих мест",5); 
	ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолВыпДоставок","Строка",25,,"Колич. доставок",5); 
	ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолВыпЗаявок","Строка",25,,"Колич. заявок",5);
	ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолНормЧас","Строка",25,,"Колич. нормочас",5);
	ТЗВозврат.ТЗРаспредел.НоваяКолонка("ПроцНачисления","Число",3,0,"% начисления",5); 
	ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолПродаж","Строка",25,,"Колич. продаж",5); 
	ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолСкладПлощ","Строка",25,,"Колич. склад. площ.",5);
	ТЗВозврат.ТЗРаспредел.НоваяКолонка("РаспредСумма","Число",10,2,"Сумма распределенная",5);
	Док.ВыбратьСтроки();
        Пока Док.ПолучитьСтроку()=1 Цикл
	        ТЗВозврат.ТЗРаспредел.НоваяСтрока();
		ТЗВозврат.ТЗРаспредел.Подраздел = Док.ПодразделРаспред; 
		ТЗВозврат.ТЗРаспредел.КолПерсонала = Док.КолПерсонала;
		ТЗВозврат.ТЗРаспредел.КолЮрЛицПодраздел = Док.КолЮрЛицПодразд;
		ТЗВозврат.ТЗРаспредел.КолРабМест = Док.КолРабМест;      
		ТЗВозврат.ТЗРаспредел.КолВыпДоставок = Док.КолВыпДоставок; 
		ТЗВозврат.ТЗРаспредел.КолВыпЗаявок = Док.КолВыпЗаявок;
		ТЗВозврат.ТЗРаспредел.КолНормЧас = Док.КолНормЧас;
		ТЗВозврат.ТЗРаспредел.ПроцНачисления = Док.ПроцНачисления; 
		ТЗВозврат.ТЗРаспредел.КолПродаж = Док.КолПродаж; 
		ТЗВозврат.ТЗРаспредел.КолСкладПлощ = Док.КолСкладПлощ;
		ТЗВозврат.ТЗРаспредел.РаспредСумма = Док.РаспредСумма;
	КонецЦикла;
КонецЦикла;


Далее используем данные вложенной таблицы стандартно.
Процедура СохранитьУсловияРаспред(ТЗСохран) 
	Док = СоздатьОбъект("Документ.РезРаспределИздержек");
	ТЗСохран.ВыбратьСтроки();
	Пока ТЗСохран.ПолучитьСтроку()=1 Цикл
		Если ПустоеЗначение(ТЗСохран.Документ)=0 Тогда
			Док.НайтиДокумент(ТЗСохран.Документ); 
			Док.УдалитьСтроки();
		Иначе
			Док.Новый();	
		КонецЕсли;
		
		Док.ДатаДок = КонДата;  
		Док.Подраздел = ТЗСохран.Подраздел;
		Док.ПервПарам = ТЗСохран.ПервПарам;
		Док.СуммаПервПарам = ТЗСохран.СуммаПервПарам;
		Док.МинСуммаПервПарам = ТЗСохран.МинСуммаПервПарам;
		Док.КолЮрЛицПодраздел = ТЗСохран.КолЮрЛицПодраздел;
		Док.СуммаКолЮрЛиц = ТЗСохран.СуммаКолЮрЛиц;
		Док.ОстПарам = ТЗСохран.ОстПарам;
		Док.ПарамАЙТи = ТЗСохран.ПарамАЙТи;
		Док.ДатЛог = ТЗСохран.ДатЛог;
		Док.ДатСклад = ТЗСохран.ДатСклад;
		Док.ГруппаОфис = ТЗСохран.ГруппаОфис;
		Док.КоэфОбъем = ТЗСохран.КоэфОбъем; 
		
		ТЗСохран.ТЗРаспредел.ВыбратьСтроки();
		Пока ТЗСохран.ТЗРаспредел.ПолучитьСтроку()=1 Цикл
			Док.НоваяСтрока();
			Док.ПодразделРаспред = ТЗСохран.ТЗРаспредел.Подраздел;
			Док.КолПерсонала = ТЗСохран.ТЗРаспредел.КолПерсонала;
			Док.КолЮрЛицПодразд = ТЗСохран.ТЗРаспредел.КолЮрЛицПодраздел;
			Док.КолРабМест = ТЗСохран.ТЗРаспредел.КолРабМест;
			Док.КолВыпДоставок = ТЗСохран.ТЗРаспредел.КолВыпДоставок;
			Док.КолВыпЗаявок = ТЗСохран.ТЗРаспредел.КолВыпЗаявок;
			Док.КолНормЧас = ТЗСохран.ТЗРаспредел.КолНормЧас;
			Док.ПроцНачисления = ТЗСохран.ТЗРаспредел.ПроцНачисления;
			Док.КолПродаж = ТЗСохран.ТЗРаспредел.КолПродаж;
			Док.КолСкладПлощ = ТЗСохран.ТЗРаспредел.КолСкладПлощ;
			Док.РаспредСумма = ТЗСохран.ТЗРаспредел.РаспредСумма;
		КонецЦикла;
			
		Док.Записать();
	КонецЦикла;
КонецПроцедуры	// СохранитьУсловияРаспред



2

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Shaman100M 1191 24.12.07 13:33 Сейчас в теме
А можно по-подробнее? Из примера кода понятно только, что в ТЗ можно сохранять и шапку, и табличную часть документа.
2. Rom_Kat 12 24.12.07 13:41 Сейчас в теме
дело вовсе не в документе.
Можно создать объект типа ТЗВозврат.ТЗРаспредел = СоздатьОбъект("ТаблицаЗначений");
и потом его читать ТЗВозврат.ТЗРаспредел.ВыбратьСтроки()

Ща статью обновлю ))
А то действительно не сильно понятно нафиг оно надо )))
4. Shaman100M 1191 24.12.07 14:15 Сейчас в теме
(2) Да, есть такое.
http://infostart.ru/profile/8196/projects/1354/
В ТЗ и СЗ можно создавать и использовать много других объектов, не только "ТаблицаЗначений", например, хранить и обращаться ко всем групповым контекстам открытых форм.
5. Rom_Kat 12 24.12.07 14:34 Сейчас в теме
(4) отлично. Можешь мне минус поставить. ;-)
7. Shaman100M 1191 24.12.07 14:59 Сейчас в теме
(5) Ну, я не настолько подвержен влиянию чужой самокритики. :)
(6) Спасибо. От прикладных особенностей реализации идею можно отвязать и обобщить, но, как замечено, для этого нужно время. Если времени не хватает, значит, оно тратится на что-то другое (на работу, например), что тоже неплохо.
3. Rom_Kat 12 24.12.07 13:44 Сейчас в теме
Вот и вся статья. Не судите строго )))
6. Rom_Kat 12 24.12.07 14:43 Сейчас в теме
(5+) Клевая демонстрашка. А у меня только на прикладные вещи времени и хватает (((( Их к сожалению не выложишь так как слишком к предметной области привязаны.
8. CheBurator 24.12.07 17:18 Сейчас в теме
А к этому еще почитать статью отчетов с вертикальными/горизонтальными группировками на основе ТЗ...
9. Rom_Kat 12 24.12.07 17:28 Сейчас в теме
10. JohnyDeath 294 24.12.07 17:43 Сейчас в теме
Ну раз пошла такая пьянка, то смотрим все на Индексированную таблицу http://www.1cpp.ru/docum/html/IndexedTable.html Особенно на методы Группировать http://www.1cpp.ru/docum/html/IndexedTable.html#group и Загрузить http://www.1cpp.ru/docum/html/IndexedTable.html#load
11. Rom_Kat 12 24.12.07 17:51 Сейчас в теме
12. JohnyDeath 294 24.12.07 18:28 Сейчас в теме
(11) ну если используешь, зачем тогда тебе:
Код
 ТЗВозврат.ТЗРаспредел = СоздатьОбъект("ТаблицаЗначений");
   ТЗВозврат.ТЗРаспредел.НоваяКолонка("Подраздел","Справочник.Подразделения",,,"Подразделение",7); 
   ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолПерсонала","Строка",25,,"Колич. персонала",5);
   ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолЮрЛицПодраздел","Строка",25,,"Колич. юр. лиц",5);
   ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолРабМест","Строка",25,,"Колич. рабочих мест",5); 
   ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолВыпДоставок","Строка",25,,"Колич. доставок",5); 
   ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолВыпЗаявок","Строка",25,,"Колич. заявок",5);
   ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолНормЧас","Строка",25,,"Колич. нормочас",5);
   ТЗВозврат.ТЗРаспредел.НоваяКолонка("ПроцНачисления","Число",3,0,"% начисления",5); 
   ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолПродаж","Строка",25,,"Колич. продаж",5); 
   ТЗВозврат.ТЗРаспредел.НоваяКолонка("КолСкладПлощ","Строка",25,,"Колич. склад. площ.",5);
   ТЗВозврат.ТЗРаспредел.НоваяКолонка("РаспредСумма","Число",10,2,"Сумма распределенная",5);
Док.ВыбратьСтроки();
        Пока Док.ПолучитьСтроку()=1 Цикл
           ТЗВозврат.ТЗРаспредел.НоваяСтрока();
      ТЗВозврат.ТЗРаспредел.Подраздел = Док.ПодразделРаспред; 
      ТЗВозврат.ТЗРаспредел.КолПерсонала = Док.КолПерсонала;
      ТЗВозврат.ТЗРаспредел.КолЮрЛицПодраздел = Док.КолЮрЛицПодразд;
      ТЗВозврат.ТЗРаспредел.КолРабМест = Док.КолРабМест;      
      ТЗВозврат.ТЗРаспредел.КолВыпДоставок = Док.КолВыпДоставок; 
      ТЗВозврат.ТЗРаспредел.КолВыпЗаявок = Док.КолВыпЗаявок;
      ТЗВозврат.ТЗРаспредел.КолНормЧас = Док.КолНормЧас;
      ТЗВозврат.ТЗРаспредел.ПроцНачисления = Док.ПроцНачисления; 
      ТЗВозврат.ТЗРаспредел.КолПродаж = Док.КолПродаж; 
      ТЗВозврат.ТЗРаспредел.КолСкладПлощ = Док.КолСкладПлощ;
      ТЗВозврат.ТЗРаспредел.РаспредСумма = Док.РаспредСумма;
   КонецЦикла; 
Показать полностью

Вместо всего этого можно написать всего 2 строчки:
Код
 ТЗВозврат.ТЗРаспредел = СоздатьОбъект("ИндексированнаяТаблица");
ТЗВозврат.ТЗРаспредел.Загрузить(Док); 
Показать полностью

!
13. Rom_Kat 12 24.12.07 18:57 Сейчас в теме
(12) можно было бы, но в обработке тогда переписывать много надо, а времени нет
15. Rom_Kat 12 21.05.08 11:24 Сейчас в теме
vacancy9

Да и у тебя я смотрю все также дела ;-)
16. Rom_Kat 12 21.05.08 11:33 Сейчас в теме
vacancy9
В асю выходи пообщаемся
19. Rom_Kat 12 21.05.08 14:13 Сейчас в теме
Да ты не понял меня. Я и писать ничего не собирался. И в этом блоге врядли кто еще увидит наш разговор )))
Твое мнение обо мне не объективно. А мое о тебе как о работодателе сложилось еще тогда и утвердилось после увиденных здесь вакансий. Если кто и спросит, что нигативного я вынес из сотрудничества с тобой, я конечно раскажу. А так сидеть писать в форум времени нет.
21. tango 484 21.05.08 16:45 Сейчас в теме
22. vasilykushnir 21.05.08 17:08 Сейчас в теме
23. Rom_Kat 12 21.05.08 19:38 Сейчас в теме
ну задел человека мой комментарий и из-за этого он даже мой блог посетил ))))
25. Rom_Kat 12 21.05.08 20:28 Сейчас в теме
может я конечно и ламер. Звез с неба не хватаю. Но 1сом занимаюсь почти 5 лет и многое из того что сделал работает до сих пор. И люди которые работают с моими ламерскими программами не жалуются.
26. Rom_Kat 12 21.05.08 20:31 Сейчас в теме
Ну и профи они не от того профи, что существуют ламеры-программеры.
27. Rom_Kat 12 21.05.08 21:21 Сейчас в теме
"много ламеров-программеров, которые проснулись однажды утром, почесались, и их осенило, "а займуська я один эсиной!"."

Я как посмотрю ты довольно часто просыпался с подобной мыслью.Шутка ли сказать 16 языков программирования.
Оставьте свое сообщение

См. также

Дистрибьюция 7.7. Часть 1. Жизненный цикл заявки покупателя. Одна заявка покупателя, много адресов доставки. 1

Статья Программист Нет файла v7.7 1С7:Комплекс 1С7:ТиС УУ Бесплатно (free) Практика программирования Адаптация типовых решений

Описан способ работы с учетом расписания с приоритетными покупателями - торговыми сетями (основными покупателями) в торговой или комплексной учетной системе на 1С 7.7. Множественная заявка покупателя на несколько торговых точек.

14.10.2019    569    ksnik    0       

Проверка часового пояса 9

Статья Программист Нет файла v7.7 Windows Бесплатно (free) Практика программирования

При использовании терминалок для удаленных баз, иногда при входе в базу данных необходимо исключить возможность входа пользователей с компьютеров с другим часовым поясом. Например, работают в Новосибирской базе с временем UTC +6 и пытаются зайти в базу с UTC +3.

16.05.2016    8192    kudenzov    3       

[ПОЛЕЗНЯШКА, 7.7] Как посчитать итоги по документам черным запросом с изподвывертом? 13

Статья Программист Нет файла v7.7 1cv7.md Windows Бесплатно (free) Практика программирования

Мелкая полезняшка, считает запросом итоговую сумму документов и количество документов.

12.03.2016    15486    CheBurator    18       

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция 111

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования WEB

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    48380    Serginio    33       

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д. 37

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент WEB

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    25410    Serginio    22       

Использование классов .Net в 1С для новичков 147

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент Универсальные функции

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    62831    Serginio    104       

Пример HTTP запроса к УТМ ЕГАИС на платформе 1С 7.7 15

Статья Программист Нет файла v7.7 1cv7.md Россия Windows Оптовая торговля Розничная торговля Бесплатно (free) Практика программирования Внешние источники данных

Запрос реализован на объекте ServerXMLHTTP из встроенной в Windows библиотеки MSXML, результатом запроса является XML объект DOMDocument из той же библиотеки MSXML со встроенным интерфейсом его обработки

16.12.2015    20007    Palmer1976    3       

Экспорт нескольких MXL таблиц в один XLS файл, на отдельные листы. Простой алгоритм 20

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Статья посвящена распространённому вопросу - как сохранить несколько таблиц (отчетов) в формате MXL, с которым работает 1С, на отдельные листы одного Excel файла. Освещается простой алгоритм решения проблемы штатными средствами, без использования внешних модулей и библиотек (не относящихся к 1С и Excel).

23.11.2015    13959    etmarket    14       

Процедура расшифровки ячейки таблицы в отчетах 1С 7.7 11

Статья Программист Нет файла v7.7 1cv7.md Windows Бесплатно (free) Практика программирования Универсальные функции

Хочу поделиться с вами универсальной процедурой для расшифровки ячеек печатной формы отчетов в 1С 7.7.

24.09.2015    13788    Anzhey    13       

Универсальный способ сравнения таблиц 15

Статья Программист Нет файла v7.7 v8 Бесплатно (free) Практика программирования

На эту тему уже есть статьи, но этот способ нигде не описан. Хотя я его использую с тех пор, как занимаюсь программированием. Его преимущество в простоте и универсальности: можно применять на 1С, SQL, а также в любом другом языке программирования.

05.07.2015    14799    json    1       

Числа прописью в родительном падеже в 7.7? Легко! 13

Статья Программист Нет файла v7.7 1cv7.md Windows Бесплатно (free) Практика программирования

Вывод числительных прописью в родительном падеже штатными средствами в три строчки кода.

20.06.2015    10046    gimalaj    3       

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним 78

Статья Программист Нет файла v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    70918    shmellevich    35       

Исправление в типовой комплексной конфигурации глобальной функции глВсеРеквизитыДокументаЗаполнены() 4

Статья Программист Нет файла v7.7 1С7:Комплекс Россия Windows Бесплатно (free) Практика программирования

В типовых конфигурациях глобальная функция глВсеРеквизитыДокументаЗаполнены() не работает с реквизитами табличной части. Данная статья содержит текст исправленной функции, корректно проверяющей табличную часть.

20.08.2014    6000    hvv2002    0       

ЗаполнитьЗначенияСвойств - заставляем работать в 7.7 11

Статья Программист Нет файла v7.7 1cv7.md Бесплатно (free) Практика программирования

Если вы используете в работе 1С:Предприятие 8.х, то наверняка знакомы и с замечательной системной процедурой, как ЗаполнитьЗначенияСвойств(). Ее использование помогает значительно упростить написание программного кода в ряде случае, делает его (код) более наглядным и простым. Но что же делать тем, кто до сих пор использует (постоянно или иногда) 1С:Предприятие 7.7?

24.07.2014    18749    tomvlad    5       

Полезные функции. Склонение (должность и фамилия подписантов). Любой язык 3

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования

Уехал директор в командировку, отпуск... , оставил доверенность на хозяйственные операции на другого сотрудника. Все договора и другие документы в обмороке - "подписант" теперь другой, по тексту тоже много правок... Пересмотрел много публикаций, вариантов много, не приглянулось. Сделал свой "Баян" . У меня всего-то крутится пять фигурантов ... Нет простого, наглядного и всепогодного варианта без языкового барьера. Всем процессом управляет пользователь.

03.03.2014    15330    kompas-dm    5       

Реализация Ctrl+Z в 1С 7.7 (ТиС) 7

Статья Программист Нет файла v7.7 1С7:ТиС Windows Бесплатно (free) Практика программирования

В семерке отсутствует возможность отменять последнее действие в формах документов. В данной статье будет рассмотрен пример реализации данной функции. Возможно, кому-нибудь пригодится.

15.07.2013    5550    a.o.popova    10       

Копия напечатанного документа или как спрятать документ. 2

Статья Программист Нет файла v7.7 Бесплатно (free) Журнал регистрации Практика программирования

Возникла необходимость, чтобы при печати определённого документа (даже потом не сохранённого), создавалась его копия, т.е. запись всех напечатанных документов. (В результате чего возникла такая потребность, полагаюсь на вашу фантазию). В итоге получилось два варианта решения, остановился на втором.

11.04.2013    13112    Dima_    8       

Автосохранение документа в 1С 7.7 3

Статья Программист Нет файла v7.7 1cv7.md Россия Windows Бесплатно (free) Практика программирования

В данной статье мы рассмотрим автосохранение документа в 1С 7.7!

22.03.2013    11065    aagubarev    25       

Конвертация данных 2.1 (2.1.3.1) 1С 7.7 - 1С 8.Х передача параметра ПКО 14

Статья Системный администратор Программист Нет файла v7.7 v8 КД Бесплатно (free) Практика программирования Перенос данных из 1С7.7 в 1C8.X

Передача параметров по умолчанию доступна только для баз 1С 8.х -1С 8.х. Показан пример, как передать параметры из 1С 7.7 - 1С 8.х

10.12.2012    22201    serg_gres    6       

Устранение проблемы при работе с полем, которое ограничено маской ввода 3

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

Для поля, у которого установлена маска ввода, перед программной инициализацией необходимо начальное значение преобразовать к значению в соответствии с маской, иначе буду потеряны символы в местах разделителях. В данной публикации приведена функция, которая универсально выполняет данное действие.

08.08.2012    14133    www2000    4       

Динамическая фильтрация в справочнике при вводе наименования 15

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

Позволяет в открытой форме списка, выбора или подбора справочника производить динамическую фильтрацию по набранному наименованию.

02.07.2012    14242    maxpiter    62       

Обновление базы 1с 7.7. с помощью движка 1с 8.х 92

Статья Системный администратор Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования Администрирование данных 1С

Если Вас угораздило в стандартную типовую конфу внести правки, причем в самый большой модуль, а именно глобальный. Если к тому же Вы внесли изменение в какую-то стандартную функцию, в которой 1с сама регулярно чего-то меняет, то любое обновление начинает доставать. Используя возможности движка платформы 1с 8.х можно существенно сэкономить себе время и нервы.

28.04.2012    15872    Valerich    31       

v77. Робот 43

Инструменты и обработки no Внешняя обработка (ert,epf) v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

Исполнитель Робот. Учебное пособие по программированию для детей дошкольного возраста. Без внешних компонент.

09.04.2012    10208    54    item    18       

Запуск внешней обработки по расписанию v7.7 39

Статья Программист Нет файла v7.7 1cv7.md Россия Windows Бесплатно (free) Практика программирования Администрирование данных 1С

Неоднократно возникали задачи организовать, например ежедневную выгрузку и отправку отчетов по эл.почте, и вот…

20.03.2012    39508    Yury1001    17       

v77. Закладки в многоуровневом справочнике аля Total Commander 28

Инструменты и обработки Программист Конфигурация (md, cf) v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

В больших многоуровневых справочниках можно ускорить доступ пользователю к наиболее популярным группам.

09.03.2012    8819    44    item    17       

v77. Паинт 53

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

v77. 1С:Паинт :) Такая вот игрушка. Без внешних компонент.

06.03.2012    11915    81    item    38       

Как уменьшить количество заблокированных объектов 26

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

История о том как я решил пересобрать форму справочника клиентов и чем это все закончилось...

12.01.2012    13201    ShEvOvIcH    18       

Регистрация текста окна сообщений 4

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

Для контроля работы пользователей потребовалось записывать текст окна сообщений в файл. Получился простейший механизм регистрации лог-файла. Удержать роста папки "Temp", в качестве рекомендации, может использование bat-файла, который будет чистить или архивировать получаемые логи. Таких батников в инете полным-полно. P.S. Особо по форуму не смотрел, может, есть уже такое.

28.11.2011    6392    sdin101    9       

7.7.: Готовим md-файл для публикации. В картинках. 46

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

Вы доработали типовую конфигурацию: скажем, добавили новый Документ, и хотите им поделиться с обществом ИС. Но нельзя же выложить МД-шник целиком, это будет нарушением правил. И как тут быть?

14.09.2011    15055    Арчибальд    21       

Учет доверенностей 6

Статья Программист Нет файла v7.7 1С7:Бух 1С7:Комплекс 1С7:ТиС 1С7:ПУБ Документооборот и делопроизводство Бесплатно (free) Практика программирования

В расходных документах есть необходимость проставления доверенности. Но заносить каждый раз одни и те же данные бывает утомительно. особенно при больших оборотах.

08.09.2011    9568    Sykoku    8       

Методика расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года (вариант) 32

Статья Программист Нет файла v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

В статье рассмотрен один из возможных вариантов расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года.

14.06.2011    19415    vkr    48       

Выбор Движений документа по конкретному регистру, с помощью прямого запроса 0

Инструменты и обработки Программист Конфигурация (md, cf) v7.7 openconf 1cv7.md Россия Бесплатно (free) Практика программирования

Чтобы узнать какие движения сделал документ по конкретному регистру, в моем случае это регистр "ОстаткиПоСчетам" (оборотный), была написана следующая функция в глобальном модуле. Работает только для SQL версии и установленной внешнй компонентой 1С++!

26.05.2011    10541    Vix    4       

Прямой запрос на выборку подчиненных документов 6

Инструменты и обработки Программист Конфигурация (md, cf) v7.7 openconf 1cv7.md Россия Бесплатно (free) Практика программирования

Иногда необходимо получить список или таблицу документов, подчиненных выбранному. Для этого в глобальном модуле была написана функция с прямым запросом на выборку подчиненных документов. Работает только в SQL версии и при установленной внешней компоненте 1С++ !

26.05.2011    16861    Vix    5       

Некоторые ошибки и «проблемные» особенности реализации встроенного языка платформы 1С:Предприятие 7.7 96

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Описание некоторых ошибок и особенностей реализации встроенного языка, которые создают «подводные камни» при программировании, а также возможных способов обхода этих проблем из собственного опыта работы на платформе 1С:Предприятие 7.7.

08.04.2011    42048    AleksR    102       

Монопольно ли запущена база 7.7 для SQL. Снятие single user в sql 9

Статья Системный администратор Программист Нет файла v7.7 openconf 1cv7.md Россия Бесплатно (free) Информационная безопасность Практика программирования

T-SQL скрипт, позволяющий определить монопольно ли запущена база на сервере SQL, а также перевести базу в multi user

11.03.2011    16433    d0dger    12       

Отпуск по уходу за ребенком. Расчет по-новому и по-старому 32

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Управление персоналом (HRM) Бесплатно (free) Практика программирования

По новому законодательству расчет среднего заработка для отпуска по уходу можно производить как по старым правилам, так и по новым, на усмотрение сотрудника. Реализуем это в ЗиК.

11.03.2011    10199    Nicholas    9       

Ошибки формата файла 2-НДФЛ в ЗиК релиз 306 100

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия НУ Зарплата НДФЛ Бесплатно (free) Практика программирования

Ошибки 2НДФЛ в релизе: файл формируется как для ЮЛ, даже если работодатель ИП, опечатка "Отчетсвто", и указание имени файла с расширением. Нужно подправить отчет "СправкиПоНДФЛ".

02.02.2011    17130    1st    6       

ЗиК 305 ЗиК 306 Больничный лист. 107

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Для переходящих больничных листов за счет работодателя оплачивается 2 дня, а не 3. Первоисточник: http://forums.kuban.ru/forum/viewtopi...669&page=2

25.01.2011    12221    Cvetic    26