Автоматическое тестирование ИБ через Web-Сервисы.

Публикация № 205703

Разработка

Веб Сервисы Веб-Сервисы Web-Сервисы 1C Тестирование Проверка Автоматическое Автомат Web-Service

Время идет, количество клиентов растет как и количество проблем. У кого то криво ведется учет и постоянно появляются отрицательные остатки, у кого то еще что то. Вот и появилась идея сделать систему которая в автоматическом режиме будет периодически проверять те самые отрицательные остатки или еще что то. Задача стояла сделать все как можно универсальней, что бы можно было приспособить ни только под отрицательные остатки. Под капотом более менее универсальное и интересное решение.

Время идет, количество клиентов растет как и количество проблем. У кого то криво ведется учет и постоянно появляются отрицательные остатки, у кого то еще что то. Вот и появилась идея сделать систему которая в автоматическом режиме будет периодически проверять те самые отрицательные остатки или еще что то. Задача стояла сделать все как можно универсальней, что бы можно было приспособить ни только под отрицательные остатки.

Для решения проблемы была выбрана технология Веб-Сервисы. Что требовалось сделать:

На сервере (Конфигурация КРС контроль работы системы) человек пишет код тестирования, именно код а ни какие то параметры. Потом этот код передается на сервер нашего клиента, и там выполняется. После чего результат выполнения отправляется обратно на наш сервер.

Для этого на нашем сервере и у клиента должен быть заведен Веб сервис. 

А теперь как это все выглядит:

Есть конрагенты, у каждого контрагента может быть несколько баз, поэтому введен справочник "КРССправочникКонфигурацийКонтрагентов" где и указывается что контрагенту "ООО" и его конфигурации "Управление торговлей База для Ведения учета" присвоен номер "211123".

Далее в справочнике "КРСОбщиеПараметрыПроверки" мы создаем параметры проверки, пишим код и присваеваем тип конфигурации.

После чего запоняем справочник "КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций" там есть выбор шаблонов или можно написать новый код, указываем период проверки, через какое время сообщять если проверка просрочена и т.д выглядит так

 

На каждом сервере клиента указываем параметры подключения

У нас имеется два регламентных задания одно это сторона сервера, другое клиента.

  1. КонтрольРаботыСистемыКлиент
  2. КонтрольРаботыСистемыСервер

Листинг первого 

Функция ЗапуститьПроверкуКонфигурации() Экспорт
	Результат = "";
	АдресФайла = Константы.КонтрольРаботыРасположениеФайлаСервера.Получить();
	Определение = Новый WSОпределения(АдресФайла,"СамоТестирование","");
	Сервис = Новый WSПрокси(Определение,"http://www.webtest.org","КРСВернутьПараметрыПроверкиКлиенту","КРСВернутьПараметрыПроверкиКлиентуSoap");
	Сервис.Пользователь = "СамоТестирование";
	Сервис.Пароль = "";
	Ид = Константы.КРМИДКлиентаВУКККод1С.Получить();
	Конф = Константы.КРМИДКлиентаВУКККонфигурация.Получить();
	ВыборкаСервис = Сервис.ПолучитьПараметрыПроверкиКлиента(Ид,Конф);
	Для Каждого Парам Из ВыборкаСервис.ПараметрКлиент Цикл
		Попытка
			Выполнить(Парам.Текст);
		Исключение
			Результат = "При выполнении кода тестирования возникла ошибка!";
		КонецПопытки;
		Если Результат = "" Тогда
			Парам.Текст = "Проверка прошла успешно. Ошибок не обнаружено!";   
			Парам.ТребуетсяВмешательство = Ложь;
		Иначе
			Парам.Текст = Результат;
			Парам.ТребуетсяВмешательство = Истина;
		КонецЕсли;
	КонецЦикла;
	РезультатВыполненияЗаписиЛога = Сервис.ЗаписатьЛог(ВыборкаСервис,Ид,Конф);
	Если РезультатВыполненияЗаписиЛога = 0 Тогда
		///Процедура создания сообщения пользователю	
	КонецЕсли;
	Возврат РезультатВыполненияЗаписиЛога;
КонецФункции

Происходит подключение к серверу и получение параметров проверки с сервера.

Листинг второго

Процедура КРСКонтрольРаботыКлиентскихФоновыхСлужб() Экспорт
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	               |	ЕСТЬNULL(КРСЛогВыполненияЗаданийСрезПоследних.Контрагент, 0) КАК Контрагент,
	               |	КРСЛогВыполненияЗаданийСрезПоследних.Параметр,
	               |	КРСЛогВыполненияЗаданийСрезПоследних.ДатаСледующегоСтарта,
	               |	КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций.СообщитьЕслиЗаданиеПросроченоБолееЧемМинут,
	               |	КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций.РасположениеФайла,
	               |	КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций.Владелец
	               |ИЗ
	               |	Справочник.КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций КАК КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций
	               |		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КРСЛогВыполненияЗаданий.СрезПоследних КАК КРСЛогВыполненияЗаданийСрезПоследних
	               |		ПО (КРСЛогВыполненияЗаданийСрезПоследних.Параметр = КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций.Ссылка)";
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		Если Выборка.Контрагент = 0 Тогда
			//Сформировать сообщение ответственному, Самотестирование не выполнялось. Проверте настройки на стороне клиента!
			Продолжить;
		КонецЕсли;
		Если  ТекущаяДата() > Выборка.ДатаСледующегоСтарта +(Выборка.СообщитьЕслиЗаданиеПросроченоБолееЧемМинут*60)  Тогда
			
			Попытка
				Определение = Новый WSОпределения(Выборка.РасположениеФайла);
				Сервис = Новый WSПрокси(Определение,"http://www.webtest.org","КРСПолучитьПараметрыПроверки","КРСПолучитьПараметрыПроверкиSoap");
				Результат = Сервис.ЗапуститьПроверкуКонфигурации();
				///Сформировать ообщение сотруднику о не работе фонового задания клиента
				Если Результат = 0 Тогда
					///Сформировать ообщение сотруднику, "При записи лога возникли ошибки"	
				КонецЕсли;
			Исключение
				///Сформировать сообщение сотруднику о недоступности вебсервиса клиента
				Сообщить(Выборка.Параметр);
			КонецПопытки;
			
		КонецЕсли;
	КонецЦикла;
КонецПроцедуры

Данная процедура ведет проверку выполнялись проверки или нет, если нет пробует запустить проверку удаленно на клиенте.

После дого как выполняется проверка все пишется в ригистр "КРСЛогВыполненияЗаданий".

 

Листинг веб сервисов 

"КРСВернутьПараметрыПроверкиКлиенту"

//!! Козырев 25/10/12
//Веб сервис сервера
//Функц. вовзращает таблицу параметров клиенту.
Функция ПолучитьПараметрыПроверкиКлиента(Ид,Конф) Экспорт
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций.Наименование,
	|	КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций.КодПроверки
	|ИЗ
	|	Справочник.КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций КАК КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций
	|ГДЕ
	|	КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций.Владелец.Код = &КонтрагентКод
	|	И КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций.Конфигурация.Код = &Код";
	Запрос.УстановитьПараметр("КонтрагентКод",Строка(Ид));
	Запрос.УстановитьПараметр("Код",Строка(Конф));
	ТаблицаПараметровТип = ФабрикаXDTO.Тип("http://www.webtest.org","Параметры");
	ТаблицаПараметров = ФабрикаXDTO.Создать(ТаблицаПараметровТип);
	ПараметрТип = ФабрикаXDTO.Тип("http://www.webtest.org","Параметр");
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		Параметр = ФабрикаXDTO.Создать(ПараметрТип);
		Параметр.Наименование = Выборка.Наименование;
		Параметр.Текст = Выборка.КодПроверки;
		ТаблицаПараметров.ПараметрКлиент.Добавить(Параметр);
	КонецЦикла;
	Возврат ТаблицаПараметров;
КонецФункции
//Вызывается с клиента.Записывает лог проверки системы клиента.
//Возвращает 0 или 1 (0- запись лога НЕ удалась, 1-запись лога прошла успешна).
Функция ЗаписатьЛог(ТаблицаТестирования,Ид,Конфигурация) Экспорт
	КодВыполненияЗаписи = 0 ; 
	Попытка
		Для Каждого Парам Из ТаблицаТестирования.ПараметрКлиент Цикл
			Рег = РегистрыСведений.КРСЛогВыполненияЗаданий.СоздатьМенеджерЗаписи();
			Рег.Период = ТекущаяДата();
			Рег.Контрагент = Справочники.Контрагенты.НайтиПоКоду(Ид);
			Рег.Параметр = Справочники.КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций.НайтиПоНаименованию(Парам.Наименование);
			Рег.Результат = Парам.Текст;
			Рег.Конфигурация = Справочники.КРССправочникКонфигурацийКонтрагентов.НайтиПоКоду(Конфигурация);
			Рег.ЕстьОшибки = Парам.ТребуетсяВмешательство;
			Рег.ДатаСледующегоСтарта = ТекущаяДата()+(Справочники.КРСДействующиеПараметрыПроверкиКлиентскихКонфигураций.НайтиПоНаименованию(Парам.Наименование).ПериодПроверки*60);
			Рег.Записать();
			КодВыполненияЗаписи = 1;
		КонецЦикла;	
	Исключение
		КодВыполненияЗаписи = 0;
	КонецПопытки;
	Возврат КодВыполненияЗаписи;
КонецФункции
//! Козырев 25/10/12
 

Второй "КРСПолучитьПараметрыПроверки"

//!! Козырев 25/10/12
//Веб сервис клиента.
//проц. запуска проверки системы соеденяется с веб сервисом Сервера, получает таблицу параметров проверки, выполняет проверку, вызывает функцию записи лога на Сервере
// возвращает 0 или 1 (0-запись лога НЕ удалась, 1- запись лога прошла успешно) 
Функция ЗапуститьПроверкуКонфигурации() Экспорт
	Результат = "";
	АдресФайла = Константы.КонтрольРаботыРасположениеФайлаСервера.Получить();
	Определение = Новый WSОпределения(АдресФайла,"СамоТестирование","");
	Сервис = Новый WSПрокси(Определение,"http://www.webtest.org","КРСВернутьПараметрыПроверкиКлиенту","КРСВернутьПараметрыПроверкиКлиентуSoap");
	Сервис.Пароль = "";
	Сервис.Пользователь = "СамоТестирование";
	Ид = Константы.КРМИДКлиентаВУКККод1С.Получить();
	Конф = Константы.КРМИДКлиентаВУКККонфигурация.Получить();
	ВыборкаСервис = Сервис.ПолучитьПараметрыПроверкиКлиента(Ид,Конф);
	Для Каждого Парам Из ВыборкаСервис.ПараметрКлиент Цикл
		Попытка
			Выполнить(Парам.Текст);
		Исключение
			Результат = "При выполнении кода тестирования возникла ошибка!";
		КонецПопытки;
		Если Результат = "" Тогда
			Парам.Текст = "Проверка прошла успешно. Ошибок не обнаружено!";   
			Парам.ТребуетсяВмешательство = Ложь;
		Иначе
			Парам.Текст = Результат;
			Парам.ТребуетсяВмешательство = Истина;
		КонецЕсли;
	КонецЦикла;
	РезультатВыполненияЗаписиЛога = Сервис.ЗаписатьЛог(ВыборкаСервис,Ид,Конф);
	Если РезультатВыполненияЗаписиЛога = 0 Тогда
		///Процедура создания сообщения пользователю	
	КонецЕсли;
	Возврат РезультатВыполненияЗаписиЛога;
КонецФункции
//! Козырев 25/10/12

Тут думаю все понятно.

Для интеграции на сервере требуется что бы был справочник "Контрагенты" или можно переписать под свой.

Интеграция производиться простым сравнением и объединением по подсистемам. Вся система разбита на две подсистемы Клиентская часть и Сервераная.

P.S. Не судите строго:) это был мой первый опыт работы с Веб сервисами да и вообще с чем то подобным.

Скачать файлы

Наименование Файл Версия Размер
Файл конфигурации всей системы

.cf 58,59Kb
5
.cf 1 58,59Kb 5 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Новиков 292 31.10.13 14:21 Сейчас в теме
В типовых конфигурациях, для подобных выкрутасов есть выполнение отчетов по расписанию с отсылкой оного на e-mail.
2. WizaXxX 301 31.10.13 14:41 Сейчас в теме
Да потом данные из письма заносишь в 1с ручками а потом строишь отчеты...
Здесь же данные заносятся автоматом, плюс можно написать тестирование чего угодно.

Кому удобнее через почту, почему нет?! я что заставляю? мне такой вариант понравился больше.
3. Yashazz 3637 31.10.13 17:16 Сейчас в теме
Нечто мне подсказывает, что произвольный "код проверки" в таких случаях - это очаровательная дыра в безопасности. Ваши клиенты знают о подобной фиче?
AlX0id; planar74; VasMart; charushkin; DitriX; WizaXxX; +6 Ответить
4. WizaXxX 301 31.10.13 18:38 Сейчас в теме
Согласен , об этом не думал , вы имеете ввиду что можно написать запрос и получить данные из базы? Если так то все клиенты находятся у нас на поддержке и у нас итак имеется полный доступ, и про безопасность веб сервисов, можно использовать защищенное соединение.
5. DitriX 1843 01.11.13 21:38 Сейчас в теме
(4) что то мне подсказывает что на той стороне есть конструкция ВЫПОЛНИТЬ. И если это так - то это просто пипец :)
Если еще с 8.3, то там можно поставить режим безопасности. а иначе - можно получить доступ к серверу, а там уже ...

Не шутите так НИКОГДА :)

Если вы все равно делаете запросы, то передавайте структуру, и на сервере подставляете что вам надо.
Тогда на сервере смогут выполняться только запросы, и ничего больше.
Можно даже поставить ограничение на количество строк, которые возвращает сервер, что бы не смогли угнать данные одной пачкой.
Вам то не нужен список всех отрицательных товаров? Вам нужен только факт их наличия.

Так что переделайте это все, моя к вам просьба.

Иначе сейчас начинающие программисты - начнут это все копировать, а вы уж думайте о последствиях.
charushkin; +1 Ответить
6. WizaXxX 301 05.11.13 07:54 Сейчас в теме
(5) Спасибо за совет:) и на будущее учту что больше надо думать о безопасности.
Задача так и стояла сделать так что бы на стороне клиента можно было выполнить любой код. Задачу я выполнил но о безопасности даже не задумывался, видимо заказчика это устраивало раз он тоже ни чего не сказал.
7. charushkin 06.11.13 07:44 Сейчас в теме
(6)
видимо заказчика это устраивало раз он тоже ни чего не сказал

Заказчик мог об этом и не подумать. В любом случае, я бы на вашем месте предупредил его о возможных, скажем так, проблемах
8. WizaXxX 301 06.11.13 14:19 Сейчас в теме
Оставьте свое сообщение

См. также

Перенос объектов 1С Промо

Перенос данных из 1C8 в 1C8 v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Регистрация/снятие с регистрации объектов в планах обмена. И многое другое. Инструменты администратора в одной обработке.

1 стартмани

16.03.2015    94630    2045    moolex    199    

Интеграция с бонусной программой лояльности ManyBonus

Управление взаимоотношениями с клиентами (СRM) Розничная торговля WEB v8 Розница УУ Абонемент ($m)

ManyBonus.com - бонусная программа лояльности на базе мессенджеров. Позволяет регистрировать клиента в программе лояльности через Telegram, Viber, VK, отправлять коды скидок в мессенджеры, получать уведомления при списании/начислении бонусных баллов, альтернатива сообщениям СМС.

3 стартмани

07.01.2021    1888    2    Anton64    0    

FormCodeGenerator Программная доработка форм. Часть 2 (Режим работы "Режим сравнения форм") на примере ERP 2.5

Практика программирования Адаптация типовых решений Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Данная публикация является продолжением описания функционирования обработки "FormCodeGenerator " в режиме сравнения форм и генерирования кода на основании сравнения. Подходит для перевода уже доработанных форм с интерактивной доработки на программную. Данный режим работы обработки снизит издержки при дальнейших обновлениях конфигураций.

5 стартмани

21.12.2020    2850    14    huxuxuya    11    

[Расширение] Временное отключение онлайн-эквайринга в РМК (УТ 11.4, Розница 2.3)

Розничная торговля Рабочее место Эквайринг v8 v8::ОУ УТ11 Розничная и сетевая торговля (FMCG) УУ Абонемент ($m)

Расширение предназначено для исправления исключительных ситуаций, когда оплата по эквайринговому терминалу с подключением оборудования прошла успешно, но чек на ККТ не был фискализирован. Расширение позволит временно отключить онлайн-эквайринг непосредственно из формы РМК.

1 стартмани

14.12.2020    2699    16    RocKeR_13    9    

Рабочее место менеджера по продажам УТ 11.3, 11.4, ERP 2.4 Промо

Рабочее место Оптовая торговля Оптовая торговля v8 v8::ОУ ERP2 УТ11 УУ Абонемент ($m)

Рабочее место менеджера по продажам УТ, ЕРП. Удобный инструмент в 1С для менеджеров по продажам для повседневной работы с клиентами. Все самое необходимое под рукой для оперативного создания заказа или реализации!

10 стартмани

17.08.2018    14391    45    Ivan90    35    

BIM: взаимодействие с платформой Autodesk Forge

WEB v8 Строительство Абонемент ($m)

Предлагаемый пример демонстрирует широкие возможности для взаимодействия «1С:Предприятие» с платформой Autodesk Forge и позволяет вам получить базовые представления о применения технологий информационного моделирования в строительстве. Поддерживаются все версии платформы от 8.3.12 и выше до 8.3.18.

1 стартмани

25.11.2020    12207    4    kandr    0    

Заготовка обработки (внешняя печатная форма) заполнения Excel документа из 1С

Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Умеет заполнять как отдельные ячейки, так и таблицы в рамках листов Excel. Удобно при разработке различных “дашбордов” (с графиками, диаграммами), отчетов финансистов (где много формул), заполнения форм документов организации. Эксель шаблон может сделать пользователь (с нужным ему оформлением, формулами и т.д.) и впоследствии самостоятельно этот шаблон менять. Программисту нужно только настроить выдачу данных для заполнения шаблона. Может подключаться как внешняя печатная форма (для обычных и управляемых форм).

2 стартмани

29.07.2020    1817    5    wonderboy    0    

[Расширение] БП 3.0. Список счетов от поставщиков / Список поступлений + Связанные документы

Оптовая торговля Рабочее место v8 v8::БУ БП3.0 БУ УУ Абонемент ($m)

Список счетов от поставщиков и список поступлений товаров и услуг + Структура подчиненности в одном окне. Расширение для программы БП 3.0.

3 стартмани

20.05.2020    4124    2    Rustig    13    

Выгрузка данных из УТ 11.3/11.4 в БП 3.0 (перенос документов и справочной информации из "Управление торговлей" ред. 11.3/11.4 в "Бухгалтерия предприятием" ред. 3.0). Обновлен до УТ 11.3.4.х/11.4.7х и БП 3.0.7х.х Промо

Обмен через XML Перенос данных из 1C8 в 1C8 v8 БП3.0 УТ11 Абонемент ($m)

Данная обработка предназначена для выгрузки в формате XML данных из программы «Управление торговлей» ред. 11.3/11.4 по основным группам документов (документы покупки/продажи товаров и услуг, складские документы, счета-фактуры, ценообразование), а также набор основных справочников. Загрузка данных в БП ред. 3.0 через обработку «Универсальный обмен данными XML». Основная цель обработки – оптимизация работы бухгалтеров во время обмена данными между программами, а также выборочная корректировка загруженных ранее документов.

04.03.2016    58813    0    SEOAngels    62    

[Расширение] УНФ. Список заказов + Структура подчиненности

Монитор заказов Рабочее место v8 УНФ УУ Абонемент ($m)

Список заказов покупателей + Структура подчиненности в одном окне. Расширение для программы Управление нашей фирмой, редакция 1.6.

2 стартмани

05.04.2020    11142    11    Rustig    1    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    10529    17    capitan    11    

Альтернативный способ добавления элементов и реквизитов на формы

Работа с интерфейсом v8 ERP2 УТ11 Россия Абонемент ($m)

Предлагаю альтернативный вариант добавления динамически создаваемых элементов и реквизитов на форму.

1 стартмани

09.09.2019    13065    23    bmk74    6    

Список заказов покупателей (новый взгляд) Промо

Рабочее место Монитор заказов Оптовая торговля Монитор заказов Оптовая торговля v8 v8::ОУ КА1 УТ10 УУ Абонемент ($m)

Внешняя обработка "Список заказов покупателей". Фишка в том, что на одной форме отображается структура связанных документов с указанием контрагента. В этом окне также есть список товаров по заказу. Видны статусы заказов: исполнен, выполняется, черновик.

4 стартмани

16.08.2017    30009    68    Rustig    60    

Аналоги номенклатуры для УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Расширение

Рабочее место Оптовая торговля Розничная торговля Управление торговлей Оптовая торговля Розничная торговля v8 Розница ERP2 УТ11 КА2 Автомобили, автосервисы Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Расширение для работы с аналогами номенклатуры. Отлично подходит для работы с кроссами запчастей и товаров с аналогичными свойствами. Поддерживаемые конфигурации: УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Лёгкое подключение, без изменения конфигурации.

1 стартмани

30.08.2019    22693    32    AleSSandre    26    

Работа с релизами 1С и договорами ИТС

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    15985    51    RocKeR_13    34    

Управляемая консоль запросов, отчетов 3.8.9 (расширение, внешняя обработка) Промо

Консоль запросов v8 v8::УФ v8::Запросы v8::СКД 1cv8.cf Абонемент ($m)

Работа с запросом и СКД, Полная поддержка пакетных запросов, временных таблиц, Сравнение результатов, текстов, Разбор структуры запроса в виде дерева, Анализ плана запроса, Групповая обработка

5 стартмани

14.08.2018    103671    2649    Evg-Lylyk    710    

Вам нравятся запросы в 1С?

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    22734    6    m-rv    88    

Модель объекта

Инструментарий разработчика v8 Абонемент ($m)

Подсистема позволяет описать модель данных объекта, где описана зависимость между реквизитами, и затем использовать эту модель в разных сценариях работы с объектом. Версия платформы: 8.3.6 и выше. С небольшими доработками будет работать на 8.2.

1 стартмани

30.06.2019    13650    0    vadim1980    5    

Цифровая подпись Cades-BES для XML средствами 1С с помощью КриптоПро

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Обработка иллюстрирует возможность подписания XML SOAP-конверта по стандарту Cades-BES средствами 1С с помощью внешней компоненты КриптоПРО "CAdESCOM" с учетом ГОСТ 2001 и ГОСТ 2012. Стандарт используется в различных механизмах государственных сайтов России, в том числе в СМЭВ и ГИС ЖКХ. Код не привязан к прикладному решению может быть встроен куда угодно, но только на платформе Windows.

1 стартмани

13.05.2019    13395    50    PythonJ    41    

Печать конвертов из 1С Промо

Пакетная печать Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Россия Абонемент ($m)

Внешняя печатная форма для печати конвертов формата C4 и C5. Печать с полной разметкой почтового конверта и размещением адресов отправителя и получателя, включая индекс.

1 стартмани

07.12.2015    29869    8    sashs1980    5    

Редактор объектов информационной базы 8.3

Универсальные обработки Обмен через XML v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.53 от 22.02.2021

2 стартмани

23.01.2019    33724    373    ROL32    41    

Расширение "Курсы валют в формулах расчета динамических цен" для УНФ 1.6

Ценообразование, прайсы Ценообразование, анализ цен Ценообразование, анализ цен v8 УНФ УУ Абонемент ($m)

Расширение "Курсы валют в формулах расчета динамических цен" с автоматическим пересчетом цен при изменении курсов валют для конфигурации "Управление нашей фирмой, редакция 1.6"

3 стартмани

17.01.2019    18207    30    Palmer1976    7    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019)

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    48805    259    informa1555    234    

Сравнение pdf-файлов актов сверки

Универсальные обработки Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Обработка сравнивает два pdf-файла, в которых находятся стандартные печатные формы актов сверки, и показывает на экране совпадающие и/или отличающиеся по суммам документы взаиморасчетов.

1 стартмани

19.12.2018    19113    14    Torin99    2    

Выгрузка изображений из справочника на диск

Учет ТМЦ Универсальные обработки Учет ТМЦ v8 УТ11 Оптовая торговля, дистрибуция, логистика Россия Абонемент ($m)

Обработка позволяет записать изображения из справочка Номенклатура на диск в указанное место.

1 стартмани

30.11.2018    19537    8    wrooom    8    

Проверка VAT номеров

WEB v8 1cv8.cf Абонемент ($m)

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    14136    3    wtlz    1    

Обнуление остатков регистров бухгалтерии и накопления

Универсальные обработки Чистка базы v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m)

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    26518    350    morozov.sv    52    

Навигатор по конфигурации базы 1С 8.3

Структура метаданных Универсальные обработки v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная внешняя обработка для просмотра метаданных конфигураций баз 1С 8.3. Отображает свойства и реквизиты объектов конфигурации, их количество, основные права доступа и т.д. Отображаемые характеристики объектов: свойства, реквизиты, стандартные рекизиты, реквизиты табличных частей, предопределенные данные, регистраторы для регистров, движения для документов, команды, чужие команды, подписки на события, подсистемы. Отображает структуру хранения объектов базы данных, для регистров доступен сервис "Управление итогами". Платформа 8.3, управляемые формы. Версия 1.1.0.75 от 15.01.2021

3 стартмани

28.10.2018    37335    333    ROL32    72    

Открывашка ячеек таблиц

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Глобальное сочетание клавиш для открытия объекта по ссылке из текущей ячейки любой таблицы в большинстве управляемых форм

1 стартмани

27.10.2018    18545    12    tormozit    31    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    37036    139    json    42    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом

Печатные формы документов Универсальные функции Email v8 КА1 БП2.0 УТ10 УПП1 Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    26349    19    stvorl    0    

TextRadar - нечеткий поиск в тексте

Разработка внешних компонент Поиск данных v8 1cv8.cf Абонемент ($m)

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

1 стартмани

19.09.2018    19238    30    TSSV    19    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    23443    13    RocKeR_13    16    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    30261    26    informa1555    26    

Визуализация событий на временной шкале средствами "Поле HTML документа"

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Интересный способ наглядно отобразить события на временной шкале. Например, может быть применен для красивого вывода документов по клиенту. Тестировалось на платформе 8.3.12.1469

1 стартмани

31.07.2018    25277    139    Plotks2017    27    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    54128    20    kalyaka    16    

Пример использования REST API Яндекс Диска

WEB v8 1cv8.cf Абонемент ($m)

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    27830    43    MKFreeUser    15    

Приложение Android для идентификации/распознавания образов (с обучением с одного раза, One-Shot Learning) с возможностью работы с 1С через веб-сервис

Мобильная разработка v8 Абонемент ($m)

В данной статье описано приложение, алгоритм и методика распознавания изображений, предоставляющее посредством http-запросов информацию о распознанных объектах в 1С. В качестве примера интеграции прилагается конфигурация, реализующая веб-сервис для приема запросов от приложения.

1 стартмани

19.06.2018    16601    4    informa1555    15    

Обмен файловыми базами данных через Yandex диск

WEB v8 Россия Абонемент ($m)

Выполнение операций обмена с Yandex диском для файловых БД, по протоколу WebDav, в автоматическом или ручном режимах.

1 стартмани

11.06.2018    18439    7    slimper    1    

Конфигурация для просмотра публичных телеграм каналов

WEB v8 Абонемент ($m)

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    19281    11    DO_WHILE_LOOP    7