Компонента "Быстрый регистр" для 1С 7.7 (на прямых запросах SQL 1c++)

Публикация № 249596

Разработка - Универсальные функции

регистр прямой запрос оптимизация 1с++ SQL быстрый итоги остатки движения

Ускорение операций с регистрами 1с 7.7 через объектную модель, за счет доступа через прямые запросы SQL (1c++). Существует возможность добавления произвольных подзапросов соединений c другими таблицами и отборов WHERE,   гибкой настройки вывода полей в результат

Установка:

Компонента реализована в виде класса 1С++. Подключение компоненты стандартно (прописывается строка c описанием класса) в файл defcls.prm в папке базы:

class БыстрыйРегистр = БыстрыйРегистр.ert
{}

 

Использование:


Создание экземпляра объекта БыстрыйРегистр:

БыстрыйРег = СоздатьОбъект("БыстрыйРегистр");

Перед каждым использованием желательно вызвать метод СброситьНастройки();

Чтобы отобрать по значению измерения (реквизита в случае движений) нужно перед получением данных вызвать метод ИспользоватьОтбор

ИспользоватьОтбор(ИмяРеквизитаОтбора , ЗначениеОтбора, ПризнакРазворачивания );

ИмяРеквизитаОтбора - Имя измерения или реквизита в виде строки

ЗначениеОтбора - Одно значение или список значений

ПризнакРазворачивания - Должно (1) или нет (0) попадать поле таблицы в группировку (в результирующие данные). Актуально для списков значений

Если отбор не осуществляется, но поле необходимо добавить в результат, нужно вызвать ВыводитьИзмерение

ВыводитьИзмерение(ИмяИзмерения, ТипИзмерения )

ТипИзмерения в виде "Справочник.МестаХранения", "Число" ....

Само получение данных осуществуляется вызовом следующих методов:

Функция ПолучитьОстатки(ИмяРегистра, ПолеКоличество = "Количество", ПолеСумма = "Сумма", МоментВремени = 0,
УсловиеСоединения = "", Параметры = "", СтандартныйРегистр = 0, СтрокаСортировки = "", ТЗ = "", СтрокаWHERE = "") Экспорт

Функция ПолучитьДвижения(ИмяРегистра, Регистратор = 0,
МоментВремениОт = 0, МоментВремениДо = 0,
ПолеКоличество = "Количество", ПолеСумма = "Сумма", СтандартныйРегистр = 0, ТЗ = "", СтрокаWHERE = "" ) Экспорт

ИмяРегистра - Имя регистра в кавычках (например, "ТоварыНаСкладах")

ПолеКоличество, ПолеСумма - названия 1-го и 2-го ресурса (могут быть любыми, кол-во и сумма взяты для примера как самые распространенные )

МоментВремени (МоментВремениОт, МоментВремениДо) - дата или документ на который рассчитываются итоги или между которыми берутся движения

Регистратор - если нужно получить движения по данному регистратору (документу)

УсловиеСоединения - строка , в которой можно добавить соеднение с другими таблицами (см. пример ниже)

Параметры - список значений, в который передаются параметры (значение и имя параметра в качестве строкового описания значения в списке - см. пример ниже

СтрокаWHERE - строка, которая может быть поставлена в место для оператора WHERE

СтрокаСортировки  -  строка, которая может быть поставлена в место для оператора ORDER BY 

ТЗ - можно передать готовую ТЗ для уменьшения операций копирования (экономия памяти)

где возвращаемое значение - таблица значений с выходными полями измерений и реквизитов, а также ресурсов (максимальное количество ресурсов в данной реализации  - 2 (например, "Количество" и "Сумма"), но его не трудно расширить)

и упрощенной функции получения скалярного остатка:

Функция  ПолучитьОстаток(ИмяРегистра, ИмяРесурса, МоментВремени = 0, УсловиеСоединения = "", Параметры = "")

Параметры данной функции аналогичны предыдущим

Кроме того, если используется соединение с другими таблицами (например, со Справочник.Номенклатура), то можно вывести поля из этой таблицы в результат с помощью метода ВыводитьПроизвольноеПоле:

ВыводитьПроизвольноеПоле(ИмяТаблицы, ИмяПоля)

ИмяТаблицы - имя таблицы, с которой идет соединение (ВНИМАНИЕ, если используется символ разыменования 1С++ "$" в запросе, то здесь он тоже должен быть указан!)

ИмяПоля - имя поля из этой таблицы


ПРИМЕР1 (получить скалярный остаток):

 Функция глПолучитьОстаток(Товар = "", Склад = "", Серия = "", Поставка = "", ДатаОстатков = 0,                              ДатаПроверкиПоставок = 0) Экспорт


БыстрыйРег.СброситьНастройки();
БыстрыйРег.ИспользоватьОтбор("Товар", Товар);
Если Склад <> "" Тогда

БыстрыйРег.ИспользоватьОтбор("Склад", Склад);

КонецЕсли;

Если Серия <> "" Тогда

БыстрыйРег.ИспользоватьОтбор("Серия", Серия);

КонецЕсли;


Если Поставка <> "" Тогда

БыстрыйРег.ИспользоватьОтбор("Поставка", Поставка);

КонецЕсли;


Если ДатаПроверкиПоставок <> 0 Тогда

Условие = "
| JOIN $Справочник.Поставки as Поставки ON ($Р.Поставка = Поставки.Id
| AND $Поставки.ДатаПоставки <= "+глСКЛПараметрДаты("ДатаПроверкиПоставок") +")";
Параметры = СоздатьОбъект("СписокЗначений");
Параметры.Установить("ДатаПроверкиПоставок", ?(ДатаПроверкиПоставок = 0, ТекущаяДата(), ДатаПроверкиПоставок));

Возврат БыстрыйРег.ПолучитьОстаток("ОстаткиТоваров", "Количество", ДатаОстатков, Условие, Параметры);

Иначе

Возврат БыстрыйРег.ПолучитьОстаток("ОстаткиТоваров", "Количество", ДатаОстатков);

КонецЕсли;

КонецФункции


ПРИМЕР2 (получить выборку остатков по настраиваемым условиям):

 Примечание: Все переменные списки могут быть как одиночными значениями, так и списками значений

Функция глПолучитьОстаткиПоТоварам(Склад = "", СписокТоваров = "", СписокСерий = "", СписокПоставок = "",
РазворачиватьТовары = 1, РазворачиватьСерии = 1, РазворачиватьПоставки = 0, ДатаОстатков = 0, ДатаПроверкиПоставок = 0,
УчитыватьГорячийРезерв = 0, РазворачиватьСклады = 0, ПолучатьСертификационныеДанные = 0, ТЗ = "") Экспорт


БыстрыйРег.СброситьНастройки();
Если Склад <> "" Тогда
БыстрыйРег.ИспользоватьОтбор("Склад", Склад, РазворачиватьСклады);
ИначеЕсли РазворачиватьСклады = 1 Тогда
БыстрыйРег.ВыводитьИзмерение("Склад", "Справочник.МестаХранения");
КонецЕсли;

Если СписокТоваров <> "" Тогда
БыстрыйРег.ИспользоватьОтбор("Товар", СписокТоваров, РазворачиватьТовары);
ИначеЕсли РазворачиватьТовары = 1 Тогда
БыстрыйРег.ВыводитьИзмерение("Товар", "Справочник.Товары");
КонецЕсли;

Если СписокСерий <> "" Тогда
БыстрыйРег.ИспользоватьОтбор("Серия", СписокСерий, РазворачиватьСерии);
ИначеЕсли РазворачиватьСерии = 1 Тогда
БыстрыйРег.ВыводитьИзмерение("Серия", "Справочник.Серии");
КонецЕсли;

Если СписокПоставок <> "" Тогда
БыстрыйРег.ИспользоватьОтбор("Поставка", СписокПоставок, РазворачиватьПоставки);
ИначеЕсли РазворачиватьПоставки = 1 Тогда
БыстрыйРег.ВыводитьИзмерение("Поставка", "Справочник.Поставки");
КонецЕсли;

Условие = "";

Если ПустоеЗначение(ДатаПроверкиПоставок) = 0 Тогда
Условие = "
| JOIN $Справочник.Поставки as Поставки " + ?(глСКЛ = 1," WITH (nolock) ", " ") + " ON ($Р.Поставка = Поставки.Id
| AND $Поставки.ДатаПоставки <= "+ глСКЛПараметрДаты("ДатаПроверкиПоставок") +")";
КонецЕсли;

Если ПолучатьСертификационныеДанные = 1 Тогда

Условие = Условие + "
| JOIN $Справочник.Товары as Товары " + ?(глСКЛ = 1," WITH (nolock) ", " ") + " ON ($Р.Товар = Товары.Id)
| LEFt JOIN $Справочник.СтавкиНДС СтавкиНДС ON СтавкиНДС.Id = $Товары.СтавкаНДС";

БыстрыйРег.ВыводитьПроизвольноеПоле("$Товары", "СрСебестоимость");
БыстрыйРег.ВыводитьПроизвольноеПоле("$СтавкиНДС", "Ставка");
Условие = Условие + "
| JOIN $Справочник.Серии as Серии " + ?(глСКЛ = 1," WITH (nolock) ", " ") + " ON ($Р.Серия = Серии.Id)";
БыстрыйРег.ВыводитьПроизвольноеПоле("$Серии", "СрокГодности");


Условие = Условие + "
| JOIN $Справочник.Сертификаты as Сертификаты " + ?(глСКЛ = 1," WITH (nolock) ", " ") + " ON ($Поставки.Сертификат = Сертификаты.Id)";

Для Сч = 1 По глСписРегионы.РазмерСписка() Цикл
Стр = 0;
глСписРегионы.ПолучитьЗначение(Сч, Стр);
БыстрыйРег.ВыводитьПроизвольноеПоле("$Сертификаты", "Статус" + Стр, "Перечисление.СтатусыСерий");
КонецЦикла;
КонецЕсли;

Если УчитыватьГорячийРезерв = 1 Тогда
Условие = Условие + "
| JOIN $Справочник.ПрайсЛист " + ?(глСКЛ = 1," WITH (nolock) ", " ") + " as ПрайсЛист ON ($Р.Товар = $ПрайсЛист.Товар)";
БыстрыйРег.ВыводитьПроизвольноеПоле("$ПрайсЛист","КоличествоГорРезерв");
КонецЕсли;

Параметры = СоздатьОбъект("СписокЗначений");
Параметры.Установить("ДатаПроверкиПоставок", ?(ДатаПроверкиПоставок = 0, ТекущаяДата(), ДатаПроверкиПоставок));

Если ТЗ = "" Тогда
ТЗ = СоздатьОбъект("ТаблицаЗначений");
КонецЕсли;

БыстрыйРег.ПолучитьОстатки("ОстаткиТоваров", , "", ДатаОстатков, Условие, Параметры,,, ТЗ);
БыстрыйРег.РежимОтладки = 0;

Возврат ТЗ;


КонецФункции



ПРИМЕР3 (получить выборку движений):


 

Функция глПолучитьДвиженияПоРегиструОстатков(ДатаОт = 0, ДатаДо = 0, Склад,
СписокТоваров = "", СписокСерий = "", СписокПоставок = "", Док = 0, РазворачиватьСклады = 0) Экспорт

БыстрыйРег.СброситьНастройки();


Если Склад <> "" Тогда
БыстрыйРег.ИспользоватьОтбор("Склад", Склад, 1);
ИначеЕсли РазворачиватьСклады = 1 Тогда
БыстрыйРег.ВыводитьИзмерение("Склад", "Справочник.МестаХранения");
КонецЕсли;

Если СписокТоваров <> "" Тогда
БыстрыйРег.ИспользоватьОтбор("Товар", СписокТоваров, 1);
КонецЕсли;

Если СписокСерий <> "" Тогда
БыстрыйРег.ИспользоватьОтбор("Серия", СписокСерий, 1);
КонецЕсли;

Если СписокПоставок <> "" Тогда
БыстрыйРег.ИспользоватьОтбор("Поставка", СписокПоставок, 1);
КонецЕсли;

Возврат БыстрыйРег.ПолучитьДвижения("ОстаткиТоваров", Док ,ДатаОт, ДатаДо, , "" );

КонецФункции




 


 


 

Скачать файлы

Наименование Файл Версия Размер
Реализация класса + Файл описания класса (пример)

.zip 14,45Kb
09.01.14
8
.zip 0.99 14,45Kb 8 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. Rothschild 13.01.14 16:17 Сейчас в теме
Смотрю еще кто-то что-то для 7.7 делает,
да еще нетривиальное - на прямых запроса.
***
смотрю примерчики в статье все для SQL
...
а что будет в DBF...в монопольном режиме...при проведении документа?
2. Rothschild 13.01.14 18:18 Сейчас в теме
(0) victor_goodwill,
PS
Использование слова "компонента" в названии статьи - не очень удачно.

Есть устаявшаяся ассоциация этого слова с понятием "внешней компаненты".
Такое название вносит определенное непонимание.
Народ читает и думает - "вот очередной костыль к 1С"

Назови уж статью гордо:
"Класс "Быстрый регистр"".

Заодно позлишь ортодоксов от 1С, люто ненавидящих ООП.
;)
3. victor_goodwill 7 14.01.14 13:29 Сейчас в теме
Спасибо за отзыв!

Изначально класс разрабатывался именно под DBF и служил верою и правдою чуть больше года на базе до 2ГБ (сейчас база выросла до 7 Гб на SQL Express)
Да в монопольном режиме там стоит вызов стандартных регистров (они вообще лучше оптимизированы под монопольный режим)
Совместимость с DBF уже не поддерживалась давно, но вернуть ее при необходимости думаю не сложно.

Насчет изменения заголовка статьи я подумаю. Согласен, что это не совсем корректное строго говоря название, но "класс" боюсь будет непонятно многим 1С-прогам, а с точки зрения использования, он немного напоминает внешнюю компоненту, поэтому остановился на таком названии :)
4. Rothschild 14.01.14 13:37 Сейчас в теме
(3) victor_goodwill,
для DBF в монопольном режиме могу посоветовать 1sqlite.dll
совместно с 1cpp.dll.
***
первая обеспечит прямые запросы к базе
ну а вторая нужна для поддержки классов.
5. victor_goodwill 7 14.01.14 14:13 Сейчас в теме
Спасибо, очень интересно... такую компоненту еще не пробовал использовать.
Правда уже может и не попробую - все таки, думаю, что уже будем переходить на 8 -ку и на 7-ке разработки постепенно будут свернуты :)
6. NoRazum 26 19.06.15 17:58 Сейчас в теме
Обработка немного не допилиная.
Есть процедуры и функция не дописанные в обработке)

Нужно дорабатывать напильником.
Оставьте свое сообщение

См. также

Методы для группировки данных по полю,полям в Таблице Значений на примере универсального метода списания по партиям, а также отбора строк в ТЗ по произвольному условию. Для 8.x и 7.7 Промо

Универсальные функции Практика программирования v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Я очень часто использую группировку данных по полю и полям, как в восьмерке, так и в семерке. Это аналог запроса Итоги, но там строится дерево, а в большинстве случаев нужны "плоские данные". Да и делать запрос в большинстве случаев более накладный процесс, чем работа с ТЗ. Все достоинства такого подхода приведены на примере метода универсального списания по париям, а так же отбора строк в ТЗ по произвольному условию. Для 7.7 еще отчеты сравнения двух ТЗ. Работая с различными базами для упрощения сравнения номенклатуры, или как аналог джойнов(join), сделал сравнение двух таблиц значений по нескольким полям. Пока группировки полей должны быть уникальны. Часто приходится искать дубли, для универсального поиска есть ДублиВТзПоПолю и пример в Тест.ert.

1 стартмани

25.06.2015    26428    3    Serginio    1    

Как создать индикатор в 1С:Предприятии 7.7

Универсальные функции Работа с интерфейсом v7.7 1cv7.md Россия Абонемент ($m)

В статье дано описание создания индикатора на форме в среде разработки 1С:Предприятие 7.7 исключительно типовыми средствами.

1 стартмани

27.09.2016    11977    2    HAMMER_59    6    

Запуск php програм в 1С 7.7

Универсальные функции v7.7 1cv7.md Абонемент ($m)

Запуск программ PHP на сервере по прямому адресному запросу. Дополнительная возможность - передавать параметры методом GET-запросов.

1 стартмани

15.09.2014    6609    3    kwadro    1    

Перевод десятичного числа в HEX, BIN, OCT, _IdToStr и другие системы

Инструментарий разработчика Практика программирования Универсальные функции v7.7 1cv7.md Абонемент ($m)

Два алгоритма перевода десятичного числа в другую систему исчисления от 2 до 36 только средствами 1С (без ВК)

1 стартмани

05.06.2014    13094    7    kos    3    

1C7.7 парсер JSON

Универсальные функции v7.7 1cv7.md Россия Абонемент ($m)

РАБОТОСПОСОБНЫЙ парсер JSON встраивается в глобальный модуль в виде 3х функций. Для достижения положительного результата активно используется regexp.

1 стартмани

23.01.2014    16394    54    pit201201    16    

Обработка проверки номера сотового телефона

Универсальные обработки Классификаторы Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Обработка предназначена для проверки номера сотового телефона по базе def номеров РФ по данным rossvyaz.ru

1 стартмани

05.10.2012    17326    2    BPAvel    8    

Почтовый клиент для скачивания вложений с почты 1С:7.7

WEB Универсальные функции v7.7 1cv7.md Абонемент ($m)

Скачивает вложения, и переименовывает на уникальное имя. Нужно для того, что бы скачивало ВСЕ файлы, даже если эти файлы с одинаковым именем. Изначально разрабатывалось для массового скачивания больших объемов квитанций о принятии отчетов в налоговую. иногда в письме было два и более разных файлов, с одинаковым именем. Существующие почтовые клиенты при этом скачивали только один (последний), остальные файлы терялись.

1 стартмани

15.08.2012    13852    2    serko8547    3    

Группировка данных в таблице значений (1С:7.7)

Работа с интерфейсом Универсальные функции v7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Надоело каждый раз морочиться с итогами по группам данных в таблице значений при выводе отчета на печать! Вот и накидал простое решение... может и боян - но мне нравится)

1 стартмани

08.08.2012    20643    8    Lancelot-2M    9    

Универсальные функции Даты-Времени в 1Cv7

Универсальные функции v7.7 1cv7.md Россия Абонемент ($m)

Представлены 4 основные функции и 2 вспомогательные. Входом функций являются Дата и Время как в стандартном, так и форматированном представлении. На закладке "Функции" дана возможность проверить работу функций. Представлен альтернативный выбор Даты с помощью Календаря (кн. "Выбор").; На закладке "Календарь" показано, как просто можно создать и распечатать календарь на любой(!) год.

1 стартмани

22.05.2012    16903    8    newold2    13    

Расчет CRC32

Универсальные функции v7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Расчет CRC32 без использования внешних компонент

1 стартмани

26.04.2012    11611    9    GAlexis    17    

Выяснение ID'а объекта в базе SQL по его внутреннему идентификатору 1С

Практика программирования Универсальные функции openconf v77::БУ 1cv7.md Абонемент ($m)

Обработка позволяет узнать ID в базе SQL конкретного агрегатного объекта конфигурации (метаданных) 1С 7.7.

1 стартмани

27.03.2012    27634    6    born85    41    

Прогрессбар для конфигураций 7.7

Работа с интерфейсом Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Простой прогрессбар для конфигураций 7.7. Реализован штатными средствами, работает с любым видом учета

1 стартмани

11.02.2012    7268    0    Gagarick    3    

Редактор таблиц значений

Универсальные функции v7.7 1cv7.md Абонемент ($m)

Простой и эффективный инструмент. Позволяет делать с таблицами значений все, что угодно: создавать, редактировать, записывать в файл, считывать из файла, обрабатывать...

1 стартмани

17.10.2011    13402    8    warenic    12    

Редактор списков значений

Универсальные функции v7.7 1cv7.md Абонемент ($m)

Простой и эффективный инструмент. Позволяет делать со списками значений все что угодно: создавать, редактировать, записывать в файл, считывать из файла, обрабатывать...

1 стартмани

17.10.2011    10471    0    warenic    6    

Консолидация и вычитание екселевских файлов.

Загрузка и выгрузка в Excel Анализ учета Универсальные функции Управление холдингом (CPM) Управление холдингом (CPM) v7.7 1cv7.md Абонемент ($m)

Куратору нужно из отчетов регионов сделать общий файл. И так каждую неделю. Автоматизируем процесс.

1 стартмани

23.09.2011    12013    0    Canabis220    7    

Дополнительные реквизиты справочников 7.7.: альтернатива.

Обработка справочников Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Никакого вмешательства в конфигурацию. Никаких дополнительных компонент.

1 стартмани

05.09.2011    19805    1    Арчибальд    27    

1C 7.7 FireBird (MSSQL, MSAccess, MySQL, PostgreSQL) - рабочий пример выполнение запроса + обработка

Внешние источники данных Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

1C 7.7 FireBird (MSSQL, MSAccess, MySQL, PostgreSQL) - рабочий пример выполнения запроса + обработка

1 стартмани

21.05.2011    12157    6    solaris_    2    

Сравнение таблиц с данными

Инструментарий разработчика Универсальные функции Анализ учета v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Выкладываю функцию для сравнения таблиц значений (может кому-нибудь пригодится). Сравнивает две таблицы - исходную и новую по заданному индексу (индекс используется в методе ИТПолноеСоединение). Сравниваются либо заданные колонки, либо все колонки, имеющиеся в обеих таблицах.

1 стартмани

16.03.2011    11049    0    waol    1    

Печать штрихкодов (не EAN-13) TTF-шрифтом

Сканер штрих-кода Ценники Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Возникла необходимость печатать серийники, состоящие из букв латинского алфавита.

1 стартмани

02.03.2011    21047    17    tdr1225    7    

Конфигурация "Челнок" - набор функций и процедур для глобального модуля

Практика программирования Универсальные функции v77::ОУ v77::БУ v77::Расчет Россия Абонемент ($m)

Еще одна разработка - набор функций и процедур общего назначения для глобального модуля.

1 стартмани

06.01.2011    10897    1    provadyuga    6    

Автонумерация документов

Обработка документов Универсальные функции v7.7 1cv7.md Абонемент ($m)

Универсальная процедура автонумерации - решение, учитывающее ручные исправления номеров документов.

1 стартмани

24.11.2010    12649    4    aleksandr_leiman    6    

Граф(ин) 7.7. (дополнение)

Математика и алгоритмы Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Строим ориентированные графы.

1 стартмани

13.11.2010    19931    1    Арчибальд    18    

ТЗ2СводнаяТаблица

Загрузка и выгрузка в Excel Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Конвертор ТЗ в сводную таблицу Эксель.

1 стартмани

12.10.2010    7525    2    dav405    1    

Сведения истории значений

Универсальные функции Обработка справочников v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m)

Разработка содержит функцию «глСведенияИсторииЗначений(Элемент, НачДата, КонДата, ВсеИдРеквизитов = "")», демонстрацию которой выполняет данная разработка. Функция работает с историей реквизитов одного конкретного элемента справочника.

1 стартмани

29.08.2010    9165    0    provadyuga    5    

Шаблон отчета по регистру, с готовым макетом отчета.

Практика программирования Учет ТМЦ Универсальные функции Учет ТМЦ v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Шаблон нового отчета по регистру, с готовым макетом отчета. Позволяет создать новый отчет за 5 минут.

1 стартмани

12.07.2010    11067    1    Bor_ka    9    

Многофирменный учет или отборы в общих журналах документов

Обработка документов Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Стандартная привязка документа к определенному журналу имеет свои неудобства. Конкретному пользователю нужны определенные документы, да еще и с отбором по разным реквизитам. Отборы же в стандартном общем журнале документов реализованы только для одного реквизита : или фирма, или вид документа, или автор и т.д. Кроме этого, при попытке ввести новый документ , вываливается список всех документов конфигурации. А если у Вас многофирменный учет...

1 стартмани

09.05.2010    16002    3    kompas-dm    8    

Хранилище файлов для 7.7

Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Макетная конфигурация для структурированного хранения внешних файлов. Ссылки прикрепляются к документам и справочникам 1С.

1 стартмани

09.04.2010    12239    8    alex_serb    9    

Гибкие блокировки для 7.7 SQL Оперативный учет (очередные грабли :))

Универсальные функции Обработка документов v77::ОУ 1cv7.md Абонемент ($m)

Обработка с функционалом по внедрению/использованию гибких блокировок в 1С 7.7 на SQL. На ваш суд и обсуждение :) Идея общеизвестная

1 стартмани

19.02.2010    12101    5    Lars Ulrich    10    

ПЕЧАТЬ ИЕРОГЛИФОВ из 1С

Загрузка и выгрузка в Excel Универсальные функции v7.7 1cv7.md Абонемент ($m)

Если Вам нужно печатать из 1С иероглифы, а Вы не знаете как - предлагаю один из вариантов решения. А если Вы знаете - предложите свой, буду премного благодарен.

1 стартмани

04.02.2010    24075    1    Tatitutu    29    

Универсальный подбор элементов справочника

Универсальные функции v7.7 1cv7.md Абонемент ($m)

Универсальная обработка для подбора элементов любого справочника путем прямого запроса с помощью 1С++ с использованием фильтра по вхождению для строковых реквизитов. (только для SQL)

1 стартмани

11.11.2009    10013    1    Boog    6    

Набор универсальных функций для 1С77

Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Набор универсальных функций и кусочки кода для 1С77

1 стартмани

22.07.2009    14179    4    Alex_Smolensky    35    

Немного примеров для BEEP.dll

Разработка внешних компонент Универсальные функции v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Несколько примеров реализации возможностей ВК BEEP.dll

1 стартмани

02.07.2009    12388    0    Parazyte    4    

1С 7.7. Календарь для "Бухгалтерии"

Управление персоналом (HRM) Универсальные функции Работа с интерфейсом Управление персоналом (HRM) v77::ОУ v77::БУ v77::Расчет 1С7:Бух Абонемент ($m)

1С 7.7. Календарь (графики работы) для "Чистой бухгалтерии". Без компоненты "РАСЧЕТ"

1 стартмани

28.06.2009    20646    5    kompas-dm    18    

Календарь

Универсальные функции Работа с интерфейсом v77::ОУ v77::БУ 1cv7.md Украина Абонемент ($m)

Вырванное из конфигурации решение справочника в виде календаря (с реализацией праздников и выходных для Украины).

1 стартмани

27.06.2009    11236    2    VRP    10    

Обработка сортировки по подразделению в любом документе

Универсальные функции Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v77::Расчет 1С7:ЗиК Абонемент ($m)

Эта обработка относится к статье "http://infostart.ru/blogs/1086/" (Создаем сортировку по подразделению в любом документе (Зарплата и Кадры 7.7))

1 стартмани

28.05.2009    11283    0    Craig    18    

Получение списка запущенных процессов. Запуск и завершение программ по PID

Универсальные функции v7.7 1cv7.md Абонемент ($m)

Демонстрация способа запуска приложения с сохранением его PID и последующим закрытием по PID, получения списка процессов.

1 стартмани

01.04.2009    14098    10    MadDAD    13    

7.7. Нумератор бланков штрих-кодом + читатель (сканирование ШК).

Сканер штрих-кода Универсальные печатные формы Универсальные функции Документооборот и делопроизводство Документооборот и делопроизводство v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Как-то высказывалось здесь пожелание познакомиться со штрих-кодированием и объектом BarCode. Знакомьтесь. Вариант использования: Контроль возврата выданных документов.

1 стартмани

20.03.2009    22879    7    Арчибальд    5