1C + jabber + python

Публикация № 262984 14.04.14

Разработка - Инструментарий разработчика

jabber xmpp python документооборот

Отправка сообщений в jabber из 1С [Документооборота] при помощи python-скрипта.

Как уже было написано тут, 1С не умееет [пока?] работать с xmpp, внешние компоненты не приносят желаемого результата (и обычно доступны только для Windows).

У нас тоже сложилось так, что внутри используется jabber и не используется email (т.к. организация небольшая).

Собственно, поискав на инфостарте, ничего дельного кроме той статьи с работой ч\з php найти не получилось. Но душа больше лежит к питону, и к php нет особой приязни. Также, покопавшись в кишочках 1С:Документооборота, оказалось, что довольно легко внедрить отправку jabber-сообщений в имеющуюся систему уведомлений по email (с полной заменой отправки по email отправкой по xmpp). И не пришлось писать свой костыль для проверки новых задач и прочего, о чем хотелось бы получать уведомления.

Для начала нам потребуется собственно python 2й версии и библиотека pyxmpp.

В Linux установка делается в два счета:

# apt-get install python2.7 python-pyxmpp

В Windows все сложнее.

  1. Берем отсюда и устанавливаем питон (версия 2.7). В зависимости от выбранной разрядности (32 или 64-bit) берите далее подходящие пакеты. Добавляем каталог с установленным питоном в переменную окружения PATH (Панель управления - Система - Дополнительные параметры системы - Переменные среды - Системные переменные, ищем в списке Path и в конце её значений дописываем (в моем случае) ";D:\Python 2.7\").
  2. Ставим пакет dnspython. Брать здесь последний релиз для 2.х (Python 2.x Stable, берем zip-архив). Содержимое архива извлекаем в "[PythonDir]\Lib\site-packages\", заходим в появившуюся папку "dnspython-[version]", открываем окно консоли (кто не умеет - зажимаем Shift, щелкаем ПКМ, выбираем "Открыть окно команд"), выполняем команду setup.py install.
  3. Следующий пакет - M2Crypto. Брать здесь M2Crypto-[latest].win[32/amd64]-py2.7. Сейчас можно найти тут только для win32 (или посильнее погуглить). Запускаем исталлятор и кликаем по кнопкам "Далее".
  4. Следующий - libxml2. Брать здесь libxml2-python-[latest].win[32/amd64]-py2.7. Также запускаем и кликаем "Далее".
  5. И наконец сам pyxmpp. Брать здесь последний архив pyxmpp-[latest].tar.gz. С содержимым поступаем аналогично пункту 2, только выполняем последовательно следующие команды: configure.pysetup.py buildsetup.py install.

Теперь запускаем конфигуратор и лезем в кишочки. Покажу что я сделал в Документообороте.

Нас будет интересовать Общий модуль РаботаСУведомлениями. Я создал новый общий модуль с такими же настройками (Сервер, Внешнее соединение, Вызов сервера, Повторное использование - не использовать) и назвал его РаботаСУведомлениямиХМПП. Скопировал в свой модуль несколько процедур и функций из оригинала, потребовавшиеся в процессе работы (СобытиеЖурналаРегистрации, ДобавитьЗначениеВМассив, ОбработатьОшибкуОтправкиУведомления, УдалитьУведомлениеИзОчередиУведомлений), и добавил свои:

Функция ФайлУведомлений()
	Возврат "\\db1c\AddIn\jabber\send_message.txt";
КонецФункции

Функция ОтправитьУведомления()
	ВозниклаОшибкаПриОтправке = Ложь;

	КодВозврата=Неопределено;
	путь="\\db1c\AddIn\jabber\";
	ЗапуститьПриложение("python "+путь+"send_message.py",путь,Истина,КодВозврата);
	
	Если КодВозврата=0 Тогда
		ЗаписьЖурналаРегистрации(
			СобытиеЖурналаРегистрации(),
			УровеньЖурналаРегистрации.Информация,,,
			НСтр("ru = 'Уведомления успешно отправлены.'"));
	Иначе
		ЗаписьЖурналаРегистрации(
			СобытиеЖурналаРегистрации(),
			УровеньЖурналаРегистрации.Предупреждение,,,
			СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
				НСтр("ru = 'Ошибка при отправке уведомления о новых событиях. Код возврата: %1.'"),
				КодВозврата));
		ВозниклаОшибкаПриОтправке = Истина;
	КонецЕсли;
	
	Возврат ВозниклаОшибкаПриОтправке;
КонецФункции

Процедура ПодготовитьФайлУведомлений(СформированныеУведомления)
	ПодготовленныеУведомления=Новый ТекстовыйДокумент;
	
	Для Каждого СформированноеУведомление Из СформированныеУведомления Цикл
		ПочтовыйАдресПолучателя = "";
		ВозниклаОшибкаПриОтправке = Ложь;
		АдресаЭлектроннойПочты = РаботаСУведомлениями.ПолучитьДанныеСпособаУведомления(
			Перечисления.СпособыУведомления.ПоПочте,
			СформированноеУведомление.Пользователь,
			Истина);
		
		Если АдресаЭлектроннойПочты.Количество() = 0 Тогда
			ЗаписьЖурналаРегистрации(
				СобытиеЖурналаРегистрации(),
				УровеньЖурналаРегистрации.Информация,,,
				СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
					НСтр("ru = 'Уведомление не отправлено, так как не указан почтовый адрес у пользователя %1.'"),
					Строка(СформированноеУведомление.Пользователь)));
			ОбработатьОшибкуОтправкиУведомления(СформированноеУведомление);
			Продолжить;
		КонецЕсли;
		
		Для Каждого ПочтовыйАдресПолучателя Из АдресаЭлектроннойПочты Цикл
			ПодготовленныеУведомления.ДобавитьСтроку("[BEGIN]");
			ПодготовленныеУведомления.ДобавитьСтроку(ПочтовыйАдресПолучателя);
			ПодготовленныеУведомления.ДобавитьСтроку(СформированноеУведомление.ТекстУведомления);
			ПодготовленныеУведомления.ДобавитьСтроку("[END]");
		КонецЦикла;
	КонецЦикла;
	
	ПодготовленныеУведомления.Записать(ФайлУведомлений(),"UTF-8");
КонецПроцедуры

Функция ОтправитьУведомленияПоХМПП(СформированныеУведомления) Экспорт
	ПодготовитьФайлУведомлений(СформированныеУведомления);
	
	ВозниклаОшибкаПриОтправке=ОтправитьУведомления();
	
	Если ВозниклаОшибкаПриОтправке Тогда
		Для Каждого СформированноеУведомление Из СформированныеУведомления Цикл
			ОбработатьОшибкуОтправкиУведомления(СформированноеУведомление);
		КонецЦикла;
	Иначе
		Для Каждого СформированноеУведомление Из СформированныеУведомления Цикл
			Для Каждого Уведомление Из СформированноеУведомление.Уведомления Цикл
				УдалитьУведомлениеИзОчередиУведомлений(Уведомление);
			КонецЦикла;
		КонецЦикла;
	КонецЕсли;
КонецФункции

И небольшое изменение в самом модуле РаботаСУведомлениями:

Функция ОтправитьУведомления()
	
....

		КонецЦикла;
			
		//Для Каждого СформированноеУведомление Из СформированныеУведомления Цикл
		//	ОтправитьУведомление(СформированноеУведомление);
		//КонецЦикла;
		
	КонецЦикла;
	
	РаботаСУведомлениямиХМПП.ОтправитьУведомленияПоХМПП(СформированныеУведомления);
	
КонецФункции

На сервере расшарена папка AddIn, к которой дан доступ только пользователю, от которого запущен сервер 1С. В этой папке лежит питоновский скрипт, который и осуществляет рассылку сообщений. Предварительно в 1С генерируется файл с этими сообщениями (один файл на всю текущую кучу уведомлений). Файл состоит из нескольких таких блоков, по одному на каждое уведомление:

[BEGIN]
адрес@получателя.сообщения
несколько
строчек
самого
сообщения
[END]

В самом скрипте задаются необходимые настройки для подключения и авторизации бота (естественно этот бот должен быть в контакт-листе пользователей):

SERVER = '10.10.0.200' # явно указанный ip-адрес jabber-сервера, если есть проблема с резолвингом имени. если все ок, можно вместо адреса оставить значение None
#SERVER = None
PORT = None # 5222 по умолчанию, если порт другой - указать его здесь явно
FROM_JID = 'bot@apk-mir.office-on-the.net/docflow' # аккаунт бота, от которого будет идти рассылка, с указанием ресурса (можно написать любое)
PASSWORD = 'randompassword' # и пароль от этого аккаунта

Возможно потребуется изменить настройки шифрования при подключении к jabber-серверу. У нас шифрование включено, поэтому в процедуре xmpp_do прописано:

c=Client(jid,password,server=server,port=port,auth_methods=['sasl:PLAIN'],tls_settings=streamtls.TLSSettings(require=True, verify_peer=False))

Если шифрование не используется, можно совсем убрать параметр tls_settings и в auth_methods убрать sasl: (тут я не уверен, надо проверять).

1Ска формирует файл сообщений в кодировке UTF-8 with BOM, можете предварительно создать тестовый файл, проверить работу скрипта.

Адреса (jid) пользователей в Документообороте вписаны в поле E-mail.

 

Вроде все описано. Пишите в комментарии, если что забыл, добавлю.

Скачать файлы

Наименование Файл Версия Размер
send_message.py

.py 1,69Kb
15
.py 1,69Kb 15 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Mogidin 130 06.03.14 18:47 Сейчас в теме
авторизация и отправка сообщений проходят практически моментально, без таких больших задержек, как в случае с php.
обработка ошибок при отправке практически никакая. если возникла какая то ошибка при отправке одного сообщения из списка - неотправленными считается весь список. хотя и ошибке тут возникнуть вроде бы и негде. только если сеть упала, или jabber не работает.
Оставьте свое сообщение

См. также

Infostart Toolkit

Инструментарий разработчика Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Простые и удобные инструменты: Консоль запросов, СКД, Редактор объекта, Поиск ссылок и другие. Редактор запросов и кода с раскраской и контекстной подсказкой. Улучшенный конструктор тонкого клиента и др.

10000 руб.

02.09.2020    80179    393    356    

466

SALE! %

PowerTools

Инструментарий разработчика Обработка документов Инструменты администратора БД Корректировка данных Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Платные (руб)

Универсальный инструмент программиста для администрирования конфигураций. Сборник наиболее часто используемых обработок под единым интерфейсом.

2400 1920 руб.

14.01.2013    164351    1009    0    

767

Многопоточность. Универсальный «Менеджер потоков» 2.1

Инструментарий разработчика Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Восстановление партий или взаиморасчетов, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

5000 руб.

07.02.2018    93181    227    95    

275

Выполнение произвольного кода или запроса с параметрами через Web-сервис (замена COM-подключений)

Инструментарий разработчика Обмен между базами 1C Платформа 1С v8.3 Платные (руб)

В процессе работы в 1С часто возникает потребность получить данные из другой базы.  Обычно это делается через COM-соединение, и время выполнения запроса при этом оставляет желать лучшего. В данной публикации представлено универсальное решение, позволяющее практически моментально выполнить произвольный код или запрос с параметрами в другой информационной базе через Web-сервис.

2400 руб.

24.09.2019    19618    11    14    

18

Универсальная обработка создания связанных документов (универсальный "ввод на основании")

Инструментарий разработчика Обработка документов Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Зарплата и Управление Персоналом 3.x Платные (руб)

Универсальная внешняя обработка призвана предоставить пользователю механизм, позволяющий быстро, в удобной и понятной форме настроить в программе функционал по созданию и заполнению новых документов на основании данных других документов (и не только), т.е. возможность настраивать типовой механизм "ввода на основании" для заполнения создаваемых документов по своим правилам.

2500 руб.

02.04.2017    41928    72    27    

128

Заполнение документа "Корректировка регистров" произвольными данными

Закрытие периода Корректировка данных Инструментарий разработчика Обработка документов Платформа 1С v8.3 Система компоновки данных 1С:Управление нашей фирмой 1.6 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Управленческий учет Платные (руб)

Внешняя обработка, позволяющая произвольным образом заполнять документ "Корректировка регистров" Предназначена для использования в конфигурациях "Управление торговлей 11", "Управление небольшой фирмой", "ERP Управление предприятием", а также в других конфигурациях, в состав которых входит библиотека стандартных подсистем (БСП) версии 2.2+ и указанный выше документ.

2400 руб.

13.07.2015    46290    155    27    

105

Менеджер конфигураций 1С

Инструментарий разработчика Платные (руб)

Менеджер конфигураций 1С — альтернативный стартер информационных баз 1С:Предприятие.

1439 руб.

21.02.2023    2992    0    24    

9

Бустер Конвертации данных 3 (Infostart Toolkit)

Инструментарий разработчика 8.3.14 1С:Конвертация данных Россия Платные (руб)

Расширение для конфигурации “Конвертация данных 3”. Добавляет подсветку синтаксиса, детальную контекстную подсказку, глобальный поиск по коду.

15000 руб.

07.10.2021    11402    2    12    

36

Автоматизация труда программиста. Библиотека прикладных функций

Инструментарий разработчика Платформа 1С v8.3 Платформа 1C v8.2 Платформа 1С v8.1 Конфигурации 1cv8 Платные (руб)

Программист - это человек, непрерывно принимающий решения. Написание кода не является процессом принятия решения - это всего лишь трансляция ваших желаний. Если вас периодически тяготит написание сотен строк кода ради решения задач, то прошу обратить внимание. Данный продукт позволит существенно сократить время на рутинные операции при разработке. За счет библиотечной реализации сокращается объём кода, а его читаемость повышается. К библиотеке прилагается документация API и шаблоны кода для наиболее популярных методов.

4200 руб.

16.04.2021    10441    2    9    

7

Шаблон для разработки внешних печатных форм с отладкой

Печатные формы Инструментарий разработчика Платформа 1С v8.3 1С:Управление торговлей 11 Россия Платные (руб)

Внешняя печатная форма печати Расходной Накладной из документа "Реализация Товаров и Услуг" для УТ 11 с возможностью тестирования и отладки программного кода, печати непроведенных документов и открытия формы обработки перед печатью, а также присутствует возможность передачи дополнительных параметров в функцию печати. Обработка полезна программистам, можно использовать как шаблон для создания собственных внешних печатных форм с отладкой кода при разработке. Помогает минимизировать трудозатраты программиста при разработке дополнительных печатных форм для конфигураций, использующих БСП.

2000 руб.

26.02.2020    5011    2    3    

2

[ЕХТ] Фреймворк для Расширений 1С

Инструментарий разработчика Платформа 1С v8.3 Управляемые формы Платные (руб)

"Фреймворк для Расширений 1С" это универсальное и многофункциональное решение, упрощающее разработку и поддержку создаваемых Расширений. Поставляется в виде комплекта из нескольких Расширений с открытым исходным кодом. Работает в любых Конфигурациях в режиме Управляемого приложения с режимом совместимости 8.3.12 и выше без необходимости внесения изменений в Конфигурацию.

3000 руб.

27.08.2019    14851    3    6    

32

1С HTML Шаблоны / HTML Templates

Инструментарий разработчика Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Быстрая и удобная обработка для работы с шаблонами HTML. Позволяет легко и быстро формировать код HTML.

2040 руб.

27.12.2017    25998    2    10    

9