INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Крючков Владимир | Начальник сектора разработки | ООО "Группа Полипластик"

«Как мы разрабатываем в EDT»

1. Ответим на вопрос как мы переходили на разработку в EDT. Где было больно и что стало лучше? Где светлое будущее? 2. Расскажем про использование процессов разработки для коммерческих продуктов и open source. Что такое «Git Flow», «Git Lab Flow» и «Git Hub Flow» в чем их отличие и в чем сила? 3. Командная разработка в новых реалиях: Где и как нам помогает SCRUM? Как и где используем KANBAN? Нужно ли следовать за белым кроликом? 4. Про системы баг трекинга: Интеграция с системами баг трекинга для коммерческих решений на примере JIRA. Достаточно ли возможностей «Git Hub Issue» для open source? 5. Про репозитарии: Какой репозитарий выбрать? Что такое «bitbucket», «github» и что они умеют? Как все это увязать с EDT и баг трекингом? Когда использовать приватные, а когда публичные хранилища? 6. Используем новые волшебные возможности: автосборка релиза, code review, pull request, ветвление (bruches) и др. Как именовать ветки и что писать в коммитах чтобы получить профит. 7. Немного про качество продукта: Как мы запускаем тесты при разработке в EDT? Как используем open source Фреймворк «Тестирование 3.0»?

Печать почтового индекса, только средствами платформы

Печать - Универсальные печатные формы

8
Обработка-пример печати почтового индекса, только средствами платформы 1С:Предприятие 8.

Пример использования: печать индекса на почтовых конвертах, без использования посторонних программ (только средствами 1С:Предприятие 8).

Обработка предназначена для ознакомления. Для нормальной работы нужно интегрировать процедуры модуля объекта в своё решение (например, печатные формы конвертов).

8

Скачать файлы

Наименование Файл Версия Размер
Обработка "Печать почтового индекса"
.epf 11,47Kb
19.12.14
17
.epf 1 11,47Kb 17 Скачать

См. также

Комментарии
Сортировка: Древо
1. monkbest 97 19.12.14 15:53 Сейчас в теме
Я думал конверты проще купить/заказать, чем самому печатать и клеить:)
2. terroristish 77 19.12.14 16:15 Сейчас в теме
Если нужна массовая рассылка, то может оказаться, что легче распечатать из 1С на пустых конвертах, чем всё от руки заполнять. При этом конечно нужно, что бы в ИБ была вся необходимая для этого информация (адреса с индексами и т.д.).
3. Идальго 88 19.12.14 21:14 Сейчас в теме
А сделали как, каждой цифре соответствует заранее нарисованная картинка, или как-то по-другому?
4. terroristish 77 20.12.14 00:54 Сейчас в теме
Для каждой цифры задан алгоритм, как её (цифру) следует изобразить с помощью графических примитивов доступных в табличном документе (линии и точки). Пропорции брал из ГОСТ Р 51506—99 приложение Д.1 Оформление шестизначного кодового штампа. Т.е.каждая цифра - это не заранее нарисованная картинка, а набор графических элементов табличного документа.
5. iov 364 23.12.14 17:30 Сейчас в теме
(4) terroristish, Было просто ради интереса? Не в обиду но картинка не поменяется с выходом новой платформы а вот программное исполнение - запросто. 1С могут )))
Проще собрать из картинок и маштабировать под конверты легче мне кажется.
6. terroristish 77 24.12.14 10:20 Сейчас в теме
(5) iov, Разработка алгоритма печати индекса выполнялась под конкретную задачу (подсистема учета и рассылки почтовых сообщений). Данная обработка, по большому счету просто часть общего модуля по печати почтового индекса в табличный документ. Вариант с картинками я рассматривал, но выбрал именно тот вариант, который реализован (пусть он и сложнее в исполнении). Существенные изменения в платформе, в части касающейся табличного документа, кажутся мне маловероятными в ближайшие годы.
7. chmv 25.12.14 17:16 Сейчас в теме
Так почему не картинка? Или подобрать шрифт?
8. terroristish 77 25.12.14 22:31 Сейчас в теме
(7) chmv, Шрифты искал. То, что нашёл мне не понравилось. Например: отсутствие в них реперных точек. В рисовании картинок я не силён. Лично мне легче примитивами табличного документа отобразить.
9. kostyaomsk 74 16.02.17 17:50 Сейчас в теме
10. kc-ropa 39 21.03.18 16:34 Сейчас в теме
Все супер, только цифры 7 и 9 неправильные. Необходимо поправить со строки 100
// ПРАВО ВЕРХ	
	Если ТекЦифра = 0
		ИЛИ ТекЦифра = 1
		ИЛИ ТекЦифра = 2
		ИЛИ ТекЦифра = 4
		//ИЛИ ТекЦифра = 7
		ИЛИ ТекЦифра = 8
		ИЛИ ТекЦифра = 9 Тогда
		
		НарисоватьЛинию(Макет, Х0 + РазмерРебра, У0, 0, РазмерРебра, ТолщинаЛинии);
			
	КонецЕсли;
	
	// ЦЕНТР
	Если ТекЦифра = 3
		ИЛИ ТекЦифра = 4
		ИЛИ ТекЦифра = 5
		ИЛИ ТекЦифра = 6		
		ИЛИ ТекЦифра = 8
		ИЛИ ТекЦифра = 9 Тогда
		
		НарисоватьЛинию(Макет, Х0,	У0+РазмерРебра, РазмерРебра, 0, ТолщинаЛинии);
			
	КонецЕсли;
	
	// ВЕРХ ПОПЕРЕЧНАЯ	
	Если ТекЦифра = 1
		ИЛИ ТекЦифра = 3
		ИЛИ ТекЦифра = 7
		ИЛИ ТекЦифра = 6 Тогда
		
		НарисоватьЛинию(Макет, Х0+РазмерРебра, У0, -РазмерРебра, РазмерРебра, ТолщинаЛинии);
				
	КонецЕсли;
	
	//ЛЕВО НИЗ
	Если ТекЦифра = 0
		ИЛИ ТекЦифра = 6		
		ИЛИ ТекЦифра = 7
		ИЛИ ТекЦифра = 8 Тогда
		
		НарисоватьЛинию(Макет, Х0,	У0+РазмерРебра, 0, РазмерРебра, ТолщинаЛинии);
					
	КонецЕсли;
		
	//ПРАВО НИЗ
	Если ТекЦифра = 0
		ИЛИ ТекЦифра = 1		
		ИЛИ ТекЦифра = 4
		ИЛИ ТекЦифра = 5
		ИЛИ ТекЦифра = 6
		//ИЛИ ТекЦифра = 7
		ИЛИ ТекЦифра = 8
		//ИЛИ ТекЦифра = 9
		Тогда
		
		НарисоватьЛинию(Макет, Х0+РазмерРебра, У0+РазмерРебра, 0, РазмерРебра, ТолщинаЛинии);
			
	КонецЕсли;
	
	// НИЗ
	Если ТекЦифра = 0
		ИЛИ ТекЦифра = 2
		ИЛИ ТекЦифра = 5
		ИЛИ ТекЦифра = 6
		ИЛИ ТекЦифра = 8
		//ИЛИ ТекЦифра = 9 
		Тогда
		
		НарисоватьЛинию(Макет, Х0,	У0+РазмерРебра*2, РазмерРебра, 0, ТолщинаЛинии);
	
	КонецЕсли;
	
	//НИЗ ПОПЕРЕЧНАЯ	
	Если ТекЦифра = 2
		ИЛИ ТекЦифра = 3
		ИЛИ ТекЦифра = 9 
		Тогда
		
		НарисоватьЛинию(Макет, Х0+РазмерРебра, У0+РазмерРебра, -РазмерРебра, РазмерРебра, ТолщинаЛинии);
	
	КонецЕсли;

Показать
Оставьте свое сообщение