IE2017

Погодный информер

Обработки - Универсальные обработки

Погодный информер от Яндекс и от меня

Вдохновило: http://maarkus.ru/prognoz-pogody-dlya-sajta-cherez-api-yandeksa/. Что получилось - на картинке.

При первом старте предлагается выбрать страну и город, при последующих загружается сам прогноз.

НЕ победил: раскраску дерева погоды, есть поле цвета температуры, но... У кого получится - поделитесь для общего развития.

Файл полученных данных разнообразный - каждый может найти информацию по душе.

Сильно не пинайте (всегда можно посмотреть погоду из окна)

Скачать файлы

Наименование Файл Версия Размер
Обработка
.epf 12,93Kb
13.08.15
13
.epf 001 12,93Kb 13 Скачать

См. также

Комментарии
1. blindcat2006 (blindcat2006) 63 14.08.15 10:43 Сейчас в теме
НЕ победил: раскраску дерева погоды, есть поле цвета температуры, но... У кого получится - поделитесь для общего развития.


Для БП 3.0

&НаСервере
Процедура ЗагрузитьПогоду()
	
	ОбъектОбработка = РеквизитФормыВЗначение("Объект");	
	ДЗ = ОбъектОбработка.ЗагрузитьПогоду(Объект.idГорода);
	Если ДЗ = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	Если ДЗ.Строки.Количество() > 0 Тогда
		
		ЗначениеВРеквизитФормы(ДЗ,"ДеревоПогоды");
		
		// Добавлено \/
		
		УсловноеОформление.Элементы.Очистить();
		
		Для каждого СтрокаДня Из ДЗ.Строки Цикл
			
			Для каждого СтрокаПогоды Из СтрокаДня.Строки Цикл
				
				Если НЕ ПустаяСтрока(СтрокаПогоды.ЦветТемпературы) Тогда
					
					ЭлементУО = УсловноеОформление.Элементы.Добавить();
					
					КомпоновкаДанныхКлиентСервер.ДобавитьОформляемоеПоле(ЭлементУО.Поля, "ДеревоПогодыТемпература");
					
					ОбщегоНазначенияКлиентСервер.ДобавитьЭлементКомпоновки(ЭлементУО.Отбор,
						"ДеревоПогоды.ЦветТемпературы", ВидСравненияКомпоновкиДанных.Равно, СтрокаПогоды.ЦветТемпературы);
					
					ЦветRGB = HexToDec(СтрокаПогоды.ЦветТемпературы);	
					
					R = ЦветRGB%256;
					G = (Цел(ЦветRGB/256))%256;
					B = (Цел(ЦветRGB/65536))%256;
					
					ЭлементУО.Оформление.УстановитьЗначениеПараметра("ЦветФона", Новый Цвет(B,G,R));
					
				КонецЕсли;
				
			КонецЦикла; 
			
		КонецЦикла; 
		// Добавлено /\
		
	КонецЕсли;
	
КонецПроцедуры
...Показать Скрыть
2. Сергей (seermak) 656 14.08.15 11:08 Сейчас в теме
(1) и ,правда, заработало, я пытался сделать подобное, но ума не хватило..... Спасибо
Оставьте свое сообщение