Автоматическое обновление конфигураций

Публикация № 401277

Администрирование - Администрирование данных 1С - Архивирование (backup)

Автообновление автоматическое обновление обновление.

Очень много времени программист тратит на обновление однотипных (и не очень) конфигураций, избавляемся от этого, и освободившееся время тратим на что-то более интересное.

    Работая в франчайзи столкнулся с тем, что много времени тратится на то, чтобы обновить нетиповые конфигурации (хоть их и не сильно изменили), особенно в отчетный период. Бухгалтеру нужно сдавать отчеты, обновление только вышло и всем надо ставить срочно, знакомо, думаю, многим. И вот однажды как-то всё надоело, и стал задумываться, а как бы их автоматически обновлять.  Первым делом выделил группы однотипно измененных конфигураций, получилось порядка 10 групп. Создал файлы обновления и поставки (материалов куча, не буду описывать). Для опыта выбрал по базе из каждой группы и поставил их на поддержку уже своей поставки (вроде так это называется, взял файл поставки того же релиза, что и конфигурация, и загрузил его). Вот теперь наши конфигурации "типовые", и теперь нам надо обновить уже не ....цать конфигураций, а всего 10, и сделать файлы обновлений. И теперь любой может обновлять как типовые. Идем дальше.  

    Хочется, чтобы при открытии конфигурация проверяла есть ли обновления, и сама устанавливала их. Возникли вопросы:

1) где хранить файлы обновлений

2) как их скачивать

3) как организовать автообновление конфигурации

1) По поводу хранения файлов обновления остановился на ftp сервере ([хорошая скорость отдачи, легкий доступ, ...). Нашел инструкцию по настройке ftp  сервера на Windows 7, благо был внешний статический ip. Если нет такового, то провайдер может его предоставить или же воспользоваться специальной программкой DynDNS.  Но для доступа к ftp серверу нужен логин и пароль, да и сам адрес, хранить его в коде не хотелось, сохранил во внешнем файле и, когда нужно, получал их. Также встал вопрос, как проверить релиз, ну тут просто имя файла сделал (2.0.64.5.cfu). 

    Так как не всем клиентам можно автоматически обновляться, а только тем, у кого есть действующая подписка ИТС, под каждого клиента была создана папка, в которой будет лежать обновление (и обновление мы будем проверять именно в этой папке). Отсюда вытекло, что хранить имя папки также где-то надо, сначала хотел хранить в константе, но потом решил хранить вне программы. 

    Руками раскидывать файлы обновлений и отслеживать, кому откуда копировать, а кому и не копировать (действующая подписка ИТС),  трудоемко, для этих целей сделал обработку.

2) Сначала попробовал скачивать файл средствами 1С, но программа при этом зависала до окончания скачивания файла. Решил сделать через bat файл, но при его запуске висело окно командной панели, решено было его скрыть, написали скрипт. Протестировав загрузку файла, невозможно было понять, когда он загрузился полностью. Тестируя на Windows XP, решил проверять загрузку файла по размеру файла. Уже не помню почему, но размер файла указал в имени файла, в итоге имя файла обновлений  стало выглядеть примерно так 2.0.64.5_12586125.cfu.

3) Обновление сделал в пакетном режиме (часть кода взял тут //infostart.ru/public/147253/, Спасибо!). Позже появилась идея использовать типовой механизм обновления конфигураций, подсунуть ему свой файл обновления, но руки так и не дошли.

Общий порядок получился такой:

В процедуре ПриНачалеРаботыСистемы проверяем наличие обновления:

ИмяFTPСервера               = Адрес;//
ПортFTPСоединения           = "21";
ПользовательFTPСоединения   = Логин;//
ПарольFTPСоединения         =  Пароль;
ПассивноеFTPСоединение      =  Ложь;
Соединение = Новый FTPСоединение(ИмяFTPСервера, ПортFTPСоединения,ПользовательFTPСоединения,ПарольFTPСоединения, ,ПассивноеFTPСоединение);
//Путь на сервере в формате /OOO_Birka/
Массив = Соединение.НайтиФайлы(СокрЛП(ПутьНаСервере), "*.cfu");
			
Если Массив.Количество() <> 0 Тогда
    Для Каждого Стр Из Массив Цикл
        //Получаем релиз и сравниваем
        ВерсияКонф = Метаданные.Версия;
        ВерсияНаСервере = Стр.ИмяБезРасширения;
        //проверить может уже скачан (вынесено выше до проверки обновления на ftp)  
        Если Число(Сред(ВерсияКонф,5,2)) < Число(Сред(ВерсияНаСервере,5,2)) Тогда 
            Режим = РежимДиалогаВопрос.ДаНет;
            //Текст = "Вышло очередное обновление" + Символы.ПС + "Скачать??";
            //Ответ = Вопрос(Текст, Режим, 0);
            СформироватьБатникНаСкачивание(Стр.Имя);
            ЭтотОбъект.ПолучитьФорму("Форма").Открыть();
						
         ИначеЕсли Число(Сред(ВерсияКонф,5,2)) = Число(Сред(ВерсияНаСервере,5,2)) и Число(Сред(ВерсияКонф,8,1)) < Число(Сред(ВерсияНаСервере,8,1)) Тогда
             Режим = РежимДиалогаВопрос.ДаНет;
             //Текст = "Вышло очередное обновление" + Символы.ПС + "Скачать??";
             //Ответ = Вопрос(Текст, Режим, 0);
             //Если Ответ = КодВозвратаДиалога.Да Тогда
                 СформироватьБатникНаСкачивание(Стр.Имя);
                 ЭтотОбъект.ПолучитьФорму("Форма").Открыть();
             //КонецЕсли;
        КонецЕсли;
    КонецЦикла;
КонецЕсли;

 

Процедура СформироватьБатникНаСкачивание(ИмяФайла)
	ПутьДляОбновлений = "";
	ПутьДляОбновлений = "D:\papka\";
	Если ПутьДляОбновлений = Null или ПутьДляОбновлений = "" Тогда
		Возврат;  
	КонецЕсли;

	ПутьНаСервере = "/OOO_Birka/";

	//vbs
	тек = Новый ТекстовыйДокумент;
	тек.ДобавитьСтроку("Dim oShell ");
	тек.ДобавитьСтроку("Set oShell = WScript.CreateObject (""WSCript.shell"") ");
	тек.ДобавитьСтроку("oShell.run """+ СокрЛП(ПутьДляОбновлений) + "1.bat"", 0 ");
	тек.ДобавитьСтроку("Set oShell = Nothing");
	тек.Записать(СокрЛП(ПутьДляОбновлений) + "start.vbs",КодировкаТекста.OEM,);
	
	//txt
	тек = Новый ТекстовыйДокумент;
 
	тек.ДобавитьСтроку("open " + Адрес);
	тек.ДобавитьСтроку(Логин);
	тек.ДобавитьСтроку(Пароль);
	тек.ДобавитьСтроку("get " + СокрЛП(ПутьНаСервере) + ИмяФайла + " " + СокрЛП(ПутьДляОбновлений) + ИмяФайла);
	тек.ДобавитьСтроку("bye");
	тек.Записать(СокрЛП(ПутьДляОбновлений) + "conf.txt",КодировкаТекста.OEM,);
	
	//bat
	тек = Новый ТекстовыйДокумент;
	тек.ДобавитьСтроку("ftp -i -s:conf.txt");
	тек.ДобавитьСтроку("timeout /t 3 ");
	тек.ДобавитьСтроку("REN | RENAME " + СокрЛП(ПутьДляОбновлений) + ИмяФайла + " ok" + ИмяФайла);
	тек.ДобавитьСтроку(СокрЛП(ПутьДляОбновлений) + "del.bat");
	тек.Записать(СокрЛП(ПутьДляОбновлений) + "1.bat",КодировкаТекста.OEM,);
	
	
	тек = Новый ТекстовыйДокумент;
	тек.ДобавитьСтроку("del " + СокрЛП(ПутьДляОбновлений) + "conf.txt");
	тек.ДобавитьСтроку("del " + СокрЛП(ПутьДляОбновлений) + "start.vbs");
	тек.ДобавитьСтроку("del " + СокрЛП(ПутьДляОбновлений) + "1.bat");	тек.ДобавитьСтроку("del %0");
	тек.Записать(СокрЛП(ПутьДляОбновлений) + "del.bat",КодировкаТекста.OEM,);

	Запустить(ПутьДляОбновлений);
КонецПроцедуры

процедура Запустить(ПутьДляОбновлений)
	КомандаСистемы(СокрЛП(ПутьДляОбновлений) + "start.vbs",СокрЛП(ПутьДляОбновлений));
КонецПроцедуры

В открываемой форме ( ЭтотОбъект.ПолучитьФорму("Форма").Открыть(); , код был в модуле обработки, в процедуре ПриОткрытии формы подключаем обработчик ожидания. Она проверяет окончание загрузки файла и открывает следующую форму:

Процедура Ожидать() Экспорт
	ПодключитьОбработчикОжидания("ЖдатьЗагрузки",10);
Конецпроцедуры

Процедура ЖдатьЗагрузки()
   Завершена = ОжиданиеЗагрузки();	/// процедура в модуле обработки
   Если Завершена Тогда
	   ОтключитьОбработчикОжидания("ЖдатьЗагрузки");
	   ЭтотОбъект.ПолучитьФорму("Форма1").ОткрытьМодально();
	   ЭтаФорма.Закрыть();
   Конецесли;   
Конецпроцедуры

Процедура ПриОткрытии()
	Ожидать();
КонецПроцедуры



Функция ОжиданиеЗагрузки() Экспорт	
	ПутьДляОбновлений = ""; ///каталог где хранится наш файл
	ПутьДляОбновлений = "D:\papka\"; ///
	Если ПутьДляОбновлений = Null или ПутьДляОбновлений = "" Тогда
		Возврат ЛОЖЬ;
	КонецЕсли;
	Массив = НайтиФайлы(СокрЛП(ПутьДляОбновлений),"*.cfu");
	Если  Массив.Количество() = 0 Тогда
		Массив = НайтиФайлы(СокрЛП(ПутьДляОбновлений), "*.cf");
	КонецЕсли;
	
	Если Массив.Количество() <> 0 Тогда
		Для каждого стр из Массив Цикл
			Если Найти(Стр.имя,"ok") Тогда
				Позиц = Найти(Стр.ИмяБезРасширения,"_"); 
				Размер = Число(Сред(Стр.ИмяБезРасширения,Позиц + 1 ));
				Если  Размер = Стр.Размер() Тогда
					//Сообщить("Загрузка завершена");
					тек = Новый ТекстовыйДокумент;
					тек.ДобавитьСтроку(Стр.Имя);
					тек.Записать(СокрЛП(ПутьДляОбновлений) + "imya.txt",КодировкаТекста.OEM,);
					Возврат Истина;
				Иначе 
					Возврат ЛОЖЬ;
				конецЕсли;
			Иначе
				Возврат ЛОЖЬ;
			КонецЕсли;
		КонецЦикла;	
	Иначе
		Возврат ЛОЖЬ;
	КонецЕсли;
	
КонецФункции

Следующие формы проверяют активные сеансы и, если есть такие, просит их закрыть. Если активных сеансов нет, формирует bat файл для обновления, запускает его и закрывает программу. Процедура формирования bat файла:

Процедура СоздатьФайлобновления() Экспорт
	ПутьДляОбновлений = "";
	ПутьДляОбновлений = "D"\papka\";
	Если ПутьДляОбновлений = Null или ПутьДляОбновлений = "" Тогда
		Возврат;
	КонецЕсли;
	ПутьДляОбновлений = Лев(ПутьДляОбновлений,СтрДлина(ПутьДляОбновлений) - 1) + "ZIK\";
	ПутьАрхива = "D:\Arhiv\";
	Если ПутьАрхива = Null или ПутьАрхива = "" Тогда
		Возврат;
	КонецЕсли;
	ПутьДля1СПредприятия = "C:\Program Files (x86)\1cv82\8.2.19.76\bin\1cv8.exe"; 
	
	тек = Новый ТекстовыйДокумент;
	тек.ДобавитьСтроку("timeout /t 10 ");
	
	ЗапускПред = """"+СокрЛП(ПутьДля1СПредприятия)+""" enterprise";
	ЗапускКонф = """"+СокрЛП(ПутьДля1СПредприятия)+""" config";
	
	Пароль = "";
	Подсказка = "Введите пароль своего пользователя в 1С (Если Он есть), "+ Символы.ПС +"  если пароль не задан нажмите ОК";
	ВвестиСтроку(Пароль, Подсказка, 0, Истина);
	
	
	ПодклБаза = " /F"""+НСтр(СтрокаСоединенияИнформационнойБазы(), "File")+"""" +?(СокрЛП(ПараметрыСеанса.ТекущийПользователь.Наименование)="" или СокрЛП(ПараметрыСеанса.ТекущийПользователь.Наименование) = "<Не указан>",""," /N"""+СокрЛП(ПараметрыСеанса.ТекущийПользователь.Наименование)+"""") + ?(СокрЛП(Пароль)="",""," /P"""+СокрЛП(Пароль)+"""");
	
	РезервКоп = " /DumpIB"""+СокрЛП(ПутьАрхива)
	+СтрЗаменить(СтрЗаменить("Было","  "," ")," ","_")+"_"
	+СтрЗаменить(Формат(ТекущаяДата(),"ДЛФ=Д"),".","_")+"Бух.dt""";
	
	РезервКоп2 = " /DumpIB"""+СокрЛП(ПутьАрхива)
	+СтрЗаменить(СтрЗаменить("стало","  "," ")," ","_")+"_"
	+СтрЗаменить(Формат(ТекущаяДата(),"ДЛФ=Д"),".","_")+"Бух.dt""";
	Массив = НайтиФайлы(СокрЛП(ПутьДляОбновлений),"imya.txt");
	Если Массив.Количество() <> 0 Тогда
		Текст = Новый ТекстовыйДокумент; 
		Текст.Прочитать(СокрЛП(ПутьДляОбновлений) + "imya.txt"); 
		ФайлОбновление = СОКРЛП(Текст.ПолучитьСтроку(1));
	Иначе
		ФайлОбновление = "";
		Возврат;
	КонецЕсли;
	ОбновлКонф = " /UpdateCfg"""+СокрЛП(ПутьДляОбновлений) + ФайлОбновление+"""";
	ОбновлБазы = " /UpdateDBCfg";
	стр = ЗапускКонф+ПодклБаза+РезервКоп;
	Если стр<>"" тогда тек.ДобавитьСтроку(стр); стр=""; конецесли;
	
	стр = ЗапускКонф+ПодклБаза+ОбновлКонф;
	стр = стр+ОбновлБазы;
	Если стр<>"" тогда тек.ДобавитьСтроку(стр); стр=""; конецесли;
	стр = ЗапускКонф+ПодклБаза+РезервКоп2;
	Если стр<>"" тогда тек.ДобавитьСтроку(стр); стр=""; конецесли;
	тек.ДобавитьСтроку("del " + СокрЛП(ПутьДляОбновлений) + ФайлОбновление);
	тек.ДобавитьСтроку("del " + СокрЛП(ПутьДляОбновлений) + "imya.txt");
	стр = ЗапускПред+ПодклБаза;
	Если стр<>"" тогда тек.ДобавитьСтроку(стр); стр=""; конецесли;
	тек.ДобавитьСтроку("del %0");
	тек.ДобавитьСтроку("");
	тек.Записать(СокрЛП(ПутьДляОбновлений) + "Obnov.bat",КодировкаТекста.OEM,);
	
	
Конецпроцедуры

процедура ЗапуститьОбновление(Форма) Экспорт
	ПутьДляОбновлений = "D:\Papka\";

	ЗапуститьПриложение(СокрЛП(ПутьДляОбновлений) + "Obnov.bat"); 
	
	ПрекратитьРаботуСистемы();

КонецПроцедуры

Позже переделал это всё в обработку (её и выкладываю) и указывал дополнительные параметры запуска "/Execute "C:\Загрузка.epf", обновляем типовые конфигурации. Нам только необходимо определиться с местом хранения параметров: адрес ftp, логин, пароль, папка клиента на ftp и папка, куда мы будем скачивать обновления. Велись работы по изменению окна обновления, чтобы не висело окно командной панели, заменить чем-нибудь красивым. И вроде как бы получилось, если кому-то надо, поищу исходники. Проблемные места:

1) Блокирует скачивание брэндмауер, Kaspersky, Avira. 

2) При наличии 2 сетевых подключений загрузка не происходит.

3) Требуется участие пользователя.

4) Иногда процесс обновления конфигурации не происходит, пользователь видит сообщение "конфигурация базы данных не соответствует сохраненной конфигурации" и звонит вам.

5) Паранормальные случаи.

Проверял только на файловых версиях. Операционные системы: Windows XP, Windows 7, Windows 8, Windows Vista. Код открытый, обработку необходимо немного изменить (решить, где хранить параметры и прописать их получение). С вводом и настройкой автоматического обновления. Обновление готовлю в свободное время (иногда поздно вечером) и терерь, сделав 10 файлов обновления, обновляем ими более 250 клиентов. Мы не привязаны к временным рамкам работы бухгалтера.

Скачать файлы

Наименование Файл Версия Размер
Обновление

.epf 30,54Kb
14
.epf 30,54Kb 14 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. CheBurator 3452 24.09.15 11:48 Сейчас в теме
2. fzt 18.04.16 12:26 Сейчас в теме
(1) CheBurator, за баблос нынче фулверсия. Тут сорцы есть.
3. u_n_k_n_o_w_n 43 09.01.19 16:39 Сейчас в теме
Неплохой вариант в случае, если у клиента стоит даже доработанная версия.
4. Xershi 1127 09.01.19 16:45 Сейчас в теме
(3) как сказал автор у него 10 групп, а если таких будет 100500?)
5. DmitriyPopow 32 09.01.19 20:13 Сейчас в теме
(4)
сказал автор у него 10 групп, а если таких будет 100500?

если будет 100500 то их в любом случае можно привести к некой группе. и из 100500 получить 200. и все равно это лучше обновить спокойно 200 чем 100500 ..
а если нельзя ... то тогда штат сотрудников должен быть огого чтобы успеть всех обновить.
6. DmitriyPopow 32 09.01.19 20:14 Сейчас в теме
с выходом расширений потеряло актуальность все таки. но имеет право на жизнь.
7. u_n_k_n_o_w_n 43 11.01.19 21:50 Сейчас в теме
Если бы они еще не глючили, им бы цены не было.
Оставьте свое сообщение

См. также

Пометка на удаление неиспользуемых элементов справочников и документов Промо

Чистка базы Обработка документов Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

В ходе работы в программе в ней зачастую накапливается "мусор". Данная разработка может помочь убрать его... (обычные или управляемые формы)

1 стартмани

02.02.2010    32245    696    AnryMc    53    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    12260    18    capitan    11    

Пакетное пробитие чеков на Онлайн-кассе при оплатах от физических лиц на расчетный счет

Банковские операции Кассовые операции Обработка документов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Автоматизация процесса пробития чеков онлайн при поступлениях на расчетный счет от физических лиц. Помогает сократить трудозатраты таким организациям, как МФЦ, Управляющие компании и т.д. Подходит для 1С:Бухгалтерия 3.0 любой версии (базовая, ПРОФ, КОРП). Не изменяет конфигурацию. Конфигурация остается на поддержке (типовая).

2 стартмани

24.09.2019    16093    6    r.resh39    6    

Списание (корректировка) задолженности контрагентов УНФ 1.6

Закрытие периода Дебиторская и кредиторская задолженность Обработка документов Дебиторская и кредиторская задолженность v8 УНФ Украина БУ Абонемент ($m)

Обнуление задолженности контрагентов в конфигурации "Управление небольшой (нашей) фирмой" версии 1.6 с помощью документа "Корректировка регистров".

1 стартмани

24.07.2019    26913    18    DMon    1    

Групповая установка даты выплаты в документах "Отпуск" и "Командировка" на заданную дату и перерасчет отобранных документов Промо

Обработка документов Зарплата Управление персоналом (HRM) Зарплата v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Обработка позволяет расчетчикам сократить время, затрачиваемое на расчет отпусков и командировок.

2 стартмани

15.02.2017    15115    86    ser6702    18    

Регистрация документов с измененной суммой

Обработка документов v8 1cv8.cf Абонемент ($m)

Обработка берет информацию из истории изменения документов. Удобна для администраторов, когда документы с измененной суммой по какой-то причине не регистрируются в плане обменов. Можно регистрировать не все документы, а только те, которые были изменены.

1 стартмани

20.04.2019    22083    6    ryan    0    

Блин, мы забыли включить регламентные задания…

Сервисные утилиты v8 Абонемент ($m)

Привет, Инфостарт! Сегодня расскажу, как я решил проблему с выключенными регламентными заданиями в рабочих базах. Желая исключить человеческий фактор и минимизировать количество ошибок, я написал небольшую конфигурацию.  В конфигурации два регламентных задания. Первое периодически подключается к кластеру и сохраняет текущие параметры: имя, Сервер БД, базу СУДБ, блокировки входа и регламентных заданий и т.д. Второе задание периодически проверяет эти параметры на ошибки.

1 стартмани

08.04.2019    20759    18    slozhenikin_com    37    

Валовая прибыль для УПП 1.3, КА 1.1 в режиме РАУЗ (работа типового отчета без доработок конфигурации)

Обработка документов v8 КА1 УПП1 УУ Абонемент ($m)

Простое и мгновенное решение для использования типового отчета "Валовая прибыль" в конфигурациях "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1" (а также отраслевых решений на их базе) при включенном режиме РАУЗ (расширенная аналитика учета затрат). Не требует настройки или изменения конфигурации, либо может быть, для дополнительного удобства, интегрировано в нее с минимальными доработками.

2 стартмани

21.01.2019    22884    28    stvorl    12    

StartManager 1.4 - Развитие альтернативного стартера Промо

Стартеры 1С v7.7 v8 Абонемент ($m)

Очередная редакция альтернативного стартера, являющегося продолжением StartManager 1.3. Спасибо всем, кто присылал свои замечания и пожелания, и тем, кто перечислял финансы на поддержку проекта. С учетом накопленного опыта, стартер был достаточно сильно переработан в плане архитектуры. В основном сделан упор на масштабируемость, для способности программы быстро адаптироваться к расширению предъявляемых требований (т.к. довольно часто просят добавить ту или иную хотелку). Было пересмотрено внешнее оформление, переработан существующий и добавлен новый функционал. В общем можно сказать, что стартер эволюционировал, по сравнению с предыдущей редакцией. Однако пока не всё реализовано, что планировалось, поэтому еще есть куда развиваться в плане функциональности.

1 стартмани

23.04.2014    135145    1739    Alexoniq    1563    

Легкое и гибкое управление списком доступных баз 1С у пользователей

Стартеры 1С Сервисные утилиты Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

7 стартмани

05.12.2018    18382    20    RomikR    9    

Многопоточная обработка данных

Производительность и оптимизация (HighLoad) Администрирование данных 1С v8 v8::УФ 1cv8.cf Абонемент ($m)

Конфигурация "Универсальные механизмы: пакеты данных". Набор инструментов для быстрой организации отказоустойчивой многопоточной обработки данных.

1 стартмани

23.11.2018    25135    85    _ASZ_    15    

Обнуление остатков регистров бухгалтерии и накопления

Универсальные обработки Чистка базы v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m)

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    28290    384    morozov.sv    54    

Правильные аналоги номенклатуры (кроссы запчастей) для 1С / Управляемые формы Промо

Обработка справочников Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

По опыту работы с запчастями много раз сталкивался с проблемой организации кроссов в разных 1С - от записи артикулов через запятую в текстовом поле до хранения кроссов в документах. Предлагаю одну из простейших и функциональных на мой взгляд схем "одноуровневого" хранения кроссов.

5 стартмани

29.07.2015    39919    3    taurus__    23    

Очистка кэша 1С 8 (8.0, 8.1, 8.2, 8.3). Грамотная чистка кэша 1С с сохранением настроек.

Чистка базы Сервисные утилиты Администрирование данных 1С v8 1cv8.cf Россия Абонемент ($m)

Эффективное средство для устранения ошибок, возникающих в локальном кэше 1С на клиенте, которым легко сможет воспользоваться пользователь с любым уровнем знаний. Wsf-скрипт, созданный на стандартном языке автоматизации Windows - "WSH JScript", очищает кэш 1С просто, быстро и безопасно. Кроме варианта, очищающего кэш текущего пользователя, имеется также вариант для чистки кэша 1С всех пользователей терминального-сервера.

1 стартмани

04.11.2018    45505    457    Eugen-S    34    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    39033    143    json    44    

TextRadar - нечеткий поиск в тексте

Разработка внешних компонент Поиск данных v8 1cv8.cf Абонемент ($m)

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

1 стартмани

19.09.2018    20163    30    TSSV    19    

Очистка регистрации обмена Промо

Чистка базы v8 v8::ОУ УТ10 Абонемент ($m)

Данная обработка предназначена для очистки узла. Для очистки необходимо указать период,организацию.

1 стартмани

19.09.2017    19150    9    serg-lom89    0    

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2

Розничная торговля Обработка документов Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    37502    83    asdfgcom    47    

Расширение резервов отпусков

Обработка документов Зарплата Зарплата v8 v8::СПР ERP2 ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Произвольная настройка базы для расчета резервов отпусков.

2 стартмани

10.08.2018    31081    63    СергейКа    25    

Очистка периодических регистров посредством T-SQL (удаление записей, кроме среза последних)

Чистка базы v8 Абонемент ($m)

Обработка для ленивых. Составит вместо Вас запрос для SQL, который удалит все не актуальные записи (т.е все, кроме среза последних)

5 стартмани

22.06.2018    18179    21    Alexander.Shvets    9    

Удаление помеченных объектов, замена ссылок. Обычное и управляемое приложение. Не монопольно, включая рекурсивные ссылки, с отбором по метаданным и произвольным запросом Промо

Чистка базы v8 1cv8.cf Абонемент ($m)

Обработка удаления помеченных объектов с расширенным функционалом. Работает в обычном и управляемом приложении. Монопольный и разделенный режим работы. Отображение и отбор по структуре метаданных. Отборы данных произвольными запросами. Копирование и сохранение отборов. Удаление циклических ссылок (рекурсия). Представление циклических в виде дерева с отображением ключевых ссылок, не позволяющих удалить текущий объект информационной базы. Удаление записей связанных независимых регистров сведений. Групповая замена ссылок. Индикатор прогресса при поиске и контроле ссылочности.

10 стартмани

31.10.2016    56854    701    m..adm    225    

Автоматическое заполнение графиков в ЗУП 3.1

Зарплата Учет рабочего времени Обработка справочников Зарплата Учет рабочего времени v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    27177    18    notserioussam    2    

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    33800    77    charivnick    4    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    67936    362    Tatitutu    48    

Корректировка остатков ЕГАИС, возврат из регистра 2, загрузка ТТН из файлов, другое для УТ10.3

Розничная торговля Обработка документов Розничная торговля v8 v8::ОУ УТ10 Россия БУ Абонемент ($m)

Набор обработок для автоматизации работы с ЕГАИС: Обработка корректировки остатков ЕГАИС для УТ 10.3, аналогичная имеющимся в УТ 11, Рознице 2.2. Автоматически формирует документы "Передача в торговый зал", "Акт постановки на баланс в торговом зале", "Акт списания в торговом зале". Обработка возврата из регистра 2 с подбором справок Б. Обработка формирования ТТН из файлов xml.

1 стартмани

24.01.2018    39701    18    biz-intel    6    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    53976    33    mvv1975    7    

Копирование меню в Трактир Management

Обработка документов Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 1cv8.cf Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Механизм копирования меню в Трактир Management. Данная обработка расширяет функционал типового решения Трактир Management, позволяя быстро вводить в эксплуатацию новую точку путём создания нового меню на основании имеющегося.

1 стартмани

28.11.2017    31262    3    integrator1983    0    

Быстрое удаление неиспользуемых версий 1С:Предприятие 8, кэша метаданных и информационных баз

Сервисные утилиты v8 Абонемент ($m)

При обновлении платформы 1С:Предприятие 8 предыдущие версии не удаляются. Со временем количество неиспользуемых версий платформы растет. Они занимают место на диске. Для решения этой проблемы предназначена программа OneCleaner. Она позволяет быстро удалить неиспользуемые версии платформы, а также почистить кэш метаданных и удалить ненужные информационные базы данных.

1 стартмани

14.11.2017    24421    91    bonv    15    

Помощник по закрытию месяца для УТ 11.3

Закрытие периода Обработка документов Закрытие периода Закрытие периода v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Помощник по закрытию месяца для УТ 11.3. Имеет две функции: обнуление товаров "К оформлению" в интеркампани и обнуление отрицательных остатков в регистре "Себестоимость товаров".

5 стартмани

10.11.2017    27059    11    Zalipaka    1    

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2

Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v8 v8::ОУ ERP2 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка "Загрузка дополнительных реквизитов и сведений справочника Номенклатура"

1 стартмани

07.08.2017    45948    296    Windyhead    44    

Упрощение работы с актами сверки в УТ/КА/УПП - вывод номеров счетов в документе и печатной форме

Обработка документов Печатные формы документов Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 КА1 УТ10 УПП1 БУ УУ Абонемент ($m)

Обычно акт сверки с клиентами содержат информацию о документах реализации товаров (накладных) и выполненных платежах. Но платежи делаются на основании счетов, номера которых отсутствуют в актах, что затрудняет собственно сверку. Данная обработка находит соответствующие расходным накладным счета/заказы, показывает их в форме документа и выводит в печатную форму акта.

2 стартмани

12.05.2017    33883    4    denmax    7    

Автокликер для 1С

Сервисные утилиты v8 1cv8.cf Абонемент ($m)

Внешняя обработка, запускаемая в обычном (неуправляемом) режиме для автоматизации действий пользователя (кликер). ActiveX компонента, используемая в обработке, получает события от клавиатуры и мыши по всей области экрана в любом приложении и транслирует их в 1С, получает информацию о процессах, текущем активном приложении, выбранном языке в текущем приложении, умеет сохранять снимки произвольной области экрана, активных окон, буфера обмена, а также, в режиме воспроизведения умеет активировать описанные выше события. Все методы и свойства компоненты доступны при непосредственной интеграции в 1С. Примеры обращения к компоненте представлены в открытом коде обработки.

1 стартмани

03.04.2017    33588    77    slava_1c    67    

DroidRAC2 - консоль администрирования кластера серверов 1С:Предприятие 8.3 под Android

Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

DroidRAC2 - клиент для RAS-сервиса кластера серверов платформы 1С:Предприятие 8.3 под Android.

1 стартмани

24.02.2017    24540    10    user700211_a.straltsou    20    

Статистика базы данных с отбором по подсистемам (кол-во и открытие списков: документов, справочников, регистров) и анализ наличия основных реквизитов: универсальная обработка (два файла - обычный и управляемый режим)

Статистика базы данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная обработка для статистики базы данных (документы, справочники, регистры, отчеты) с отбором по подсистемам и с анализом наличия основных реквизитов (организации, контрагенты, договора, номенклатура, сотрудники, физлица, валюта). Возможность просмотра списка документов или справочников или регистров при активизации в колонке "Документы, справочники, регистры, отчеты" в текущей строке. Полезная обработка для консультации пользователей, где искать метаданные в каком интерфейсе, т.к. подсистема указывает в каком интерфейсе находятся метаданные (документы, справочники, регистры, отчеты).

1 стартмани

20.02.2017    19760    53    strelec13    11    

Определение ИНН Сотрудника (service.nalog.ru). ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Внешняя печатная форма для справочника "Сотрудники организаций". ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

1 стартмани

03.02.2017    75243    50    Indgo    34    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Обмен через XML v8 Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    45470    159    Aphanas    4    

Универсальный поиск объектов по глобальному уникальному идентификатору (ГУИД, GUID)

Универсальные обработки Поиск данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Универсальная обработка поиска объектов информационной базы по глобальному уникальному идентификатору (ГУИД, GUID) или по его части.

1 стартмани

06.09.2016    35902    107    Dzenn    9    

Лекарство на случай, если перестала работать форма списка для сделок. (ERP).

Тестирование и исправление v8 ERP2 Абонемент ($m)

Форма списка справочник сделки стала выпадать с ошибкой?  Или все еще в порядке, но хочется спокойно съездить в отпуск, без паники, что менеджеры устроят бунт.

1 стартмани

28.07.2016    23882    0    milkers    2    

Многопоточное удаление объектов

Чистка базы v8 1cv8.cf Абонемент ($m)

Обработка предназначена для ускорения процедуры удаления объектов

2 стартмани

02.06.2016    27217    55    zzz_natali    20    

Загрузка Счета покупателя из PDF

Обработка документов Файловые протоколы обмена, FTP Оптовая торговля Оптовая торговля v8 v8::БУ БП3.0 Абонемент ($m)

Обработка позволяет загрузить счет покупателя из pdf-файла в документ Счет на оплату покупателю (Бухгалтерия 3.0)

2 стартмани

23.05.2016    22791    25    John_d    3    

Обработка "Все одной кнопкой" (групповое создание и печать документов) для УПП ред. 1.3

Обработка документов Пакетная печать Кассовые операции Оптовая торговля Производство готовой продукции (работ, услуг) Кассовые операции Оптовая торговля Производство готовой продукции (работ, услуг) v8 УПП1 БУ УУ Абонемент ($m)

Данная обработка предназначена для группового создания, редактирования и печати основных документов («Реализация товаров и услуг», «Счет-Фактура выданный», «Счет на оплату клиентом», «Доверенность» на получение продукции, "Приходного кассового ордера") на основании документа «Заказ клиента». Основная цель обработки – оптимизация работы менеджеров при формировании пакета документов клиентам.

3 стартмани

09.04.2016    25995    31    SEOAngels    0    

Инструкция по установке и настройке SQL Server и 1С

Администрирование данных 1С v8 Россия Абонемент ($m)

Данный мануал позволит практически каждому пользователю пошагово установить и произвести первоначальную настройку SQL Server и 1С (клиент-серверный вариант). Основой для данной инструкции послужил SQL Server 2014 и 1С Предприятие 8.3, также данная инструкция может работать и для других версий SQL Server и 1С Предприятия.

1 стартмани

06.04.2016    90992    1100    LastSoldier    48