Простые радости жизни программиста 1С: выбор типа значения

Публикация № 459332

Разработка - Практика программирования

выбор тип альтернативный

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

 

Красота, конечно, спасет мир, но, похоже, никто в этом мире не думает о спасении.

 

Версии обработки:

Версия 1.3 от 02.01.2018
 +  добавлен показ типа
"СписокЗначений" при показе дополнительных типов (вместе с типом "ДвоичныеДанные").
 +  в группу типов
"Системные перечисления" добавлен тип "СтатусСообщения".
 +  добавлен показ типов ключей записей регистров учета (сведений, накопления, бухгалтерии и расчета)
     (
Рис.19.1
, Рис.20.1, Рис.19.2, Рис.20.2 ).
 +  добавлен показ типов менеджеров констант, а также типов объектов встроенных отчетов и обработок
    (опция не имеет смысла для управляемой формы диалога из-за недоступности типов,
Рис.19.1
, Рис.20.1, Рис.19.2).
 +  добавлена возможность испоьзования кратких названий групп ссылочных типов
    (
"Справочники" вместо "СправочникСсылка").
 +  добавлена возможность указания заголовка диалога, отличного от выводимого по умолчанию.
 +  тип параметра открытия диалога
"ТипыВВидеДерева" , определяющий представление списка типов,
     изменен на числовой (с сохранением поведения для обратной совместимост
и):
          0 -
"список", 1 - "многоуровневое дерево", 2 - "одноуровневое дерево".
 +  добавлена смена представления списка типов в диалоге с возможностью сохранения
     выбранного значения в настройках формы-владельца, открывшей диалог (
Рис.19.3
, Рис.20.3 ).
 +  исправлены замеченные ошибки.

Версия 1.2 от 11.04.2016
 + поиск по строке в имени или синониме типа (Рис.18.1, Рис.18.4), ограничение поиска изначально отмеченными типами (Рис.18.2);
 + показ только отмеченных строк в списке типов (как особый режим поиска, Рис.18.3);
 + показ дополнительных типов "ХранилищеЗначения", "УникальныйИдентификатор" (в дополнение к "ДвоичныеДанные", Рис.18.5);


Версия 1.1 от 13.03.2016
 + в контекстное меню флага "Составной тип данных" добавлено два подменю:
    - "Выбрать тип характеристик"  (Рис.14.2, для установки в списке составного типа "Характеристика.ИмяПВХ")
    - "Выбрать определяемый тип"  (Рис.14.3, для установки в списке составного типа "ОпределяемыйТип.ИмяОТ")


Версия 1.0 от 17.02.2016 (Исходная)


Предыстория:

Здоровый консерватизм и врожденное стремление к прекрасному послужили причиной для появления данной разработки. Лично у меня (и думаю, что я не одинок) сравнение диалогов выбора типа в обычном и управляемом приложении всегда вызывает когнитивный диссонанс.

Примером для подражания и отправной точкой для работы послужила форма выбора типа объекта в известной обработке «Администратор 1С». К списку ссылочных типов формы были добавлены примитивные и прочие типы. Также были добавлены квалификаторы данных и режим редактирования составного типа. Общая функциональность и оформление формы были максимально приближены к системному диалогу (насколько это возможно при использовании стандартной библиотеки картинок).

Формы обработки:

  • "DemoОбычное"Основная форма для обычного приложения (Рис.1),
    служит для демонстрации использования альтернативного диалога выбора типа в режиме обычного приложения;
  • "DemoУправляемое" Основная форма для управляемого приложения (Рис.2),
    служит для демонстрации использования альтернативного диалога выбора типа в режиме управляемого приложения; 
  • "EditTypeОбычное" Служебная универсальная форма (Рис.3, Рис.4),
    реализует функционал системного диалога редактирования/выбора типа для обычного приложения;
  • "EditTypeУправляемое":  Служебная универсальная форма (Рис.5, Рис.6),
     реализует функционал системного диалога редактирования/выбора типа для управляемого приложения;


Возможности альтернативных диалогов выбора типа:

1. Формы альтернативных  диалогов максимально полно реализуют функциональность системного диалога редактирования/выбора типа обычного приложения (включая оформление).

2. Диалоги имеют двойной русско-английский интерфейс, инициализируемый программным образом при открытии формы. При разработке форм диалогов устранены некоторые корявости системного диалога и добавлены дополнительные интерфейсные удобства.

3. Формы альтернативных диалогов редактирования/выбора типа полностью самодостаточны и универсальны.  Они могут использоваться как общие формы в составе любой конфигурации, так и в составе форм любого объекта метаданных.

4. Альтернативные диалоги редактирования/выбора типа поддерживают выбор основных типов данных, которые можно хранить в реквизитах объектов или форм и для которых есть штатные средства выбора значений (включая некоторые системные перечисления).

5. Также добавлена возможность (через параметры формы) включать в списке типов диалога показ типа "ДвоичныеДанные" (Рис.3, Рис.4, Рис.5, Рис.6). В настоящий момент эта возможность практической ценности не имеет (этот тип нельзя напрямую хранить в реквизитах объектов и форм). Возможность добавлена ради доступа к квалификаторам двоичных данных, которые появились у объекта "ОписаниеТипов" в платформе версии 8.3.

В диалоге при показе типа  "ДвоичныеДанные" в списке типов диалога, также отображаются некоторые другие типы данных ( Рис.18.5):

  • "ХранилищеЗначения"
  • "УникальныйИдентификатор"
  • "СписокЗначений"

6. Добавлена возможность (через параметры формы) включать в списке типов диалога показ
    типов менеджеров значений констант и типов ключей записей регистров учета
    ( Рис.19.2, Рис.20.2 ):

  • "КонстантаМенеджерЗначения.ИмяКонстанты"
  • "РегистрСведенийКлючЗаписи.ИмяРегистра"
  • "РегистрНакопленияКлючЗаписи.ИмяРегистра"
  • "РегистрБухгалтерииКлючЗаписи.ИмяРегистра"
  • "РегистрРасчетаКлючЗаписи.ИмяРегистра"

7. Формы диалогов могут работать как в режиме редактирования составного типа данных,
    так и в режиме выбора типа текущего значения реквизита (из списка возможных типов,
    определяемых описанием составного типа реквизита).

8. Через параметры формы диалогов полноценно поддерживаются следующие представления списка типов в диалоге:

  • "Таблица значений" (Рис.7, Рис.8, только для управляемой формы диалога);
  • "Одноуровневое дерево значений" (Рис.9, Рис.10);
  • "Многоуровневое дерево значений" (Рис.11, Рис.12, действует по умолчанию);

    Установленное при открытии представление списка типов можно изменить
    из контекстного меню списка ( Рис.19.3, Рис.20.3 ).
    При этом установленное значение представления сохраняется в реквизите формы-владельца диалога
    (если через параметры формы диалога передано имя этого реквизита).

    Также при успешном сохранении выполняется оповещение формы-владельца диалога
    глобальным методом Оповестить() со следующими параметрами:
        ИмяСобытия = "EditType.ТипыВВидеДерева.Смена"
        Параметр     = [выбранное значение представления списка: 0, 1, 2]
        Источник     = [ссылка на форму-владельца диалога]
    Ответственность за дальнейшее сохранение/восстановление выбранного представления списка типов
    возлагается на форму-владельца диалога.

9. Формы диалогов при закрытии с подтверждением возвращают значение типа "ОписаниеТипов", которое соответствует
    отредактированному описанию типа или выбранному типу значения (с учетом квалификаторов данных).

При этом поддерживаются всевозможные режимы выбора значений в формах 1С
(определяется режимом открытия и установкой параметров формы диалога):

  • "Модальный выбор"
  • "Асинхронный выбор (обработка выбора)"
  • "Асинхронный выбор (оповещение о закрытии)"

Примечание:
При использовании режима  "Асинхронный выбор (обработка выбора)" в обработчике события "ОбработкаВыбора"
поля ввода может возникнуть неопределенная ситуация, если в составном типе реквизита использован тип "ОписаниеТипов".

А именно - как интерпретировать значение переменной ВыбранноеЗначение:
- Это выбрано ограничение типа реквизита (в диалоге выбора типа в режиме редактирования составного типа).
- Это выбран тип текущего значения реквизита (в диалоге выбора типа в режиме выбора типа).
- Это в поле ввода просто выбрано текущее значение реквизита типа "ОписаниеТипов".

В демонстрационных формах этой обработки считается:
- Если ВыбранноеЗначение - описание простого типа, то выбран тип текущего значения реквизита.
- Если ВыбранноеЗначение - описание составного типа, то выбрано текущее значение реквизита типа "ОписаниеТипов".


Дополнительные интерфейсные удобства:

  1. Во всех режимах выбора имеется возможность указания заголовка диалога
    отличного от того, что выводится по умолчанию.
  2. В режиме выбора типа значения:
    • Показ квалификаторов примитивных тиров данных (Рис.4, Рис.6) аналогично тому,
      как в режиме редактирования, но только для просмотра
      ;
  3. В режиме редактирования типа:
    • При редактировании составного типа в списке типов доступны для пометки узлы групп типов.
      При изменении пометки группы типов устанавливаются или снимаются метки со всех входящих в группу строк типов.
    • Пометка строки в списке типов для выбора (установки метки) при снятии флага "Составной тип данных" (Рис.13).
      Строка помечается двойным кликом при установленном флаге и выделяется подчеркиванием.
  4. Контекстное меню флага "Составной тип данных" (Рис.14.1, Рис.14.2, Рис.14.3), которое позволяет:
    • а. Отметить все строки в списке типов для выбора;
    • б. Сбросить метки выбора со всех строк списка типов;
    • в. Выбрать один из “предопределенных” составных типов конфигурации:
      • - Тип "ЛюбаяСсылка";
      • - Тип "ВсеСсылки" указанного типа прикладных объектов;
    • г. Выбрать составной тип одного из планов видов характеристик в конфигурации;
      д. Выбрать один из определяемых типов в конфигурации (содержащих только поддерживаемые диалогом типы);
      е. Восстановить исходное значение составного типа (переданное при открытии диалога);
  5. Контекстное меню списка типов диалога (Рис.15), которое позволяет:
    • Включить/выключить режим показа имен типов (объектов) вместо их синонимов
      (запоминаемая настройка диалога, по умолчанию - Истина);
    • Включить/выключить дополнительное оформление списка типов
      (запоминаемая настройка диалога, по умолчанию - Ложь):
      • Группы типов в списке выделяются светло-серым фоном;
      • В режиме редактирования типа (Рис.16):
        Изначально выбранные при открытии типы выделяются жирным шрифтом;
      • В режиме выбора типа (Рис.17):
        Переданное при открытии диалога текущее значение типа выделяется жирным шрифтом;
    • Сменить представление списка типов ( Рис.19.3, Рис.20.3 ):
      • "список", "многоуровневое дерево", "одноуровневое дерево";


Особенности поиска в списке типов в альтернативном диалоге:

В диалоге (начиная с версии 1.2) имеется два режима поиска:

  • Поиск по строке в имени или синониме типа - устанавливается при вводе символов в строке поиска над списком типов (Рис.18.1, Рис.18.4);
  • Показ отмеченных строк списка (с текущей пометкой) - переключается нажатием на гиперссылку картинки справа от строки поиска (Рис.18.3);

Оба режима поиска доступны как при редактировании составного типа (Рис.18.1), так и при выборе текущего типа значения (Рис.18.4).

Поиск по строке в имени или синониме типа реализован на запросе к временной таблице списка типов с условием
на поле поиска ПОДОБНО шаблону поиска. Поле поиска выбирается в соответствии с установленным режимом
показа имен типов (объектов) вместо их синонимов.

При этом шаблон поиска строится по строке поиска следующим образом:

  • В строке поиска слева и справа отсекаются конечные пробелы;
  • Внутренние пробелы заменяются на символы процента "%";
  • Двойные звездочки "**" заменяются на одинарные символы процента "%";
  • Все кратные символы процента "%" заменяются на одинарные;
  • Шаблон поиска дополняется слева и справа символами процента "%";

Специальные сочетания символов в строке поиска (вырезаются из шаблона и модифицируют условия поиска):

  • Символы "^%" в начале строки поиска - отменяют дополнение шаблона поиска слева символом "%" (поиск ПОДОБНО СЛЕВА, Рис.18.4);
  • Символы "^%" в конце строки поиска  - отменяют дополнение шаблона поиска справа символом "%" (поиск ПОДОБНО СПРАВА, Рис.18.6);
  • Символы "[]" ("пустой" диапазон символов) в любой части строки поиска - ограничивает поиск только изначально отмеченными строками списка (Рис.18.2);

Результаты поиска показываются в специальной таблице результатов поиска (в дереве значений).
Строки основного списка типов синхронизуются с таблицей результатов поиска при пометке и активизации его строк.

Быстрые клавиши, связанные с поиском в списке типов (Рис.18.6):

  • Ctrl+Alt+M    - активизировать строку поиска (также, как в системном диалоге);
  • Ctrl+Shift+1  - включить/выключить режим показа только отмеченных строк списка;
  • Ctrl+Shift+2  - очистить результаты поиска;


Использование альтернативных диалогов выбора типа:

  1. Режим редактирования типа требуется сравнительно редко, например, когда в реквизите типа "ОписаниеТипов"
    задается дополнительное ограничение типа другого реквизита составного типа значения.

    Для открытия альтернативного диалога выбора типа в этом случае можно использовать следующие события элементов формы:
    • Событие "НачалоВыбора" поля ввода формы (если описание типов редактируется напрямую);
    • Событие "Нажатие" или процедура обработки команды формы (если описание типов редактируется кнопкой формы);
    • Событие "Выбор" табличного поля формы (если описание типа редактируется при клике
      по строке табличного поля в специально предусмотренной колонке)
      ;
  2. Режим выбора типа значения требуется значительно чаще (при редактировании в полях ввода реквизитов составного типа).

    Для открытия альтернативного диалога выбора типа в режиме выбора типа можно использовать событие "НачалоВыбора"
    поля ввода значения реквизита в форме, когда значение реквизита составного типа равно Неопределено
    (системный диалог выбора типа открывается именно в этом случае).

    Есть также другой удобный способ для программного открытия диалога выбора типа (Рис.1, Рис.2):
    В обработчике события "Очистка" поля ввода
    методами ЭтаФорма.ВыбратьИзСписка() или ЭтаФорма.ПоказатьВыборИзСписка()
    выводить меню в виде выпадающего списка,
    в котором  предлагать пользователю следующие возможности:
    • "Выбрать тип значения" (выбрать текущий тип в альтернативном диалоге выбора);
    • “Пустое значение” (установить реквизиту пустое значение текущего типа, если тип простой);
    • "Очистить" (присвоить реквизиту значение Неопределено);
       
  3. Примеры использования альтернативных диалогов выбора типа смотрите ниже в приложениях к работе,
    а также в исходном коде демонстрационных форм обработки.


Ограничения обратной совместимости:

  •  Под платформой 8.2 все формы этой обработки будут нормально работать в толстом и тонком клиентах.
     
  • При работе на Web-клиенте под 8.2 будет ошибка компиляции модуля формы "EditTypeУправляемое"
    из-за "открытого" использования  глобального асинхронного метода
    ПоказатьПредупреждение() ,
    появившегося только под платформой 8.3.

    Проблема решается закомментариванием строки с вызовом этого метода на стороне Web-клиенте,
    специально выделенной для этой цели инструкцией препроцессора.
     
  • Под платформой 8.3.7 и выше  в форме "EditTypeУправляемое"
    при изменении представления списка типов с многоуровневого на одноуровневый и наоборот,
    а также при включении/отключении режима показа только отмеченных строк в списке,
    наблюдается неприятный визуальный эффект:

    форма диалога "самостоятельно" увеличивает размер по вертикали и горизонтали.
     

Приложение 1 (Пример кода использования диалога в режиме обычного приложения):

Пояснения к примеру:
Объект – основной реквизит обработки;
ТестРеквизит – реквизит обработки составного типа (непосредственно редактируется в форме);
ТестРеквизитТип – дополнительное ограничение типа реквизита ТестРеквизит (непосредственно редактируется в форме);
Смысл остальных реквизитов ясен из их названия, пример ориентирован на платформу 8.3

// На клиенте обычного приложения
Процедура ТестРеквизитНачалоВыбора(Элемент, СтандартнаяОбработка)
    Перем
Оповещение;
    Перем
ПараметрыВыбора;

    Если
ТипЗнч(Объект.ТестРеквизит) = Тип("ОписаниеТипов") И Объект.СистемныйДиалог <> Истина Тогда
       
// выбираем значение описания типа в нашем красивом диалоге
       
СтандартнаяОбработка = Ложь;
       
ПараметрыВыбора = Новый Структура("Элемент,ЭтоРедактированиеТипаДанных",Элемент,Истина);
       
ТипОО = ТипIf("ОписаниеОповещения");

       
стПараметры = Новый Структура;
       
стПараметры.Вставить("ЗаголовокДиалога","");
       
стПараметры.Вставить("РежимВыбораТипаДанных",Ложь);
       
стПараметры.Вставить("ТипыВВидеДерева",Объект.ТипыВВидеДерева);
       
стПараметры.Вставить("ТипыВВидеДереваИмяРеквизита","Объект.ТипыВВидеДерева");
       
стПараметры.Вставить("ПоказыватьТипBD",Объект.ПоказыватьТипBD);
       
стПараметры.Вставить("ПоказыватьКонстанты",Объект.ПоказыватьКонстанты);
       
стПараметры.Вставить("ПоказыватьОтчетыОбработки",Объект.ПоказыватьОтчетыОбработки);
       
стПараметры.Вставить("ПоказыватьРегистры",Объект.ПоказыватьРегистры);
       
стПараметры.Вставить("КраткиеИменаГруппТипов",Объект.КраткиеИменаГруппТипов);
       
стПараметры.Вставить("ТипЗначения",Объект.ТестРеквизит);
       
стПараметры.Вставить("ТекущийТип",Неопределено);

        Если
Объект.РежимВыбораТипа = "МодальныйВыбор" Тогда
           
Диалог = ПолучитьФорму(ПутьКФорме+"EditTypeОбычное");
           
Диалог.ФормаВладелец = ЭтаФорма;
           
Диалог.ОписаниеОповещенияОЗакрытии = Неопределено;
           
Диалог.Параметры = стПараметры;;
           
ВыбранноеЗначение = Диалог.ОткрытьМодально(180);
            Если
ВыбранноеЗначение <> Неопределено Тогда
               
ТестРеквизитПриВыбореЗначения(ВыбранноеЗначение,ПараметрыВыбора);
            КонецЕсли;
        ИначеЕсли
Объект.РежимВыбораТипа = "ОбработкаВыбора" Тогда
           
Диалог = ПолучитьФорму(ПутьКФорме+"EditTypeОбычное",Элемент,ЭтаФорма);
           
Диалог.ФормаВладелец = ЭтаФорма;
           
Диалог.ОписаниеОповещенияОЗакрытии = Неопределено;
           
Диалог.Параметры = стПараметры;;
           
Диалог.Открыть();
        ИначеЕсли
Объект.РежимВыбораТипа = "ОповещениеОЗакрытии" И ТипОО <> Null Тогда
           
мсПараметры = Новый Массив;
           
мсПараметры.Добавить("ТестРеквизитПриВыбореЗначения");
           
мсПараметры.Добавить(ЭтаФорма);
           
мсПараметры.Добавить(ПараметрыВыбора);
           
Оповещение = Новый(ТипОО,мсПараметры);
           
Диалог = ПолучитьФорму(ПутьКФорме+"EditTypeОбычное",Неопределено,ЭтаФорма);
           
Диалог.ФормаВладелец = ЭтаФорма;
           
Диалог.ОписаниеОповещенияОЗакрытии = Оповещение;
           
Диалог.Параметры = стПараметры;;
           
Диалог.Открыть();
        КонецЕсли;
    ИначеЕсли
Объект.ТестРеквизит = Неопределено И Объект.СистемныйДиалог <> Истина Тогда
       
// по нажатию кнопки выбора типа - выбираем тип значения в поле ввода в нашем красивом диалоге
       
СтандартнаяОбработка = Ложь;
       
ТестРеквизитВыбратьТип(Элемент,Объект.ТестРеквизит,Объект.ТестРеквизитТип,Ложь);
    Иначе
    КонецЕсли;

КонецПроцедуры

Процедура
ТестРеквизитОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    Если
ТипЗнч(ВыбранноеЗначение) = Тип("ОписаниеТипов") И Объект.РежимВыбораТипа = "ОбработкаВыбора"
   
И ВыбранноеЗначение.Типы().Количество() = 1 Тогда
       
// из формы выбора прилетело значение "ОписаниеТипов" простого типа -
        // - считаем, что в диалоге выбора типа выбран текущий тип значения реквизита
       
СтандартнаяОбработка = Ложь;
       
ПараметрыВыбора = Новый Структура("Элемент,ЭтоРедактированиеТипаДанных",Элемент,Ложь);
       
ТестРеквизитПриВыбореТипаЗначения(ВыбранноеЗначение,ПараметрыВыбора);
    Иначе
       
// из формы выбора прилетело значение, отличное от "ОписаниеТипов" простого типа -
        // - считаем, что в форме выбора выбрано значение реквизита
       
СтандартнаяОбработка = Истина;
    КонецЕсли;
КонецПроцедуры

Процедура
ТестРеквизитОчистка(Элемент, СтандартнаяОбработка)
    Перем
Оповещение;
    Перем
ПараметрыОповещения;
   
СтандартнаяОбработка = Ложь;
   
ТипОО = ТипIf("ОписаниеОповещения");
   
ПараметрыОповещения = Новый Структура("Элемент",Элемент);
   
Меню = Новый СписокЗначений;
   
Меню.Добавить(1, НСтр("ru = 'Выбрать тип значения'; en = 'Select data type'"),,БиблиотекаКартинок.ВыбратьТип);
    Если (
Объект.ТестРеквизитТип.Типы().Количество()=1) Тогда
       
Меню.Добавить(2, НСтр("ru = 'Пустое значение'; en = 'Empty value'"),,БиблиотекаКартинок.Выбрать);
    КонецЕсли;
   
Выбор0 = Меню.Добавить(0, НСтр("ru = 'Очистить'; en = 'Clear'"),,БиблиотекаКартинок.Очистить);
    Если
Объект.РежимВыбораТипа <> "МодальныйВыбор" И ТипЗнч(ЭтаФорма) = ТипIf("УправляемаяФорма") И ТипОО <> Null Тогда
       
мсПараметры = Новый Массив;
       
мсПараметры.Добавить("ТестРеквизитОчисткаПродолжение");
       
мсПараметры.Добавить(ЭтаФорма);
       
мсПараметры.Добавить(ПараметрыОповещения);
       
Оповещение = Новый(ТипОО,мсПараметры);
       
ЭтаФорма.ПоказатьВыборИзСписка(Оповещение,Меню,Элемент,Выбор0);
    Иначе
       
Выбор = ЭтаФорма.ВыбратьИзСписка(Меню,Элемент,Выбор0);
       
ТестРеквизитОчисткаПродолжение(Выбор, ПараметрыОповещения);
    КонецЕсли;
КонецПроцедуры

Процедура
ТестРеквизитОчисткаПродолжение(Выбор, ПараметрыОповещения) Экспорт
    Перем
Элемент;
    Если
Выбор = Неопределено Тогда
        Возврат;
    КонецЕсли;
    Если
ТипЗнч(ПараметрыОповещения) = Тип("Структура") Тогда
       
ПараметрыОповещения.Свойство("Элемент",Элемент);
    КонецЕсли;
    Если
Выбор.Значение = 0 Тогда
       
Объект.ТестРеквизит = Неопределено;
       
ТестРеквизитПриИзменении(Элемент);
    ИначеЕсли
Выбор.Значение = 2 Тогда
       
Объект.ТестРеквизит = Объект.ТестРеквизитТип.ПривестиЗначение(Неопределено);
       
ТестРеквизитПриИзменении(Элемент);
    ИначеЕсли
Выбор.Значение = 1 Тогда
       
ТестРеквизитВыбратьТип(Элемент,Объект.ТестРеквизит,Объект.ТестРеквизитТип,Ложь);
    КонецЕсли;
КонецПроцедуры

Процедура
ТестРеквизитВыбратьТип(Элемент,Значение,ТипЗначения,ЭтоРедактированиеТипаДанных)
    Перем
Оповещение;
    Перем
ПараметрыВыбора;

   
ПараметрыВыбора = Новый Структура("Элемент,ЭтоРедактированиеТипаДанных",Элемент,ЭтоРедактированиеТипаДанных);
   
ТипОО = ТипIf("ОписаниеОповещения");
    Если
ТипЗнч(ТипЗначения.ПривестиЗначение(Значение)) = ТипЗнч(Значение) Тогда
       
ТекущийТип = ТипЗнч(Значение);
    Иначе
// для простых типов "двоичные данные", "хранилище значения" и "ключ записи регистра учета"
          // - результат приведения значения почему-то строковое значение
       
ТекущийТип = ТипЗнч(Неопределено);
    КонецЕсли;

   
// установка параметров диалога
   
стПараметры = Новый Структура;
   
// 1. Заголовок диалога редактирования/выбора типа
    //    по умолчанию: "Редактирование типа данных"/"Выбор типа данных"
   
стПараметры.Вставить("ЗаголовокДиалога","");
   
// 2. Режим работы диалога редактирования/выбора типа (обязателен!)
   
стПараметры.Вставить("РежимВыбораТипаДанных",(ЭтоРедактированиеТипаДанных <> Истина));
   
// 3. Представление списка типов в диалоге (по умолчанию - многоуровневое "ДеревоЗначений")
   
стПараметры.Вставить("ТипыВВидеДерева",Объект.ТипыВВидеДерева);
   
// 4. Путь в данных формы для сохранения измененного в диалоге представления списка типов
   
стПараметры.Вставить("ТипыВВидеДереваИмяРеквизита","Объект.ТипыВВидеДерева");
   
// 5. Признак показа в диалоге дополнительных типов "ДвоичныеДанные", "СписокЗначений" и т.п.
    //    (параметр добавлен для доступа к квалификаторам двоичных данных)
   
стПараметры.Вставить("ПоказыватьТипBD",Объект.ПоказыватьТипBD);
   
// 6. Признак показа в диалоге типов менелжеров записи значений констант
    //    (недоступно на клиенте в управляемом приложения!)
   
стПараметры.Вставить("ПоказыватьКонстанты",Объект.ПоказыватьКонстанты);
   
// 7. Признак показа в диалоге типов объектов отчетов и обработок
    //    (недоступно на клиенте в управляемом приложения!)
   
стПараметры.Вставить("ПоказыватьОтчетыОбработки",Объект.ПоказыватьОтчетыОбработки);
   
// 8. Признак показа в диалоге типов ключей записей регистров учета
   
стПараметры.Вставить("ПоказыватьРегистры",Объект.ПоказыватьРегистры);
   
// 9. Признак показа кратких имен групп ссылочных типов данных
    //    (например, "Справочник" вместо "СправочникСсылка")
   
стПараметры.Вставить("КраткиеИменаГруппТипов",Объект.КраткиеИменаГруппТипов);
   
//10. Составной тип данных для редактирования или для выбора текущего типа значения реквизита
    //    (обязателен!)
   
стПараметры.Вставить("ТипЗначения",ТипЗначения);
   
//11. Тип, определяющий текущую строку в списке типов при открытии
    //    (в режиме редактирования типа можно не указывать)
   
стПараметры.Вставить("ТекущийТип",ТекущийТип);

    Если
Объект.РежимВыбораТипа = "МодальныйВыбор" Тогда
       
Диалог = ПолучитьФорму(ПутьКФорме+"EditTypeОбычное");
       
//12. Параметр для имитации блокировки окна владельца диалога
       
Диалог.ФормаВладелец = ЭтаФорма;
       
//13. Параметр для имитации оповещения о закрытии диалога
       
Диалог.ОписаниеОповещенияОЗакрытии = Неопределено;
       
Диалог.Параметры = стПараметры;;
       
ВыбранноеЗначение = Диалог.ОткрытьМодально(180);
       
ТестРеквизитПриВыбореТипаЗначения(ВыбранноеЗначение,ПараметрыВыбора);
    ИначеЕсли
Объект.РежимВыбораТипа = "ОбработкаВыбора" Тогда
       
Диалог = ПолучитьФорму(ПутьКФорме+"EditTypeОбычное",Элемент,ЭтаФорма);
       
//12. Параметр для имитации блокировки окна владельца диалога
       
Диалог.ФормаВладелец = ЭтаФорма;
       
//13. Параметр для имитации оповещения о закрытии диалога
       
Диалог.Параметры = стПараметры;;
       
Диалог.Открыть();
    ИначеЕсли
Объект.РежимВыбораТипа = "ОповещениеОЗакрытии" И ТипОО <> Null Тогда
       
мсПараметры = Новый Массив;
       
мсПараметры.Добавить("ТестРеквизитПриВыбореТипаЗначения");
       
мсПараметры.Добавить(ЭтаФорма);
       
мсПараметры.Добавить(ПараметрыВыбора);
       
Оповещение = Новый(ТипОО,мсПараметры);
       
Диалог = ПолучитьФорму(ПутьКФорме+"EditTypeОбычное",Неопределено,ЭтаФорма);
       
//12. Параметр для имитации блокировки окна владельца диалога
       
Диалог.ФормаВладелец = ЭтаФорма;
       
//12. Параметр для имитации оповещения о закрытии диалога
       
Диалог.ОписаниеОповещенияОЗакрытии = Оповещение;
       
Диалог.Параметры = стПараметры;;
       
Диалог.Открыть();
    КонецЕсли;

КонецПроцедуры

Процедура
ТестРеквизитПриВыбореТипаЗначения(ВыбранноеЗначение,ПараметрыВыбора) Экспорт
    Перем
Элемент;
    Перем
ЭтоРедактированиеТипаДанных;
    Если
ТипЗнч(ПараметрыВыбора) = Тип("Структура") Тогда
       
ПараметрыВыбора.Свойство("Элемент",Элемент);
       
ПараметрыВыбора.Свойство("ЭтоРедактированиеТипаДанных",ЭтоРедактированиеТипаДанных);
    КонецЕсли;
    Если
ТипЗнч(ВыбранноеЗначение) <> Тип("ОписаниеТипов") Тогда
        Возврат;
    КонецЕсли;
    Если
ЭтоРедактированиеТипаДанных = Истина Тогда
       
Объект.ТестРеквизитТип = ВыбранноеЗначение;
    КонецЕсли;
   
Объект.ТестРеквизит = ВыбранноеЗначение.ПривестиЗначение(Объект.ТестРеквизит);
   
ТестРеквизитПриИзменении(ЭлементыФормы.ТестРеквизит);
КонецПроцедуры

Процедура
ТестРеквизитПриВыбореЗначения(ВыбранноеЗначение,ПараметрыВыбора) Экспорт
    Перем
Элемент;
    Перем
ЭтоРедактированиеТипаДанных;
    Если
ТипЗнч(ПараметрыВыбора) = Тип("Структура") Тогда
       
ПараметрыВыбора.Свойство("Элемент",Элемент);
       
ПараметрыВыбора.Свойство("ЭтоРедактированиеТипаДанных",ЭтоРедактированиеТипаДанных);
    КонецЕсли;
   
Объект.ТестРеквизит = ВыбранноеЗначение;
   
ТестРеквизитПриИзменении(ЭлементыФормы.ТестРеквизит);
КонецПроцедуры

Процедура
ТестРеквизитПриИзменении(Элемент)
   
ПолеФормыКонтрольТипЗначения(Элемент,Объект.ТестРеквизитТип,Объект.ТестРеквизит);
КонецПроцедуры

Процедура
ПолеФормыКонтрольТипЗначения(Элемент,ТипЗначения,Значение)
   
СтрФорматЧ = "";
   
ПЧ = Неопределено;
    Если
ТипЗначения.СодержитТип(Тип("Число")) Тогда
       
ДЛ = ТипЗначения.КвалификаторыЧисла.Разрядность;
       
ТЧ = ТипЗначения.КвалификаторыЧисла.РазрядностьДробнойЧасти;
       
ПЧ = (ТипЗначения.КвалификаторыЧисла.ДопустимыйЗнак = ДопустимыйЗнак.Неотрицательный);
       
СтрФорматЧ = "ЧЦ="+Формат(ДЛ,"ЧДЦ=; ЧН=; ЧГ=0")+"; ЧДЦ="+Формат(ТЧ,"ЧДЦ=; ЧН=; ЧГ=0");
    КонецЕсли;
   
СтрФорматД = "";
    Если
ТипЗначения.СодержитТип(Тип("Дата")) Тогда
       
ТЧ = ТипЗначения.КвалификаторыДаты.ЧастиДаты;
        Если
ТЧ = ЧастиДаты.Дата Тогда
           
СтрФорматД = "ДЛФ=D";
        ИначеЕсли
ТЧ = ЧастиДаты.Время Тогда
           
СтрФорматД = "ДЛФ=T";
        КонецЕсли;
    КонецЕсли;
   
СтрФормат = СтрФорматЧ +
    ?(
ЗначениеЗаполнено(СтрФорматЧ) И ЗначениеЗаполнено(СтрФорматД),"; ","") + СтрФорматД;
    Попытка
       
Элемент.Формат = СтрФормат;
    Исключение
    КонецПопытки;
    Если
ТипЗнч(Значение) = Тип("Число") И ПЧ = Истина И Значение < 0 Тогда
       
// контроль положительности числа по ограничениям в типе данных
       
Значение = -Значение;
    КонецЕсли;
    Если
ТипЗнч(Значение) = Тип("Число") ИЛИ ТипЗнч(Значение) = Тип("Строка")
    ИЛИ
ТипЗнч(Значение) = Тип("Дата")   ИЛИ ТипЗнч(Значение) = Тип("ДвоичныеДанные") Тогда
       
// контроль длины и точности значения по ограничениям в типе данных
       
Значение = ТипЗначения.ПривестиЗначение(Значение);
    КонецЕсли;
   
Элемент.ВыбиратьТип = (Значение = Неопределено);
КонецПроцедуры

 

Приложение 2 (пример кода использования диалога в режиме управляемого приложения):

Пояснения к примеру:
Объект – основной реквизит обработки;
ТестРеквизит – реквизит обработки составного типа (непосредственно редактируется в форме);
ТестРеквизитТип – дополнительное ограничение типа реквизита ТестРеквизит (непосредственно редактируется в форме);
Смысл остальных реквизитов ясен из их названия, пример ориентирован на платформу 8.3.

// На клиенте управляемого приложения
&НаКлиенте
Процедура ТестРеквизитНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    Перем
Оповещение;
    Перем
ПараметрыВыбора;

    Если
ТипЗнч(Объект.ТестРеквизит) = Тип("ОписаниеТипов") И Объект.СистемныйДиалог <> Истина Тогда
       
// выбираем значение описания типа в нашем красивом диалоге
       
СтандартнаяОбработка = Ложь;
       
ПараметрыВыбора = Новый Структура("Элемент,ЭтоРедактированиеТипаДанных",Элемент,Истина);
       
ТипОО = ТипIf("ОписаниеОповещения");

       
стПараметры = Новый Структура;
       
стПараметры.Вставить("ЗаголовокДиалога","");
       
стПараметры.Вставить("РежимВыбораТипаДанных",Ложь);
       
стПараметры.Вставить("ТипыВВидеДерева",Объект.ТипыВВидеДерева);
       
стПараметры.Вставить("ТипыВВидеДереваИмяРеквизита","Объект.ТипыВВидеДерева");
       
стПараметры.Вставить("ПоказыватьТипBD",Объект.ПоказыватьТипBD);
       
стПараметры.Вставить("ПоказыватьКонстанты",Объект.ПоказыватьКонстанты);
       
стПараметры.Вставить("ПоказыватьОтчетыОбработки",Объект.ПоказыватьОтчетыОбработки);
       
стПараметры.Вставить("ПоказыватьРегистры",Объект.ПоказыватьРегистры);
       
стПараметры.Вставить("КраткиеИменаГруппТипов",Объект.КраткиеИменаГруппТипов);
       
стПараметры.Вставить("ТипЗначения",Объект.ТестРеквизит);
       
стПараметры.Вставить("ТекущийТип",Неопределено);

        Если
Объект.РежимВыбораТипа = "МодальныйВыбор" Тогда
           
ВыбранноеЗначение = ОткрытьФормуМодально(ПутьКФорме+"EditTypeУправляемое",стПараметры);
            Если
ВыбранноеЗначение <> Неопределено Тогда
               
ТестРеквизитПриВыбореЗначения(ВыбранноеЗначение,ПараметрыВыбора);
            КонецЕсли;
        ИначеЕсли
Объект.РежимВыбораТипа = "ОбработкаВыбора" Тогда
           
ОткрытьФорму(ПутьКФорме+"EditTypeУправляемое",стПараметры,Элемент,ЭтаФорма);
        ИначеЕсли
Объект.РежимВыбораТипа = "ОповещениеОЗакрытии" И ТипОО <> Null Тогда
           
мсПараметры = Новый Массив;
           
мсПараметры.Добавить("ТестРеквизитПриВыбореЗначения");
           
мсПараметры.Добавить(ЭтаФорма);
           
мсПараметры.Добавить(ПараметрыВыбора);
           
Оповещение = Новый(ТипОО,мсПараметры);
           
#Если ВебКлиент Тогда
               
Диалог = Вычислить("ОткрытьФорму(ПутьКФорме+""EditTypeУправляемое"",стПараметры,Неопределено,ЭтаФорма,,,Оповещение)");
           
#Иначе
               
Выполнить("ОткрытьФорму(ПутьКФорме+""EditTypeУправляемое"",стПараметры,Неопределено,ЭтаФорма,,,Оповещение)");
           
#КонецЕсли
       
КонецЕсли;
    ИначеЕсли
Объект.ТестРеквизит = Неопределено И Объект.СистемныйДиалог <> Истина Тогда
       
// при выборе типа - выбираем тип значения в поле ввода в нашем красивом диалоге
       
СтандартнаяОбработка = Ложь;
       
ТестРеквизитВыбратьТип(Элемент,Объект.ТестРеквизит,Объект.ТестРеквизитТип,Ложь);
    Иначе
    КонецЕсли;

КонецПроцедуры


&НаКлиенте
Процедура ТестРеквизитОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    Если
ТипЗнч(ВыбранноеЗначение) = Тип("ОписаниеТипов") И Объект.РежимВыбораТипа = "ОбработкаВыбора"
   
И ВыбранноеЗначение.Типы().Количество() = 1 Тогда
       
// из формы выбора прилетело значение "ОписаниеТипов" простого типа -
        // - считаем, что в диалоге выбора типа выбран текущий тип значения реквизита
       
СтандартнаяОбработка = Ложь;
       
ПараметрыВыбора = Новый Структура("Элемент,ЭтоРедактированиеТипаДанных",Элемент,Ложь);
       
ТестРеквизитПриВыбореТипаЗначения(ВыбранноеЗначение,ПараметрыВыбора);
    Иначе
       
// из формы выбора прилетело значение, отличное от "ОписаниеТипов" простого типа -
        // - считаем, что в форме выбора выбрано значение реквизита
       
СтандартнаяОбработка = Истина;
    КонецЕсли;
КонецПроцедуры


&НаКлиенте
Процедура ТестРеквизитОчистка(Элемент, СтандартнаяОбработка)
    Перем
Оповещение;
    Перем
ПараметрыОповещения;
   
СтандартнаяОбработка = Ложь;
   
ТипОО = ТипIf("ОписаниеОповещения");
   
ПараметрыОповещения = Новый Структура("Элемент",Элемент);
   
Меню = Новый СписокЗначений;
   
Меню.Добавить(1, НСтр("ru = 'Выбрать тип значения'; en = 'Select data type'"),,БиблиотекаКартинок.ВыбратьТип);
    Если (
Объект.ТестРеквизитТип.Типы().Количество()=1) Тогда
       
Меню.Добавить(2, НСтр("ru = 'Пустое значение'; en = 'Empty value'"),,БиблиотекаКартинок.Выбрать);
    КонецЕсли;
   
Выбор0 = Меню.Добавить(0, НСтр("ru = 'Очистить'; en = 'Clear'"),,БиблиотекаКартинок.Очистить);
    Если
Объект.РежимВыбораТипа <> "МодальныйВыбор" И ТипЗнч(ЭтаФорма) = ТипIf("УправляемаяФорма") И ТипОО <> Null Тогда
       
мсПараметры = Новый Массив;
       
мсПараметры.Добавить("ТестРеквизитОчисткаПродолжение");
       
мсПараметры.Добавить(ЭтаФорма);
       
мсПараметры.Добавить(ПараметрыОповещения);
       
Оповещение = Новый(ТипОО,мсПараметры);
       
ЭтаФорма.ПоказатьВыборИзСписка(Оповещение,Меню,Элемент,Выбор0);
    Иначе
       
Выбор = ЭтаФорма.ВыбратьИзСписка(Меню,Элемент,Выбор0);
       
ТестРеквизитОчисткаПродолжение(Выбор, ПараметрыОповещения);
    КонецЕсли;
КонецПроцедуры


&НаКлиенте
Процедура ТестРеквизитОчисткаПродолжение(Выбор, ПараметрыОповещения) Экспорт
    Перем
Элемент;
    Если
Выбор = Неопределено Тогда
        Возврат;
    КонецЕсли;
    Если
ТипЗнч(ПараметрыОповещения) = Тип("Структура") Тогда
       
ПараметрыОповещения.Свойство("Элемент",Элемент);
    КонецЕсли;
    Если
Выбор.Значение = 0 Тогда
       
Объект.ТестРеквизит = Неопределено;
       
ТестРеквизитПриИзменении(Элемент);
    ИначеЕсли
Выбор.Значение = 2 Тогда
       
Объект.ТестРеквизит = Объект.ТестРеквизитТип.ПривестиЗначение(Неопределено);
       
ТестРеквизитПриИзменении(Элемент);
    ИначеЕсли
Выбор.Значение = 1 Тогда
       
ТестРеквизитВыбратьТип(Элемент,Объект.ТестРеквизит,Объект.ТестРеквизитТип,Ложь);
    КонецЕсли;
КонецПроцедуры


&НаКлиенте
Процедура ТестРеквизитВыбратьТип(Элемент,Значение,ТипЗначения,ЭтоРедактированиеТипаДанных)
    Перем
Оповещение;
    Перем
ПараметрыВыбора;

   
ПараметрыВыбора = Новый Структура("Элемент,ЭтоРедактированиеТипаДанных",Элемент,ЭтоРедактированиеТипаДанных);
   
ТипОО = ТипIf("ОписаниеОповещения");
    Если
ТипЗнч(ТипЗначения.ПривестиЗначение(Значение)) = ТипЗнч(Значение) Тогда
       
ТекущийТип = ТипЗнч(Значение);
    Иначе
// для простых типов "двоичные данные", "хранилище значения" и "ключ записи регистра учета"
          // - результат приведения значения почему-то строковое значение
       
ТекущийТип = ТипЗнч(Неопределено);
    КонецЕсли;

   
// установка параметров диалога
   
стПараметры = Новый Структура;
   
// 1. Заголовок диалога редактирования/выбора типа
    //    по умолчанию: "Редактирование типа данных"/"Выбор типа данных"
   
стПараметры.Вставить("ЗаголовокДиалога","");
   
// 2. Режим работы диалога редактирования/выбора типа (обязателен!)
   
стПараметры.Вставить("РежимВыбораТипаДанных",(ЭтоРедактированиеТипаДанных <> Истина));
   
// 3. Представление списка типов в диалоге (по умолчанию - многоуровневое "ДеревоЗначений")
   
стПараметры.Вставить("ТипыВВидеДерева",Объект.ТипыВВидеДерева);
   
// 4. Путь в данных формы для сохранения измененного в диалоге представления списка типов
   
стПараметры.Вставить("ТипыВВидеДереваИмяРеквизита","Объект.ТипыВВидеДерева");
   
// 5. Признак показа в диалоге дополнительных типов "ДвоичныеДанные", "СписокЗначений" и т.п.
    //    (параметр добавлен для доступа к квалификаторам двоичных данных)
   
стПараметры.Вставить("ПоказыватьТипBD",Объект.ПоказыватьТипBD);
   
// 6. Признак показа в диалоге типов менелжеров записи значений констант
    //    (недоступно на клиенте в управляемом приложения!)
   
стПараметры.Вставить("ПоказыватьКонстанты",Объект.ПоказыватьКонстанты);
   
// 7. Признак показа в диалоге типов объектов отчетов и обработок
    //    (недоступно на клиенте в управляемом приложения!)
   
стПараметры.Вставить("ПоказыватьОтчетыОбработки",Объект.ПоказыватьОтчетыОбработки);
   
// 8. Признак показа в диалоге типов ключей записей регистров учета
   
стПараметры.Вставить("ПоказыватьРегистры",Объект.ПоказыватьРегистры);
   
// 9. Признак показа кратких имен групп ссылочных типов данных
    //    (например, "Справочник" вместо "СправочникСсылка")
   
стПараметры.Вставить("КраткиеИменаГруппТипов",Объект.КраткиеИменаГруппТипов);
   
//10. Составной тип данных для редактирования или для выбора текущего типа значения реквизита
    //    (обязателен!)
   
стПараметры.Вставить("ТипЗначения",ТипЗначения);
   
//11. Тип, определяющий текущую строку в списке типов при открытии
    //    (в режиме редактирования типа можно не указывать)
   
стПараметры.Вставить("ТекущийТип",ТекущийТип);

    Если
Объект.РежимВыбораТипа = "МодальныйВыбор" Тогда
       
ВыбранноеЗначение = ОткрытьФормуМодально(ПутьКФорме+"EditTypeУправляемое",стПараметры);
       
ТестРеквизитПриВыбореТипаЗначения(ВыбранноеЗначение,ПараметрыВыбора);
    ИначеЕсли
Объект.РежимВыбораТипа = "ОбработкаВыбора" Тогда
       
ОткрытьФорму(ПутьКФорме+"EditTypeУправляемое",стПараметры,Элемент,ЭтаФорма);
    ИначеЕсли
Объект.РежимВыбораТипа = "ОповещениеОЗакрытии" И ТипОО <> Null Тогда
       
мсПараметры = Новый Массив;
       
мсПараметры.Добавить("ТестРеквизитПриВыбореТипаЗначения");
       
мсПараметры.Добавить(ЭтаФорма);
       
мсПараметры.Добавить(ПараметрыВыбора);
       
Оповещение = Новый(ТипОО,мсПараметры);
       
#Если ВебКлиент Тогда
           
Диалог = Вычислить("ОткрытьФорму(ПутьКФорме+""EditTypeУправляемое"",стПараметры,Неопределено,ЭтаФорма,,,Оповещение)");
       
#Иначе
           
Выполнить("ОткрытьФорму(ПутьКФорме+""EditTypeУправляемое"",стПараметры,Неопределено,ЭтаФорма,,,Оповещение)");
       
#КонецЕсли
   
КонецЕсли;
КонецПроцедуры


&НаКлиенте
Процедура ТестРеквизитПриВыбореТипаЗначения(ВыбранноеЗначение,ПараметрыВыбора) Экспорт
    Перем
Элемент;
    Перем
ЭтоРедактированиеТипаДанных;
    Если
ТипЗнч(ПараметрыВыбора) = Тип("Структура") Тогда
       
ПараметрыВыбора.Свойство("Элемент",Элемент);
       
ПараметрыВыбора.Свойство("ЭтоРедактированиеТипаДанных",ЭтоРедактированиеТипаДанных);
    КонецЕсли;
    Если
ТипЗнч(ВыбранноеЗначение) <> Тип("ОписаниеТипов") Тогда
        Возврат;
    КонецЕсли;
    Если
ЭтоРедактированиеТипаДанных = Истина Тогда
       
Объект.ТестРеквизитТип = ВыбранноеЗначение;
    КонецЕсли;
   
Объект.ТестРеквизит = ВыбранноеЗначение.ПривестиЗначение(Объект.ТестРеквизит);
   
ТестРеквизитПриИзменении(Элементы.ТестРеквизит);
КонецПроцедуры


&НаКлиенте
Процедура ТестРеквизитПриВыбореЗначения(ВыбранноеЗначение,ПараметрыВыбора) Экспорт
    Перем
Элемент;
    Перем
ЭтоРедактированиеТипаДанных;
    Если
ТипЗнч(ПараметрыВыбора) = Тип("Структура") Тогда
       
ПараметрыВыбора.Свойство("Элемент",Элемент);
       
ПараметрыВыбора.Свойство("ЭтоРедактированиеТипаДанных",ЭтоРедактированиеТипаДанных);
    КонецЕсли;
   
Объект.ТестРеквизит = ВыбранноеЗначение;
   
ТестРеквизитПриИзменении(Элемент);
КонецПроцедуры


&НаКлиенте
Процедура ТестРеквизитПриИзменении(Элемент)
   
ПолеФормыКонтрольТипЗначения(Элемент,Объект.ТестРеквизитТип,Объект.ТестРеквизит);
КонецПроцедуры


&НаКлиенте
Процедура ПолеФормыКонтрольТипЗначения(Элемент,ТипЗначения,Значение)
   
СтрФорматЧ = "";
   
ПЧ = Неопределено;
    Если
ТипЗначения.СодержитТип(Тип("Число")) Тогда
       
ДЛ = ТипЗначения.КвалификаторыЧисла.Разрядность;
       
ТЧ = ТипЗначения.КвалификаторыЧисла.РазрядностьДробнойЧасти;
       
ПЧ = (ТипЗначения.КвалификаторыЧисла.ДопустимыйЗнак = ДопустимыйЗнак.Неотрицательный);
       
СтрФорматЧ = "ЧЦ="+Формат(ДЛ,"ЧДЦ=; ЧН=; ЧГ=0")+"; ЧДЦ="+Формат(ТЧ,"ЧДЦ=; ЧН=; ЧГ=0");
    КонецЕсли;
   
СтрФорматД = "";
    Если
ТипЗначения.СодержитТип(Тип("Дата")) Тогда
       
ТЧ = ТипЗначения.КвалификаторыДаты.ЧастиДаты;
        Если
ТЧ = ЧастиДаты.Дата Тогда
           
СтрФорматД = "ДЛФ=D";
        ИначеЕсли
ТЧ = ЧастиДаты.Время Тогда
           
СтрФорматД = "ДЛФ=T";
        КонецЕсли;
    КонецЕсли;
   
СтрФормат = СтрФорматЧ +
    ?(
ЗначениеЗаполнено(СтрФорматЧ) И ЗначениеЗаполнено(СтрФорматД),"; ","") + СтрФорматД;
    Попытка
       
Элемент.Формат = СтрФормат;
    Исключение
    КонецПопытки;
    Попытка
       
Элемент.ФорматРедактирования = СтрФормат;
    Исключение
    КонецПопытки;
    Если
ТипЗнч(Значение) = Тип("Число") И ПЧ = Истина И Значение < 0 Тогда
       
// контроль положительности числа по ограничениям в типе данных
       
Значение = -Значение;
    КонецЕсли;
    Если
ТипЗнч(Значение) = Тип("Число") ИЛИ ТипЗнч(Значение) = Тип("Строка")
    ИЛИ
ТипЗнч(Значение) = Тип("Дата")   ИЛИ ТипЗнч(Значение) = Тип("ДвоичныеДанные") Тогда
       
// контроль длины и точности значения по ограничениям в типе данных
       
Значение = ТипЗначения.ПривестиЗначение(Значение);
    КонецЕсли;
   
Элемент.ВыбиратьТип = (Значение = Неопределено);
КонецПроцедуры

 

Актуальные версии обработки:

Наименование Файл Версия Размер
EditType83(1.3)

.epf 189,38Kb
16.01.18
13
.epf 8.3.1.3 189,38Kb 13 Скачать
EditType81(1.3)

.epf 97,02Kb
16.01.18
1
.epf 8.1.1.3 97,02Kb 1 Скачать

Архив:

Наименование Файл Версия Размер
EditType83(1.2)

.epf 157,56Kb
17.04.16
17
.epf 8.3.1.2 157,56Kb 17 Скачать
EditType81(1.2)

.epf 80,89Kb
17.04.16
7
.epf 8.1.1.2 80,89Kb 7 Скачать
EditType83(1.1)

.epf 127,92Kb
17.04.16
5
.epf 8.3.1.1 127,92Kb 5 Скачать
EditType83(1.0)

.epf 124,42Kb
17.04.16
8
.epf 8.3.1.0 124,42Kb 8 Скачать

Специальные предложения

Имеет ли практический смысл при разработке универсального функционала подобного этому создавать версию функционала для платформы 8.1


Да имеет, для нас это актуально. Есть рабочие базы, работающие под 8.1 (8.43%, 7 голосов)
8.43%
Вряд ли стоит делать "дангрейд" для платформы 8.1, поскольку она практически неиспользуется (44.58%, 37 голосов)
44.58%
Делать что-либо для 8.1 - это пустая трата времени. (46.99%, 39 голосов)
46.99%

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. yuraos 966 18.02.16 08:28 Сейчас в теме
Всем привет и доброго времени суток!

1. Версия для 8.1 пока не готова (сделаю быстрее, если будут особые пожелания).

2. В будущем в контекстное меню думаю вставить пару подменю:
- для выбора составного типа "Характеристика.ИмяПланаВидовХарактеристик
- для выбора составного типа "ОпределяемыйТип.ИмяОпределяемогоТипа"
2. the1 572 18.02.16 09:10 Сейчас в теме
Ну явно не хватает фильтра по типам
Прикрепленные файлы:
adhocprog; yuraos; +2 Ответить
3. yuraos 966 18.02.16 10:30 Сейчас в теме
(2) the1,
да, увы, да не хватает
....
также не хватает в 1с поиска в таблицах по регулярным выражениям
(ну хотя бы по строке шаблона оператора ПОДОБНО).

А в дереве значений управляемой формы - вообще никакие поиски не работают
(приходится при необходимости их индексировать)!!!!!

вот когда 1С дорастет до выше сказанного - сделаю и отбор по строке в наименовании

;)
4. yuraos 966 18.02.16 10:37 Сейчас в теме
(2)(3)
можно конечно извратиться с помощью запроса...
но делать серверный вызов для поиска в таблице на клиенте -
- это ЯВНЫЙ НЕ ФЭНШУЙ !!!!
5. the1 572 20.02.16 09:14 Сейчас в теме
6. yuraos 966 20.02.16 12:25 Сейчас в теме
(5) the1,
понимаю что это можно сделать через запрос.
***
НО неохота делать это для управляемой формы:

7. yuraos 966 20.02.16 12:25 Сейчас в теме
(6)
1. так-как потребуется серверный вызов с неизбежными тормозами при поиске.
(наверное можно наверное извратиться с ВРЕМЕННЫМ ХРАНИЛИЩЕМ, чтобы сделать этот вызов ВНЕКОНТЕКСТНЫМ).
8. yuraos 966 20.02.16 12:27 Сейчас в теме
(6)
2. после получения списка удовлетворяющих условиям поиска строк
придется установить для этих строк признак отбора и включить сам отбор строк в таблице формы по этому признаку.

Но в настоящий момент
реально отбор строк в таблице управляемой формы работает только для таблицы формы связанной с "ТаблицейЗначения"
ДЛЯ "ДЕРЕВА ЗНАЧЕНИЙ" В УПРАВЛЯЕМОЙ ФОРМЕ ОТБОР СТРОК НЕ РАБОТАЕТ !!!
(в дополнении с отсутствием обычного поиска строк)
9. yuraos 966 20.02.16 12:36 Сейчас в теме
(6)(7)(8)
так что этот поиск в настоящий момент можно сделать только в одном частном случае
(в случае представления таблицы типов в виде "ТаблицыЗначений" в управляемой форме)
***
и думаю что делать это не стоит ...
... не хочется нарушать универсальность функциональности в разных режимах.
10. DrAku1a 1314 25.02.16 02:42 Сейчас в теме
(2) the1, Юзаем пока что "Ctrl+F" в дереве.
12. yuraos 966 13.03.16 08:50 Сейчас в теме
ДАЛЬНЕЙШИЕ ПЛАНЫ:

1. По замечанию the1(2):
Таки сделаю поиск по строке, похожий на тот, что в системном диалоге.
Но сразу хочу сказать что получится довольно стремно -
- без выделения цветом вхождений строки поиска в таблице найденных строк.
(так как использовать тип "ФорматированнаяСтрока" в таблицах форм под 8.2 и 8.3 нельзя)
Может что-то изменится под 8.4 ...
Хотя на вряд ли, юзабилити у 1С - не в приоритете.

2. Судя по опросу, все-таки есть народ, который все еще варится на платформе 8.1.
И поскольку на моей новой работе тоже оказались базы под 8.1 -
- ДАУНГРЕЙДУ ДЛЯ 8.1 БЫТЬ !!!
...
но после добавления поиска по строке.
13. yuraos 966 17.04.16 10:21 Сейчас в теме
Всем доброго времени суток!!!
Обновлены файлы поставки::

Опубликована версия 8.3.1.2 от 11.04.2016
Опубликована версия 8.1.1.2 от 11.04.2016 - обещанный даунгрэйд для платформы 1с-8.1

Новое в версиях:
- исполнено пожелание (2) the1
добавлен поиск по строке в имени/синониме типа с разными дополнительными опциями

(пришлось малость повозиться - но что не сделаешь для хорошего человека! ).

- добавлен показ только отмеченных строк в списке типов.


- добавлен показ типов "ХранилищеЗначений" и "УникальныйИдентификатор".
(особого смысла нет, но пусть будут - может у кого есть нештатные средства для редактирования этих типов)..

- подправлены кое какие мелкие косячки.
14. the1 572 16.08.16 15:11 Сейчас в теме
(13) от теперь полная крутотень!
11. yuraos 966 13.03.16 08:36 Сейчас в теме
Всем доброго времени суток!
***
Обновлены файлы поставки::
Опубликована версия 1.1 от 13.03.2016
В контекстное меню флага "Составной тип данных" добавлено два подменю:
- "Выбрать тип характеристик" (Рис.14.2, для установки в списке составного типа "Характеристика.ИмяПВХ")
- "Выбрать определяемый тип" (Рис.14.3, для установки в списке составного типа "ОпределяемыйТип.ИмяОТ")
15. yuraos 966 14.01.18 16:20 Сейчас в теме
Всем доброго времени суток!
***
Обновлены файлы поставки:
Опубликована версия 1.3 от 02.01.2018
+ добавлен показ типа "СписокЗначений" при показе дополнительных типов (вместе с типом "ДвоичныеДанные").
+ в группу типов "Системные перечисления" добавлен тип "СтатусСообщения".
+ добавлен показ типов ключей записей регистров учета (сведений, накопления, бухгалтерии и расчета).
+ добавлен показ типов менеджеров констант, а также типов объектов встроенных отчетов и обработок
(опция не имеет смысла для управляемой формы диалога из-за недоступности типов).
+ добавлена возможность испоьзования кратких названий групп ссылочных типов
("Справочники" вместо "СправочникСсылка").
+ добавлена возможность указания заголовка диалога, отличного от выводимого по умолчанию.
+ тип параметра открытия диалога "ТипыВВидеДерева" , определяющий представление списка типов,
изменен на числовой (с сохранением поведения для обратной совместимости):
0 - "список", 1 - "многоуровневое дерево", 2 - "одноуровневое дерево".
+ добавлена смена представления списка типов в диалоге с возможностью сохранения
выбранного значения в настройках формы-владельца, открывшей диалог.
+ исправлены замеченные ошибки.
16. yuraos 966 14.01.18 16:23 Сейчас в теме
(15) Буду благодарен тем,
кто подскажет как обойти глюки в управляемой форме:

---------------------------------------------------------------------------------------------
Под платформой 8.3.7 и выше в форме "EditTypeУправляемое"
при изменении представления списка типов с многоуровневого на одноуровневый и наоборот,
а также при включении/отключении режима показа только отмеченных строк в списке,
наблюдается неприятный визуальный эффект:
форма диалога "самостоятельно" увеличивает размер по вертикали и горизонтали.

---------------------------------------------------------------------------------------------
17. yuraos 966 17.01.18 05:47 Сейчас в теме
(15)

1. Показ менеджеров констант и ключей записей регистров в диалоге
добавлен в связи с возможностью его использования
для выбора типов объектов в универсальных обработках
массовой регистрации изменений данных в узлах планов обмена.

2. Показ объектов встроенных отчетов и обработок в диалоге
добавлен в связи с возможностью его использования
для выбора типов объектов в гибких механизмах
программного разграничения доступа.
Оставьте свое сообщение

См. также

Альтернативный способ добавления элементов и реквизитов на формы Промо

Работа с интерфейсом v8 ERP2 УТ11 Россия Абонемент ($m)

Предлагаю альтернативный вариант добавления динамически создаваемых элементов и реквизитов на форму.

1 стартмани

09.09.2019    8822    10    bmk74    1    

Вам нравятся запросы в 1С?

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    17258    4    m-rv    86    

Безопасная работа с транзакциями во встроенном языке

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    30274    10    tormozit    44    

Шпаргалка разработчика для работы с формами

Работа с интерфейсом v8 Россия Абонемент ($m)

Сборник помогает быстро освоить встроенный язык и средства конфигурирования при разработке обычных и управляемых форм.

3 стартмани

31.10.2018    14498    77    ELAM    3    

Расширенная настройка динамического списка УФ Промо

Работа с интерфейсом v8 v8::УФ 1cv8.cf Абонемент ($m)

Открывая управляемую форму выбора и не увидев там видимых в форме списка элементов, часто хочется узнать причину их отсутствия там, т. е. какой наложен отбор. Но стандартная настройка списка управляемой формы показывает только пользовательские настройки, скрывая от пользователя фиксированный отбор. Предлагаю вам расширение конфигурации с расширенной настройкой динамического списка, отображающей пользователю кроме пользовательских настроек еще фиксированные.

1 стартмани

31.05.2017    29979    147    tormozit    23    

Открывашка ячеек таблиц

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Глобальное сочетание клавиш для открытия объекта по ссылке из текущей ячейки любой таблицы в большинстве управляемых форм

1 стартмани

27.10.2018    14983    12    tormozit    31    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    18797    12    RocKeR_13    16    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    25371    25    informa1555    26    

Лучший подарок для бухгалтера - счёты 8.2 (со звуком) Промо

Работа с интерфейсом v8 1cv8.cf Россия Абонемент ($m)

(Толстый клиент) Подарите бухгалтеру счеты, и он(а) Вас никогда не забудет.

1 стартмани

13.05.2011    38322    24    Tatitutu    45    

Визуализация событий на временной шкале средствами "Поле HTML документа"

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Интересный способ наглядно отобразить события на временной шкале. Например, может быть применен для красивого вывода документов по клиенту. Тестировалось на платформе 8.3.12.1469

1 стартмани

31.07.2018    21450    135    Plotks2017    27    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    39226    17    kalyaka    16    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар")

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    27567    86    m-rv    57    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    25089    66    vasvl123    9    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    41087    33    dsdred    36    

Как выполнить отчет на СКД через COM и получить данные отчета?

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    25674    8    wowik    3    

Работа со схемой запроса

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    40963    85    kalyaka    34    

Заполняем по шаблону (по умолчанию)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    25468    19    mvxyz    17    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    33106    54    rpgshnik    48    

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула

Печатные формы документов Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    36533    27    agent00mouse    0    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    24804    49    kwazi    6    

Программное формирование форматированной строки в стиле html+inline CSS

Работа с интерфейсом Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Если вам приходилось работать с форматированными строками программно, то вы знаете, какая это боль. Данное решение облегчает программное формирование таких строк.

1 стартмани

18.11.2017    28371    31    bonv    10    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    116376    13    signum2009    46    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    47304    15    DarkAn    86    

Простой способ индексирования интервалов

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    38116    38    ildarovich    22    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    44681    36    Demanoidos    60    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    53117    7    wowik    30    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    51699    19    arakelyan    18    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    74465    150    igo1    52    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    16536    1    Alexander.Shvets    5    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    21568    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    35412    19    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    53183    47    YPermitin    19    

Быстрое определение интервалов в запросе

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    47788    32    ildarovich    41    

Полезные приемы при работе с Excel из 1С (Версия 3.1)

Практика программирования Разработка внешних компонент Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    179331    429    Zerocl    65    

Code First и Linq to EF на примере 1С версии 7.7 и 8.3 часть I

Практика программирования v8 Абонемент ($m)

Данный проект является чисто исследовательским примером использования Code First и Linq to EF на примере 1С версии 7.7. Так как сам я программист 1С, то мне всегда было интересно, как можно перенести модель объектов 1С на компилируемые языки, и использовать мощь Linq to EF. С появлением Code First давно хотел прикрутить, но все как-то руки не доходили, и вот, наконец ..

1 стартмани

28.08.2015    21433    3    Serginio    2    

Универсальная учетная система с конструктором документов и справочников в режиме 1С: Предприятие

Инструментарий разработчика Практика программирования v8 1cv8.cf УУ Абонемент ($m)

Заголовок статьи звучит фантастично, но это не шутка. Занимаясь внедрениями, я часто сталкивался с ситуацией, когда надо было к типовой конфе приделать простенький модуль учета чего-нибудь, не специфичного для самой конфы. Например в УТ учет материалов в эксплуатации. Модуль обычно состоял из пары справочников (2-3), 3-х документов и регистра или пары регистров. Однажды подобные пристройки понадобились одновременно на 3 проектах. Скучно делать одинаковую работу, и я подумал, а что, если сделать универсальный инструмент, в котором пользователь сам сможет нарисовать себе справочники, реквизиты к ним, документы и движения. Т.е. конструктор полноценных документов в пользовательском режиме. Это оказалось не так сложно - все дело в подходящей архитектуре данных.

1 стартмани

29.07.2015    30061    87    informa1555    41    

NativeDraw: Компонента рисования для 1С [V2.6.2]

Разработка внешних компонент Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Рисуйте в формах 1С, также предлагается небольшое количество нерисовальных функций

1 стартмани

13.07.2015    44399    419    ПерваяСистема    147    

Методы для группировки данных по полю,полям в Таблице Значений на примере универсального метода списания по партиям, а также отбора строк в ТЗ по произвольному условию. Для 8.x и 7.7

Универсальные функции Практика программирования v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Я очень часто использую группировку данных по полю и полям, как в восьмерке, так и в семерке. Это аналог запроса Итоги, но там строится дерево, а в большинстве случаев нужны "плоские данные". Да и делать запрос в большинстве случаев более накладный процесс, чем работа с ТЗ. Все достоинства такого подхода приведены на примере метода универсального списания по париям, а так же отбора строк в ТЗ по произвольному условию. Для 7.7 еще отчеты сравнения двух ТЗ. Работая с различными базами для упрощения сравнения номенклатуры, или как аналог джойнов(join), сделал сравнение двух таблиц значений по нескольким полям. Пока группировки полей должны быть уникальны. Часто приходится искать дубли, для универсального поиска есть ДублиВТзПоПолю и пример в Тест.ert.

1 стартмани

25.06.2015    26395    3    Serginio    1    

И снова "Как сжать картинки для экспорта в EXCEL?" или Умная картинка 8.2

Практика программирования Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Прошла уже эпоха , когда экономили на трафике интернета. Но все же...повторюсь. Я предлагаю совершенно новый способ сжатия картинки - эффект в 20 раз !!!

1 стартмани

17.06.2015    28438    43    Tatitutu    10    

Кнопки управления группировками табличного документа для управляемых форм

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Универсальный механизм управления группировками табличного документа из управляемой формы

1 стартмани

02.06.2015    25183    23    unichkin    9    

Альтернативная визуализация данных для 1С 8.3.6

Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Нужен приятный Bi Dashboard? Или просто красивый график/диаграмма для сайта? Тогда эта разработка для Вас!

1 стартмани

29.05.2015    29614    78    vano-ekt    3