Кантер Андрей | Руководитель отдела, зам директора по работе с учебными заведениями | ООО НПФ "Форус"

«Новые кадры никто не завезет»

Мы попали в интересную ситуацию на рынке, когда число возможных проектов превысило число потенциальных исполнителей. Кадры нужны всем, но где же их взять? Нужны сегодняшние студенты, которые станут нашими сотрудниками завтра. В докладе я расскажу: 1. Как меняется подход работодателей к работе со студентами и почему уже нельзя позвонить в деканат и попросить "Дайте мне кого-нибудь умного"; 2. Как мы создали студенческое предприятие совместно с ВУЗом, в котором трудятся более 10 человек. Студенты получают реальных клиентов, опыт и стаж по специальности без отрыва от учебы. Но выгодна ли эта схема партнеру 1С? 3. Как набирать 15 человек в год на вакансии программистов и консультантов через ВУЗы. Крутых человек, которые через 3-4 года становятся ведущими. 4. Как не растерять студентов за время их обучения ("отвал" не более 50% - и почему это все равно выгоднее, чем искать на рынке); 5. Как построить для студентов систему мотивации, адаптации и обучения в компании. Нам есть с чем сравнивать: год назад мы потеряли почти всех, в этом году - почти всех удержали. Покажу в чем была разница; 6. Выжать максимум. Зачем писать со студентами дипломные проекты? Действительно ли они не могут сделать ничего серьезного? 7. Студенты кончились. Что дальше? Школьники!

Старые обработки в новом (Управляемом) интерфейсе

Программирование - Практика программирования

Многие разработчики привыкли использовать какие-либо обработки, разработанные для приложений с обычным интерфейсом. Но они не работают в приложениях на управляемых формах. Как вариант, эту обработку можно включить в состав конфигурации, указать в свойствах конфигурации, что возможно использование обычных форм

Идея, как таковая, принадлежит не мне, а автору всем известной подсистемы "Инструменты разработчика" //infostart.ru/public/15126/

Многие разработчики привыкли использовать какие либо обработки, разработанные для приложений с обычным интерфейсом.

Но они не работают в приложениях на управляемых формах. Как вариант, эту обработку можно включить в состав конфигурации, указать в свойствах конфигурации, что возможно использование обычных форм, и радоваться…

Но не всегда есть такая возможность, например если конфигурация стоит на поддержке.

Для таких случаев можно произвести небольшую модификацию внешней обработки.

Для этого необходимо через меню Сервис->Параметры на закладке общие указать, что будет использоваться режим запуска «Управляемое приложение и обычное приложение»

После чего станет возможным добавить в нашу обработку управляемую форму.

В самой форме размещаем команду, которая запустит нашу конфигурацию в режиме обычного приложения и автоматически откроет нашу обработку.

В обработчике команды прописываем код, который произведет запуск в обычном режиме


&НаКлиенте
Процедура ЗапуститьОбычноеПриложение(Команда)
	
	#Если ВебКлиент Тогда
		Сообщить("Команда недоступна веб клиенте");
	#Иначе
		ПараметрыЗапуска = "";
		СтрокаСоединения = СтрокаСоединенияИнформационнойБазы();
		ПараметрыЗапуска = ПараметрыЗапуска + " ENTERPRISE";
		ПараметрыЗапуска = ПараметрыЗапуска + " /IBConnectionString""" + СтрЗаменить(СтрокаСоединения, """", """""") + """";
		ПараметрыЗапуска = ПараметрыЗапуска + " /RunModeOrdinaryApplication";
		ИспользуемоеИмяФайла = ПолучитьИспользуемоеИмяФайла(ИмяКомпьютера());
		Если ЗначениеЗаполнено(ИспользуемоеИмяФайла) Тогда
			ПараметрыЗапуска = ПараметрыЗапуска + " /Execute""" + ИспользуемоеИмяФайла + """";
		КонецЕсли; 
		ЗапуститьПриложение(КаталогПрограммы() + "1cv8.exe " + ПараметрыЗапуска);
	#КонецЕсли 
	
КонецПроцедуры

&НаСервере
Функция ПолучитьИспользуемоеИмяФайла(ИмяКомпьютера)
	
	Если ИмяКомпьютера = ИмяКомпьютера() Тогда
		Возврат РеквизитФормыВЗначение("Объект").ИспользуемоеИмяФайла;
	Иначе
		Возврат Неопределено;
	КонецЕсли; 
	
КонецФункции

Радуемся использованию инструмента, который много раз выручал и выручит еще не раз.

См. также

Комментарии
Сортировка: Древо
1. zhyhallo 92 16.08.16 07:22 Сейчас в теме
Интересная идея. Удобная для пользователя. Спасибо за статью.
moolex; valerasv; +2 Ответить
2. Dem1urg 82 17.08.16 10:02 Сейчас в теме
В большинстве случаев хватает отдельного ярлыка для запуска 1С в котором в параметрах прописан ключ RunModeOrdinaryApplication
degepie; 7OH; monkbest; +3 Ответить
3. valerasv 101 17.08.16 14:35 Сейчас в теме
Если это на одном компьютере, можно и ярлык создать.
А если где то на выезде или при удаленном соединении?...
Тут даже задумываться о ярлыках не нужно. К тому же такую обработку
можно отдать в пользование обычному пользователю....
4. vis_tmp 28 24.08.16 07:09 Сейчас в теме
5. demon_infernal 30 29.09.16 08:08 Сейчас в теме
А если конфигурация еще и базовая - то между запуском этой команды и открытием окна обычного приложения нужно успеть закрыть сеанс управляемого приложения, что очень неудобно.
6. valerasv 101 02.10.16 19:08 Сейчас в теме
(5) demon_infernal,
Для этого, в самом простом случае, достаточно прописать ЗавершитьРаботуСистемы().
Посложнее -
Если ЗакрыватьОкноПриложения Тогда
ЗавершитьРаботуСистемы();
КонецЕсли;

Где "ЗакрыватьОкноПриложения" типа Булево, выведенное на форму....
7. Probot1c 02.02.17 11:47 Сейчас в теме
Интересное решение, спасибо за статью, надо попробовать!
Оставьте свое сообщение