Печатная форма многофункциональная для быстрой разработки на шаблонах (обычные и управляемые формы)

Публикация № 595984

Печать - Универсальные печатные формы

печатная форма документ ворд word конструктор внешняя договор шаблон многофункциональная бухгалтерия зарплата erp

14
Создайте печатную форму за 5 минут! Программировать не потребуется. Будет полезна как директорам, которые хотят экономить на сопровождении, так и программистам, желающим экономить кучу времени. Можно подключать к любому количеству видов документов. Модуль постоянно развивается.

Описание

Обработка позволяет быстро создавать и дорабатывать печатные формы. Достаточно определить в нужных местах шаблона замены (список выводится в отдельном окне). Работает в основных типовых конфигурациях (БП, УТ, ЗУП, УНФ, Розница, КА*, УПП, БГУ 2, ЗиК ГУ, ERP), в обычном и управляемом интерфейсах, файловом,  клиент-серверном режимах, веб-интерфейсе. Подключается как обычная печатная форма или через расширение. Работает и в "самописных" конфигурациях. Шаблоном является файл Ворда или MXL. Пользователь даже не заметит разницы при вызове! (В "Параметрах обработки" надо задать НомерШаблона, нумерация с 1). Можно получать из базы любые данные. Есть даже отладка кода!

Конфигурации, в которых работает:

  1. Бухгалтерия 2 и 3
  2. "Управление торговлей", 10 и 11
  3. "Зарплата и управление персоналом" 2.5 и 3
  4. Управление нашей фирмой
  5. Розница
  6. "Комплексная автоматизация" 1 и 2
  7. Управление производственным предприятием
  8. "Бухгалтерия государственного учреждения" 2
  9. "Зарплата и кадры государственного учреждения" 3
  10. ERP

Можно печатать автоматически:

  1. Коммерческие предложения
  2. Договоры поставок, подряда, оказания услуг
  3. Счета с логотипом, печатью, подписью
  4. Дополнительные соглашения
  5. Накладные, счета с подсчитанными площадью, объёмом, весом товара.
  6. Прайсы с картинками
  7. Муниципальные контракты
  8. Претензии
  9. Счета-оферты
  10. Договоры о неразглашении коммерческой тайны
  11. Спецификации к договорам
  12. Подарочные сертификаты к товарам

Возможности:

  1. обработка переменных до вывода в шаблон (есть отладчик)
  2. чтение дополнительных реквизитов
  3. замена пустых значений на другие (прочерки)
  4. сводное формирование нескольких документов как один
  5. вывод данных из табличных частей с возможностью указать количество знаков после запятой
  6. поддержка валют
  7. печать для каждой строки документа (указать имя табличной части)
  8. не использует COM-объект !
  9. печатная форма по строкам табличной части
  10. шаблоны могут храниться в базе при многопользовательской работе
  11. Лёгкий перенос настроек между базами (сохранение в файл, загрузка из файла)

Функции, которые можно использовать для получения своих переменных и обработки:

  1. Склонение
  2. НайтиСимволСКонца
  3. ПолучитьГородАдреса
  4. ПолучитьДокументФизЛица
  5. ПолучитьДопРеквизиты
  6. ПолучитьПоследнееСлово
  7. ПолучитьСловоСБольшойБуквыПоНомеру
  8. ПолучитьСокращенноеНаименование
  9. ТолькоКириллицаВСтроке
  10. УбратьПрилагательные
  11. УбратьЛидирующиеНули
  12. ЭтоПрилагательное
  13. ФамилияИнициалы(ФамилияИмяОтчество, ИОФ = Ложь)
  14. ПолучитьСтрокиРегистра(РегистрИмя, РеквизитИмя, РеквизитЗначение, ДатаАктуальности = Неопределено)
  15. Функции для дат

Планируется сделать в следующих релизах:

  1. Увеличение скорости вывода
  2. Автоматизирование создания шаблона
  3. Печать реестра документов
  4. Использование редакторов OpenOffice и LibreOffice
  5. Добавление разнообразных процедур и функций

 

Вызов из расширения

Добавим кнопку печати и пропишем в ней:


&НаКлиенте
Процедура Расш_ЗППечатьПосле(Команда)
    
    ПараметрыОбработки = Новый Структура("НомерШаблона", 1);
    ПараметрыОбработки.Вставить("ОбъектыНазначения", Объект.Ссылка);
    СтрокаВызоваФормы = "Обработка.МногофункциональнаяПечатнаяФорма.Форма.ФормаУправляемая";
    ОткрытьФорму(СтрокаВызоваФормы, ПараметрыОбработки);
    
КонецПроцедуры

Пример кода для УПП. Документы: "Прием на работу в организацию", "Кадровое перемещение организаций"

РежимОтладки = Ложь;
РаботникиОрганизации_ДатаНачала = РаботникиОрганизации_ДатаНачала;
Номер = СокрЛП(Номер);
НаименованиеПолноеОрганизацииДП = СтрЗаменить(НаименованиеПолноеОрганизации, "Общество ", "Обществом ");
СтрокаДокумента = РаботникиОрганизации[НомерСтрокиТЧ];
ДатаНачала = ?(СсылкаТип = "КадровоеПеремещениеОрганизаций", РаботникиОрганизации_ДатаНачала, "");
Сотрудник = РаботникиОрганизации_Сотрудник;
ГрафикРаботы = "" + РаботникиОрганизации_ГрафикРаботы;
НомерДоговора = СокрЛП(Сотрудник.НомерДоговора);
НомерДоговора = НомерДоговора + ?(СсылкаТип = "КадровоеПеремещениеОрганизаций", " от " + ДатаБезВремени(Сотрудник.ДатаДоговора) + " г.", "");
ПодразделениеОрганизации = РаботникиОрганизации_ПодразделениеОрганизации;
ФизЛицо = РаботникиОрганизации_Физлицо;
ВидЗанятости = " " + ?(Найти(Сотрудник.ВидЗанятости, "совмест") > 0, "по совместительству", "основным местом работы");
ДатаРождения = Формат(ФизЛицо.ДатаРождения, "ДФ=dd.MM.yyyy; ДЛФ=");
ИспытательныйСрок = ?(СсылкаТип = "КадровоеПеремещениеОрганизаций", "", СтрокаДокумента.ИспытательныйСрок);
ЗанимаемыхСтавок = РаботникиОрганизации_ЗанимаемыхСтавок;
Должность = РаботникиОрганизации_Должность;
ДокументФизлица = ПолучитьДокументФизлица(ФизЛицо, Ссылка.Дата);
ДатаПриема = Формат(Сотрудник.ДатаНачала, "ДФ=dd.MM.yyyy; ДЛФ=");
ДатаОкончания = Формат(Сотрудник.ДатаОкончания, "ДФ=dd.MM.yyyy; ДЛФ=");
ТекстСрока = ?(ЗначениеЗаполнено(Сотрудник.ДатаОкончания), "определенный срок. Действие договора до " + ДатаОкончания, "неопределенный срок");
ТекстТарифнойСтавки = ?(ЗанимаемыхСтавок = 1, "тарифная ставка", "тарифной ставки");
Гражданство = ПолучитьСтрокиРегистра("ГражданствоФизЛиц", "ФизЛицо", ФизЛицо);
Гражданство = ?(ЗначениеЗаполнено(Гражданство), "" + Гражданство[0].Страна, "РФ");
Гражданство = ?(Врег(Гражданство = "РОССИЯ"), "РФ", Гражданство);
Оклад = 0;
НачисленияСотрудника = ОсновныеНачисления.НайтиСтроки(Новый Структура("Сотрудник", Сотрудник));

Для Каждого СтрокаТЧ Из НачисленияСотрудника Цикл
    
    Если Найти("" + СтрокаТЧ.ВидРасчета, "Оклад") > 0 Тогда
        Оклад = СтрокаТЧ.Показатель1;
        Прервать;
    КонецЕсли;
    
КонецЦикла;
    
ОкладПропись = СтрЗаменить(ЧислоПрописью(Оклад), "  00 ", "");

Если Найти(ГрафикРаботы, "/") = 0 Тогда
    РежимВремени = "нормированный учет рабочего времени. Пятидневная рабочая неделя с понедельника по пятницу, неполный-часовой рабочий день (неделей), от пятидневной- 40 часовой рабочей недели 0,5 ставки по штатному расписанию."
Иначе
    РежимВремени = "суммированный учет рабочего времени с периодом расчета 1 (один) календарный год. Выходы Работника на работу регулируются графиком работы."
КонецЕсли;

КоличествоСтрокТЧ = ?(РежимОтладки, 0, КоличествоСтрокТЧ);
// конец кода

Пример кода для ЗУП 3. Документы: "Договор (работы, услуги)", "Прием на работу"

Начисления = Начисления;
ДатаДФ = СтрЗаменить(ДатаПеревернуть(ДатаДокумента), СимволРазделенияВДате, "-");
СНИЛС = ФизическоеЛицо.СтраховойНомерПФР;
ИННФЛ = ФизическоеЛицо.ИНН;
ФИО = ФамилияИнициалы(ФизическоеЛицо);
ФИОДФ = СтрЗаменить(ФИО, ".", "");
РуководительФИО = ФамилияИнициалы(Руководитель);
РуководительРП = Склонение(Руководитель, 2, , "ФИО");
ДолжностьРуководителяРП = НРег(Склонение(ДолжностьРуководителя, 2));

Если СсылкаТип = "ПриемНаРаботу" Тогда
	НомерДоговора = Ссылка.ТрудовойДоговорНомер;
	НомерДоговора = ?(Найти(НомерДоговора, " ") = 0, НомерДоговора, Сред(НомерДоговора, Найти(" ", НомерДоговора)+1));
	ДатаЗавершенияТрудовогоДоговора = ТекущаяДата();
	СтрокаОклада = Начисления[0];
	РазмерОклада = СтрокаОклада.Размер;
Иначе
	Начисления = 0;
	НомерДоговора = Ссылка.Номер;
	РазмерОклада = Ссылка.Сумма;
	ДатаПриема = Ссылка.ДатаНачала;
	ДатаЗавершенияТрудовогоДоговора = Ссылка.ДатаОкончания;
КонецЕсли;

НомерДоговораДФ = СтрЗаменить(НомерДоговора, СимволРазделенияВДате, "-");
РазмерОкладаПропись = ЧислоПрописьюСПопыткой(РазмерОклада);
ДатаПриемаПропись = ДатаПрописьюКавычки(ДатаПриема);
ДатаЗавершенияПропись = ДатаПрописьюКавычки(ДатаЗавершенияТрудовогоДоговора);
ДатаДокументаПропись = ДатаПрописьюКавычки(Ссылка.Дата);

// документ физического лица
ДокументСотрудникаСтруктура = "";
ДокументСотрудника = ПолучитьДокументФизЛица(ФизическоеЛицо, ДокументСотрудникаСтруктура);
АдресСтруктура = ПолучитьКонтактнуюИнформацию(ФизическоеЛицо);
ФизическоеЛицоАдресПрописка = АдресСтруктура.ЮридическийАдрес;
ФизическоеЛицоТелефон = АдресСтруктура.Телефон;

КППОрганизации = Организация.РегистрацияВНалоговомОргане.КПП;
ИННКПП = ИННОрганизации + ?(ЗначениеЗаполнено(КППОрганизации), "/", "") + КППОрганизации;
ОГРННаименование = "ОГРН" + ?(ЗначениеЗаполнено(КППОрганизации), "", "ИП");
ОГРН = ОГРНОрганизации;

// РасчетныйСчетОрганизации
РасчетныйСчетОрганизации2 = "";
РСОрг = ПолучитьЭлементыПоРеквизиту("ЗарплатныеПроекты", "Организация", Организация);
Попытка
	РасчетныйСчетОрганизации2 = РСОрг[0].РасчетныйСчет + " в " + РСОрг[0].Банк.Наименование + " к/с " + РСОрг[0].Банк.КоррСчет + " БИК " + РСОрг[0].Банк.Код;
КонецПопытки;

// РасчетныйСчетКонтрагента
РС = ПолучитьЭлементыВладельца("Банковские счета контрагентов", ФизическоеЛицо);
РС= РС[0];
РасчетныйСчетКонтрагента = РС.НомерСчета + " в " + РС.Банк.Наименование + " к/с " + РС.Банк.КоррСчет + " БИК " + РС.Банк.Код;

Услуга = "";
Попытка
	Услуга = ДополнительныеРеквизиты[0].Значение;
Исключение КонецПопытки;

Код полностью открыт пользователю после приобретения прав на его использование. Возможны доработки после приобретения.

Бесплатно предоставляются обновления по электронной почте в течение 1 месяца.

Готовится релиз 0.97

Причины купить

  1. Возможен мастер-класс по созданию шаблона
  2. Вложены разнообразные готовые шаблоны
  3. Чтобы сделать печатную форму, не требуется знаний программиста
  4. Проще освоить одну обработку, чем много разных
  5. Цена ниже, чем у аналогов (пока), количество конфигураций больше
  6. Не требуется встраивать в конфигурацию
  7. Возможность заменить пустые переменные на "значения по умолчанию"
  8. Много функций обработки значений и они постоянно добавляются
  9. Индивидуальная или общая настройка под разных пользователей
  10. Бесплатно высылаем новые релизы в течении месяца

Достоинства

Обработка (она же печатная форма) передается по электронной почте в течении суток с момента поступления уведомлении автора об покупке.

  1. Быстрое создание разнообразных печатных форм
  2. Для распространенных конфигураций, однако работает и на самописных конфигурациях
  3. Неограниченные возможности для обработки значений

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

14

Скачать файлы

Наименование Файл Версия Размер
Инструкция
.docx 103,95Kb
11.10.18
44
.docx 103,95Kb 44 Скачать бесплатно
Подарочный сертификат при продаже бытовой техники
.docx 730,99Kb
11.10.18
10
.docx 730,99Kb 10 Скачать бесплатно
Нормы расхода - шаблон для БП
.docx 11,64Kb
11.10.18
15
.docx 11,64Kb 15 Скачать бесплатно
Шаблон счета с весом и объёмом в формате MXL
.mxl 16,08Kb
11.10.18
16
.mxl 16,08Kb 16 Скачать бесплатно
Печатная форма многофункциональная для быстрой разработки на шаблонах (обычные и управляемые формы):
.doc 84,50Kb
29.10.18
14
.doc 84,50Kb 14 Скачать бесплатно
Типовой Договор Поставки
.doc 84,50Kb
29.10.18
7
.doc 84,50Kb 7 Скачать бесплатно
31.01.2019
6 3900 руб.

Моментальная
доставка

31.01.2019
0 3900 руб.

Моментальная
доставка

31.01.2019
0 6900 руб.

Моментальная
доставка

31.01.2019
0 900 руб.
31.01.2019
0 900 руб.

Печатная форма многофункциональная для быстрой разработки на шаблонах (обычные и управляемые формы)
Подскажите когда выходит следующий релиз? поддержка ERP интересует
8
1
Печатная форма документов многофункциональная для быстрой разработки на шаблонах - Управляемые формы
Здравствуйте! Заказ оплатили, платежка из банка во вложении, можно нам поскорее выслать обработку пожалуйста.
2
1

Новый вопрос

E-mail*
Тема (вопрос)*

См. также

Специальные предложения