Сохранение реквизитов объектов обработки. Обычное приложение

Публикация № 611617

Разработка - Инструментарий разработчика

Обработка сохранение реквизитов сохранение объектов

Универсальный механизм позволяющий сохранять все реквизиты обработки (даже те которые будут изменены или добавлены). Механизм простой и универсальный

Сохранение реквизитов объектов обработки. Обычное приложение

Для пользователей создается множество обработок которые загружают/исправляют какие то данные, создают объекты и пр. Для удобства работы пользователей приходилось каждый раз прописывать сохранение ключевых реквизитов и их восстановление при открытии. Постепенно создал универсальный механизм - удобный и простой. Вроде аналога я не нашел, поэтому решил выложить здесь.

Суть механизма в том что все реквизиты обрабтки сохраняются в структуру методом СохранитьЗначение() и потом при открытии формы заполняются из структуры методом ВосстановитьЗначение(). Ничего нового я не выдумывал - взял стандартные методы.

ЭТАП 1.

В модуле объекта обработки создаем строковую переменную для сохранения настроек. Я использую имя обработки.

Перем ИмяОбработки  Экспорт;

ИмяОбработки = ЭтотОбъект.Метаданные().ПолноеИмя();

ЭТАП 2.

При закрытии формы обработки вызываем метод сохранения настроек СохранитьРеквизиты(). В котором циклом проходим реквизиты обработки,  сохраняем их в структуру и потом сохраняем структуру методом СохранитьЗначение() .

Процедура СохранитьРеквизиты()

    СтруктураРеквизитов = Новый  Структура;
    Для Каждого текРеквизит из ЭтотОбъект.Метаданные().Реквизиты Цикл 
        СтруктураРеквизитов.Вставить(текРеквизит.Имя, ЭтотОбъект[текРеквизит.Имя]);
    КонецЦикла;    
    СохранитьЗначение(ИмяОбработки, СтруктураРеквизитов);
    
КонецПроцедуры

Этап 3. 

При открытии формы вызываем процедуру ВосстановитьРеквизиты() которая восстанавливает структуру реквизитов и заполняет из структуры реквизиты обработки

Процедура ВосстановитьРеквизиты()

    СтруктураРеквизитов = ВосстановитьЗначение(ИмяОбработки);
    Если ТипЗнч(СтруктураРеквизитов) = Тип("Структура") Тогда
        ЗаполнитьЗначенияСвойств(ЭтотОбъект, СтруктураРеквизитов);            
    КонецЕсли;

КонецПроцедуры 

Для проверки работоспособности добавляю обработку с кодом. В обработке указано два реквизита: Организация, Склад (реквизиты текстовые). При первом открытии нужно заполнить реквизиты, при повторном открытии рекзвиты восстановлятся из последних указанных значений. Обработка на обычной форме, на управляемых работать не будет. Обработка будет работать на любой конфигурации с обычными формами.

Скачать файлы

Наименование Файл Версия Размер
Сохранение реквизитов объектов обработки. Обычное приложение:

.epf 7,34Kb
1
.epf 7,34Kb 1 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Arhey 24.04.17 16:31 Сейчас в теме
Минус метода - другой пользователь не восстановит реквизиты.
2. modevi 4 24.04.17 22:13 Сейчас в теме
(1) Да, другой не восстановит. Зато ему будет достаточно один раз заполнить реквизиты и в следующий раз они подтянутся.
3. VmvLer 24.04.17 22:24 Сейчас в теме
СохранитьЗначение() на 8.3 вроде уже нет. Посему сохраняю просто в ХранилищеОбщихНастроек. Универсально и просто. чяднт?
4. modevi 4 24.04.17 22:29 Сейчас в теме
(3) СохранитьЗначение() не работает на уравляемых формах. Поэтому я даже в теме указал "Сохранение реквизитов объектов обработки. Обычное приложение"

И в конце описания указал Обработка на обычной форме, на управляемых работать не будет.

Сначала читайте тему потом делайте замечания
6. VmvLer 24.04.17 22:37 Сейчас в теме
(4) я не увидел, сразу смотрю в код, извините
5. VmvLer 24.04.17 22:35 Сейчас в теме
Функция ПолучитьИзХранилищаОбщихНастроекРеквизитыОбъекта(СтруктураРеквизитыОбъекта) Экспорт
	
	// Значения переменных {КлючОбъекта, СуффиксКлючаНастроек} должны быть идентичны значениям в методе
	// СохранитьВХранилищеОбщихНастроекРеквизитыОбъекта()
	КлючОбъекта          = "ВнешняяОбработка_ВыгрузкаПоРеализации";
	СуффиксКлючаНастроек = "_ИзХранилища";
	
	СтруктураРеквизитыОбъекта_ИзХранилища = Новый Структура;               
	
	Для каждого ЭлементСтруктуры Из СтруктураРеквизитыОбъекта Цикл
		КлючНастроек = ЭлементСтруктуры.Ключ + СуффиксКлючаНастроек;             // Например, для реквизита "Партнеры" КлючНастроек будет "Партнеры_ИзХранилища"
		ЗначениеИзХранилища = ХранилищеОбщихНастроек.Загрузить(КлючОбъекта, КлючНастроек);
		СтруктураРеквизитыОбъекта_ИзХранилища.Вставить(ЭлементСтруктуры.Ключ, ЗначениеИзХранилища);
	КонецЦикла;
	
	Возврат СтруктураРеквизитыОбъекта_ИзХранилища;
	
КонецФункции


Процедура СохранитьВХранилищеОбщихНастроекРеквизитыОбъекта(СтруктураРеквизитыОбъекта) Экспорт
	
	// Значения переменных {КлючОбъекта, СуффиксКлючаНастроек} должны быть идентичны значениям в методе
	// ПолучитьИзХранилищаОбщихНастроекРеквизитыОбъекта()
	КлючОбъекта          = "ВнешняяОбработка_ВыгрузкаПоРеализации";
	СуффиксКлючаНастроек = "_ИзХранилища";
	
	Для каждого ЭлементСтруктуры Из СтруктураРеквизитыОбъекта Цикл
		КлючНастроек = ЭлементСтруктуры.Ключ + СуффиксКлючаНастроек;              // Например, для реквизита "Партнеры" КлючНастроек будет "Партнеры_ИзХранилища"
		ХранилищеОбщихНастроек.Сохранить(КлючОбъекта, КлючНастроек, ЭлементСтруктуры.Значение); 
	КонецЦикла;	
	
КонецПроцедуры


Показать


заметьте, ХранилищеОбщихНастроек позволяет сохранять и тиражировать сохранки другим пользователям, если использовать параметр метода ИмяПользователя.

А время СохранитьЗначение() уже тю-тю
alexlug95; cherkass; +2 Ответить
Оставьте свое сообщение

См. также

FormCodeGenerator Программная доработка форм. Часть 2 (Режим работы "Режим сравнения форм") на примере ERP 2.5 Промо

Практика программирования Адаптация типовых решений Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Данная публикация является продолжением описания функционирования обработки "FormCodeGenerator " в режиме сравнения форм и генерирования кода на основании сравнения. Подходит для перевода уже доработанных форм с интерактивной доработки на программную. Данный режим работы обработки снизит издержки при дальнейших обновлениях конфигураций.

5 стартмани

21.12.2020    2814    14    huxuxuya    11