Почему при загрузке таблицы Excel в 1С возникают ошибки?

Публикация № 616875

Разработка - Обмен данными 1С - Загрузка и выгрузка в Excel

загрузка Excel ADODB

9
При загрузке из EXCEL в 1С методом MS ADODB.Connection столкнулся с некоторыми проблемами, которые попытался устранить в ниже приведенной статье. Надеюсь, что статья поможет вам сократить время разработки.  Особая благодарность Андрею М. за публикацию //infostart.ru/public/163640/

В данной статье приведен функционал, с помощью которого в обработке
"Импорт из EXCEL (xls) в 1С"
производится считывание данных из файлов табличного типа *xls.

Есть множество статей на эту тему:

Метод "MS ADO" (Чтение файлов xls, xlsx средствами Microsoft ADO): //infostart.ru/public/163640/
- Метод "MS EXCEL" (Чтение файлов xls, xlsx с картинками средствами Microsoft Office): //infostart.ru/public/163641/
- Метод "LO CALC" (Чтение файлов xls, xlsx, ods, sxc с картинками средствами LibreOffice): //infostart.ru/public/163642/
- Метод "NativeXLSX" (Чтение файлов xlsx с картинками средствами 1С. ПостроительDOM): //infostart.ru/public/300092/
- Метод "NativeXLSX". Предыдущий вариант (Чтение файлов xlsx средствами 1С. ЧтениеXML)://infostart.ru/public/225624/
- Метод "Excel1C" (Загрузка на платформе 8.3.6 с картинками. Чтение файлов xls, xlsx, ods): //infostart.ru/public/341855/
- Список листов файла: //infostart.ru/public/163724/

Но всегда возникают какие-то проблемы:

При загрузке из EXCEL в 1С методом MS ADODB.Connection столкнулся со следующим:

  • пользователь выделил цветом всю таблицу Excel, что привело к считыванию всего листа книги.  

  • EOF() оказался гораздо дальше чем реально пользователь видел при визуальном осмотре таблицы Excel, т. е. загружались пустые строки

  • необходимо было очищать таблицу от строк  с наименованиями колонок

Это моя первая публикация. Буду рад вашим исправлениям и комментариям. P.S. Код написан только для расширения .xls. 

 

&НаКлиенте
Процедура ЗагрузитьExcel(Команда)
	
	Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
	Диалог.Заголовок = "Выберите файл";
	Диалог.Фильтр = "|*.xls";
	Диалог.МножественныйВыбор = Ложь;
	
	Если Диалог.Выбрать() Тогда
		
		Адрес = "";
		ПоместитьФайл(Адрес,Диалог.ПолноеИмяФайла,,Ложь);
		ЗагрузитьНаСервере(Адрес);
		
	КонецЕсли;
	
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ЗагрузитьНаСервере(Адрес)

	ТЗ = ЗагрузитьТаблицуExcelНаСервере(Адрес);
    //далее код работы с ТЗ ....
	
КонецПроцедуры

&НаСервереБезКонтекста
Функция ЗагрузитьТаблицуExcelНаСервере(Адрес)
	
	ФайлИзХранилища =  ПолучитьИзВременногоХранилища(Адрес);
	ВременныйФайл = ПолучитьИмяВременногоФайла("xls");
	//Сохранение во временнный файл на диске
	ФайлИзХранилища.Записать(ВременныйФайл);
	//Если опущен, тогда 1-й лист
	еБаза=Новый COMОбъект("ADODB.Connection");
	СтрокаПодключения = "
	|Provider=Microsoft.Jet.OLEDB.4.0;
	|Data Source="+ВременныйФайл+";
	|Extended Properties=""Excel 8.0;IMEX=1;HDR=NO;"";";
	
	Попытка 
		еБаза.Open(СтрокаПодключения);	
	Исключение
		
		СтрокаПодключения = "
		|Provider=Microsoft.ACE.OLEDB.12.0;
		|Data Source="+ПутьКФайлу+";
		|Extended Properties=""Excel 12.0;IMEX=1;HDR="+?(HDR,"Yes","No")+";"";";
		
		Попытка                        		
			еБаза.Open(СтрокаПодключения);		
		Исключение                     		
			Сообщить(ОписаниеОшибки());
		КонецПопытки;
		
	КонецПопытки;
	
	Catalog = Новый COMОбъект("ADOX.Catalog");
	Catalog.ActiveConnection = еБаза;
	лСпис=Новый СписокЗначений;
	лИмяЛиста="";
		
	Для iCount = 0 По Catalog.Tables.Count-1 Цикл
		Если Catalog.Tables.Item(iCount).Type <> "VIEW" Тогда
			лСпис.Добавить(Catalog.Tables.Item(iCount).Name);	
		КонецЕсли;
	КонецЦикла;
	
	Если лСпис.Количество()>0 И лИмяЛиста="" тогда
		лИмяЛиста = лСпис[0];
	Конецесли;
	
		
	Catalog=Неопределено;
	лСтрВнЗапроса="select * from ["+лИмяЛиста+"]";
	
	RS = Новый  COMОбъект("ADODB.Recordset");
	
	rs.Open(лСтрВнЗапроса,еБаза,0);
	
	лТз=Новый ТаблицаЗначений;
	
	ЕстьОшибкиВИмениКолонки=Ложь;
	
	Для iCount = 0 По rs.Fields.Count-1 Цикл
		
		Если СокрЛП(rs.Fields.Item(iCount).Value) = "" Тогда //прервём на пустой ячейке имени колонки
			Прервать;
		КонецЕсли; 
		
		Попытка
			лТз.Колонки.Добавить(rs.Fields.Item(iCount).Value,, rs.Fields.Item(iCount).Name); // Считаем что в первой строке заголовки колонок
		Исключение
		    Сообщить(ОписаниеОшибки()+" «"+(rs.Fields(iCount).Value)+"»");
			ЕстьОшибкиВИмениКолонки = Истина;
		КонецПопытки;	
		
	КонецЦикла;
	
	Если ЕстьОшибкиВИмениКолонки Тогда //прерываем, чтобы исправили
		Возврат лТз;
	КонецЕсли;
	
	// Перебор данных
	Строк=0;
	rs.MoveFirst();                 
	
	//пользователь выделил цветом весь лист Excel, в том числе и пустые ячейки
	//добавим переменную для счета количества пустых ячеек, 
	//как только будет 10 пустых ячеек, считаем, что уже закончились строки в таблице
	
	СчПустых = 0;
	ПустыеСтроки = 0;
	
	Пока rs.EOF() = 0 Цикл
		
		СчПустых = 0;
		Строк=Строк+1;
		//как только будет 10 пустых ячеек, считаем, что уже закончились строки в таблице
		Если ПустыеСтроки = 10 Тогда
			Прервать;
		КонецЕсли;
		
		лТз.Добавить();
		
		Для iCount = 0 По rs.Fields.Count-1 Цикл
			
			Если СчПустых = 3 Тогда //подряд три пустых ячейки, прервём
				СчПустых = 0;//уменьшим
				ПустыеСтроки = ПустыеСтроки+1;
				//Если три первые ячейки строки пустые, то удаляем строку
				Если лТз[лтз.Количество()-1][0]=Неопределено И лТз[лтз.Количество()-1][0] = лТз[лтз.Количество()-1][1] И лТз[лтз.Количество()-1][1] = лТз[лтз.Количество()-1][2] Тогда
					лТз.Удалить(лТз[лтз.Количество()-1]);
				КонецЕсли;	
				Прервать;
			КонецЕсли;
		
			Если Строка(rs.Fields(iCount).Value) = "" Тогда
				СчПустых = СчПустых+1;
				Продолжить;
			КонецЕсли; 
			
			Попытка
				лТз[лтз.Количество()-1][iCount]=Строка(rs.Fields(iCount).Value);
				ПустыеСтроки = 0;
			Исключение
				Прервать;
			КонецПопытки;					
		КонецЦикла;
		rs.MoveNext();  
	КонецЦикла;
	rs=Неопределено;
	еБаза.Close();
	еБаза=Неопределено;
	УдалитьИзВременногоХранилища(Адрес);
	//Удалим первую строку с наименованием колонок
	Если лТз[0][0] = лТз.Колонки[0].Имя Тогда
		лТз.Удалить(лТз[0]);
	КонецЕсли; 
	
	Возврат лТз;
	
КонецФункции

 

9

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. CheBurator 3400 03.05.17 00:52 Сейчас в теме
на загрузку через ADO я плюнул много лет назад, когда при первой же попытке применить сей инструмент на первом же файле (а я промучался часа четыре) - выяснилось что из прайса ~10тысяч строк возвращается тупо порядка ~4000, хотя при обычном открытии экселем и обычным чтением из экселя все нормально проходило. и ADO на ДРУГИХ файлах - нормально проходило. А вот на этом - фигушки. так как я не спец в этих делах, а загрузку надо было ставить в автомат в продакшен - ADO благословеннно почил в бозе.. так я его и не освоил...
2. unichkin 1202 16.05.17 23:15 Сейчас в теме
Можно было лишние поля прямо в запросе отсеять.. Собственно, возможность указывать фильтр в запросе - одна из фишек ADO. Еще его используют когда:
- надо работать с Excell на сервере (а устанавливать его на сервер нельзя)
- надо читать большие объемы, без загрузки их в память (recordset) - в этом случае быстрее работает, чем перебор строк в Excell.Application
Но не всегда ADO выгоднее - его минусы в том, что всякий раз надо муздыкаться с драйверами. Локально у себя - все отлично, только передал клиенту, начинаются вопросы "что это он про какой-то драйвер спрашивает".. Поэтому для себя определился так, что ADO применять только в двух выше описанных случаях. А если файл небольшой, и работа идет на клиенте - вполне можно использовать чтение через Excell, работая с диапазонами (http://infostart.ru/public/20090/). Если все делать через range - в случае небольших книг по скорости не уступает ADO. Кстати, через range можно и записывать.
3. dakork 14 05.06.17 15:15 Сейчас в теме
Для использования ADO нет необходимости в установке msoffice.
4. KazanKokos 8 05.06.17 15:17 Сейчас в теме
сам когда делал выбор адо-неадо столкнулся с тем что не нашел в АДО уровень группировки строк, который есть в ексель.аппликейшн, а мне надо было загруженную номенклатуру раскидывать по папкам + еще прибавлять к имени номенклатуры названия папок двух верхних уровней и пришлось от АДО отказываться
Оставьте свое сообщение

См. также

Выгрузка из 1С номенклатуры со штрихкодами без программирования 3

Статья Программист Пользователь Стажер Нет файла v8 УТ11 Россия Бесплатно (free) Загрузка и выгрузка в Excel Внешние источники данных

Я так и не смог найти простой инструкции или обработки, чтобы выгрузить из 1С: Управление торговлей 11 номенклатуру вместе со штрихкодами, поэтому решил написать собственную инструкцию.

28.08.2019    1675    user1114182    4       

Загрузка картинок в справочники (Универсальная загрузка из табличного документа) 8

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Обработка справочников Загрузка и выгрузка в Excel

Пример загрузки картинок в справочник Номенклатура (с помощью обработки универсальная загрузка данных из табличного документа). Проверялось на конфигурации УТ 11.4.7.

28.05.2019    2156    rasdag    2       

Преобразование EXCEL в таблицу значений без COM и других извращений 208

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Получение таблицы значений из excel в 1С v8, без COM, внешних источников данных и т.д. EXCELВТаблицуЗначений() - За 10 строчек кода! Реализация протестирована на 1С 8.3.12.1714 (x64).

18.04.2019    12213    9    Eret1k    43       

Копирование числовых ячеек из 1С в Excel 26

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel Администрирование данных 1С

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    10597    itriot11    21       

Запись одной книги Excel на нескольких листах средствами 1С (без внешних компонент) 140

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Пользователи часто просят сохранить им стопиццот отчетов в один файл Excel, чтобы отчеты были в одном файле. Ну или клиент хочет счет, накладную и счет-фактуру получить в одном документе. 1С умеет это делать без всяких там COM-объектов. Давайте разберемся, куда нажимать и что крутить.

14.01.2019    11792    starik-2005    23       

Как легко загружать данные из электронных таблиц (Excel, OpenOffice и т.д) 35

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Как легко загружать данные из электронных таблиц (Excel, OpenOffice и т.д). На примере загрузки в табличную часть документа Поступление товаров и услуг в УТ 11.4.

09.01.2019    6793    rasdag    14       

Работа с Excel через COM 20

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel

Несколько примеров работы с excel (ms office 2010, в моем случае) через COM.

01.10.2018    5104    jaroslav.h    0       

Выгрузка в Excel с использованием формата OpenXML, разбор файла sheet1.xml 13

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Судя по количеству просмотров темы https://infostart.ru/public/900022/ решил описать структуру файла Листа excel. На полноту не претендую, опишу то, что знаю.

21.09.2018    4167    user1045404    2       

Excel: создание в формате xlsx без COM технологии 112

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

По работе приходится часто выгружать данные в Excel формате. При большом количестве строк и формул этот процесс достаточно длительный. Решил написать для своих целей небольшую библиотечку для выгрузки данных. Используется технология open-xml. Никаких библиотек не надо, пишу напрямую в xml файлики. На данном этапе сделано форматирование, формулы.

10.09.2018    7747    user1045404    16       

Из Excel в 1С запросом 33

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    13628    m-rv    5       

Загрузка из Excel в управляемом приложении 25

Статья Программист Нет файла v8::УФ Windows Бесплатно (free) Загрузка и выгрузка в Excel

С появлением управляемого интерфейса стали актуальными вопросы в давно освоенных приемах работы. В частности, загрузка из файла.

30.11.2017    21780    alex_bitti    15       

Функция сохранения картинок из книги Excel в каталог с определением координат на листе 8

Статья Программист Нет файла v8 Бесплатно (free) Загрузка и выгрузка в Excel Универсальные функции

Разбор файла *.xlsx как Web-архива, выгрузка изображений без потери качества, с определением положения изображений.

12.11.2017    7174    user634820_zergemoth    1       

Работа с Excel 289

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24988    arakelyan    39       

Невалидный XLSX при сохранении Табличного документа 3

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Ошибка открытия XLSX файлов, созданных при сохранении Табличного документа. (Невалидный формат файла)

21.10.2017    8835    saddy    3       

Загрузка значений свойств номенклатуры в Альфа-Авто с использованием обработки загрузки данных из табличного документа 15

Статья Программист Руководитель проекта Нет файла v8 1cv8.cf Автомобили, автосервисы Россия УУ Windows Учет ТМЦ Бесплатно (free) Загрузка и выгрузка в Excel

В публикации будет рассмотрено использование встроенной в отраслевую конфигурацию Альфа-Авто обработки по загрузке данных из табличного документа для заполнения значений дополнительных свойств номенклатуры.

13.10.2016    14237    miavolas    15       

Решение проблемы медленной загрузки из файла Excel, защищенного паролем 11

Статья Программист Нет файла v8 Россия Бесплатно (free) Загрузка и выгрузка в Excel

Столкнулся с проблемой загрузки из файла Excel. Загрузка занимала около получаса и не всегда заканчивалась успешно. Решение проблемы изложу в данной статье.

27.09.2016    7952    HAMMER_59    4       

Быстрая выгрузка больших плоских отчетов в Excel 22

Статья Программист Нет файла v8 Windows Бесплатно (free) Загрузка и выгрузка в Excel

Предлагаю способ для того, чтобы быстрее выгружать большие плоские отчеты из 1С 8 в Excel, без использования оперативной памяти на сервере и на клиенте, что очень важно, поскольку помогает избежать ошибок вида "Недостаточно памяти на клиенте" или "Недостаточно памяти на сервере". Не использует внешние компоненты. Минусы в том, что отчет выходит неформатированный, приходится настраивать ширину колонок, закрашивать границы, шрифты, жирность и т.п. Но когда отчет, выгружавшийся 3 часа, выгружается 20 минут, эти проблемы мои клиенты считают несущественными.

29.11.2015    12930    matveev.andrey.v    17       

Экспорт нескольких MXL таблиц в один XLS файл, на отдельные листы. Простой алгоритм 20

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Статья посвящена распространённому вопросу - как сохранить несколько таблиц (отчетов) в формате MXL, с которым работает 1С, на отдельные листы одного Excel файла. Освещается простой алгоритм решения проблемы штатными средствами, без использования внешних модулей и библиотек (не относящихся к 1С и Excel).

23.11.2015    13977    etmarket    14       

Внедрение адресного склада в логистическом операторе 25

Статья Системный администратор Программист Бизнес-аналитик Пользователь Нет файла v8 v8::ОУ УТ11 Оптовая торговля, дистрибуция, логистика Россия УУ Windows Оптовая торговля Розничная торговля Учет ТМЦ УСН Бесплатно (free) Загрузка и выгрузка в Excel Бухгалтерский учет Рабочее место

Каких-то 10 лет назад бюджет внедрений адресных складов составлял десятки тысяч долларов и месяцы работ целой команды, а теперь - типовое решение от 1С вполне рабочее и без кастомизации: немного интеграции, немного консультирования – и в продуктив. Внедрение адресного склада, в массе внедрений 1С:Управление торговлей, ред. 11.1 (далее УТ), штука до сих пор довольно-таки редкая. Данная статья описывает опыт одного маленького, но свежего внедрения адресного склада в УТ (11.1.10) и может быть интересна как практический кейс.

1 стартмани

10.08.2015    18412    papche    12       

Выгрузка таблицы значений в Excel 30

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel

Примитивно, грубо, без дизайна, но очень быстро.

28.06.2015    17156    Yashazz    31       

Скорость закачки с EXCEL при работе с большими файлами 26

Инструменты и обработки Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Производительность и оптимизация (HighLoad) Загрузка и выгрузка в Excel

Поставлена задача уменьшить время загрузки данных с EXCEL. Пока ждал ответа от разработчиков ядра, сам начал копать всё, что угодно. ЗАДАЧА решена, с чем спешу поделиться.

09.06.2015    13786    ybatiaev    31       

Чтение из Эксель-файла 9

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Некоторые выдержки из моих наработок, связанных с работой 1С и приложений майкрософт-оффис

26.05.2015    9960    nikitin19819    7       

Загрузка из EXCEL в 1С на платформе 8.3.6/8.3.7/8.3.8/8.3.9/8.3.10 (с картинками) 319

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Импорт содержимого из файлов в форматах XLS (Microsoft Excel 97), Microsoft Office OpenXML (Microsoft Excel 2007- 2010) и ODS (OpenDocument) в таблицу значений.

06.04.2015    206317    StepByStep    72       

Вывод таблицы значений в Excel 17

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Изложена методика вывода таблицы значений в Excel с помощью именованных ячеек.

21.01.2015    13216    scientes    6       

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним 78

Статья Программист Нет файла v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    70998    shmellevich    35       

Загрузка из EXCEL в 1С. Чтение файла XLSX средствами 1С. ПостроительDOM 100

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Универсальные обработки Загрузка и выгрузка в Excel Обмен через XML

ПРАКТИЧЕСКОЕ ПОСОБИЕ РАЗРАБОТЧИКА: Метод "NativeXLSX" (ПостроительDOM). Обрабатываются данные EXCEL типов: "Строка", "Число", "Дата" ("Время"), "Булево", "Процент", а также изображения.

11.09.2014    63388    StepByStep    26       

Простой способ программного сохранения больших отчетов из СКД в формат Excel 39

Статья Программист Нет файла v8::СКД 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel Универсальные функции

Перерыв весь интернет не смог найти простого способа сохранить отчет с большим числом строк в формате Excel. Везде предлагалось писать процедуры построчной записи, ADO, COMSafeArray и прочее. Метод же, используемый во всех найденный публикациях "Результат.Записать(ИмяФайла,ТипФайлаТабличногоДокумента.XLSX)", не работает при большом числе строк. Публикация http://infostart.ru/public/77128/ натолкнула на простую идею, которую и реализовал.

07.08.2014    27233    den_valley    14       

Преобразование Универсального отчета в сводную таблицу Excel. 6

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel

Тем, кто часто пользуется сводной таблицей Excel, неудобно использовать формат, который получается на выходе универсального отчета. т.к. Универсальный отчет строится с группировками, а данные для сводной таблицы нужны в плоском виде.

16.06.2014    14500    Mos    4       

Как предотвратить возникновение ошибки при одновременном обращении пользователя и обработки к Excel. 41

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel

Если открыт (или открыть) файл Excel (к которому будет обращаться обработка), и активировать какую-либо ячейку или любое диалоговое окно и при этом обработка обратится к этому файлу, то возникнет ошибка. Так же, ошибка может возникнуть, если обработка запустила один экземпляр Excel, если пользователь, во время работы обработки откроет другой файл Excel или тот, к которому обращается обработка, то этот файл откроется в том же экземпляре приложения Excel и тогда опять возможна ошибка. Как этого избежать?

30.03.2014    16781    akor77    13       

Загрузка из EXCEL в 1С. Чтение файла XLSX средствами 1С. ЧтениеXML 165

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel Обмен через XML

ПРАКТИЧЕСКОЕ ПОСОБИЕ РАЗРАБОТЧИКА: Метод "NativeXLSX" (ЧтениеXML). Обрабатываются данные EXCEL типов: "Строка", "Число", "Дата" ("Время"), "Булево", "Процент".

01.11.2013    96958    StepByStep    73       

Работа с Excel в фоновом задании 129

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel

Встала задача. По электронной почте приходят письма с вложениями таблиц Excel. Получение почты производится встроенным клиентом 1С фоновым заданием. Необходимо было по расписанию несколько раз в день извлекать из новых писем вложения и загружать из них данные. Тут я столкнулся с проблемой - работать с Excel в фоновом задании ни через COM, ни через ADO не удавалось. Вываливалась ошибка. Нигде в сети четкого решения проблемы я не обнаружил. В итоге, собирая информацию по крупицам из разных источников (порой и вовсе не связанных с 1с) и нескольких дней мучений все же я решил данную проблему. Ниже я опишу свое решение, чтобы помочь таким же, как я )

01.08.2013    56829    ltfriend    58       

Выгрузка Таблицы значений из 1С 8 в Excel с помощью MS ADO 38

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel

Функции для выгрузки Таблицы значений из 1С 8 в таблицу Excel с использованием объектов Microsoft ActiveX Data Objects (ADO) и Microsoft ActiveX Data Objects Extensions (ADOX).

10.06.2013    23779    AzagTot    17       

Подсистема "COMExchange": прямой доступ к EXCEL через ADO 8

Статья Системный администратор Программист Нет файла v8 1cv8.cf УТ10 УПП1 Россия Windows Бесплатно (free) Файловые протоколы обмена, FTP Загрузка и выгрузка в Excel Внешние источники данных

На примере этой, очень популярной, темы наглядно продемонстрированы нетривиальные возможности консоли запросов в составе подсистемы: 1. использование событий выполнения запроса (в том числе для запуска на выполнение других запросов) 2. запуск на выполнение запроса в цикле с подстановкой значений параметров из таблицы значений.

20.01.2013    21238    yuraos    7       

Загрузка из EXCEL в 1С. Список листов EXCEL 34

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Универсальные обработки Загрузка и выгрузка в Excel Обмен через XML

ПРАКТИЧЕСКОЕ ПОСОБИЕ РАЗРАБОТЧИКА: Методы получения списка листов файлов типа EXCEL. Поддерживаемые типы: *.xls,*.xlsx,*.ods,*.sxc.

30.11.2012    45790    StepByStep    5       

Функция получения массива из Экселя 18

Статья Программист Нет файла v8 Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel Универсальные функции

Функция, возвращающая содержимое эксель-файла в виде массива структур (работает в тонком клиенте и может результат передавать на сервер)

21.10.2012    5458    yermak    5       

Загрузка материалов из программы Командор Дизайнер в 1С: Бухгалтерия 8. 4

Статья Системный администратор Программист Нет файла v8 БП2.0 Россия БУ Windows Учет ТМЦ Бесплатно (free) Пользователю системы Загрузка и выгрузка в Excel Внешние источники данных

Komandor Designer - программа для проектирования шкафов купе. Ее используют многие предприятия, которые производят мебель. Также они используют для учета программу 1С. Поэтому возникает проблема обмена данными между этими программами. Что важно для плодотворного общения двух людей — правильно — они должны понимать друг друга, разговаривать на одном языке. То же правило и в нашем случае, программы должны одинаково правильно понимать, какой материал находится в заказе, расходе сырья по заказу.

22.08.2012    9353    knigula    1       

Обработка событий документов MS Office из 1С8.х. и кольцевые ссылки. 11

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Обработка событий документов MS Office из 1С8.х. Возникновение кольцевых ссылок при работе с документами MS Office из 1С8.х

18.07.2012    8242    План счетов    1       

Выгрузка данных в Excel 30

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel

Часто в ходе работы в 1С требуется выбирать данные одновременно из разных источников (справочников, документов, регистров и т.д.) и сохранять эту сводную информацию в формате Excel (*.xls) или Табличных документов 1С (*.mxl). Затем, с помощью универсальной обработки "Загрузка данных из табличного документа", можно загрузить данные, например, в другую базу. В данной статье представлен метод выгрузки информации во внешнюю таблицу через Табличный Документ с сохранением форматов данных.

15.06.2012    38175    volconok27    12       

Чтение файлов *.xlsx средствами 1С 8.2 134

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Загрузка и выгрузка в Excel

Формат файлов *.xlsx представляет собой фактически ZIP-архив, внутри которого находятся xml-файлы, что позволяет считывать значения ячеек исключительно средствами 1С 8.2

13.06.2012    31447    1249    Abadonna    43       

Функция получения таблицы значений из файла Excel 30

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel Универсальные функции

Функция получения таблицы значений из файла Excel. Использует запрос в среде самого Excel. Параметры функции: ПутьКФайлу (строка) - полный путь к файлу Excel ИмяНомерСтраницы - имя (строка) или порядковый номер (число) страницы файла Excel Заголовок (булево) - является ли первая строка строкой заголовка. Если Истина, то колонки будущей ТЗ проименуются из строки заголовка Excel, если Ложь, то колонки проименуются системно "F1", "F2" и т.д ПерваяСтрока (число) - номер первой строки считывания с листа Excel ВАЖНО!!! Типы колонок будущей ТЗ будут определяться типом первой строки данных Excel (именно данных, не заголовка). Поэтому важно соблюдать в Excel тип колонок данных Функцию достаточно разместить в общем модуле своей конфигурации.

31.05.2012    26585    sbv2005    8       

Обработка «Загрузка данных из табличного документа». Пример настроек и использование. 33

Статья Системный администратор Программист Нет файла v8 1cv8.cf Учет ТМЦ Бесплатно (free) Инструментарий разработчика Загрузка и выгрузка в Excel

Данный пример будет полезен программистам 1С и специалистам по «Управлению торговлей», которым необходимо автоматизировать загрузку в справочники и документы из внешних табличных документов. В частности тем, кому необходимо загрузить товары в документ «поступление товаров и услуг» из электронной накладной в формате xls.

30.05.2012    24957    sabob    6