Создание мульти-базовых отчетов. Все, что вы хотели об этом знать

Публикация № 803950

Разработка - Практика программирования

В статье описано создание отчета по данным из клиент-серверных баз кластера 1С. Подключение к базам осуществляется через com-соединение. В качестве примера создается отчет «Права доступа мульти-базовый», который оформлен в виде внешнего отчета с двумя вариантами выполнения. Для построения собственного отчета на базе описанного достаточно будет изменить функции «ПолучитьТекстЗапроса», в модуле объекта отчета и построить свой макет запроса. Также описан код вызова отчета путем нажатия кнопки с передачей параметров в макет запроса и форму отчета. Описание примера отчета показывает, что создание отчетов по нескольким базам данных в 1С, не является сверхсложной задачей и достигается простыми методами

     Рассмотрим пример создания внешнего отчета с двумя вариантами выполнения. Примеры разрабатывались на платформе 8.3.10.2561. Варианты созданы на базе таблиц и показывают "Роли пользователей" группируемые по "Профилям" с разворотом по базам данных и подразделениям. В первом варианте колонками отчета являются базы данных с разворотом по подразделениям. Этот вариант удобен для сравнения ролей одного пользователя по базам. Во втором варианте колонками отчета являются сами пользователи и этот вариант удобен для сравнения ролей пользователей с по одной базе данных. И так приступим.

  1. Создание реквизитов объекта отчета

      Для подключения к кластеру 1с нам понадобятся следующие реквизиты объекта отчета:                         
«Сервер» – IP адрес кластера серверов 1с, отличается от IP адреса 1с сервера, номером порта ;
«COM_соединение» – имя установленного com соединения (стандартное имя для текущей платформы - V83.COMConnector) .
      Для подключения к внешним базам данных создадим реквизиты:                
«СерверБазы» – IP адрес 1с сервера;        
«Пользователь» и  «Пароль» – логин и пароль пользователя.    
Дополнительные реквизиты:
    «ЭтаБаза» - содержит имя базы из которой запускается отчет;
    «ИмяВариантаНастроек» - имя выполняемого варианта настроек макета отчета.
Для хранения списка баз кластера 1с, создадим табличный реквизит «ТаблицаБаз» , содержащий следующие колонки : «Выбор» - тип «Булево»,  «ИмяБазы» и «ОписаниеБазы» тип «Строка».

Рис. 1.

     2. Создание формы отчета

     Продвинутые программисты могут пропустить этот раздел статьи, поскольку работа ведется исключительно в конструкторе формы.
Форму отчета создадим на базе двух закладок.  Сразу установим свойство формы, АитоматическоеСохранениеДанныхВНастройках = «Использовать».
Первая закладка «Настройки подключения к базам», включает в себя реквизиты необходимые, для создания com-подключений к базам данных кластера 1с.

     Рис. 2.

    Вторая закладка содержит непосредственно сам отчет. Для его создания создадим реквизиты «ДанныеРасшифровки»,  «НаименованиеТекущегоВарианта» с типом «Строка», и «Результат» с типом «ТабличныйДокумент». Отмечу, что имена реквизитов строго регламентированы.
Для удобства выбора варианта отчета создадим «Группу4», как «Обычная группа», установим свойство «Группировка» = «Горизонтальная» и поместим в нее реквизит  «НаименованиеТекущегоВарианта».  Откроем закладку конструктора формы, «Команды/Стандартные команды» и раскроем элемент «Форма». Выберем подчиненный элемент «Выбрать вариант» (Рис.3.) и перетащим его в «Группу4».  
Создадим панель управления отчетом путем перетаскивания  корневого элемента «Форма» на закладку «Отчет» .
Перейдем на закладку «Реквизиты» конструктора формы, раскроем объект «Отчет», подчиненный элемент «КомпановщикНастроек» и добавим на закладку «Отчет», элемент «ПользовательскиеНастройки». Установим свойство ПоложениеКоманднойПанели = «Нет», и уберем флаг «Шапка».
И последнее. Добавим реквизит «Результат», на закладку «Отчет».
Создание формы отчета на этом закончено. Переходим к программированию в модуле  формы отчета.

Рис. 3.

3. Процедуры и функции модуля формы

Код снабжен подробными комментариями и не нуждается в дополнительном разъяснении.

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
//  Если имя пользователя не заполнено то вызываем серверную процедуру ПолучитьПользователя(),
//	которая возвращает имя текущего пользователя
	Если Отчет.ИмяПользователя = "" Тогда 
		 Отчет.ИмяПользователя = ПолучитьПользователя();
	КонецЕсли;
         	 
	Если Отчет.COM_соединение = "" Тогда 
		 Отчет.COM_соединение = "V83.COMConnector";
	КонецЕсли;
	
// Плучим данные по серверам	
	СерверПолучить(); 
	
// Если табличный реквизит Отчет.ТаблицаБаз уже содержит записи, то предполагается, что эти записи с именами баз заполнены
// при вызове отчета из другой формы конфигурации, поэтому перейдем сразу на закладку отчет. 
// Если записи отсутствуют, то вызовем процедуру ПолучитьСписокБаз()
	Если Отчет.ТаблицаБаз.Количество() = 0 Тогда
		ПолучитьСписокБаз();
	Иначе 
		Элементы.Группа1.ТекущаяСтраница = Элементы.Группа1.ПодчиненныеЭлементы.Отчет;
	КонецЕсли;	
		
КонецПроцедуры

&НаСервере
Функция ПолучитьПользователя()
	Возврат (ПользователиИнформационнойБазы.ТекущийПользователь().Имя);
КонецФункции

&НаСервере
Процедура СерверПолучить()
	
	ИБ = СтрокаСоединенияИнформационнойБазы();
// Заполним имя текушей базы	
	Отчет.ЭтаБаза = Сред(ИБ,СтрНайти(ИБ,";")+6,((СтрДлина(ИБ)-(СтрНайти(ИБ,";")+6)))-1);

	Если не Отчет.Сервер = "" И не Отчет.СерверБазы = "" Тогда 
		 Возврат;
	КонецЕсли;
	
	П1 			= Сред(ИБ, 7, 32);
	СерверПорт 	= Лев(П1, СтрНайти(П1, "Ref")-3);
	
//	Поскольку IP адреса кластера 1с и сервера 1с могут отличаться, при нестандартных номерах портов, то адрес сервера 1с
// 	заносится в реквизит Отчет.СерверБазы, а адрес кластера 1с заносится в реквизит Отчет.Сервер
	Отчет.СерверБазы= СерверПорт;
	
	ДвоеточиеПоложение = СтрНайти(СерверПорт, ":");
	Если ДвоеточиеПоложение=0 Тогда
		Сервер = СерверПорт;
	Иначе
	//	Как правило номер порта кластера 1с на 1 меньше номера порта сервера 1с - вычислим этот порт.
		Сервер = Лев(СерверПорт, ДвоеточиеПоложение-1)+":"+СтрЗаменить((Число(Сред(СерверПорт, ДвоеточиеПоложение+1, 4)) -1), Символы.НПП, "");
	КонецЕсли;	
	Отчет.Сервер = Сервер;	
	
КонецПроцедуры

&НаСервере
Процедура ПолучитьСписокБаз()
	
//	 Создаем объект Соединитель 	
	Попытка
		Соединитель = Новый COMОбъект(Отчет.COM_соединение);
	Исключение
		Сообщить("Ошибка создания "+Отчет.COM_соединение+". "+ОписаниеОшибки());
		Возврат;
	КонецПопытки;
	
//	Подключаемся к агенту кластера 1с	
//  Если номера портов кластера и сервера 1с стандартные (1540 и 1541), то их можно не вводить
	Попытка	
		АгентСервера = Соединитель.ConnectAgent("tcp://" + Отчет.Сервер);
	Исключение
		Если СтрНайти(Отчет.Сервер, ":") > 1 Тогда
			Сообщить("Внимание!!! Проверьте номер порта. " + ОписаниеОшибки());
		Иначе	
			Сообщить("Ошибка создания агента сервера. " + ОписаниеОшибки());
		КонецЕсли;	
		Возврат;
	КонецПопытки;
	
// Загрузим кластеры сервера 1с	
    КластерыСерверов = АгентСервера.GetClusters().Выгрузить();
	Для Каждого Кластер Из КластерыСерверов Цикл
		
		Попытка
		//  Если Вы не являетесь администратором кластера серверов, то Вам придется раскомментировать
		// нижеследующую строку и ввести данные подключения к кластеру
			//АгентСервера.Authenticate(Кластер, АдминистраторКластера, ПарольАдмКластера);
			АгентСервера.Authenticate(Кластер, "", "");
		Исключение
			Сообщить(ОписаниеОшибки());
			Возврат ;
		КонецПопытки;	
		
// Загрузим список баз кластера в таблицу Отчет.ТаблицаБаз
		Базы = АгентСервера.GetInfoBases(Кластер).Выгрузить();
		Для каждого База Из Базы Цикл
			
				СтрТабБаз = Отчет.ТаблицаБаз.Добавить();
				СтрТабБаз.ИмяБазы = База.Name;
				СтрТабБаз.ОписаниеБазы = База.Descr;
				
		КонецЦикла;
		
		Прервать;
	КонецЦикла;	
	
КонецПроцедуры

&НаКлиенте
Процедура ОбновитьСписокБаз(Команда)  
	ПолучитьСписокБаз();
КонецПроцедуры

     На Рис. 4, представлен результат работы формы отчета, для закладки "Настройки подключения к базам"

Рис. 4.

4.    Создание макета отчета

     Создание макета отчета имеет некоторые особенности, поэтому необходимо этот раздел прочитать обязательно.
Откроем схему компоновки данных закладку «Наборы данных» и создадим «Набор данных – объект»-"ОтчетПоВнешнимДанным" . Создадим поля набора данных согласно Рис. 5. Установим «Имя объекта, содержащего данные» = ТаблицаДанных.

Рис. 5.

Перейдем на закладку «Ресурсы» и создадим ресурсы макета согласно Рис. 6.

Рис. 6.

Первый ресурс считает количество ролей, второй показывает доступность роли - "Да" или "Нет", для этого ресурса установим в колонке "Рассчитывать по...", значение "Роль".

Перейдем на закладку «Параметры» и создадим параметры согласно Рис. 7.

Рис. 7.

     Для параметра «ПрофилиГруппДоступа» установим тип «СправочникСсылка.ПрофилиГруппДоступа», для параметра «Пользователи» установим составной тип «СправочникСсылка.Пользователи, Строка»-составной тип сделан в связи с тем, что не во всех базах могут быть одинаковые списки пользователей. Поэтому открыта возможность ввести имя пользователя в ручную.  Необходимо особо отметить, что у параметров, кроме "ВариантОтчета", необходимо установить флаг «Доступен список значений». Параметр «ВариантОтчета», нам необходим для того, чтобы отслеживать имя выполняемого варианта отчета, в отборах по запросу он не участвует.

    Откроем закладку «Настройки», создадим два варианта отчета согласно Рис.8 и Рис.9  и для параметра «Вариант отчета» установим значения «Вариант1» и «Вариант2» соответственно. Единственным выбранным полем для вариантов отчета, является поле ресурс «РольДоступна».
Как видно из рисунков, варианты отчета выполнены в виде таблиц. Первый вариант разворачивает роли пользователя по базам данных и подразделениям. Второй вариант разворачивает роли базы данных и подразделения по пользователям. Для параметров "Пользователи" и "Вариант отчета" установим флаг "Включать в пользовательские настройки"

Рис. 8.

Рис. 9.

5. Модуль объекта отчета

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
	СтандартнаяОбработка = Ложь;
	
// Осуществим проверку на выбор баз для формирования отчета, и в случае если выбранных баз нет сформируем предупреждающее сообщение.	
	ПараметрыОтбора = Новый Структура;
	ПараметрыОтбора.Вставить("Выбор", Истина);
	СтрокиБаз = ТаблицаБаз.НайтиСтроки(ПараметрыОтбора);
	Если СтрокиБаз.Количество() = 0 Тогда
		Сообщить("Необходимо выбрать хотябы одну базу!");
		Возврат;
	КонецЕсли;	
	
// Создадим таблицу значений для формирования отчета.
// Имена полей возьмем из созданного нами набора данных "ОтчетПоВнешнимДанным", в макете отчета
	ТаблицаДляСКД = Новый ТаблицаЗначений;    
	ПоляНабораДанных = СхемаКомпоновкиДанных.НаборыДанных.ОтчетПоВнешнимДанным.Поля;
	Для каждого Строка из ПоляНабораДанных Цикл
		ТаблицаДляСКД.Колонки.Добавить(Строка.Поле);
	КонецЦикла;
	
// Цикл по массиву выбранных база. 	
	Для Каждого СтрТабБаз из СтрокиБаз Цикл
		
// Если имя базы совпадает с именем текущей базы, то обработаем запрос к текущей базе.
// Понятно, что подключаться к текущей базе данных через com-соединение довольно затратно по ресурсам, времени и поэтому не производительно.
// Поэтому этот процесс разделеяется в нижеследующем коде.
		Если СтрТабБаз.ИмяБазы = ЭтаБаза Тогда
			 РезультатЗапроса = ЗапросКТекущейБазе(СтрТабБаз.ИмяБазы);
		Иначе 
// иначе сформируем строку подключения к базе и вызовем процедуру запроса к внешней базе			 
			СтрокаКоннекта	 = "Srvr="""+СерверБазы+""";Ref="""+СтрТабБаз.ИмяБазы+""";Usr="""+ИмяПользователя+""";Pwd="""+Пароль+"""";
			РезультатЗапроса = ЗапосКВнешнейБазе(СтрокаКоннекта, СтрТабБаз.ИмяБазы);
		КонецЕсли;	
		
		Если РезультатЗапроса = Неопределено Тогда
			Продолжить;
		КонецЕсли;
		
		Для Каждого СтрТЗ Из РезультатЗапроса Цикл 
// Построчно перенесем результаты каждого запроса в таблицу значений "ТаблицаДляСКД" и добавим имя базы данных в соответствующую колонку		
			СтрТабСкд=ТаблицаДляСКД.Добавить();
			Для Каждого Колонка из ТаблицаДляСКД.Колонки Цикл
				Если Колонка.Имя = "ИмяБазыДанных" Тогда
					СтрТабСкд[Колонка.Имя] = СтрТабБаз.ИмяБазы;
				Иначе	
			    	СтрТабСкд[Колонка.Имя] = СтрТЗ[Колонка.Имя];
				КонецЕсли;	
			КонецЦикла;
			
		КонецЦикла;
		
	КонецЦикла;	
	
// Далее идет стандартный код формирования отчета из итоговой таблицы значений "ТаблицаДляСКД"
	ВнешнийНабор 	  	= Новый Структура("ТаблицаДанных", ТаблицаДляСКД);
	Настройки 		  	= КомпоновщикНастроек.Настройки;
	КомпоновщикМакета 	= Новый  КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки   	= КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки);
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, ВнешнийНабор);
	ПроцессорВывода 	= Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	ПроцессорВывода.Вывести(ПроцессорКомпоновки);
	
// Этот код сворачивает группировки до уровней профиля пользователя в зависимости от варианта отчета	
	Если ИмяВариантаНастроек = "Вариант1" Тогда
		ДокументРезультат.ПоказатьУровеньГруппировокСтрок(1);
	ИначеЕсли  ИмяВариантаНастроек = "Вариант2" Тогда
	    ДокументРезультат.ПоказатьУровеньГруппировокСтрок(2);
	КонецЕсли;
	
// Данный код является универсальным не зависимости от набора данных в макете отчета	
	
КонецПроцедуры

Функция ЗапосКВнешнейБазе(СтрокаКоннекта, ИмяБазы)	
	
//  Подключимся к внешней базе	
	Попытка
		Соединитель = Новый COMОбъект(COM_соединение);
	Исключение
		Ошибка = ОписаниеОшибки();
		Сообщить("Ошибка создания "+COM_соединение+". "+Ошибка);
		Возврат Неопределено;
	КонецПопытки;
	
	Попытка
		ДругаяБаза=Соединитель.Connect(СтрокаКоннекта);
	Исключение
		Ошибка = ОписаниеОшибки();
		Сообщить(Ошибка);
		Возврат Неопределено;
	КонецПопытки;
	
//	Создадим запрос во внешней базе
	Запрос = ДругаяБаза.NewObject("Запрос");
// 	Текст запроса у нас одинаков, как для внешней, так и для текущей базы  	
	Запрос.Текст = ПолучитьТекстЗапроса();
// Вызовем процедуру установки параметров запроса	
	УстановитьПараметрыЗапроса(Запрос, ДругаяБаза);

	Попытка
		ТЗ = Запрос.Выполнить().Выгрузить();
		Возврат(ТЗ);
	Исключение
		Ошибка = ОписаниеОшибки();
		Сообщить(Ошибка);
		Возврат Неопределено;
	КонецПопытки;
	
КонецФункции

Функция ЗапросКТекущейБазе(ИмяБазы)

//  Запрос к текущей базе является стандартным 
	Запрос = Новый Запрос;
	УстановитьПараметрыЗапроса(Запрос);

	Запрос.Текст = ПолучитьТекстЗапроса();
	ТЗ = Запрос.Выполнить().Выгрузить();
	
	Возврат ТЗ;
	
КонецФункции

Функция ПолучитьТекстЗапроса()
	
// Текст запроса по выходным полям строго соответствует именам полей набора данных в макете отчета.
// Все выходные поля запроса необходимо привести к простым типам: число, строка, дата, булево ...  
// Особо важно отметить, что имена параметров запроса строго согласованны с именами параметров макета отчета
// Поскольку используемая конфигурация является не стандартной, то для своей конфигурации необходимо будет запрос отредактировать.
// В тексте запроса даны пояснительные комментарии

	ТекстЗапроса =
	 "ВЫБРАТЬ
	 |	Таблица.Пользователь1С КАК Пользователь1С,
	 |	Таблица.ПользовательКод КАК ПользовательКод,
	 |	Таблица.ПользовательОС КАК ПользовательОС
	 |ПОМЕСТИТЬ ПользователиОС
	 |ИЗ
	 |	&ТаблицаПользователей КАК Таблица
	 |;
// Обратите внимание, для получения значения ПользовательОС и ПользовательКод в таблицу передается 
// параметр таблица значений "ТаблицаПользователей", которая формируется в процедуре УстановитьПараметрыЗапроса().	 
	 |
	 |////////////////////////////////////////////////////////////////////////////////
	 |ВЫБРАТЬ
	 |	ГруппыДоступаПользователи.Пользователь.Наименование КАК Пользователь,
	 |	ГруппыДоступа.Профиль.Наименование КАК Профиль,
	 |	ПрофилиГруппДоступаРоли.Роль КАК Роль,
	 |	ВЫБОР
	 |		КОГДА ПрофилиГруппДоступаРоли.Роль ЕСТЬ NULL
	 |			ТОГДА 0
	 |		ИНАЧЕ 1
	 |	КОНЕЦ КАК РольДоступна,
	 |	"""" КАК ИмяБазыДанных,
	 |	ПользователиПодразделения.Подразделение.Наименование КАК Подразделение,
	 |	ГруппыДоступаПользователи.Пользователь.Код КАК ПользовательКод
	 |ПОМЕСТИТЬ ПраваПользователей
	 |ИЗ
	 |	Справочник.ГруппыДоступа.Пользователи КАК ГруппыДоступаПользователи
	 |		ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ГруппыДоступа КАК ГруппыДоступа
	 |			ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ПрофилиГруппДоступа КАК ПрофилиГруппДоступа
	 |				ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.ПрофилиГруппДоступа.Роли КАК ПрофилиГруппДоступаРоли
	 |				ПО (ПрофилиГруппДоступаРоли.Ссылка = ПрофилиГруппДоступа.Ссылка)
	 |			ПО ГруппыДоступа.Профиль = ПрофилиГруппДоступа.Ссылка
	 |		ПО ГруппыДоступаПользователи.Ссылка = ГруппыДоступа.Ссылка
	 |		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Пользователи.Подразделения КАК ПользователиПодразделения
	 |		ПО ГруппыДоступаПользователи.Пользователь.Ссылка = ПользователиПодразделения.Ссылка
	 |ГДЕ
	 |	НЕ ГруппыДоступаПользователи.Ссылка.ЭтоГруппа
	 |	И НЕ ГруппыДоступаПользователи.Ссылка.ПометкаУдаления
	 |	И НЕ ГруппыДоступаПользователи.Пользователь.ПометкаУдаления
// Имя параметра начинающееся с "Использовать..." объединяется с значением самого параметра. 
// В результате если параметр "Использовать..." = Ложь, то значение объединенного параметра игнорируется. 
// Таким образом мы согласуем использование этих параметров с параметрами получаемыми из макета запроса
// Второй объединяемый параметр должен иметь условие "В списке значений".
	 |	И (НЕ &ИспользоватьПользователи
	 |			ИЛИ ГруппыДоступаПользователи.Пользователь.Наименование В (&Пользователи))
	 |	И (НЕ &ИспользоватьПрофилиГруппДоступа
	 |			ИЛИ ГруппыДоступа.Профиль.Наименование В (&ПрофилиГруппДоступа))
	 |
	 |ОБЪЕДИНИТЬ ВСЕ
	 |
// Особенностью запроса является, то что искусственно создается роль "Дополнительные настройки прав"
// для регистра сведений "Настройки пользователя".
	 |ВЫБРАТЬ
	 |	НастройкиПользователей.Пользователь.Наименование,
	 |	""Дополнительные настройки прав"",
	 |	НастройкиПользователей.Настройка.Наименование,
	 |	1,
	 |	"""",
	 |	ПользователиПодразделения.Подразделение.Наименование,
	 |	НастройкиПользователей.Пользователь.Код
	 |ИЗ
	 |	РегистрСведений.НастройкиПользователей КАК НастройкиПользователей
	 |		ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Пользователи.Подразделения КАК ПользователиПодразделения
	 |		ПО НастройкиПользователей.Пользователь = ПользователиПодразделения.Ссылка
	 |ГДЕ
	 |	НастройкиПользователей.Значение = ИСТИНА
	 |	И (НЕ &ИспользоватьПользователи
	 |			ИЛИ НастройкиПользователей.Пользователь.Наименование В (&Пользователи))
	 |	И НЕ &ИспользоватьПрофилиГруппДоступа
	 |;
	 |
	 |////////////////////////////////////////////////////////////////////////////////
	 |ВЫБРАТЬ
	 |	ПраваПользователей.Пользователь КАК Пользователь,
	 |	ПраваПользователей.Профиль КАК Профиль,
	 |	ПраваПользователей.Роль КАК Роль,
	 |	ПраваПользователей.РольДоступна КАК РольДоступна,
	 |	ПраваПользователей.ИмяБазыДанных КАК ИмяБазыДанных,
	 |	ПраваПользователей.Подразделение КАК Подразделение,
	 |	ЕСТЬNULL(ПользователиОС.ПользовательКод, ПраваПользователей.ПользовательКод) КАК ПользовательКод,
	 |	ЕСТЬNULL(ПользователиОС.ПользовательОС, """") КАК ПользовательОС
	 |ИЗ
	 |	ПраваПользователей КАК ПраваПользователей
	 |		ЛЕВОЕ СОЕДИНЕНИЕ ПользователиОС КАК ПользователиОС
	 |		ПО ПраваПользователей.Пользователь = ПользователиОС.Пользователь1С"
	 ;
	Возврат ТекстЗапроса;
	 
КонецФункции

Процедура УстановитьПараметрыЗапроса(Запрос, ДругаяБаза = Неопределено)
	
// Для передачи параметров в запрос, сформируем цикл по пользовательским настройкам	
	ПользовательскиеНастройкиЭлементы = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
	Для каждого Элемент из ПользовательскиеНастройкиЭлементы Цикл
		
		Если не Строка(Элемент) = "ЗначениеПараметраНастроекКомпоновкиДанных" Тогда
			Продолжить;
		КонецЕсли;
		
		ИмяПараметра = Строка(Элемент.Параметр); 
// Параметр вариат отчета в запрос не передается		
		Если ИмяПараметра = "ВариантОтчета" Тогда
			Продолжить;
		КонецЕсли;	
		
// Все другие параметры у нас имеют флаг "доступен список значений", поэтому для их передачи в запрос, создадим массив-"МассивПараметра".
// Понятно, что передача ссылок объектов в качестве параметров не имеет смысла поскольку одинаково названные объекты разных базах не будут равны.
// Как вариант можно осуществлять поиск ссылки объекта во внешней базе по наименованию и передавать уже массив ссылок в качестве параметра.
// Для параметра ТаблицаПользователей создадим таблицы значений с соответствующими полями
		Если ДругаяБаза = Неопределено Тогда
	
			МассивПараметра = Новый Массив;
			ТаблицаПользователей = Новый ТаблицаЗначений;
			ТаблицаПользователей.Колонки.Добавить("ПользовательОС", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64))); 
			ТаблицаПользователей.Колонки.Добавить("Пользователь1С", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64)));
			ТаблицаПользователей.Колонки.Добавить("ПользовательКод", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64)));
			
// Поскольку поля параметра ТаблицаПользователей - используется только в варианте 1, то и заполнять эту таблицу из массива пользователей, мы будем только для варианта отчета 1 
			Если ИмяВариантаНастроек = "Вариант1" Тогда
// Получим данные по пользователям функцией 1с	
				МассивПользователей = ПользователиИнформационнойБазы.ПолучитьПользователей();
			КонецЕсли;	
		Иначе
// Если параметр функции ДругаяБаза определен, то массив-"МассивПараметра" создается во внешней базе
			МассивПараметра = ДругаяБаза.NewObject("Массив"); 
// Передаваемый параметр таблица значений "ТаблицаПользователей", так же создадим в внешней базе
			ТаблицаПользователей = ДругаяБаза.NewObject("ТаблицаЗначений");
			ТаблицаПользователей.Колонки.Добавить("ПользовательОС", ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки", 64))); 
			ТаблицаПользователей.Колонки.Добавить("Пользователь1С", ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки", 64)));
			ТаблицаПользователей.Колонки.Добавить("ПользовательКод", ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки",64)));

// Для варианта отчета "Вариант1" заполним массив пользователей, для последующего копирования в таблицу значений "ТаблицаПользователей
			Если ИмяВариантаНастроек = "Вариант1" Тогда
				МассивПользователей = ДругаяБаза.ПользователиИнформационнойБазы.ПолучитьПользователей();
			КонецЕсли;	
		КонецЕсли;	
			
		Если Элемент.Использование и не Элемент.Значение = Неопределено Тогда
// Запишем значения параметров запроса в соответствующие массивы
// Отметим, что здесь применено правило автоматического формирования имени параметра запроса, 
// из имени параметра пользовательских настроек, которого необходимо строго придерживаться для автоматизации процесса программирования
			Если ТипЗнч(Элемент.Значение) = Тип("СправочникСсылка." + ИмяПараметра) Тогда
				 МассивПараметра.Добавить(СокрП(Элемент.Значение.Наименование));
			ИначеЕсли ТипЗнч(Элемент.Значение) = Тип("Строка") Тогда
				 МассивПараметра.Добавить(СокрП(Элемент.Значение));
			ИначеЕсли Элемент.Значение.Количество() > 0 Тогда
				Для каждого Параметр из Элемент.Значение Цикл 
					Если ТипЗнч(Параметр.Значение) = Тип("СправочникСсылка." + ИмяПараметра) Тогда
						МассивПараметра.Добавить(СокрП(Параметр.Значение.Наименование));
					Иначе
						МассивПараметра.Добавить(СокрП(Параметр.Значение));
					КонецЕсли;	
				КонецЦикла;
			Иначе
				Элемент.Использование = Ложь;
			КонецЕсли;
		Иначе
			Элемент.Использование = Ложь;
		КонецЕсли;
// Установим параметры в запрос. 	
		Запрос.УстановитьПараметр("Использовать" + ИмяПараметра, Элемент.Использование);
		Запрос.УстановитьПараметр(ИмяПараметра, МассивПараметра);
		
	КонецЦикла;
	
// Если используется вариант1 отчета, то заполним параметр "ТаблицаПользователей". 	
	Если ИмяВариантаНастроек = "Вариант1" Тогда
		Для Каждого Строка Из МассивПользователей Цикл
// В данном случае используются всего два поля таблицы "ПользователиИнформационнойБазы".
// Если Вам неолбходима и другая информация по пользователям, то ее легко здесь добавить
			НоваяСтрока = ТаблицаПользователей.Добавить(); 
			НоваяСтрока.Пользователь1С = Строка(Строка.ПолноеИмя);
			НоваяСтрока.ПользовательОС = Строка.ПользовательОС;
			НоваяСтрока.ПользовательКод = Строка.Имя;
			
		КонецЦикла;	
	КонецЕсли;
	
	Запрос.УстановитьПараметр("ТаблицаПользователей", ТаблицаПользователей);
	
// На код процедуры является универсальным (за исключение передачи параметра "ТаблицаПользователей")
// Одно из условий универсальности - установка флага "доступен список значений" и соответственно 
// в запросе параметры должны иметь условие "В списке значений"
// Второе условие универсальности - придерживаться правил наименования пользовательских параметров. 
// Таким образом, если исключить код создания и заполнения параметра "ТаблицаПользователей", процедура будет универсальна для всех отчетов.

КонецПроцедуры	


Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)

	Если Пароль="" Тогда
		Сообщить("Необходимо ввести пароль пользователя!");
		Отказ = Истина;
	КонецЕсли;
	

// Параметр "ВариантОтчета" используется для определения выполняемого варианта отчета.
// Установив значение параметра на стадии разработки макета отчета, мы легко получаем информацию о 
// текущем варианте отчета. 
	Настройки = КомпоновщикНастроек.ПолучитьНастройки();
	Если не Настройки = Неопределено Тогда
	// Заполняем реквизит ИмяВариантаНастроек	
		ИмяВариантаНастроек = Настройки.ПараметрыДанных.Элементы.Найти("ВариантОтчета").Значение;
	КонецЕсли;
	
КонецПроцедуры

Фактически данный отчет можно использовать в качестве шаблона для построения других мульти-базовых отчетов. Если придерживаться предложенных правил наименований пользовательских параметров, редактируется только процедура «ПолучитьТекстЗапроса» и макет отчета. Варианты сформированного отчета представлены на Рис. 10 и Рис. 11.

Рис. 10.

Рис. 11.

     6. Вызываем отчет из другой формы

Для вызова отчета нам необходимо сохранить его в справочнике «Дополнительные отчеты и обработки» конфигурации. Далее следуют процедуры и функции модуля формы, кнопки «ОткрытьОтчет».

&НаКлиенте
Процедура ОткрытьОтчет(Команда)
	
	ИмяОтчета = "ПраваДоступаМультибвзоый";
	
// 	Для загрузки внешнего отчета в стандартных конфигурациях можно воспользоваться готовой процедурой, 
//  которая расположена в общем модуле - ДополнительныеОтчетыИОбработки.ПодключитьВнешнююОбработку	
//  Мы не ищем легких путей и напишем такую процедуру сами.
	ИмяОбработки = ЗагрузитьВнешнююОбработку(ИмяОтчета);
	Если ИмяОбработки = Неопределено Тогда
		Сообщить("Отчет " + ИмяОтчета + "не найден в базе данных!");
		Возврат; 
	КонецЕсли;
	
// Получаем форму и из нее достаем КомпоновщикНастроекКомпоновкиДанных.ПользовательскиеНастройки	
	Форма = ПолучитьФорму("ВнешнийОтчет."+ ИмяОбработки +".Форма");
	КомпоновщикНастроекКомпоновкиДанных = Форма.Отчет.КомпоновщикНастроек;
	ПользовательскиеНастройки = КомпоновщикНастроекКомпоновкиДанных.ПользовательскиеНастройки;
	
	ПолеКомпановкиПараметр = Новый ПараметрКомпоновкиДанных("ИмяПользователя");
	Для Каждого Элемент Из ПользовательскиеНастройки.Элементы Цикл
		
		Если ТипЗнч(Элемент) = Тип("ЗначениеПараметраНастроекКомпоновкиДанных") и Элемент.Параметр = ПолеКомпановкиПараметр Тогда
// В функции ПолучитьСписокПользователей() мы возвращаем СписокЗначений с занесенными в него ФИО пользователей с типом строка
// Как заполнить этот список, полностью ваша задача, для примера введено два пользователя 
			Список = ПолучитьСписокПользователей(); 
			Если Список =  Неопределено Тогда
				Продолжить;
			КонецЕсли;
// Заполняем параметр отчета "ИмяПользователя"			
			Элемент.Значение = Список;
            Элемент.Использование = Истина;
            Прервать;
			
		КонецЕсли;
		
	КонецЦикла;
	
// Получим имя команды дополнительного отчета	
    ВыполняемаяКоманда = ПолучитьПараметрыКомандыВнешнегоОтчета(ИмяОтчета);
	Если ВыполняемаяКоманда = Неопределено Тогда 
		Возврат; 
	КонецЕсли;
	
    ПараметрыОбработки = Новый Структура("ИдентификаторКоманды, ДополнительнаяОбработкаСсылка, ИмяФормы, КлючСессии, ПользовательскиеНастройки, СформироватьПриОткрытии");
    ПараметрыОбработки.ИдентификаторКоманды          = ВыполняемаяКоманда.Идентификатор;
    ПараметрыОбработки.ДополнительнаяОбработкаСсылка = ВыполняемаяКоманда.Ссылка;
    ПараметрыОбработки.ИмяФормы                      = Неопределено;
    ПараметрыОбработки.КлючСессии                    = ВыполняемаяКоманда.Ссылка.УникальныйИдентификатор();
	//ПараметрыОбработки.СформироватьПриОткрытии       = Истина;	
	ПараметрыОбработки.СформироватьПриОткрытии       = Ложь;
	
//  Установим пользовательские настройки в отчет	
	ПараметрыОбработки.ПользовательскиеНастройки     = ПользовательскиеНастройки;
	
	Форма = ПолучитьФорму("ВнешнийОтчет."+ ИмяОбработки +".Форма", ПараметрыОбработки);
	
//Форма получена, можно заполнить список баз. Для примера добавленно имя двух баз	
	ТаблицаБаз = Форма.Отчет.ТаблицаБаз;
	СтрТабБаз = ТаблицаБаз.Добавить();
	СтрТабБаз.ИмяБазы = "База1";
	СтрТабБаз.ОписаниеБазы = "Добавлено программно";
	СтрТабБаз.Выбор = Истина;
	СтрТабБаз = ТаблицаБаз.Добавить();
	СтрТабБаз.ИмяБазы = "База2";
	СтрТабБаз.ОписаниеБазы = "Добавлено программно";
	СтрТабБаз.Выбор = Истина;
// Занесение имен баз непосредственно в таблицу формы отчета не позволяет нам сразу выполнить отчет при открытии
// поэтому строка - ПараметрыОбработки.СформироватьПриОткрытии = Истина закомментирована. При желании этот вопрос
// можно решить путем создания параметра СписокБаз и передавать в этот параметр имена баз. Правда код процедуры ПриКомпоновкеРезультата
// в модуле объекта отчета, необходимо будет переделать. Организовать цикл по выбранным именам баз, по значениям элементов этого параметра.
// Код конечно усложнится, но, что ни сделаешь для удовлетворения желаний заказчика. Зато отчет будет выполняться при открытии отчета.

// Список пользователей заполнен, список баз заполнен - можно открыть отчет.	
	ОткрытьФорму(Форма);

КонецПроцедуры

&НаСервере
Функция ЗагрузитьВнешнююОбработку(ИмяОбъекта, БезопасныйРежим = Ложь)
	
// Общий модуль - ДополнительныеОтчетыИОбработки.ПодключитьВнешнююОбработку	
	УстановитьПривилегированныйРежим(Истина);
	
// Получаем двоичный код обработки из справочника	
	ВнешняяОбработкаСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяОбъекта);
	Если ВнешняяОбработкаСсылка = Неопределено Тогда
		Возврат Неопределено;
	КонецЕсли;
	
	ДвоичныеДанныеОбработки = ВнешняяОбработкаСсылка.ХранилищеОбработки.Получить();
	АдресВоВременномХранилище = ПоместитьВоВременноеХранилище(ДвоичныеДанныеОбработки);

	Если ВнешняяОбработкаСсылка.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.Отчет
	 ИЛИ ВнешняяОбработкаСсылка.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительныйОтчет Тогда
	 
		Возврат ВнешниеОтчеты.Подключить(АдресВоВременномХранилище,, БезопасныйРежим);
		
	ИначеЕсли ВнешняяОбработкаСсылка.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительнаяОбработка Тогда
		
		Возврат ВнешниеОбработки.Подключить(АдресВоВременномХранилище,, БезопасныйРежим);
		
	Иначе 
		Сообщить("Объект не является внешней обработкой или отчетом.", СтатусСообщения.БезСтатуса);
	КонецЕсли;


КонецФункции

&НаСервере
Функция ПолучитьПараметрыКомандыВнешнегоОтчета(ИмяОтчета)
	
	ОтчетСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяОтчета);
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Ссылка", ОтчетСсылка);
    Запрос.Текст =
    "ВЫБРАТЬ
    |   ТаблицаКоманды.Ссылка,
    |   ТаблицаКоманды.Идентификатор,
    |   ТаблицаКоманды.ВариантЗапуска,
    |   ТаблицаКоманды.Представление КАК Представление,
    |   ТаблицаКоманды.ПоказыватьОповещение,
    |   ТаблицаКоманды.Модификатор
    |ИЗ
    |   Справочник.ДополнительныеОтчетыИОбработки.Команды КАК ТаблицаКоманды
    |ГДЕ
    |   ТаблицаКоманды.Ссылка = &Ссылка"
	;

    Результат = Запрос.Выполнить().Выбрать();

    Если Результат.Количество() = 0 Тогда
        Возврат Неопределено;
	Иначе		
	// При условии, чио команда отчета 1 одна цикла нет	
        Результат.Следующий();
        ВыполняемаяКоманда = Новый Структура(
        "Ссылка, Представление,
        |Идентификатор, ВариантЗапуска, ПоказыватьОповещение,
        |Модификатор, ОбъектыНазначения, ЭтоОтчет, Вид");

        ЗаполнитьЗначенияСвойств(ВыполняемаяКоманда, Результат);  
		ВыполняемаяКоманда.ЭтоОтчет = Истина;
    	ВыполняемаяКоманда.Вид      = Перечисления.ВидыДополнительныхОтчетовИОбработок.Отчет;

        Возврат ВыполняемаяКоманда;
		
	КонецЕсли;
	
КонецФункции

&НаСервере
Функция ПолучитьСписокПользователей()
	
	СписокЗнч = Новый СписокЗначений; 
	Пользователь = Справочники.Пользователи.НайтиПоНаименованию("Пользователь 1");
	СписокЗнч.Добавить(Пользователь);
	Пользователь = Справочники.Пользователи.НайтиПоНаименованию("Пользователь 2");
	СписокЗнч.Добавить(Пользователь);
	
	Возврат СписокЗнч;
	
КонецФункции

На рисунках Рис. 12  и Рис. 13 показаны закладки отчета после нажатия кнопки «ОткрытьОтчет»

Рис. 12.

Рис. 13.

    В версии 1.1 добавлена возможность отбора пользователей по логину операционной системы и ФИО пользователя, с условием подобия (Рис. 14). Очень удобное дополнение для администратора. Можно зная часть логина или ФИО пользователя посмотреть его права в базах данных. Файл меньше так как удалены подробные комментарии.

Рис. 14.  

Для получения универсальной обработки параметра в коде процедуры, с условием подобно, используется ключевая последовательность символов в имени параметра "подобно" - Рис. 15.

Рис. 15.

    Код процедуры УстановитьПараметрыЗапроса, изменен следующим образом:

Процедура УстановитьПараметрыЗапроса(Запрос, ДругаяБаза = Неопределено)
	
	Для каждого Элемент из КомпоновщикНастроек.ПользовательскиеНастройки.Элементы Цикл
		
		Если не Строка(Элемент) = "ЗначениеПараметраНастроекКомпоновкиДанных" Тогда
			Продолжить;
		КонецЕсли;
		
		ИмяПараметра = Строка(Элемент.Параметр); 
		Если ИмяПараметра = "ВариантОтчета" Тогда
			Продолжить;
		КонецЕсли;	
		
		Если ДругаяБаза = Неопределено Тогда
			МассивПараметра = Новый Массив;
			ТаблицаПользователей = Новый ТаблицаЗначений;
			ТаблицаПользователей.Колонки.Добавить("ПользовательОС", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64))); 
			ТаблицаПользователей.Колонки.Добавить("Пользователь1С", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64)));
			ТаблицаПользователей.Колонки.Добавить("ПользовательКод", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64)));

			Если ИмяВариантаНастроек = "Вариант1" Тогда
				МассивПользователей = ПользователиИнформационнойБазы.ПолучитьПользователей();
			КонецЕсли;	
		Иначе	
			МассивПараметра = ДругаяБаза.NewObject("Массив"); 
			ТаблицаПользователей = ДругаяБаза.NewObject("ТаблицаЗначений");
			ТаблицаПользователей.Колонки.Добавить("ПользовательОС",  ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки", 64))); 
			ТаблицаПользователей.Колонки.Добавить("Пользователь1С",  ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки", "64")));
			ТаблицаПользователей.Колонки.Добавить("ПользовательКод", ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки", "64")));
			Если ИмяВариантаНастроек = "Вариант1" Тогда
				МассивПользователей = ДругаяБаза.ПользователиИнформационнойБазы.ПолучитьПользователей();
			КонецЕсли;	
		КонецЕсли;	
			
		Если Элемент.Использование и не Элемент.Значение = Неопределено Тогда
			
			ТипЗнчЭлемента = ТипЗнч(Элемент.Значение);
			Попытка 
				ТипСправочник = Тип("СправочникСсылка." + ИмяПараметра);
			Исключение
				ТипСправочник = Неопределено;
			КонецПопытки;	

			Если ТипЗнчЭлемента = Тип("Строка") Тогда
				ЭлементЗначение = СокрЛП(Элемент.Значение);
// Обработка заполненных параметров с условием "подобно"
				Если СтрНайти(ИмяПараметра, "подобно")>1 Тогда
					ЭлементЗначение =  "%"+ЭлементЗначение+"%";
					Запрос.УстановитьПараметр("Использовать" + ИмяПараметра, Истина);
					Запрос.УстановитьПараметр(ИмяПараметра, ЭлементЗначение);
					Продолжить;
			   	КонецЕсли;
				МассивПараметра.Добавить(ЭлементЗначение);
			ИначеЕсли ТипЗнчЭлемента = ТипСправочник Тогда
				 МассивПараметра.Добавить(СокрП(Элемент.Значение.Наименование));
			ИначеЕсли Элемент.Значение.Количество() > 0 Тогда
				Для каждого Параметр из Элемент.Значение Цикл 
					Если ТипСправочник <> Неопределено и ТипЗнч(Параметр.Значение) = ТипСправочник Тогда
						МассивПараметра.Добавить(СокрП(Параметр.Значение.Наименование));
					Иначе
						МассивПараметра.Добавить(СокрП(Параметр.Значение));
					КонецЕсли;	
				КонецЦикла;
			Иначе
				Элемент.Использование = Ложь;
			КонецЕсли;
		Иначе
			Элемент.Использование = Ложь;
// Обработка пустых параметров с условием "подобно"
			Если СтрНайти(ИмяПараметра, "подобно")>1 Тогда
				Запрос.УстановитьПараметр("Использовать" + ИмяПараметра, Элемент.Использование);
				Запрос.УстановитьПараметр(ИмяПараметра, "% %");
				Продолжить;
			КонецЕсли;				
		КонецЕсли;
	
		Запрос.УстановитьПараметр("Использовать" + ИмяПараметра, Элемент.Использование);
		Запрос.УстановитьПараметр(ИмяПараметра, МассивПараметра);
		
	КонецЦикла;
	
	Если ИмяВариантаНастроек = "Вариант1" Тогда
		Для Каждого Строка Из МассивПользователей Цикл
			
			НоваяСтрока = ТаблицаПользователей.Добавить(); 
			НоваяСтрока.Пользователь1С = Строка(Строка.ПолноеИмя);
			НоваяСтрока.ПользовательОС = Строка.ПользовательОС;
			НоваяСтрока.ПользовательКод = Строка.Имя;
			
		КонецЦикла;	
	КонецЕсли;
	
	Запрос.УстановитьПараметр("ТаблицаПользователей", ТаблицаПользователей);
	
КонецПроцедуры

Соответственно в запросе устанавливаем отборы на выходной запрос:

     |ГДЕ
     |    (НЕ &ИспользоватьПользовательОСподобно
     |            ИЛИ ПользователиОС.ПользовательОС ПОДОБНО &ПользовательОСподобно)
     |    И (НЕ &ИспользоватьФИОпользователя_подобно
     |            ИЛИ ПраваПользователей.Пользователь ПОДОБНО &ФИОпользователя_подобно)

Таким образом мы можем добавлять любые отборы по символьным полям запроса с условием - ПОДОБНО.

Скачать файлы

.erf.erf.epf
Наименование Файл Версия Размер
ПраваДоступаМультибвзоыйОтчет

.erf 18,90Kb
10.10.18
0
1.1 18,90Kb Скачать
ПраваДоступаМультибвзоыйОтчет

.erf 21,09Kb
22.03.18
3
21,09Kb 3 Скачать
ОткрытьДополнительныйОтчетСПараметрами

.epf 7,84Kb
22.03.18
2
7,84Kb 2 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    29973    10    tormozit    44    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    14137    17    sapervodichka    41    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

1 стартмани

07.10.2019    26328    14    HostHost    40    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    16891    11    Dementor    30    

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    17144    4    m-rv    86    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    20647    21    Stepa86    44    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    31346    13    vasilev2015    57    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    26092    76    Evil Beaver    119    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    27469    86    m-rv    57    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    26497    19    Hatson    22    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    29361    32    riposte    63    

Баг или фича? Неожиданное поведение платформы

Практика программирования Тестирование и исправление Разработка v8 1cv8.cf Абонемент ($m)

Рассмотрим несколько случаев неожиданного поведения платформы 1С, а также что с этим можно cделать.

18.02.2019    21356    0    YPermitin    89    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    25301    19    mvxyz    17    

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX

Универсальные обработки Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    26485    90    Synoecium    46    

Отладка сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    24373    84    maxx    58    

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере"

Практика программирования v8 1cv8.cf Абонемент ($m)

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    20675    16    dmitry1975    32    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    24935    65    vasvl123    9    

Использование подсистемы БСП "Заполнение объектов"

Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем) v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Применение механизмов БСП для добавления новых команд заполнения к формам различных объектов. Использование расширений конфигурации для доработки. Шаблоны для реализации собственных команд заполнения.

1 стартмани

23.11.2018    23528    12    ids79    23    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    30481    48    dsdred    15    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    25266    25    informa1555    26    

Работа с публикациями "Инфостарт" Промо

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    18707    12    RocKeR_13    16    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    38977    17    kalyaka    16    

HTTP Сервисы: Путь к своему сервису. Часть 1

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    73112    23    dsdred    24    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    27236    11    SITR-utyos    13    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    25548    8    wowik    3    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    40840    33    dsdred    36    

Работа со схемой запроса

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    40764    85    kalyaka    34    

Асинхронная запись и чтение файла без использования модальных методов и временных файлов

Практика программирования v8 1cv8.cf Абонемент ($m)

В статье рассмотрено решение задачи формирования и записи файла на основе данных информационной базы. Формирование происходит на стороне сервера с помощью механизма потоков. Используются асинхронные методы передачи файлов между клиентом и сервером. Также рассмотрено решение обратной задачи - чтение файла и запись его данных в информационную базу. Статья ориентирована прежде всего на новичков, также приведенный код может использоваться в качестве шаблона.

1 стартмани

10.04.2018    26133    19    Alxby    23    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    44591    36    Demanoidos    60    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    32994    54    rpgshnik    48    

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула

Печатные формы документов Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    36326    27    agent00mouse    0    

Практика доступа в базу 1С через протокол oData. Чтение данных

Сервисные утилиты Практика программирования Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    86812    299    Dementor    47    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    68660    206    ildarovich    117    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    24724    49    kwazi    6    

Простой бесплатный DashBoard с помощью http сервиса

Практика программирования v8 Абонемент ($m)

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    51646    63    dewersia    32    

Полезный код для программистов 1С (часть 1). Управление свойствами элементов формы. Хранение копии данных реквизитов

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

У каждого программиста за время работы накапливается полезный инструментарий, которым он привык пользоваться. Естественно и у меня он тоже имеется. И вот решено было немного поделиться с сообществом. Возможно идеи не новые. Более того, допускаю, что реализованы они не самым оптимальным образом. Но ведь для этого сообщество и существует, чтобы делиться с ним, получая обратную связь.

1 стартмани

24.09.2017    39911    15    vandalsvq    80    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    47681    32    ildarovich    41    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    28819    127    PLAstic    54    

Макеты СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Рассмотрены некоторые типовые задачи, которые решаются с помощью предопределенных макетов, а также перечислены несколько случаев, для которых макеты не подходят

1 стартмани

25.07.2017    90399    122    json    27    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    115681    13    signum2009    46    

Простой способ индексирования интервалов Промо

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    38027    38    ildarovich    22    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    47195    15    DarkAn    86    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    28481    111    romasna    49    

Разбираемся с механизмом Дополнительные отчеты и обработки в БСП

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Чуть более комплексное описание, чем на других ресурсах

1 стартмани

30.10.2016    139661    946    json    66    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    34071    95    json    25