Создание мульти-базовых отчетов. Все, что вы хотели об этом знать

Публикация № 803950

Разработка - Практика программирования

В статье описано создание отчета по данным из клиент-серверных баз кластера 1С. Подключение к базам осуществляется через com-соединение. В качестве примера создается отчет «Права доступа мульти-базовый», который оформлен в виде внешнего отчета с двумя вариантами выполнения. Для построения собственного отчета на базе описанного достаточно будет изменить функции «ПолучитьТекстЗапроса», в модуле объекта отчета и построить свой макет запроса. Также описан код вызова отчета путем нажатия кнопки с передачей параметров в макет запроса и форму отчета. Описание примера отчета показывает, что создание отчетов по нескольким базам данных в 1С, не является сверхсложной задачей и достигается простыми методами

     Рассмотрим пример создания внешнего отчета с двумя вариантами выполнения. Примеры разрабатывались на платформе 8.3.10.2561. Варианты созданы на базе таблиц и показывают "Роли пользователей" группируемые по "Профилям" с разворотом по базам данных и подразделениям. В первом варианте колонками отчета являются базы данных с разворотом по подразделениям. Этот вариант удобен для сравнения ролей одного пользователя по базам. Во втором варианте колонками отчета являются сами пользователи и этот вариант удобен для сравнения ролей пользователей с по одной базе данных. И так приступим.

  1. Создание реквизитов объекта отчета

      Для подключения к кластеру 1с нам понадобятся следующие реквизиты объекта отчета:                         
«Сервер» – IP адрес кластера серверов 1с, отличается от IP адреса 1с сервера, номером порта ;
«COM_соединение» – имя установленного com соединения (стандартное имя для текущей платформы - V83.COMConnector) .
      Для подключения к внешним базам данных создадим реквизиты:                
«СерверБазы» – IP адрес 1с сервера;        
«Пользователь» и  «Пароль» – логин и пароль пользователя.    
Дополнительные реквизиты:
    «ЭтаБаза» - содержит имя базы из которой запускается отчет;
    «ИмяВариантаНастроек» - имя выполняемого варианта настроек макета отчета.
Для хранения списка баз кластера 1с, создадим табличный реквизит «ТаблицаБаз» , содержащий следующие колонки : «Выбор» - тип «Булево»,  «ИмяБазы» и «ОписаниеБазы» тип «Строка».

Рис. 1.

     2. Создание формы отчета

     Продвинутые программисты могут пропустить этот раздел статьи, поскольку работа ведется исключительно в конструкторе формы.
Форму отчета создадим на базе двух закладок.  Сразу установим свойство формы, АитоматическоеСохранениеДанныхВНастройках = «Использовать».
Первая закладка «Настройки подключения к базам», включает в себя реквизиты необходимые, для создания com-подключений к базам данных кластера 1с.

     Рис. 2.

    Вторая закладка содержит непосредственно сам отчет. Для его создания создадим реквизиты «ДанныеРасшифровки»,  «НаименованиеТекущегоВарианта» с типом «Строка», и «Результат» с типом «ТабличныйДокумент». Отмечу, что имена реквизитов строго регламентированы.
Для удобства выбора варианта отчета создадим «Группу4», как «Обычная группа», установим свойство «Группировка» = «Горизонтальная» и поместим в нее реквизит  «НаименованиеТекущегоВарианта».  Откроем закладку конструктора формы, «Команды/Стандартные команды» и раскроем элемент «Форма». Выберем подчиненный элемент «Выбрать вариант» (Рис.3.) и перетащим его в «Группу4».  
Создадим панель управления отчетом путем перетаскивания  корневого элемента «Форма» на закладку «Отчет» .
Перейдем на закладку «Реквизиты» конструктора формы, раскроем объект «Отчет», подчиненный элемент «КомпановщикНастроек» и добавим на закладку «Отчет», элемент «ПользовательскиеНастройки». Установим свойство ПоложениеКоманднойПанели = «Нет», и уберем флаг «Шапка».
И последнее. Добавим реквизит «Результат», на закладку «Отчет».
Создание формы отчета на этом закончено. Переходим к программированию в модуле  формы отчета.

Рис. 3.

3. Процедуры и функции модуля формы

Код снабжен подробными комментариями и не нуждается в дополнительном разъяснении.

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
//  Если имя пользователя не заполнено то вызываем серверную процедуру ПолучитьПользователя(),
//	которая возвращает имя текущего пользователя
	Если Отчет.ИмяПользователя = "" Тогда 
		 Отчет.ИмяПользователя = ПолучитьПользователя();
	КонецЕсли;
         	 
	Если Отчет.COM_соединение = "" Тогда 
		 Отчет.COM_соединение = "V83.COMConnector";
	КонецЕсли;
	
// Плучим данные по серверам	
	СерверПолучить(); 
	
// Если табличный реквизит Отчет.ТаблицаБаз уже содержит записи, то предполагается, что эти записи с именами баз заполнены
// при вызове отчета из другой формы конфигурации, поэтому перейдем сразу на закладку отчет. 
// Если записи отсутствуют, то вызовем процедуру ПолучитьСписокБаз()
	Если Отчет.ТаблицаБаз.Количество() = 0 Тогда
		ПолучитьСписокБаз();
	Иначе 
		Элементы.Группа1.ТекущаяСтраница = Элементы.Группа1.ПодчиненныеЭлементы.Отчет;
	КонецЕсли;	
		
КонецПроцедуры

&НаСервере
Функция ПолучитьПользователя()
	Возврат (ПользователиИнформационнойБазы.ТекущийПользователь().Имя);
КонецФункции

&НаСервере
Процедура СерверПолучить()
	
	ИБ = СтрокаСоединенияИнформационнойБазы();
// Заполним имя текушей базы	
	Отчет.ЭтаБаза = Сред(ИБ,СтрНайти(ИБ,";")+6,((СтрДлина(ИБ)-(СтрНайти(ИБ,";")+6)))-1);

	Если не Отчет.Сервер = "" И не Отчет.СерверБазы = "" Тогда 
		 Возврат;
	КонецЕсли;
	
	П1 			= Сред(ИБ, 7, 32);
	СерверПорт 	= Лев(П1, СтрНайти(П1, "Ref")-3);
	
//	Поскольку IP адреса кластера 1с и сервера 1с могут отличаться, при нестандартных номерах портов, то адрес сервера 1с
// 	заносится в реквизит Отчет.СерверБазы, а адрес кластера 1с заносится в реквизит Отчет.Сервер
	Отчет.СерверБазы= СерверПорт;
	
	ДвоеточиеПоложение = СтрНайти(СерверПорт, ":");
	Если ДвоеточиеПоложение=0 Тогда
		Сервер = СерверПорт;
	Иначе
	//	Как правило номер порта кластера 1с на 1 меньше номера порта сервера 1с - вычислим этот порт.
		Сервер = Лев(СерверПорт, ДвоеточиеПоложение-1)+":"+СтрЗаменить((Число(Сред(СерверПорт, ДвоеточиеПоложение+1, 4)) -1), Символы.НПП, "");
	КонецЕсли;	
	Отчет.Сервер = Сервер;	
	
КонецПроцедуры

&НаСервере
Процедура ПолучитьСписокБаз()
	
//	 Создаем объект Соединитель 	
	Попытка
		Соединитель = Новый COMОбъект(Отчет.COM_соединение);
	Исключение
		Сообщить("Ошибка создания "+Отчет.COM_соединение+". "+ОписаниеОшибки());
		Возврат;
	КонецПопытки;
	
//	Подключаемся к агенту кластера 1с	
//  Если номера портов кластера и сервера 1с стандартные (1540 и 1541), то их можно не вводить
	Попытка	
		АгентСервера = Соединитель.ConnectAgent("tcp://" + Отчет.Сервер);
	Исключение
		Если СтрНайти(Отчет.Сервер, ":") > 1 Тогда
			Сообщить("Внимание!!! Проверьте номер порта. " + ОписаниеОшибки());
		Иначе	
			Сообщить("Ошибка создания агента сервера. " + ОписаниеОшибки());
		КонецЕсли;	
		Возврат;
	КонецПопытки;
	
// Загрузим кластеры сервера 1с	
    КластерыСерверов = АгентСервера.GetClusters().Выгрузить();
	Для Каждого Кластер Из КластерыСерверов Цикл
		
		Попытка
		//  Если Вы не являетесь администратором кластера серверов, то Вам придется раскомментировать
		// нижеследующую строку и ввести данные подключения к кластеру
			//АгентСервера.Authenticate(Кластер, АдминистраторКластера, ПарольАдмКластера);
			АгентСервера.Authenticate(Кластер, "", "");
		Исключение
			Сообщить(ОписаниеОшибки());
			Возврат ;
		КонецПопытки;	
		
// Загрузим список баз кластера в таблицу Отчет.ТаблицаБаз
		Базы = АгентСервера.GetInfoBases(Кластер).Выгрузить();
		Для каждого База Из Базы Цикл
			
				СтрТабБаз = Отчет.ТаблицаБаз.Добавить();
				СтрТабБаз.ИмяБазы = База.Name;
				СтрТабБаз.ОписаниеБазы = База.Descr;
				
		КонецЦикла;
		
		Прервать;
	КонецЦикла;	
	
КонецПроцедуры

&НаКлиенте
Процедура ОбновитьСписокБаз(Команда)  
	ПолучитьСписокБаз();
КонецПроцедуры

     На Рис. 4, представлен результат работы формы отчета, для закладки "Настройки подключения к базам"

Рис. 4.

4.    Создание макета отчета

     Создание макета отчета имеет некоторые особенности, поэтому необходимо этот раздел прочитать обязательно.
Откроем схему компоновки данных закладку «Наборы данных» и создадим «Набор данных – объект»-"ОтчетПоВнешнимДанным" . Создадим поля набора данных согласно Рис. 5. Установим «Имя объекта, содержащего данные» = ТаблицаДанных.

Рис. 5.

Перейдем на закладку «Ресурсы» и создадим ресурсы макета согласно Рис. 6.

Рис. 6.

Первый ресурс считает количество ролей, второй показывает доступность роли - "Да" или "Нет", для этого ресурса установим в колонке "Рассчитывать по...", значение "Роль".

Перейдем на закладку «Параметры» и создадим параметры согласно Рис. 7.

Рис. 7.

     Для параметра «ПрофилиГруппДоступа» установим тип «СправочникСсылка.ПрофилиГруппДоступа», для параметра «Пользователи» установим составной тип «СправочникСсылка.Пользователи, Строка»-составной тип сделан в связи с тем, что не во всех базах могут быть одинаковые списки пользователей. Поэтому открыта возможность ввести имя пользователя в ручную.  Необходимо особо отметить, что у параметров, кроме "ВариантОтчета", необходимо установить флаг «Доступен список значений». Параметр «ВариантОтчета», нам необходим для того, чтобы отслеживать имя выполняемого варианта отчета, в отборах по запросу он не участвует.

    Откроем закладку «Настройки», создадим два варианта отчета согласно Рис.8 и Рис.9  и для параметра «Вариант отчета» установим значения «Вариант1» и «Вариант2» соответственно. Единственным выбранным полем для вариантов отчета, является поле ресурс «РольДоступна».
Как видно из рисунков, варианты отчета выполнены в виде таблиц. Первый вариант разворачивает роли пользователя по базам данных и подразделениям. Второй вариант разворачивает роли базы данных и подразделения по пользователям. Для параметров "Пользователи" и "Вариант отчета" установим флаг "Включать в пользовательские настройки"

Рис. 8.

Рис. 9.

5. Модуль объекта отчета

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
	СтандартнаяОбработка = Ложь;
	
// Осуществим проверку на выбор баз для формирования отчета, и в случае если выбранных баз нет сформируем предупреждающее сообщение.	
	ПараметрыОтбора = Новый Структура;
	ПараметрыОтбора.Вставить("Выбор", Истина);
	СтрокиБаз = ТаблицаБаз.НайтиСтроки(ПараметрыОтбора);
	Если СтрокиБаз.Количество() = 0 Тогда
		Сообщить("Необходимо выбрать хотябы одну базу!");
		Возврат;
	КонецЕсли;	
	
// Создадим таблицу значений для формирования отчета.
// Имена полей возьмем из созданного нами набора данных "ОтчетПоВнешнимДанным", в макете отчета
	ТаблицаДляСКД = Новый ТаблицаЗначений;    
	ПоляНабораДанных = СхемаКомпоновкиДанных.НаборыДанных.ОтчетПоВнешнимДанным.Поля;
	Для каждого Строка из ПоляНабораДанных Цикл
		ТаблицаДляСКД.Колонки.Добавить(Строка.Поле);
	КонецЦикла;
	
// Цикл по массиву выбранных база. 	
	Для Каждого СтрТабБаз из СтрокиБаз Цикл
		
// Если имя базы совпадает с именем текущей базы, то обработаем запрос к текущей базе.
// Понятно, что подключаться к текущей базе данных через com-соединение довольно затратно по ресурсам, времени и поэтому не производительно.
// Поэтому этот процесс разделеяется в нижеследующем коде.
		Если СтрТабБаз.ИмяБазы = ЭтаБаза Тогда
			 РезультатЗапроса = ЗапросКТекущейБазе(СтрТабБаз.ИмяБазы);
		Иначе 
// иначе сформируем строку подключения к базе и вызовем процедуру запроса к внешней базе			 
			СтрокаКоннекта	 = "Srvr="""+СерверБазы+""";Ref="""+СтрТабБаз.ИмяБазы+""";Usr="""+ИмяПользователя+""";Pwd="""+Пароль+"""";
			РезультатЗапроса = ЗапосКВнешнейБазе(СтрокаКоннекта, СтрТабБаз.ИмяБазы);
		КонецЕсли;	
		
		Если РезультатЗапроса = Неопределено Тогда
			Продолжить;
		КонецЕсли;
		
		Для Каждого СтрТЗ Из РезультатЗапроса Цикл 
// Построчно перенесем результаты каждого запроса в таблицу значений "ТаблицаДляСКД" и добавим имя базы данных в соответствующую колонку		
			СтрТабСкд=ТаблицаДляСКД.Добавить();
			Для Каждого Колонка из ТаблицаДляСКД.Колонки Цикл
				Если Колонка.Имя = "ИмяБазыДанных" Тогда
					СтрТабСкд[Колонка.Имя] = СтрТабБаз.ИмяБазы;
				Иначе	
			    	СтрТабСкд[Колонка.Имя] = СтрТЗ[Колонка.Имя];
				КонецЕсли;	
			КонецЦикла;
			
		КонецЦикла;
		
	КонецЦикла;	
	
// Далее идет стандартный код формирования отчета из итоговой таблицы значений "ТаблицаДляСКД"
	ВнешнийНабор 	  	= Новый Структура("ТаблицаДанных", ТаблицаДляСКД);
	Настройки 		  	= КомпоновщикНастроек.Настройки;
	КомпоновщикМакета 	= Новый  КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки   	= КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки);
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки, ВнешнийНабор);
	ПроцессорВывода 	= Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	ПроцессорВывода.Вывести(ПроцессорКомпоновки);
	
// Этот код сворачивает группировки до уровней профиля пользователя в зависимости от варианта отчета	
	Если ИмяВариантаНастроек = "Вариант1" Тогда
		ДокументРезультат.ПоказатьУровеньГруппировокСтрок(1);
	ИначеЕсли  ИмяВариантаНастроек = "Вариант2" Тогда
	    ДокументРезультат.ПоказатьУровеньГруппировокСтрок(2);
	КонецЕсли;
	
// Данный код является универсальным не зависимости от набора данных в макете отчета	
	
КонецПроцедуры

Функция ЗапосКВнешнейБазе(СтрокаКоннекта, ИмяБазы)	
	
//  Подключимся к внешней базе	
	Попытка
		Соединитель = Новый COMОбъект(COM_соединение);
	Исключение
		Ошибка = ОписаниеОшибки();
		Сообщить("Ошибка создания "+COM_соединение+". "+Ошибка);
		Возврат Неопределено;
	КонецПопытки;
	
	Попытка
		ДругаяБаза=Соединитель.Connect(СтрокаКоннекта);
	Исключение
		Ошибка = ОписаниеОшибки();
		Сообщить(Ошибка);
		Возврат Неопределено;
	КонецПопытки;
	
//	Создадим запрос во внешней базе
	Запрос = ДругаяБаза.NewObject("Запрос");
// 	Текст запроса у нас одинаков, как для внешней, так и для текущей базы  	
	Запрос.Текст = ПолучитьТекстЗапроса();
// Вызовем процедуру установки параметров запроса	
	УстановитьПараметрыЗапроса(Запрос, ДругаяБаза);

	Попытка
		ТЗ = Запрос.Выполнить().Выгрузить();
		Возврат(ТЗ);
	Исключение
		Ошибка = ОписаниеОшибки();
		Сообщить(Ошибка);
		Возврат Неопределено;
	КонецПопытки;
	
КонецФункции

Функция ЗапросКТекущейБазе(ИмяБазы)

//  Запрос к текущей базе является стандартным 
	Запрос = Новый Запрос;
	УстановитьПараметрыЗапроса(Запрос);

	Запрос.Текст = ПолучитьТекстЗапроса();
	ТЗ = Запрос.Выполнить().Выгрузить();
	
	Возврат ТЗ;
	
КонецФункции

Функция ПолучитьТекстЗапроса()
	
// Текст запроса по выходным полям строго соответствует именам полей набора данных в макете отчета.
// Все выходные поля запроса необходимо привести к простым типам: число, строка, дата, булево ...  
// Особо важно отметить, что имена параметров запроса строго согласованны с именами параметров макета отчета
// Поскольку используемая конфигурация является не стандартной, то для своей конфигурации необходимо будет запрос отредактировать.
// В тексте запроса даны пояснительные комментарии

	ТекстЗапроса =
	 "ВЫБРАТЬ
	 |	Таблица.Пользователь1С КАК Пользователь1С,
	 |	Таблица.ПользовательКод КАК ПользовательКод,
	 |	Таблица.ПользовательОС КАК ПользовательОС
	 |ПОМЕСТИТЬ ПользователиОС
	 |ИЗ
	 |	&ТаблицаПользователей КАК Таблица
	 |;
// Обратите внимание, для получения значения ПользовательОС и ПользовательКод в таблицу передается 
// параметр таблица значений "ТаблицаПользователей", которая формируется в процедуре УстановитьПараметрыЗапроса().	 
	 |
	 |////////////////////////////////////////////////////////////////////////////////
	 |ВЫБРАТЬ
	 |	ГруппыДоступаПользователи.Пользователь.Наименование КАК Пользователь,
	 |	ГруппыДоступа.Профиль.Наименование КАК Профиль,
	 |	ПрофилиГруппДоступаРоли.Роль КАК Роль,
	 |	ВЫБОР
	 |		КОГДА ПрофилиГруппДоступаРоли.Роль ЕСТЬ NULL
	 |			ТОГДА 0
	 |		ИНАЧЕ 1
	 |	КОНЕЦ КАК РольДоступна,
	 |	"""" КАК ИмяБазыДанных,
	 |	ПользователиПодразделения.Подразделение.Наименование КАК Подразделение,
	 |	ГруппыДоступаПользователи.Пользователь.Код КАК ПользовательКод
	 |ПОМЕСТИТЬ ПраваПользователей
	 |ИЗ
	 |	Справочник.ГруппыДоступа.Пользователи КАК ГруппыДоступаПользователи
	 |		ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ГруппыДоступа КАК ГруппыДоступа
	 |			ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ПрофилиГруппДоступа КАК ПрофилиГруппДоступа
	 |				ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.ПрофилиГруппДоступа.Роли КАК ПрофилиГруппДоступаРоли
	 |				ПО (ПрофилиГруппДоступаРоли.Ссылка = ПрофилиГруппДоступа.Ссылка)
	 |			ПО ГруппыДоступа.Профиль = ПрофилиГруппДоступа.Ссылка
	 |		ПО ГруппыДоступаПользователи.Ссылка = ГруппыДоступа.Ссылка
	 |		ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.Пользователи.Подразделения КАК ПользователиПодразделения
	 |		ПО ГруппыДоступаПользователи.Пользователь.Ссылка = ПользователиПодразделения.Ссылка
	 |ГДЕ
	 |	НЕ ГруппыДоступаПользователи.Ссылка.ЭтоГруппа
	 |	И НЕ ГруппыДоступаПользователи.Ссылка.ПометкаУдаления
	 |	И НЕ ГруппыДоступаПользователи.Пользователь.ПометкаУдаления
// Имя параметра начинающееся с "Использовать..." объединяется с значением самого параметра. 
// В результате если параметр "Использовать..." = Ложь, то значение объединенного параметра игнорируется. 
// Таким образом мы согласуем использование этих параметров с параметрами получаемыми из макета запроса
// Второй объединяемый параметр должен иметь условие "В списке значений".
	 |	И (НЕ &ИспользоватьПользователи
	 |			ИЛИ ГруппыДоступаПользователи.Пользователь.Наименование В (&Пользователи))
	 |	И (НЕ &ИспользоватьПрофилиГруппДоступа
	 |			ИЛИ ГруппыДоступа.Профиль.Наименование В (&ПрофилиГруппДоступа))
	 |
	 |ОБЪЕДИНИТЬ ВСЕ
	 |
// Особенностью запроса является, то что искусственно создается роль "Дополнительные настройки прав"
// для регистра сведений "Настройки пользователя".
	 |ВЫБРАТЬ
	 |	НастройкиПользователей.Пользователь.Наименование,
	 |	""Дополнительные настройки прав"",
	 |	НастройкиПользователей.Настройка.Наименование,
	 |	1,
	 |	"""",
	 |	ПользователиПодразделения.Подразделение.Наименование,
	 |	НастройкиПользователей.Пользователь.Код
	 |ИЗ
	 |	РегистрСведений.НастройкиПользователей КАК НастройкиПользователей
	 |		ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Пользователи.Подразделения КАК ПользователиПодразделения
	 |		ПО НастройкиПользователей.Пользователь = ПользователиПодразделения.Ссылка
	 |ГДЕ
	 |	НастройкиПользователей.Значение = ИСТИНА
	 |	И (НЕ &ИспользоватьПользователи
	 |			ИЛИ НастройкиПользователей.Пользователь.Наименование В (&Пользователи))
	 |	И НЕ &ИспользоватьПрофилиГруппДоступа
	 |;
	 |
	 |////////////////////////////////////////////////////////////////////////////////
	 |ВЫБРАТЬ
	 |	ПраваПользователей.Пользователь КАК Пользователь,
	 |	ПраваПользователей.Профиль КАК Профиль,
	 |	ПраваПользователей.Роль КАК Роль,
	 |	ПраваПользователей.РольДоступна КАК РольДоступна,
	 |	ПраваПользователей.ИмяБазыДанных КАК ИмяБазыДанных,
	 |	ПраваПользователей.Подразделение КАК Подразделение,
	 |	ЕСТЬNULL(ПользователиОС.ПользовательКод, ПраваПользователей.ПользовательКод) КАК ПользовательКод,
	 |	ЕСТЬNULL(ПользователиОС.ПользовательОС, """") КАК ПользовательОС
	 |ИЗ
	 |	ПраваПользователей КАК ПраваПользователей
	 |		ЛЕВОЕ СОЕДИНЕНИЕ ПользователиОС КАК ПользователиОС
	 |		ПО ПраваПользователей.Пользователь = ПользователиОС.Пользователь1С"
	 ;
	Возврат ТекстЗапроса;
	 
КонецФункции

Процедура УстановитьПараметрыЗапроса(Запрос, ДругаяБаза = Неопределено)
	
// Для передачи параметров в запрос, сформируем цикл по пользовательским настройкам	
	ПользовательскиеНастройкиЭлементы = КомпоновщикНастроек.ПользовательскиеНастройки.Элементы;
	Для каждого Элемент из ПользовательскиеНастройкиЭлементы Цикл
		
		Если не Строка(Элемент) = "ЗначениеПараметраНастроекКомпоновкиДанных" Тогда
			Продолжить;
		КонецЕсли;
		
		ИмяПараметра = Строка(Элемент.Параметр); 
// Параметр вариат отчета в запрос не передается		
		Если ИмяПараметра = "ВариантОтчета" Тогда
			Продолжить;
		КонецЕсли;	
		
// Все другие параметры у нас имеют флаг "доступен список значений", поэтому для их передачи в запрос, создадим массив-"МассивПараметра".
// Понятно, что передача ссылок объектов в качестве параметров не имеет смысла поскольку одинаково названные объекты разных базах не будут равны.
// Как вариант можно осуществлять поиск ссылки объекта во внешней базе по наименованию и передавать уже массив ссылок в качестве параметра.
// Для параметра ТаблицаПользователей создадим таблицы значений с соответствующими полями
		Если ДругаяБаза = Неопределено Тогда
	
			МассивПараметра = Новый Массив;
			ТаблицаПользователей = Новый ТаблицаЗначений;
			ТаблицаПользователей.Колонки.Добавить("ПользовательОС", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64))); 
			ТаблицаПользователей.Колонки.Добавить("Пользователь1С", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64)));
			ТаблицаПользователей.Колонки.Добавить("ПользовательКод", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64)));
			
// Поскольку поля параметра ТаблицаПользователей - используется только в варианте 1, то и заполнять эту таблицу из массива пользователей, мы будем только для варианта отчета 1 
			Если ИмяВариантаНастроек = "Вариант1" Тогда
// Получим данные по пользователям функцией 1с	
				МассивПользователей = ПользователиИнформационнойБазы.ПолучитьПользователей();
			КонецЕсли;	
		Иначе
// Если параметр функции ДругаяБаза определен, то массив-"МассивПараметра" создается во внешней базе
			МассивПараметра = ДругаяБаза.NewObject("Массив"); 
// Передаваемый параметр таблица значений "ТаблицаПользователей", так же создадим в внешней базе
			ТаблицаПользователей = ДругаяБаза.NewObject("ТаблицаЗначений");
			ТаблицаПользователей.Колонки.Добавить("ПользовательОС", ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки", 64))); 
			ТаблицаПользователей.Колонки.Добавить("Пользователь1С", ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки", 64)));
			ТаблицаПользователей.Колонки.Добавить("ПользовательКод", ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки",64)));

// Для варианта отчета "Вариант1" заполним массив пользователей, для последующего копирования в таблицу значений "ТаблицаПользователей
			Если ИмяВариантаНастроек = "Вариант1" Тогда
				МассивПользователей = ДругаяБаза.ПользователиИнформационнойБазы.ПолучитьПользователей();
			КонецЕсли;	
		КонецЕсли;	
			
		Если Элемент.Использование и не Элемент.Значение = Неопределено Тогда
// Запишем значения параметров запроса в соответствующие массивы
// Отметим, что здесь применено правило автоматического формирования имени параметра запроса, 
// из имени параметра пользовательских настроек, которого необходимо строго придерживаться для автоматизации процесса программирования
			Если ТипЗнч(Элемент.Значение) = Тип("СправочникСсылка." + ИмяПараметра) Тогда
				 МассивПараметра.Добавить(СокрП(Элемент.Значение.Наименование));
			ИначеЕсли ТипЗнч(Элемент.Значение) = Тип("Строка") Тогда
				 МассивПараметра.Добавить(СокрП(Элемент.Значение));
			ИначеЕсли Элемент.Значение.Количество() > 0 Тогда
				Для каждого Параметр из Элемент.Значение Цикл 
					Если ТипЗнч(Параметр.Значение) = Тип("СправочникСсылка." + ИмяПараметра) Тогда
						МассивПараметра.Добавить(СокрП(Параметр.Значение.Наименование));
					Иначе
						МассивПараметра.Добавить(СокрП(Параметр.Значение));
					КонецЕсли;	
				КонецЦикла;
			Иначе
				Элемент.Использование = Ложь;
			КонецЕсли;
		Иначе
			Элемент.Использование = Ложь;
		КонецЕсли;
// Установим параметры в запрос. 	
		Запрос.УстановитьПараметр("Использовать" + ИмяПараметра, Элемент.Использование);
		Запрос.УстановитьПараметр(ИмяПараметра, МассивПараметра);
		
	КонецЦикла;
	
// Если используется вариант1 отчета, то заполним параметр "ТаблицаПользователей". 	
	Если ИмяВариантаНастроек = "Вариант1" Тогда
		Для Каждого Строка Из МассивПользователей Цикл
// В данном случае используются всего два поля таблицы "ПользователиИнформационнойБазы".
// Если Вам неолбходима и другая информация по пользователям, то ее легко здесь добавить
			НоваяСтрока = ТаблицаПользователей.Добавить(); 
			НоваяСтрока.Пользователь1С = Строка(Строка.ПолноеИмя);
			НоваяСтрока.ПользовательОС = Строка.ПользовательОС;
			НоваяСтрока.ПользовательКод = Строка.Имя;
			
		КонецЦикла;	
	КонецЕсли;
	
	Запрос.УстановитьПараметр("ТаблицаПользователей", ТаблицаПользователей);
	
// На код процедуры является универсальным (за исключение передачи параметра "ТаблицаПользователей")
// Одно из условий универсальности - установка флага "доступен список значений" и соответственно 
// в запросе параметры должны иметь условие "В списке значений"
// Второе условие универсальности - придерживаться правил наименования пользовательских параметров. 
// Таким образом, если исключить код создания и заполнения параметра "ТаблицаПользователей", процедура будет универсальна для всех отчетов.

КонецПроцедуры	


Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)

	Если Пароль="" Тогда
		Сообщить("Необходимо ввести пароль пользователя!");
		Отказ = Истина;
	КонецЕсли;
	

// Параметр "ВариантОтчета" используется для определения выполняемого варианта отчета.
// Установив значение параметра на стадии разработки макета отчета, мы легко получаем информацию о 
// текущем варианте отчета. 
	Настройки = КомпоновщикНастроек.ПолучитьНастройки();
	Если не Настройки = Неопределено Тогда
	// Заполняем реквизит ИмяВариантаНастроек	
		ИмяВариантаНастроек = Настройки.ПараметрыДанных.Элементы.Найти("ВариантОтчета").Значение;
	КонецЕсли;
	
КонецПроцедуры

Фактически данный отчет можно использовать в качестве шаблона для построения других мульти-базовых отчетов. Если придерживаться предложенных правил наименований пользовательских параметров, редактируется только процедура «ПолучитьТекстЗапроса» и макет отчета. Варианты сформированного отчета представлены на Рис. 10 и Рис. 11.

Рис. 10.

Рис. 11.

     6. Вызываем отчет из другой формы

Для вызова отчета нам необходимо сохранить его в справочнике «Дополнительные отчеты и обработки» конфигурации. Далее следуют процедуры и функции модуля формы, кнопки «ОткрытьОтчет».

&НаКлиенте
Процедура ОткрытьОтчет(Команда)
	
	ИмяОтчета = "ПраваДоступаМультибвзоый";
	
// 	Для загрузки внешнего отчета в стандартных конфигурациях можно воспользоваться готовой процедурой, 
//  которая расположена в общем модуле - ДополнительныеОтчетыИОбработки.ПодключитьВнешнююОбработку	
//  Мы не ищем легких путей и напишем такую процедуру сами.
	ИмяОбработки = ЗагрузитьВнешнююОбработку(ИмяОтчета);
	Если ИмяОбработки = Неопределено Тогда
		Сообщить("Отчет " + ИмяОтчета + "не найден в базе данных!");
		Возврат; 
	КонецЕсли;
	
// Получаем форму и из нее достаем КомпоновщикНастроекКомпоновкиДанных.ПользовательскиеНастройки	
	Форма = ПолучитьФорму("ВнешнийОтчет."+ ИмяОбработки +".Форма");
	КомпоновщикНастроекКомпоновкиДанных = Форма.Отчет.КомпоновщикНастроек;
	ПользовательскиеНастройки = КомпоновщикНастроекКомпоновкиДанных.ПользовательскиеНастройки;
	
	ПолеКомпановкиПараметр = Новый ПараметрКомпоновкиДанных("ИмяПользователя");
	Для Каждого Элемент Из ПользовательскиеНастройки.Элементы Цикл
		
		Если ТипЗнч(Элемент) = Тип("ЗначениеПараметраНастроекКомпоновкиДанных") и Элемент.Параметр = ПолеКомпановкиПараметр Тогда
// В функции ПолучитьСписокПользователей() мы возвращаем СписокЗначений с занесенными в него ФИО пользователей с типом строка
// Как заполнить этот список, полностью ваша задача, для примера введено два пользователя 
			Список = ПолучитьСписокПользователей(); 
			Если Список =  Неопределено Тогда
				Продолжить;
			КонецЕсли;
// Заполняем параметр отчета "ИмяПользователя"			
			Элемент.Значение = Список;
            Элемент.Использование = Истина;
            Прервать;
			
		КонецЕсли;
		
	КонецЦикла;
	
// Получим имя команды дополнительного отчета	
    ВыполняемаяКоманда = ПолучитьПараметрыКомандыВнешнегоОтчета(ИмяОтчета);
	Если ВыполняемаяКоманда = Неопределено Тогда 
		Возврат; 
	КонецЕсли;
	
    ПараметрыОбработки = Новый Структура("ИдентификаторКоманды, ДополнительнаяОбработкаСсылка, ИмяФормы, КлючСессии, ПользовательскиеНастройки, СформироватьПриОткрытии");
    ПараметрыОбработки.ИдентификаторКоманды          = ВыполняемаяКоманда.Идентификатор;
    ПараметрыОбработки.ДополнительнаяОбработкаСсылка = ВыполняемаяКоманда.Ссылка;
    ПараметрыОбработки.ИмяФормы                      = Неопределено;
    ПараметрыОбработки.КлючСессии                    = ВыполняемаяКоманда.Ссылка.УникальныйИдентификатор();
	//ПараметрыОбработки.СформироватьПриОткрытии       = Истина;	
	ПараметрыОбработки.СформироватьПриОткрытии       = Ложь;
	
//  Установим пользовательские настройки в отчет	
	ПараметрыОбработки.ПользовательскиеНастройки     = ПользовательскиеНастройки;
	
	Форма = ПолучитьФорму("ВнешнийОтчет."+ ИмяОбработки +".Форма", ПараметрыОбработки);
	
//Форма получена, можно заполнить список баз. Для примера добавленно имя двух баз	
	ТаблицаБаз = Форма.Отчет.ТаблицаБаз;
	СтрТабБаз = ТаблицаБаз.Добавить();
	СтрТабБаз.ИмяБазы = "База1";
	СтрТабБаз.ОписаниеБазы = "Добавлено программно";
	СтрТабБаз.Выбор = Истина;
	СтрТабБаз = ТаблицаБаз.Добавить();
	СтрТабБаз.ИмяБазы = "База2";
	СтрТабБаз.ОписаниеБазы = "Добавлено программно";
	СтрТабБаз.Выбор = Истина;
// Занесение имен баз непосредственно в таблицу формы отчета не позволяет нам сразу выполнить отчет при открытии
// поэтому строка - ПараметрыОбработки.СформироватьПриОткрытии = Истина закомментирована. При желании этот вопрос
// можно решить путем создания параметра СписокБаз и передавать в этот параметр имена баз. Правда код процедуры ПриКомпоновкеРезультата
// в модуле объекта отчета, необходимо будет переделать. Организовать цикл по выбранным именам баз, по значениям элементов этого параметра.
// Код конечно усложнится, но, что ни сделаешь для удовлетворения желаний заказчика. Зато отчет будет выполняться при открытии отчета.

// Список пользователей заполнен, список баз заполнен - можно открыть отчет.	
	ОткрытьФорму(Форма);

КонецПроцедуры

&НаСервере
Функция ЗагрузитьВнешнююОбработку(ИмяОбъекта, БезопасныйРежим = Ложь)
	
// Общий модуль - ДополнительныеОтчетыИОбработки.ПодключитьВнешнююОбработку	
	УстановитьПривилегированныйРежим(Истина);
	
// Получаем двоичный код обработки из справочника	
	ВнешняяОбработкаСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяОбъекта);
	Если ВнешняяОбработкаСсылка = Неопределено Тогда
		Возврат Неопределено;
	КонецЕсли;
	
	ДвоичныеДанныеОбработки = ВнешняяОбработкаСсылка.ХранилищеОбработки.Получить();
	АдресВоВременномХранилище = ПоместитьВоВременноеХранилище(ДвоичныеДанныеОбработки);

	Если ВнешняяОбработкаСсылка.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.Отчет
	 ИЛИ ВнешняяОбработкаСсылка.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительныйОтчет Тогда
	 
		Возврат ВнешниеОтчеты.Подключить(АдресВоВременномХранилище,, БезопасныйРежим);
		
	ИначеЕсли ВнешняяОбработкаСсылка.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок.ДополнительнаяОбработка Тогда
		
		Возврат ВнешниеОбработки.Подключить(АдресВоВременномХранилище,, БезопасныйРежим);
		
	Иначе 
		Сообщить("Объект не является внешней обработкой или отчетом.", СтатусСообщения.БезСтатуса);
	КонецЕсли;


КонецФункции

&НаСервере
Функция ПолучитьПараметрыКомандыВнешнегоОтчета(ИмяОтчета)
	
	ОтчетСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяОтчета);
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Ссылка", ОтчетСсылка);
    Запрос.Текст =
    "ВЫБРАТЬ
    |   ТаблицаКоманды.Ссылка,
    |   ТаблицаКоманды.Идентификатор,
    |   ТаблицаКоманды.ВариантЗапуска,
    |   ТаблицаКоманды.Представление КАК Представление,
    |   ТаблицаКоманды.ПоказыватьОповещение,
    |   ТаблицаКоманды.Модификатор
    |ИЗ
    |   Справочник.ДополнительныеОтчетыИОбработки.Команды КАК ТаблицаКоманды
    |ГДЕ
    |   ТаблицаКоманды.Ссылка = &Ссылка"
	;

    Результат = Запрос.Выполнить().Выбрать();

    Если Результат.Количество() = 0 Тогда
        Возврат Неопределено;
	Иначе		
	// При условии, чио команда отчета 1 одна цикла нет	
        Результат.Следующий();
        ВыполняемаяКоманда = Новый Структура(
        "Ссылка, Представление,
        |Идентификатор, ВариантЗапуска, ПоказыватьОповещение,
        |Модификатор, ОбъектыНазначения, ЭтоОтчет, Вид");

        ЗаполнитьЗначенияСвойств(ВыполняемаяКоманда, Результат);  
		ВыполняемаяКоманда.ЭтоОтчет = Истина;
    	ВыполняемаяКоманда.Вид      = Перечисления.ВидыДополнительныхОтчетовИОбработок.Отчет;

        Возврат ВыполняемаяКоманда;
		
	КонецЕсли;
	
КонецФункции

&НаСервере
Функция ПолучитьСписокПользователей()
	
	СписокЗнч = Новый СписокЗначений; 
	Пользователь = Справочники.Пользователи.НайтиПоНаименованию("Пользователь 1");
	СписокЗнч.Добавить(Пользователь);
	Пользователь = Справочники.Пользователи.НайтиПоНаименованию("Пользователь 2");
	СписокЗнч.Добавить(Пользователь);
	
	Возврат СписокЗнч;
	
КонецФункции

На рисунках Рис. 12  и Рис. 13 показаны закладки отчета после нажатия кнопки «ОткрытьОтчет»

Рис. 12.

Рис. 13.

    В версии 1.1 добавлена возможность отбора пользователей по логину операционной системы и ФИО пользователя, с условием подобия (Рис. 14). Очень удобное дополнение для администратора. Можно зная часть логина или ФИО пользователя посмотреть его права в базах данных. Файл меньше так как удалены подробные комментарии.

Рис. 14.  

Для получения универсальной обработки параметра в коде процедуры, с условием подобно, используется ключевая последовательность символов в имени параметра "подобно" - Рис. 15.

Рис. 15.

    Код процедуры УстановитьПараметрыЗапроса, изменен следующим образом:

Процедура УстановитьПараметрыЗапроса(Запрос, ДругаяБаза = Неопределено)
	
	Для каждого Элемент из КомпоновщикНастроек.ПользовательскиеНастройки.Элементы Цикл
		
		Если не Строка(Элемент) = "ЗначениеПараметраНастроекКомпоновкиДанных" Тогда
			Продолжить;
		КонецЕсли;
		
		ИмяПараметра = Строка(Элемент.Параметр); 
		Если ИмяПараметра = "ВариантОтчета" Тогда
			Продолжить;
		КонецЕсли;	
		
		Если ДругаяБаза = Неопределено Тогда
			МассивПараметра = Новый Массив;
			ТаблицаПользователей = Новый ТаблицаЗначений;
			ТаблицаПользователей.Колонки.Добавить("ПользовательОС", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64))); 
			ТаблицаПользователей.Колонки.Добавить("Пользователь1С", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64)));
			ТаблицаПользователей.Колонки.Добавить("ПользовательКод", Новый ОписаниеТипов("Строка", Новый КвалификаторыСтроки(64)));

			Если ИмяВариантаНастроек = "Вариант1" Тогда
				МассивПользователей = ПользователиИнформационнойБазы.ПолучитьПользователей();
			КонецЕсли;	
		Иначе	
			МассивПараметра = ДругаяБаза.NewObject("Массив"); 
			ТаблицаПользователей = ДругаяБаза.NewObject("ТаблицаЗначений");
			ТаблицаПользователей.Колонки.Добавить("ПользовательОС",  ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки", 64))); 
			ТаблицаПользователей.Колонки.Добавить("Пользователь1С",  ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки", "64")));
			ТаблицаПользователей.Колонки.Добавить("ПользовательКод", ДругаяБаза.NewObject("ОписаниеТипов", "Строка", ДругаяБаза.NewObject("КвалификаторыСтроки", "64")));
			Если ИмяВариантаНастроек = "Вариант1" Тогда
				МассивПользователей = ДругаяБаза.ПользователиИнформационнойБазы.ПолучитьПользователей();
			КонецЕсли;	
		КонецЕсли;	
			
		Если Элемент.Использование и не Элемент.Значение = Неопределено Тогда
			
			ТипЗнчЭлемента = ТипЗнч(Элемент.Значение);
			Попытка 
				ТипСправочник = Тип("СправочникСсылка." + ИмяПараметра);
			Исключение
				ТипСправочник = Неопределено;
			КонецПопытки;	

			Если ТипЗнчЭлемента = Тип("Строка") Тогда
				ЭлементЗначение = СокрЛП(Элемент.Значение);
// Обработка заполненных параметров с условием "подобно"
				Если СтрНайти(ИмяПараметра, "подобно")>1 Тогда
					ЭлементЗначение =  "%"+ЭлементЗначение+"%";
					Запрос.УстановитьПараметр("Использовать" + ИмяПараметра, Истина);
					Запрос.УстановитьПараметр(ИмяПараметра, ЭлементЗначение);
					Продолжить;
			   	КонецЕсли;
				МассивПараметра.Добавить(ЭлементЗначение);
			ИначеЕсли ТипЗнчЭлемента = ТипСправочник Тогда
				 МассивПараметра.Добавить(СокрП(Элемент.Значение.Наименование));
			ИначеЕсли Элемент.Значение.Количество() > 0 Тогда
				Для каждого Параметр из Элемент.Значение Цикл 
					Если ТипСправочник <> Неопределено и ТипЗнч(Параметр.Значение) = ТипСправочник Тогда
						МассивПараметра.Добавить(СокрП(Параметр.Значение.Наименование));
					Иначе
						МассивПараметра.Добавить(СокрП(Параметр.Значение));
					КонецЕсли;	
				КонецЦикла;
			Иначе
				Элемент.Использование = Ложь;
			КонецЕсли;
		Иначе
			Элемент.Использование = Ложь;
// Обработка пустых параметров с условием "подобно"
			Если СтрНайти(ИмяПараметра, "подобно")>1 Тогда
				Запрос.УстановитьПараметр("Использовать" + ИмяПараметра, Элемент.Использование);
				Запрос.УстановитьПараметр(ИмяПараметра, "% %");
				Продолжить;
			КонецЕсли;				
		КонецЕсли;
	
		Запрос.УстановитьПараметр("Использовать" + ИмяПараметра, Элемент.Использование);
		Запрос.УстановитьПараметр(ИмяПараметра, МассивПараметра);
		
	КонецЦикла;
	
	Если ИмяВариантаНастроек = "Вариант1" Тогда
		Для Каждого Строка Из МассивПользователей Цикл
			
			НоваяСтрока = ТаблицаПользователей.Добавить(); 
			НоваяСтрока.Пользователь1С = Строка(Строка.ПолноеИмя);
			НоваяСтрока.ПользовательОС = Строка.ПользовательОС;
			НоваяСтрока.ПользовательКод = Строка.Имя;
			
		КонецЦикла;	
	КонецЕсли;
	
	Запрос.УстановитьПараметр("ТаблицаПользователей", ТаблицаПользователей);
	
КонецПроцедуры

Соответственно в запросе устанавливаем отборы на выходной запрос:

     |ГДЕ
     |    (НЕ &ИспользоватьПользовательОСподобно
     |            ИЛИ ПользователиОС.ПользовательОС ПОДОБНО &ПользовательОСподобно)
     |    И (НЕ &ИспользоватьФИОпользователя_подобно
     |            ИЛИ ПраваПользователей.Пользователь ПОДОБНО &ФИОпользователя_подобно)

Таким образом мы можем добавлять любые отборы по символьным полям запроса с условием - ПОДОБНО.

Скачать файлы

Наименование Файл Версия Размер
ПраваДоступаМультибвзоыйОтчет

.erf 18,90Kb
10.10.18
0
.erf 1.1 18,90Kb Скачать
ПраваДоступаМультибвзоыйОтчет

.erf 21,09Kb
22.03.18
3
.erf 21,09Kb 3 Скачать
ОткрытьДополнительныйОтчетСПараметрами

.epf 7,84Kb
22.03.18
2
.epf 7,84Kb 2 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Безопасная работа с транзакциями во встроенном языке Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    34332    tormozit    44    

Загрузка, скачивание, удаление файлов с помощью НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера()

Практика программирования v8 1cv8.cf Абонемент ($m)

В платформе 8.3.15 появились новые методы НачатьПомещениеФайлаНаСервер() и НачатьПолучениеФайлаССервера(). В данной статье рассмотрено готовое решение проверенное и прекрасно работающее на тонком и веб-клиенте.

1 стартмани

25.07.2020    2453    Flashill    10    

Параллельные вычисления расчета факториала числа N

Практика программирования v8 1cv8.cf Абонемент ($m)

Распараллеливание алгоритма с помощью фоновых заданий (асинхронные вычисления)

1 стартмани

29.06.2020    2471    Rustig    17    

Универсальная печатная форма Приказа/Договора с возможностью настройки макета в пользовательском режиме

Практика программирования Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

В данной статье я опишу реализацию универсальной (в кавычках) печати Приказа (Договора или чего пожелаете) с возможностью настройки выводимого текста с параметрами из пользовательского режима

1 стартмани

24.06.2020    1229    BuriyLesha    0    

Как выполнить отчет на СКД через COM и получить данные отчета? Промо

Практика программирования v8 УПП1 Россия Абонемент ($m)

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    26960    wowik    3    

Методика обновления формы объекта данных при изменении объекта

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В формах объектов данных часто встречаются элементы, косвенно связанные с объектом. Логику обновления этих элементов при изменении объекта обычно вызывают из обработчиков ПриСозданнииНаСервере и ПриОткрытии, забывая про наличие других способов изменения объекта. В статье предложена методика для обычных и управляемых форм, учитывающая все способы.

1 стартмани

09.03.2020    7526    tormozit    13    

Отправка уведомлений с помощью командной строки, Оповещения с сервера на клиент с помощью командной строки

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Отправка уведомлений с помощью команды командной строки msg. Оповестить пользователей из серверного модуля или регламентного задания, с помощью командной строки msg.

1 стартмани

05.03.2020    5466    user5300    3    

Вывод сообщений в HTML поле средствами 1С

Практика программирования v8 v8::УФ Абонемент ($m)

Пример использования вывода большого количества сообщений в поле HTML. С возможностью открывать ссылочные объекты и создавать новые объекты передавая параметры прямо из HTML поля. Протестировано на релизах 8.3.12 и 8.3.15+

2 стартмани

31.01.2020    5612    burni4    16    

Как нарисовать граф на 1С Промо

Практика программирования v8 Абонемент ($m)

Описывается реализация на языке запросов 1С метода расположения вершин графа на плоскости, основанного на использовании электромеханической аналогии. При этом вершины графа представляются одноименными электрическими зарядами, дуги - пружинками. Силы взаимодействия вершин в этой системе переводят их из случайного начального в нужное конечное положение. Приведена обработка рисования графов "ГрафОграф", реализующая данный подход, показывающая также динамику процесса. Граф можно задать списком ребер вручную, выбрать из нескольких предопределенных примеров или сформировать по данным информационной базы.

1 стартмани

09.08.2013    70248    ildarovich    117    

Краткое руководство по внесению изменений в конфигурацию

Практика программирования v8 1cv8.cf Абонемент ($m)

Кратко описаны основополагающие моменты при старте групповой разработки конфигурации несколькими программистами. Полезно для проектной документации как требование к разработчикам или сопровождающей компании.

1 стартмани

13.01.2020    16709    sapervodichka    41    

Универсальные функции: разложение произвольной строки адреса в структуру

Практика программирования Универсальные функции v8 1cv8.cf Абонемент ($m)

Процедуры и функции раскладывают произвольную строку адрес в структуру по ключевым словам.

1 стартмани

30.12.2019    3556    vik070777    10    

"Живые" картинки со Snap.SVG

Практика программирования WEB Работа с интерфейсом v8 Абонемент ($m)

В статье рассмотрен пример использования http-сервисов для визуализации данных

1 стартмани

24.10.2019    13324    blackhole321    7    

Простой способ индексирования интервалов Промо

Практика программирования v8 Абонемент ($m)

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    39318    ildarovich    22    

RLS - дубли условий в запросах к СУБД

Практика программирования Роли и права v8 v8::Права 1cv8.cf Абонемент ($m)

"Подводные камни", возникающие при бездумном копировании ролей с ограничениями RLS, как это отражается на производительности, разбор примера и инструмент для анализа.

1 стартмани

07.10.2019    8333    geron4    4    

Полезные процедуры и функции для программиста

Практика программирования Универсальные функции v8 1cv8.cf Россия Абонемент ($m)

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    29392    HostHost    40    

Полное копирование одной формы в другую

Практика программирования Универсальные обработки Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Однажды я столкнулся с необходимостью открыть форму ЛЮБОГО документа с определенными изменениями, не зависящими от структуры объекта (например, заблокировать все кнопки). В интернете решения я не нашел. Обычно на форумах на запросы подобного рода отвечают чем-то вроде "покажи первоначальную задачу, а не спрашивай как реализовать то, что ты придумал". Тем не менее, мне стало интересно, как это можно сделать.

1 стартмани

03.10.2019    4855    nekit_rdx    23    

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    34888    rpgshnik    49    

Многопоточная обработка данных на примере перепроведения документов

Обработка документов Практика программирования v8 ERP2 УТ11 КА2 Абонемент ($m)

Дальнейшее развитие темы фоновой обработки данных - проведение документов в потоках. Настройка параметров и запуск основного процесса (менеджера потоков). Разбивка документов для проведения на не связанные друг с другом наборы и запуск дополнительных фоновых заданий для отдельных потоков. Отслеживание выполнения каждого потока в родительском сеансе.

1 стартмани

17.09.2019    8945    ids79    46    

Отображение истории выполнения по всем задачам комплексного процесса в документообороте

Документооборот и делопроизводство Практика программирования v8 ДО Абонемент ($m)

Коллеги, предлагаю вашему вниманию доработку для вывода полной истории в задачах комплексного процесса.

1 стартмани

15.09.2019    6679    pavelpribytkin96    8    

Описание формата внутреннего представления данных 1С в контексте обмена данными

Практика программирования Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    19145    Dementor    30    

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному Промо

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    44261    dsdred    36    

Удобный просмотр результата запроса с большим количеством временных таблиц

Практика программирования v8 Абонемент ($m)

Если Вам часто приходится просматривать в отладчике сложные пакетные запросы с большим количеством временных таблиц, то эта статья для Вас.

1 стартмани

27.08.2019    10756    ids79    21    

Запуск фонового задания во внешней обработке. Отключение предупреждений защиты от опасных действий в фоновом задании

Практика программирования v8 1cv8.cf Абонемент ($m)

Как запустить фоновое задание из модуля внешней обработки используя БСП. Как отключить безопасный режим и сообщения защиты от опасных действий независимо от профиля безопасности пользователя в фоновом задании во внешней обработке.

2 стартмани

24.08.2019    10394    BenGunn    22    

Изменяющееся контекстное меню в 1С 8.3

Практика программирования Работа с интерфейсом Разработка v8 v8::УФ Абонемент ($m)

В одной практической задаче мне пришлось разрабатывать контекстное меню таблицы управляемой формы, которое должно было меняться в зависимости от данных, находящихся в этой таблице. Ниже приведен мой способ решения этой задачи.

1 стартмани

06.08.2019    15301    signum2009    16    

Некоторая работа с данными через COM Промо

Практика программирования v8 Абонемент ($m)

В статье приведены примеры работы с Платформой 8.X через COM (точнее, через объект COMConnector). Примеры кода были использованы при реализации прикладных задач в процессе трудовой деятельности.

2 стартмани

05.12.2012    57284    wowik    32    

Процедура ПриКомпоновкеРезультата

Практика программирования v8 1cv8.cf Абонемент ($m)

Коллекция кода

1 стартмани

26.07.2019    37177    vasilev2015    64    

10 способов получить модуль числа (а может, и больше)

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Пишем функцию вычисления модуля числа. Сколько способов существует? Давайте посчитаем!

1 стартмани

11.07.2019    7885    sam441    29    

Ловец дедлоков СУБД

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Россия Абонемент ($m)

Анализ простейшего дедлока СУБД в рабочей базе с использованием ЦУП (центра управления производительностью) и profiler MS SQL (Microsoft SQL Server). Эта статья будет полезна людям, изучающим вопросы оптимизации работы 1С, или тем, у кого возникают дедлоки в рабочей базе. UPD 09.07.2019 добавлено воспроизведение блокировки в случае установки управляемой блокировки перед чтением набора записей регистра сведений. UPD 10.07.2019 добавлена тестовая база с примером.

1 стартмани

08.07.2019    10944    azazana    79    

Работа со схемой запроса Промо

Инструментарий разработчика Практика программирования v8 v8::Запросы Абонемент ($m)

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    43533    kalyaka    35    

Мониторинг производительности и искусственный интеллект

Производительность и оптимизация (HighLoad) Практика программирования Разработка v8 Абонемент ($m)

Расскажем и покажем практически, как использовать искусственный интеллект на страже мониторинга производительности. У вас появится возможность создать собственного помощника Ларису, которая возьмет на себя вопросы по контролю и диагностике состояния обслуживаемой системы.

1 стартмани

01.07.2019    9146    ivanov660    28    

"Убер на складе": динамический расчет маршрутов с учетом реальных расстояний

Учет ТМЦ Практика программирования Учет ТМЦ v8 УУ Абонемент ($m)

Представляю методику и инструмент для динамического расчета маршрутов отбора на высоконагруженных складах для максимального повышения эффективности склада, ускорения проходимости и, как следствие, экономии денег. Это методика и обработка для интеграции в WMS решения. Тестировалось на 1С 8.3.14.1565.

3 стартмани

24.06.2019    15239    informa1555    17    

1С:Ассемблер. Немного летнего веселья!

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    28635    Evil Beaver    126    

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов Промо

Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad) v8 1cv8.cf Россия Абонемент ($m)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    48868    DarkAn    86    

Простые примеры сложных отчетов на СКД

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    29367    Hatson    31    

Графики работы из БСП

Практика программирования Разработка v8 1cv8.cf Россия Абонемент ($m)

Не очень давно на канале 1С:БСП была опубликована заметка по использованию Графиков работы и Календарных графиков.

1 стартмани

23.05.2019    3166    fenixnow    0    

Создание внешней печатной формы в формате документа Word

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье написано, как создать внешнюю печатную форму (для конфигураций с БСП) в формате Word.

1 стартмани

17.05.2019    12931    ВикторП    21    

Новый запрос и новая таблица значений как функции Промо

Практика программирования v8 Абонемент ($m)

Предлагается две простые функции, использование которых уменьшает объем кода в конфигурациях на платформе «1С:Предприятие 8». Эти функции можно добавлять к своему общему модулю, что сделает процесс программирования более эффективным.

1 стартмани

27.11.2012    45118    ildarovich    46    

Пример настройки шаблонов и реализации печати отчетов в документ MS Word используя функциональную часть "Библиотеки Стандартных Подсистем 1С" (БСП)

Практика программирования Разработка v8 Россия Абонемент ($m)

В конфигурации выбраны и использованы только необходимые объекты библиотеки стандартных подсистем для реализации вывода отчёта, с табличными частями, в документ MS Word. Показан пример создания необходимых областей в шаблоне для вывода параметров в отчёт.

1 стартмани

23.04.2019    6055    olegpkc    11    

Ops средствами 1С:Предприятие

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В статье описан программный пакет "Автоматизация ИТ-процессов" (АИТП), позволяющий автоматизировать задачи по администрированию, управлению и обслуживанию ИТ-инфраструктуры.

1 стартмани

23.04.2019    17283    blackhole321    28    

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки

Практика программирования Внешние источники данных Обмен через XML WEB Разработка v8 1cv8.cf Абонемент ($m)

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    32583    riposte    65    

Уровни, глубина, прародители, циклы и аналоги запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В продолжение публикации «Транзитивное замыкание запросом» [http://infostart.ru/public/158512/] добавлены другие варианты использования того же приема. Приведены запросы для быстрого определения уровней всех элементов справочника, максимальной глубины справочника, прародителей произвольных элементов справочника, запрос для быстрого определения циклов (на примере справочника спецификаций «1С:Управление производственным предприятием») и определения множеств аналогов номенклатуры (также на примере конфигурации «1С:Управление производственным предприятием»).

1 стартмани

13.11.2012    111435    ildarovich    98    

Вывод вариантов СКД в таблицы на управляемой форме

Практика программирования Работа с интерфейсом v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Задача стояла такая: есть 2 различных запроса, результаты которых выгружаются на форму обработки в таблицы значений (далее ТЗ) и программно "соприкасаются" между собой определенным образом (как именно- в рамках данной статьи неважно). Нюанс в том, что запросы должны иметь свой компоновщик настроек и могут интерактивно на форме изменяться пользователем. На оригинальность публикации не претендую - изначально в рамках поставленной задачи пытался найти что-то подобное (уже готовый шаблон) на инфостарте, возможно "плохо искал" ;)

05.04.2019    10948    artkor    1    

Функциональное программирование в 1С

Практика программирования Математика и алгоритмы Разработка v8 1cv8.cf Абонемент ($m)

Статья о функциональном программировании в 1С. Добавляем новые возможности. Пример передачи функций в качестве аргумента.

1 стартмани

28.03.2019    8288    alexey.kutya    26    

[EnterpriseData] Антисвертка характеристик номенклатуры при выгрузке в Бухгалтерию

Практика программирования Перенос данных из 1C8 в 1C8 Разработка v8 v8::ПВХ КД УНФ БП3.0 Россия БУ Абонемент ($m)

Рассмотрена выгрузка каждой пары значений Номенклатура - Характерстика из УНФ 1.6 в отдельную номенклатуру в Бухгалтерию 3.0 путём доработки правил обмена в формате EnterpriseData.

1 стартмани

27.03.2019    4523    nforce    5    

Неоплаченные долги при распределении оплаты по правилу ФИФО одним запросом и намного быстрее, чем Вы думали Промо

Практика программирования Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::СКД КА1 УТ10 УПП1 УУ Абонемент ($m)

Предлагается метод для быстрого нахождения неоплаченных долгов при распределении оплаты по правилу ФИФО, основанный на дихотомии. Описывается реализация метода в виде достаточно простого запроса, решающего за линейное время указанную задачу, считавшуюся ранее существенно более трудоемкой. Приводятся примеры использования запроса в отчетах на СКД для конфигураций УТ, КА, УПП.

1 стартмани

28.02.2014    68074    ildarovich    124    

Интеграция 1С и SharePoint

Практика программирования Разработка v8 УНФ ДО ERP2 БП3.0 УТ11 УХ КА2 Россия Абонемент ($m)

Заказчики поставили задачу автоматизации согласования заявок на оплату в программе 1С:Бухгалтерия предприятия 3.0. Согласно ТЗ, данные должны подтягиваться из действующей электронной системы документаоборота на MS SharePoint (в дальнейшем СЭД MS SP).

1 стартмани

22.03.2019    5312    -I-    4    

Легкий "тюнинг" УТ 10.3

Практика программирования Разработка v8 v8::ОУ УТ10 Россия УУ Абонемент ($m)

Вариант программной реализации изменения форм типовых объектов для конфигурации Управление торговлей 10.3.

1 стартмани

15.03.2019    4341    pm74    6    

Пример использования СКД и данных расшифровки на мобильной платформе

Практика программирования Разработка v8 v8::Mobile v8::СКД 1cv8.cf Россия Абонемент ($m)

СКД в мобильном приложении и меню действий на основе данных расшифровки (отчет, совместимый с мобильной платформой 8.3.13.45).

1 стартмани

12.03.2019    5469    majoram    0    

Транзитивное замыкание запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

В частности, показывается, как одним пакетным запросом найти ВСЕХ предков (потомков) в иерархическом справочнике. Аналогично можно определять входимость деталей в узлы и готовые изделия по их спецификациям, определять подмножества аналогичных запчастей по цепочке аналогов, решать другие подобные задачи. Приложен файл с примером отчета для замыкания иерархии произвольного справочника, позволяющий протестировать быстродействие запроса в разных условиях.

1 стартмани

29.10.2012    84707    ildarovich    118    

Программное создание реквизита управляемой формы с помощью механизма расширений

Практика программирования Разработка v8 v8::УФ 1cv8.cf Абонемент ($m)

В ЗУП 3 возникла задача добавить реквизит в справочник не внося изменений в конфигурацию. БСП с механизмом дополнительных реквизитов использовать было нежелательно, поэтому был использован механизм расширений. Для вывода данного реквизита на форму добавлять саму форму в расширение не хотелось по ряду причин, описанных ниже. Создание реквизита и элемента формы, соответствующего данному реквизиту было решено сделать программно в самом расширении, следуя принципу минимального воздействия на конфигурацию.

1 стартмани

12.03.2019    34565    ni_cola    31    

Иерархия библиотек. Автоматическое обновление или как отказаться от переопределяемых модулей

Практика программирования Математика и алгоритмы Разработка v8 Абонемент ($m)

В статье рассмотрен один из вариантов библиотечного подхода к разработке, позволяющий организовать иерархический вызов библиотечных процедур и упростить автоматическую сборку готового продукта из нескольких библиотек. Предлагаемый подход может служить одним из элементов CI/CD при разработке ПО на платформе 1С.

1 стартмани

04.03.2019    5709    Alxby    4    

Асинхронная работа с текстовыми файлами в 1С 8.3

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

В этой статье я рассмотрю основные моменты работы с текстовым файлом в 1С 8.3. (загрузка - выгрузка) в режиме отключенной модальности (асинхронно).

1 стартмани

28.02.2019    7297    signum2009    6