Напиши свое имя по-японски :)

Публикация № 81975

Программирование - Практика программирования

18
Нашел в сети шутку и решил написать простенький преобразователь имен, чтобы не мучится "вручную". Пользы практической ноль, но отдохнуть и повеселиться - можно :)

Следует ввести в первое поле Ваше имя и нажать Enter, во втором поле появится преобразованное имя.

Написано на 8.2 (толстый клиент), но можете переписать на другие платформы.

Вот код:

Перем Алфавит;

Процедура ПриОткрытии()
  Алфавит = новый Соответствие);
  Алфавит.Вставить("А", "ка");
  Алфавит.Вставить("Б", "зу");
  Алфавит.Вставить("В", "ру");
  Алфавит.Вставить("Г", "жи");
  Алфавит.Вставить("Д", "тэ");
  Алфавит.Вставить("Е", "ку");
  Алфавит.Вставить("Ё", "ку");
  Алфавит.Вставить("Ж", "су");
  Алфавит.Вставить("З", "з");
  Алфавит.Вставить("И", "ки");
  Алфавит.Вставить("Й", "ки");
  Алфавит.Вставить("К", "мэ");
  Алфавит.Вставить("Л", "та");
  Алфавит.Вставить("М", "рин");
  Алфавит.Вставить("Н", "то");
  Алфавит.Вставить("О", "мо");
  Алфавит.Вставить("П", "но");
  Алфавит.Вставить("Р", "ши");
  Алфавит.Вставить("С", "ари");
  Алфавит.Вставить("Т", "чи");
  Алфавит.Вставить("У", "до");
  Алфавит.Вставить("Ф", "лу");
  Алфавит.Вставить("Х", "ри");
  Алфавит.Вставить("Ц", "ми");
  Алфавит.Вставить("Ч", "кэ");
  Алфавит.Вставить("Ш", "хи");
  Алфавит.Вставить("Щ", "хи");
  Алфавит.Вставить("Ъ", "зук");
  Алфавит.Вставить("Ы", "зук");
  Алфавит.Вставить("Ь", "зук");
  Алфавит.Вставить("Э", "мэй");
  Алфавит.Вставить("Ю", "фу");
  Алфавит.Вставить("Я", "на");
  Алфавит.Вставить(" ", " ");
КонецПроцедуры

Процедура ПолеВвода1ПриИзменении(Элемент)
  Перем Имя, Ответ, Сч, Буква;
  Имя = ВРЕГ(СокрЛП(ВводимоеИмя));
  Ответ = "";
  Для Сч=1 По СтрДлина(Имя)Цикл
   Буква = Сред(Имя, Сч, 1);
   Ответ = Ответ+Алфавит.Получить(Буква); 
  КонецЦикла;
  НовоеИмя = ТРег(Ответ);
КонецПроцедуры

 

18

Скачать файлы

Наименование Файл Версия Размер
Японец.epf
.epf 62,76Kb
24.02.11
78
.epf 62,76Kb 78 Скачать

См. также

Специальные предложения