gifts2017

Заполнение табличной части документа "Списание материалов из эксплуатации" по МОЛ (Управляемый интерфейс!)

Опубликовал Екатерина * * (ekaterinaeon) в раздел Обработки - Обработка документов

Обработка "Заполнить по МОЛ" предназначена для заполнения табличной части документа "Списание материалов из эксплуатации".

Обработка "Заполнить по МОЛ" предназначена для заполнения табличной части документа Списание материалов из эксплуатации с отбором по МОЛу, Подразделению и Организации. Заполняет табличные части: Спецодежда и Инвентарь.

Если у вас большой объем номенклатуры на МЦ02, МЦ04 счетах у разных подотчетников, то очень удобно отобрать позиции по МОЛу. Также есть строчка для отбора по части наименования (если оставить пустой, то будут отбираться позиции только по МОЛу).

Добавляется через Дополнительные отчеты и обработки и доп.настройки не требует.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ЗТЧ_ЗаполнитьПоМОЛ (Списание из эксплуатации)
.epf 9,78Kb
14.10.13
75
.epf 9,78Kb 75 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Sergey Boltach (ser6702) 16.10.13 18:02
Плюсую, но рекомендовал бы использовать несколько иную структуру запроса
Можно к ней уже при желании добавить "ПОДОБНО" для расширения

&НаСервере
Функция ЗаполнитьОбъект(ДокОбъект,Отбор,ТЧ)

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("МОЛ", Отбор.МОЛ);
Запрос.УстановитьПараметр("Период",Новый Граница(ДокОбъект.Дата, ВидГраницы.Исключая));
Запрос.УстановитьПараметр("Организация", ДокОбъект.Организация);
//МЦ.02 и МЦ.04 забалансовые
Запрос.УстановитьПараметр("СчетЭксплуатации",?(ТЧ="Спецодежда",ПланыСчетов.Хозрасчетный.СпецодеждаВЭксплуатацииВспомогательный,ПланыСчетов.Хозрасчетный.ИнвентарьИХозяйственныеПринадлежностиВЭксплуатации));
//Если ЗначениеЗаполнено(Отбор.Наимен) тогда
// СтрокаПоиска = " И Субконто1.Наименование ПОДОБНО ""%"" + &СтрокаПоиска + ""%""";
// Запрос.УстановитьПараметр("СтрокаПоиска",Отбор.Наимен);
//КонецЕсли;
Запрос.УстановитьПараметр("Номенклатура", Отбор.Наимен);

Запрос.Текст =
"ВЫБРАТЬ
| ХозрасчетныйОстатки.Счет КАК СчетУчета,
| ХозрасчетныйОстатки.Субконто1 КАК Номенклатура,
| ХозрасчетныйОстатки.Субконто2 КАК ПартияМатериаловВЭксплуатации,
| ХозрасчетныйОстатки.Субконто3 КАК ФизЛицо,
| ХозрасчетныйОстатки.КоличествоОстаток КАК Количество
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(
| &Период,
| Счет = &СчетЭксплуатации,
| ,
| Организация = &Организация
| И (Субконто1 В ИЕРАРХИИ (&Номенклатура)
| ИЛИ Субконто1 = &Номенклатура)
| И Субконто3 = &МОЛ) КАК ХозрасчетныйОстатки
|
|УПОРЯДОЧИТЬ ПО
| Номенклатура
|АВТОУПОРЯДОЧИВАНИЕ";
ДокОбъект[ТЧ].Очистить();
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
НоваяСтрока = ДокОбъект[ТЧ].Добавить();
Если ТЧ = "Спецодежда" тогда
НоваяСтрока.СчетПередачи = ПланыСчетов.Хозрасчетный.СпецодеждаВЭксплуатации;
КонецЕсли;
ЗаполнитьЗначенияСвойств(НоваяСтрока,Выборка);
КонецЦикла;
Если ЗначениеЗаполнено(Отбор.Наимен) и ДокОбъект[ТЧ].Количество() = 0 тогда
Сообщить("По введенной части наименования - "+Отбор.Наимен+ " - не найдено номенклатуры!");
КонецЕсли;

КонецФункции
2. Екатерина * * (ekaterinaeon) 17.10.13 06:11
| И (Субконто1 В ИЕРАРХИИ (&Номенклатура)
| ИЛИ Субконто1 = &Номенклатура)


Если бухгалтер ввел часть названия, которая есть в середине наименования номенклатуры (вне зависимости от регистра), так не сработает, тем более если принять во внимание, что Субконто1 на 10.11.1 счету это Номенклатура, а мы устанавливаем в виде параметра Строку.
3. Андрей (anv77) 18.11.13 19:57
Очень хотел найти, нашел) Спасибо)
4. Андрей Киселев (kisandr) 31.07.14 09:36
На БП 2 не работает
"Заполнение ТЧ не произведено!
Метод объекта не обнаружен (Инициализировать)"
Что может быть ?(2) ekaterinaeon,
5. Екатерина * * (ekaterinaeon) 31.07.14 11:13
(4) kisandr, какой у вас основной режим запуска? Управляемое приложение или обычное? Какой клиент?
6. Kirill Komrakov (medvedkiller) 24.12.15 13:32
Обработка не работает, выбираю МОЛа ни чего не заполняет
7. Екатерина * * (ekaterinaeon) 28.12.15 07:21
(6) medvedkiller, какая конфигурация, какая платформа?
8. Оксана Проненко (prochka) 28.12.15 17:59
Обработка не работает, выбираю МОЛа ни чего не заполняет

Такая же проблема.
1С:Предприятие 8.3 (8.3.7.1790)
Бухгалтерия предприятия, редакция 3.0 (3.0.43.29)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа