gifts2017

Пример работы с заголовками HTTP-запросов: загрузка версий программ с users.v8.1c.ru

Опубликовал Валерий Федоров (barelpro) в раздел Обмен - Интеграция с WEB

Узнайте больше о HTTP-запросах и о программной работе с сайтами, требующими авторизацию

На написание этой статьи сподвигли два фактора:

1. Весной 2013 в версии платформы 8.2.18 появились новые возможности языка:

Реализована возможность работы с заголовками HTTP-запросов, обработки кодов возврата, получения и установки тела запроса в виде строки или двоичных данных. Реализованы объекты HTTPЗапрос, HTTPОтвет.
В объекте HTTPСоединение реализованы следующие изменения:
Методы Записать(), ОтправитьДляОбработки(), Получить(), Удалить() возвращают значение типа HTTPОтвет;
Для методов Записать(), ОтправитьДляОбработки(), Получить(), Удалить() реализован синтаксис, позволяющий использовать программно сформированный HTTP-запрос.

2. В декабре 2013 из 1С-зазеркалья вышли две новости:

Автоматический REST интерфейс прикладных решений http://v8.1c.ru/o7/201312rest/index.htm и HTTP-сервисы в прикладном решении http://v8.1c.ru/o7/201312http/index.htm

Т.е. скоро мы получим инструмент с возможностями COM-соединения и WEB-сервисов одновременно. Задачи интеграции станут интереснее, появятся новые возможности, а это не может не радовать true-программиста! Поскольку для  работы со сторонними REST сервисами можно использовать имеющиеся в платформе средства работы с HTTP: объекты HTTPСоединениеHTTPЗапрос и HTTPОтвет, предлагаю рассмотреть эти методы чуть подробней, а в конце решить прикладную задачку: программно авторизоваться на страничке https://users.v8.1c.ru/distribution/total, распарсить ее и заполнить справочники Программы и Версии. Результат прикреплен к этой статье в виде конфигурации. Запускать ее можно на платформе не ниже 8.2.18.

Что такое HTTP - запросы? Мы с ними сталкиваемся каждый день.

Для начала предлагаю открыть Инструменты разработчика в браузере Yandex - кнопками Ctrl-Shift-I и перейти на закладку Network - именно здесь можно увидеть содержимое HTTP-запросов

Например, когда в браузере вводим адрес сайта https://login.1c.ru/loginна сервер уходит HTTP-запрос типа GET:

Request URLhttps://login.1c.ru/login
Request Method: GET

Request Headers:
Host: login.1c.ru
Connection: keep-alive 
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.12785 YaBrowser/13.12.1599.12785 Safari/537.36 
Accept-Encoding: gzip,deflate,sdch Accept-Language: ru,en;q=0.8

В 1С у HTTP-запроса типа GET есть вполне конкретный аналог: метод объекта HTTPСоединение.Получить(<HTTPЗапрос>)
А у объекта HTTPЗапрос есть свойства:
АдресРесурса типа Строка (он же 
Request URL)
и Заголовки типа Соответствие (он же 
Request Headers)

В ответ на этот запрос сервер возвращает браузеру HTTP-ответ:

Status Code: 200
Responce Headers:
Server: nginx
Date: Tue, 04 Feb 2014 07:36:25 GMT
Content-Type: text/html;charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
Pragma: no-cache
Expires: Thu, 01 Jan 1970 00:00:00 GMT
Cache-Control: no-cache
Cache-Control: no-store
Set-Cookie: JSESSIONID=AAEB3E82351662F43E37CE3F64B7795E.login1c8010; Path=/; Secure; HttpOnly
Content-Language: ru
Content-Encoding: gzip

И тело ответа, в котором содержится код запрошенной страницы на HTML (см закладку Response в Инструментах разработчика Yandex браузера)

В 1С метод HTTPСоединение.Получить(<HTTPЗапрос>) возвращает объект типа HTTPОтвет, у которого соответственно есть свойства:
КодСостяния (он же Status Code)
Заголовки (он же Responce Headers)
и метод ПолучитьТелоКакСтроку() (он же тело ответа - Response)

Когда на страничке https://login.1c.ru/login вводим логин/пароль и нажимаем кнопку Войти, то на сервер уходит HTTP-запрос типа POST:

Request URL: https://login.1c.ru/login;jsessionid=AAEB3E82351662F43E37CE3F64B7795E.login1c8010
Request Method: POST
Request Headers:
POST /login;jsessionid=AAEB3E82351662F43E37CE3F64B7795E.login1c8010 HTTP/1.1
Host: login.1c.ru
Connection: keep-alive
Content-Length: 122
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Origin: https://login.1c.ru
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.12785 YaBrowser/13.12.1599.12785 Safari/537.36
Content-Type: application/x-www-form-urlencoded
Referer: https://login.1c.ru/login
Accept-Encoding: gzip,deflate,sdch
Accept-Language: ru,en;q=0.8
Cookie: JSESSIONID=AAEB3E82351662F43E37CE3F64B7795E.login1c8010
Form Data или Request Body или Тело запроса:
inviteCode=&lt=LT-43557-KdRxeZdJGp2n25STSoj6meIPL09eYv&execution=e1s1&_eventId=submit&username=Barelpro&password=123

В 1С у HTTP-запроса типа POST есть вполне конкретный аналог: метод объекта HTTPСоединение.ОтправитьДляОбработки(<HTTPЗапрос>)
А у объекта HTTPЗапрос, кроме свойств АдресРесурса и Заголовки можно задать тело запроса (Request Body) с помощью метода УстановитьТелоИзСтроки()

 
Во всех этих нагромождениях полей заголовков нас интересуют только некоторые поля в контексте нашей задачки. 

Что происходит при первом входе на страничку https://login.1c.ru/login
сервер открывает Java-сессию и присваивает ей идентификатор JSESSIONID, значение которого передает через поле Set-Cookie в заголовке ответа. 

Что происходит при заполнении полей Логин и Пароль и нажатии на кнопку Войти:
Браузер передает серверу идентификатор сессии JSESSIONID через параметр Cookie, а логин и пароль через параметр inviteCode

Если авторизация сессии прошла удачно, то во всех следующих запросах достаточно использовать только идентификатор JSESSIONID. А если таймаут между запросами будет больше установленного на сервере, то время сессии истечет и придется повторять авторизацию заново.

Конечно при практической реализации нашей задачки пришлось встретиться с небольшими сложностями, которые в итоге удалось преодолеть:

Так, чтобы пройти от страницы авторизации  https://login.1c.ru/login до целевой страницы https://users.v8.1c.ru/distribution/total пришлось выполнить целых 8 HTTP-запросов (см процедуру НайтиJSESSIONID()). Но эту задачу сильно упростила еще одна особенность: в заголовке ответа сервер присылает поле Location, в котором содержится адрес следующего необходимого запроса, своего рода редирект на следующую страницу, в некоторых случаях с дополнительными параметрами, например:

В итоге надо выполнять запросы по адресу, указанному в Location до тех пор, пока не придет ответ без Location. В данном случае такова особенность реализации защиты сайта 1С: пройти 8 запросов и в трех местах создать три различные Java-Сессии.

Еще одна особенность: в теле HTML-кода на страничке https://login.1c.ru/login заключены скрытые параметры, которые надо распарсить и включить в тело POST-запроса при передаче логина/пароля в inviteCode=&lt=LT-43557-KdRxeZdJGp2n25STSoj6meIPL09eYv&execution=e1s1&_eventId=submit&username=Barelpro&password=123 (см процедуры РаспарситьinviteCode() и РекурсивныйПарсингСтраницыЛогина())

Дальнейший парсинг странички https://users.v8.1c.ru/distribution/total я делал через объект ПостроительDOM в рекурсивной процедуре РекурсивныйПарсингСпискаКонфигураций(), а парсинг страниц с версиями делал в рекурсивной процедуре РекурсивныйПарсингСпискаВерсий().

Для запуска обработки ЗагрузкаПрограммИВерсий используйте кнопку "Загрузить" в командной панели справочника Программы. В обработке заполните поля логин/пароль для доступа к сайту 1С и нажмите по очереди кнопки "Загрузить программы" и "Загрузить версии".

В общем, как видите, в доступе к запароленным сайтам нет ничего сложного, пользуйтесь на здоровье, удачи!

 
DISCLAIMER:

1. Не пытайтесь для доступа к сайту 1С использовать логин Barelpro и пароль 123. Я его привел для примера. У вас должен быть свой доступ:
- или у вас есть официальный 1С-продукт и доступ к обновлениям 1С через регистрационный номер и пароль
- или вы сотрудник компании-партнера 1С, у вас есть хотя бы один сертификат типа Спец и вам руководство открыло доступ почти ко всем к обновлениям (кроме некоторых специфических, типа "Корпоративный инструментальный пакет 8")

2. Конечно, существует механизм получения обновлений, встроенный во все современные типовые конфигурации 1С. Например, для "1С:Конвертация данных" скачиваем архив http://downloads.1c.ru/ipp/ITSREPV/V8Update/Configs/Conversion/21/82/v8upd11.zip, в нем лежит файлик v8cscdsc.xml, в котором указаны названия и пути скачивания всех обновлений данного продукта. Но, во-первых, не для всех программ выложены такие файлики. А во-вторых, надо еще где-то узнать адреса к v8upd11.zip для всех 466 конфигураций!

3. Зачем это может быть нужно? Ну, например, в моей компании есть служба Регулярного сопровождения (в просторечье ИТС). Сервис-инженеры при установке обновлений типовых конфигураций у клиентов должны в обязательном порядке указывать в своей учетной базе релиз конфигурации до и после обновления. Для этого можно использовать справочник Версии из моей конфигурации. А обновлять этот справочник можно ежедневно через регламентные задачи, исключив таким образом человеческий фактор.


PS от 01.09.2014. Выпущена версия 2. 1С слегка изменила алгоритм авторизации, пришлось слегка переписать код, попутно удалось уменьшить количество запросов с 8 до 4.

PS от 27.08.2015. Выпущена версия 3. 1С изменила дизайн и адреса.

PS от 02.09.2015. Выпущена версия 4. 1С изменила авторизацию.

PS от 08.09.2015. Выпущена версия 5. Оптимизирован код. Заменены методы рекурсивных парсингов на конструкции ПолучитьЭлементПоИдентификатору и ПолучитьЭлементыПоИмени. Старые функции остались закоментированными.

Скачать файлы

Наименование Файл Версия Размер
загрузка версий программ с users.v8.1c.ru v5.cf 521
.cf 24,76Kb
08.09.15
521
.cf 5 24,76Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Алексей (artspeed) 05.02.14 05:26
Скачал, развернул конфу, открыл, ввел логин и пароль. Загрузка версий - кнопочка просто не работает. Загрузка - программ - долго думает и заканчивает свое действие без результата((

В общем не работоспособная конфа((
Очень жаль

Испытывал на 8.2.19.80
2. Валерий Федоров (barelpro) 05.02.14 08:36
(1) artspeed,

Что-то с вашим логином и паролем не так. В браузере со страницы login.1c.ru куда он приводит? Отладчиком на какой строке зависает? Дайте больше информации!
3. Артем Бичинов (arteast) 05.02.14 09:53
Не работает.
В режиме Предприятия вообще никаких действий не производит.
Пробовал на платформе 1С:Предприятие 8.3 (8.3.4.389).

В отладке:
Соединение проходит удачно, авторизация тоже...а вот дальше
http://joxi.ru/xNHxUv3JTJBmeSOOWH4
4. Osiris_ (StaticUnsafe) 05.02.14 10:19
5. Валерий Федоров (barelpro) 05.02.14 10:20
(3) arteast,

мне чтобы понять, что не так, нужен ваш логин-пароль. Пришлите в личку, потом поменяете.
6. Валерий Федоров (barelpro) 05.02.14 11:14
(1) artspeed, (3) arteast,

Проблема решена, выложено обновление от 05.02.2014 11:54
Повторная закачка не списывает стартмани :)
7. Павел Ванин (pahich) 05.02.14 16:30
Спасибо, забрал в личную коллекцию )
8. Валерий Федоров (barelpro) 05.02.14 16:32
Люди, скачали уже 23 человека, скажите хоть работает? успокойте меня! )))))
9. Евгений К (John_d) 05.02.14 16:49
Спасибо за статью. Все работает.
Круто можно методом пост отправлять данные из 1с на сайт без посредников)
Alexoniq; barelpro; +2 Ответить
10. Евгений К (John_d) 05.02.14 17:48
Можете подсказать как правильно указать параметры post? чтобы они в глобальный массив post пришли на сайте
так:
HTTPЗапрос1.Заголовки.Вставить("name=" + name + "&col=" + kol);
11. Валерий Федоров (barelpro) 05.02.14 18:29
(10)
Если запрос Post, то обязательно должно быть заполнено тело запроса через УстановитьТелоИзСтроки. Например, так:

HTTPЗапрос2 = Новый HTTPЗапрос;
HTTPЗапрос2.Заголовки.Вставить("Connection", "keep-alive");
HTTPЗапрос2.Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");
HTTPЗапрос2.Заголовки.Вставить("Cookie", JSESSIONID1);
HTTPЗапрос2.УстановитьТелоИзСтроки("name=" + name + "&col=" + kol);
HTTPЗапрос2.АдресРесурса = "/login";

Соединение1 = Новый HTTPСоединение("login.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
ОтветHTTP = Соединение1.ОтправитьДляОбработки(HTTPЗапрос2);
12. Алексей Захаров (almas) 05.02.14 21:31
Спасибо. Очень актуальная тема.
13. Алексей Бочков (Aleksey.Bochkov) 05.02.14 23:36
По поводу списка файлов обновлений - конфигуратор умеет искать нужные обновления на серверах 1С, т.е. общий список есть.
Вот он (конфигуратор к нему обращается) - http://downloads.v8.1c.ru/tmplts/v8cscdsc.lst
Раньше точно работало, сейчас пишет что файла нет. Или я не те логин-пароль использую, или ошибка у 1С из-за перестройки ресурсов.
Прикрепленные файлы:
14. Валерий Федоров (barelpro) 06.02.14 00:24
(13) Aleksey.Bochkov,

если найдете путь к файлу с общим списком обновлений - получите огромный респект от всего сообщества 1С :)
15. Евгений К (John_d) 06.02.14 11:49
16. Алексей (artspeed) 06.02.14 15:08
Отлично. Действительно после обновления загрузка стала работать.
За это вам жирный "+"
По мне так: Что бы развивать программу можно сделать так:

Вместо одного логина/пасса от личного кабинет users.v8.1c.ru - сделать несколько учетных данных.
Т.е. я подписан, например на бюджет, хозрасчет, УТ под разными личными кабинетами.
Ваша программа последовательно открывает все учетки, скачивает заголовки, затем в таблице значений сворачивает по точным наименованиям. Ну как то так.
Таким образом мы получим более точный список ВСЕХ (тех, на которые есть подписка в одном/нескольких личных кабинетах) конфигураций

НУ и наверное последнее: Осталось включить возможность скачивать конфигурации, или на крайний случай получать "КОНЕЧНУЮ ПРЯМУЮ ССЫЛКУ НА ОБНОВЛЕНИЕ", а не рыскать каждый раз по сайту.
т.е. отметили галочками, какие конфигурации необходимо скачать и пошли чай пить. В программе предварительно в настройках в справочнике задаем конечные пути скачки.
По нажатию "скачать" скачиваем обновления, которые уже рассованы по нужным папкам, и спокойно едем обновляться.

Извиняюсь за извращения, люблю это дело))
17. Валерий Федоров (barelpro) 06.02.14 19:16
(16) artspeed,

Алексей, не вижу никаких извращений, вполне дельные требования к разработке. Надо только правильно спозиционироваться на целевой аудитории - кому такая разработка будет интересна - и вперед!
Что касается меня - я писал статью из просветительских побуждений. Если найдется смельчак доработать мою конфу - с удовольствием передам ему неисключительные права на нее (достаточно просто сослаться на меня) :)
18. Алексей (artspeed) 07.02.14 04:20
(17) barelpro, проанализировал вашу конфу и запрос HTML. 1С-ники очень хитро генерируют ссылку на скачивание. Предполагаю java скриптом... С разных сторон подходил, но так конечную ссылку не получилось выудить...
19. Вячеслав Клюев (slavik27) 08.02.14 15:21
(16) artspeed, есть такой функционал http://infostart.ru/public/197576/
сейчас дорабатываем на переделанный сайт 1с, немного изменили пути
20. Павел Опарин (opx) 09.02.14 12:21
А может знает кто как реализовать автоматический редирект. Например при Oauth авторизации осуществляется редирект, а HTTPОтвет возвращает код 302. Было бы неплохо реализовать редирект автоматически. Как это сделать вручную я не сообразил.
21. Валерий Федоров (barelpro) 09.02.14 12:46
(20) opx,

В моем примере как раз редирект отрабатывается. На скриншоте посмотрите, код ответа 302, сервер возвращает в шапке ответа поле Location, в котором указан адрес редиректа
22. Алекс Климанов (fuxic) 10.02.14 12:30
Тема отличная, только начал веб-программированием увлекаться. Спасибо
23. Александр Зубцов (iov) 10.02.14 14:55
Спасибо. очень доходчиво.
24. Андрей Акулов (DrAku1a) 11.02.14 10:18
Все работает. Спасибо!
Осталось сделать загрузчик новых вышедших обновлений и информер =)
25. Борис (soap) 13.02.14 12:22
Спасибо ОЧЕНЬ информативно. Будем использовать!
26. Валерий Федоров (barelpro) 13.02.14 12:30
(24) DrAku1a,
не хочу ломать бизнес тем, кто берет за информер деньги :)
27. Андрей Акулов (DrAku1a) 13.02.14 18:40
(26) за информер - да, а за загрузчик?
кстати, можно сделать иерархический список (как на картинке)

1. Справочник "Программы" делаем иерархическим (нужен один уровень иерархии).

2. Немного корректируем процедуру в форме обработки "ЗагрузкаПрограммИВерсий":
Процедура РекурсивныйПарсингСпискаКонфигураций(ДокументHTML)
	
	ТекИмяГруппы = "";
	ТекГруппа = Справочники.Программы.ПустаяСсылка();
	Для Каждого ЭлДок Из ДокументHTML.ДочерниеУзлы Цикл
		
		Если СокрЛП(ЭлДок.ТекстовоеСодержимое) = "Название" Тогда
			
			//количество строк в таблице дистрибутивов
			СписокУзловHTML = ЭлДок.РодительскийУзел.РодительскийУзел.РодительскийУзел.ДочерниеУзлы[1].ДочерниеУзлы;
			КолЭлементов = СписокУзловHTML.Количество();
			
			Для А=0 По КолЭлементов-1 Цикл
				
				Если СписокУзловHTML[А].ДочерниеУзлы.Количество()=1 Тогда
					ТекИмяГруппы = СокрЛП(СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[0].ТекстовоеСодержимое);
				КонецЕсли;
				
				ТекЯчейка = СписокУзловHTML[А].ДочерниеУзлы[0].ДочерниеУзлы[0];
				Если ТипЗнч(ТекЯчейка) = Тип("ЭлементЯкорьHTML") Тогда
					
					Если ТекИмяГруппы<>"" Тогда
						Если СокрЛП(ТекГруппа.Наименование)<>ТекИмяГруппы Тогда
							Запрос = Новый Запрос;
							Запрос.УстановитьПараметр("Название", ТекИмяГруппы);
							Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
							               |	Программы.Ссылка
							               |ИЗ
							               |	Справочник.Программы КАК Программы
							               |ГДЕ
							               |	Программы.НазваниеПолное ПОДОБНО &Название
							               |	И Программы.ЭтоГруппа";
							Выборка = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
							Если Выборка.Следующий() Тогда
								ТекГруппа = Выборка.Ссылка;
							Иначе
								НовГруппа = Справочники.Программы.СоздатьГруппу();
								НовГруппа.Наименование = ТекИмяГруппы;
								НовГруппа.Записать();
								ТекГруппа = НовГруппа.Ссылка;
							КонецЕсли;
						КонецЕсли;
					КонецЕсли;
					
					Название = СокрЛП(ТекЯчейка.ТекстовоеСодержимое);
					ГиперСсылка = ТекЯчейка.ГиперСсылка;
					
					Запрос = Новый Запрос;
					Запрос.УстановитьПараметр("Название", Название);
					Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
					               |	Программы.Ссылка,
					               |	Программы.Родитель
					               |ИЗ
					               |	Справочник.Программы КАК Программы
					               |ГДЕ
					               |	Программы.НазваниеПолное ПОДОБНО &Название
					               |	И НЕ Программы.ЭтоГруппа";
					Выборка = Запрос.Выполнить().Выбрать();
					Если Выборка.Количество() = 0 Тогда
						
						НовыйСправочник = Справочники.Программы.СоздатьЭлемент();
						НовыйСправочник.Наименование = Название;
						НовыйСправочник.НазваниеПолное = Название;
						НовыйСправочник.ГиперСсылка = ГиперСсылка;
						НовыйСправочник.Родитель = ТекГруппа;
						НовыйСправочник.Записать();
						
						Загружено = Загружено + 1;
					Иначе
						
						Выборка.Выбрать();
						Пока Выборка.Следующий() Цикл
							Если Выборка.Родитель<>ТекГруппа Тогда
								НовыйСправочник = Выборка.Ссылка.ПолучитьОбъект();
								НовыйСправочник.Родитель = ТекГруппа;
								НовыйСправочник.Записать();
							КонецЕсли;
						КонецЦикла;

					КонецЕсли;
					
				КонецЕсли;
			КонецЦикла;
			Возврат;
		КонецЕсли;
			
		Если ЭлДок.ЕстьДочерниеУзлы() Тогда
			
			РекурсивныйПарсингСпискаКонфигураций(ЭлДок);
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры
...Показать Скрыть


3. В самой форме перенастроить список - режим вывода: дерево, разворачивать все уровни.
Прикрепленные файлы:
28. Андрей Акулов (DrAku1a) 13.02.14 18:58
(0) Да, и ещё вопрос автору: Чем пользовались для составления процедур парсинга?
Т.е. вижу по коду, что с помощью ЧтениеHTML и ПостроительDOM создавали объектную модель HTML-документа и дальше с ней работали...
Вопрос в том - с помощью какого вьювера просматривали DOM?
29. Валерий Федоров (barelpro) 13.02.14 22:34
(28) DrAku1a, хороший вопрос!

был бы вьюер, сэкономил бы 15 минут жизни :)
А так все по наитию
30. Сергей (seermak) 05.03.14 08:22
31. Alexandr Bogush (x_under) 26.03.14 17:04
Супер! Встраиваем в свою конфигурацию для ИТСников.
32. Евгений L (laeg) 18.04.14 20:53
Огромное спасибо за вашу работу. Взял за основу вашу разработку, переделал конечно структуру, версии перенес в РС, переделал справочник Программ, сделал функцию обновления, подцепил к регламенту - в итоге свои идеи воплотил в вашу разработку :)

Прикрепленные файлы:
33. Leon (lnnd) 08.05.14 13:50
Можно еще больше оптимизировать, в место рекурсии обработать ДокументHTML одним циклом c получением всех данных
В цикле заполняется: Название, гиперссылка, номер версии, дата выхода, планируемый номер версии, планируемая дата выхода, планируемая дата обновления данных, ознакомительный номер версии, дата выхода ознакомительной версии

В место процедуры РекурсивныйПарсингСпискаКонфигураций(ДокументHTML)

Процедура ЗаполнитьДанные(ДокументHTML, ТаблицаДанных)
	
	ТекГруппа = "";
	
	ЭлементыDOM = ДокументHTML.ПолучитьЭлементыПоИмени("td");
		
	Для Каждого Элемент Из ЭлементыDOM Цикл
				
		Если Элемент.ИмяКласса = "groupColumn" Тогда
						
			ИндексКолонки = 1;
			ТекГруппа = СокрЛП(Элемент.ТекстовоеСодержимое);
			
			Продолжить;
			
		КонецЕсли;
		
		Если Элемент.ИмяКласса = "nameColumn" Тогда
			
			НоваяСтрока = ТаблицаДанных.Добавить();
			
			НоваяСтрока.Группа = ТекГруппа;
			НоваяСтрока.Название = СокрЛП(Элемент.ТекстовоеСодержимое);
			
			Если ТипЗнч(Элемент.ДочерниеУзлы[0]) = Тип("ЭлементЯкорьHTML") Тогда
			    НоваяСтрока.Гиперcсылка = СокрЛП(Элемент.ДочерниеУзлы[0].Гиперссылка);
			КонецЕсли;	
										
			ИндексКолонки = 3;
			
			Продолжить;
			
		КонецЕсли;	
		
		ИндексКолонки = ИндексКолонки + 1;
		НоваяСтрока[ТаблицаДанных.Колонки[ИндексКолонки].Имя] = СокрЛП(Элемент.ТекстовоеСодержимое);
		
	КонецЦикла;	
		
КонецПроцедуры
...Показать Скрыть
34. Alexandr Bogush (x_under) 19.05.14 09:27
Добрый день.
Внедрили вашу систему в рабочую базу, все отлично. Потом решили перевести в регламентное задание и тут начались сложности: база в клиент серверном варианте. Регламентное задание запускается. Система получает JSESSIONID, но при получении страницы со списком конфигурации система ничего уже не возвращает. Подскажите куда смотреть
35. Александр Буганов (buganov) 29.05.14 19:56
(19) slavik27, за две тысячи? Есть бесплатные аналоги не хуже )
36. Сергей Соколов (ssokolov1) 10.06.14 13:13
Не работает.
Не грузит список программ.
До какого то момента работало, потом перестало. Выдавало ошибку, после скачал исправленную.
Ошибка исчезла, но программы не грузит
37. Валерий Федоров (barelpro) 01.09.14 18:08
(36) Спасибо за замечание!
Выпущена версия 2. 1С слегка изменила алгоритм авторизации, пришлось слегка переписать код, попутно удалось уменьшить количество запросов с 8 до 4.
maXon777; laeg; +2 Ответить
38. Александр Полтава (Патриот) 05.09.14 21:42
(0) +
Статья супер, хороший толчок для новичка, чтобы освоить новую для себя технологию 1С. Вы когда писали конфу, то пользовались только платформой 1С и инструментами разработчика браузера, чтобы распутать эту хитрую регистрацию на сайте 1С?
39. Александр Полтава (Патриот) 05.09.14 21:44
(0), Сам вашу конфу не использовал, т.к. не зареган на сайте 1С, но использовал её, как пример
40. Валерий Федоров (barelpro) 05.09.14 23:27
(38) Спасибо за оценку! Я пользовался советами своего брата, работающего в Яндексе, поэтому использовал инструменты Яндекс-браузера. А вообще, как мне подсказали здесь, есть инструменты не хуже, например, Firebug для Firefox.
41. deevil deevil (deevil) 06.09.14 03:46
Статья зачетная для изучения механизмов 1с для веб
42. Рустам Джалилов (RustamTurn) 09.09.14 23:54
Спасибо за статью. У меня возник вопрос, а как выполнить метод PATCH в объекте Httpсоединение, есть методы PUT,POST,DELETE,GET, а метод PATCH я не обнаружил и не смог воспроизвести его, хоть 1с пишет что к REST можно обращаться с помощью метода PATCH.
43. Валерий Федоров (barelpro) 11.09.14 16:27
(42) Да, так и есть, метод PATCH не наблюдается. А зачем он вам?
44. Рустам Джалилов (RustamTurn) 11.09.14 22:18
(43) barelpro, ОН используется для замены только указанных свойств, при этом остальные свойства остаются не тронутыми, его можно заменить методом PUT , но он очищает все незаполненные поля.
Плюс еще в объекте HTTPсервисы, появилась куча методов,которыми из 1с никак не обратиться.

● GET;

● POST;

● PUT;

● DELETE;

● PATCH;

● MERGE;

● CONNECT;

● OPTIONS;

● TRACE;

● PROPFIND;

● PROPPATCH;

● MKCOL;

● COPY;

● MOVE;

● LOCK;

● UNLOCK.
45. Илья (husky) 23.10.14 23:12
А как для обычных форм переделать пожалуйста, нужно под УПП 1.3. Заранее спасибо.
46. Илья (husky) 29.10.14 00:02
Как определить какие строки для запроса на сервер включать в заголовки, а какие нет, а также как определить возможно какие-то еще параметры нужно задать?
47. Денис Стеганцев (stegantsov) 07.11.14 10:27
(43) barelpro,
Расскажите поподробнее как изменился порядок авторизации в новых релизах
scandal2; +1 Ответить
48. Insanity Coming (Insanity) 26.01.15 11:32
Спасибо за статью. Обработка работает. Но не это главное, мне очень пригодился сам метод работы с сайтами, требующими аутентификации. Я оказывается всё делал не совсем правильно. Сэкономили мне массу времени. Ещё раз спасибо.
49. Кирилл Кремянский (xsazar) 08.08.15 18:55
Как теперь получить страницу, после обновления сайта???
50. Кирилл Кремянский (xsazar) 09.08.15 00:11
Разобрался! Теперь так!

&НаСервере
Функция НайтиJSESSIONID()

Попытка

//для GET-запросов
HTTPЗапрос1 = Новый HTTPЗапрос;
HTTPЗапрос1.Заголовки.Вставить("Connection", "keep-alive");

//для POST-запросов
HTTPЗапрос2 = Новый HTTPЗапрос;
HTTPЗапрос2.Заголовки.Вставить("Connection", "keep-alive");
HTTPЗапрос2.Заголовки.Вставить("Content-Type", "application/x-www-form-urlencoded");

Соединение1 = Новый HTTPСоединение("login.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
//Соединение2 = Новый HTTPСоединение("users.v8.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
//portal.1c.ru
Соединение2 = Новый HTTPСоединение("releases.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);

//Запрос 1
HTTPЗапрос1.АдресРесурса = "/releases.1c.ru/total";
ОтветHTTP1 = Соединение2.Получить(HTTPЗапрос1);
результат = ОтветHTTP1.КодСостояния;
JSESSIONID = ОтветHTTP1.Заголовки.Получить("Set-Cookie");
JSESSIONID = Лев(JSESSIONID, Найти(JSESSIONID, ";") - 1);
Объект.JSESSIONID = JSESSIONID;
LOCATION1 = СтрЗаменить(ОтветHTTP1.Заголовки.Получить("Location"), "https://login.1c.ru", "");

//Запрос 2
HTTPЗапрос1.АдресРесурса = LOCATION1;
ОтветHTTP2 = Соединение1.Получить(HTTPЗапрос1);
JSESSIONID1 = ОтветHTTP2.Заголовки.Получить("Set-Cookie");
JSESSIONID1 = Лев(JSESSIONID1, Найти(JSESSIONID1, ";") - 1);
inviteCode = РаспарситьinviteCode(ОтветHTTP2.ПолучитьТелоКакСтроку());

//Запрос 3
HTTPЗапрос2.АдресРесурса = "/login;"
+ СтрЗаменить(JSESSIONID1, "JSESSIONID=", "jsessionid=")
+ "?service=https%3A%2F%2Fusers.v8.1c.ru%2Fdistribution%2Fpublic%2Fsecurity_check%3Bjsessionid%3D"­
+ СтрЗаменить(JSESSIONID, "JSESSIONID=", "");
HTTPЗапрос2.Заголовки.Вставить("Cookie", JSESSIONID1);
HTTPЗапрос2.УстановитьТелоИзСтроки(inviteCode);
ОтветHTTP3 = Соединение1.ОтправитьДляОбработки(HTTPЗапрос2);
LOCATION3 = СтрЗаменить(ОтветHTTP3.Заголовки.Получить("Location"), "https://releases.1c.ru", "");

//Запрос 4
HTTPЗапрос1.АдресРесурса = LOCATION3;
HTTPЗапрос1.Заголовки.Вставить("Cookie", JSESSIONID);
ОтветHTTP4 = Соединение2.Получить(HTTPЗапрос1);


Исключение
Возврат Ложь;
КонецПопытки;

Возврат Истина;

КонецФункции

&НаСервере
Функция ЗагрузитьПрограммыНаСервере()

Попытка

Загружено = 0;
Запрос = Новый HTTPЗапрос;
Запрос.Заголовки.Вставить("Connection", "keep-alive");
Запрос.Заголовки.Вставить("Cookie", JSESSIONID);
Запрос.АдресРесурса = "/total";
Соединение2 = Новый HTTPСоединение("releases.1c.ru",,,,Новый ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL);
ОтветHTTP = Соединение2.Получить(Запрос);

ЧтениеHTML = Новый ЧтениеHTML;
ЧтениеHTML.УстановитьСтроку(ОтветHTTP.ПолучитьТелоКакСтроку());

Построитель = Новый ПостроительDOM;
ДокументHTML = Построитель.Прочитать(ЧтениеHTML);

РекурсивныйПарсингСпискаКонфигураций(ДокументHTML);

Исключение

Возврат Ложь;

КонецПопытки;

Возврат Истина;

КонецФункции

51. Константин Марков (markovki) 17.08.15 16:02
(50) xsazar, объясните чайнику пожалуйста, как подобным методом программно авторизоваться на login.1c.ru, затем с той же авторизацией попасть на страницу https://releases.1c.ru/total
Далее таким же методом хочу добраться до страницы (там 4 перехода):
https://releases.1c.ru/version_file?nick=Accounting30&ver=3.0.34.10&path=Accounting\3_0_34_10\updsetup.exe
К сожалению, не могу понять, тема для меня новая, а ваш пример не работает, возможно, что-то не так сделал, после нажатия немного думает и ничего не происходит.
52. Кирилл Кремянский (xsazar) 19.08.15 00:05
(51) markovki, по вашим словам, можно понять, что вы ни чего не меняли в процедуре, где идет парсинг страницы релиза, а она обновилась, там то же нужно менять, поэтому и ни чего не происходит, у меня пока только есть регламентное задание, могу показать как идет парсинг страницы, но он для обработки не подойдет.
53. Константин Марков (markovki) 21.08.15 08:21
(52) xsazar, вы правы, не менял.
Просто пытаюсь более детально разобраться как происходит переход на releases.1c.ru после авторизации.
Мне казалось, что для этого необходимы только логин/пароль и кукисы c login.1c.ru.
Зачем например, парсить страницу и собственно сама переменная inviteCode...
54. Александр (NcSteel) 21.08.15 13:55
1С изменила сайт и естественно данная конфигурация перестала работать. Будет ли доработана ?
55. Валерий Федоров (barelpro) 27.08.15 22:04
Внимание! Выпущена версия 3. Учтен новый дизайн сайта 1С.
56. Alexandr Kuritsyn (hibico) 01.09.15 11:17
Здорово!
Прошу разрешение на использование Вашего кода для авторизации в моей разработке для скачивания файлов обновлений "updsetup.exe". Ссылки в коде и публикации гарантирую.
57. Денис Сорокин (Avrobus) 02.09.15 14:34
На 1С слегка изменилась авторизация. Помогли такие костыли:
В функции НайтиJSESSIONID()
1. Запрос 2
Перед JSESSIONID1 = Лев(JSESSIONID1, Найти(JSESSIONID1, ";") - 1); вставить
JSESSIONID1 = Прав(JSESSIONID1, СтрДлина(JSESSIONID1) - Найти(JSESSIONID1, "SESSION") + 1);

2. Запрос 3
HTTPЗапрос2.АдресРесурса заменить на
HTTPЗапрос2.АдресРесурса = "/login?service=https%3A%2F%2Freleases.1c.ru";
barelpro; hibico; +2 Ответить 2
58. Валерий Федоров (barelpro) 02.09.15 22:40
(57) Да, что-то они зачастили... Сейчас поправлю и выложу v4
59. Валерий Федоров (barelpro) 02.09.15 22:43
(56) Не возражаю. Но если 1С так часто будет менять сайт и авторизацию, то это нифига не enterprise solution! Замучаетесь выпускать заплатки... Я уже замучался...
60. Сергей McAlister (mcfearson) 07.09.15 23:57
Подскажите, пожалуйста. У нас здесь есть домены releases.1c.ru и login.1c.ru. Мы авторизуемся на login.1c.ru, шлем туда имя пользователя и пароль, а затем получаем страницу с releases.1c.ru. Куки разные. Как нас идентифицируют как одного и того же пользователя и дают доступ к releases.1c.ru?
61. Валерий Федоров (barelpro) 08.09.15 18:17
(60)
Смотрим функцию НайтиJSESSIONID()
В первом запросе к releases.1c.ru нам присваивается JSESSIONID
Во втором запросе к login.1c.ru нам присваиваются параметры inviteCode
В третьем запросе мы отправляем inviteCode с логином-паролем и получаем ticket
В четвертом запросе мы связываем JSESSIONID и ticket
62. Валерий Федоров (barelpro) 08.09.15 18:38
Внимание! Выпущена версия 5. Оптимизирован код. Заменены методы рекурсивных парсингов на конструкции ПолучитьЭлементПоИдентификатору и ПолучитьЭлементыПоИмени. Старые функции остались закоментированными.
Спасибо коллеге Avrobus за идею! :)
63. Сергей McAlister (mcfearson) 09.09.15 15:55
64. Анна Борзенкова (azazana) 21.09.15 18:30
А подскажите, каким образом можно посмотреть какой именно post запрос формируется при когда на сайте вводишь логин и пароль?
65. Анна Борзенкова (azazana) 22.09.15 10:31
Если смотреть в Хроме, то там формируется куча различных запросов. Как отобрать нужный?
66. Юрий Пихоцкий (pihy) 03.10.15 13:06
Знающие люди, подскажите, пожалуйста.

Пытаюсь авторизироваться на сайте средствами 1с:

Соединение = Новый HTTPСоединение("toysland.crimea.ua");			
Заголовки = Новый Соответствие;
Заголовки.Вставить("host", "toysland.crimea.ua");
Заголовки.Вставить("Connection", "keep-alive");
Заголовки.Вставить("Accept","text/html");
Заголовки.Вставить("Accept-Language", "ru");
	
Заголовки.Вставить("Content-Length",СтрДлина(СтрЗаменить(СтрЗаменить(action=secure-login&login="$ЛОГИН$"&passwd="$ПАРОЛЬ$","$ЛОГИН$",Объект.Пользователь),"$ПАРОЛЬ$",Объект.Пароль)));
Запрос = Новый HTTPЗапрос(ТекАдрес, Заголовки);
Запрос.УстановитьТелоИзСтроки(СтрЗаменить(СтрЗаменить(Объект.ШаблонПОСТ,"$ЛОГИН$",Объект.Пользователь),"$ПАРОЛЬ$",Объект.Пароль));
Ответ = Соединение.ОтправитьДляОбработки(Запрос);
...Показать Скрыть


Строку action=secure-login&login="$ЛОГИН$"&passwd="$ПАРОЛЬ$" подсмотрел снифером во время отправки данных на сервер браузером.
В
Ответ.ПолучитьТелоКакСтроку();

попадает заблокированная страница. Т.е. авторизацию не проходит...
67. Юрий Пихоцкий (pihy) 03.10.15 13:32
(65) azazana, я искал по статусу "302". POST запрос. Внизу раздел "Form data" переключить на "View source". Эту строку и добавляю в тело запроса.
68. Алекс zhu4 (Arxxximed) 30.10.15 14:43
Подскажите, пожалуйста , как все таки получать текст страницы полученной в сжатом виде gzip. Устанавливаю Заголовок "Accept-Encoding : gzip"
По итогу HTTPОтвет.ПолучитьТелоКакСтроку() Возвращает сжатые данные

Поднял вопрос в теме http://forum.infostart.ru/forum26/topic140086/
69. Сергей Старых (tormozit) 23.01.16 21:20
У меня ОтветHTTP3.КодСостояния = 200, а нужен 302. Почему такое может быть?
Ответ: в моем случае был неверный логин или пароль
70. Денис Денис (Denois1333) 17.02.16 08:11
Здравствуйте, подскажите пожалуйста, не получается авторизоваться на сайте интернет банка. Там то тоже используется HTTPS, но если при авторизации на users.v8.1c.ru в теле POST запроса отправляются незашифрованные логин/пароль, то в интернет банк отправляется шифрованный пароль, причем всегда разный. Как сформировать POST запрос на авторизацию?
71. Денис Денис (Denois1333) 19.02.16 11:15
Разобрался со своей проблемой, там действительно при каждой авторизации происходит шифрование пароля. Я разобрал алгоритм шифрования и на авторизацию отправляю шифрованный пароль. HTTPS соединение и сертификаты здесь не причем. Кодирование идет встроенными процедурами сайта.
72. biformatus (biformatus) 20.02.16 21:50
(14) barelpro, Чтобы качнуть этот файл нужна в качестве UserAgent указать 1с:Предприятие.
73. Юра Кавун (info@itshkola.com) 21.03.16 21:37
74. Юра Кавун (info@itshkola.com) 21.03.16 21:39
Валерий, здравствуйте!
Можно Вас попросить эту обработку скинуть на business.kavun@gmail.com
Уж очень нужна, а нет возможности скачать.
Спасибо большое за статью - очень грамотно написана
75. biformatus (biformatus) 25.10.16 18:45
Сломалось что-то.
Функция РаспарситьinviteCode(Текст)
	
	ЧтениеHTML = Новый ЧтениеHTML;
	ЧтениеHTML.УстановитьСтроку(Текст);
	
	Построитель = Новый ПостроительDOM;
	ДокументHTML = Построитель.Прочитать(ЧтениеHTML);
	
	loginForm = ДокументHTML.ПолучитьЭлементПоИдентификатору("loginForm");
	
	inviteCode = "inviteCode=<=" + loginForm.Элементы[1].Значение 
				+ "&execution=" + loginForm.Элементы[2].Значение 
				+ "&_eventId=" + loginForm.Элементы[3].Значение
	 			+ "&username=" + КонстантыНабор.username 
				+ "&password=" + КонстантыНабор.password;
				
	//РекурсивныйПарсингСтраницыЛогина(ДокументHTML, inviteCode);
	//inviteCode = inviteCode + "&username=" + КонстантыНабор.username + "&password=" + КонстантыНабор.password;
	
	Возврат inviteCode;
	
КонецФункции
...Показать Скрыть


Здесь ошибка - не получает элемент по идентификатору loginForm. Логин и пароль рабочие.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа