gifts2017

Загрузка Индексов инфляции. Dom-модель Html

Опубликовал Ярослав Хаустович (z86) в раздел Обмен - Интеграция с WEB

Загрузка Индексов инфляции с сайта.

В обработке используется анализ сайта и его чтение с помощью Dom-модели Html

Скачать файлы

Наименование Файл Версия Размер
Загрузка индекса инфдяции с сайта 106
.epf 8,44Kb
27.10.09
106
.epf 8,44Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Светлана (sveta333) 28.10.09 12:49
2. Юрий (putilin) 28.10.09 17:10
Ну попробовал. Мне очень понравилось.
Вопрос. Этот сайт готов все время давать данные по индексу или так проба.
Очень хорошо.!!!
3. Юрий (putilin) 28.10.09 17:16
Да, кстати, особенно понравилась операция "ы", чтобы некто не догадался.
Ну это шутка, а так все хорошо!!!
4. Ярослав Хаустович (z86) 28.10.09 17:51
(2) На сайте даже не знают что мы уних сливаем индекс инфляции.
Все равно сольйом
5. Ярослав Хаустович (z86) 28.10.09 17:52
(3) хорошо так хорошо а плюсики не ставлят :cry:
6. Вячеслав Кадацкий (marsohod) 29.10.09 16:03
"ИндексИнфлиции.epf"
"Загрузка индекса инфдяции с сайта"
Руки чтоль замерзли? :)
Плюсик ставлю, не переживай 8)
7. Ярослав Хаустович (z86) 29.10.09 18:55
8. Ярослав Хаустович (z86) 29.10.09 18:56
хочу ище сделать загрузку валют
9. aga_aga (Збянтэжаны Саўка) 26.05.10 17:44
Посмотрел код и увы - он совершенно не соответствует громкому заголовку "Dom-модель Html", т.к. там из DOM используется только одна строка обращения к HTML-документу: getElementsByTagName("*").
А такие свойства документа как table и ему подчиненные rows и cells вообще не используются :(

Можно было бы улучшить код ну хотя бы примерно так:

Для каждого Элемент из ТелоДокумента.getElementsByTagName("*") Цикл
ИмяТега = Элемент.tagName;
ТекстТега = СокрЛП(Элемент.outerText);

Если ИмяТега = "TABLE" Тогда
Rows = Элемент.Rows();
ВсегоСтрок = Элемент.Rows().length();

// Цикл по строкам таблицы
Для каждого стр из Rows Цикл

Текст = СокрЛП(стр.outerText);
Cells = стр.Cells();
ВсегоКол = стр.Cells().length();

// Цикл по столбцам таблицы
Для каждого эл Из Cells Цикл
ИмяТегаКол = Эл.tagName;
Текст = СокрЛП(эл.outerText);

// работа с ячейкой таблицы...

КонецЦикла; // каждого эл Из Cells

КонецЦикла; // каждого стр из Rows

КонецЕсли; // ИмяТега = "TABLE"

КонецЦикла;

ну конечно же здесь путей для оптимизации море ... лень все описывать, сорри

но плюс я все же поставлю за ... идею

У меня есть рабочая обработка сходной направленности на выдирание данных по тел. разговорам из отчета HTML в ТЗ, но направление ее слишком узкое, так что выкладывать ее нет смысла имхо.
Да, честно говоря и некогда да и лень заморачиваться с выкладкой, т.к. гораздо легче написать код, чем описание к нему: "чукча не писатель, чукча читатель" :)
Прикрепленные файлы:
10. Мухтар (makfromkz) 15.08.11 05:56
Спасибо , мне пригодилась идея :D
11. Lubov Ya (Mbisha) 22.05.14 10:28
Спасибо! Взяла обработку за основу. Пришлось немного допилить: 1)Исправила возникающую ошибку - до тэга "table" попадается тэг параграфа "p", поэтому ругается на запись массива. 2) Добавила выбор периода, за который необходимо загрузить индексы.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа